Vous êtes sur la page 1sur 16

ROYAUME DU MAROC ********

OFFICE DE LA FORMATION PROFESSIONNELLE ET DE LA PROMOTION DU TRAVAIL I.S.T.A BENI MELLAL

********

Ralis par: Khadija ATTAK. Hayate HRAITA. Encadres par : Mr. Khalil RHATAY. Mr. Mohamed BENTALEB Anne de formation : 2001/2002

Gestion des feuilles de calcul

Section : TIB1

Sommaire
INTRODUCTION.........................................................................................................................................................2 CHANGER LA COULEUR DU QUADRILLAGE...................................................................................................3 SUPPRIMER DES FEUILLES...................................................................................................................................4 AFFICHER OU MASQUER UN CLASSEUR OU UNE FEUILLE.......................................................................5 AFFICHER OU MASQUER DES LIGNES OU DES COLONNES.......................................................................7 AFFICHER OU MASQUER UNE LIGNE OU UNE COLONNE MASQUE .............................................................................................7 MASQUER UNE LIGNE OU UNE COLONNE.............................................................................................................................8 AFFICHER OU MASQUER LES BARRES DE DFILEMENT...........................................................................8 AFFICHER OU MASQUER LES ONGLETS DE CLASSEUR.............................................................................8 AFFICHER OU MASQUER TOUS LES ONGLETS DE CLASSEUR......................................................................................................8 AFFICHER UN NOMBRE PLUS OU MOINS GRAND D'ONGLETS DE CLASSEUR..................................................................................8 AJOUTER DES COULEURS AUX ONGLETS D'UNE FEUILLE.......................................................................9 AFFICHER OU MASQUER LA BARRE D'TAT..................................................................................................9 MASQUER LE QUADRILLAGE DES CELLULES...............................................................................................9 INSRER UNE NOUVELLE FEUILLE DE CALCUL...........................................................................................9 AJOUTER UNE SEULE FEUILLE DE CALCUL..........................................................................................................................10 AJOUTER PLUSIEURS FEUILLES DE CALCUL.........................................................................................................................10 INSRER UNE NOUVELLE FEUILLE BASE SUR UN MODLE PERSONNALIS................................................................................10 ATTRIBUER UN NOM AUX CELLULES D'UN CLASSEUR............................................................................11 DPLACER OU COPIER DES FEUILLES...........................................................................................................15 RENOMMER UNE FEUILLE..................................................................................................................................16

INTROD UCTION
ATTAK&HRAITA -2TIB1

Gestion des feuilles de calcul


Excel est un logiciel tableur du bureautique grce auquel un utilisateur peut avoir plusieurs outils en sa disposition, permis les plus importants la gestion des feuilles de calcul . Cest loutil quon va prendre comme sujet dans cette action de formation.

Changer la couleur du quadr i l lage


1. Slectionnez les feuilles dont vous souhaitez changer la couleur du quadrillage. Lorsque vous entrez ou modifiez des donnes, les modifications affectent l'ensemble des feuilles slectionnes. Il se peut que ces modifications remplacent des donnes sur la feuille active et sur les autres feuilles slectionnes. Pour slectionner Une seule feuille Procdez comme suit Cliquez sur l'onglet de la feuille. Si vous ne voyez pas l'onglet voulu, cliquez sur les boutons de dfilement d'onglets pour afficher l'onglet souhait, puis cliquez dessus.

Deux feuilles adjacentes ou plus

Cliquez sur l'onglet correspondant la premire feuille, puis maintenez la touche MAJ enfonce et cliquez sur l'onglet correspondant la dernire feuille.

Deux feuilles non Cliquez sur l'onglet correspondant la premire adjacentes ou plus feuille, puis maintenez la touche CTRL enfonce et cliquez sur les onglets correspondant aux autres feuilles. Toutes les feuilles d'un classeur Cliquez avec le bouton droit sur un onglet de la feuille, puis cliquez sur Slectionner toutes les feuilles dans le menu contextuel.

Remarque Si des onglets de la feuille ont t cods l'aide de couleurs, les noms des onglets de la feuille seront souligns l'aide d'une couleur spcifie par l'utilisateur lorsqu'ils seront slectionns. Si l'onglet de la feuille s'affiche avec une couleur d'arrire-plan, cela signifie que la feuille n'a pas t slectionne.

Pour annuler une slection de plusieurs feuilles


Pour annuler une slection de plusieurs feuilles dans un classeur, cliquez sur une feuille quelconque non slectionne.

ATTAK&HRAITA

-3-

TIB1

Gestion des feuilles de calcul


Si aucune feuille non slectionne n'est visible, cliquez avec le bouton droit sur l'onglet d'une feuille slectionne, puis cliquez sur Dissocier les feuilles dans le menu contextuel.

2. Dans le menu Outils, cliquez sur Options, puis sur l'onglet


Affichage.

3 4 1 Form1 3. Sous Fentres, cliquez dans la zone Couleur sur la


couleur souhaite. Pour utiliser la couleur de quadrillage par dfaut, cliquez sur Automatique.

Suppr imer des feu i l les


1. Slectionnez les feuilles que vous souhaitez supprimer. 2. Dans le menu Edition, cliquez sur Supprimer une feuille.

ATTAK&HRAITA

-4-

TIB1

Gestion des feuilles de calcul

Aff icher ou m asquer un c lasseur ou une feu i l le


Effectuez au moins l'une des actions suivantes :

Pour afficher ou masquer un classeur 1. Dans le menu Fentre, cliquez sur Afficher.

Si la commande Afficher est indisponible, cela signifie que le classeur ne contient pas de feuilles masques. Si les commandes Renommer et Masquer sont toutes les deux indisponibles, cela signifie que le classeur est protg contre les modifications structurelles. Vous devez supprimer la protection du classeur pour dterminer si des feuilles sont masques ; il est possible que la suppression de la protection require un mot de passe. Dans le menu Outils, pointez sur Protection, puis cliquez sur ter la protection du classeur.

ATTAK&HRAITA

-5-

TIB1

Gestion des feuilles de calcul


Si vous y tes invit, entrez le mot de passe de protection du classeur. Les mots de passe respectent la casse. Vous devez donc taper le mot de passe exactement tel qu'il a t saisi lors de sa cration, en respectant une ventuelle distinction entre les majuscules et les minuscules.

2. Dans la zone Afficher le classeur, double-cliquez


sur le nom du classeur masqu.

Pour afficher une feuille masque 1. Dans le menu Format, pointez sur Feuille, puis
cliquez sur Afficher.

Si des feuilles sont masques par un programme Visual Basic pour Applications qui affecte la proprit xlSheetVeryHidden, vous ne pouvez pas utiliser la commande Afficher pour afficher les feuilles. Si vous utilisez un classeur avec des macros Visual Basic et si le masquage des feuilles pose problme, contactez le propritaire du classeur afin d'obtenir des informations supplmentaires.

2. Dans la zone Afficher la feuille, double-cliquez


sur le nom afficher. de la feuille que vous souhaitez

Pour masquer une fentre de classeur


1. Ouvrez le classeur. 2. Dans le menu Fentre, cliquez sur Masquer. 3. Lorsque vous quittez Microsoft Excel, un message vous demande si vous souhaitez enregistrer les modifications apportes au classeur masqu. Cliquez sur Oui si vous voulez que la fentre de classeur soit masque lors de la prochaine ouverture du classeur.

Pour masquer une feuille

ATTAK&HRAITA

-6-

TIB1

Gestion des feuilles de calcul


1. Slectionnez les feuilles que vous souhaitez masquer. 2. Dans le menu Format, pointez sur Feuille, puis cliquez sur Masquer.

Pour afficher ou masquer plusieurs classeurs dans la barre des tches de Microsoft Windows 1. Dans le menu Outils, cliquez sur Options, puis sur
l'onglet Affichage. 2. Activez ou dsactivez la case cocher Fentres dans la barre des tches. (Voir N 2 au form1)

Aff icher ou m asquer des l ignes ou des co lonnes


Afficher ou masquer une ligne ou une colonne masque
1. Slectionnez une ligne ou une colonne de chaque ct des lignes ou des colonnes que vous voulez afficher. 2. Dans le menu Format, pointez sur Ligne ou Colonne, puis cliquez sur Afficher.

Conseil
Si la premire ligne ou colonne d'une feuille de calcul est masque, cliquez dans le menu Edition sur Atteindre. Tapez A1 dans la zone Rfrence, puis cliquez sur OK. Pointez dans le menu Format sur Ligne ou Colonne, puis cliquez sur Afficher.

Il est galement possible que la hauteur de la ligne ou la largeur de la colonne ait t dfinie zro. Pointez

ATTAK&HRAITA

-7-

TIB1

Gestion des feuilles de calcul


sur la bordure du bouton Slectionner tout

jusqu' ce que le curseur se transforme en ou en , puis faites glisser largir la ligne ou la colonne. la souris pour

Masquer une ligne ou une colonne


1. Slectionnez les lignes ou colonnes que vous souhaitez masquer. 2. Dans le menu Format, pointez sur Ligne ou Colonne, puis cliquez sur Masquer.

Aff icher ou m asquer les barres de df i lement


1. Dans le menu Outils, cliquez sur Options, puis sur
l'onglet Affichage. dfilement verticale.

2. Activez ou dsactivez les cases cocher Barre de


horizontale et Barre de dfilement

(Voir N3 au form1)

Aff icher ou m asquer les onglets de c lasseur


Afficher ou masquer tous les onglets de classeur 1. Dans le menu Outils, cliquez sur Options, puis sur
l'onglet Affichage.

2. Activez ou dsactivez la case cocher Onglets de


classeur. Lors de l'affichage des onglets de classeur, vous devrez peut-tre galement dvelopper la zone de dfilement d'onglets.

Afficher un nombre plus ou moins grand d'onglets de classeur


1. Pointez sur la barre de fractionnement d'onglet.

2. Lorsque le pointeur se transforme en curseur de


fractionnement fractionnement gauche. , faites glisser d'onglet vers la la barre droite ou de la

Double-cliquez sur la barre de fractionnement d'onglet pour la ramener sa position d'origine.

ATTAK&HRAITA

-8-

TIB1

Gestion des feuilles de calcul Conseil


Vous pouvez activer une feuille en double-cliquant sur n'importe quel bouton de dfilement d'onglet, puis en slectionnant la feuille voulue partir du menu contextuel.

Si les noms de feuille sont coups ou difficiles lire


Augmentez la hauteur de la barre de dfilement. Dans le Panneau de configuration Microsoft Windows, doublecliquez sur l'icne Affichage, cliquez sur l'onglet Apparence, sur Barre de dfilement dans la liste lment, puis augmentez le nombre dans la zone Taille.

Ajouter des couleurs aux onglets d'une feu i l le

1. Slectionnez les feuilles que vous souhaitez colorier. 2. Dans le menu Format, pointez sur Feuille, puis cliquez sur Couleur d'onglet. Vous pouvez galement cliquer avec le bouton droit sur l'onglet de la feuille, puis cliquez sur Couleur d'onglet. 3. Cliquez sur la couleur souhaite, puis sur OK.

Aff icher ou m asquer la barre d'tat


1. Dans le menu Outils, cliquez sur Options, puis sur
l'onglet Affichage. 2. Activez ou dsactivez d'tat. la case cocher Barre

Masquer le quadr i l lage des ce l lu les


1. Slectionnez
les feuilles pour lesquelles vous voulez masquer le quadrillage. 2. Dans le menu Outils, cliquez sur Options, puis sur l'onglet Affichage. 3. Sous Fentres, dsactivez la case cocher Quadrillage. (Voir N 4 au form2)

Insrer une nouvelle feuille de calcul

ATTAK&HRAITA

-9-

TIB1

Gestion des feuilles de calcul Ajouter une seule feuille de calcul

Cliquez sur Insertion.

Feuille

de

calcul

dans

le

menu

Ajouter plusieurs feuilles de calcul


Dterminez le nombre voulez ajouter. de feuilles de calcul que vous

1. Maintenez la touche MAJ enfonce, puis slectionnez un nombre d'onglets de feuille de calcul existants correspondant celui que vous voulez ajouter dans le classeur ouvert. Par exemple, si vous voulez ajouter trois nouvelles feuilles de calcul, slectionnez trois onglets de feuille de calcul existants.

2. Cliquez

sur Insertion.

Feuille

de

calcul

dans

le

menu

Insrer une nouvelle feuille base sur un modle personnalis


Vous devez avoir pralablement cr un modle de feuille personnalis. 1. Choisissez le type de modle souhait :

Modle de classeur
Crez un dossier contenant des feuilles, du texte par dfaut (par exemple des en-ttes de page et des tiquettes de lignes et de colonnes), des formules et d'autres mises en forme que vous souhaitez faire apparatre dans tous les nouveaux classeurs bass sur ce modle.

Modle de feuille de calcul


Crez un classeur contenant une feuille de calcul. Dans la feuille de calcul, insrez les mises en forme,le texte et les autres informations que vous souhaitez faire apparatre dans toutes les nouvelles feuilles de calcul du mme type.

2. Pour afficher une image de la premire page du


modle dans la zone Aperu de la bote de dialogue Modles (Modles gnraux..., dans le volet Office Nouveau classeur), cliquez sur Proprits dans le menu Fichier, slectionnez l'onglet Rsum, puis activez la case cocher Enregistrer l'image de l'aperu. 3. Dans le menu Fichier, cliquez sur Enregistrer sous. 4. Dans la zone Type de fichier, cliquez sur Modle.

ATTAK&HRAITA

- 10 -

TIB1

Gestion des feuilles de calcul 5. Dans


la zone Enregistrer dans, slectionnez le dossier dans lequel vous souhaitez stocker le modle. o Pour crer le modle de classeur par dfaut ou le modle de feuille de calcul par dfaut, slectionnez soit le dossier XLOuvrir, soit l'autre dossier de dmarrage . Pour crer un modle de classeur ou de feuille de calcul personnalis, slectionnez le dossier Modles.

6. Entrez

le nom du modle dans la zone Nom de fichier. Effectuez l'une des actions suivantes :

Modle de classeur
o

Tapez classeur pour classeur par dfaut.

crer

le

modle

de

Pour crer un modle de classeur personnalis, tapez un nom de fichier valide.

Modle de feuille de calcul


o

Tapez feuille pour crer un modle pour les feuilles de calcul par dfaut. Pour crer un modle de feuille personnalis, tapez un nom de fichier valide.

7. Cliquez sur Enregistrer, puis sur Fermer dans le


menu Fichier.

1. Cliquez avec le bouton droit sur l'onglet de la


feuille, puis cliquez sur Insrer. 2. Double-cliquez sur le modle correspondant au type de feuille souhait.

Attribuer un nom aux cellules d'un classeur


Vous pouvez utiliser les tiquettes de colonnes et de lignes dans une feuille de calcul pour faire rfrence aux cellules situes dans ces colonnes et lignes. Vous pouvez galement crer des noms. Descriptifs pour reprsenter les cellules, les plages de cellules, les formules ou les valeurs de constante. Les tiquettes peuvent tre utilises dans les formules qui font rfrence aux donnes dans la mme feuille de calcul ; si vous souhaitez reprsenter une plage sur une autre feuille de calcul, utilisez un nom. Vous pouvez galement crer des noms 3D qui reprsentent la mme cellule ou plage de cellules dans plusieurs feuilles de calcul.

ATTAK&HRAITA

- 11 -

TIB1

Gestion des feuilles de calcul Pour utiliser des tiquettes comme rfrences
Cette option doit tre dfinie lorsque vous crez un classeur, vous devrez sinon entrer de nouveau les formules qui utilisent ces tiquettes.

1. Cliquez

sur Options dans le cliquez sur l'onglet Calcul.

menu

Outils,

puis

(Voir N5 au form1)

2. Sous Options de classeur, activez la case cocher


Accepter les tiquettes dans les formules. 3. Pour entrer de nouveau une formule utilisant une tiquette avant de dfinir cette option, slectionnez la cellule qui contient la formule, appuyez sur F2, puis appuyez sur ENTRE. Remarque Pour que cette option soit reconnue par dfaut pour tous les nouveaux classeurs, crez un classeur, suivez la procdure ci-dessus et enregistrez le paramtre dans le modle de classeur.xlt. 1. Choisissez le type de modle souhait :

Modle de classeur
Crez un dossier contenant des feuilles, du texte par dfaut (par exemple des en-ttes de page et des tiquettes de lignes et de colonnes), des formules et d'autres mises en forme que vous souhaitez faire apparatre dans tous les nouveaux classeurs bass sur ce modle.

Modle de feuille de calcul


Crez un classeur contenant une feuille de calcul. Dans la feuille de calcul, insrez les mises en forme, le texte et les autres informations que vous souhaitez faire apparatre dans toutes les nouvelles feuilles de calcul du mme type.

2. Pour afficher une image de la premire page du

modle dans la zone Aperu de la bote de dialogue Modles (Modles gnraux..., dans le volet Office Nouveau classeur), cliquez sur Proprits dans le menu Fichier, slectionnez l'onglet Rsum, puis activez la case cocher Enregistrer l'image de l'aperu. 3. Dans le menu Fichier, cliquez sur Enregistrer sous. 4. Dans la zone Type de fichier, cliquez sur Modle. 5. Dans la zone Enregistrer dans, slectionnez le dossier dans lequel vous souhaitez stocker le modle.

ATTAK&HRAITA

- 12 -

TIB1

Gestion des feuilles de calcul


Pour crer le modle de classeur par dfaut, ou le modle de feuille de calcul par dfaut, slectionnez soit le dossier XLOuvrir, soit l'autre dossier de dmarrage. Pour crer un modle de classeur ou de feuille de calcul personnalis, slectionnez le dossier Modles.

6. Entrez

le nom du modle dans la zone Nom de fichier. Effectuez l'une des actions suivantes : Modle de classeur
o

Tapez classeur pour classeur par dfaut.

crer

le

modle

de

Pour crer un modle de classeur personnalis, tapez un nom de fichier valide.

Modle de feuille de calcul


o

Tapez feuille pour crer un modle pour les feuilles de calcul par dfaut. Pour crer un modle de feuille personnalis, tapez un nom de fichier valide.

7. Cliquez sur Enregistrer, puis sur Fermer dans le


menu Fichier.

Pour nommer une cellule ou une plage de cellules 1. Slectionnez la cellule, la plage de cellules ou
des slections non adjacentes que vous voulez nommer.

2. Cliquez sur la zone Nom l'extrmit gauche de la


barre de formule .

Tapez le nom des cellules. 3. Appuyez sur ENTRE. Remarque Vous ne pouvez pas nommer une cellule pendant que vous en modifiez le contenu.

Pour convertir les tiquettes de lignes ou de colonnes en noms

ATTAK&HRAITA

- 13 -

TIB1

Gestion des feuilles de calcul


1. Slectionnez la plage nommer, y compris les tiquettes de lignes ou de colonnes. 2. Dans le menu Insertion, pointez sur Nom puis cliquez sur Crer.

1 Forme 2 3. Dans la bote de dialogue Crer des noms, dsignez


l'emplacement contenant les tiquettes en activant la case cocher Ligne du haut, Colonne de gauche, Ligne du bas ou Colonne de droite.

Remarque Un nom cr l'aide de cette procdure ne fait rfrence qu'aux cellules contenant des valeurs et n'inclut pas les tiquettes de lignes et de colonnes existantes. Spcifier des tiquettes Lorsque vous slectionnez des cellules dans des plages tiquetes pour crer des formules, Microsoft Excel peut insrer les tiquettes la place des rfrences de cellule dans vos formules. L'utilisation d'tiquettes permet une meilleure comprhension de la construction de la formule. Vous pouvez utiliser la bote de dialogue Plages d'tiquettes (menu Insertion, sous-menu Nom, commande Intitul) pour indiquer les plages qui contiennent les tiquettes de lignes et de colonnes dans votre feuille de calcul.

Pour nommer des cellules dans plusieurs feuilles de calcul l'aide d'une rfrence 3D
Le rsultat rfrence 3D . de cette opration est galement appel

ATTAK&HRAITA

- 14 -

TIB1

Gestion des feuilles de calcul 1. Dans


le menu Insertion, cliquez sur Dfinir. pointez sur Nom, puis

(Voir N1 la forme 2)

2. Dans la zone Noms dans le classeur, tapez le nom. 3. Si la zone Fait rfrence contient une rfrence,
slectionnez le signe gal (=) et la rfrence, puis appuyez sur RET.ARR.

4. Dans

la zone Fait rfrence , tapez = (signe gal). 5. Cliquez sur l'onglet correspondant la premire feuille de calcul rfrencer. 6. Maintenez la touche MAJ enfonce et cliquez sur l'onglet correspondant la dernire feuille de calcul rfrencer. 7. Slectionnez la cellule ou la plage de cellules rfrencer.

Dplacer ou copier des feuilles


Attention Soyez prudent lors du dplacement ou de la copie de feuilles. Les calculs ou les graphiques bass sur des donnes de feuille de calcul risquent d'tre faux si vous dplacez la feuille de calcul. De mme, si vous insrez une feuille de calcul entre des feuilles qui sont rfrences par une rfrence de formule 3D, les donnes de cette feuille de calcul risquent d'tre prises en compte dans le calcul. 1. Pour dplacer ou copier des feuilles dans un autre classeur, ouvrez ce dernier. 2. Passez dans le classeur qui contient les feuilles dplacer ou copier, puis slectionnez-les. 3. Dans le menu Edition, cliquez sur Dplacer ou copier une feuille. 4. Dans la zone Dans le classeur, cliquez sur le classeur de destination. Pour dplacer ou copier les feuilles slectionnes dans un nouveau classeur, cliquez sur (nouveau classeur).

ATTAK&HRAITA

- 15 -

TIB1

Gestion des feuilles de calcul 5. Dans la zone Avant la feuille, cliquez sur la
feuille avant laquelle vous souhaitez insrer les feuilles dplaces ou copies. 6. Pour copier les feuilles au lieu de les dplacer, activez la case cocher Crer une copie.

Conseil
Pour dplacer des feuilles l'intrieur du classeur en cours, vous pouvez faire glisser les feuilles slectionnes sur la range des onglets de feuille. Pour copier des feuilles, maintenez la touche CTRL enfonce et faites-les glisser ; relchez le bouton de la souris avant de relcher la touche CTRL.

Renommer une feuille


1. Pour
renommer la feuille active, dans le menu Format, pointez sur Feuille, puis cliquez sur Renommer.

2. Tapez le nouveau nom par-dessus le nom actuel.

Travail faire:
1. lancer Excel. 2. crer un classeur nomm Travail . 3. changer la couleur du quadrillage (une couleur de votre choix). 4. renommer 3 feuilles respectivement (produit, stock, commande). 5. slectionner les trois feuilles. 6. Ajouter deux feuilles (Client, Article). 7. supprimer les trois feuilles premires. 8. Enregistrer Votre travail. 9. Quitter Excel.

ATTAK&HRAITA

- 16 -

TIB1