Vous êtes sur la page 1sur 201
Ce document est la propriété exclusive de Cisco Systems, Inc. L’autorisation d’imprimer et de co
Ce document est la propriété exclusive de Cisco Systems, Inc. L’autorisation d’imprimer et de co
Ce document est la propriété exclusive de Cisco Systems, Inc. L’autorisation d’imprimer et de co
Ce document est la propriété exclusive de Cisco Systems, Inc. L’autorisation d’imprimer et de co

Ce document est la propriété exclusive de Cisco Systems, Inc. L’autorisation d’imprimer et de copier ce document n’est autorisée que pour une distribution non commerciale et l’utilisation de ce document est exclusivement réservée aux formateurs du cours CCNA Exploration :

Accès au réseau étendu, en tant que partie intégrante du programme officiel Cisco Networking Academy.

Travaux pratiques 1.4.1 : travaux pratiques : révision avancée Diagramme de topologie Table d’adressage Périphérique
Travaux pratiques 1.4.1 : travaux pratiques : révision avancée Diagramme de topologie Table d’adressage Périphérique

Travaux pratiques 1.4.1 : travaux pratiques : révision avancée

Diagramme de topologie

pratiques : révision avancée Diagramme de topologie Table d’adressage Périphérique Interface Adresse

Table d’adressage

Périphérique

Interface

Adresse IP

Masque de

Passerelle

sous-réseau

par défaut

 

Fa0/1

N/D

N/D

N/D

Fa0/1.10

192.168.10.1

255.255.255.0

N/D

R1

Fa0/1.12

10.12.12.1

255.255.255.0

N/D

Fa0/1.13

10.13.13.1

255.255.255.0

N/D

S0/0/0

10.1.1.1

255.255.255.252

N/D

 

Fa0/1

N/D

N/D

N/D

Fa0/1.12

10.12.12.2

255.255.255.0

N/D

R2

Fa0/1.20

192.168.20.1

255.255.255.0

N/D

S0/0/0

10.1.1.2

255.255.255.252

N/D

S0/0/1

10.2.2.1

255.255.255.252

N/D

R3

Fa0/1

N/D

N/D

N/D

Copyright sur l’intégralité du contenu © 1992 2007 Cisco Systems, Inc. Tous droits réservés. Ce document contient des informations publiques Cisco.

Page 1 sur 4

CCNA Exploration Accès au réseau étendu : révision d’Exploration 2 et 3

Travaux pratiques 1.4.1 : révision avancée

 

Fa0/1.13

10.13.13.3

255.255.255.0

N/D

Fa0/1.30

192.168.30.1

255.255.255.0

N/D

S0/0/1

10.2.2.2

255.255.255.252

N/D

Comm1

VLAN10

192.168.10.2

255.255.255.0

192.168.10.1

Comm2

VLAN20

192.168.20.2

255.255.255.0

192.168.20.1

Comm3

VLAN30

192.168.30.2

255.255.255.0

192.168.30.1

PC1

Carte réseau

192.168.10.10

255.255.255.0

192.168.10.1

PC3

Carte réseau

192.168.30.10

255.255.255.0

192.168.30.1

Objectifs pédagogiques

À l’issue de ces travaux pratiques, vous serez en mesure d’effectuer les tâches suivantes :

Câbler un réseau conformément au diagramme de topologie

Supprimer la configuration de démarrage et recharger un routeur pour revenir aux paramètres par défaut

Exécuter les tâches de configuration de base d’un routeur

Configurer et activer des interfaces

Configurer le protocole Spanning Tree

Configurer les serveurs et le client VTP

Configurer les réseaux locaux virtuels (VLAN) sur les commutateurs

Configurer le routage RIP sur tous les routeurs

Configurer le routage OSPF sur tous les routeurs

Configurer le routage EIGRP sur tous les routeurs

Scénario

Au cours de ces travaux pratiques, vous allez examiner les concepts de routage et de commutation. Essayez cependant de travailler de façon autonome. Si vous éprouvez des difficultés, reportez-vous au cours précédent.

Remarque : il n’est pas conseillé d’utiliser la configuration de trois protocoles de routage distincts (RIP, OSPF et EIGRP) pour acheminer le même réseau. En effet, cette pratique est des moins recommandées, et elle ne devrait pas être mise en œuvre dans un réseau de production. Elle a été adoptée ici pour vous permettre d’examiner les principaux protocoles de routage et pour illustrer le concept de distance administrative.

Tâche 1 : préparation du réseau

Étape 1 : câblage d’un réseau similaire à celui du diagramme de topologie

Étape 2 : suppression des configurations existantes sur les routeurs

Copyright sur l’intégralité du contenu © 1992 2007 Cisco Systems, Inc. Tous droits réservés. Ce document contient des informations publiques Cisco.

Page 2 sur 4

CCNA Exploration Accès au réseau étendu : révision d’Exploration 2 et 3

Travaux pratiques 1.4.1 : révision avancée

Tâche 2 : exécution des configurations de base des périphériques

Configurez les routeurs R1, R2 et R3, ainsi que les commutateurs Comm1, Comm2, Comm3, en respectant les consignes suivantes :

Configurez le nom d’hôte.

Désactivez la recherche DNS.

Configurez un mot de passe pour le mode d’exécution privilégié.

Configurez une bannière de message du jour.

Configurez un mot de passe pour les connexions de consoles.

Configurez la connexion synchrone.

Configurez un mot de passe pour les connexions de terminaux virtuels (vty).

Tâche 3 : configuration et activation d’adresses série et Ethernet

Étape 1 : configuration des interfaces sur R1, R2 et R3

Étape 2 : vérification de l’adressage IP et des interfaces

Étape 3 : configuration de l’interface VLAN de gestion sur Comm1, Comm2 et Comm3

Étape 4 : configuration des interfaces Ethernet PC1 et PC3

Étape 5 : test de la connectivité entre les ordinateurs

Tâche 4 : configuration du protocole STP

Étape 1 : configuration systématique de Comm1 en tant que racine

Étape 2 : vérification de la définition de Comm1 en tant que racine

Tâche 5 : configuration de VTP

Étape 1 : configuration de Comm1 en tant que serveur VTP et création d’un nom de domaine et d’un mot de passe

Étape 2 : configuration de Comm2 et de Comm3 en tant que clients VTP, affectés d’un nom de domaine et d’un mot de passe

Étape 3 : vérification de la configuration

Tâche 6 : configuration des réseaux locaux virtuels

Étape 1 : configuration de Comm1 avec les réseaux locaux virtuels

Étape 2 : vérification que Comm2 et Comm3 ont reçu les configurations VLAN de Comm1

Étape 3 : attribution de ports aux réseaux locaux virtuels appropriés

Copyright sur l’intégralité du contenu © 1992 2007 Cisco Systems, Inc. Tous droits réservés. Ce document contient des informations publiques Cisco.

Page 3 sur 4

CCNA Exploration Accès au réseau étendu : révision d’Exploration 2 et 3

Travaux pratiques 1.4.1 : révision avancée

Tâche 7 : configuration du routage RIP

Étape 1 : configuration du routage RIP sur R1, R2 et R3

Étape 2 : test de la connectivité avec la commande ping

Étape 3 : vérification de la table de routage

Tâche 8 : configuration du routage OSPF

Étape 1 : configuration du routage RIP sur R1, R2 et R3

Étape 2 : vérification du remplacement des routes RIP par les routes OSPF en raison d’une distance administrative inférieure

En quoi l'activation du protocole OSPF affecte-t-elle les décisions de routage ?

Étape 3 : vérification de l’activation du protocole RIP

Tâche 9 : configuration du routage EIGRP

Étape 1 : configuration du routage EIGRP sur R1, R2 et R3

Étape 2 : vérification du remplacement des routes OSPF par les routes EIGRP en raison d’une distance administrative inférieure

Étape 3 : vérification de l’activation du protocole OSPF

Tâche 10 : documentation des configurations des routeurs

Tâche 11 : remise en état

Supprimez les configurations et rechargez les routeurs. Déconnectez le câblage et stockez-le dans un endroit sécurisé. Reconnectez le câblage souhaité et restaurez les paramètres TCP/IP pour les PC hôtes habituellement connectés aux autres réseaux (réseaux locaux de votre site ou Internet).

Copyright sur l’intégralité du contenu © 1992 2007 Cisco Systems, Inc. Tous droits réservés. Ce document contient des informations publiques Cisco.

Page 4 sur 4

Travaux pratiques 2.5.1 : configuration de base du protocole PPP Diagramme de topologie Table d’adressage

Travaux pratiques 2.5.1 : configuration de base du protocole PPP

Diagramme de topologie

de base du protocole PPP Diagramme de topologie Table d’adressage       Masque de

Table d’adressage

     

Masque de

sous-réseau

Passerelle

Périphérique

Interface

Adresse IP

par défaut

 

Fa0/1

192.168.10.1

255.255.255.0

N/D

R1

S0/0/0

10.1.1.1

255.255.255.252

N/D

 

Lo0

209.165.200.225

255.255.255.224

N/D

R2

S0/0/0

10.1.1.2

255.255.255.252

N/D

S0/0/1

10.2.2.1

255.255.255.252

N/D

R3

Fa0/1

192.168.30.1

255.255.255.0

N/D

S0/0/1

10.2.2.2

255.255.255.252

N/D

PC1

Carte réseau

192.168.10.10

255.255.255.0

192.168.10.1

PC3

Carte réseau

192.168.30.10

255.255.255.0

192.168.30.1

Copyright sur l’intégralité du contenu © 1992 2007 Cisco Systems, Inc. Tous droits réservés. Ce document contient des informations publiques Cisco.

Page 1 sur 20

CCNA Exploration Accès au réseau étendu : protocole PPP

Travaux pratiques 2.5.1 : configuration de base du protocole PPP

Objectifs pédagogiques

À l’issue de ces travaux pratiques, vous serez en mesure d’effectuer les tâches suivantes :

Câbler un réseau conformément au diagramme de topologie

Supprimer la configuration de démarrage et recharger un routeur pour revenir aux paramètres par défaut

Exécuter les tâches de configuration de base d’un routeur

Configurer et activer des interfaces

Configurer le routage OSPF sur tous les routeurs

Configurer l’encapsulation PPP sur toutes les interfaces série

Comprendre le fonctionnement des commandes debug ppp negotiation et debug ppp packet

Remplacer l’encapsulation PPP par l’encapsulation HDLC sur les interfaces série

Interrompre volontairement une encapsulation PPP et la restaurer

Configurer l’authentification PPP à l’aide des protocoles PAP et CHAP

interrompre volontairement l’authentification PPP PAP et CHAP et la restaurer

Scénario

Dans le cadre de ces travaux pratiques, vous apprendrez à configurer l’encapsulation PPP sur les liaisons série en utilisant le réseau illustré dans le diagramme de topologie. Vous apprendrez également à restaurer l’encapsulation HDLC des liaisons série. Observez bien le résultat affiché par le routeur lorsque vous interrompez volontairement l’encapsulation PPP. Cela vous aidera dans les travaux pratiques de dépannage associés à ce chapitre. Enfin, vous apprendrez à configurer l’authentification PPP à l’aide des protocoles PAP et CHAP.

Tâche 1 : préparation du réseau

Étape 1 : câblage d’un réseau similaire à celui du diagramme de topologie

Vous pouvez utiliser n’importe quel routeur disponible durant les travaux pratiques, pourvu qu’il dispose des interfaces requises, comme illustré sur le diagramme de topologie.

Remarque : si vous utilisez les routeurs 1700, 2500 ou 2600, les sorties des routeurs et les descriptions des interfaces s’affichent différemment.

Étape 2 : suppression des configurations existantes sur les routeurs

Tâche 2 : configuration de base d’un routeur

Configurez les routeurs R1, R2 et R3 conformément aux instructions suivantes :

Configurez le nom d’hôte du routeur.

Désactivez la recherche DNS.

Configurez un mot de passe pour le mode d’exécution privilégié.

Configurez une bannière de message du jour.

Configurez un mot de passe pour les connexions de consoles.

Copyright sur l’intégralité du contenu © 1992 2007 Cisco Systems, Inc. Tous droits réservés. Ce document contient des informations publiques Cisco.

Page 2 sur 20

CCNA Exploration Accès au réseau étendu : protocole PPP

Travaux pratiques 2.5.1 : configuration de base du protocole PPP

Configurez la connexion synchrone.

Configurez un mot de passe pour les connexions de terminaux virtuels (vty).

Tâche 3 : configuration et activation d’adresses série et Ethernet

Étape 1 : configuration des interfaces sur R1, R2 et R3

Configurez les interfaces des routeurs R1, R2 et R3 avec les adresses IP de la table d’adressage figurant au début des travaux pratiques. Veillez à inclure la fréquence d’horloge sur les interfaces série DCE.

Étape 2 : vérification de l’adressage IP et des interfaces

Utilisez la commande show ip interface brief pour vérifier que l’adressage IP est correct et que les interfaces sont actives.

Lorsque vous aurez terminé, veillez à enregistrer la configuration actuelle dans la mémoire NVRAM du routeur.

Étape 3 : configuration des interfaces Ethernet de PC1 et PC3

Configurez les interfaces Ethernet de PC1 et PC3 avec les adresses IP et les passerelles par défaut provenant de la table d’adressage.

Étape 4 : test de la configuration par l’envoi d’une requête ping entre le PC et la passerelle par défaut

Tâche 4 : configuration du protocole OSPF sur les routeurs

Si vous souhaitez revoir les commandes OSPF, consultez la section Exploration 2, module 11.

Étape 1 : activation du routage OSPF sur R1, R2 et R3

Utilisez la commande router OSPF avec l’ID de processus 1. Veillez à annoncer correctement les réseaux.

R1(config)#router ospf 1 R1(config-router)#network 192.168.10.0 0.0.0.255 area 0 R1(config-router)#network 10.1.1.0 0.0.0.3 area 0 *Aug 17 17:49:14.689: %OSPF-5-ADJCHG: Process 1, Nbr 209.165.200.225 on Serial0/0/0 from LOADING to FULL, Loading Done

R1(config-router)#

R2(config)#router ospf 1 R2(config-router)#network 10.1.1.0 0.0.0.3 area 0 *Aug 17 17:48:40.645: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.10.1 on Serial0/0/0 from LOADING to FULL, Loading Done R2(config-router)#network 10.2.2.0 0.0.0.3 area 0 R2(config-router)#network 209.165.200.224 0.0.0.31 area 0

R2(config-router)#

*Aug 17 17:57:44.729: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.30.1 on Serial0/0/1 from LOADING to FULL, Loading Done

R2(config-router)#

R3(config)#router ospf 1 R3(config-router)#network 10.2.2.0 0.0.0.3 area 0 *Aug 17 17:58:02.017: %OSPF-5-ADJCHG: Process 1, Nbr 209.165.200.225 on

Copyright sur l’intégralité du contenu © 1992 2007 Cisco Systems, Inc. Tous droits réservés. Ce document contient des informations publiques Cisco.

Page 3 sur 20

CCNA Exploration Accès au réseau étendu : protocole PPP

Travaux pratiques 2.5.1 : configuration de base du protocole PPP

Serial0/0/1 from LOADING to FULL, Loading Done R3(config-router)#network 192.168.30.0 0.0.0.255 area 0

R3(config-router)#

Étape 2 : vérification de la connectivité sur l’ensemble du réseau

Utilisez les commandes show ip route et ping pour vérifier la connectivité.

R1#show ip route

<résultat omis>

O

192.168.30.0/24 [110/1563] via 10.1.1.2, 00:33:56, Serial0/0/0

C

192.168.10.0/24 is directly connected, FastEthernet0/1 209.165.200.0/32 is subnetted, 1 subnets

O

209.165.200.225 [110/782] via 10.1.1.2, 00:33:56, Serial0/0/0 10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks

C

10.1.1.2/32 is directly connected, Serial0/0/0

O

10.2.2.0/30 [110/1562] via 10.1.1.2, 00:33:56, Serial0/0/0

C

10.1.1.0/30 is directly connected, Serial0/0/0

R1#ping

192.168.30.1

Type escape sequence to abort.

Sending

5, 100-byte ICMP Echos to 192.168.30.1, timeout is 2 seconds:

!!!!!

Success

rate is 100 percent (5/5), round-trip min/avg/max = 32/32/32 ms

R1#

R2#show

ip route

<résultat omis>

O

192.168.30.0/24 [110/782] via 10.2.2.2, 00:33:04, Serial0/0/1

O

192.168.10.0/24 [110/782] via 10.1.1.1, 00:33:04, Serial0/0/0 209.165.200.0/27 is subnetted, 1 subnets

C

209.165.200.224 is directly connected, Loopback0 10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks

C

10.2.2.2/32 is directly connected, Serial0/0/1

C

10.2.2.0/30 is directly connected, Serial0/0/1

C

10.1.1.0/30 is directly connected, Serial0/0/0

C

10.1.1.1/32 is directly connected, Serial0/0/0

R2#ping

192.168.30.1

Type escape sequence to abort.

Sending

5, 100-byte ICMP Echos to 192.168.30.1, timeout is 2 seconds:

!!!!!

Success

rate is 100 percent (5/5), round-trip min/avg/max = 16/16/16 ms

R2#ping

192.168.10.1

Type escape sequence to abort.

Sending

5, 100-byte ICMP Echos to 192.168.10.1, timeout is 2 seconds:

!!!!!

Success

rate is 100 percent (5/5), round-trip min/avg/max = 16/16/16 ms

R2#

Copyright sur l’intégralité du contenu © 1992 2007 Cisco Systems, Inc. Tous droits réservés. Ce document contient des informations publiques Cisco.

Page 4 sur 20

CCNA Exploration Accès au réseau étendu : protocole PPP

Travaux pratiques 2.5.1 : configuration de base du protocole PPP

R3#show ip route

<résultat omis>

C

192.168.30.0/24 is directly connected, FastEthernet0/1

O

192.168.10.0/24 [110/1563] via 10.2.2.1, 00:32:01, Serial0/0/1 209.165.200.0/32 is subnetted, 1 subnets

O

209.165.200.225 [110/782] via 10.2.2.1, 00:32:01, Serial0/0/1 10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks

C

10.2.2.0/30 is directly connected, Serial0/0/1

O

10.1.1.0/30 [110/1562] via 10.2.2.1, 00:32:01, Serial0/0/1

C

10.2.2.1/32 is directly connected, Serial0/0/1

R3#ping

209.165.200.225

Type escape sequence to abort.

Sending

5, 100-byte ICMP Echos to 209.165.200.225, timeout is 2 seconds:

!!!!!

Success

rate is 100 percent (5/5), round-trip min/avg/max = 16/16/16 ms

R3#ping

192.168.10.1

Type escape sequence to abort.

Sending

5, 100-byte ICMP Echos to 192.168.10.1, timeout is 2 seconds:

!!!!!

Success

rate is 100 percent (5/5), round-trip min/avg/max = 32/32/32 ms

R3#

Tâche 5 : configuration de l’encapsulation PPP sur les interfaces série

Étape 1 : utilisation de la commande show interface pour vérifier que le protocole HDLC est l’encapsulation série par défaut

R1#show interface serial0/0/0

Serial0/0/0 is up, line protocol is up Hardware is GT96K Serial Internet address is 10.1.1.1/30 MTU 1500 bytes, BW 128 Kbit, DLY 20000 usec, reliability 255/255, txload 1/255, rxload 1/255

Encapsulation HDLC

<résultat omis>

, loopback not set

R2#show interface serial 0/0/0

Serial0/0/0 is up, line protocol is up Hardware is GT96K Serial Internet address is 10.1.1.2/30 MTU 1500 bytes, BW 128 Kbit, DLY 20000 usec, reliability 255/255, txload 1/255, rxload 1/255

Encapsulation HDLC

<résultat omis>

, loopback not set

R2#show interface serial 0/0/1

Serial0/0/1 is up, line protocol is up Hardware is GT96K Serial

Copyright sur l’intégralité du contenu © 1992 2007 Cisco Systems, Inc. Tous droits réservés. Ce document contient des informations publiques Cisco.

Page 5 sur 20

CCNA Exploration Accès au réseau étendu : protocole PPP

Travaux pratiques 2.5.1 : configuration de base du protocole PPP

Internet address is 10.2.2.1/30 MTU 1500 bytes, BW 128 Kbit, DLY 20000 usec, reliability 255/255, txload 1/255, rxload 1/255

Encapsulation HDLC

<résultat omis>

, loopback not set

R3#show interface serial 0/0/1 Serial0/0/1 is up, line protocol is up Hardware is GT96K Serial Internet address is 10.2.2.2/30 MTU 1500 bytes, BW 128 Kbit, DLY 20000 usec, reliability 255/255, txload 1/255, rxload 1/255

Encapsulation HDLC

<résultat omis>

, loopback not set

Étape 2 : utilisation des commandes de débogage sur R1 et R2 pour constater les effets de la configuration du protocole PPP

R1#debug ppp negotiation PPP protocol negotiation debugging is on R1#debug ppp packet PPP packet display debugging is on

R1#

R2#debug ppp negotiation PPP protocol negotiation debugging is on R2#debug ppp packet PPP packet display debugging is on

R2#

Étape 3 : remplacement de l’encapsulation HDCL des interfaces série par l’encapsulation PPP

Modifiez le type d’encapsulation sur la liaison entre R1 et R2, puis observez les effets. Si vous commencez à recevoir trop de données de débogage, utilisez la commande undebug all pour désactiver les opérations de débogage.

R1(config)#interface serial 0/0/0 R1(config-if)#encapsulation ppp

R1(config-if)#

*Aug 17 19:02:53.412:

%OSPF-5-ADJCHG: Process 1, Nbr 209.165.200.225 on

 

Serial0/0/0 from FULL to DOWN, Neighbor Down: Interface down or detached

R1(config-if)#

*Aug 17 19:02:53.416: Se0/0/0

*Aug 17 19:02:53.416: Se0/0/0 PPP: Using default call direction *Aug 17 19:02:53.416: Se0/0/0 PPP: Treating connection as a dedicated line *Aug 17 19:02:53.416: Se0/0/0 PPP: Session handle[E4000001] Session id[0]

*Aug 17 19:02:53.416: Se0/0/0 PPP: Phase is

*Aug 17 19:02:53.424: Se0/0/0 LCP: O CONFREQ [Closed] id 1 len 10

*Aug 17 19:02:53.424: Se0/0/0 LCP:

R1(config-if)#

*Aug 17 19:02:55.412: Se0/0/0 PPP: Outbound cdp packet dropped

*Aug 17 19:02:55.432: Se0/0/0 LCP:

*Aug 17 19:02:55.432: Se0/0/0 LCP: O CONFREQ [REQsent] id 2 len 10

*Aug 17 19:02:55.432: Se0/0/0 LCP:

*Aug 17 19:02:56.024: Se0/0/0 PPP: I pkt type 0x008F, datagramsize 24

PPP: Phase is DOWN

, Setup

ESTABLISHING, Active Open

MagicNumber 0x63B994DE (0x050663B994DE)

TIMEout: State REQsent

MagicNumber 0x63B994DE (0x050663B994DE)

Copyright sur l’intégralité du contenu © 1992 2007 Cisco Systems, Inc. Tous droits réservés. Ce document contient des informations publiques Cisco.

Page 6 sur 20

CCNA Exploration Accès au réseau étendu : protocole PPP

Travaux pratiques 2.5.1 : configuration de base du protocole PPP

link[

*Aug 17 19:02:56.024: Se0/0/0

R1(config-if)#

*Aug 17 19:02:57.252: Se0/0/0 PPP: I pkt type 0x000F, datagramsize 84 link[illegal]

*Aug 17 19:02:57.252: Se0/0/0 UNKNOWN(0x000F): Non-NCP packet, discarding *Aug 17 19:02:57.448: Se0/0/0 LCP: TIMEout: State REQsent *Aug 17 19:02:57.448: Se0/0/0 LCP: O CONFREQ [REQsent] id 3 len 10

*Aug 17 19:02:57.448: Se0/0/0 LCP:

R1(config-if)#

*Aug 17 19:02:58.412: %LINEPROTO-5-UPDOWN:

illegal ]
illegal
]

UNKNOWN(0x008F): Non-NCP packet, discarding

MagicNumber 0x63B994DE (0x050663B994DE)

Line protocol on Interface

Serial0/0/0, changed state to down

R2(config)#interface serial 0/0/0 R2(config-if)#encapsulation ppp

R2(config-if)#

*Aug 17 19:06:48.848: Se0/0/0

*Aug 17 19:06:48.848: Se0/0/0 PPP: Using default call direction *Aug 17 19:06:48.848: Se0/0/0 PPP: Treating connection as a dedicated line *Aug 17 19:06:48.848: Se0/0/0 PPP: Session handle[C6000001] Session id[0]

*Aug 17 19:06:48.848: Se0/0/0

*Aug 17 19:06:48.856: Se0/0/0 LCP: O CONFREQ [Closed] id 1 len 10

*Aug 17 19:06:48.856: Se0/0/0 LCP:

*Aug 17 19:06:48.860: Se0/0/0 PPP: I pkt type 0xC021, datagramsize 14 link[ppp] *Aug 17 19:06:48.860: Se0/0/0 LCP: I CONFACK [REQsent] id 1 len 10

R2(config-if)#

*Aug 17 19:06:48.860: Se0/0/0 LCP:

R2(config-if)#

*Aug 17 19:06:50.864: Se0/0/0 LCP: TIMEout: State ACKrcvd

*Aug 17 19:06:50.864: Se0/0/0 LCP: O CONFREQ [ACKrcvd] id 2 len 10

*Aug 17 19:06:50.864: Se0/0/0 LCP:

*Aug 17 19:06:50.868: Se0/0/0 PPP: I pkt type 0xC021, datagramsize 14 link[ppp] *Aug 17 19:06:50.868: Se0/0/0 LCP: I CONFREQ [REQsent] id 61 len 10

*Aug 17 19:06:50.868: Se0/0/0 LCP:

*Aug 17 19:06:50.868: Se0/0/0 LCP: O CONFACK [REQsent] id 61 len 10

*Aug 17 19:06:50.868: Se0/0/0 LCP:

*Aug 17 19:06:50.868: Se0/0/0 PPP: I pkt type 0xC021, datagramsize 14 link[ppp]

*Aug 17 19:06:50.868: Se0/0/0 LCP: I CONFACK [ACKsent] id 2 len 10

*Aug 17 19:06:50.868: Se0/0/0 LCP:

*Aug 17 19:06:50.868: Se0/0/0 LCP:

, Attempting Forward

*Aug 17 19:06:50.872: Se0/0/0 *Aug 17 19:06:50.872: Se0/0/0 *Aug 17 19:06:50.872: Se0/0/0

*Aug 17 19:06:50.872: Se0/0/0 IPCP: O CONFREQ [Closed] id 1 len 10

*Aug 17 19:06:50.872: Se0/0/0 IPCP:

*Aug 17 19:06:50.872: Se0/0/0 CDPCP: O CONFREQ [Closed] id 1 len 4 *Aug 17 19:06:50.872: Se0/0/0 PPP: Process pending ncp packets *Aug 17 19:06:50.876: Se0/0/0 PPP: I pkt type 0x8021, datagramsize 14

link[ip] *Aug 17 19:06:50.876: Se0/0/0 IPCP: I CONFREQ [REQsent] id 1 len 10

*Aug 17 19:06:50.876: Se0/0/0 IPCP:

*Aug 17 19:06:50.876: Se0/0/0 PPP: I pkt type 0x8207, datagramsize 8

link[cdp]

PPP: Phase is DOWN, Setup

PPP: Phase is ESTABLISHING, Active Open

MagicNumber 0x63BD388C (0x050663BD388C)

MagicNumber 0x63BD388C (0x050663BD388C)

MagicNumber 0x63BD388C (0x050663BD388C)

MagicNumber 0x63BDB9A8 (0x050663BDB9A8)

MagicNumber 0x63BDB9A8 (0x050663BDB9A8)

MagicNumber 0x63BD388C (0x050663BD388C)

, Finish LCP

State is Open

PPP: Phase is FORWARDING

PPP: Phase is ESTABLISHING

PPP: Phase is UP

Address 10.1.1.2 (0x03060A010102)

Address 10.1.1.1 (0x03060A010101)

Copyright sur l’intégralité du contenu © 1992 2007 Cisco Systems, Inc. Tous droits réservés. Ce document contient des informations publiques Cisco.

Page 7 sur 20

CCNA Exploration Accès au réseau étendu : protocole PPP

Travaux pratiques 2.5.1 : configuration de base du protocole PPP

*Aug 17 19:06:50.876: Se0/0/0 IPCP: O CONFACK [REQsent] id 1 len 10

*Aug 17 19:06:50.876: Se0/0/0 IPCP:

*Aug 17 19:06:50.876: Se0/0/0 CDPCP: I CONFREQ [REQsent] id 1 len 4 *Aug 17 19:06:50.876: Se0/0/0 CDPCP: O CONFACK [REQsent] id 1 len 4 *Aug 17 19:06:50.876: Se0/0/0 PPP: I pkt type 0x8021, datagramsize 14

link[ip] *Aug 17 19:06:50.876: Se0/0/0 IPCP: I CONFACK [ACKse R2(config-if)#nt] id 1 len 10

*Aug 17 19:06:50.876: Se0/0/0 IPCP:

*Aug 17 19:06:50.876: Se0/0/0 IPCP: State is Open *Aug 17 19:06:50.876: Se0/0/0 PPP: I pkt type 0x8207, datagramsize 8 link[cdp] *Aug 17 19:06:50.876: Se0/0/0 IPCP: Install route to 10.1.1.1 *Aug 17 19:06:50.880: Se0/0/0 CDPCP: I CONFACK [ACKsent] id 1 len 4

*Aug 17 19:06:50.880: Se0/0/0 CDPCP: State is Open *Aug 17 19:06:50.880: Se0/0/0 PPP: O pkt type 0x0021, datagramsize 80 *Aug 17 19:06:50.880: Se0/0/0 IPCP: Add link info for cef entry 10.1.1.1 *Aug 17 19:06:50.884: Se0/0/0 PPP: I pkt type 0x0021, datagramsize 80 link[ip]

*Aug 17 19:06:51.848: %LINEPROTO-5-UPDOWN:

Address 10.1.1.1 (0x03060A010101)

Address 10.1.1.2 (0x03060A010102)

Line protocol on Interface

Serial0/0/0, changed state to up

R2(config-if)#

*Aug 17 19:06:51.888: Se0/0/0 LCP-FS: I ECHOREQ [Open] id 1 len 12 magic

0x63BDB9A8

*Aug 17 19:06:51.888: Se0/0/0 LCP-FS: O ECHOREP [Open] id 1 len 12 magic

0x63BD388C

<résultat omis>

*Aug 17 19:07:00.936: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.10.1 on

*Aug 17 19:07:00.936: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.10.1 on

Serial0/0/0 from LOADING to FULL, Loading Done

*Aug 17 19:07:00.936: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.10.1 on Serial0/0/0 from LOADING to FULL, Loading Done

Que se passe-t-il lorsque l’une des extrémités de la liaison série est encapsulée avec le protocole PPP et l’autre extrémité avec le protocole HDLC ?

Par quelles étapes le protocole PPP passe-t-il si l’autre extrémité de la liaison série sur R2 est configurée via l’encapsulation PPP ?

Copyright sur l’intégralité du contenu © 1992 2007 Cisco Systems, Inc. Tous droits réservés. Ce document contient des informations publiques Cisco.

Page 8 sur 20

CCNA Exploration Accès au réseau étendu : protocole PPP

Travaux pratiques 2.5.1 : configuration de base du protocole PPP

Que se passe-t-il lorsque l’encapsulation PPP est configurée sur chaque extrémité de la liaison série ?

Étape 4 : désactivation de la fonction de débogage

Désactivez la fonction de débogage si vous n’avez pas encore utilisé la commande undebug all.

R1#undebug all Port Statistics for unclassified packets is not turned on.

All possible debugging has been turned off

R1#

R2#undebug all Port Statistics for unclassified packets is not turned on.

All possible debugging has been turned off

R2#

Étape 5 : remplacement de l’encapsulation HDLC par l’encapsulation PPP aux deux extrémités de la liaison série entre R2 et R3

R2(config)#interface serial0/0/1 R2(config-if)#encapsulation ppp

R2(config-if)#

*Aug 17 20:02:08.080: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.30.1 on Serial0/0/1 from FULL to DOWN, Neighbor Down: Interface down or detached

R2(config-if)#

*Aug 17 20:02:13.080: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/1, changed state to down

R2(config-if)#

*Aug 17 20:02:58.564: %LINEPROTO-5-UPDOWN:

Line protocol on Interface

Serial0/0/1, changed state to up

R2(config-if)#

*Aug 17 20:03:03.644:

%OSPF-5-ADJCHG: Process 1, Nbr 192.168.30.1 on

Serial0/0/1 from LOADING to FULL, Loading Done

 

R2(config-if)#

*Aug 17 20:03:46.988: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/1, changed state to down R3(config)#interface serial 0/0/1 R3(config-if)#encapsulation ppp

R3(config-if)#

*Aug 17 20:04:27.152: %LINEPROTO-5-UPDOWN:

Line protocol on Interface

Serial0/0/1, changed state to up

 

*Aug 17 20:04:30.952:

%OSPF-5-ADJCHG: Process 1, Nbr 209.165.200.225 on

Serial0/0/1 from LOADING to FULL, Loading Done

 

Copyright sur l’intégralité du contenu © 1992 2007 Cisco Systems, Inc. Tous droits réservés. Ce document contient des informations publiques Cisco.

Page 9 sur 20

CCNA Exploration Accès au réseau étendu : protocole PPP

Travaux pratiques 2.5.1 : configuration de base du protocole PPP

Quand le protocole de ligne sur la liaison série est-il activé et quand la contiguïté OSPF est-elle restaurée ?

Étape 6 : vérification de l’activation de l’encapsulation PPP sur les interfaces série

R1#show interface serial0/0/0 Serial0/0/0 is up, line protocol is up Hardware is GT96K Serial Internet address is 10.1.1.1/30 MTU 1500 bytes, BW 128 Kbit, DLY 20000 usec, reliability 255/255, txload 1/255, rxload 1/255

Encapsulation PPP

, LCP Open

Open: CDPCP, IPCP, loopback not set

<résultat omis>

R2#show interface serial 0/0/0 Serial0/0/0 is up, line protocol is up Hardware is GT96K Serial Internet address is 10.1.1.2/30 MTU 1500 bytes, BW 128 Kbit, DLY 20000 usec, reliability 255/255, txload 1/255, rxload 1/255

Encapsulation PPP

, LCP Open

Open: CDPCP, IPCP, loopback not set

<résultat omis>

R2#show interface serial 0/0/1 Serial0/0/1 is up, line protocol is up Hardware is GT96K Serial Internet address is 10.2.2.1/30 MTU 1500 bytes, BW 128 Kbit, DLY 20000 usec, reliability 255/255, txload 1/255, rxload 1/255

Encapsulation PPP

, LCP Open

Open: CDPCP, IPCP, loopback not set

<résultat omis> R3#show interface serial 0/0/1 Serial0/0/1 is up, line protocol is up Hardware is GT96K Serial Internet address is 10.2.2.2/30 MTU 1500 bytes, BW 128 Kbit, DLY 20000 usec, reliability 255/255, txload 1/255, rxload 1/255

Encapsulation PPP

, LCP Open

Open: CDPCP, IPCP, loopback not set

<résultat omis>

Copyright sur l’intégralité du contenu © 1992 2007 Cisco Systems, Inc. Tous droits réservés. Ce document contient des informations publiques Cisco.

Page 10 sur 20

CCNA Exploration Accès au réseau étendu : protocole PPP

Travaux pratiques 2.5.1 : configuration de base du protocole PPP

Tâche 7 : interruption et restauration de l’encapsulation PPP

En interrompant volontairement l’encapsulation PPP, vous en saurez plus sur les messages d’erreur générés. Cela vous aidera ultérieurement dans les travaux pratiques de dépannage.

Étape 1 : rétablissement de l’encapsulation HDLC par défaut des deux interfaces série de R2

R2(config)#interface serial 0/0/0 R2(config-if)#encapsulation hdlc

R2(config-if)#

*Aug 17 20:36:48.432: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.10.1 on Serial0/0/0 from FULL to DOWN, Neighbor Down: Interface down or detached *Aug 17 20:36:49.432: %LINEPROTO-5-UPDOWN: Line protocol on Interface

Serial0/0/0, changed state to down

R2(config-if)#

*Aug 17 20:36:51.432: %LINEPROTO-5-UPDOWN: Line protocol on Interface

Serial0/0/0, changed state to up

R2(config-if)#interface serial 0/0/1 *Aug 17 20:37:14.080: %LINEPROTO-5-UPDOWN: Line protocol on Interface

Serial0/0/0, changed state to down

R2(config-if)#encapsulation hdlc

R2(config-if)#

*Aug 17 20:37:17.368: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.30.1 on Serial0/0/1 from FULL to DOWN, Neighbor Down: Interface down or detached *Aug 17 20:37:18.368: %LINEPROTO-5-UPDOWN: Line protocol on Interface

Serial0/0/1, changed state to down

R2(config-if)#

*Aug 17 20:37:20.368: %LINEPROTO-5-UPDOWN: Line protocol on Interface

Serial0/0/1, changed state to up

R2(config-if)#

*Aug 17 20:37:44.080: %LINEPROTO-5-UPDOWN: Line protocol on Interface

Serial0/0/1, changed state to down

R2(config-if)#

En quoi l’interruption délibérée d’une configuration est-elle utile ?

Pourquoi les deux interfaces série sont-elles désactivées, activées, puis désactivées de nouveau ?

Copyright sur l’intégralité du contenu © 1992 2007 Cisco Systems, Inc. Tous droits réservés. Ce document contient des informations publiques Cisco.

Page 11 sur 20

CCNA Exploration Accès au réseau étendu : protocole PPP

Travaux pratiques 2.5.1 : configuration de base du protocole PPP

Outre l’utilisation de la commande encapsulation hdlc, comment peut-on remplacer l’encapsulation PPP d’une interface série par l’encapsulation HDLC par défaut ? (Indice :

la réponse à cette question est liée à la commande no.)

Étape 2 : rétablissement de l’encapsulation PPP des deux interfaces série de R2

R2(config)#interface s0/0/0 R2(config-if)#encapsulation ppp *Aug 17 20:53:06.612: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up R2(config-if)#interface s0/0/1 *Aug 17 20:53:10.856: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.10.1 on Serial0/0/0 from LOADING to FULL, Loading Done R2(config-if)#encapsulation ppp *Aug 17 20:53:23.332: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/1, changed state to up

R2(config-if)#

*Aug 17 20:53:24.916: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.30.1 on Serial0/0/1 from LOADING to FULL, Loading Done

R2(config-if)#

Tâche 8 : configuration de l’authentification PPP

Étape 1 : configuration de l’authentification PPP à l’aide du protocole PAP sur la liaison série reliant R1 et R2

R1(config)#username R1 password cisco R1(config)#int s0/0/0 R1(config-if)#ppp authentication pap

R1(config-if)#

*Aug 22 18:58:57.367: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to down

R1(config-if)#

*Aug 22 18:58:58.423: %OSPF-5-ADJCHG: Process 1, Nbr 209.165.200.225 on Serial0/0/0 from FULL to DOWN, Neighbor Down: Interface down or detached R1(config-if)#ppp pap sent-username R2 password cisco

Copyright sur l’intégralité du contenu © 1992 2007 Cisco Systems, Inc. Tous droits réservés. Ce document contient des informations publiques Cisco.

Page 12 sur 20

CCNA Exploration Accès au réseau étendu : protocole PPP

Travaux pratiques 2.5.1 : configuration de base du protocole PPP

Que se passe-t-il lorsque lauthentification PPP, via le protocole PAP, est configurée sur une seule extrémité de la liaison série ?

R2(config)#username R2 password cisco R2(config)#interface Serial0/0/0 R2(config-if)#ppp authentication pap R2(config-if)#ppp pap sent-username R1 password cisco

R2(config-if)#

*Aug 23 16:30:33.771: %LINEPROTO-5-UPDOWN:

Line protocol on Interface

Serial0/0/0, changed state to up

R2(config-if)#

*Aug 23 16:30:40.815: %

OSPF-5-ADJCHG: Process 1, Nbr 192.168.10.1 on

Serial0/0/0 from LOADING to FULL

, Loading Done

R2(config-if)#

Que se passe-t-il lorsque l’authentification PPP, via le protocole PAP, est configurée sur chaque extrémité de la liaison série ?

Étape 2 : configuration de l’authentification PPP, via le protocole CHAP, sur la liaison série reliant R2 et R3

Dans le cas d’une authentification PAP, le mot de passe n’est pas chiffré. Même sil vaut mieux utiliser ce type dauthentification plutôt que de nen utiliser aucune, il est préférable de chiffrer le mot de passe transmis sur la liaison. Le protocole CHAP chiffre le mot de passe.

R2(config)#username R3 password cisco R2(config)#int s0/0/1 R2(config-if)#ppp authentication chap

R2(config-if)#

*Aug 23 18:06:00.935: %LINEPROTO-5-UPDOWN: Line protocol on Interface

Serial0/0/1, changed state to

R2(config-if)#

*Aug 23 18:06:01.947: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.30.1 on

Serial0/0/1 from FULL to

R2(config-if)#

down
down
DOWN
DOWN

, Neighbor Down: Interface down or detached

R3(config)#username R2 password cisco *Aug 23 18:07:13.074: %LINEPROTO-5-UPDOWN: Line protocol on Interface

Serial0/0/1, changed state to

R3(config)#int s0/0/1

R3(config-if)#

*Aug 23 18:07:22.174: %OSPF-5-ADJCHG: Process 1, Nbr 209.165.200.225 on Serial0/0/1 from LOADING to FULL, Loading Done R3(config-if)#ppp authentication chap

R3(config-if)#

up
up

Copyright sur l’intégralité du contenu © 1992 2007 Cisco Systems, Inc. Tous droits réservés. Ce document contient des informations publiques Cisco.

Page 13 sur 20

CCNA Exploration Accès au réseau étendu : protocole PPP

Travaux pratiques 2.5.1 : configuration de base du protocole PPP

Vous pouvez constater que létat du protocole de ligne de linterface série 0/0/1 passe à UP (activé) avant même que linterface ne soit configurée pour lauthentification CHAP. Pouvez- vous en déterminer la raison ?

Étape 3 : examen du résultat du débogage

Pour mieux comprendre le processus CHAP, consultez le résultat de la commande debug ppp authentication sur R2 et R3. Arrêtez ensuite l’interface Serial 0/0/1 sur R2, puis exécutez la commande no shutdown sur l’interface Serial 0/0/1 sur R2.

R2#debug ppp authentication PPP authentication debugging is on R2#conf t Enter configuration commands, one per line. End with CNTL/Z. R2(config)#int s0/0/1

R2(config-if)#shutdown

R2(config-if)#

*Aug 23 18:19:21.059: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.30.1 on Serial0/0/1 from FULL to DOWN, Neighbor Down: Interface down or detached

R2(config-if)#

*Aug 23 18:19:23.059: %LINK-5-CHANGED: Interface Serial0/0/1, changed state to administratively down *Aug 23 18:19:24.059: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/1, changed state to down R2(config-if)#no shutdown

*Aug 23 18:19:55.059: Se0/0/1 PPP: Using default call direction *Aug 23 18:19:55.059: Se0/0/1 PPP: Treating connection as a dedicated line *Aug 23 18:19:55.059: Se0/0/1 PPP: Session handle[5B000005] Session id[49] *Aug 23 18:19:55.059: Se0/0/1 PPP: Authorization required *Aug 23 18:19:55.063: %LINK-3-UPDOWN: Interface Serial0/0/1, changed state to up *Aug 23 18:19:55.063: Se0/0/1 CHAP: O CHALLENGE id 48 len 23 from "R2" *Aug 23 18:19:55.067: Se0/0/1 CHAP: I CHALLENGE id 2 len 23 from "R3" *Aug 23 18:19:55.067: Se0/0/1 CHAP: Using hostname from unknown source *Aug 23 18:19:55.067: Se0/0/1 CHAP: Using password from AAA *Aug 23 18:19:55.067: Se0/0/1 CHAP: O RESPONSE id 2 len 23 from "R2" *Aug 23 18:19:55.071: Se0/0/1 CHAP: I RESPONSE id 48 len 23 from "R3" *Aug 23 18:19:55.071: Se0/0/1 PPP: Sent CHAP LOGIN Request *Aug 23 18:19:55.071: Se0/0/1 PPP: Received LOGIN Response PASS *Aug 23 18:19:55.071: Se0/0/1 PPP: Sent LCP AUTHOR Request *Aug 23 18:19:55.075: Se0/0/1 PPP: Sent IPCP AUTHOR Request *Aug 23 18:19:55.075: Se0/0/1 LCP: Received AAA AUTHOR Response PASS *Aug 23 18:19:55.075: Se0/0/1 IPCP: Received AAA AUTHOR Response PASS *Aug 23 18:19:55.075: Se0/0/1 CHAP: O SUCCESS id 48 len 4 *Aug 23 18:19:55.075: Se0/0/1 CHAP: I SUCCESS id 2 len 4 *Aug 23 18:19:55.075: Se0/0/1 PPP: Sent CDPCP AUTHOR Request *Aug 23 18:19:55.075: Se0/0/1 CDPCP: Received AAA AUTHOR Response PASS *Aug 23 18:19:55.079: Se0/0/1 PPP: Sent IPCP AUTHOR Request *Aug 23 18:19:56.075: %LINEPROTO-5-UPDOWN: Line protocol on Interface

Copyright sur l’intégralité du contenu © 1992 2007 Cisco Systems, Inc. Tous droits réservés. Ce document contient des informations publiques Cisco.

Page 14 sur 20

CCNA Exploration Accès au réseau étendu : protocole PPP

Travaux pratiques 2.5.1 : configuration de base du protocole PPP

Serial0/0/1, changed state to up

R2(config-if)#

*Aug 23 18:20:05.135: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.30.1 on Serial0/0/1 from LOADING to FULL, Loading Done

R3#debug ppp authentication PPP authentication debugging is on

R3#

*Aug 23 18:19:04.494: %LINK-3-UPDOWN: Interface Serial0/0/1, changed state to down

R3#

*Aug 23 18:19:04.494: %OSPF-5-ADJCHG: Process 1, Nbr 209.165.200.225 on Serial0/0/1 from FULL to DOWN, Neighbor Down: Interface down or detached *Aug 23 18:19:05.494: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/1, changed state to down

R3#

*Aug 23 18:19:36.494: %LINK-3-UPDOWN: Interface Serial0/0/1, changed state to up *Aug 23 18:19:36.494: Se0/0/1 PPP: Using default call direction *Aug 23 18:19:36.494: Se0/0/1 PPP: Treating connection as a dedicated line *Aug 23 18:19:36.494: Se0/0/1 PPP: Session handle[3C000034] Session id[52] *Aug 23 18:19:36.494: Se0/0/1 PPP: Authorization required *Aug 23 18:19:36.498: Se0/0/1 CHAP: O CHALLENGE id 2 len 23 from "R3" *Aug 23 18:19:36.502: Se0/0/1 CHAP: I CHALLENGE id 48 len 23 from "R2" *Aug 23 18:19:36.502: Se0/0/1 CHAP: Using hostname from unknown source *Aug 23 18:19:36.506: Se0/0/1 CHAP: Using password from AAA *Aug 23 18:19:36.506: Se0/0/1 CHAP: O RESPONSE id 48 len 23 from "R3" *Aug 23 18:19:36.506: Se0/0/1 CHAP: I RESPONSE id 2 len 23 from "R2"

R3#

*Aug 23 18:19:36.506: Se0/0/1 PPP: Sent CHAP LOGIN Request *Aug 23 18:19:36.506: Se0/0/1 PPP: Received LOGIN Response PASS *Aug 23 18:19:36.510: Se0/0/1 PPP: Sent LCP AUTHOR Request *Aug 23 18:19:36.510: Se0/0/1 PPP: Sent IPCP AUTHOR Request *Aug 23 18:19:36.510: Se0/0/1 LCP: Received AAA AUTHOR Response PASS *Aug 23 18:19:36.510: Se0/0/1 IPCP: Received AAA AUTHOR Response PASS *Aug 23 18:19:36.510: Se0/0/1 CHAP: O SUCCESS id 2 len 4 *Aug 23 18:19:36.510: Se0/0/1 CHAP: I SUCCESS id 48 len 4 *Aug 23 18:19:36.514: Se0/0/1 PPP: Sent CDPCP AUTHOR Request *Aug 23 18:19:36.514: Se0/0/1 PPP: Sent IPCP AUTHOR Request *Aug 23 18:19:36.514: Se0/0/1 CDPCP: Received AAA AUTHOR Response PASS

R3#

*Aug 23 18:19:37.510: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/1, changed state to up

R3#

*Aug 23 18:19:46.570: %OSPF-5-ADJCHG: Process 1, Nbr 209.165.200.225 on Serial0/0/1 from LOADING to FULL, Loading Done

R3#

Copyright sur l’intégralité du contenu © 1992 2007 Cisco Systems, Inc. Tous droits réservés. Ce document contient des informations publiques Cisco.

Page 15 sur 20

CCNA Exploration Accès au réseau étendu : protocole PPP

Travaux pratiques 2.5.1 : configuration de base du protocole PPP

Tâche 9 : interruption délibérée et restauration de l’authentification PPP via le protocole CHAP

Étape 1 : interruption de l’authentification PPP à l’aide du protocole CHAP

Sur la liaison série reliant R2 et R3, activez le protocole dauthentification PAP pour linterface série 0/0/1.

R2#conf t Enter configuration commands, one per line. End with CNTL/Z. R2(config)#int s0/0/1 R2(config-if)#ppp authentication pap

R2(config-if)#^Z

R2#

*Aug 24 15:45:47.039: %SYS-5-CONFIG_I: Configured from console by console R2#copy run start Destination filename [startup-config]? Building configuration [OK]

R2#reload

Lactivation du protocole dauthentification PAP sur linterface série 0/0/1 provoque-t-elle une interruption de lauthentification entre R2 et R3 ?

Étape 2 : restauration de l’authentification PPP avec le protocole CHAP sur la liaison série

Notez qu’il n’est pas nécessaire de recharger le routeur pour que ces modifications soient prises en compte.

R2#conf t Enter configuration commands, one per line. End with CNTL/Z. R2(config)#int s0/0/1 R2(config-if)#ppp authentication chap

R2(config-if)#

*Aug 24 15:50:00.419: %LINEPROTO-5-UPDOWN:

Line protocol on Interface

Serial0/0/1, changed state to up

R2(config-if)#

*Aug 24 15:50:07.467:

%OSPF-5-ADJCHG: Process 1, Nbr 192.168.30.1 on

Serial0/0/1 from LOADING to FULL

, Loading Done

R2(config-if)#

Étape 3 : interruption volontaire de l’authentification PPP avec le protocole CHAP par le changement du mot de passe de R3

R3#conf t Enter configuration commands, one per line. End with CNTL/Z.

R3(config)#username R2 password

R3(config)#^Z

R3#

*Aug 24 15:54:17.215: %SYS-5-CONFIG_I: Configured from console by console

cisco
cisco

Copyright sur l’intégralité du contenu © 1992 2007 Cisco Systems, Inc. Tous droits réservés. Ce document contient des informations publiques Cisco.

Page 16 sur 20

CCNA Exploration Accès au réseau étendu : protocole PPP

Travaux pratiques 2.5.1 : configuration de base du protocole PPP

R3#copy run start Destination filename [startup-config]? Building configuration [OK]

R3#reload

Une fois le rechargement terminé, quel est létat du protocole de ligne sur linterface série 0/0/1 ?

Étape 4 : restauration de l’authentification PPP avec le protocole CHAP par le changement du mot de passe de R3

R3#conf t Enter configuration commands, one per line. End with CNTL/Z.

R3(config)#username R2 password

R3(config)#

*Aug 24 16:11:10.679: %LINEPROTO-5-UPDOWN: Line protocol on Interface

Serial0/0/1, changed state to

R3(config)#

*Aug 24 16:11:19.739: %OSPF-5-ADJCHG: Process 1, Nbr 209.165.200.225 on

Serial0/0/1 from LOADING to

R3(config)#

cisco
cisco
up
up

, Loading Doneon Serial0/0/1 from LOADING to R3(config)# cisco up Tâche 10 : documentation des configurations des routeurs

Tâche 10 : documentation des configurations des routeurs

Exécutez la commande show run sur chaque routeur et capturez les configurations.

R1#show run

!<résultat omis>

!

hostname R1

!

!

enable secret class

!

!

!

no ip domain lookup

!

username R1 password 0 cisco

!

!

!

interface FastEthernet0/1 ip address 192.168.10.1 255.255.255.0 no shutdown

!

!

interface Serial0/0/0 ip address 10.1.1.1 255.255.255.252 encapsulation ppp

clockrate 64000

Copyright sur l’intégralité du contenu © 1992 2007 Cisco Systems, Inc. Tous droits réservés. Ce document contient des informations publiques Cisco.

Page 17 sur 20

CCNA Exploration Accès au réseau étendu : protocole PPP

Travaux pratiques 2.5.1 : configuration de base du protocole PPP

ppp authentication pap ppp pap sent-username R2 password 0 cisco no shutdown

!

!

!

router ospf 1 network 10.1.1.0 0.0.0.3 area 0 network 192.168.10.0 0.0.0.255 area 0

!

!

banner motd ^CCUnauthorized access strictly prohibited and prosecuted to the

full extent of the law^C

!

line con 0 exec-timeout 0 0 password cisco logging synchronous login line aux 0 line vty 0 4 password cisco login

!

end

R2#show run

!<résultat omis>

!

hostname R2

!

!

enable secret class

!

!

no ip domain lookup

!

username R3 password 0 cisco username R2 password 0 cisco

!

!

!

interface Loopback0 ip address 209.165.200.225 255.255.255.224

!

!

!

interface Serial0/0/0 ip address 10.1.1.2 255.255.255.252 encapsulation ppp ppp authentication pap ppp pap sent-username R1 password 0 cisco no shutdown

!

Copyright sur l’intégralité du contenu © 1992 2007 Cisco Systems, Inc. Tous droits réservés. Ce document contient des informations publiques Cisco.

Page 18 sur 20

CCNA Exploration Accès au réseau étendu : protocole PPP

Travaux pratiques 2.5.1 : configuration de base du protocole PPP

interface Serial0/0/1 ip address 10.2.2.1 255.255.255.252 encapsulation ppp clockrate 64000 ppp authentication chap no shutdown

!

!

router ospf 1 network 10.1.1.0 0.0.0.3 area 0 network 10.2.2.0 0.0.0.3 area 0 network 209.165.200.224 0.0.0.31 area 0

!

!

banner motd ^CUnauthorized access strictly prohibited and prosecuted to the full extent of the law^C

!

line con 0 exec-timeout 0 0 password cisco logging synchronous login line aux 0 line vty 0 4 password cisco login

!

end

R3#show run

!<résultat omis>

!

hostname R3

!

!

enable secret class

!

!

!

no ip domain lookup

!

username R2 password 0 cisco

!

!

!

interface FastEthernet0/1 ip address 192.168.30.1 255.255.255.0 no shutdown

!

!

interface Serial0/0/1 ip address 10.2.2.2 255.255.255.252 encapsulation ppp ppp authentication chap

no shutdown

Copyright sur l’intégralité du contenu © 1992 2007 Cisco Systems, Inc. Tous droits réservés. Ce document contient des informations publiques Cisco.

Page 19 sur 20

CCNA Exploration Accès au réseau étendu : protocole PPP

Travaux pratiques 2.5.1 : configuration de base du protocole PPP

!

router ospf 1 network 10.2.2.0 0.0.0.3 area 0 network 192.168.30.0 0.0.0.255 area 0

!

!

banner motd ^CUnauthorized access strictly prohibited and prosecuted to the

full extent of the law^C

!

line con 0 exec-timeout 0 0 password cisco logging synchronous login line aux 0 line vty 0 4 password cisco login

!

end

Tâche 11 : remise en état

Supprimez les configurations et rechargez les routeurs. Déconnectez le câblage et stockez-le dans un endroit sécurisé. Reconnectez le câblage souhaité et restaurez les paramètres TCP/IP pour les hôtes PC connectés habituellement aux autres réseaux (réseau local de votre site ou Internet).

Copyright sur l’intégralité du contenu © 1992 2007 Cisco Systems, Inc. Tous droits réservés. Ce document contient des informations publiques Cisco.

Page 20 sur 20

Travaux pratiques 2.5.2 : configuration avancée du protocole PPP Diagramme de topologie Table d’adressage

Travaux pratiques 2.5.2 : configuration avancée du protocole PPP

Diagramme de topologie

avancée du protocole PPP Diagramme de topologie Table d’adressage Périphérique Interface Adresse

Table d’adressage

Périphérique

Interface

Adresse IP

Masque de

Passerelle

sous-réseau

par défaut

 

Fa0/1

10.0.0.1

255.255.255.128

N/D

R1

S0/0/0

172.16.0.1

255.255.255.252

N/D

S0/0/1

172.16.0.9

255.255.255.252

N/D

 

Lo0

209.165.200.161

255.255.255.224

N/D

R2

S0/0/0

172.16.0.2

255.255.255.252

N/D

S0/0/1

172.16.0.5

255.255.255.252

N/D

Copyright sur l’intégralité du contenu © 1992 2007 Cisco Systems, Inc. Tous droits réservés. Ce document contient des informations publiques Cisco.

Page 1 sur 4

CCNA Exploration Accès au réseau étendu : protocole PPP

Travaux pratiques 2.5.2 : configuration avancée du protocole PPP

 

Fa0/1

10.0.0.129

255.255.255.128

N/D

R3

S0/0/0

172.16.0.10

255.255.255.252

N/D

S0/0/1

172.16.0.6

255.255.255.252

N/D

PC1

Carte réseau

10.0.0.10

255.255.255.128

10.0.0.1

PC3

Carte réseau

10.0.0.139

255.255.255.128

10.0.0.129

Objectifs pédagogiques

À l’issue de ces travaux pratiques, vous serez en mesure d’effectuer les tâches suivantes :

Câbler un réseau conformément au diagramme de topologie

Supprimer la configuration de démarrage et recharger un routeur pour revenir aux paramètres par défaut

Exécuter les tâches de configuration de base d’un routeur

Configurer et activer des interfaces

Configurer le routage OSPF sur tous les routeurs

Configurer l’encapsulation PPP sur toutes les interfaces série

Faire passer l’encapsulation des interfaces série de PPP à HDLC

Interrompre volontairement une encapsulation PPP et la restaurer

Configurer l’authentification PPP à l’aide du protocole CHAP

Interrompre volontairement et restaurer l’authentification PPP via le protocole CHAP.

Scénario

Dans le cadre de ces travaux pratiques, vous apprendrez à configurer l’encapsulation PPP sur les liaisons série en utilisant le réseau illustré dans le diagramme de topologie. Vous configurerez également lauthentification PPP CHAP. Si vous rencontrez des difficultés, reportez-vous aux travaux pratiques Configuration PPP de base. Essayez cependant de travailler de façon autonome, sans y avoir recours.

Tâche 1 : préparation du réseau

Étape 1 : câblage d’un réseau similaire à celui du diagramme de topologie

Étape 2 : suppression des configurations existantes sur les routeurs

Tâche 2 : configuration de base d’un routeur

Configurez les routeurs R1, R2 et R3 conformément aux instructions suivantes :

Configurez le nom d’hôte du routeur.

Désactivez la recherche DNS.

Configurez un mot de passe pour le mode d’exécution privilégié.

Configurez une bannière de message du jour.

Configurez un mot de passe pour les connexions de consoles.

Configurez la connexion synchrone.

Configurez un mot de passe pour les connexions de terminaux virtuels (vty).

Copyright sur l’intégralité du contenu © 1992 2007 Cisco Systems, Inc. Tous droits réservés. Ce document contient des informations publiques Cisco.

Page 2 sur 4

CCNA Exploration Accès au réseau étendu : protocole PPP

Travaux pratiques 2.5.2 : configuration avancée du protocole PPP

Tâche 3 : configuration et activation dadresses série et Ethernet

Étape 1 : configuration des interfaces sur R1, R2 et R3

Étape 2 : vérification de l’adressage IP et des interfaces

Étape 3 : configuration des interfaces Ethernet de PC1 et PC3

Étape 4 : test de la connectivité entre les ordinateurs

Tâche 4 : configuration du protocole OSPF sur les routeurs

Étape 1 : activation du routage OSPF sur les routeurs

Étape 2 : vérification de la connectivité sur l’ensemble du réseau

Tâche 5 : configuration de l’encapsulation PPP sur les interfaces série

Étape 1 : configuration du protocole PPP sur les interfaces série des trois routeurs

Étape 2 : vérification que toutes les interfaces série utilisent l’encapsulation PPP

Tâche 6 : interruption et restauration volontaire de l’encapsulation PPP

Étape 1 : choix d’une méthode d’interruption de l’encapsulation PPP sur le réseau

Étape 2 : restauration d’une connectivité complète sur le réseau

Étape 3 : vérification de la connectivité complète sur le réseau

Tâche 7 : configuration de l’authentification PPP via le processus CHAP

Étape 1 : configuration de l’authentification PPP, via le processus CHAP, sur toutes les liaisons série

Étape 2 : vérification de l’authentification PPP, via le protocole CHAP, sur toutes les liaisons série

Tâche 8 : interruption délibérée et restauration de l’authentification PPP via le protocole CHAP

Étape 1 : choix d’une méthode d’interruption de l’authentification PPP, via le protocole CHAP, sur une ou plusieurs liaisons série

Étape 2 : vérification de la rupture de l’authentification PPP avec le protocole CHAP

Étape 3 : restauration de l’authentification PPP, via le protocole CHAP, sur toutes les liaisons série

Étape 4 : vérification de l’authentification PPP, via le protocole CHAP, sur toutes les liaisons série

Copyright sur l’intégralité du contenu © 1992 2007 Cisco Systems, Inc. Tous droits réservés. Ce document contient des informations publiques Cisco.

Page 3 sur 4

CCNA Exploration Accès au réseau étendu : protocole PPP

Travaux pratiques 2.5.2 : configuration avancée du protocole PPP

Tâche 9 : documentation des configurations des routeurs

Tâche 10 : remise en état

Supprimez les configurations et rechargez les routeurs. Déconnectez le câblage et stockez-le dans un endroit sécurisé. Reconnectez le câblage souhaité et restaurez les paramètres TCP/IP pour les hôtes PC connectés habituellement aux autres réseaux (réseau local de votre site ou Internet).

Copyright sur l’intégralité du contenu © 1992 2007 Cisco Systems, Inc. Tous droits réservés. Ce document contient des informations publiques Cisco.

Page 4 sur 4

Travaux pratiques 2.5.3 : dépannage de la configuration PPP Diagramme de topologie Table d’adressage Périphérique
Travaux pratiques 2.5.3 : dépannage de la configuration PPP Diagramme de topologie Table d’adressage Périphérique

Travaux pratiques 2.5.3 : dépannage de la configuration PPP

Diagramme de topologie

: dépannage de la configuration PPP Diagramme de topologie Table d’adressage Périphérique Interface Adresse

Table d’adressage

Périphérique

Interface

Adresse IP

Masque de

Passerelle par défaut

sous-réseau

 

Fa0/1

10.0.0.1

255.255.255.128

N/D

R1

S0/0/0

172.16.0.1

255.255.255.252

N/D

S0/0/1

172.16.0.9

255.255.255.252

N/D

 

Lo0

209.165.200.161

255.255.255.224

N/D

R2

S0/0/0

172.16.0.2

255.255.255.252

N/D

S0/0/1

172.16.0.5

255.255.255.252

N/D

Copyright sur l’intégralité du contenu © 1992 2007 Cisco Systems, Inc. Tous droits réservés. Ce document contient des informations publiques Cisco.

Page 1 sur 6

CCNA Exploration Accès au réseau étendu : protocole PPP

Travaux pratiques 2.5.3 : dépannage de la configuration de PPP

 

Fa0/1

10.0.0.129

255.255.255.128

N/D

R3

S0/0/0

172.16.0.10

255.255.255.252

N/D

S0/0/1

172.16.0.6

255.255.255.252

N/D

PC1

Carte réseau

10.0.0.10

255.255.255.128

10.0.0.1

PC3

Carte réseau

10.0.0.139

255.255.255.128

10.0.0.129

Objectifs pédagogiques

À l’issue de ces travaux pratiques, vous serez en mesure d’effectuer les tâches suivantes :

Câbler un réseau conformément au diagramme de topologie

Supprimer la configuration de démarrage et recharger un routeur pour revenir aux paramètres par défaut

Charger les routeurs avec les scripts fournis

Détecter et corriger des erreurs réseau

Documenter le réseau corrigé

Scénario

Les routeurs de votre société ont été configurés par un ingénieur réseau peu expérimenté. La présence de plusieurs erreurs dans la configuration a provoqué des problèmes de connectivité. Votre responsable vous demande de détecter les erreurs de configuration et de les corriger, puis de décrire le travail réalisé. En utilisant vos connaissances en matière de protocole PPP, ainsi que des méthodes de vérification standard, détectez les erreurs et corrigez-les. Veillez à ce que toutes les liaisons série utilisent l’authentification PPP CHAP et vérifiez que tous les réseaux sont accessibles.

Tâche 1 : chargement des routeurs avec les scripts fournis

R1

enable configure terminal

!

hostname R1

!

!

enable secret class

!

!

!

no ip domain lookup

!

username R2 password 0 cisco

!

!

!

interface FastEthernet0/0 ip address 10.0.0.1 255.255.255.128

shutdown

Copyright sur l’intégralité du contenu © 1992 2007 Cisco Systems, Inc. Tous droits réservés. Ce document contient des informations publiques Cisco.

Page 2 sur 6

CCNA Exploration Accès au réseau étendu : protocole PPP

Travaux pratiques 2.5.3 : dépannage de la configuration de PPP

duplex auto

speed auto

!

interface FastEthernet0/1

duplex auto

speed auto

!

interface Serial0/0/0 ip address 172.16.0.1 255.255.255.248 no fair-queue clockrate 64000

!

interface Serial0/0/1 ip address 172.16.0.2 255.255.255.252 encapsulation ppp ppp authentication pap

!

router ospf 1 log-adjacency-changes network 10.0.0.0 0.0.0.127 area 0

network 172.16.0.8 0.0.0.3 area 0

!

ip classless

!

ip http server

!

!

control-plane

!

banner motd ^CUnauthorized access strictly prohibited and prosecuted to the

full extent of the law^C

!

line con 0 exec-timeout 0 0 password cisco logging synchronous login

line aux 0 line vty 0 4 password cisco login

!

end

R2

enable

configure terminal

!

hostname R2

!

!

enable secret class

!

!

no ip domain lookup

Copyright sur l’intégralité du contenu © 1992 2007 Cisco Systems, Inc. Tous droits réservés. Ce document contient des informations publiques Cisco.

Page 3 sur 6

CCNA Exploration Accès au réseau étendu : protocole PPP

Travaux pratiques 2.5.3 : dépannage de la configuration de PPP

!

username R1 password 0 cisco

username R3 password 0 class

!

!

!

interface Loopback0

!

interface FastEthernet0/0 no ip address shutdown duplex auto speed auto

!

interface FastEthernet0/1 ip address 209.165.200.161 255.255.255.224 shutdown duplex auto speed auto

!

interface Serial0/0/0 ip address 172.16.0.2 255.255.255.252 encapsulation ppp no fair-queue ppp authentication chap

!

interface Serial0/0/1 ip address 172.16.0.2 255.255.255.252

!

router ospf 1 log-adjacency-changes network 172.16.0.0 0.0.0.3 area 0 network 172.16.0.4 0.0.0.3 area 0 network 209.165.200.128 0.0.0.31 area 0

!

ip classless

!

ip http server

!

!

control-plane

!

banner motd ^CUnauthorized access strictly prohibited and prosecuted to the

full extent of the law^C

!

line con 0 exec-timeout 0 0 password cisco logging synchronous login line aux 0 line vty 0 4 password cisco login

!

end

Copyright sur l’intégralité du contenu © 1992 2007 Cisco Systems, Inc. Tous droits réservés. Ce document contient des informations publiques Cisco.

Page 4 sur 6

CCNA Exploration Accès au réseau étendu : protocole PPP

Travaux pratiques 2.5.3 : dépannage de la configuration de PPP

R3

enable

configure terminal

!

hostname R3

!

!

enable secret class

!

!

no ip domain lookup

!

username R1 password 0 cisco username R3 password 0 cisco

!

!

interface FastEthernet0/0 no ip address shutdown duplex auto speed auto

!

interface FastEthernet0/1 ip address 10.0.0.129 255.255.255.0 duplex auto speed auto

!

interface Serial0/0/0 ip address 172.16.0.10 255.255.255.252 no fair-queue clockrate 64000

!

interface Serial0/0/1 encapsulation ppp ppp authentication pap

!

router ospf 1 log-adjacency-changes network 10.0.0.128 0.0.0.127 area 0 network 192.16.0.4 0.0.0.3 area 0 network 192.16.0.8 0.0.0.3 area 0

!

ip classless

!

ip http server

!

!

control-plane

!

banner motd ^CUnauthorized access strictly prohibited and prosecuted to the

full extent of the law^C

!

line con 0 exec-timeout 0 0

Copyright sur l’intégralité du contenu © 1992 2007 Cisco Systems, Inc. Tous droits réservés. Ce document contient des informations publiques Cisco.

Page 5 sur 6

CCNA Exploration Accès au réseau étendu : protocole PPP

Travaux pratiques 2.5.3 : dépannage de la configuration de PPP

password cisco logging synchronous login line aux 0 line vty 0 4 password cisco login

!

end

Tâche 2 : recherche et correction des erreurs sur le réseau

Tâche 3 : documentation du réseau corrigé

Une fois que vous avez corrigé toutes les erreurs et testé la connectivité du réseau, documentez la configuration finale de chaque périphérique.

Tâche 4 : remise en état

Supprimez les configurations et rechargez les routeurs. Déconnectez le câblage et stockez-le dans un endroit sécurisé. Reconnectez le câblage souhaité et restaurez les paramètres TCP/IP pour les hôtes PC connectés habituellement aux autres réseaux (réseau local de votre site ou Internet).

Copyright sur l’intégralité du contenu © 1992 2007 Cisco Systems, Inc. Tous droits réservés. Ce document contient des informations publiques Cisco.

Page 6 sur 6

Travaux pratiques 3.5.1 : Frame Relay de base

Diagramme de topologie

pratiques 3.5.1 : Frame Relay de base Diagramme de topologie Table d’adressage Périphérique Interface Adresse
pratiques 3.5.1 : Frame Relay de base Diagramme de topologie Table d’adressage Périphérique Interface Adresse

Table d’adressage

Périphérique

Interface

Adresse IP

Masque de

Passerelle

sous-réseau

par défaut

 

Fa0/0

192.168.10.1

255.255.255.0

N/D

R1

S0/0/1

 

10.1.1.1 255.255.255.252

N/D

 

S0/0/1

 

10.1.1.2 255.255.255.252

N/D

R2

Lo 0

209.165.200.225

255.255.255.224

N/D

Comm1

VLAN1

192.168.10.2

255.255.255.0

192.168.10.1

PC1

Carte réseau

192.168.10.10

255.255.255.0

192.168.10.1

Exploration 4 Accès au réseau étendu : Frame Relay

Travaux pratiques 3.5.1 : protocole Frame Relay de base

Objectifs pédagogiques

À l’issue de ces travaux pratiques, vous serez en mesure d’effectuer les tâches suivantes :

Câbler un réseau conformément au diagramme de topologie

Supprimer la configuration de démarrage et recharger un routeur pour revenir aux paramètres par défaut

Exécuter les tâches de configuration de base d’un routeur

Configurer et activer des interfaces

Configurer le routage EIGRP sur tous les routeurs

Configurer l’encapsulation Frame Relay sur toutes les interfaces série

Configurer un routeur en tant que commutateur Frame Relay

Comprendre le résultat des commandes show frame-relay

Connaître les effets de la commande debug frame-relay lmi

Interrompre volontairement une liaison Frame Relay et la restaurer

Remplacer l’encapsulation Frame Relay par défaut Cisco par une encapsulation de type IETF

Remplacer l’interface de supervision locale (LMI) Frame Relay Cisco par une interface ANSI

Configurer une sous-interface Frame Relay

Scénario

Dans le cadre de ces travaux pratiques, vous apprendrez à configurer l’encapsulation Frame Relay sur les liaisons série en utilisant le réseau illustré dans le diagramme de topologie. Vous apprendrez également à configurer un routeur en tant que commutateur Frame Relay. Des normes Cisco et des normes ouvertes s’appliquent à Frame Relay. Nous allons passer en revue ces deux types de norme. Portez une attention particulière à la section des travaux pratiques dans laquelle vous interrompez volontairement les configurations du protocole Frame Relay. Cela vous aidera dans les travaux pratiques de dépannage associés à ce chapitre.

Tâche 1 : préparation du réseau

Étape 1 : câblage d’un réseau similaire à celui du diagramme de topologie Vous pouvez utiliser n’importe quel routeur durant les travaux pratiques, à condition qu'il soit équipé des interfaces indiquées dans la topologie. Les travaux pratiques relatifs au protocole Frame Relay comportent deux liens DCE sur le même routeur, à la différence des autres travaux pratiques d’Exploration 4. Assurez-vous que votre câblage soit conforme au diagramme de topologie.

Remarque : si vous utilisez les routeurs 1700, 2500 ou 2600, les sorties des routeurs et les descriptions des interfaces s’affichent différemment.

Étape 2 : suppression des configurations existantes sur les routeurs

Tâche 2 : configuration de base d’un routeur

Configurez les routeurs R1 et R2, ainsi que le commutateur Comm1, conformément aux instructions suivantes :

Configurez le nom d’hôte du routeur.

Désactivez la recherche DNS.

Configurez un mot de passe pour le mode d’exécution privilégié.

Configurez une bannière de message du jour.

Exploration 4 Accès au réseau étendu : Frame Relay

Travaux pratiques 3.5.1 : protocole Frame Relay de base

Configurez un mot de passe pour les connexions de consoles.

Configurez un mot de passe pour les connexions de terminaux virtuels (vty).

Configurez des adresses IP sur les routeurs R1 et R2.

Important : laissez les interfaces séries désactivées.

Activez le système autonome (AS) 1 du protocole EIGRP sur les routeurs R1 et R2 pour tous les réseaux.

enable configure terminal

no ip domain-lookup enable secret class banner motd ^CUnauthorized access strictly prohibited, violators will be prosecuted to the full extent of the law^C

!

!

!

line console 0 logging synchronous password cisco login

!

line vty 0 4 password cisco login end copy running-config startup-config

!R1

interface serial 0/0/1 ip address 10.1.1.1 255.255.255.252 shutdown

!Les interfaces série s doivent rester désactivées jusqu’à ce que le

!Les interfaces séries doivent rester désactivées jusqu’à ce que le

!commutateur Frame Relay soit configuré.

!Les interfaces série s doivent rester désactivées jusqu’à ce que le !commutateur Frame Relay soit configuré.

interface fastethernet 0/0 ip address 192.168.10.1 255.255.255.0 no shutdown router eigrp 1 no auto-summary network 10.0.0.0 network 192.168.10.0

!

!R2

interface serial 0/0/1 ip address 10.1.1.2 255.255.255.252 shutdown

!Les interfaces séries doivent rester désactivées jusqu’à ce que le

!Les interfaces séries doivent rester désactivées jusqu’à ce que le

!commutateur Frame Relay soit configuré.

!Les interfaces séries doivent rester désactivées jusqu’à ce que le !commutateur Frame Relay soit configuré.

Exploration 4 Accès au réseau étendu : Frame Relay

Travaux pratiques 3.5.1 : protocole Frame Relay de base

interface loopback 0 ip address 209.165.200.225 255.255.255.224 router eigrp 1 no auto-summary network 10.0.0.0 network 209.165.200.0

!

Tâche 3 : configuration du protocole Frame Relay

Vous allez à présent configurer une liaison de base Frame Relay point à point entre les routeurs 1 et 2. Vous devez tout d’abord configurer le commutateur FR en tant que commutateur Frame Relay, puis créer des identificateurs de connexion de liaisons de données (DLCI).

Que signifie DLCI ?

Quelle est la fonction d’un DLCI ?

Qu’est-ce qu’un PVC et comment est-il utilisé ?

Étape 1 : configuration d’un commutateur FR en tant que commutateur Frame Relay et création d’un PVC entre les routeurs R1 et R2

Cette commande permet d’activer globalement la commutation Frame Relay sur le routeur, lui permettant de transférer des trames sur la base du DLCI entrant plutôt que sur une adresse IP :

Commutateur-FR(config)#frame-relay switching

Remplacez le type d’encapsulation de l’interface par le type Frame Relay. Tout comme HDLC ou PPP, le protocole Frame Relay est un protocole de couche liaison de données qui définit le tramage du trafic de la couche 2.

Commutateur-FR(config)#interface serial 0/0/0 Commutateur-FR(config)#clock rate 64000

Commutateur-FR(config-if)#encapsulation frame-relay

La modification du type d’interface en DCE indique au routeur d’envoyer des messages de veille à l’interface de supervision locale et permet à Frame Relay d’acheminer des instructions à appliquer. Il n’est pas possible de configurer des PVC entre deux interfaces DTE Frame Relay à l’aide de la commande frame-relay route.

Commutateur-FR(config-if)#frame-relay intf-type dce

Exploration 4 Accès au réseau étendu : Frame Relay

Travaux pratiques 3.5.1 : protocole Frame Relay de base

Remarque : les types d’interface Frame Relay ne doivent pas forcément correspondre au type de l’interface physique sous-jacente. Une interface série ETTD physique peut faire office d’interface DCE Frame Relay et une interface DCE physique peut faire office d’interface ETTD Frame Relay.

Configurez le routeur pour qu’il transfère le trafic entrant sur l’interface série 0/0/0 avec DLCI 102 vers l’interface série 0/0/1 avec un DLCI de sortie défini sur 201.

Commutateur-FR(config-if)#frame-relay route 102 interface serial 0/0/1 201 Commutateur-FR(config-if)#no shutdown

La configuration suivante permet la création de deux PVC : la première, entre le routeur R1 et le routeur R2 (DLCI 102) et la seconde, entre le routeur R2 et le routeur R1 (DLCI 201). Vous pouvez vérifier la configuration à l’aide de la commande show frame-relay pvc.

Commutateur-FR(config-if)#interface serial 0/0/1 Commutateur-FR(config)#clock rate 64000 Commutateur-FR(config-if)#encapsulation frame-relay Commutateur-FR(config-if)#frame-relay intf-type dce Commutateur-FR(config-if)#frame-relay route 201 interface serial 0/0/0 102 Commutateur-FR(config-if)#no shutdown

Commutateur-FR#show frame-relay pvc

PVC Statistics for interface Serial0/0/0 (Frame Relay DCE)

Active

Inactive

Deleted

Static

Local

0

0

0

0

Switched

0

1
1

0

0

Unused

0

0

0

0

DLCI = 102

,

DLCI USAGE = SWITCHED, PVC STATUS = INACTIVE, INTERFACE =

Serial0/0/0

input pkts 0

out bytes 0 out pkts dropped 0 in FECN pkts 0 out BECN pkts 0 out bcast pkts 0

output pkts 0 dropped pkts 0 out bytes dropped 0 in BECN pkts 0 in DE pkts 0 out bcast bytes 0

in bytes 0 in pkts dropped 0

out FECN pkts 0 out DE pkts 0

30

second input rate 0 bits/sec, 0 packets/sec

30

second output rate 0 bits/sec, 0 packets/sec

switched pkts 0

Detailed packet drop counters:

no out intf 0 in PVC down 0 shaping Q full 0

pvc create time 00:03:33, last time pvc status changed 00:00:19

out intf down 0 out PVC down 0 pkt above DE 0

no out PVC 0 pkt too big 0 policing drop 0

PVC Statistics for interface Serial0/0/1 (Frame Relay DCE)

Active

Inactive

Deleted

Static

Local

0

0

0

0

Switched

0

1
1

0

0

Unused

0

0

0

0

DLCI = 201

Serial0/0/1

, DLCI USAGE = SWITCHED,

PVC STATUS = INACTIVE

, INTERFACE =

Exploration 4 Accès au réseau étendu : Frame Relay

Travaux pratiques 3.5.1 : protocole Frame Relay de base

input pkts 0 out bytes 0 out pkts dropped 0 in FECN pkts 0 out BECN pkts 0 out bcast pkts 0

output pkts 0 dropped pkts 0

in bytes 0 in pkts dropped 0

out bytes dropped 0

in BECN pkts 0 in DE pkts 0 out bcast bytes 0

out FECN pkts 0 out DE pkts 0

30

second input rate 0 bits/sec, 0 packets/sec

30

second output rate 0 bits/sec, 0 packets/sec

switched pkts 0 Detailed packet drop counters:

out intf down 0 out PVC down 0 pkt above DE 0

pvc create time 00:02:02, last time pvc status changed 00:00:18

no out intf 0 in PVC down 0 shaping Q full 0

no out PVC 0 pkt too big 0 policing drop 0

Remarquez le 1 dans la colonne Inactive. Aucun point d’extrémité n’a été configuré pour le PVC créé. Le commutateur Frame Relay le détecte et marque alors le PVC comme étant inactif.

Exécutez la commande show frame-relay route. Elle vous indique toutes les routes Frame Relay existantes, leurs interfaces, leurs DLCI et leurs états. Il s’agit de la route de couche 2, qu’emprunte le trafic du protocole Frame Relay via le réseau. Ne le confondez pas avec le routage IP de la couche 3.

Commutateur-FR#show frame-relay route

Input Intf

Input Dlci

Output Intf

Output Dlci

Status

Serial0/0/0

102

Serial0/0/1

201

inactive

Serial0/0/1

201

Serial0/0/0

102

inactive

Étape 2 : configuration du routeur R1 pour Frame Relay

Le protocole de résolution d’adresse inverse (ARP inverse) permet aux extrémités distantes d’une liaison Frame Relay de se découvrir de manière dynamique et offre une méthode dynamique de mappage d’adresses IP avec des DLCI. Malgré l’utilité du protocole ARP inverse, il n'est pas toujours fiable. La meilleure pratique consiste à mapper les adresses IP avec les DLCI, de manière statique, puis de désactiver l’ARP inverse.

R1(config)#interface serial 0/0/1 R1(config-if)#encapsulation frame-relay R1(config-if)#no frame-relay inverse-arp

À quoi sert de mapper une adresse IP avec un DCLI ?

La commande frame-relay map mappe de manière statique une adresse IP vers un DLCI. Outre le mappage de l’adresse IP vers un DLCI, le logiciel Cisco IOS permet le mappage de plusieurs adresses de protocole de couche 3. Le mot clé broadcast de la commande ci-après envoie le trafic multidiffusion ou de diffusion destiné à cette liaison sur le DLCI. La plupart des protocoles de routage nécessitent le mot clé broadcast pour fonctionner correctement sur Frame Relay. Vous pouvez utiliser le mot clé broadcast pour plusieurs DLCI sur la même interface. Le trafic est alors répliqué sur l’ensemble des PVC.

Exploration 4 Accès au réseau étendu : Frame Relay

Travaux pratiques 3.5.1 : protocole Frame Relay de base

R1(config-if)#frame-relay map ip 10.1.1.2 102 broadcast

Le DLCI est-il mappé avec l’adresse IP locale ou avec celle de l’autre extrémité du PVC ?

R1(config-if)#no shutdown

Pourquoi la commande no shutdown doit-elle être utilisée après la commande no frame-relay inverse-arp ?

Étape 3 : configuration du routeur R2 pour Frame Relay

R2(config)#interface serial 0/0/1 R2(config-if)#encapsulation frame-relay R2(config-if)#no frame-relay inverse-arp R2(config-if)#frame-relay map ip 10.1.1.1 201 broadcast R2(config-if)#no shutdown

À ce stade, vous recevez des messages indiquant l’activation des interfaces et l’établissement de la contiguïté du voisinage du protocole EIGRP.

R1#*Sep 9 17:05:08.771: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 10.1.1.2 (Serial0/0/1) is up: new adjacency

R2#*Sep 9 17:05:47.691: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 10.1.1.1 (Serial0/0/1) is up: new adjacency

La commande show ip route affiche des tables de routage complètes.

R1 :

R1#show ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2

i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS

level-2

 

ia - IS-IS inter area, * - candidate default, U - per-user

static

route

o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

Exploration 4 Accès au réseau étendu : Frame Relay

Travaux pratiques 3.5.1 : protocole Frame Relay de base

C

192.168.10.0/24 is directly connected, FastEthernet0/0

D

209.165.200.0/24 [90/20640000] via 10.1.1.2, 00:00:07, Serial0/0/1 10.0.0.0/30 is subnetted, 1 subnets

C

10.1.1.0 is directly connected, Serial0/0/1

R2 :

 

R2#show

ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2 E1 - OSPF external type 1, E2 - OSPF external type 2

i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

ia - IS-IS inter area, * - candidate default, U - per-user static route

o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

D

192.168.10.0/24 [90/20514560] via 10.1.1.1, 00:26:03, Serial0/0/1 209.165.200.0/27 is subnetted, 1 subnets

C

209.165.200.224 is directly connected, Loopback0 10.0.0.0/30 is subnetted, 1 subnets

C

10.1.1.0 is directly connected, Serial0/0/1

Tâche 4 : vérification de la configuration

À présent, vous devez être en mesure d’envoyer une requête ping de R1 vers R2 Il est possible que les PVC ne soient activés que quelques secondes après le démarrage des interfaces. Vous pouvez également voir les routages EIGRP de chaque routeur.

Étape 1 : transmission d’une requête ping à R1 et R2

Vérifiez que vous pouvez envoyer une requête ping à R2, à partir de R1.

R1#ping 10.1.1.2

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.1.1.2, timeout is 2 seconds: