Vous êtes sur la page 1sur 24

Introduction

ANSYS est un code lments finis dusage gnral ddi la rsolution numrique dune large varit de problmes physique en gnral et de mcanique en particulier. Ces problmes portent notamment : analyse structurale en statique et en dynamique (linaire et non linaire), transfert de chaleur, dynamique des fluides, acoustique, lectromagntique. De faon gnrale, une rsolution par lments finis comporte trois tapes : 1. Prparation des donnes ou Pr-processing: dfinir le problme; les tapes majeurs sont donnes ci-dessous: o Dfinition des points cls (keypoints) /lignes/surfaces/volumes ; o Dfinir le type dlment fini, ses proprits gomtriques et les proprits physiques des matriaux ; o Maillage des lignes /surfaces/volume si cela est requis. Les donnes ncessaires dpendent videmment de la de la dimension du problme. (i.e. 1D, 2D, axisymtrique, 3D).

2. Traitement ou Processing: assigner les charges, contraintes (conditions aux limites) et rsolution; on spcifie notamment la nature des charges (localises et/ou distribues), contraintes ou conditions aux limites (translation et rotation ) et, finalement, on rsout le systme dquations.

3. Post-processing: analyse et visualisation des rsultats; lors de cette tape, on peut examiner: o La liste des dplacements nodaux ; o Les forces et des moments au niveau des lments; o Trac des Dformes o Trac des Iso contours des contraintes

Treillis Bidimensionnel
Introduction
Cet exemple a t trait avec ANSYS 7.0.

Description du Problme
Dterminer les dflections aux nuds, les forces de raction, et les contraintes pour le systme de treillis ci-dessous (Module de Young E = 200GPa, Section A = 3250mm2).

(Modifie de Chandrupatla & Belegunda, Introduction to Finite Elements in Engineering, p.123)

Pre-Processing : Dfinir le Problme


1. Donner un Titre au Problme (par exemple 'Treillis 2D'). Dans la barre Utility menu slectionner File > Change Title:

La fentre suivante apparatra:

Entrer le titre et cliquer 'OK'. Ce titre apparatra en bas gauche de lcran graphique une fois que vous avez commenc. Pour faire apparatre ce titre immdiatement, slectionner Utility Menu > Plot > Replot

2. Gnration des points-cls ou Keypoints La gomtrie du problme trait est dfinie en utilisant des points-cls ou keypoints en anglais. Pour cet exemple, ces points concident avec les extrmits de chaque barre. Nous allons dfinir 7 points-cls, modlisant la structure simplifie, dont les coordonnes en mm sont indiques dans la table suivante. Coordonnes X 1 2 3 4 5 6 7
o o

Point-cl

Y 0 3118 0 3118 0 3118 0

0 1800 3600 5400 7200 9000 10800

(Les points-cls sont indiqus sur la figure ci-dessus) Dans le menu principal d 'ANSYS' selectionner: Preprocessor > Modeling > Create > Keypoints > In Active CS

La fentre suivante apparatra :

Pour dfinir le premier point-cl dont les coordonnes sont x = 0 et y = 0: Entrer keypoint number 1 dans la case approprie, et saisissez les coordonnes x,y: 0, 0 dans les cases appropries (comme indiqu ci-dessus). Cliquer 'Apply' pour valider ce que vous venez de saisir o Entrer les pointscls restants de la mme manire.
o

Note: Lorsque vous saisissez le dernier point, cliquer sur 'OK' pour indiquer que vous avez termin la saisie des points cls. Si vous pressez sur 'Apply' ensuite sur 'OK' pour le dernier point, vous laurez dfini deux fois !. Si vous avez press sur 'Apply' pour le dernier point, presser simplement sur 'Cancel' pour fermer la boite de dialogue. Units Notez que les units de mesure (ie mm) nont pas t spcifies. Cest la responsabilit de lutilisateur dutiliser un systme consistant dunits de mesure pour le problme trait; il est donc ncessaire deffectuer les conversions qui simposent. Correction des Erreurs

Quand on dfinit les points-cls, lignes, surfaces, volumes, lments, contraintes, on peut commettre des erreurs. Heureusement, on peut y remdier facilement. En effet, chaque menu 'Create' pour la gnration de telles entits il y a galement un menu 'Delete' correspondant. 3. Gnration des lignes Les points-cls doivent tre maintenant connects. Nous allons utilise la souris pour slectionner les points-cls pour former les lignes.
o

Dans le menu principal slectionner: Preprocessor > Modeling > Create > Lines > Lines > In Active Coord. La fentre suivante apparatra :

Utiliser la souris pour slectionner le point-cl #1 (i.e. cliquer dessus). Dplacer la souris vers le point-cl #2. Sur lcran, une ligne, joignant ces deux points apparatra. o Connecter les points-cls restant en utilisant la mme procdure. o Quand vous avez termin, cliquer sur 'OK' dans la fentre 'Lines in Active Coord' , minimiser le menu 'Lines' et le menu 'Create'. La fentre Graphics dANSYS devrait ressembler la figure suivante.
o o

Si les lignes napparaissent pas Si les lignes napparaissent pas sur votre cran, allez dans Utility Menu et slectionner: Plot > Lines

4. Dfinir le type dlment Dsormais, il est ncessaire de crer les lments. Cette opration est communment dsigne par 'maillage'. On doit indiquer ANSYS quel type dlments nous allons utiliser :
o

A partir du menu Preprocessor, slectionner: Element Type > Add/Edit/Delete. La fentre suivante va apparatre:

Cliquer sur le bouton 'Add...' . La fentre suivante apparatra :

Pour cet exemple, nous allons utiliser llment 2D spar comme indiqu sur la figure ci-dessus. Slectionner llment indiqu et cliquer sur 'OK'. Vous devriez voir 'Type 1 LINK1' dans la fentre 'Element Types'. o Cliquer sur 'Close' dans la boite de dialogue 'Element Types'.
o

5. Dfinir les proprits gomtriques Maintenant, nous allons maintenant spcifier les proprits gomtriques pour nos lments:
o

Dans le menu Preprocessor, slectionner Real Constants > Add/Edit/Delete

Cliquer sur Add... et slectionner 'Type 1 LINK1' (dans ce cas, il est dj slectionner). Cliquer sur 'OK'. La fentre suivante apparatra:

Comme montr dans la fentre ci-dessus, entrer la surface de la section droite, (3250mm2): o Cliquer sur 'OK'. o Maintenant, 'Set 1' apparat dans la boite de dialogue. Cliquer sur 'Close' dans la fentre 'Real Constants'.
o o

6. Dfinir les proprits physiques de llment Dsormais, nous devons dfinir les spcificits matrielles de llment:
o

Dans le menu 'Preprocessor', slectionner Material Props > Material Models

Double cliquer sur Structural > Linear > Elastic > Isotropic

Nous allons imposer les proprits de lacier. Dans le champ devant EX, entrer la valeur suivante : 200000
o o

Cliquer sur 'OK'. Note: 'PRXY est suppos nul'. Le coefficient de Poisson nest pas ncessaire pour le type dlment choisi. Cliquer sur 'OK' pour continuer. Fermer "Define Material Model Behavior" en cliquant sur le 'X' dans le coin suprieur droit de la boite de dialogue.

7. Taille du maillage La dernire tape prcdant la phase de maillage est de spcifier Ansys la taille des lments. Il existe une varit de faons de le faire mais nous allons juste spcifier une seule.
o

Dans le menu Preprocessor, slectionner Meshing > Size Cntrls > ManualSize > Lines > All Lines

Dans le champ 'NDIV', entrer le nombre dsir de divisions par ligne. Pour cet exemple, nous allons imposer juste une division par ligne, ds lors saisissez '1' et cliquer 'OK'. Notez que nous navons pas encore mailler la gomtrie, nous avons simplement dfinit la taille des lments.

8. Maillage Maintenant, la structure en question peut tre maill. Dans le menu 'Preprocessor', slectionner Meshing > Mesh > Lines et cliquer 'Pick All' dans la fentre 'Mesh Lines'. Votre modle devrait apparatre comme suit :

Numrotation Pour faire apparatre la numrotation des lignes, des points-cls,


A partir du menu Utility Menu, slectionner PlotCtrls > Numbering... Fill in the Window as shown below and click 'OK'

Maintenant, vous pouvez activer ou dsactivez la numrotation votre guise. Sauvegarder votre travail Sauvegarder votre modle ce moment. A partir du menu Utility Menu, slectionner File > Save as.... Slectionner le nom et la directory o vous voulez sauvegarder votre fichier.

Etape de rsolution : Imposer les charges et rsoudre


Vous avez dfinit votre modle. Il est temps maintenant dimposer les charges et les contraintes et rsoudre le systme dquations rsultant. Ouvrez le menu 'Solution' ( partir du mme menu principal dAnsys 'ANSYS Main Menu'). 1. Dfinir le type danalyse Premirement, Indiquer ANSYS le type danalyse A partir du menu Solution, slectionner Analysis Type > New Analysis.

Slectionner 'Static'; Click 'OK'. 2. Imposer les contraintes


o o

Il est ncessaire dimposer des contraintes ou conditions aux limites au modle autrement le problme ne possderait pas une solution unique. En mcanique des structures, ces contraintes peuvent tre du type encastrement, appui fixe ou rotul, appui roulant, appui roulant avec rotation nulle. Comme montr ci-dessus, lextrmit gauche du treillis est un appui fixe alors lextrmit droite est un appui roulant.

Dans le menu Solution, slectionner Define Loads > Apply > Structural > Displacement > On Keypoints

Slectionner lextrmit gauche du treillis (point-cl 1) en cliquant dessus dans la fentre graphics de Windows et cliquer sur 'OK' dans la fentre 'Apply U,ROT on KPs'.

Cette extrmit est fixe ce qui veut dire que toutes les degrs de libert sont imposs. Donc, slectionner 'All DOF' en cliquant dessus et entrer '0' dans le champ Value et cliquer 'OK'. Vous allez voir deux triangles en bleue dans la fentre graphique de Windows indiquant que les dplacements ont t imposes.

En suivant le mme principe, imposer un appui roulant lextrmit droite (UY impos). Dslectionner, 'All DOF' et slectionner loption UY .

3. Imposer les charges Comme spcifi plus haut, il y a quatre chargements ponctuels de 280kN, 210kN, 280kN, et 360kN aux points-cls 1, 3, 5, et 7 respectivement. Slectionner Define Loads > Apply > Structural > Force/Moment > on Keypoints. o Slectionner le premier point-cl (extrmit gauche du treillis) et cliquer 'OK' dans la fentre 'Apply F/M on KPs'.
o

Slectionner FY in the 'Direction of force/mom'. Ceci indique que vous allez appliquer la charge dans la direction 'y'. o Entrer la valeur de -280000 dans la boite 'Force/moment value' et cliquer 'OK'. Notez que nous utilisons des newtons N comme unit ce qui est consistent avec les units utilises prcdemment. o Cette force apparatra comme une flche verticale rouge dirige vers le bas. o Appliquer les charges restantes de la mme manire.
o

Les charges appliques apparatront comme ci-dessous.

4. Rsolution du systme dquations Cherchons maintenant la solution. Dans le menu 'Solution' slectionner Solve > Current LS. Ceci indique que lon cherche une solution sous le pas de charge courant (Current load Step).

La fentre ci-dessous apparat, montrant que les options choisies sont ceux montres ci-dessus. Cliquer 'OK'. o Une fois la solution obtenue, la fentre suivante apparat. Cliquer sur 'Close' et fermer la fentre /STATUS Command.
o

Post-processing: Visualisation des rsultats


1. Calculs prliminaires Calculons les forces et les contraintes au niveau de llment 1 (comme indiqu dans la description du problme).

2. Rsultats en utilisant ANSYS Forces de Raction Une liste des forces de raction peut tre obtenue partir de cet lment
o

A partir du menu principal Main Menu, slectionner General Postproc > List Results > Reaction Solu.

Slectionner 'All struc forc F' comme montr ci-dessus et cliquer 'OK'

Ces valeurs concordant avec les forces de raction calcules. Dformation


o

Dans le menu General Postproc, slectionner Plot Results > Deformed Shape. La fentre suivante va apparatre.

Slectionner 'Def + undef edge' et cliquer sur 'OK' pour visualiser le treillis dans ses tats initial et dform

o o

Observer que la valeur maximale de la dflection dans le coin haut gauche (DMX=7.409). On peut aussi observer que les degrs de libert imposs ont une dflection nulle (comme on peut le prvoir!)

Dplacements
o

A partir du menu 'General Postproc' slectionner Plot results > Contour Plot > Nodal Solution. La fentre suivante apparatra.

Slectionner 'DOF solution' et 'USUM' as shown in the above window. Cliquer sur 'OK'.

La dflection peut tre obtenue comme une liste de valeurs nodales comme montr ci-dessous. A partir de General Postproc > List Results > Nodal Solution slectionner 'DOF Solution' et 'ALL DOFs' partir des listes dans la fentre 'List Nodal Solution' et cliquer 'OK'. Une liste des degrs de libert est alors affiche.

Noter que tous les degrs de libert imposs au niveau du nud 1 sont nuls, alors que le dplacement UY est nul au niveau du noeud 7. o Si vous voulez sauvegarder ces rsultats dans un fichier, slectionner 'File' dans la fentre des rsultats (coin suprieur gauche) et slectionner 'Save as'.
o

Contrainte axiale Pour calculer les contraintes axiales, nous allons utiliser la commande Element Table. Pour cet exemple, nous allons comparer les contraintes axiales calcules ceux dtermines par Ansys. Element Table est diffrente pour chaque type dlment. De la Table 1.2 dans le fichier Help, nous pouvons voir que SAXL peut tre obtenue grce ETABLE, en utilisant la combinaison 'LS,1' A partir du menu General Postprocessor, slectionner Element Table > Define Table o Cliquer sur 'Add...'
o

Comme montr ci-dessus, entrer 'SAXL' dans la boite 'Lab'. Ceci dfinit le nom de litem. Ensuite, dans les boites 'Item,Comp' boxes, selectionner 'By sequence number' et 'LS,'. Ensuite entrer 1 aprs LS, dans la boite de slection o Cliquer sur 'OK' et fermer la fentre 'Element Table Data' o Tracer les contraintes en slectionnant Element Table > Plot Elem Table o La fentre suivante va apparatre. Assurez vous que 'SAXL' est slectionner et cliquer 'OK'
o

Liste des contraintes A partir du menu 'Element Table', slectionner 'List Elem Table' A partir de la fentre 'List Element Table Data' assurez vous que 'SAXL' est slectionn Cliquer sur 'OK'

Notez que la contrainte axiale dans llment 1 est 82.9MPa ce qui est concorde avec la valeur calcule analytiquement.

Fichier de Commandes
Lexemple ci-dessous a t rsolue en utilisant le langage graphique (GUI , Graphical User Interface) dANSYS. Ce problme peut tre galement rsolue en utilisant et le langage de commande propre dAnsys. Dans un diteur de texte telle que Notepad de Windows copier et coller le texte ci-dessous et sauvegarder le fichier comme Treillis.txt par exemple. Maintenant, aller 'File > Read input from...' et slectionner ce fichier.
! Fichier de commandes ANSYS pour rsoudre le probleme de treillis 2D ! /title, Treillis 2D /PREP7 ! phase de preprocessing ! ! dfinir les parameters en (mm) height = 3118 width = 3600 ! ! definer les points cls ! point-cl, #, x, y K,1, 0, 0 K,2, width/2,height K,3, width, 0 K,4, 3*width/2, height K,5, 2*width, 0 K,6, 5*width/2, height K,7, 3*width, 0 ! ! definer les lignes ! L,1,2 ! ligne connectant les points cls 1 and 2 L,1,3 L,2,3 L,2,4 L,3,4 L,3,5 L,4,5 L,4,6 L,5,6 L,5,7 L,6,7 ! ! Dfinition de llment ! ET,1,LINK1 ! type dlment #1; spring element R,1,3250 ! constante relle #1; Xsect area: 3250 mm^2 MP,EX,1,200e3 ! proprit matrielle #1; Module de Young: 200 GPa LESIZE,ALL, , ,1,1,1 ! spcifier le nombre de divisions sur les lignes LMESH,all ! maillage des lignes

! FINISH ! Terminer la phase de pre-processing ! /SOLU ! entrer dans la phase de solution ! ! appliquer les contraintes DK,1,ALL,0 ! imposer un DOF au niveau dun point cl DK,7,UY,0 ! ! appliquer les charges ! FK,1,FY,-280e3 ! dfinir la charge ponctuelle au point cl FK,3,FY,-210e3 FK,5,FY,-280e3 FK,7,FY,-360e3 ! SOLVE ! rsoudre le systme dquations rsultant FINISH ! Terminer la rsolution /POST1 ! Pahse de Post-Processing PRRSOL,F ! List des forces de Reaction PLDISP,2 ! Dessin de la dforme PLNSOL,U,SUM,0,1 ! IsoContour de dflection ETABLE,SAXL,LS, 1 ! Contrainte Axial PRETAB,SAXL ! List Element Table PLETAB,SAXL,NOAV ! Visualiser les contraintes axiales

Vous aimerez peut-être aussi