Vous êtes sur la page 1sur 29

Sminaire

L'Informatique Applique au Gnie Parasismique

LA MODELISATION DES STRUCTURES AU SAP2000 EXEMPLES DE CALCUL


H. AKNOUCHE, Attach de Recherche Centre National de Recherche Applique au Gnie Parasismique, CGS

MODELISATION PAR SAP2000


La modlisation sur SAP2000 consiste en les tapes suivantes : 1. Entrer la gomtrie du modle (position des nuds, connectivit des lments). 2. Spcifier les proprits des lments et les assigner aux lments. 3. Dfinir les cas de charges (statique et dynamique) et assigner ces charges aux nuds et aux lments. 4. Spcifier les conditions aux limites (appuis, diaphragmes, etc). 5. Dmarrer lexcution du problme, apporter des corrections au modle sil y a lieu. 6. Visualiser les rsultats ( lcran, sur fichier, etc).

EXEMPLE N1 : PORTIQUE AUTOSTABLE EN B.A EN R+4


1.1. Description du Btiment
La structure tudie est un btiment en bton arm usage dhabitation implant en zone 2.

1.1.1. Dimensions en Plan de la Structure


Longueur (X) .................................................................................................................. 18.30 m Largeur (Y) ..................................................................................................................... 08.80 m Hauteur (Z)...................................................................................................................... 16.00 m Charges permanentes G : Plancher terrasse G = 5.50 KN/m Plancher courant G = 5.00 KN/m

Surcharges dexploitations Q : Plancher terrasse Q = 1.00 KN/m Plancher courant Q = 1.50 KN/m

1.1.2. Dfinition des Cas de Charges


G : charge permanente. Q : charge dexploitation. Ex(y) : charge dynamique spectrale selon X(Y)

1.1.3. Dfinition des Combinaisons de Charge.


G+Q 1.35 G + 1.5 Q G+QE G + Q 1.2 E 0.8 G E

Sminaire

L'Informatique Applique au Gnie Parasismique

1.1.4. Calcul des Masses pour lAnalyse Modale


Les masses des planchers sont calcules comme suit : W = Wp + Wq Wp : poids propre = 0.2 Q = Surcharge dexploitation. W = 700 t

1.1.5. Calcul des Charges Statiques Equivalentes Ex1,y1 :


Les charges statiques quivalentes sont calcules selon la mthode donne par le RPA99 :

V=

ADQ W R

o : A = 0.15 ; D = 2.2 ; Q = 1.20 ; R = 3.5 d'o : V=79.2 t

- Distribution des Charges Statiques :

V Ft Wi H i Fi = n W j H j
j =1

Ft= 0.0 car T < 0.7 s F1 = 208.00 KN F2 = 146.85 KN F3 = 144.66 KN F4 = 145.02 KN F5 = 147.41 KN

1.2. Etape N1 : Dfinir la Gomtrie du Modle


La premire tape consiste dfinir la gomtrie de la structure modliser.

1.2.1. Choix des Units


Contrairement au SAP90, vous devez choisir un systme dunits pour la saisie des donnes dans SAP2000. Au bas de lcran, slectionnez par exemple lunit (KN.m) comme units de base pour les forces et dplacements.

1.2.2. Gomtrie de Base


Slectionnez New model from template dans le menu File. Cette option permet de crer rapidement un modle rgulier, en utilisant des templates prdfinis.

Sminaire

L'Informatique Applique au Gnie Parasismique

Comme il sagit dune structure tridimensionnelle, slectionnez licne suivante :

Vous devez spcifier le nombre dtages, le nombre de traves suivant X et Y, hauteur de ltage et la largeur des traves suivant X et Y. Entrez les donnes prcdentes, mme si le btiment est irrgulier (les changement seront effectus plus tard). La fentre suivante prsente les donnes de notre exemple.

Deux vues du modle sont affiches (3D et 2D). Si vous maximiser une fentre et que le modle nest plus centr, cliquez sur licne Restore full view , le modle dfini ressemble ceci :

Sminaire

L'Informatique Applique au Gnie Parasismique

Sauvegarder votre modle laide du menu File et Save. Vous devez spcifier le dossier de sauvegarde et le nom du fichier. Les fichiers de donnes de SAP2000 ont des extensions SDB ou S2K. Vous pouvez galement cliquer sur licne .

1.2.3. Modification de la Gomtrie de Base


Comme la gomtrie du btiment nest pas tout fait rgulire, il faut la modifier. La longueur des traves est diffrente. Slectionner Draw et Edit Grid, sur la fentre qui apparat sur cran, choisissez laxe X et remplacer la ligne de coordonne X=-12 par X=-9.15 en cliquant sur Move Grid Line. Assurez-vous que loption Glue Joints to Grid Lines soit slectionne.

Rpter cette opration pour remplacer les autres lignes de coordonnes 7.2,-2.4,2.4,7.2 et 12 par 6.15, -1.35, 1.35, 6.15 et 9.15 respectivement. Slectionnez OK et reprendre cette opration pour les directions Y et Z comme suit : Direction Y remplacer la ligne Y=4.9 par 3.9, Slectionnez OK. Z ajouter +1 aux ctes Z=3,6,9,12 et 15, Slectionnez OK. Votre modle devrait maintenant ressembler ceci :

3.0

4.8

2.7

4.8

3.0

4.9

3.9

Sminaire

L'Informatique Applique au Gnie Parasismique

1.3. Etape N2 : Spcification des Proprits des Elments


La deuxime tape consiste spcifier les proprits des lments.

1.3.1. Dfinition du Matriau


Slectionnez Define et Materials puis Modify/Show Material pour visualiser ou modifier les caractristiques dun matriau dj existant dans la bibliothque du SAP2000 ou Define et Materials puis Add New Material pour ajouter un nouveau matriau, dans les deux cas, la fentre suivante apparat ou vous devez prciser pour le matriau le nom dans Material Type, le type dans Type of Material, la masse volumique, le poids volumique, le module dlasticit, le coefficient de poisson et le coefficient de dilatation thermique dans Analysis Property Data.

Cliquez OK et reprendre cette opration pour dfinir dautres matriaux.

1.3.2. Choix des Sections


Il existe une multitude de sections prdfinies dans SAP2000. Il est possible, par exemple, de choisir parmi une longue liste de profils en acier contenant toutes les informations pour une section donne (E, A, I, etc). Pour lexemple considr ici, comme les sections ne sont pas standard, il faut dabord dfinir les nouvelles sections pour les poutres et poteaux. Il faut ensuite les affecter aux lments correspondants.

1.3.2.1. Dfinition des Sections


Slectionnez Define et Frames Sections puis Import/Wide Flange pour importer une section prdfinie dans la bibliothque du SAP2000 ou Define et Frames Sections puis Add Rectangular pour dfinir une section rectangulaire. La fentre suivante apparat, vous devez prciser pour chaque section le nom dans Section Name, le type du matriau dans Material et les dimensions (largeur et hauteur) dans Dimensions. Ainsi, choisissez POT35 comme nom de section des poteaux de RDC et de 1er tage de dimensions 35x35 et inscrivez les dimensions, en mtres, des deux cts (0.35x0.35m). Slectionnez le matriau MAT pour le bton.

Sminaire

L'Informatique Applique au Gnie Parasismique

Cliquez OK et rpter cette opration en choisissant comme nom de section: POT30 pour dfinir la section des poteaux de dimensions 30x30, P30 pour dfinir la section des poutres de dimensions 30x30, P40X30 pour dfinir la section des poutres de dimensions 40x30.

Note : Cliquez sur le bouton Section Properties pour voir visualiser laire, les moments dinerties, laire de cisaillement et autres proprits calcules par SAP2000.

1.3.2.2 Affectation des Sections aux Elments de Structures


Les sections POT35, POT30, P30 et P40X30 ont t dfinies et le matriau MAT correspond aux proprits du bton du btiment considr. Il faut maintenant affecter ces proprits aux lments appropris. Pour affecter la section POT35 aux poteaux du RDC et 1er tage par exemple, prsentez la structure du btiment dans le plan XZ ou XY sur lune des vues du modle affiches (3D et 2D) sur cran. Cliquez sur licne Clear dans la barre doutils flottante pour liminer toute slection. Note : Cette icne nest active que sil y a dj une slection effectue.

Sminaire

L'Informatique Applique au Gnie Parasismique

Slectionnez dans le plan choisi les poteaux concerns (poteaux 1er et 2me tage) laide de licne dans la barre doutils flottante. Ceci permet de tracer une ligne avec la souris et de slectionner tous les lments croiss par la ligne. Rpter cette opration pour les poteaux appartenant aux plans parallles au plan choisi laide des icnes . On attribue les sections avec le menu Assign, puis Frame et Sections. Choisissez dans ce cas la section POT35 qui convient aux poteaux slectionns. En cliquant sur OK le nom de la section apparatra sur la fentre active. Reprendre lopration pour tous les poteaux de la structure en choisissant les sections adquates. Cette opration est aussi utilise pour attribuer les sections dj dfinies aux poutres, nanmoins, pour slectionner les poutres, on doit, cette fois-ci, reprsenter la structure du btiment dans le plan XY.

1.3.3. Affichage dInformation sur le Modle


Il est possible d'afficher diffrentes informations (numros de nuds, dlments,etc) sur le modle. Cliquez sur licne Set elements choisissez les options daffichage suivantes :

Si nous choisissons le plancher du 1er tage sur lune des deux fentres, le plancher affich est comme suit :

1.4. Etape N3 : Dfinition des Cas de Charges


Pour SAP2000, chaque cas de chargement doit tre dfini de faon gnrale. Les charges sont ensuite appliques sur les nuds et les lments appropris et associs un cas de chargement existant. Lexemple trait ici comporte les cas de chargement suivants : 7

Sminaire

L'Informatique Applique au Gnie Parasismique

La charge permanente G, La surcharge dexploitation P, Les charges sismiques Ex et Ey dans les cas de la mthode statique quivalente, Les fonctions de spectres de rponse SPCX et SPCY dans le cas de la mthode spectrale.

1.4.1. Cas de Charges Statiques (Permanent et dExploitation)


Slectionnez Static Load Cases dans le menu Define. Cette option permet de crer les cas de chargement statique dsir.

Dans le cas du chargement permanent G et si Self Weight Multiplier est pris gal 1, le poids propre des lments de structure sera considr automatiquement par le logiciel dans le calcul. Dans le cas contraire, le logiciel nglige le poids propre des lments de structures.

1.4.2. Cas de Charges Sismiques 1.4.2.1. Mthode Statique Equivalente


Si la structure rpond aux spcifications de lapplication de la mthode statique quivalente prsentes dans le RPA99, le chargement sismique sera considr comme une force statique applique aux nuds matres des planchers. Ainsi, pour introduire cette force : Slectionnez Static Load Cases dans le menu Define. Cette option permet de crer les cas de chargement statique EX et EY.

Sminaire

L'Informatique Applique au Gnie Parasismique

1.4.2.2. Mthode dAnalyse Modale Spectrale (Spectre de Rponse)


Pour charger le fichier de la fonction de spectre de rponse dj cr et sauvegard dans votre rpertoire sous le nom de spectre.dat par exemple, en deux colonnes, une colonne des priodes et une colonne des acclrations, cliquez dans le menu Define puis Response Spectrum Functions et Add Function from File. La fentre ci-dessous apparat sur cran, vous devez entrez selon la direction X par exemple : SPCX Nom de la fonction de spectre de rponse dans Function Name, Spectre.dat nom du fichier dans Open File, Slectionnez la boite Period and Acceleration value.

Cliquez OK et rpter les tapes de lopration prcdente pour introduire les donnes relatives la direction dexcitation Y. Voir lintroduction des donnes sur les fentres suivantes : Note : Si vous slectionnez la boite Function at equal period step of, il est ncessaire dintroduire le pas des priodes et le nombre de point par ligne dans la boite Number of points per line ( ces points reprsentent les valeurs dacclrations par ligne dans le fichier choisi ).

1.4.3. Affectation des Charges Statiques


Pour affecter les charges statiques verticales dfinies aux poutres, on doit dabord prsenter la structure du btiment dans le plan XY, le premier tage par exemple, sur lune des vues affiches du modle (3D et 2D) sur cran. Cliquez sur licne Clear dans la barre doutils flottante pour liminer toute slection. Slectionnez dans le plan choisi les poutres charger laide de licne dans la barre doutils flottante. Rpter cette opration pour les poutres ayant un chargement gal et appartenant aux plans suprieurs laide de licne . On attribue le chargement avec le menu Assign, puis Frame Static Loads et Point and Uniform ou Trapezoidal pour un chargement uniforme et concentr ou trapzodal respectivement. En cliquant sur Point and Uniform, la fentre suivante apparat, vous devez prciser le nom de cas de charge attribuer (charge permanente G par exemple), le type de la charge (forces ou moments), le sens dapplication de la charge et la valeur de la charge dans Uniform Loads. 9

Sminaire

L'Informatique Applique au Gnie Parasismique

Note : Pour un chargement concentr (permanent ou dexploitation), on doit prciser la position et la valeur de ce dernier dans Point Loads.

1.4.4. Affectation des Charges Sismiques 1.4.4.1. Mthode Statique Equivalente


On attribue les charges sismiques statiques quivalentes en slectionnant le nud matre concern pour chaque plancher, avec le menu Assign, puis Joint Static Loads et Forces. Sur la fentre qui apparat sur cran vous devez prciser selon la direction dexcitation X ou Y la valeur du chargement sismique.

1.4.4.2. Mthode dAnalyse Modale Spectrale (Spectre de Rponse)


On attribue les charges sismiques par spectre de rponse avec le menu Define, puis Response Spectrum Cases et Add New Spectra.

10

Sminaire

L'Informatique Applique au Gnie Parasismique

Sur la fentre qui apparat sur cran, vous devez prciser selon la direction dexcitation X : EX Nom du cas de chargement par spectre de rponse dans Spectrum Cases Name, 0 Angle dexcitation dans Excitation Angle, 0.07 Amortissement dans Damping, SPCX Nom de la fonction de spectre de rponse dfini prcdemment et 9.81 le facteur dchelle dans Input Response Spectra. Cliquez OK et rpter les tapes de lopration prcdente pour introduire les donnes relatives la direction dexcitation Y. Voir lintroduction des donnes sur les fentres ci-dessous.

1.4.5. Combinaisons dActions


On introduit les combinaisons daction dans le menu Define, puis Loads combinaison et Add New Comb. Sur la fentre qui apparat sur cran vous devez prciser pour la combinaison de ltat limite ultime par exemple ce qui suit : ELU Nom de la combinaison daction dans Load Combination Name, ADD Type de la combinaison dactions dans Load Combination Load, ELU Intitul de la combinaison dans Title, 1.35 et 1.5 facteurs de pondration des cas de chargement G et P dans Define Combinaison. Lorsque vous tapez OK le nom de la combinaison introduite apparat dans la fentre Define Load Combinations. Reprendre les tapes de lopration prcdente pour introduire les autres combinaisons dactions. Les deux fentres suivantes prsentent lintroduction des donnes relatives aux combinaisons 1.35G+1.5P et G+PEy

11

Sminaire

L'Informatique Applique au Gnie Parasismique

Note : Linstruction ADD reprsente la somme algbrique des actions combiner.

1.5. Etape N04 : Conditions aux Limites


Cette tape consiste spcifier les conditions aux limites (appuis, etc) pour la structure modliser.

1.5.1. Appuis (Restraints)


Le template utilis a dj plac des appuis doubles au bas de chaque popteau. Puisque dans le cas prsent il sagit dencastrements, il faut les modifier. Slectionnez les nuds de la base en dessinant une fentre qui les englobent laide de la souris dans le plan X-Y pour Z=0. On attribue des appuis (restraints) avec le menu Assign, puis Joint (nuds) et Restraints. Cliquez sur licne qui reprsente un encastrement.

12

Sminaire

L'Informatique Applique au Gnie Parasismique

Ce menu peut tre utilis pour attribuer nimporte quelle combinaison de degrs de liberts un nud quelconque. Sauvegarder votre modle laide du menu File et Save.

1.5.2. Cration du Nud Matre


Dans le SAP2000, le nud matre peut tre cr avec le menu Draw et Add Special Joint. Cette opration vous permet de dplacer la souris vers la position dsire dont les coordonnes sont affichs au fur et mesure au bas de la fentre reprsentant le plan X-Y du premier tage par exemple, une fois la position recherche atteinte, appuyez sur le bouton gauche de la souris. Pour modifier les coordonnes de ce nud ou dun nud quelconque. Il suffit de slectionner le nud et dappuyer sur le bouton de droite de la souris. Une fentre apparat sur votre cran et permet de modifier les coordonnes X, Y et Z, ainsi que le numro du nud. Rpter cette opration pour les autres tages. Note : La position du nud matre reprsente le centre de gravit des masses plus ou moins 0.05L (L tant la dimension du plancher perpendiculaire la direction de laction sismique) comme stipule lArticle 4.3.7 du RPA99. Comme il sagit dun plancher rigide on doit attribuer aux nud matre de chaque plancher : 1Trois degrs de liberts : deux translations (suivant X et Y) et une rotation autour de Z. Pour cela, slectionnez les nuds matres crs en cliquant sur eux laide de la souris. On attribue les restraints avec le menu Assign, puis Joint (nuds) et Restraints. Sur la fentre Joint Restraint qui apparat sur cran, slectionnez la combinaison de degr de libert suivante :

2-

La masse du plancher pour les degrs de translation et linertie massique du plancher pour le degr de rotation. Pour cela, slectionnez les nuds matres ayant les valeurs des masses et dinertie massique en cliquant sur eux laide de la souris. On attribue les masses avec le menu Assign, puis Joint (nuds) et Masses. Sur la fentre Joint Masses qui apparat sur votre cran, affectez les valeurs de la masse du plancher suivant les deux directions X et Y et la valeur dinertie massique autour de laxe Z.

13

Sminaire

L'Informatique Applique au Gnie Parasismique

1.5.3. Constraints
Comme pour le SAP90, les constraints permettent de relier des degrs de liberts (DDL) dun ou plusieurs nuds aux degrs de libert dun seul nud. Ceci a pour effet de rduire le nombre dquations rsoudre. Cliquez sur licne Clear dans la barre doutils flottante pour liminer toute slection. Slectionnez les nuds du premier tage en dessinant une fentre qui englobe ces nuds laide de la souris. Dans SAP2000, on attribue des constraints avec le menu Assign, puis Joints et Constraints, sur la fentre constraints qui apparat sur votre cran, slectionnez Add Diaphragm.

Il faut attribuer un nom pour le Add Diaphragm assign au premier tage et spcifier que le degr de libert sera commun tous les nuds de cet tage. Choisissez DIAPH1 comme nom et slectionnez le DDL selon laxe des Z, sur la fentre diaphragm constraint .

14

Sminaire

L'Informatique Applique au Gnie Parasismique

Cliquez sur OK et rptez lopration pour tous les tages en slectionnant un nom diffrent (DIAPH2, DIAPH3, DIAPH4 et DIAPH5) et toujours laxe des Z. Avant de lancer lexcution de lexemple de calcul, il faut spcifier que l'analyse sera effectue en trois dimensions. Slectionnez Space Frame dans le menu Analyze, puis Set Analysis Options. Sur la mme fentre et avant de cliquer OK, slectionnez Dynamic Analysis puis Set Dynamic Parameters pour fixer le nombre de mode de vibration retenir dans Number of modes. Slectionnez ensuite loption Generate Output pour crer un fichier de rsultats qui pourra tre imprimer. Appuyer sur Select Output Options pour spcifier les rsultats sauvegarder sur fichiers :

Slectionner toutes les options possibles et, dans chaque cas, appuyer sur Select/Show Loads pour choisir le cas de chargement ou la combinaison daction.

1.6. Etape N5 : Dmarrage de l'Excution


L'excution du problme peut tre dmarre en slectionnant Analyze et Run Analysis. Elle peut galement tre dmarre en appuyant sur F5 ou bien sur l'icne . S'il y a des erreurs, vous pouvez retourner dans le module graphique et apporter les corrections ncessaires. La prochaine tape consiste visualiser les rsultats de l'analyse.

15

Sminaire

L'Informatique Applique au Gnie Parasismique

1.7. Etape N6 : Visualisation et Exploitation des Rsultats


Aprs excution du modle, le SAP2000 construit trois fichiers dextension et .LOG). Le fichier dextension ( .out) permet dobtenir : (.OUT, .EKO

La somme de la masse effective modale (> 90%) pour revoir, le cas chant, le nombre de modes retenir. Leffort tranchant sismique la base dans le cas de la mthode modale spectrale,

Dans notre exemple : La masse effective modale dpasse 96% de lnergie pour cinq modes :
P A R T I C I P A T I N G PERIOD 0.946236 0.762738 0.715778 0.313598 0.262696 M A S S R A T I O S CUMULATIVE SUM (PERCENT) UX UY UZ 0.0000 73.7407 87.4385 87.4385 96.7737 86.0998 86.0998 86.0998 96.4372 96.4372 0.0000 0.0000 0.0000 0.000 0.0001

M O D A L MODE 1 2 3 4 5

INDIVIDUAL MODE (PERCENT) UX UY UZ 0.0000 73.7407 13.6977 0.0000 9.3352 86.0998 0.0000 0.0000 10.3374 0.0000 0.0000 0.0000 0.0000 0.0000 0.0000

Ainsi, la condition du RPA99 est vrifie pour 05 modes. Effort tranchant sismique la base dans le cas de la mthode modale spectrale :
R E S P O N S E S P E C T R U M B A S E R E A C T I O N S

IN RESPONSE-SPECTRUM LOCAL COORDINATES SPEC EX ------------------

FOR EACH MODE, DUE TO SPECTRAL ACCELERATION IN DIRECTION U1: MODE 1 2 3 4 5 F1 5.62E-13 545.154501 105.721253 6.17E-10 91.823680 F2 1.76E-05 6.71E-06 1.43E-06 0.000250 -0.002457 F3 2.88E-09 -1.51E-06 -2.84E-07 -2.84E-07 0.000603 M1 M2 M3 -0.000204 5.19E-12 -7.44E-12 4.10E-05 6276.546 -289.924046 3.49E-06 1216.489 626.302963 0.000393 -1.17E-08 -7.82E-09 -0.001014 -185.593785 -28.186564

COMBINED FOR ALL MODES AND ALL DIRECTIONS OF SPECTRAL ACCELERATION: SPEC SPEC F1 562.851669 F2 0.002470 F3 0.000603 M1 0.001107 M2 6396.040 M3 690.728483

EY ------------------

FOR EACH MODE, DUE TO SPECTRAL ACCELERATION IN DIRECTION U2: MODE 1 2 3 4 5 F1 1.76E-05 6.71E-06 1.43E-06 0.000250 -0.002457 F2 550.940664 8.25E-14 1.94E-14 101.680894 6.58E-08 F3 0.090182 -1.86E-14 -3.84E-15 -0.115235 -1.61E-08 M1 -6392.060 5.04E-13 4.72E-14 159.614135 2.71E-08 M2 0.000163 7.72E-05 1.65E-05 -0.004747 0.004967 M3 -0.000233 -3.57E-06 8.48E-06 -0.003173 0.000754

16

Sminaire

L'Informatique Applique au Gnie Parasismique

COMBINED FOR ALL MODES AND ALL DIRECTIONS OF SPECTRAL ACCELERATION: SPEC F1 0.002470 F2 560.245142 F3 0.146328 M1 6394.053 M2 0.006873 M3 0.003270

Note : En comparant leffort tranchant la base Vt obtenu par la mthode spectrale avec leffort tranchant Vs dduit par la mthode statique quivalente on voit clairement que 0.8Vs est largement suprieur Vt. Ainsi, on doit majorer Vt par un coefficient gal 0.8Vs/Vt conformment larticle 4.3.6 du RPA99.

1.7.1. Rsultats sur Fichiers


Le menu File, puis Print output tables permet dimprimer ou dexporter les rsultats dsirs (Dplacement, Raction, Forces internes,...) pour chaque cas de chargement et pour chaque lment slectionn de la structure dans un fichier. Ces fichiers peuvent tre exploits en les exportant vers Excel pour dterminer par exemple : - Les efforts max pour le ferraillage des lments de structures, Le dplacement max pour le calcul du dplacement inter-tage et le dimensionnement du joint sismique. Par exemple pour dterminer les efforts max revenant aux poteaux de dimensions 40x40. Slectionnez dabord ces lments, choisissez pour les combinaisons dsires, les rsultats imprimer sur fichier dans la boite Print Output Tables dans File. -

1.7.2. Visualisation des Rsultats l'Ecran


L'interface graphique de SAP2000 permet de visualiser les rsultats sous diffrentes formes.

1.7.2.1. Dplacements
Avec le menu Display, il est possible de choisir Show Deformed Shape (ou tout simplement appuyer sur F6) pour visualiser les dplacements. Le sous-menu Show Deformed Shape conduit la fentre ci-dessous :

17

Sminaire

L'Informatique Applique au Gnie Parasismique

Il faut spcifier le cas de chargement. L'option Scaling permet de spcifier un facteur de multiplication pour le dplacement ou de laisser SAP2000 en choisir un (Auto). L'option Wire Shadow permet de superposer la gomtrie non dforme (en gris ple) la gomtrie dforme. L'option Cubic Curve permet d'illustrer la dforme avec une interpolation cubique tenant compte non seulement des translations mais galement des rotations et donc reprsentative de la flexion dans les lments. Il est possible d'animer les dplacements. Cliquez sur Start Animation au bas de l'cran pour voir la structure vibrer. Pour le cas de chargement par spectres de rponse EX et EY, les formes affiches seront comme suit :

Suivant EX

Suivant EY

Cette configuration nous permet de dterminer le dplacement de la structure au sommet et le dplacement inter-tages conformment au RPA99. Les dformes modales peuvent tre visualiser en slectionnant, cette fois, la section Show Mode Shape dans le menu Display.

1.7.2.2. Ractions
Le menu Display permet d'afficher les ractions avec l'option Show Element Forces/Stresses et Joints. Slectionnez Reactions et le cas de charges dsir. Les ractions seront affiches sur les appuis. Vous pouvez imprimer cette vue avec le menu File et Print Graphics.

18

Sminaire

L'Informatique Applique au Gnie Parasismique

1.7.2.3. Forces Internes


Le menu Display permet d'afficher les forces internes avec Show Element Forces /Stresses et Frames. Slectionner sur la fentre qui apparat sur votre cran la combinaison de charge et leffort dsir dans Load et component respectivement.

L'option Axial Force permet d'afficher le diagramme des efforts normaux . L'option Shear 2-2 et 3-3 permet d'afficher le diagramme des efforts tranchants dans les directions 2-2 et 3-3. L'option Moment 3-3 et 2-2 affiche le diagramme des moments flchissants dans les directions 3-3 et 2-2. Les figures suivantes montrent la distribution de leffort normal pour la combinaison G+P.

19

Sminaire

L'Informatique Applique au Gnie Parasismique

1.9. Dmarrage d'une Autre Analyse


Lorsque l'analyse est effectue, SAP2000 "verrouille" le modle. Ainsi, pendant toute l'tape de visualisation des rsultats, il est impossible de modifier le modle (gomtrie, connectivit, matriaux, appuis, charges, etc). L'icne de verrouillage, dans la barre d'outils en haut de l'cran, . Pour apporter des modifications au modle, il faut le dverrouiller en cliquant est enfonce sur cette icne. Dans ce cas, tous les rsultats d'analyse seront dtruits. Une fois dverrouill, le modle peut tre dit et une autre analyse peut tre effectue.

20

Sminaire

L'Informatique Applique au Gnie Parasismique

EXEMPLE N2 : STRUCTURE MIXTE EN B.A


On garde la structure de lexemple N 1, en insrant des voiles en L de 1.50 m de longueur au niveau des angles du btiment.

2.1. Etape N1 : Dfinition de la Gomtrie du Modle ( Insertion des Voiles)


Pour insrer les voiles, on doit dabord crer de nouveaux Grid Lines aux limites extrieures des voiles. Dans notre cas, les coordonnes de ces Grids sont : Direction X : -7.65m et 7.65m Direction Y : -3.40m et 2.40m Pour le SAP2000, linsertion des lments Shell peut tre effectue avec le menu Draw, puis Quick Draw Rectangular Shell Element ou en slectionnant licne dans la barre doutils flottante. Dplacez la souris vers la position dsire, une fois cette dernire est atteinte, cliquez sur le bouton gauche de la souris pour raliser linsertion. Rpter cette opration pour introduire les autres lments de voiles. Les voiles peuvent tre subdiviss en sous-lments en slectionnant dabords ces lments puis dans le menu Edit et Mesh Shells, choisissez le nombre de sous-lments dsirs dans la fentre affiche sur votre cran.

2.2. Etape N2 : Spcification des Proprits des Elments


Slectionnez Define et Shell Sections puis Add New Section, sur la fentre qui apparat sur votre cran, vous devez prciser pour chaque section le nom dans Section Name, le type du matriau dans Material, lpaisseur dans Membrane et Bending et le type de llment voile dans type. Ainsi, choisissez VOIL15 comme nom de section des voiles et inscrivez lpaisseur, en mtres, 0.15 m slectionnez shell dans Type et le matriau MAT pour le bton. On attribue la section VOIL15 avec le menu Assign puis Shell et Sections en slectionnant tous les lments Shell.

21

Sminaire

L'Informatique Applique au Gnie Parasismique

2.3. Etape N3 : Dfinition des Cas de Charges


On garde les mmes cas de charges que lexemple prcdent N1.

2.4 Etape N4 : Conditions aux Limites (Justification de lInteraction Voiles-Portiques)


Conformment au RPA99 et afin dassurer la compatibilit entre le portique et le voile, on doit assurer linteraction en subdivisant les lments frames de faon que leurs nuds concident avec ceux des sous lments de voiles crs prcdemment. Slectionnez toute la structure laide de licne all dans la barre doutils flottante puis avec le menu Edit et Divide Frame slectionnez la section Break at intersections With Selected frames and joints. Avant de lancer lexcution du problme, on doit redfinir les diaphragmes pour chaque plancher afin dattribuer aux nouveaux nuds dcoulant de lopration de discrtisation du maillage des voiles les degrs de libert adquats.

2.5. Etape N5 : Dmarrage de lExcution


Aprs excution du problme en appuyant sur F5 ou en slectionnant Analyze et Run Analysis, le SAP2000 construit trois fichiers dextension (.OUT, .EKO et .LOG). Le fichier dextension ( .out) permet dobtenir. La somme de la masse effective modale.
P A R T I C I P A T I N G PERIOD 0.539353 0.443642 0.332626 0.136459 0.122132 M A S S R A T I O S CUMULATIVE SUM (PERCENT) UX UY UZ 0.0000 76.9194 76.9562 76.9562 93.3917 75.6280 75.6280 75.6280 92.5307 92.5307 0.0000 0.0000 0.0000 0.0002 0.0002

M O D A L MODE 1 2 3 4 5

INDIVIDUAL MODE (PERCENT) UX UY UZ 0.0000 76.9194 0.0369 0.0000 16.4355 75.6280 0.0000 0.0000 16.9027 0.0000 0.0000 0.0000 0.0000 0.0001 0.0000

la condition du RPA99 est vrifie pour 05 modes. 22

Sminaire

L'Informatique Applique au Gnie Parasismique

Effort tranchant sismique la base dans le cas de la mthode modale spectrale,


S P E C T R U M B A S E R E A C T I O N S

R E S P O N S E

IN RESPONSE-SPECTRUM LOCAL COORDINATES SPEC EX ------------------

FOR EACH MODE, DUE TO SPECTRAL ACCELERATION IN DIRECTION U1: MODE 1 2 3 4 5 F1 6.58E-15 578.827449 0.277385 1.58E-10 144.567944 F2 1.89E-06 1.03E-05 -2.65E-07 0.000147 -0.000527 F3 5.99E-10 1.61E-05 -1.32E-07 -2.53E-07 4.77E-05 M1 -2.30E-05 -2.79E-05 4.44E-07 -0.000323 0.000809 M2 1.96E-14 7009.463 3.286352 1.99E-10 282.439000 M3 -9.43E-16 239.975560 38.874622 1.77E-10 68.128229

COMBINED FOR ALL MODES AND ALL DIRECTIONS OF SPECTRAL ACCELERATION: SPEC SPEC F1 597.832133 F2 0.000452 F3 5.03E-05 M1 0.000663 M2 7018.132 M3 260.014146

EY ------------------

FOR EACH MODE, DUE TO SPECTRAL ACCELERATION IN DIRECTION U2: MODE 1 2 3 4 5 F1 1.89E-06 1.03E-05 -2.65E-07 0.000147 -0.000527 F2 540.738547 1.83E-13 2.54E-13 137.633211 1.92E-09 F3 M1 0.171666 -6606.762 2.86E-13 -4.97E-13 1.27E-13 -4.24E-13 -0.235985 -301.732616 -1.74E-10 -2.95E-09 M2 5.63E-06 0.000125 -3.14E-06 0.000185 -0.001029 M3 -2.70E-07 4.27E-06 -3.72E-05 0.000165 -0.000248

COMBINED FOR ALL MODES AND ALL DIRECTIONS OF SPECTRAL ACCELERATION: SPEC F1 0.000452 F2 558.921944 F3 0.290835 M1 6615.780 M2 0.000935 M3 0.000200

2.6. Visualisation et Exploitation des Rsultats 2.6.1. Dplacements


Les dplacements peuvent tre visualiss en excutant les opration dfinies prcdemment. Pour le cas de chargement par spectre de rponse dans le sens X, on obtient ce qui suit :

23

Sminaire

L'Informatique Applique au Gnie Parasismique

La configuration prcdente nous permet de dterminer le dplacement inter-tages conformment au RPA99. Note : Les dformes modales et les ractions peuvent tre visualises en excutant les oprations dfinies prcdemment.

2.6.2. Forces Internes


Pour dterminer les efforts revenant aux voiles et aux portiques sparment, il suffit de : Slectionner les nuds de base et les lments voiles connects ces nuds, Affecter un nom de groupe aux lments slectionns en cliquant sur Assign puis Groupe Name, Visualiser les rsultats en cliquant sur Display puis Show Groupe Joint Force Sums.

En excutant ces tapes pour les voiles, on obtient, pour les cas de charges dfinies prcdemment, la rduction des efforts suivante au centre de gravit de la section du groupe :

Ces efforts peuvent tre imprimer sur fichier en slectionnant dans la boite Print Output Tables dans File, les noms de groupes et les combinaisons dactions.

24

Sminaire

L'Informatique Applique au Gnie Parasismique

EXEMPLE N3 : STRUCTURE EN VOILES


3.1. Description de la Structure

3.50

3.50

2.70

3.50

3.50

3.2. Etape N1 : Dfinition de la Gomtrie du Btiment


Pour introduire la gomtrie du btiment, on doit dfinir la bote Modify Grid Line du menu Edit Grid et Draw les lignes reprsentant les axes des voiles et les limites des ouvertures dans les trois directions X,Y et Z. Dans notre exemple, on a : X 0.00 2.25 3.25 3.50 3.75 4.50 4.75 6.00 7.00 9.70 11.95 12.95 13.2 13.45 14.45 16.70 Y 0.00 3.50 3.75 4.75 5.00 9.50 Z 0.00 2.20 3.00 5.2 6.00 8.20 9.00 11.2 12.00 14.20 15.00 Linsertion des lments Shell peut tre effectue avec le menu Draw, puis Quick Draw Rectangular Shell Element ou en slectionnant licne dans la barre doutils flottante. Dplacez la souris vers la position dsire, une fois cette dernire atteinte, cliquez sur le bouton gauche de la souris pour linsertion. Rpter cette opration pour introduire les autres lments (voiles et dalles).

3.5

1.5

4.5

25

Sminaire

L'Informatique Applique au Gnie Parasismique

3.3. Etape N2 : Spcification des Proprits des Elments 3.3.1. Dfinition du Matriau
Comme il sagit dune dalle pleine en BA, deux mthodes peuvent tre utilises pour dfinir les caractristiques du matriau des lments SHELL : 1re Mthode : Elle consiste introduire les caractristiques relatives au matriau bton dj dfinies dans les paragraphes prcdents. La masse des cloisons de sparation et des revtements sera rpartie sur les nuds du plancher en fonction de la surface qui leur revient. Le poids des cloisons de sparation et des revtements est considr comme une charge rpartie sur la surface des lments dalles. Ainsi, pour un plancher courant de 500 kg/m et une dalle pleine en BA de 16 cm dpaisseur, la masse rpartir sur les nuds est gale 500-0.16x2500=100 kg/m. 2me Mthode : Pour tenir compte de la masse des lments de sparation et des revtements un nouveau matriau sera dfini avec une masse et un poids volumique quivalent. Ainsi, pour un plancher courant de 500 Kg/m, on obtient pour les lments shell (ep=16 cm) du plancher une masse volumique de 3.3125 Kg/m et un poids de 33.125 KN/m.

3.3.2. Dfinition de la Section


Choisissons VOIL15 et DALLE pour dfinir la section des voiles et des dalles respectivement.

3.4. Etape N3 : Dfinition de Cas de Charges et des Combinaisons


Reprendre les tapes des phases N 3 et N 4 de lexemple N 1 pour la dfinition des cas de charges et des combinaisons dactions considrer. Note : La combinaison G+P1.2E est remplace par la combinaison G+PE conformment au RPA99.

3.4.1. Affectation des Cas de Charges Statiques


Dans le cas o vous utilisez la premire mthode pour la dfinition du matriau, on doit affecter dans ce paragraphe le poids des revtements et des cloisons de sparation comme une charge uniforme. Pour cela, on doit slectionner dans le plan choisi XY les lments shell charger laide de licne dans la barre doutils flottante. Rpter cette opration pour les autres lments ayant un chargement gal. On attribue le chargement avec le menu Assign, puis Shell Static Loads et Uniform pour un chargement uniforme. En cliquant sur Uniform, la fentre suivante apparat o vous devez prciser le nom de cas de charge attribuer dans la case Load Case Name, la valeur de la charge et la direction dapplication de la charge dans Uniform Load.

26

Sminaire

L'Informatique Applique au Gnie Parasismique

Dans le cas o vous utilisez la deuxime mthode pour la dfinition du matriau, il suffit dans ce paragraphe dattribuer les surcharges dexploitation aux lments Shell de votre plancher comme une charge uniformment rpartie.

3.4.2. Affectation des cas de charges sismiques


Dans le cas de la mthode modale spectrale, laffectation des charges sismiques se fait de la mme manire que lexemple N1.

3.5. Etape N4 : Conditions dAppuis


Slectionnez les nuds de la base en dessinant une fentre qui les englobe laide de la souris dans le plan X-Y pour Z=0. On attribue des appuis (restraints) avec le menu Assign, puis Joint (nuds) et Restraints. Dans la boite qui apparat cliquez sur licne qui reprsente un encastrement. Comme la masse des voiles est relativement comparable la masse des dalles, on nglige dans cet exemple lutilisation de diaphragm

3.6. Etape N5 : Dmarrage de lExcution


Avant de lancer lexcution de lexemple de calcul, il faut spcifier que l'analyse sera effectue en trois dimensions. Slectionnez Space Frame dans le menu Analyze, puis Set Analysis Options. Sur la mme fentre et avant de taper OK slectionnez Dynamic Analysis puis Set Dynamic Parameters pour fixer le nombre de mode de vibration retenir dans Number of modes. Slectionnez ensuite loption Generate Output pour crer un fichier de rsultats qui pourra tre imprimer. Appuyer sur Select Output Options pour spcifier les rsultats sauvegarder sur fichiers. L'excution du problme peut tre dmarre en slectionnant Analyze et Run Analysis. Aprs excution, le SAP2000 construit trois fichiers dextension (.OUT, .EKO et .LOG). Le fichier dextension ( .out) permet dobtenir : La somme de la masse effective modale.
P A R T I C I P A T I N G PERIOD 0.118868 0.110972 0.098271 0.071551 0.059253 0.058595 0.057311 M A S S R A T I O S CUMULATIVE SUM (PERCENT) UX UY UZ 73.0613 0.0005 0.0000 73.0621 67.9295 0.0242 79.0739 67.9296 0.0242 79.0739 67.9296 0.0243 79.0739 67.9298 0.0249 79.0739 68.2457 1.2146 79.0739 68.2457 1.2148 MODE 1 2 3 4 5 6 7 INDIVIDUAL MODE (PERCENT) UX UY UZ 73.0613 0.0005 0.0000 0.0008 67.9290 0.0242 6.0117 0.0001 0.0000 0.0000 0.0000 0.0001 0.0000 0.0002 0.0006 0.0000 0.3159 1.1897 0.0000 0.0000 0.0002

M O D A L

Avec ce nombre de modes la condition 4.3.4.b du RPA99 est vrifie. 27

Sminaire

L'Informatique Applique au Gnie Parasismique

Leffort tranchant sismique la base dans le cas de la mthode modale spectrale,


S P E C T R U M B A S E R E A C T I O N S

R E S P O N S E

IN RESPONSE-SPECTRUM LOCAL COORDINATES SPEC SPECX ------------------

FOR EACH MODE, DUE TO SPECTRAL ACCELERATION IN DIRECTION U1: MODE 1 2 3 4 5 6 7 F1 709.981764 0.008187 60.622081 0.000196 1.28E-05 1.23E-05 3.80E-06 F2 1.810409 -2.340048 0.228187 0.000289 0.000160 -0.006654 3.58E-05 F3 -0.039636 0.044142 0.005883 0.000529 0.000294 -0.012914 8.55E-05 M1 -23.255324 28.014889 -2.987732 0.001643 0.001190 -0.054555 0.000312 M2 7765.963 -0.281777 666.755651 -0.073200 -0.006084 0.107826 0.007516 M3 -4419.216 -19.561331 911.826414 0.050442 0.004320 -0.055478 -0.003028

COMBINED FOR ALL MODES AND ALL DIRECTIONS OF SPECTRAL ACCELERATION: SPEC SPEC F1 743.420969 F2 0.941177 F3 0.025958 M1 10.974431 M2 8133.508 M3 4035.444

SPECY ------------------

FOR EACH MODE, DUE TO SPECTRAL ACCELERATION IN DIRECTION U2: MODE 1 2 3 4 5 6 7 F1 1.810409 -2.340048 0.228187 0.000289 0.000160 -0.006654 3.58E-05 F2 0.004616 668.879982 0.000859 0.000426 0.001998 3.604251 0.000337 F3 -0.000101 -12.617540 2.21E-05 0.000780 0.003674 6.994801 0.000805 M1 -0.059300 -8007.783 -0.011246 0.002421 0.014867 29.548698 0.002938 M2 19.802721 80.543309 2.509731 -0.107885 -0.075993 -58.401972 0.070769 M3 -11.268725 5591.416 3.432201 0.074344 0.053953 30.048616 -0.028513

COMBINED FOR ALL MODES AND ALL DIRECTIONS OF SPECTRAL ACCELERATION: SPEC F1 0.941177 F2 669.191522 F3 13.915737 M1 8005.463 M2 111.943094 M3 5586.420

3.7. Visualisation et Exploitation des Rsultats 3.7.1. Dplacements


Les dplacements peuvent tre visualiss en excutant les oprations dfinies prcdemment.

3.7.2. Forces Internes


Pour dterminer les efforts internes revenant aux voiles, il suffit de dfinir pour chaque voile un nom de groupe en cliquant sur Assign puis Groupe Name, aprs avoir slectionner les nuds de base et les lments connects ces nuds. Les rsultats peuvent tre visualiss en cliquant sur Display puis Show Groupe Joint Force Sums ou imprimer sur fichier en slectionnant, dans la bote Print Output Tables dans File, les noms de groupes et les combinaisons dactions. On peut aussi visualiser les efforts internes par mtre linaire en cliquant sur Shells dans Show Element/Forces stresses dans le menu Display. Dans le cas de notre exemple, on reprsente sur la figure ci-dessous la distribution de leffort interne F11 par mtre linaire affiche par SAP2000. 28

Sminaire

L'Informatique Applique au Gnie Parasismique

29