Vous êtes sur la page 1sur 10

Initiation SolidWorks

Mthodes de travail

I - Introduction :
Solidworks est un logiciel de C.A.O. (Conception Assiste par Ordinateur) ce qui permet de concevoir directement un modle numrique en trois dimensions dune pice ou dun assemblage.

I.1- Architecture des fichiers SolidWorks.


Trois familles de fichiers peuvent tre cres laide de SolidWorks. 1) PICE 2) ASSEMBLAGE 3) MISE EN PLAN

Type de fichier : SLDPART Exemple : Corps.Sldpart

Type de fichier :SLDASM Exemple : Vrin.Sldasm

Type de fichier :SLDDRW Exemple : Corps.Slddrw

II - PRISE EN MAIN DE LINTERFACE GRAPHIQUE DE SOLIDWORKS

Initiation

Anane Zayed / 2006

Page: 1

III - MODLISATION DU BLOC DE JONCTION

Pour la construction du bloc de jonction vous DEVEZ IMPRATIVEMENT RESPECTER lhistorique de cration fournit ( voir figure ci-contre ) Historique de cration du bloc de jonction

Avant de commencer la conception d'une pice :

Grille/Aimant : Aprs avoir ouvert une nouvelle fentre (Menu Fichier Nouveau Slectionner Pice), vrifier que la grille et les points aimants sont correctement configurs. (Menu Outil Option Onglet Proprits du document Slectionner Grille/Aimant) L'espacement de la grille principale, le nombre de subdivisions et le nombre de points aimants entre subdivision doivent permettre de dessiner aisment les esquisses peu prs aux bonnes dimensions (les dimensions exactes tant fixes ensuite par la cotation).
Par dfaut les valeurs sont : o o o Espacement grille principale : 100mm Nombre de subdivision entre grille majeure : 10 Points aimants : nombre de points entre subdivision : 1

On peut pour une petite pice (quelques millimtres) prendre : o o o Espacement grille principale : 10mm Nombre de subdivision entre grille majeure : 10 Points aimants : nombre de points entre subdivision : 2

Initiation

Anane Zayed / 2006

Page: 2

Orientation de la pice Avant de passer en mode esquisse et si la pice doit plus tard venir s'insrer dans un assemblage, il faut se poser la question de son orientation. Choisir le bon plan, reprer le sens des axes, puis passer en mode esquisse et placer les formes dans le bon sens. - Plan 1 : c'est le plan frontal XZ. Si on dessine une pice dans ce plan, elle sera donc dans un plan vertical. - Plan 2 : c'est le plan horizontal XY. C'est l qu'on dessine le plus souvent les bases des pices. - Plan 3 : c'est le plan debout YZ. Comme le plan 1 il est vertical.

Illustration

Mode esquisse : Zoom Aprs tre pass en mode esquisse, faire un zoom afin de pouvoir dessiner les traits peu prs aux bonnes dimensions (mme remarque que pour la grille).

Enregistrer sous : Il faut d'emble donner un nom la pice. Pour cela il faut enregistrer la fentre actuelle dans un fichier sur le disque dur. Ne jamais travailler directement sur une disquette (risques de plantage et fonctionnement trs lent).

Initiation

Anane Zayed / 2006

Page: 3

Initiation SolidWorks

Comment dessiner et crer des pices avec SolidWorks ?

Quelles sont les fonctions de base permettant de crer des formes ? Comment raliser ceci ou cela ? Pour chaque procd et pour chaque fonction sont donns le principe, la mthode gnrale et un exemple d'application.

Fonctions "de base" :

Comment crer un volume par extrusion ?


o o

Mthode gnrale Exemple.1 (Forme oblongue).


Cet exemple permet en plus de voir comment coter un trou oblong en "horstout".

Exemple.2 (Fonctions plus spcifiques). Perage dbouchant et borgne. Trou taraud Chambrage pour vis tte cylindrique ou hexagonale
o

Rptition linaire.

Comment crer un volume par rvolution ?


o o

Mthode gnrale Exemple.1 (Arbre paul).


Cet exemple permet en plus de voir comment utiliser les relations gomtriques et comment chanfreiner l'arbre.

Exemple.2 (Roue dente).


Cet exemple permet en plus de voir comment utiliser les relations gomtriques et comment faire des rptitions circulaires.

Enlvement de matire Congs et arrondis Chanfreins Perages (simples ou complexes) Coque Nervure Balayage Lissage Dpouille Dme Dformation rptition circulaire

Initiation

Anane Zayed / 2006

Page: 4

Fonctions plus spcifiques :

Comment crer un filetage et un taraudage sur un volume de rvolution ?

o o

Mthode gnrale Exemple.1 (Arbre paul avec filetage une extrmit et taraudage l'autre extrmit).
Cet exemple permet en plus de voir comment raliser autrement une pice de rvolution simple (par extrusion).

Exemple.2 ( Vis CHc M 10-20 )


Cet exemple permet en plus de voir comment raliser autrement une pice de rvolution peu complexe (par enlvement de la matire balayage).

Fonctions "avances" :

Comment lier les cotes d'une pice entre elles l'aide d'quations ? Comment lier une cote d'une pice celle d'une autre pice ?

Initiation

Volume par extrusion


Anane Zayed / 2006 Page: 5

Initiation

SolidWorks

Mthode de ralisation
Slectionner Plan1 dans l'arborescence ( droite). Menu Insertion - Esquisse ou Bouton . Le papier millimtr apparait alors. L'origine est au centre de l'cran. Se reporter la rubrique "Mthodes" pour voir en dtail ce qu'il faut faire avant de commencer l'esquisse. Tracer avec les Outils d'esquisse la forme extruder.

1. Il faut tout d'abord dessiner la surface de base partir de laquelle on va raliser le volume par extrusion : on va raliser une esquisse dans le plan de base OXY.
o

Si cette palette n'apparat pas, aller dans le menu Visualiser - Barre d'outil - Outils d'esquisse. Important : Plutt que de vouloir dessiner cette esquisse directement aux bonnes dimensions, crer d'abord la forme sans se soucier de la valeur des cotes. Une fois le profil dessin, coter la forme en laissant telles quelles les valeurs proposes : (menu Outils - Cotation - Parallle ou bouton . Une fois la cotation installe, ajouter les relations ncessaires (menu Outils - Relations Ajouter ou bouton . Une fois les relations dfinies, spcifier les bonnes valeurs pour chaque cote (doublecliquer sur la cote). Pour ne pas dformer exagrment le profil, il faut veiller ce qu'une cote A plus grande qu'une cote B ne devienne pas plus petite que cette cote B une fois la bonne valeur introduite. Il faut donc rduire d'abord les cotes les plus petites (la cote B par exemple), ou bien agrandir les cotes les plus grandes (la cote A).
o

Si la forme dessine n'est pas au bon endroit, slectionner tous les lments : bouton puis maintenir la touche CTRL enfonce et cliquer sur les diffrents lments dplacer. Relcher la touche CTRL et dplacer les lments avec la souris. (Attention, si vous maintenez la touche CTRL enfonce pendant le dplacement, vous allez faire une copie des lments).

2. Raliser le volume par extrusion :


o o o

Sortir du mode esquisse en cliquant sur . Slectionner l'esquisse en cliquant sur "Esquisse1" dans l'arbre ( gauche du cadre dessin). Cliquer sur ou menu Insertion - Base - Extrusion. Donner la valeur de la hauteur que doit avoir le volume. Application .2 :exemple de ralisation d'une forme oblongue extrude

Initiation SolidWorks

Volume de rvolution Mthode de ralisation


Anane Zayed / 2006 Page: 6

Initiation

1. Il faut tout d'abord dessiner le profil de rvolution partir duquel on va raliser le volume 3D en faisant tourner ce profil autour d'un axe. Il faut donc tout d'abord raliser une esquisse dans le plan de base OXY.
o

Slectionner Plan1 dans l'arborescence ( droite). Menu Insertion - Esquisse ou Bouton . Le papier millimtr apparat alors. L'origine est au centre de l'cran. Se reporter la rubrique "Mthodes" pour voir en dtail ce qu'il faut faire avant de commencer l'esquisse. Tracer avec les Outils d'esquisse le profil de rvolution.

Si cette palette n'apparat pas, aller dans le menu Visualiser - Barre d'outil - Outils d'esquisse. Important : Plutt que de vouloir dessiner cette esquisse directement aux bonnes dimensions, crer d'abord la forme sans se soucier de la valeur des cotes. Une fois le profil dessin, coter la forme en laissant telles quelles les valeurs proposes : (menu Outils - Cotation - Parallle ou bouton . Une fois la cotation installe, ajouter les relations ncessaires (menu Outils - Relations Ajouter ou bouton . Une fois les relations dfinies, spcifier les bonnes valeurs pour chaque cote (doublecliquer sur la cote). Pour ne pas dformer exagrment le profil, il faut veiller ce qu'une cote A plus grande qu'une cote B ne devienne pas plus petite que cette cote B une fois la bonne valeur introduite. Il faut donc rduire d'abord les cotes les plus petites (la cote B par exemple), ou bien agrandir les cotes les plus grandes (la cote A). Tracer l'axe, autour duquel on fera tourner le profil pour gnrer la forme 3D, en utilisant dans les Outils d'esquisse la ligne de construction.

o o

Si la forme dessine n'est pas au bon endroit, slectionner tous les lments : bouton puis maintenir la touche CTRL enfonce et cliquer sur les diffrents lments dplacer. Relcher la touche CTRL et dplacer les lments avec la souris. (Attention, si vous maintenez la touche CTRL enfonce pendant le dplacement, vous allez faire une copie des lments). 2. Raliser le volume de rvolution :
o o o

Sortir du mode esquisse en cliquant sur . Slectionner l'esquisse en cliquant sur "Esquisse1" dans l'arbre ( gauche du cadre dessin).

Cliquer sur ou menu Insertion - Bossage - Rvolution. Donner l'angle (en gnral 360). 3. On peut ensuite utiliser les fonctions chanfrein ou cong pour casser ou arrondir les angles, ce qui permet de na pas avoir raliser une esquisse trop complexe. Appliction.2 :exemple de ralisation d'une forme de rvolution.

Initiation

SolidWorks

Comment faire un plan 2D partir d'un fichier 3D ?


(Pice ou Assemblage)
Mise en plan, choix des vues, mise en page, coupes, cotation, modification du dessin 2D...

Initiation

Anane Zayed / 2006

Page: 7

La Mise en Plan

Fonds de plan Pour faire des mises en plan, il est tout d'abord ncessaire d'avoir des fonds de plan pour y projeter les dessins. Ces fonds de plans ont un format (A4, A3, ...), une orientation (portrait ou paysage) et contiennent ventuellement un cartouche. Un certain nombre de fonds de plan de base sont proposs l'origine, mais il est prfrable, avant de commencer, de personnaliser les fonds en plan que l'on utilisera par la suite, moins que vous ne les ayez dj en mmoire sur votre disque dur. Si vous avez les bons fonds de plan, vous pouvez commencer la mise en plan :

Prparation de la feuille et du cartouche


o o

Ouvrir le fichier correspondant la pice mettre en plan. Faire une nouvelle mise en plan : menu Fichier Nouveau et cliquer sur Mise en Plan.

Dans la bote de dialogue qui s'affiche, slectionner fond de plan personnalis, cliquer sur Parcourir et choisir le fichier correspondant au format souhait. Dans cet exemple nous choisissons lsp_A3V.slddrt pour faire une mise en plan au format A3 horizontal. Cliquer avec le bouton de droite de la souris n'importe o sur la feuille et slectionner diter le fond de plan. Cliquer avec le bouton de droite de la souris sur chaque cadre texte du cartouche qui doit tre modifi et slectionner Proprit pour adapter le texte. o Cliquer avec le bouton de droite de la souris n'importe o sur la feuille et slectionner diter la feuille pour sortir de la modification du fond. o Vrifier que le mode de projection est celui utilis en Europe : cliquer avec le bouton de droite de la souris n'importe o sur la feuille et slectionner Proprits et slectionner Europe pour le Type de projection. Insertion de la pice o La pice ayant t pralablement charge, on peut visualiser la fentre de cette pice et celle de la mise en plan simultanment : Menu Fentre - Mosaque horizontale.
o

Attraper la pice dans l'arbre de cration de la pice et la faire glisser sur la feuille de l'arbre de cration de la mise en plan. On obtient alors trois vues 2D standards. Agrandir la fentre de la mise en plan, afin de pouvoir y travailler plus facilement. Choix et mise en place des vues o Les vues proposes n'tant pas forcment les bonnes, commencer par supprimer celle(s) dont on ne veut pas : slectionner la vue (cliquer sur le bord, dans la zone grise : le cadre vert avec les poignes doit s'afficher ; ou bien cliquer dans l'arbre de cration) et taper sur la touche Suppr. o Dplacer les vues pour les placer au bon endroit.
o

Initiation

Anane Zayed / 2006

Page: 8

Pour crer une vue supplmentaire : slectionner la vue partir de laquelle la vue

supplmentaire va tre dfinie, puis cliquer sur le bouton et placer la vue sur la feuille. Mise en place d'une coupe o Il faut tout d'abord dfinir la coupe avec une ligne de construction. Dans les Outils
o

d'esquisse cliquer sur et tracer la ligne de coupe. Transformer cette ligne de construction en ligne de coupe : menu Insertion - Changer en ligne de coupe. Si la direction de coupe n'est pas la bonne, cliquer avec le bouton de droite de la souris sur la ligne de coupe, choisir Proprits et slectionner Changer la direction de la coupe/section.

Faire la coupe en cliquant sur le bouton et la positionner au bon endroit sur la feuille. Cotation o Pour importer dans la mise en plan la cotation qui a t faite sur la pice, il faut importer cette cotation : menu Insertion - Objet du modle... ,choisir Cotes. On peut aussi ce niveau importer, par exemple, les reprsentations de filetage ou les spcifications gomtriques (annotations). Modifications de la mise en plan o Il ne reste plus qu' modifier manuellement les vues et la cotation si besoin est.
o

Initiation SolidWorks

Crer ses propres fonds de plan

Nous allons voir ici comment crer ses propres fonds de plan, afin de pouvoir ultrieurement les utiliser pour faire des mises en plan. 1. Faire une nouvelle mise en plan : menu Fichier Nouveau et cliquer sur Mise en Plan.

Dans la bote de dialogue qui s'affiche, slectionner fond de plan personnalis, cliquer sur Parcourir et choisir le fichier correspondant au format souhait. Dans cet exemple nous choisissons temp_a3.slddrt pour faire une mise en plan au format A3 horizontal. Initiation Anane Zayed / 2006 Page: 9

Note : les fichiers temp_a.slddrt, temp_b.slddrt, temp_c.slddrt, temp_d.slddrt et temp_e.slddrt sont des fonds de plan avec cartouche primprims en anglais modifier et les fichiers temp_a0.slddrt, temp_a1.slddrt, temp_a2.slddrt, temp_a3.slddrt, temp_a4v.slddrt et temp_a4h.slddrt sont des fonds de plan avec cartouche vides modifier.

2. Cliquer avec le bouton de droite de la souris n'importe sur la feuille et slectionner Editer le fond de plan. Slectionner le cadre texte qui se trouve au milieu de la feuille et appuyer sur la touche Suppr du clavier pour supprimer ce texte inutile. 3. En utilisant le bouton pour crire les textes et les outils d'esquisse pour tracer les traits, personnaliser le cartouche (mme type de travail qu'avec les esquisses). 4. Cliquer avec le bouton de droite de la souris n'importe o sur la feuille et slectionner diter la feuille pour sortir de la modification du fond. 5. Vrifier que le mode de projection est celui utilis en Europe : cliquer avec le bouton de droite de la souris n'importe o sur la feuille et slectionner Proprits et slectionner Europe pour le Type de projection. 6. Sauvegarder le fond de plan ainsi cr : menu Fichier - Enregistrer le fond de plan.... Dans la bote de dialogue qui s'affiche, slectionner fond de plan personnalis, cliquer sur Parcourir et taper le nom de fichier. Dans cet exemple Chape(3)_A4V.SDLDRT.

Initiation

Anane Zayed / 2006

Page: 10