Vous êtes sur la page 1sur 4

BENEMRITA UNIVERSIDAD AUTNOMA DE PUEBLA

PREPARATORIA 2 DE OCTUBRE DE 1968

ALGORTIMOS PSEINT

PROFESORA MINERVA GOMEZ MARCOS

ALUMNO

Campos Pavn Hebert Emmanuel

3 D Matutino Agosto 2013

1.- Escribir un programa que pregunte el ao actual y la edad de esa persona en el ao 2015. Datos de entrada: Edad, ao actual, constante 2015 Datos de salida: Edad nueva 1 Proceso sin_titulo 2 Escribir "dame tu edad"; 3 Leer edad; 4 Escribir "dame el ao actual"; 5 Leer A_actual; 6 edadfinal<-(2015-A_actual)+edad; 7 Escribir "tu edad en el 2015 ser:',edadfinal 8 FinProceso

2.- El seor Snchez tiene una tienda de autoservicio y requiere un programa que tras de preguntar el nmero de almacn asociado a un determinado tipo de pieza, la cantidad perdida de esa pieza y el precio por unidad, efectu el clculo total de las piezas perdidas. El programa deber escribir toda la informacin de la pieza en la pantalla, adems del importe total del pedido.

Datos de entrada: Numero de almacn, nombre de la pieza, cantidad de piezas requeridas, precio de la pieza, clave de la pieza. Datos de salida: Nombre de la pieza, cantidad de piezas, precio individual de la pieza, precio total de las piezas, numero de clave. 1. 2. 3. 4. 5. 6. 7. 8. 9. Proceso sin_titulo Escribir "Numero de almacen"; Leer Nalmacen; Escribir "Dame el nombre de la pieza"; Leer Npieza; Escribir "Cantidad de piezas requeridas"; Leer Cpiezas; Escribir "Dame el precio"; Leer Precio;

10. 11. 12. 13. 14. 15. 16. 17. 18.

Totalprecio<- (Cpiezas*precio); Escribir "Dame clave"; Leer Clave; Escribir "Nombre:', Npieza; Escribir "Cantidad:', Cpiezas; Escribir "Precio de pieza:', Precio; Escribir "total:', Totalprecio; Escribir "N de clave:',Clave; FinProceso

3.- Mara trabaja en un caf, le pagan por comisin dependiendo cuantas bebidas sirve es su turno de 8 horas. Cada bebida se la pagan a $3.00 y necesita saber cunto le van a pagar si el administrador le dijo que va a recibir un pago extra del 15% sobre el total del pago, el dia de la fiesta de disfraces. Elabora un algoritmo que determine cul sera su pago total ese dia de fiesta, en base a las bebidas que sirva. Datos de entrada: numero de bebidas servidas, costo de cada bebida, aumento de porcentaje en el salario Datos de salida: Salario sin aumento, salario con aumento 1. 2. 3. 4. 5. 6. 7. 8. 9. 10. 11. 12. 13. Proceso sin_titulo Escribir "Dame el numero de bebidas servidas"; Leer numbebidasservidas; Escribir "Dame el costo de cada bebida"; Leer costobebida; Totalprecio<- (numbebidasservidas*costobebida) Escribir "Salario total sin aumento:', Totalprecio; Escribir "Dame el aumento al salario sin el signo de porcentaje" Leer aumento; Totalconaumento<- (Totalprecio*aumento/100+Totalprecio) Escribir "Salario total con aumento:" Escribir Totalconaumento; FinProceso

4.- En un restaurante se van a cambiar los manteles de las mesas, para ello solo se solicita la medida de los dimetros de los manteles requeridos los cuales son redondos. Crear un programa que pueda calcular cuntos metros cuadrados se necesitan para determinado nmero de mesas. Datos de entrada: Nuemero de mesas, medida del dimetro de los manteles en centmetros Datos de salida: Metros requeridos 1. 2. 3. 4. 5. 6. 7. 8. 9. Proceso sin_titulo Escribir "Dame el numero de mesas" Leer nummesas Escribir "Dame medida del diametro de los manteles en centimetros" Leer diametromanteles Metrosrequeridos<- (diametromanteles/2*diametromanteles/2*3.1416/100*nummesas) Escribir "Metros cuadrados requeridos" Escribir Metrosrequeridos; FinProceso