Vous êtes sur la page 1sur 3

Λύσεις Θεμάτων Ενιαίων Λυκείων 2004

ΘΕΜΑ 1ο
Α. 1 – Σ, 2 – Σ, 3 – Λ, 4 – Σ, 5 – Λ
Β. 1 – β, δ
2 – α, γ
Γ. 1. Αληθής
2. Αληθής
3. Ψευδής
4. Ψευδής
Δ. 1. Τρεις (3) επαναλήψεις
2. Καμία (0) επανάληψη
3. Μία (1) επανάληψη
4. Τέσσερις (4) επαναλήψεις
Ε. Σχ. Βιβλίο, παρ. 9.2, σελ. 191
ΣΤ. Σχ. Βιβλίο, παρ. 10.3, σελ. 208-209

ΘΕΜΑ 2ο

A B Lmin Lmax min max


1η επανάληψη 2 5 2 5 2 5
2η επανάληψη 15 -1 -1 15 -1 15
3η επανάληψη 32 14 14 32 -1 32
Έξω από την επανάληψη: D = -32

ΘΕΜΑ 3ο
Αλγόριθμος Ταχυδρομείο
Διάβασε Β, Π
Αν Π = “ΕΣ” τότε
Αν Β <= 500 τότε
Χ ←2
αλλιώς_αν Β <= 1000 τότε
Χ ← 3,5
αλλιώς
Χ ← 4,6
Τέλος_αν
αλλιώς
Αν Β <= 500 τότε
Χ ← 4,8
αλλιώς_αν Β <= 1000 τότε
Χ ← 7,2
αλλιώς
Χ ← 11,5
Τέλος_αν
Τέλος_αν
Εμφάνισε Χ
Τέλος Ταχυδρομείο
Λύσεις στα Θέματα πανελλαδικών Ενιαίων Λυκείων 2004 - panosgn@yahoo.com - Σελίδα 1 από 3
ΘΕΜΑ 4ο
Αλγόριθμος Ολυμπιάδα Αλγόριθμος Ολυμπιάδα
!Εισαγωγή των πινάκων (α) ερώτ.
Για i από 1 μέχρι 500
!Εισαγωγή των πινάκων Διάβασε name[i]
Για i από 1 μέχρι 500 Τέλος_επανάληψης (β) ερώτ.
Διάβασε name[i] Για i από 1 μέχρι 500
Για j από 1 μέχρι 3 Για j από 1 μέχρι 3
Διάβασε ΒΑΘ[i, j] Διάβασε ΒΑΘ[i, j]
Τέλος_επανάληψης Τέλος_επανάληψης
Τέλος_επανάληψης Τέλος_επανάληψης (γ) ερώτ.

!Υπολογισμός και αποθήκευση σε πίνακα !Υπολογισμός του ΜΟ κάθε μαθητή


του μέσου όρου κάθε μαθητή Για i από 1 μέχρι 500
Για i από 1 μέχρι 500 ΜΟ[i] ← 0
sum ← 0 Τέλος_επανάληψης
Για j από 1 μέχρι 3 Για i από 1 μέχρι 500
sum ← sum+ΒΑΘ[i, j] Για j από 1 μέχρι 3
Τέλος_επανάληψης ΜΟ[i] ← ΜΟ[i] +ΒΑΘ[i, j]
ΜΟ[i] ← sum/3 Τέλος_επανάληψης
Τέλος_επανάληψης Τέλος_επανάληψης
Για i από 1 μέχρι 500
ΜΟ[i] ← sum/3
Τέλος_επανάληψης
!Ταξινόμηση των πινάκων !Ταξινόμηση των πινάκων
Για i από 2 μέχρι 500 Για i από 2 μέχρι 500
Φθίνουσα
Για j από 500 μέχρι i με_βήμα -1 Για j από 500 μέχρι i με_βήμα -1
ταξινόμηση
Αν (ΜΟ[j]>MO[j-1]) ή Αν (ΜΟ[j-1]<MO[j]) τότε
(ΜΟ[j]=MO[j-1] και Αντιμετάθεσε ΜΟ[j], MO[j-1]
name[j] < name[j-1]) τότε Αντιμετάθεσε name[j], name[j-1]
Αντιμετάθεσε ΜΟ[j], MO[j-1] Αλλιώς
Αν ισοβαθμία
Αντιμετάθεσε name[j], name[j-1] Αν ΜΟ[j]=MO[j-1] τότε
Τέλος_αν Αν name[j-1] > name[j]) τότε
Τέλος_επανάληψης Αντιμετάθεσε name[j], name[j-1]
Τέλος_επανάληψης Τέλος_αν
Τέλος_αν
Τέλος_αν Δε χρειάζεται να αντιμεταθέ-
Τέλος_επανάληψης σουμε τους ΜΟ αφού είναι ίσοι
!Εμφάνιση αποτελεσμάτων και Τέλος_επανάληψης
υπολογισμός ερωτήματος ε
Π ←0 !Εμφάνιση αποτελεσμάτων ερώτ.(δ) και ερώτ.(ε)
Για i από 1 μέχρι 500 Π ←0
Εμφάνισε name[i], MO[i] Για i από 1 μέχρι 500
!Το ΜΟ[1] θα είναι το μέγιστο, Εμφάνισε name[i], MO[i]
λόγω ταξινόμησης !Το ΜΟ[1] θα είναι το μέγιστο
Αν ΜΟ[i]=ΜΟ[1] τότε Αν ΜΟ[i]=ΜΟ[1] τότε
Π ← Π+1 Π ← Π+1
Τέλος_αν Τέλος_αν
Τέλος_επανάληψης Τέλος_επανάληψης
Εμφάνισε Π Εμφάνισε Π
Τέλος Ολυμπιάδα Τέλος Ολυμπιάδα

Λύσεις στα Θέματα πανελλαδικών Ενιαίων Λυκείων 2004 - panosgn@yahoo.com - Σελίδα 2 από 3
Λύσεις στα Θέματα πανελλαδικών Ενιαίων Λυκείων 2004 - panosgn@yahoo.com - Σελίδα 3 από 3