Vous êtes sur la page 1sur 17

- TP6 -

Formation
ARCGIS Desktop 9.3.1

- Analyse spatiale en mode raster -

- Modlisation de processus
avec ModelBuilder -





Objectifs :

- Identifier un site appropri limplantation dun nouvel tablissement scolaire.
- Identifier le trac optimum pour la construction dune route reliant la nouvelle
cole un point de la zone.
- Dfinir le processus didentification multi-critres du site.
- Savoir utiliser les outils de Spatial Analyst et Model Builder pour rpondre au
problme.














2010 2011

ArcGis 9.3.1 - 3 - TP6
Analyse spatiale en mode raster avec "Spatial Analyst"

Suite une augmentation de sa population, la ville de Stowe, Vermont (Etats-Unis) demande ses
services municipaux didentifier le meilleur site pour construire une nouvelle cole, ainsi quune
nouvelle route reliant le site un point de la zone.

Examen des donnes disposition

1. Ouvrez ArcCatalog et prenez connaissance de ces diffrentes donnes que vous trouverez dans
le dossier "TP6").

Afin de trouver le meilleur site, il convient de prendre en compte un certain nombre de
paramtres. Ci-dessous, les donnes que vous allez exploiter :

- Un MNT au format ESRI GRID (raster) : elevation
- Loccupation du sol au format ESRI GRID (raster) : landuse
- La localisation des coles existantes au format Shapefile (vecteur) : schools.shp
- La localisation des sites dactivits de plein air au format Shapefile (vecteur) : rec_sites.shp
- Le rseau de routes au format Shapefile (vecteur) : roads.shp

Activation de lextension Spatial Analyst, chargement des donnes et paramtrage

2. Activez ArcMap, allez dans le menu "Outils/Extensions" puis :







Cochez l'extension "Spatial
Analyst" pour activer sa licence.
Allez dans le menu "Affichage >
Barre d'outils" et cochez
l'extension "Spatial Analyst" pour
afficher sa barre d'outils.
ArcGis 9.3.1 - 4 - TP6

3. Chargez les donnes suivantes dans ArcMap :




Lutilisation de "Spatial Analyst" suppose un paramtrage pralable des informations suivantes :

- Rpertoire de travail (l o les calculs vont tre enregistrs),
- Extension gographique considrer pour les calculs : on sappuie sur le GRID "landuse",
- Rsolution des donnes raster qui vont tre calcules par le processus danalyse : on prend
la rsolution la plus grande parmi les jeux de donnes en entre (30m pour le MNT, 25m pour
loccupation du sol, donc 30m).


4. Dans le menu "Spatial Analyst" de la barre d'outils "Spatial Analyst", slectionnez "Options" :



Onglet "Gnral"
Dfinir le dossier "TP6"
comme rpertoire de travail.
Dfinir la couche "Landuse"
comme tendue d'analyse.
Onglet "tendue"
Dfinir la couche "elevation"
comme Onglet taille de
cellule d'analyse.
Slectionnez "Options".
Onglet "Taille de cellule"
ArcGis 9.3.1 - 5 - TP6

1
re
partie : identification des sites possibles
Cration des donnes drives

partir des donnes source, vous allez crer successivement :
- Un GRID de la pente ( partir du MNT)
- Un GRID de la distance aux coles existantes
- Un GRID de la distance aux quipements dactivits de plein air

En effet, on considre quun site est dautant plus appropri lorsquil a une pente minimale, quil est
suffisamment loign des coles existantes et proximit des quipements de loisirs.

5. Calculez le GRID de la pente en choisissant dexprimer les pentes en degrs. Crez un GRID
nomm "pente" qui est enregistr dans le rpertoire de travail dfini plus haut.



6. Calculez le GRID de distance aux coles existantes en crant un GRID temporaire. Celui-ci est
enregistr temporairement dans un rpertoire et sera effac la fermeture de la session ArcMap.



7. Calculez le GRID de distance aux quipements dactivits de plein air ("rec_sites") comme pour
les coles ci-dessus.
ArcGis 9.3.1 - 6 - TP6

Reclassification des donnes drives

Vous disposez maintenant des donnes directement utiles pour lidentification du site. Il vous reste
les combiner.

Pour ce faire, il faut tout dabord ramener les diffrents phnomnes mesurs sur une chelle
commune de valeurs. On choisit une chelle variant de 1 10, une valeur proche de 10 traduisant le
fait que le site convient parfaitement.

8. Pour reclasser le GRID de la pente, vous devez reclasser les donnes par la mthode des
intervalles gaux en 10 classes. Inversez ensuite la classification en attribuant la valeur 10 la
premire classe, 9 la seconde, etc.



9. Reclassez le GRID de distance aux coles existantes de la mme faon que prcdemment mais
sans inverser la classification.

10. Reclassez le GRID de distance aux quipements dactivits de plein air de la mme faon que
prcdemment mais en inversant la classification.

11. Pour le GRID doccupation du sol ("landuse"), il faut prendre en compte le cot de construction
sur certains sols ainsi que le cot dacquisition de certaines parcelles. Il est clair que certains
terrains sont plus appropris que dautres la construction dune cole. Les terrains de type
"Water" et "Wetland" sont dclars inconstructibles. Pour les autres, reclassez sur lchelle 1-10
en tenant compte du tableau ci-dessous :

Agriculture 10
Barren land 6
Brush/transitional 5
Built up 3
Forest 4
"Reclassification"
"Classement"
"Intervalles gaux
(nombre variable)"
10 classes
Inversez les valeurs (10 pour
la plage de pente minimale
jusqu' 1 pour la plage de
pente maximale).
ArcGis 9.3.1 - 7 - TP6

Pondration et combinaison des donnes

Pour ce faire, on utilise la calculatrice raster. Cet outil permet deffectuer tous types doprations sur
des GRID raster, dont les oprations arithmtiques lmentaires.

On pondre les 4 critres comme suit :

Distance aux quipements 0.5
Distance aux coles 0.25
Occupation du sol 0.125
Pente 0.125

12. Afin que lexpression valuer par la calculatrice raster soit correcte utilisez les boutons de
linterface pour saisir lexpression :




La premire partie est termine. Pour la suite de la recherche des sites optimums, vous allez
dcouvrir et exploiter l'application ModelBuilder.

Ne tapez rien au clavier (sauf "suitability").
Double-cliquez sur les couches raster pour les
faire apparatre dans la fentre de calcul. Pour
les oprateurs et les chiffres, un simple clic suffit.
Le rsultat va crer une couche raster que
vous nommerez "suitability". Si vous
n'crivez pas "[suitability] = ", le calcul se
fera quand mme et crera une couche
nomme "calcul" par dfaut.
ArcGis 9.3.1 - 8 - TP6

2
me
partie : Slection du site optimum avec Model Builder

Il est possible de concatner des squences doutils et dalimenter ainsi chaque outil avec les
rsultats dun autre. Vous pouvez utiliser cette fonctionnalit pour composer une varit de modles
de gotraitement (squences doutils) vous permettant dautomatiser votre travail, d'effectuer une
analyse et de rsoudre des problmes complexes.

ModelBuilder est une application permettant de composer une squence doprations sous forme de
modle pour lautomatisation du traitement des cartes et des donnes, ainsi que pour lanalyse.

13. Dans ArcToolBox, crez votre propre bote outils "Mes outils". l'intrieur de celle-ci, vous allez
crer un modle que vous nommerez "Site optimum" en procdant de la manire suivante :



14. Fermez le modle pour constater que son nom a bien chang dans la bote outils "Mes outils".
ditez nouveau ce modle qui se nomme maintenant "Site optimum" en faisant un clic-droit
dessus et en choisissant "Edition"
Clic-droit sur "ArcToolBox" puis
"Nouvelle bote outils".
Nommez la nouvelle bote
outils : "Mes outils".
Clic-droit sur "Mes outils" puis
"Nouveau > Modle".
Vous obtenez un
modle vierge.
Dans les proprits du modle, renommez celui-ci
"Site optimum".
Attention : c'est le champ "Etiquette" qui doit tre
rempli car c'est lui qui s'affiche dans la bote outils.
Le champ "Nom" n'accepte pas les espaces. Dans ce
champ, crivez plutt : "SiteOptimum".
ArcGis 9.3.1 - 9 - TP6

Pour la suite de l'exercice, il va falloir extraire tous les pixels du GRID "suitability" dont la valeur est
suprieure 8.5 et recoder tous ces pixels avec la valeur unique : 1. Voici comment procder :

15. Glissez loutil "Outils Spatial Analyst > Cration de rasters > Crer un raster constant" pour crer
un GRID la taille de la zone dtude et dont les pixels valent 1 et paramtrez-le comme ci-
dessous :



Ce premier traitement crera un raster "r1" avec une emprise gographique identique "suitability"
(comme celle des autres rasters) et dont les pixels seront tous cods 1.

16. Glissez loutil "Outils Spatial Analyst > Condition > Con" dans la fentre du modle "Site
optimum" pour extraire les pixels > 8.5 partir du GRID "suitability".

17. Double-cliquez sur l'outils "Con" (ce n'est pas un gros mot !) et paramtrez-le comme suit :



Le traitement conditionnel "Con" crera un GRID nomm "opt_sites" dans lequel, seuls les pixels du
GRID "suitability" valant plus de 8.5 auront t gards. Ils auront t recods 1.

Clissez l'outil dans la
fentre du modle
"Site optimum".
Double-cliquez sur l'outil
pour activer sa bote de
paramtrage.
Nommez le raster en
sortie "opt_sites".
Raster en sortie : "r1"
Valeur constante : 1
ArcGis 9.3.1 - 10 - TP6

Cela tant, pour construire une cole, il faut une zone dune certaine tendue : on recherche donc un
ensemble de pixels contigus de valeur 1 de taille suffisante.

Il va donc falloir r chantillonner le GRID "opt_sites" avec un pixel de 90m (en appliquant une fentre
de 3 pixels de ct, soit un carr de 9 pixels) : autrement dit, on va recoder chaque pixel en
considrant ses 8 voisins. Pour quun pixel soit recoder la mme valeur, il faudra que plus de la
moiti de ses voisins aient la mme valeur (1)

18. Glissez loutil " Outils Spatial Analyst > Gnralisation > Filtre majoritaire" et paramtrez-le
comme suit :



Le modle doit ressembler ceci :



Si vous faites tourner l'outil ce stade, le fichier "fopt_site" sera cr avec environ 188 pixels qui
satisferont la recherche. Le raster "fopt_sites" ne sera pas ajout au document ArcMap; il sera
enregistr dans le dossier "TP6".

ArcGis 9.3.1 - 11 - TP6

Vous pouvez distinguer, ci-dessous, les trois endroits principaux o seront reprsents, par des
taches sombres (rouge si votre document est en couleur), les sites optimiss dans "fopt_sites. Ces
taches, localises par les flches, sont montres en surimpression sur le fond du raster "suitability" :




La recherche peut tre affine en prenant en compte les 2 critres suivants :

Le site doit tre desservi par le rseau routier.
La superficie du site doit tre suprieure 4ha.


Pour ce faire vous allez convertir le GRID "fopt_sites" en entits vecteur avec loutil "conversion > A
partir d'un raster > Raster vers Polygones". partir de maintenant, vous allez conduire lanalyse en
mode vecteur. Les rsultats des gotraitements seront enregistrs sous forme de classe dentits de
godatabase.


19. Dans le dossier "TP6", crez une nouvelle godatabase personnelle "Nouveau_site" avec
ArcCatalog.

20. Dans votre modle "Site optimum", glissez l'outil "Outils de conversion > A partir d'un raster >
Raster vers Polygones", enregistrez le rsultat dans une classe nomme "site1".

On va ensuite ne conserver, parmi les polygones crs, que ceux desservis par le rseau de routes
en considrant quun site est desservi par le rseau de routes sil est situ moins de 30m dune
route.

21. Glissez la couche "roads" dans le modle pour crer une couche "roads2_C" avec loutil "Outils
de gestion de donnes > Couches et vues tabulaire > Gnrer un couche". Glissez une
deuxime fois le mme outil pour crer une couche "site1_C" partir de site1 dj prsent dans
le modle. Ces deux couches ("roads2_C" et "site1_C") sont obligatoires pour le paramtrage du
prochain outil (tape 22, page suivante).
Les sites possibles
dans "fopt_sites".
ArcGis 9.3.1 - 12 - TP6

22. Glissez loutil "Outils de gestion de donnes > Couches et vues tabulaire > Slectionner une
couche par emplacement" pour rcuprer une nouvelle couche "site2_C" qui ne gardera que les
sites moins de 30m d'une route. Paramtrage de l'outil ci-dessous :



23. Appliquez ensuite loutil "Outils de gestion de donnes > Gnralisation > Fusionner" pour
fusionner les polygones contigus de "site2_C". Dans cet outil, dcochez l'option "Crer des
entits multi-parties" (les objets seront indpendants les uns des autres). Nommez la classe
rsultat "site3". ce stade, la classe d'entits "site3" ne devrait pas contenir plus de 16 entits
polygones.

Il reste prendre en compte le critre de superficie : un examen de la table attributaire nous montrera
que deux sites seulement ont une taille suprieure 4ha. On va donc prendre le plus grand des deux.

24. Pour ce faire, appliquer loutil "Outils d'analyse > Extraire > Slectionner" qui permet deffectuer
une requte SQL sur une classe dobjets. Nommez la classe d'entits en sortie "site4".


[Shape_area] = (select max([Shape_Area]) FROM site3)
ArcGis 9.3.1 - 13 - TP6


Le modle final complet de slection du site le plus appropri doit ressembler ceci :





3
me
partie : identification dun trac optimum

Cration d'un modle d'analyse

25. Crez dans la bote doutils "Mes Outils" un nouveau modle "Route optimum".

Modlisation de la cration du GRID de cot

26. Dans le menu "Outils > Options > Gotraitement" de l'application ArcMap, paramtrez le dossier
de stockage des GRID calculs par Modelbuilder.

27. Glissez l'outil "Outils Spatial Analyst > Reclassement > Tranche" dans la fentre Modelbuilder de
"Route optimum".

28. Glissez le GRID de "pente" calcul prcdemment (avant reclassification en 10 classes) dans la
fentre Modelbuilder. Vous obtenez :



29. Connectez le GRID "pente" loutil "Tranche" laide du connecteur de la barre doutils de
Modelbuilder. Double-cliquez ensuite sur loutil "Tranche" et remplissez la bote de dialogue
comme suit (page suivante) :
Vous pouvez lancer la procdure avec ce bouton.
Bouton "Ajouter une connexion"
ArcGis 9.3.1 - 14 - TP6



30. Validez avec le bouton "OK". Le modle ressemble a



31. Glissez ensuite le GRID doccupation du sol "landuse" et l'outil "Outils Spatial Analyst >
Reclassement > Reclassification". Utilisez loutil "Reclassification" comme ci-dessous pour
reclasser le GRID sur lchelle 1-10 :


Les couleurs indiquent que le
modle est prt fonctionner.
ArcGis 9.3.1 - 15 - TP6


32. Utilisez ensuite les 2 GRID ainsi obtenues ("r_pente1" et "r_landuse1") avec loutil "Outils >
Spatial Analyst > Superposition > Superposition pondre. Nommez le GRID en sortie "cot".
Travaillez avec une chelle de valeurs allant de 1 10 et attribuez un poids identique aux 2 GRID



Le modle doit ressembler a :



On va maintenant ajouter au modle ltape de calcul du cot daccs au nouveau site scolaire depuis
chaque point de la zone tudie.

33. Glissez loutil "Outils Spatial Analyst > Distance > Distance de cot". Cet outil gnre 2 GRID : la
premire contient le cot cumul pour chaque pixel de chemin daccs de moindre cot lcole ;
la seconde donne la direction du chemin de moindre cot reliant chaque pixel au pixel prcdent.

Loutil "Distance de cot" ne peut traiter en entre que des GRID : il faut donc convertir la classe
d'entits "site4" qui contient le polygone vecteur reprsentant l'emplacement optimum de lcole en
GRID raster.

ArcGis 9.3.1 - 16 - TP6

34. Glissez la classe dentits "site4" et loutil "Outils de conversion > Vers Raster > Entit vers
raster". Connectez la couche "site4" cet outil et nommez le GRID rsultat r_site.

35. Connectez ensuite les GRID "r_site" et "cot" loutil "Distance de cot". Nommez les 2 GRID en
sortie "r_dist" et "r_back".



Le GRID de cot cumul a laspect suivant :



36. Cela tant, chargez dans ArcMap le fichier "destination.shp" qui situe lautre extrmit de la route
construire. Glissez cette couche dans le modle puis glissez l'outil "Outils Spatial Analyst >
Distance > Chemin de cot". Calculez le chemin de moindre cot reliant ce point au site scolaire
en rentrant les paramtres suivants :
ArcGis 9.3.1 - 17 - TP6



Le modle final "route optimum" doit ressembler a :



et le rsultat a :