Vous êtes sur la page 1sur 11

Tutoriel code::blocks

E. Lunville
2006

Le logiciel code::blocks fait partie des logiciels de type EDI (Environnement de Dveloppement Intgr,
IDE en anglais) pour le langage C++. Il est multiplateforme en particulier Windows et Linux. Il propose
dans une mme fentre :
la gestion dun projet C++ avec le suivi des chiers dentte et dimplmentation
la prise en compte de dirents modles de projet : console, graphique (winapi, qt, wxwidget)
un diteur avec mis en vidence de la syntaxe C++ , compltion de code et possibilit de le recongurer
un outil de mise en forme du code C++
un outil de visualisation et daccs rapide aux dirents composants du projet (fonction, classe, membre, enum, ...)
lappel intgr dirents compilateurs (par dfaut le compilateur GNU) avec possibilit de modier
les options de compilation et dexporter le makele
un debugger intgr permettant de tracer les variables
un outil de proling
une zone pour saisir des actions faire (to do list)
des outils dexport du code (HTML, RTF, ODT)
la possibilit de rajouter de nouvelles fonctionnalits plug-in
Cest un produit assez jeune sous licence GPL qui sadresse plutt au dveloppeur individuel. Il ny a pas
pour le moment doutil permettant de grer les versions.

Installation

Suivant la plateforme et le type de distribution linstallation dire. On trouve les direntes distributions
de code::blocks ladresse suivante (dernire version stable en novembre 2006 : 1.0 RC2) :
http://wiki.codeblocks.org/index.php?title=Compiled_packages_of_Code::Blocks
Ils existenr des versions dites SVN, qui sont les dernires versions. Depuis la version 1.0 RC2, de nombreuses
amliorations ont t introduites et linterface a beaucoup volu. Cest pourquoi il est prfrable dutiliser
ces versions en attendant la prochaine release candidate (RC3).
Il existe deux distributions pour Windows, la distribution sans compilateur et la distribution intgrant
le compilateur GNU gcc (distribution minGW). Les distributions sont des excutables Windows qui ne
soulvent aucune di cult particulire dinstallation; installer la version comprenant minGW si on ne dispose
pad du compilateur GCC sous Windows.
Il existe des distributions de binaires pour dirents linux : Gentoo, Fedora, Freebsd, Ubuntu, .... Attention,
sous linux, linterface graphique de code::blocks sappuie sur les bibliothques wxGTK quil faut donc se
procurer par ailleurs : http://dag.wieers.com/packages/wxGTK/.
1

Prise en main de code::blocks

Nous dcrivons dans ce qui suit un exemple dutilisation de Code::blocks. La version utilise est la SVN
3222 du 15 novembre 2006 sous Fedora core5 et Kde.
Une fois linstallation russie de code::blocks, vous le lancez et devez obtenir une fentre de ce genre :

La premire opration consiste crer un nouveau projet : soit en cliquant sur Create new project soit
en cliquant sur New project dans le menu File (raccourci clavier Ctl-Shift-n). Une fentre dialogue
New from template souvre et vous demande de choisir un modle de projet :

Il existe des modles prdnis de projets et on peut galement choisir de crer seulement des chier (.h,
.cpp). On choisit Application Console, une fentre nomme Application console souvre dans laquelle on
spcie le nom du projet et le dossier o il sera sauv :
2

ensuite souvre une fentre permettant de choisir le compilateur (par dfaut GNU GCC) et les versions qui
seront gnres, par dfaut Debug (permettant de faire du suivi dexcution) et Release (version sabs option
de dbogage) :

Enn, on dcide si lon dveloppe une application C ou C++ :

Par dfaut, des chiers sont cres (leur nombre dpendant du modle de projet). Pour une application
console, seul un chier main.cpp minimaliste est cr (programme "Hello word!"). Dans le volet Project
apparat larborescence Workspace des projets et en particulier celui qui vient dtre cr. En cliquant sur
le chier source main.cpp, ce dernier est a ch dans une fentre centrale ddition avec mis en vidence de
la syntaxe C++ :

On peut modier le code source de faon immdiate avec des actions standards dun diteur souris. A tout
moment le projet peut tre sauv en cliquant sur licone reprsentant une disquette ou ouvrir le menu File
qui ore plusieurs commandes de sauvegarde.
A ce stade, le projet peut dj tre compil et excut. Pour le compiler, il su t de cliquer sur la commande
Build du menu Build (raccourci clavier Ctl-F9) qui va enchainer les oprations de compilation et ddition
de liens, gnrant ainsi un chier excutable (essai.exe dans notre exemple) ;
4

Les ventuels avertissements, messages derreur et ltat nal du processus de compilation apparaissent
dans longlet Build log situ en bas :

Lorsquil y a des erreurs, longlet Build messages indique les lignes en cause et en cliquant sur le message
derreur on est positionn dans lditeur sur la ligne en cause :

Pour excuter le code, il su t de cliquer sur la commande Run du menu Build (raccourci clavier Ctl-F10),
une fentre dxcution souvre alors (application console) :

On peut enchainer la compilation et lexcution en cliquant sur la commande Build & Run du menu Build
(raccourci clavier F5).
Code::blocks ore des possibilits de dbogage interactives. Il faut tout dabord placer au moins un point
darrt sur une des lignes du code, soit en cliquant sur la colonne de gauche, soit en invoquant le menu
contextuel (click bouton de droite) et en cliquant sur Toggle breakpoint au niveau de la ligne de code;
un point rouge devrait apparatre :

Ensuite on lance lexcution du programme laide de la commande Start du menu Debug :

le programme sarrte sur la premire ligne rencontre qui possde un point darrt (un curseur apparat) :

A ce stade, on peut consulter le contenu des variables actives dans la fentre Watches que lon fait
apparatre en cochant la case Watches dans le menu Debugging windows :

La fentre Watches fournit par dfaut le contenu des variables actives et on peut en rajouter dautres
laide du menu contextuel de lditeur :

On peut drouler lexcution suivant dirents modes : commandes Step over (F7), Step into ( Shift-F7)
ou Step out (Ctl-Shift-F7) et Abort du menu Debug ou via les boutons daccs rapide :

Principales fonctionnalits

Nous ne dcrivons que les grandes lignes et invitons le lecteur les explorer en dtail par lui mme.

3.1

Menu chier

Le menu File propose les actions usuelles relatives aux chiers ainsi que le actions dimpression et dexport
de projet ( HTML, RTF,ODT et PDF).

3.2

Menu Edit

Le menu Edit propose les actions attaches lditeur du code :

auto-compltions de code, passer du chier dimplmentation au chier entte, poser des marqueurs, (d)commenter,
...

3.3

Menu Search

Le menu Search permet deectuer des oprations de recherche, de dplacement rapide et de remplacement
:

3.4

Menu View

Ce menu permet de grer les direntes fentres actives de lenvironnement :

3.5

Menu Settings

Le menu Settings permet de rgler dirents comportements de lenvironnement. Il se divise en 4 catgories


:

3.5.1

Menu Environnement

Ce menu ouvre une fentre proposant les rglages gnraux de lenvironnement qui de dcompose en divers
rglages, dont le choix des polices des fntres de message, la taille des icones, lactivation des sauvegardes
automatiques, ... :

3.5.2

Menu Editor

Le menu Editor permet de rgler divers paramtres de lditeur de code C++, avec entre autres : le choix de
la police de lditeur, les couleurs des syntaxes C++, la dnition des abrviations, les rgles de compltion
de codes, les raccourcis clavier, le choix de la mise en forme automatique du code, ...

3.5.3

Menu Compiler and Debugger

Ce menu permet de prciser les paramtres du compilateur et du debogueur qui seront appliqus par dfaut. On y trouve la plupart des options du compilateur et la possibilit den activer dautres, la possibilitdindiquer des librairies externes,... La fentre lie au debogueur permet dactiver la possibilit de
voir le contenu dune variable du code lors du survol la souris en mode debug et da cher la fentre ou
apparaissent tous les messages de debogueur.

3.5.4

Menu Global Variable

Ce menu permet de dnir des variables internes Code::blocks pouvant tre utiles par le compilateur.

10

3.6

Barre daccs rapide

La barre dicones propose sous forme de boutons les actions les plus utilises :

dont la signication sa che lorsque la souris les survole : Nouveau projet, Nouveau chier, Ouvrir un
projet ou un chier, Sauver les modications, Dfaire, Refaire, Couper, Copier, Coller, Rechercher dans un
ou plusieurs chiers, Remplacer dans le chier courant, Construire (compiler le projet), Excutere, Stopper la
construction ou lexcution, Un champ indiquant la cible de construction, Continuer (mode debug), Excuter
jusquau curseur (mode debug), Avancer sans rentrer dans les fonctions( step over du mode debug), Avancer
en rentrant dans les fonctions (step in du mode debug), Sortir dune fonction (step out du mode debug),
Stopper le mode debug.

Fichiers daide

Par dfaut, code::blocks nore pas de documentation C++ en ligne. Dans le menu Settings -> Environment -> Help les il est possible den ajouter, par exemple celle de BorlandC++ sous windows si on
la ! Sinon, on peut toujours utiliser une aide sur internet, par exemple celle, trs complte, de C. Casteyde :
http://casteyde.christian.free.fr/cpp/cours/online/book1.html. Il est possible de lappeler directement depuis
code::blocks depuis le menu Tools en ajoutant un nouvel outil (commande Congure tools ... dans le
menu Tools).
On trouvera des informations relatives Code::blocks ladresse suivante :
http://wiki.codeblocks.org/index.php?title=Special:Allpages.

11