Vous êtes sur la page 1sur 2

Comment migrer les fichiers hyper files 7 en une base MySql ?

Voici la procdure permettant de transformer les fichier Hyper File 7 en tables


MySQL.
Etape 1
Dfinir, si besoin, dans MySQL la database qui va acceuillir les nouvelles tables.
Etape 2
Dans l`analyse du projet, modifier le type des fichiers (onglet "Info" dans la fentre
"Description du fichier"). Remplacer "Hyper File 7" par "Accs natif / Autres accs
OLEDB". Si elle n`existe pas, vous devrez dcrire une connexion vers MySQL et la
slectionner. Valider et gnrer l`analyse.
Etape 3
Pour la cration des tables MySQL, utiliser la commande Hcration() ou
HCrationSiInexistant().
Exemple: HCrationSiInexistant(Cedex)
Etape 4
Transfert des donnes HF7 vers les tables MySQL correspondantes. Cette tape est
ralise par le code suivant:
// Transfert des donnes du fichier HF7 Cedex
// vers la table MySQL Cedex
// Rpertoire du fichier
RpertoireHF7 est une chane "F:Mes ProjetsprojetExe"
// Fichier HF7
CedexHF7 est une Source de Donnes
// Ouvre une connexion HF7
SI HOuvreConnexion("ConnectionHF7", "", "", RpertoireHF7, "", hAccsHF7) ALORS
// Dfinition d`un alias qui permettra d`utiliser
// la commande HCopieEnreg
SI HAlias(Cedex,CedexHF7) ALORS
// L`alias est redirig vers la connexion HF7
HChangeConnexion(CedexHF7,"ConnectionHF7")
// Ncessaire car le fichier physique s`appelle CEDEX
HChangeNom(CedexHF7,"Cedex")
// Boucle de lecture avec transfert des enregistrements de HF vers MySQL
HLitPremier(CedexHF7)
TANTQUE PAS HEnDehors()
Trace(CedexHF7.Ville)
HRAZ(Cedex)
SI HCopieEnreg(Cedex,CedexHF7,"","",hCopieIdAuto) ALORS
HAjoute(Cedex)
FIN

HLitSuivant(CedexHF7)
FIN
SINON
Erreur(HErreurInfo())
FIN
SINON
Erreur(HErreurInfo())
FIN