Vous êtes sur la page 1sur 3

FICHE 18 : LES RELATIONS ENTRE LES TABLES

1. CRER UNE RELATION ENTRE DEUX TABLES


ACCESS peut grer une relation entre 2 tables dune mme base de donnes. Cette relation vous permettra daccder
des enregistrements partir dune valeur dun champ.
Par exemple, une relation entre une table des commandes et une table des clients permettra dobtenir partir de la
valeur du champ N client de la table COMMANDE le nom du client situ dans la table des clients.
REMARQUE : les champs utiliss, pour relier les deux tables, doivent avoir le mme type de donnes.
Pour crer une relation entre 2 tables :
-

Ouvrez la base de donnes contenant les 2 tables relier. Son contenu doit tre affich lcran.

Cliquez dans le menu Outils la commande Relations ou cliquez sur le bouton


liste des tables cres.

Si vous voulez en plus afficher les requtes, cliquez longlet Les deux. Dans la liste des tables, cliquez le nom de la
premire table relier puis cliquez le bouton Ajouter. Faites de mme pour la deuxime table de la relation.

Cliquez le bouton Fermer. Les tables apparaissent cte cte.

AUTEUR : KARINE PETIT

. Une fentre apparat donnant la

Dans la premire table, cliquez le champ qui est en commun avec lautre table et faites le glisser vers son
homonyme dans lautre table. Une fentre souvre o vous pourrez ventuellement choisir des options cette
relation. Cochez Appliquer lintgrit rfrentielle (permet de vrifier que les donnes communes aux 2 tables ont le
mme type de donnes).

AUTEUR : KARINE PETIT

Cliquez le bouton Crer. Les deux tables rapparaissent, la relation entre elles est schmatise par un trait les
reliant.

Cliquez dans le menu Fichier la commande Enregistrer puis Fermer pour revenir la fentre principale.

2. SUPPRIMER UNE RELATION ENTRE DEUX TABLES


-

Ouvrez la base de donnes contenant les 2 tables relies.

Cliquez dans le menu Outils la commande Relations. Une nouvelle fentre souvre.

Les relations cres apparaissent. Cliquez le trait schmatisant la relation supprimer. Celui ci doit apparatre en
gras.

Appuyez sur la touche Suppr du clavier.

Cliquez la commande Fermer du menu Fichier pour revenir la fentre principale.

AUTEUR : KARINE PETIT