Vous êtes sur la page 1sur 5

Configuration d'une borne Wifi

sous ios de cisco


Prambule :
Le Wi-Fi est un ensemble de protocoles de communication sans fil rgis par les
normes du groupe IEEE 802.11 (ISO/CEI 8802-11). Un rseau Wi-Fi permet de
relier par ondes radio plusieurs appareils informatiques au sein d'un rseau
informatique afin de permettre la transmission de donnes entre eux.
Pr-requis :
Voici les diffrents services qui seront ncessaires au dploiement de cette
configuration :

DHCP (Dynamic Host Configuration Protocol)

Ce tutoriel vous guidera travers la configuration en accs simple ou en AP Wifi


avec Multi-SSID (mbssid) d'une borne wifi sous ios de cisco.
Dynamic Host Configuration Protocol (DHCP) est un protocole rseau dont le rle
est dassurer la configuration automatique des paramtres IP dune station,
notamment en lui affectant automatiquement une adresse IP et un masque de
sous-rseau.
Explication AP Wifi avec Multi-SSID :

Comme on peut le remarquer notre AP wifi est connect au switch via un seul
cble. Mais elle diffuse deux noms de rseau diffrents, chaque nom diffus
appel SSID est connect un rseau virtuel diffrent (rseau virtuel appel
aussi Vlan).

I. Configuration basic de la borne WiFi (accs simple


wifi)
ap(config)#interface bvi1
ap(config-if)#ip address dhcp
ap(config-if)#no shut
ap(config-if)#exit
ap(config)#dot11 ssid BTS-LM
ap(config-ssid)#authentication open
ap(config-ssid)#guest-mode
ap(config-ssid)#exit
ap(config)#interface dot11Radio 0
ap(config-if)#ssid BTS-LM
ap(config-if)#encryption mode wep mandatory
ap(config-if)#encryption key 1 size 128bit 01234567890123456789abcdef
ap(config-if)#no shut

II. Configuration AP Wifi avec Multi-SSID (mbssid)


1. Configuration du Switch
Creation des VLANs
Switch#conf ter
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#vlan 101
Switch(config-vlan)#name WiFi-Stade
Switch(config-vlan)#exit
Switch(config)#vlan 12
Switch(config-vlan)#name Equipes
Switch(config-vlan)#exit
Switch(config)#interface fastEthernet 0/6
Switch(config-if)#switchport access vlan 101
Switch(config-if)#no shut
Switch(config-if)#exit
Switch(config)#
Switch(config)#interface fastEthernet 0/2
Switch(config-if)# switchport access vlan 12
Switch(config-if)#no shut
Switch(config-if)#exit
Switch(config)#

Creation des ports trunk


Switch(config)#interface fastEthernet 0/23 - 24
Switch(config-if-range)#switchport mode trunk
Switch(config-if-range)#no shut
Switch(config-if-range)#
Switch(config-if-range)#exit
Switch(config)#

2. Configuration de lAP Wifi


Maintenant nous allons configurer notre AP Wifi. Nous commencerons par la
configuration de
base, puis nous configurons les deux SSID.

Commencez par brancher la borne Wifi sur un


port trunk.
wifi, et fastethernet :

Taper ces deux commandes permettant dactiver le pont entre les interfaces.
ap(config)#
ap(config)#bridge irb
ap(config)#bridge 1 route ip
ap(config)#exit

ap#
Sur une AP wifi Cisco, on ne configure pas ladresse IP sur linterface Ethernet
comme avec les
routeurs mais sur linterface BVI, cette adresse IP va en autre vous permettre de
configurer
votre AP grce linterface graphique que nous allons activer ci-dessous :
ap(config)#interface bVI1
ap(config-if)#ip address 172.20.3.2 255.255.255.128
ap(config-if)#no shut
ap(config-if)#
Je vous conseille de configurer un routeur par dfaut, qui vous permettra de
rediriger tous les
paquets vers la passerelle et ainsi gagner du temps dans la gestion des paquets
destin un
rseau diffrents de celui de lAP :
ap(config)#ip default-gateway 172.20.3.1
Voil maintenant nous allons configurer les deux SSID :
ap(config)# dot11 vlan-name WIFI vlan 101
ap(config)#dot11 dot11 vlan-name EQUIPES vlan 12
ap(config)# dot11 ssid Wifistade-ST
ap(config-ssid)#vlan 11
ap(config-ssid)#authentication open
ap(config-ssid)#mbssid gues
ap(config-ssid)#mbssid guest-mode
ap(config-ssid)#exit
ap(config)#
ap(config)# dot11 ssid Equipes-ST
ap(config-ssid)#vlan 12
ap(config-ssid)#authentication open
ap(config-ssid)#mbssid guest-mode
ap(config-ssid)#exit
ap(config)#
On configure linterface radio 0 :
ap(config)#interface dot11Radio 0
ap(config-if)#mbssid
ap(config-if)#encryption vlan 11 mode wep mandatory
ap(config-if)#encryption vlan 11 key 1 size 128bit
01234567890123456789abcdef
ap(config-if)#exit
ap(config)#
ap(config)#interface dot11Radio 0
ap(config-if)#mbssid
ap(config-if)#encryption vlan 12 mode wep mandatory
ap(config-if)#encryption vlan 12 key 1 size 128bit
abcdef01234567890123456789

ap(config-if)#exit
ap(config)#
ap(config)#interface dot11Radio 0
ap(config-if)#ssid Wifi-ST
ap(config-if)#ssid Equipes-ST
ap(config-if)#no shut
ap(config-if)#
ap(config)#interface dot11Radio 0.11
ap(config-subif)#encapsulation dot1Q 11
ap(config-subif)#bridge-group 11
ap(config-subif)#no shut
ap(config-subif)#exit
ap(config)#
ap(config)#interface dot11Radio 0.12
ap(config-subif)#encapsulation dot1Q 12
ap(config-subif)#bridge-group 12
ap(config-subif)#no shut
ap(config-subif)#exit
ap(config)#
On configure linterface fastethernet 0 :
ap(config)#interface fastEthernet 0
ap(config-if)#bridge-group 1
ap(config-if)#no shut
ap(config-if)#exit
ap(config)#
ap(config)#interface fastEthernet 0.11
ap(config-subif)#encapsulation dot1Q 11
ap(config-subif)#bridge-group 11
ap(config-subif)#no shut
ap(config-subif)#exit
ap(config)#
ap(config)#interface fastEthernet 0.12
ap(config-subif)#encapsulation dot1Q 12
ap(config-subif)#bridge-group 12
ap(config-subif)#no shut
ap(config-subif)#exit
ap(config)#

Vous aimerez peut-être aussi