Vous êtes sur la page 1sur 1

Procedimiento para agregar datos a la cola Forma 1

Si (Cola [ N ] <> ) Entonces


Escribir (imposible ingresar el elemento. La cola est llena);
Sino
Cont = 0;
Para I = 1 Hasta N
Si (Cola [ I ] <> ) entonces
Cont = Cont +1;
Fin si
Fin para
Auxiliar = Cont
Para I = 1 Hasta Cont
Cola [ Auxiliar +1 ] = Cola [ Auxiliar ];
Auxiliar = Auxiliar 1;
Fin para
Leer (Cola [ 1 ] );
Fin Sino
Fin Si
Procedimiento para agregar datos a la cola Forma 2
Si (Cola [ N ] <> ) Entonces
Escribir (imposible ingresar el elemento. La cola est llena);
Sino
Cont = 0;
Para I = 1 Hasta N
Si (Cola [ I ] <> ) entonces
Cont = Cont +1;
Fin si
Fin para
Leer (Cola [ Cont + 1 ] );
Fin Sino
Fin Si
Procedimiento para eliminar elementos de la cola, Trabaja con el procedimiento agregar Forma 2
Si (Cola [ 1 ] = ) Entonces
Escribir (Imposible eliminar el elemento. La cola se encuentra vaca);
Sino
Cont = 0;
Para I = 1 Hasta N
Si (Cola [ I ] <> ) entonces
Cont = Cont +1;
Fin si
Fin para
Para I = 1 Hasta Cont
Si ( I <> Cont ) Entonces
Cola [ I ] = Cola [ I + 1 ];
Si no
Cola [ I ] = ;
Fin Sino
Fin si
Fin para
Fin sino
Fin si