Vous êtes sur la page 1sur 6

Router(config)#interface serial 2/0

Router(config-if)#ip address 30.0.0.2 255.0.0.0


Router(config-if)#no shutdown
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2/0, changed state to up
Router(config-if)#exit
Router(config)#router rip
Router(config-router)#version 2
Router(config-router)#network 30.0.0.0
Router(config-router)#network 20.0.0.0
Router(config-router)#network 10.0.0.0

Commands
Router(config)#router rip
Router(config-router)#network w.x.y.z
Router(config)#no router rip
Router(config-router)#no network w.x.y.z

Router(config-router)#version 2

Router(config-router)#version 1

Descriptions
Enables RIP as a routing protocol
w.x.y.z is the network number of the directly
connected network you want to advertise.
Turns off the RIP routing process
Removes network w.x.y.z from the RIP
routing process.
RIP will now send and receive RIPv2 packets
globally.
RIP will now send and receive RIPv1 packets
only
RIPv2 summarizes networks at the classful

Router(config-router)#no auto-summary

boundary.

This

command

turns

auto

summarization off.
Router(config-router)#passive-interface

RIP updates will not be sent out this

s0/0/0

interface.

Router(config-router)#no ip split-horizon

Turns off split horizon (on by default).

Router(config-router)#ip split-horizon

Re-enables split horizon


Changes timers in RIP: 30 = Update timer (in

Router(config-router)#timers basic 30 90
180 270 360

seconds) 90 = Invalid timer (in seconds) 180


= Hold-down timer (in seconds) 270 = Flush
timer (in seconds) 360 = Sleep time (in
milliseconds)

Router#debug ip rip

Displays all RIP activity in real time

Router#show ip rip database

Displays contents of the RIP database

Router#conf term
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#interface fastEthernet 0/0
Router(config-if)#ip address 10.0.0.1 255.0.0.0
Router(config-if)#no shutdown
Router(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
Router(config-if)#exit
Router(config)#interface Serial 2/0
Router(config-if)#ip address 30.0.0.1 255.0.0.0
Router(config-if)#clock rate 64000
Router(config-if)#bandwidth 64
Router(config-if)#no shutd
Router(config-if)#no shutdown
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
Router(config)#router rip
Router(config-router)#version 2
Router(config-router)#net
Router(config-router)#network 10.0.0.0
Router(config-router)#network 20.0.0.0
Router(config-router)#network 30.0.0.0
Router(config-router)#
Router>enable
Router#configure term
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#interface fastEthernet 0/0
Router(config-if)#ip address 20.0.0.1 255.0.0.0
Router(config-if)#no shutdown
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
Router(config-if)#exit

Router#show running-config
Building configuration...
Current configuration : 729 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
interface FastEthernet0/0
ip address 10.0.0.1 255.0.0.0
duplex auto
speed auto
!
interface FastEthernet1/0
no ip address
duplex auto
speed auto
shutdown

!
interface Serial2/0
bandwidth 64
ip address 30.0.0.1 255.0.0.0
clock rate 64000
!
interface Serial3/0
no ip address
shutdown
!
interface FastEthernet4/0
no ip address
shutdown
!
interface FastEthernet5/0
no ip address
shutdown
!
router rip
version 2
network 10.0.0.0
network 20.0.0.0
network 30.0.0.0
!
ip classless
!
line con 0
line vty 0 4
login
!
!
!
End

Vous aimerez peut-être aussi