Vous êtes sur la page 1sur 28

Introduccin a la

Programacin
y Diagramas de Flujo

1. Objetivo
El objetivo principal del tema consiste en la realizacin de algoritmos
mediante pseudocdigo y diagrama de flujo.

2. Definiciones: Algoritmo y Programa


Un algoritmo es un conjunto ordenado y finito de instrucciones que permite
hallar la solucin de un problema.
Un programa es la codificacin del algoritmo en algn lenguaje de
programacin o en lenguaje mquina.

Ejemplo: Receta de cocina

Partes de un algoritmo
Un algoritmo utiliza un conjunto de datos de entrada y proporciona unos
datos de salida.
ENTRADA: Corresponde a los datos que requiere el proceso para ofrecer los
resultados esperados.
PROCESO: Pasos necesarios para obtener la solucin del problema o la
situacin planteada.
SALIDA: Datos presentados por el proceso como solucin, resultado.

3. Programacin Estructurada
Programacin estructurada: consiste en un conjunto de reglas para escribir
programas de tal manera que sean legibles y fciles de modificar.
Reglas a seguir para la programacin estructurada:
a) Caractersticas de algoritmos estructurados
Finito: El algoritmo debe tener un nmero finito de pasos.
Eficientes: Deben ocupar la mnima memoria y minimizar el tiempo de
ejecucin.
Legibles: El texto que lo describe debe ser claro, de forma que permita
entenderlo y leerlo fcilmente.
Modificables: Estarn diseados de modo que sus posteriores
modificaciones sean fciles de realizar, incluso por programadores
diferentes a sus propios autores.

Modulares: La filosofa utilizada para su diseo debe favorecer la


divisin del problema en mdulos pequeos.
nico punto de entrada, nico punto de salida: A los algoritmos y a los
mdulos que lo integran, se entra por un solo punto (inicio) y se sale por
un solo punto (fin)
b) Cmo construir un algoritmo estructurado?
Definicin y anlisis del problema: datos de entrada y salida
(resultados)
Aplicar la tcnica que consiste en descomponer el problema en
subproblemas ms sencillos
Resolucin de los subproblemas: realizacin de los algoritmos
correspondientes a los subproblemas
Depurar (prueba de validez) el algoritmo resultante

c) Estructuras algortmicas estructuradas


Secuenciales: cada accin se realiza una sola vez y en un determinado
orden.
Condicionales (selectivas): permiten seleccionar una accin a realizar
entre varias alternativas.
Iterativas (repetitivas): una determinada accin se realiza ms de una
vez.

4. Herramientas para la realizacin de algoritmos


Existen diferentes mtodos para representar un algoritmo, los procedimientos
ms habituales son:
Pseudocdigo (herramienta no grfica)
Diagrama de flujo (herramienta grfica)

PSEUDOCODIGO
Tipos de Estructuras
Secuencial

Condicional Simple

Inicio

Inicio

Instruccin 1
Instruccin 2
.
.
.
Fin

Si <Condicin> Entonces
Bloque de Instrucciones
Fin_Si
Fin

Condicional Doble
Si <Condicin> Entonces
Bloque de Instrucciones 1
Sino
Bloque de Instrucciones 1
Fin_Si

Condicional Anidada
Si <Condicin 1> Entonces
Bloque de Instrucciones 1
Sino
Si <Condicin 2> Entonces
Bloque de Instrucciones 2
.
.
.
Fin_Si
Fin_Si

Repetitiva Mientras

Repetitiva Hacer-Mientras
Hacer

Mientras <Condicin>
Bloque de instrucciones
Bloque de instrucciones
Mientras <Condicin>
Fin_mientras

Repetitiva Para
Para var= lim_inf hasta lm_super hacer
Bloque de instrucciones
Fin_para

Ejemplo de pseudocdigo
Problema: leer dos nmeros enteros y escribir la suma.
Pseudocdigo:
Definimos las
Variables de
entrada

1. Inicio
2. Variables a,b,R
3. Leer primer nmero
4. Leer segundo nmero

Datos de entrada
(nmeros enteros)

a
b

5. Hallar la suma de los nmeros

a+b

>
Asignacin

6. Imprimir R
7. Fin

Datos de salida
(nmeros enteros)

Suma aritmtica
>

Escribir un Pseudocdigo que calcule el rea de un tringulo recibiendo como


entrada el valor de la base y la altura del triangulo.
Pseudocdigo:
Inicio
Variables

Altura, Base, rea.

Imprimir "Introduce la base y la altura del triangulo: "


Leer Base y Altura
rea= (Base*Altura)/2.
Imprimir "El rea del triangulo es: ", rea
Fin

Escribir Pseudocodigo que realice la divisin entre 2 valores de entrada y siempre


imprima la divisin del mayor entre el menor.
Inicio
Variables num1, num2, Res
Imprimir Escriba el primer numero:"
Leer num1
Imprimir Escriba el segundo numero:"
Leer num2
Si num1>=num2 entonces
R= num1/num2
Sino
R= num2/num1
Fin_si
Imprimir El mayor resultado es: R
Fin.

Estructura
Condicional

Escribir Pseudocdigo que lea de entrada 3 nmeros y que indique cual es el


mayor de ellos.
Inicio
Variables a,b,c
Imprimir "Introduce los datos a comparar: "
Leer a,b,c
Si a<b y a<c entonces
Imprime "El mayor es: ", a
Sino
Si b<a y b<c entonces
Imprime "El mayor es: ",b
sino
Imprime "El mayor es: ", c
Fin_si
Fin_si
Fin.

Estructura
Condicional
ANIDADA

Escribir Pseudocodigo que solicite una contrasea de un usuario y la valide hasta


que la contrasea sea correcta.

Inicio
Variables contrasea
Imprimir Escriba su contrasea:"
Leer contrasea
mientras (contrasea < > programacion")
imprimir("La contrasea es incorrecta !... Escriba de nuevo su contrasea:")
Leer (contrasea)
fin-mientras
Imprimir "Ha tecleado la contrasea correcta
Fin

DIAGRAMAS DE FLUJO

Los Diagramas de Flujo son herramientas grficas


para representar algoritmos.
Estn formados por una serie de smbolos, que tienen
al menos una flecha que viene del paso anterior y otra
que va al paso siguiente.
Los smbolos representan distintas acciones:
lectura/escritura, principio, fin, salto

Smbolos mas utilizados

Inicio / Fin

Proceso

Entrada /
salida de datos

Conector

Toma de Decisin

Tipos de Estructuras
Secuencial

Condicional Simple

Inicio

Proceso 1
NO

Proceso 2

Proceso N

Fin

.
.
.

Condicin ?

SI

Opcin

Condicional Doble

NO

Opcin 2

Condicin ?

Condicional Anidada

SI

NO

Opcin 1

Condicin 1 ?

SI

Opcin 1
NO

Opcin 3

Condicin 2 ?

SI

Opcin 2

Repetitiva Mientras

Repetitiva Hacer-Mientras

Ejemplo de D.F
Problema: leer dos nmeros enteros y escribir la
suma.

NOTA: REALIZAR
LOS EJEMPLOS DE
PSEUDOCODIGO
EN D.F