Vous êtes sur la page 1sur 64

1.

*Calcular el promedio de un alumno que tiene 7 calificaciones en la materia de


Diseño Estructurado de Algoritmos

ANALISIS:

Promedio= (c1 + c2+ c3+ c4+c5+ c6+c7)/7

DIAGRAMA DE FLUJO:
Inicio

Promedio, c1, c2, c3, c4, c5, c6,


c7

c1, c2, c3, c4,


c5, c6, c7

Promedio= (c1 + c2+ c3+ c4+c5+ c6+c7)/7

‘su promedio en
estructura de algoritmos
es de: ‘; promedio

Fin

PSEUDOCÓDIGO:
Inicio
Promedio, c1, c2, c3, c4, c5, c6, c7
Escriba (“digite su calificación nº1”)
Lea (c1)
Escriba (“digite su calificación nº2”)
Lea (c2)
Escriba (“digite su calificación nº3”)
Lea (c3)
Escriba (“digite su calificación nº4”)
Lea (c4)
Escriba (“digite su calificación nº5”)
Lea (c5)
Escriba (“digite su calificación nº6”)
Lea (c6)
Escriba (“digite su calificación nº7”)
Lea (c7)
Promedio= (c1 + c2+ c3+ c4+c5+ c6+c7)/7
Escriba (“su promedio en estructura de algoritmos es de: ‘; promedio)
Fin

PRUEBA DE ESCRITORIO:

C1 C2 C3 C4 C5 C6 C7 C8 C9 PROMEDIO
4.5 5.0 2.3 4.5 3.0 4.7 3.0 5.0 4.9 5.2

2. Leer 10 números y obtener su cubo y su cuarta.

ANALISIS:
CUBO=NUM*NUM*NUM
CUARTA=CUBO*NUM

DIAGRAMA DEFLUJO:
INICIO

N=1 A
10

NUM

CUBO = NUM * NUM * NUM


CUARTA=CUBO* NUM

CUBO, CUARTA

FIN
PSEUDOCODIGO:
Inicio
Hacer para n=1 a 10
Leer num
Cubo=num*num*num
Cuarta=cubo*num
Mostrar cubo, cuarta
Fin para
Fin
PRUEBA DE ESCRITORIO:
N1=2 N2=6 N3=4
CUBO=8 CUBO= 216 CUBO=64
CUARTA=16 CUARTA=1296 CUARTA=256

N4=5 N5=7 N6=8


CUBO=125 CUBO= 343 CUBO= 512
CUARTA=625 CUARTA= 2401 CUARTA= 4096

N7=1 N8=3 N9=9


CUBO=1 CUBO= 27 CUBO= 729
CUARTA=1 CUARTA= 81 CUARTA= 6561

N10=11
CUBO=1331
CUARTA=14641

3. Leer 10 números e imprimir solamente los números positives

ANALISIS:

NUMEROS POSITOVOS SON= 1 2 3 4 5 6 7 8 9 10……


NUMERO NEGATIVOS SON = -1 -2 -3 -4 -5 -6 -7 -8 -9 -10………

DIAGRAMA DE FLUJO:
INICIO

N=1 A
10

NUM

NUM>
0

NUM

FIN
PSEUDOCODIGO:
Inicio
Hacer para n=1 a10
Leer num
Si num>0 entonces
Mostrar num
Fin si
Fin para
Fin

PRUEBA DE ESCRITORIO:
NUM = 5 5
NUM-2 =…….

4. Leer 20 números e imprimir cuantos son positivos, cuantos negativos y cuantos


neutros.

ANALISIS:
NP=+
NG=-

PSEUDOCODIGO:
INICIO
CN=0
CP=0
CNEG=0
HACER PARA X =1 A 20
LEER NUM
SI NUM=0 ENTONCES
CN= CN+1
SI NO
SI NUM >0 ENTONCES
CP=CP+1
SI NO
CNEG=CNEG+1
FIN SI
FIN SI
FIN PARA
MOSTRAR CN, CP, CNEG
FIN
DIAGRAMA DE FLUJO

INICIO

CN=0
CP=0
CNG=0

X=1 A
20

NUM

NUM=
0

CN=CN+1

NUM>
0

CNEG=CNEG+1 CP=CP+1

FIN

PRUEBA DE ESCRITORIO:
NUM: 5 NUM: 10
NUM: -6 NUM: 11
NUM: -8 NUM: 12
NUM: 9 NUM:-11
NUM: 3 NUM:-14
NUM: -13 NUM:-5

5. Leer 15 números negativos y convertirlos a positivos e imprimir dichos números.

ANALISIS:

POS = NUM * -1
DIAGRAMA DE FLUJO:

INICIO

X= 1 A
15

NUM

POS=NUM*-1

NUM, POS

FIN

PSEUDOCODIGO:
INICIO
HACER PARA X =1 A 15
LEER NUM
POS= NUM*-1
MOSTRAR NUM, POS
FIN PARA
FIN

PRUEBA DE ESCRITORIO:

NUM:-1 NUM:-2 NUM:-3


NUM: 1 NUM: 2 NUM: 3

NUM:-4 NUM: -5 NUM:-6 NUM:-7


NUM: 4 NUM: 5 NUM:6 NUM: 7

NUM:-8 NUM:-9 NUM:-10 NUM:-11


NUM: 8 NUM: 9 NUM: 10 NUM: 11

NUM:-12 NUM:-13 NUM:-14 NUM:-15


NUM: 12 NUM: 13 NUM: 14 NUM: 15
6. Suponga que se tiene un conjunto de calificaciones de un grupo de 40 alumnos.
Realizar un algoritmo para calcular la calificación media y la calificación mas baja
de todo el grupo.

ANALISIS:

Media=(num1+num2+num3+num4)/4
calificacion mas alta

DIGRAMA DE FLUJO:

INICIO

SUM=0
BAJA=9999

A=1 A 40

CALIF

SUM= SUM+ CALIF

NO SI
CALIF<BAJ
A
BAJA=CALIF

MEDIA=SUM/2

MEDIA, BAJA

FIN
PSEUDOCODIGO:
INICIO
SUM=0
BAJA=9999
PARA A=1 A 40
LEER CALIF
SUM= SUM+ CALIF
SI CALIF<BAJA ENTONCES
BAJA=CALIF
FIN SI
FIN PARA
MEDIA=SUM/2
MOSTRAR MEDIA, BAJA
FIN

PRUEBA DE ESCRITORIO:

CALIFICACIONES: 30, 30, 30, 32, 35,36,


38,39,40,42,42,43,40,50,30,20,25,36,32,
31,36,38,39,37,31,35,36,34,31,30,30,32,31, 35, 36, 30, 34, 32, 32,40
CALIFICACION MEDIA:
CALIFICACION BAJA:

7. Calcular e imprimir la tabla de multiplicar de un número cualquiera. Imprimir el


multiplicando, el multiplicador y el producto.

ANALISIS:

Result=multi*un

PSEUDOCODIGO:

Inicio
Result, multi, nu
Escriba (“escriba el numero que desea multiplicar”)
Lea (multi)
For nu = 1 hasta 10
Result=multi * nu
Escriba (multi & “*” nu & “=” & result)
Sigmulti
Fin
DIAGRAMA DE FLUJO: Inicio

Result, multi, nu

“digite el multiplicando”

Multi

Nu=1 to 10

Resul=multi*nu

Multi & “*” & “=” &


result

Signu

Fin

PRUEBA DE ESCRITORIO:

MULTI UN RESULT MOSTRAR


8 2 16 16

8. Simular el comportamiento de un reloj digital, imprimiendo la hora, minutos y


segundos de un día desde las 0:00:00 horas hasta las 23:59:59 horas

ANALISIS:

HORA=24
MINUTOS=60
SEGUNDOS=60

PSEUDOCODIGO
INICIO
PARA H=1 A 23
PARA M=1 A 59
PARA S=1 A59
MOSTRAR H, M, S
FIN PARA
FIN PARA
FIN PARA
FIN

DIAGRAMA DE FLUJO:
INICIO

H=1 A 23

M=1 A 59

S=1 A59

H, M, S

FIN

PRUEBA DE ESCRITORIO:

H M S
5 30 50

Problemas Propuestos

9. Una persona debe realizar un muestreo con 50 personas para determinar el


promedio de peso de los niños, jóvenes, adultos y viejos que existen en su zona
habitacional. Se determinan las categorías con base en la sig, tabla:

Niños 0 – 12 Jóvenes 13 – 29 Adultos 30 – 59 Viejos60 en adelante


ANALISIS:
INICIO
EDAD= 0 < 12
N = SUMA N + EDAD
X=1A
CONT. N = CONT. N + 1
50

DIAGRAMA DE FLUJO;

SI EDAD > N = SUMA N +


0 Y <= 12 EDAD
CONT. N =
CONT. N + 1
EDAD >=13
Y EDAD <=
29

NO EDAD >=
30 Y <=
59
SUMA J =
SUMA A = SUMA J +
EDAD>=6 SUMA A + EDAD
0 EDAD CONT. J =
CONT.A=CON CONT. J +1
SUMAV=SUMA T.A+1
V+EDAD
CONTV=CONT
V+1

PRN=SUMAN/CONTN,PRJ=SUMAJ/CONTJ,PRA=SUMAA/CONTA,PRV=SUMAV/CONTV

PRN, PRJ, PRA, PRV

FIN

PSEUDOCODIGO:

INICIO
PARA X = 1 A 50
SI EDAD > 0 Y <= 12 ENTONCES
SUMA N = SUMA N + EDAD
CONT. N = CONT. N + 1
SINO
SI EDAD >=13 Y EDAD <= 29 ENTONCES
SUMA J = SUMA J + EDAD
CONT. J = CONT. J + 1
SINO
SI EDAD >= 30 Y <= 59 ENTONCES
SUMA A = SUMA A + EDAD
CONT.A=CONT.A+1
SINO
SIEDAD>=60ENTONCES
SUMAV=SUMAV+EDAD
CONTV=CONTV+1
FINPARA
PRN=SUMAN/CONTN
PRJ=SUMAJ/CONTJ
PRA=SUMAA/CONTA
PRV=SUMAV/CONTV
MOSTRAR:PRN,PRJ,PRA,PRV
FISI
FINSI
FINSI
FINSI
FIN

10. Al cerrar un expendio de naranjas, 15 clientes que aun no han pagado recibirán
un 15% de descuento si compran mas de 10 kilos. Determinar cuanto pagara cada
cliente y cuanto percibirá la tienda por esas compras.

ANALISIS:

Descuento=compra*0.15
Compra=compra-descuento
DIAGRAMA DE FLUJO: Inicio

Descuento; compra,
kilos

“digite el numero de kilos que compro”

Kilos

Kilos>10

Descuento=compra*0.15
Compra=compra-descuento

“el descuento de su compra es


de: “; compra

fin

PSEUDOCODIGO:

Inicio
Descuento; compra, kilos
Escriba (“escriba el numero de kilos que compro”)
Lea (kilos)
Si kilos>10
Descuento=compra*0.15
Compra=compra-descuento
Sino
Fin si
Fin
PRUEBA DE ESCRITORIO:

Kilos compra descuento compra mostrar


10 5600 840 4790 4790

11. En un centro de verificación de automóviles se desea saber el promedio de puntos


contaminantes de los primeros 25 automóviles que lleguen. Asimismo se desea
saber los puntos contaminantes del carro que menos contamino y del que mas
contamino.

ANALISIS:
X=1 TO 25
SUMA= SUMA + CG

DIGRAMA DE FLUJO:

INICIO

BAJA=100
ALTA=0

X=1 A 25

CG

SUMA=SUMA+CG

CG<BAJA
=”CG”>AL
TA
ALTA=CG

PR=SUMA725

BAJA, ALTA, PR

FIN
PSEUDOCODIGO:
INICIO
BAJA=100
ALTA=0
PARA X=1 A 25
LEER CG
SUMA=SUMA+CG
SI CG<BAJA=”CG”>ALTA ENTONCES
ALTA=CG
FIN PARA
PR=SUMA725
MOSTRAR BAJA, ALTA, PR
FIN SI
FIN SI
FI

12. Un entrenador le ha propuesto a un atleta recorrer una ruta de cinco kilómetros


durante 10 días, para determinar si es apto para la prueba de 5 Kilómetros o debe buscar
otra especialidad. Para considerarlo apto debe cumplir por lo menos una de las siguientes
condiciones:
- Que en ninguna de las pruebas haga un tiempo mayor a 16 minutos.
- Que al menos en una de las pruebas realice un tiempo mayor a 16 minutos.
- Que su promedio de tiempos sea menor o igual a 15 minutos.

ANALISIS:
Kilómetros >16 Pasa
Inici
DIAGRAMA DE FLUJO: o

Tiempo, acto

“digite el tiempo que recorrió

Tiempo

Tiempo
>16
Acto=tiempo
“NO eres acto”

“si eres acto”


PSEUDOCODIGO:
Fin
Inicio
Tiempo, acto
Escriba (“digite su tiempo recorrido”)
Lea (recorrido)
Si tiempo>16
Acto=tiempo
Escriba (“si eres acto”)
Sino
Escriba (“no eres acto”)
Fin si
Fin

PRUEBA DE ESCRITORIO

TIEMPO ACTO MOSTRAR


18 SI SI ERES ACTO
5 NO NO ERES ACTO

12. Un Zoólogo pretende determinar el porcentaje de animales que hay en las


siguientes tres categorías de edades: de 0 a 1 año, de más de 1 año y menos de 3 y
de 3 o mas años. El zoológico todavía no esta seguro del animal que va a estudiar.
Si se decide por elefantes solo tomara una muestra de 20 de ellos; si se decide por
las jirafas, tomara 15 muestras, y si son chimpancés tomara 40.

ANALISIS:

La siguiente formula explica la cantidad de animales * el 0.20, donde 0.20 es el 20% de


los animales
nn1=n1 * 0.20
DIAGRAMA DE FLUJO
PSEUDOCODIGO
Inicio
Tipo, edad , n1,nn1,nn2,nn3,nn4,nn5,nn6,nn7,nn8,nn9
Si
Tipo = 1 or edad = 1
nn1=n1 * 0.20
'el porcentaje de elefantes es', nn1
Sino
Tipo = 1 or edad = 2
nn2=n2 * 0.2
'el porcentaje de elefantes es', nn2
Sino
Tipo = 1 or edad = 3
nn3=n3 * 0.20
'el porcentaje de elefantes es', nn3
Sino
Tipo = 2 or edad = 1
nn4=n4 * 0.15
'el porcentaje de jirafas es', nn4
Sino
Tipo = 2 or edad = 2
nn5=n5 * 0.15
'el porcentaje de jirafas es', nn5
Sino
Tipo = 2 or edad = 3
nn6=n6 * 0.15
'el porcentaje de jirafas es', nn6
Sino
Tipo = 3 or edad = 1
nn7=n7 * 0.4
'el porcentaje de chimpancés es', nn7
Sino
tipo = 3 or edad = 2
nn8=n8 * 0.4
'el porcentaje de chimpancés es', nn8
Sino
tipo = 3 or edad = 3
nn9=n9 * 0.4
'el porcentaje de chimpancés es', nn9

Prueba de escritorio

Edades
Animales 1. 0 a 1 2. 1 a 2 3. 3 a mas %
Elefante 40 * 0.2 8
Jirafa 25 * 0.15 3,75
Chimpancés 32 * 0.4 12,8

13. Una compañía de seguros tiene contratados a n vendedores. Cada uno hace tres
ventas a la semana. Su política de pagos es que un vendedor recibe un sueldo base, y
un 10% extra por comisiones de sus ventas. El gerente de su compañía desea saber
cuanto dinero obtendrá en la semana cada vendedor por concepto de comisiones por
las tres ventas realizadas, y cuanto tomando en cuenta su sueldo base y sus
comisiones

ANALISIS
TCOMISION= VENTAS – COMISION
SUELDOT= SUELDO+ TCOMSION

DIAGRAMA DE FLUJO: INICIO

SULBASE, COMISIÓN, SUELDOTVENTAS,


TCOMISION, SUELDO

SULBASE

COMISION=0.10
VENTAS= 3
TCOMISION= VENTAS * COMISION
SUELDOT= TCOMISION + SULBASE

‘TOTAL
SUELDO = ‘;
SUELDOT

PSEUDOCODIGO: FIN
INICIO
SULBASE, COMISION= 0.10, VENTAS=3, TCOMISION, SUELDOT
ESCRIBA (“VALOR SULBASE”)
LEA (SULBASE)

TCOMISION= VENTAS * COMISION


SUELDOT= SULBASE + TCOMISION
MOSTRAR (“EL SUELDO TOTALL DEL EMPLEADO ES; “
FIN

PRUEBA DE ESCRITORIO:

SULBASE COMISION VENTAS TCOMISION SUELDOT


MOSTRAR
$515000 0.10 3 0.3 154500
154500

14. En una empresa se requiere calcular el salario semanal de cada uno de los n
obreros que laboran en ella. El salario se obtiene de la sig. forma:
Si el obrero trabaja 40 horas o menos se le paga $20 por hora
Si trabaja mas de 40 horas se le paga $20 por cada una de las primeras 40 horas y
$25 por cada hora extra.

ANALISIS:
40HORAS= 20
P40HORAS=20
O20HORAS=25

DIGRAMA DE FLUJO:
15. Determinar cuantos hombres y cuantas mujeres se encuentran en un grupo de n
personas, suponiendo que los datos son extraídos alumno por alumno.

ANALISIS:
PCANTIDADH= (CANTIDADH*100)/NºESTUDIENTES
PCANTIDADM= (CANTIDADM*100)/NºESTUDIENTES

DIAGRAMA DE FLUJO:

INICIO

CANTIDADH, CANTIDADM, PCANTIDADM


PCANTIDADH, NºESTUDIANTES
NºESTUDIENTES,

NºESTIDIANTES, CANTIDADM,CANTIDADH

“LA CANTIDAD DEFIN


HOMBRES EN
EL SALON ES=’; PCANTIDADH
“LA CANTIDAD DE MUJERES EN
EL SALON ES=’; PCANTIDADM

FIN

PSEUDOCODIGO:
INICIO
CANTIDADH, CANTIDADM, NºESTUDIENTES
ESCRIBA (“VALOR NºESTUDIENTES”)
LEA (NºESTUDIENTES)
ESCRIBA (“VALOR CANTIDADH”)
LEA (CANTIDADH)
ESCRIBA (“VALOR CANTIDADM”)
LEA (CANTIDADM)
PCANTIDADH= (CANTIDADH*100)/NºESTUDIENTES
PCANTIDADM= (CANTIDADM*100)/NºESTUDIENTES
MOSTRAR
(“LA CANTIDAD DE HOMBRES EN EL SALON ES=’; CANTIDADH)
(“LA CANTIDAD DE MUJERES EN EL SALON ES=’; CANTIDADM)
FIN

PRUEBA DE ESCRITORIO:

nºestudientes cantidadh cantidadm pcantidadh pcantidadm


mostrar
25 11 14 44
56 56

16. Calcular el promedio de edades de hombres, mujeres y de todo un grupo de


alumnos.

ANALISIS
Cantidad de hombre
Cantidad de mujeres
Promedio = cantidad de hombre + cantidad de mujeres

Pseudocodigo
Inicio
Cantiada de hombres (entera)
Cantidad de mujeres (entera)
Promedio (entera)
Escriba (“Digite la cantidad de hombre en el salón”)
Lea cantidad de hombre
Escriba(“Digite cantidad de mujeres”9
Lea cantidad de mujeres
Promedio = cantidad de hombre + cantidad de mujeres
Escriba (promedio)
Escriba(“ cantidad de hombre”)
Imprima cantidad de mujeres
FiN

DIAGRAMA DE FLUJO:
Inici
o

Ch , Cm , P

Ch , Cm , P

P= Cm+Ch

Ch , Cm , P

Fin

PRUEBA DE ESCRITORIO
Ch=10
Cm=10
P=20

17. El Depto. de Seguridad Publica y Transito del D.F. desea saber, de los n autos
que entran a la ciudad de México, cuantos entran con calcomanía de cada color.
Conociendo el ultimo dígito de la placa de cada automóvil se puede determinar el
co5lor de la calcomanía utilizando la sig. Relación:
INICIO

NA
UL
<=NA

UL

E=E+1

SI UL=1>
O UL=2

AMARILLO=
UL=3> O AMARILLO+1
UL=4

ROSA=ROSA+1
UL=5> O
UL=6
AMARILLO
ROJO=ROJO+1 ROSA
UL=7> O
UL=8
AZUL=AZUL+1 ROJO

AZUL
UL=9> O
UL=0

VERDE=VERDE+1

VERDE

FIN
SEPUDOCODIGO:
INICIO
LEER NA
MIENTRAS UL <=NA
LEER UL
E=E+1
SI UL=1> O UL=2 ENTONCES
AMARILLO=AMARILLO+1
MOSTRAR AMARILLO
SINO
SI UL=3> O UL=4 ENTONCES
ROSA=ROSA+1
MOSTRAR ROSA
SINO
SI UL=5> O UL=6 ENTONCES
ROJO=ROJO+1
MOSTRAR ROJO
SINO
SI UL=7> O UL=8 ENTONCES
VERDE=VERDE+1
MOSTRAR VERDE
SINO
SI UL=9> O UL=0 ENTONCES
AZUL=AZUL+1
MOSTRAR AZUL
FIN MIENTRAS
FIN

PRUEBA DE ESCRITORIO
UL AMARILLO ROSA ROJO VERDE AZUL MOSTAR
1 AMARILLO

5 ROJO

18. Obtener el promedio de calificaciones de un grupo de n alumnos.


Análisis:

Nº=10
Promedio= (A1 + A2 +A3 +A4 +A5 +A6 +A7 +A8+ A9 +A10
DIAGRAMA DE FLUJO:
INICIO

Promedio,A1,A2,A3,A4,A5,A6,A7,A8,A9

A1,A2,A3,A4,A5,A6,A7,A8,A9

Promedio= (A1 + A2 +A3 +A4 +A5 +A6


+A7 +A8+ A9 +A10)/10

“el promedio del grupo de alumnos es de:”·; PROMEDIO

FIN

PSEUDOCODIGO:
Inicio
Escriba (“el promedio del alumno1”)
Lea (a1)
Escriba (“el promedio del alumno2”)
Lea (a2)
Escriba (“el promedio del alumno3”)
Lea (a3)
Escriba (“el promedio del alumno4”)
Lea (a4)
Escriba (“el promedio del alumno5”)
Lea (a5)
Escriba (“el promedio del alumno6”)
Lea (a6)
Escriba (“el promedio del alumno7”)
Lea (a7)
Escriba (“el promedio del alumno8”)
Lea (a8)
Escriba (“el promedio del alumno9”)
Lea (a9)
Escriba (“el promedio del alumno10”)
Lea (a10)
Promedio= (A1 + A2 +A3 +A4 +A5 +A6 +A7 +A8+ A9 +A10)/10
Escriba (“el promedio del grupo de alumnos es de:”·; PROMEDIO)
Fin
PRUEBA DE ESCRITORIO

A1 A2 A3 A4 A5 A6 A7 A8 A9 A10 PROMEDIO
2.0 3.0 5.0 3.5 2.0 4.9 3.5 5.0 4.8 3.0 0.3571

19. Una persona desea invertir su dinero en un banco, el cual le otorga un 2% de


interés. Cual será la cantidad de dinero que esta persona tendrá al cabo de un año si
la ganancia de cada mes es reinvertida?.

ANALISIS:

Interés=dinero*0.02

DIAGRAMA DE FLUJO:
Inicio

Dinero,
interés

“digite la cantidad de dinero que sea invertir

Dinero

Interés=dinero*0.02

“su interés por el dinero invertido será de:”; interés

fin

PSEUDOCÓDIGO:

INICIO
Escriba (“la cantidad de dinero que invirtió”)
Lea (dinero)
Interés= dinero*0.02
Escriba (“su interés por el dinero invertido será de:”; interés)
Fin
PRUEBA DE ESCRITORIO:

dinero interés mostrar

200000 4000 4000

20. Calcular el promedio de edades de hombres, mujeres y de todo un grupo de


alumnos.
aja.

ANALISIS:

Prom= (M1+M2+M3+M4+M5+M6)/6
Proh= (H1+H2+H3+H4+H5+H6+H7+H8)/8
Promedio= (prom+proh)/2

DIAGRAMA DE FLUJO: INICI


O
Prom,M1,M2,M3,M4,M5,M6,Proh,H1,H2,H3,H4,H5,H6,H7,H8

“digite el promedio de los hombre y las mujeres”

M1,M2,M3,M4,M5,M6,H1,H2,H3,H4,H5,H6,H7,H8

Prom= (M1+M2+M3+M4+M5+M6)/6
Proh= (H1+H2+H3+H4+H5+H6+H7+H8)/8
Promedio= (prom+proh)/2

“El promedio de edades de hombre y mujeres del salón es de:”; promedio

Fin

PSEUDOCODIGO:
Inicio
Prom,M1,M2,M3,M4,M5,M6,Proh,H1,H2,H3,H4,H5,H6,H7,H8
Escriba (“la edad de el estudiante)
Lea (M1)
Escriba (“la edad de el estudiante)
Lea (M2)
Escriba (“la edad de el estudiante)
Lea (M3)
Escriba (“la edad de el estudiante)
Lea (M4)
Escriba (“la edad de el estudiante)
Lea (M5)
Escriba (“la edad de el estudiante)
Lea (M6)
Escriba (“la edad de el estudiante)
Lea (H1)
Escriba (“la edad de el estudiante)
Lea (H2)
Escriba (“la edad de el estudiante)
Lea (H3)
Escriba (“la edad de el estudiante)
Lea (H4)
Escriba (“la edad de el estudiante)
Lea (H5)
Escriba (“la edad de el estudiante)
Lea (H6)
Escriba (“la edad de el estudiante)
Lea (H7)
Escriba (“la edad de el estudiante)
Lea (H8)
Prom= (M1+M2+M3+M4+M5+M6)/6
Proh= (H1+H2+H3+H4+H5+H6+H7+H8)/8
Promedio= (prom+proh)/2
ESCRIBA (“El promedio de edades de hombre y mujeres del salón es de:”; promedio)
FIN

PRUEBA DE ESCRITORIO

M1 M2 M3 M4 M5 M6 Prom

12 15 16 15 16 17 15.1

H1 H2 H3 H4 H5 H6 H7 H8 Proh
13 12 15 16 13 17 18 15 14.875

PROMEDIO
14.98

21. Cinco miembros de un club contra la obesidad desean saber cuanto han bajado o
subido de peso desde la ultima vez que se reunieron. Para esto se debe realizar un
ritual de pesaje en donde cada uno se pesa en diez básculas distintas para así tener el
promedio más exacto de su peso. Si existe diferencia positiva entre este promedio de
peso y el peso de la última vez que se reunieron, significa que subieron de peso.
Pero si la diferencia es negativa, significa que bajaron. Lo que el problema requiere
es que por cada persona se imprima un letrero que diga: “SUBIO” o “BAJO” y la
cantidad de kilos que subió o bajo de peso.

Análisis
Debemos tomar el peso de las diez balanzas de cada uno de los miembros del club, sacar
el promedio y luego si el peso promedio es mayor a el peso anterior restar: peso promedio
menos peso anterior; pero si es al contrario el peso anterior menos el peso promedio
actual.

DIGRAMA DE FLUJO:
Inicio

Peso1, peso2, peso3, peso4, peso5, peso6,


peso7, peso8, peso9, peso10, suma, subió,
bajo

‘Digite su peso anterior”

Pesoprin

‘Digite el peso de cada


bascula”

Peso1, peso2, peso3, peso4, peso5, peso6, peso7, peso8, peso9, peso10

Suma= peso1 + peso2 + peso3 + peso4 + peso5


+ peso6 + peso7 + peso8 + peso9 + peso10

Suma<peso
prin

Subió=Suma-pesoprin Bajo= pesoprin-suma

“Ha subido”, Subió “Felicidades ha bajado”, Bajo


“kilos” “Kilos”

Fin
Pseudocódigo

Inicio
Escriba “digite su peso anterior”
Lea pesoprin
Escriba “digite el peso de la primer bascula”
Lea peso1
Escriba “digite el peso de la segunda bascula”
Lea peso2
Escriba “digite el peso de la tercera bascula”
Lea peso3
Escriba “digite el peso de la cuarta bascula”
Lea peso4
Escriba “digite el peso de la quinta bascula”
Lea peso5
Escriba “digite el peso de la sexta bascula”
Lea peso6
Escriba “digite el peso de la séptima bascula”
Lea peso7
Escriba “digite el peso de la octava bascula”
Lea peso8
Escriba “digite el peso de la novena bascula”
Lea peso9
Escriba “digite el peso de la decima bascula”
Lea peso10
Suma = peso1 + peso2 + peso3 + peso4 + peso5 + peso6 + peso7 + peso8 + peso9 +
peso10
Escriba “Su peso actual es”, Suma “kilos”
Si
Suma< pesoprin
Bajo=pesoprin-Suma
Escriba “Felicidades ha bajado”, Bajo “Kilos”
Sino
Suma>pesoprin
Subió=Suma-pesoprin
Escriba “Ha subido”, Subió “kilos”
Sino
Suma=Pesoprin
Escriba “No ha subido ni ha bajado kilos”
Fin si
Fin si
Fin
22. Se desea obtener el promedio de g grupos que están en un mismo año escolar;
siendo que cada grupo puede tener n alumnos que cada alumno puede llevar m
materias y que en todas las materias se promedian tres calificaciones para obtener el
promedio de la materia. Lo que se desea desplegar es el promedio de los grupos, el
promedio de cada grupo y el promedio de cada alumno.

ANALISIS:

DIAGRAMA DE FLUJO:

PSEUDOCODIGO:

PRUEBA DE ESCRITORIO:

23. En una tienda de descuento las personas que van a pagar el importe de su compra
llegan a la caja y sacan una bolita de color, que les dirá que descuento tendrán sobre
el total de su compra. Determinar la cantidad que pagara cada cliente desde que la
tienda abre hasta que cierra. Se sabe que si el color de la bolita es roja el cliente
obtendrá un 40% de descuento; si es amarilla un 25% y si es blanca no obtendrá
descuento.

ANALISIS:
Descuento=compra*descuento
Compra=compra-descuento
DIGRAMA DE FLUJO:
Inicio

Descuento, compra

compra

‘sacar la bolita de color’

Color

Color=’roj
a’
Descuento=compra*0.40
Compra=compra-descuento
Color=’amarill
a’
“el valor de su compra es
de:”; compra
Color
=blan
ca
Descuento=compra*0.25
Compra=compra-descuento

“el valor de su compra es


de:”; compra
“no tienes
descuento”

Fin

PSEUDOCODIGO:
Inicio
Descuento, compra
Escriba (“valor de su compra”)
Lea (compra)
Escriba (“escoja su bolita”)
Lea (color)

Si color=’rojo’
Descuento=compra*0.40
Compra=compra-descuento
Escriba (““el valor de su compra es de:”; compra)

Sino
Color= ‘amarilla’
Descuento=compra*0.25
Compra=compra-descuento
Escriba (““el valor de su compra es de:”; compra)
Sino
Color=’blanco’
Escriba (“no tienes descuento”)

Sino
Finsi
Finsi
Finsi
Fin

PRUEBA DE ESCRITORIO:
Compra color descuento compra mostrar
2500 ‘rojo’ 1000 1500 1500
3600 ‘amarillo’ 900 27000 2700
2500 ‘blanco’ 0 2500 2500

24. En un supermercado una ama de casa pone en su carrito los artículos que va
tomando de los estantes. La señora quiere asegurarse de que el cajero le cobre bien
lo que ella ha comprado, por lo que cada vez que toma un articulo anota su precio
junto con la cantidad de artículos iguales que ha tomado y determina cuanto dinero
gastara en ese articulo; a esto le suma lo que ira gastando en los demás artículos,
hasta que decide que ya tomo todo lo que necesitaba. Ayúdale a esta señora a
obtener el total de sus compras.

ANALISIS:

Compras= art1 + art2 + art3 + art4

DIAGRAMA DE FLUJO:
INICI
O
Compras, art1, art2, art3, art4, art5

“digite el valor de su
articulo1”

art1

“digite el valor de su
articulo2”

Art2

Compra=art1+art2

“digite el valor de su
articulo3”
Fin
Art3
Compra=compra+art3

“digite el valor de su
articulo4”

Art4
Compra=compra+art4

“digite el valor de su
articulo5”

Art5

Compra=compra+art5

“el total de su compra


es de:”; compra

Fin

PSEUDOCODIGO:
Inicio:
Compras, art1, art2, art3, art4, art5
Escriba (“el valor de su articulo1”)
Lea (art1)
Escriba (“el valor de su articulo2”)
Lea (art2)
Compra=art1+art2
Escriba (“el valor de su articulo3”)
Lea (art3)
Compra=compra+art3
Escriba (“el valor de su articulo4”)
Lea (art5)
Compra=compra+art4
Escriba (“el valor de su articulo5”)
Lea (art5)
Compra=compra+art5
Escriba(“el total de su compra es de:”; compra)
fin

PRUEBA DE ESCRITORIO:

Art1 art2 compra art3 compra art4 compra art5 compra


2600 3100 5700 15300 21000 8950 29950 8800 38750

25. un teatro otorga descuentos según la edad del cliente. Determinar la cantidad de
dinero que el teatro deja de percibir por cada una de las categorías. Tomar en cuenta
que los niños menores de 5 años no pueden entrar al teatro y que existe un precio
único en los asientos. Los descuentos se hacen tomando en cuenta el siguiente
cuadro:
Análisis
Categoría 1=precio*0.35
Categoría 2=precio*0.25
Categoría 3=precio*0.10
Categoría 4=precio*0.25
Categoría 5=precio*0.65

DIAGRAMA DE FLUJO

INICIO
Precio boleta

Precio

Años
cliente

Años

Años =>5 or
<14

Años =>15 or
Descuento=precio*0.35
<19
Perdida=Precio-
Descuento
Años =>20 or Descuento=precio*0.25
<45 Descuento=Precio-Descuento

Años =>46 or Descuento=precio*0.10


<65 Descuento=Precio-Descuento

Descuento=precio*0.65 Descuento=precio*0.25
Perdida=Precio-Descuento Perdida=Precio-Descuento

FIN

Pseudocódigo
Inicio
Escriba “Precio boleta”
Leer precio
Escriba “Años cliente”
Leer años
Si
Años =>5 or <14
Descuento=precio*0.35
Perdida=Precio-Descuento
Escriba “Total dinero descontado categoría 1”, Perdida
Sino
Años =>15 or <19
Descuento=precio*0.25
Descuento=Precio-Descuento
Escriba “Total dinero descontado categoría 2”, Perdida
Sino
Años =>20 or <45
Descuento=precio*0.10
Perdida=Precio-Descuento
Escriba “Total dinero descontado categoría 3”, Perdida
Sino
Años =>46 or <65
Descuento=precio*0.25
Perdida=Precio-Descuento
Escriba “Total dinero descontado categoría 4”, Perdida
Sino
Años =>66
Descuento=precio*0.65
Perdida=Precio-Descuento
Escriba “Total dinero descontado categoría 5”, Perdida
Fin si
Fin si
Fin si
Fin si
Fin

Prueba de escritorio
Precio boleta Años cliente Descuento
2000 17 500
3000 27 300

Problemas Propuestos
26. La presión, volumen y temperatura de una masa de aire se relacionan por la
formula:
Masa= presión * volumen .
0.37 * (temperatura + 460)

Calcular el promedio de masa de aire de los neumáticos de n vehículos que están


en compostura en un servicio de alineación y balanceo. Los vehículos pueden ser
motocicletas o automóviles.

ANALISIS:

Masa= presión * volumen .


0.37 * (temperatura + 460)

DIGRAMA DE FLUJO: INICIO

Masa,presión,volumen,temperatura
“digite la presión de su vehículo”

Presión

“digite el volumen de su vehículo”

Volumen

“digite la temperatura de su vehículo”

temperatura

Masa=(presión*volumen)/0.37+(temperatura+460)

“la masa de su vehículo es de:”; masa

Fin
PSEUDOCODIGO:
Inicio
Masa, presión, volumen, temperatura
Escriba (“la presión de su vehículo”)
Lea (presión)
Escriba (“la volumen de su vehículo”)
Lea (volumen)
Escriba (“la temperatura de su vehículo”)
Lea (temperatura)
Masa= (presión*volumen)/0.37+(temperatura+460)
Escriba (“la masa de su vehículo es de:”; masa)
Fin

PRUEBA DE ESCRITORIO:
Presión volumen temperatura masa mostrar
2.63 4 8 496,54 496,54

27. Determinar la cantidad semanal de dinero que recibirá cada uno de los n obreros
de una empresa. Se sabe que cuando las horas que trabajo un obrero exceden de 40,
el resto se convierte en horas extras que se pagan al doble de una hora normal,
cuando no exceden de 8; cuando las horas extras exceden de 8 se pagan las primeras
8 al doble de lo que se paga por una hora normal y el resto al triple.

Diagrama de flujo
Inicio

Ht , pph

Ht

Ht <= 40 He = ht – 40
He <= 8
Tp = ht * pph

Pe = he * pph * 2

Pd ,
pt
Tp = 40 * pph +pe Pd = 8 *pp *2
Pt = ( he – 8) * pph * 3

Pe = pd + pt

tp

Pseudocódigo:
fin
Inicio
Leer ht, pph
Si ht < = 40 entonces
tp = ht * pph
si no
he = ht - 40
Si he < = 8 entonces
pe = he * pph * 2
si no
pd = 8 * pph * 2
pt = (he - 8) * pph * 3
pe = pd + pt

Fin
fin-si
tp = 40 * pph + pe
fin-si
Imprimir tp
fin

Prueba de escritorio
Ht Pph Pd Pt
10 5 50 40
20 46 920 368

28. En una granja se requiere saber alguna información para determinar el precio de
venta por cada kilo de huevo. Es importante determinar el promedio de calidad de
las n gallinas que hay en la granja. La calidad de cada gallina se obtiene según la
formula:

calidad = peso de la gallina * altura de la gallina


numero de huevos que pone

ANALISIS:
Calidad = peso de la gallina * altura de la gallina
Numero de huevos que pone

“digite la altura de su gallina”

NHUEVOS
DIAGRAMA DE FLUJO: INICIO

Calidad,peso,altura,nºhuevos

Peso

“digite el peso de su gallina”

Altura

“digite el numero de huevos que pone su


gallina”

Calidad=(peso*altura)/nºhuevos

“la calidad de su gallina


es de “; calidad

Calidad=>15

Calidad>8<1 Precio=1.2*calidad
5
“el precio del huevo es de”; precio
Calidad<=
8 Precio=1.00*calidad

“el precio del


Precio=0.80*calidad huevo es de”;
precio
“el precio del huevo
es de”; precio

fin
PSEUDOCODIGO:
Inicio
Calidad, peso, altura, nºhuevo
Escriba(“digite el peso de su gallina”)
Lea (peso)
Escriba (“digite la altura de su gallina”)
Lea (altura)
Escriba (“digite numero de huevos de su gallina”)
Lea (nºhuevos)
Calidad= (peso*altura)/nºhuevos
Escriba (“la calidad de su gallina es de “; calidad)
Fin

PRUEBA DE ESCRITORIO:

Peso altura nºhuevos calidad precio mostrar


2 3 15 0.4 0.32 0.32
10 8 20 4 16 16

28 En la Cámara de Diputados se levanta una encuesta con todos los integrantes con el
fin de determinar que porcentaje de los n diputados esta a favor del Tratado de Libre
Comercio, que porcentaje esta en contra y que porcentaje se abstiene de opinar.

ANÁLISIS:

N = diputados
Encuesta de libre tratado de libre comercio
Quienes están en contra
Quienes están a favor
Quien se abstiene de votar
N= n * porcentaje

DIAGRAMA DE FLUJO:

PSEUDOCÓDIGO:

Inicio
29. Una persona que va de compras a la tienda “Enano, S.A.”, decide llevar un
control sobre lo que va comprando, para saber la cantidad de dinero que tendrá que
pagar al llegar a la caja. La tienda tiene una promoción del 20% de descuento sobre
aquellos artículos cuya etiqueta sea roja. Determinar la cantidad de dinero que esta
persona deberá pagar.

Análisis:
Descuento1=compra*0.20
Descuento=compra-descuento1

Diagrama de flujo:
Inicio

Descuento1,Netiquetas,Compra,descuento

‘digite el numero de etiquetas


rojas que tiene el numero de
productos que ha comprado.

Netiquetas

‘digite el valor de su compra’

Compr
a fin

Descuento1=Netiquetas*0.20
Compra=compra-descuento

Pseudocódigo:
Inicio
Descuento1, Netiquetas, Compra, descuento
‘el valor total de su
Escriba (‘numero de etiquetas’)
compra es de:’ compra
Lea (Netiquetas)
Escriba (‘valor compra)
Lea (compra)
Descuento1=Netiquetas*0.20
Compra=compra-descuento
Escribe (‘el valor total de su compra es de:’ compra)
Fin

Prueba de escritorio
Netiquetas Descuento1 Compra descuento mostrar
18 3.6 35600 35596,4 35596,4

30. Un censador recopila ciertos datos aplicando encuestas para el ultimo Censo
Nacional de Población y Vivienda. Desea obtener de todas las personas que alcance
a encuestar en un día, que porcentaje tiene estudios de primaria, secundaria, carrera
técnica, estudios profesionales y estudios de posgrado.

31. Un jefe de casilla desea determinar cuantas personas de cada una de las secciones
que componen su zona asisten el día de las votaciones. Las secciones son: norte, sur
y centro. También desea determinar cual es la sección con mayor numero de
votantes.

32. Un negocio de copias tiene un limite de producción diaria de 10 000 copias si el


tipo de impresión es offset y de 50 000 si el tipo es estándar. Si hay una solicitud de
un el empleado tiene que verificar que las copias pendientes hasta el momento y las
copias solicitadas no excedan del limite de producción. Si el limite de producción se
excediera el trabajo solicitado no podría ser aceptado. El empleado necesita llevar
un buen control de las copias solicitadas hasta el momento para decidir en forma
rápida si los trabajos que se soliciten en el día se deben aceptar o no.

33. Calcular la suma siguiente:


100 + 98 + 96 + 94 + . . . + 0 en este orden

Análisis:
Suma=100+98+…….+0

Diagrama de flujo
Inici
o

Suma

Suma=100+98+96+94+92+90+88+86+84+82+80+78+76+74+72+70+68+66+64+62+60+58+56
+54+52+50+48+46+44+42+40+38+36+34+32+30+28+26+24+22+20+18+16+14+12+10+8+6+
4+2+0
“la suma es =:”suma

Fin

Pseudocódigo
Inicio
Suma
Suma=100+98+96+94+92+90+88+86+84+82+80+78+76+74+72+70+68+66+64+62+60
+58+56+54+52+50+48+46+44+42+40+38+36+34+32+30+28+26+24+22+20+18+16+14
+12+10+8+6+4+2+0
Escriba (“la suma es =:”suma)
Fin

Prueba de escritorio
SUMA

34. Leer 50 calificaciones de un grupo de alumnos. Calcule y escriba el porcentaje de


reprobados. Tomando en cuenta que la calificación mínima aprobatoria es de 70.

ANÁLISIS
Se toma las 50 calificaciones +1 ósea 51 si las calificaciones son >70 reprueba y si 70<
aprueban
Haci obtendrán a calificación de cada grupo

PSEUDOCÓDIGO:

entrada de calificaciones (alumno + 1).


- Si alumno < 51 entonces, si calificación < 70 entonces (reprobados + 1) y regresa a entrada de
calificaciones.
- Sino porcentaje_reprobados= reprobados/alumno

DIAGRAMA DE FLUJO FIN

ALUM , REPRO , APRO, PORREPRO,

ALUM < 51

70< APROVADOS 70> REPROBADOS

PORCREPRO
TOTAL DE ALUM APRO ,REPRO
TOTAL DE ALUM APRO , REPRO PORCREPRO= REPRO/ALUM

FIN
PUEBRA DE ESCRITORIO:

ALUMOS NOTA APROVADOS REPROBADOS


1 45 X
2 30 X
3 75 X
4 82 X
5 30 X

35. Leer por cada alumno de Diseño estructurado de algoritmos su numero de control
y su calificación en cada una de las 5 unidades de la materia. Al final que escriba el
numero de control del alumno que obtuvo mayor promedio. Suponga que los
alumnos tienen diferentes promedios.

36. El profesor de una materia desea conocer la cantidad de sus alumnos que no
tienen derecho al examen de nivelación.Diseñe un algoritmo que lea las
calificaciones obtenidas en las 5 unidades por cada uno de los 40 alumnos y escriba
la cantidad de ellos que no tienen derecho al examen de nivelación.

Análisis
Promedio = Cal1, Cal2, Cal3, Cal4, Cal5,
DIGRAMA DE FLUJO:
Inicio

cal1, cal2, cal3,


cal4, cal5,
Promedio

“digite las 5
calificaciones obtenidas”

cal1, cal2, cal3, cal4, cal5

Promedio = cal1, cal2, cal3, cal4, cal5

Promedio=
>2.0
“su promedio es”, Promedio “NO
tiene derecho a examen de
nivelación”
“su promedio es”, Promedio
“tiene derecho a examen de
nivelación”

Pseudocódigo Fin

Inicio
Escriba “digite las 5 calificaciones obtenidas”
Lea cal1, cal2, cal3, cal4, cal5
Promedio= cal1+cal2+cal3+cal4+cal5 /5
Si
Promedio=>2.0
Escriba “su promedio es”, Promedio “tiene derecho a examen de nivelación”
Sino
Escriba “su promedio es”, Promedio “NO tiene derecho a examen de nivelación”
Fin si
Fin

Prueba de escritorio

Calificaciones Promedio Mensaje


3, 2, 5, 4, 2 3.2 su promedio es 3.2 tiene derecho a examen de nivelación
3, 0, 3, 2, 1 1.8 su promedio es 1.8 NO tiene derecho a examen de nivelación

37. Leer los 250,000 votos otorgados a los 3 candidatos a gobernador e imprimir el
número del candidato ganador y su cantidad de votos.

38. Suponga que tiene usted una tienda y desea registrar las ventas en su
computadora. Diseñe un algoritmo que lea por cada cliente, el monto total de su
compra. Al final del día que escriba la cantidad total de ventas y el numero de
clientes atendidos.

39. El profesor de una materia desea conocer la cantidad de sus alumnos que no
tienen derecho al examen de nivelación. Diseñe un pseudocódigo que lea las
calificaciones obtenidas en las 5 unidades por cada uno de los 40 alumnos y escriba
la cantidad de ellos que no tienen derecho al examen de nivelación.

Análisis
Tenemos que obtener las notas de las 5 unidades
Promedio = Cal1, Cal2, Cal3, Cal4, Cal5,

DIGRAMA DE FLUJO
Inicio

cal1, cal2, cal3,


cal4, cal5,
Promedio

“digite las 5
calificaciones obtenidas”

cal1, cal2, cal3, cal4, cal5

Promedio = cal1, cal2, cal3, cal4, cal5

Promedio=
>2.0

“su promedio es”, Promedio “NO


tiene derecho a examen de
nivelación” “su promedio es”, Promedio
“tiene derecho a examen de
nivelación”

Pseudocódigo Fin

Inicio
Escriba “digite las 5 calificaciones obtenidas”
Lea cal1, cal2, cal3, cal4, cal5
Promedio= cal1+cal2+cal3+cal4+cal5 /5
Si
Promedio=>2.0
Escriba “su promedio es”, Promedio “tiene derecho a examen de nivelación”
Sino
Escriba “su promedio es”, Promedio “NO tiene derecho a examen de nivelación”
Fin si
Fin

Prueba de escritorio
Calificaciones Promedio Mensaje
3, 2, 5, 4, 2 3.2 su promedio es 3.2 tiene derecho a examen de nivelación
3, 0, 3, 2, 1 1.8 su promedio es 1.8 NO tiene derecho a examen de nivelación

40. Diseñe un diagrama que lea los 2,500,000 votos otorgados a los 3 candidatos a
gobernador e imprima el número del candidato ganador y su cantidad de votos.

41. Suponga que tiene usted una tienda y desea registrar las ventas en una
computadora. Diseñe un pseudocódigo que lea por cada cliente, el monto total de su
compra. Al final del día escriba la cantidad total de las ventas y el número de
clientes atendidos.

42. Suponga que tiene una tienda y desea registrar sus ventas por medio de una
computadora. Diseñe un pseudocódigo que lea por cada cliente:
a).- el monto de la venta,
b).- calcule e imprima el IVA ,
c).-calcule e imprima el total a pagar,
d).- lea la cantidad con que paga el cliente,
e).-calcule e imprime el cambio.
Al final del día deberá imprimir la cantidad de dinero que debe haber en la caja.

42. Modificar el pseudocódigo anterior de tal forma que no permita que la cantidad
con la que paga el cliente sea menor a lo que debe pagar.

43. Se tiene un conjunto de 1,000 tarjetas cada una contiene la información del censo
para una persona:
1.- Número de censo,
2.- Sexo
3.- Edad
4.- Estado civil (a.- soltero, b. Casado, c. Viudo, d. Divorciado )
Diseñe un pseudocódigo estructurado que lea todos estos datos, e imprima el número de
censo de todas las jóvenes solteras que estén entre 16 y 21 años.

ANÁLISIS

DIAGRAMA DE FLUJO

INICIO

X=1 a 1000

“Digite numero de
censo”

Censo
“Digite su sexo 1-Masculino, 2-
Femenino”

Sexo
“Digite su estado civil 1-Soltero, 2-Casado, 3-Viudo, 4-
Divorciado”

Estadocivil

Edad=>16 or =< 21 or Sexo=1 or Estadocivil =1

Edad=>16 or =< 21 or Sexo=1 or Estadocivil =2 Escriba “Numero de censo”, Censo


Escriba “Sexo-Masculino”
Escriba “Estado civil-Soltero”
Edad=>16 or =< 21 or Sexo=1 or Estadocivil =3
Escriba “Numero de censo”, Censo
Escriba “Sexo-Masculino”
Escriba “Estado civil-Casado”
Escriba “Numero de censo”, Censo
Escriba “Sexo-Masculino”
Escriba “Estado civil-viudo”

Edad=>16 or =< 21 or Sexo=1 or Estadocivil =4

Escriba “Numero de censo”, Censo


Escriba “Sexo-Masculino”
Edad=>16 or =< 21 or Sexo=2 or Estadocivil =1 Escriba “Estado civil-Divorciado”

Edad=>16 or =< 21 or Sexo=2 or Estadocivil =2


Escriba “Numero de censo”, Censo
Escriba “Sexo-Femenino”
Escriba “Estado civil-Soltero”
Escriba “Numero de censo”, Censo
Edad=>16 or =< 21 or Sexo=2 orEscriba “Sexo-
Estadocivil =2 Femenino”
Escriba “Estado civil-Casado”

Escriba “Numero de censo”, Censo


Escriba “Sexo- Femenino”
Escriba “Estado civil-viudo”

Escriba “Numero de censo”, Censo


Escriba “Sexo- Femenino”
Escriba “Estado civil-Divorciado”

FIN
Pseudocódigo

Inicio
Mientras X=1 a 1000
Lea X
Escriba “Digite numero de censo”
Lea Censo
Escriba “Digite su sexo 1-Masculino, 2-Femenino”
Leer Sexo
Escriba “Digite su estado civil 1-Soltero, 2-Casado, 3-Viudo, 4-Divorciado”
Leer estadocivil
Si
Edad=>16 or =< 21 or Sexo=1 or Estadocivil =1
Escriba “Numero de censo”, Censo
Escriba “Sexo-Masculino”
Escriba “Estado civil-Soltero”
Sino
Edad=>16 or =< 21 or Sexo=1 or Estadocivil =2
Escriba “Numero de censo”, Censo
Escriba “Sexo-Masculino”
Escriba “Estado civil-Casado”
Sino
Edad=>16 or =< 21 or Sexo=1 or Estadocivil =3
Escriba “Numero de censo”, Censo
Escriba “Sexo-Masculino”
Escriba “Estado civil-viudo”
Sino
Edad=>16 or =< 21 or Sexo=1 or Estadocivil =4
Escriba “Numero de censo”, Censo
Escriba “Sexo-Masculino”
Escriba “Estado civil-Divorciado”
Escriba “Estudiantes con calificación igual a 50” Calificación
Sino
Edad=>16 or =< 21 or Sexo=2 or Estadocivil =1
Escriba “Numero de censo”, Censo
Escriba “Sexo-Femenino”
Escriba “Estado civil-Soltero”
Sino
Edad=>16 or =< 21 or Sexo=1 or Estadocivil =2
Escriba “Numero de censo”, Censo
Escriba “Sexo-Femenino”
Escriba “Estado civil-Casado”
Sino
Edad=>16 or =< 21 or Sexo=1 or Estadocivil =3
Escriba “Numero de censo”, Censo
Escriba “Sexo-Femenino”
Escriba “Estado civil-viudo”
Sino
Edad=>16 or =< 21 or Sexo=1 or Estadocivil =4
Escriba “Numero de censo”, Censo
Escriba “Sexo-Femenino”
Escriba “Estado civil-Divorciado”
Escriba “Estudiantes con calificación igual a 50” Calificación
Fin si
Fin si
Fin si
Fin si
Fin si
Fin si
Fin si
Fin Mientras
Fin

Prueba de escritorio

Calificaciones 57, 50, 64, 70, 52, 80, 84, 92

Igual a 50 = > a 50 pero < 80 = > a 70 pero < 80 = > 80

Estudiantes 3 5 1 3

44. Diseñe un pseudocódigo que lea el valor de un ángulo expresado en radianes y


calcule e imprima el valor del seno de dicho ángulo. Se leerá también el número de
términos de la serie.
SEN(X) = X - ( X 3 / 3 ! ) + ( X 5 / 5 ! ) - (X7/ 7!) + .....

45. -Un jeep puede viajar 500 km con un tanque lleno de gasolína. Desde una
posición inicial, conteniendo ‘n’ tanques de gasolína el mismo jeep puede viajar:
L = 500 ( 1 + 1/3 + 1/5 + ...+ 1 / (2n -1) ) km
Estableciendo economía de combustible en una ruta . Diseñe un
pseudocódigo que calcule el valor de ‘L’ dado ‘ n ‘ .

46. Se ofrece un trabajo que pague un centavo en la primera semana, pero dobla su
salario cada semana, es decir , $.01 la primera semana; $.02 la segunda semana;
$0.4 la tercera semana; ... etc. Hasta $(2n-1)/100 la n- ésima . Diseñar el
pseudocódigo que determine ( y escriba ) el salario por cada semana y el salario
pagado hasta la fecha por espacio de 50 semanas.

47. Diseñe un pseudocódigo que calcule e imprima el pago de 102 trabajadores que
laboran en la Cía. GACMAN. Los datos que se leerán serán los siguientes:
a) Las horas trabajadas
b) El sueldo por hora
c) El tipo de trabajador (1.-obrero,2.-empleado)
Para calcular los pagos considerar lo siguiente:
- Los obreros pagan 10 % de impuesto
- Los empleados pagan 10 % de impuesto.
- Los trabajadores (obreros y empleados) que reciban un pago menor de 100,000 pesos
no pagan impuesto.
-Al final se deberá imprimir el total a pagar a los trabajadores y a los empleados.

ANÁLISIS
Total=Horas*Preciohora
TotalSueldo=Horas*Preciohora
A=Total*0.10
B=Total-A

DIAGRAMA DE FLUJO

INICIO

X=1 a
102

“Digite las horas


trabajadas”

Horas

“Digite el
precio hora”

PrecioHoras

Total=Horas*Preciohora
Total=Total+1

“Digite tipo de
trabajador 1-obrero,
2-empleado”

Tipo

TotalSueldo=Horas*Preciohora

TotalSueldo>100.00
0 or Tipo=1

A=Total*0.10
TotalSueldo>100.00 B=Total-A
0 or Tipo=2

FIN
A=Total*0.10 “total obreros”,
TotalSueldo<100.00 B=Total-A B
0 or Tipo=1

“total empleados”, “total empleados”,


Total “total obreros”, Total
B

Pseudocódigo

Inicio
Hacer para X=1 a 102
Escriba “Digite las horas trabajadas”
Leer Horas
Escriba “Digite el precio hora”
Leer Preciohora
Total=Horas*Preciohora
Total=Total+1
Escriba “Digite tipo de trabajador 1-obrero, 2-empleado”
Tipo
TotalSueldo=Horas*Preciohora
Si
TotalSueldo>100.000 or Tipo=1
A=Total*0.10
B=Total-A
Escriba “total obreros”, B
Sino
TotalSueldo>100.000 or Tipo=2
A=Total*0.10
B=Total-A
Escriba “total empleados”, B
Sino
TotalSueldo<100.000 or Tipo=1
Escriba “total obreros”, Total
Sino
TotalSueldo<100.000 or Tipo=2
Escriba “total empleados”, Total
Fin si
Fin si
Fin si
Fin

Prueba de escritorio

Horas Trabajadas Precio Hora Tipo Trabajador Total


5 2000 Empleado 10000

48. - Diseñar un pseudocódigo que convierta un número del sistema decimal a :


a) sistema binario b)sistema octal c)sistema hexadecimal. Según se elija.

48. Un objeto es dejado caer a una altura de 100 mts. Diseñe un pseudocódigo que
imprima cada décima de segundo la distancia entre el objeto y el suelo y al final
imprima el tiempo necesario en décimas de segundo para que el objeto toque el
suelo.

Análisis

Decima = segundos * 10
Time = decima * 100

DIGRAMA DE FLUJO:
Inicio

“digite las el tiempo en segundos que demoro


el objeto en caer al suelo”

Segundos

Decimasegundos*10

Timedecima*100

“el objeto se demora en


caer”, decima “decima de
segundos”

“el objeto se demora en caer”,


time “por cada metro”

Fin
Pseudocódigo

Inicio
Escriba “digite las el tiempo en segundos que demoro el objeto en caer al suelo”
Lea segundos
Decima= segundos*10
Time= Decima/100
Escriba “el objeto se demora en caer”, decima “decima de segundos”
Escriba “el objeto se demora en caer”, time “por cada metro”
Fin

Prueba de escritorio

Segundos Decima de segundos Time


15 150 15000

49. La Cía. Automovilística Mexicana, S.A. de C.V premia anualmente a sus


mejores vendedores de acuerdo a la siguiente tabla:

Si vendió Le corresponde de Comisión


Sobre ventas totales
1, 000,000 <= v < 3, 000,000 3%
3, 000,000 <= v < 5, 000,000 4%
5, 000,000 <= v < 7, 000,000 5%
7, 000,000 <= v 6%
Diseñar un pseudocódigo que lea las ventas de 100 vendedores y que
escriba la comisión anual que le corresponda a cada vendedor. Suponer que nadie vende
más de 10,000,000 al año.
ANALISIS

Si la venta es mayor de mil y meno de 30000


Comisión = 3%
Si la venta es mayor a 3.000.000 y menor a 5000.000
Comisión = 4%

Si la venta 5, 000,000 <= v < 7, 000,000


Comisión = 5%

7, 000,000 <= v
Si la venta
Comisión= 6%
PSEUDOCODIGO
Inicio
Venta comicio c total
Entrada
Diguite el valor de la venta
Lea valor venta
Diguite el sueldo
Lea sueldo
Si v = 1,000, 000 <= asta < 3, 000,000
Ct= s + 3%
Sino
Si 3, 000,000 <= v < 5, 000,000 entonces
Ct= s+4%
Sino
Si 5, 000,000 <= v < 7, 000,000
Ct = s+ 5%
Sino
Si venta 7, 000,000 <= v entonces
Ct=s+6%
Sino
No hay comisión
Mostrar ct

50. Diseñe un pseudocódigo que imprima la fecha en palabras a partir de la


representación siguiente: S, DD, MM, AA.
En donde:
S = Día de la semana, 1 a 7 (1 = lunes; 2 = martes; etc...);
DD = Día del mes, 1 a 30 ó 31, según el mes. Fijar el mes de febrero con 28 días;
AA = Dos últimas cifras del año.

51. Un grupo de 100 estudiantes presentan un exámen de Física. Diseñe un diagrama


que lea por cada estudiante la calificación obtenida y calcule e imprima:
A.- La cantidad de estudiantes que obtuvieron una calificación menor a 50.
B.- La cantidad de estudiantes que obtuvieron una calificación de 50 o más pero menor
que 80.
C.- La cantidad de estudiantes que obtuvieron una calificación de 70 o más pero menor
que 80.
D. La cantidad de estudiantes que obtuvieron una calificación de 80 o más.

ANÁLISIS

Calificación= Calificación + 1

DIAGRAMA DE FLUJO

INICIO

X=1 a
100

“Digite la calificación
obtenida”
Horas

“Digite el
precio hora”

Calificación

Calificación= 50

Calificación= Calificación + 1
Calificación=>50 or <
80
“Estudiantes
con calificación
Calificación= Calificación + 1
Calificación=>70 or igual a 50”
<80 Calificación
Escriba Escriba
Escriba
“Estudiantes “Estudiantes
“Estudiantes
con calificación con calificación
con calificación
mayor a 80” igual o mayor a
igual o mayor a
Calificación 50 y menor que
70 y menor que
Calificación 80” Calificación
80” Calificación

FIN
Pseudocódigo
Inicio
Mientras X=1 a 100
Escriba “Digite la calificación obtenida”
Leer Calificación
Si
Calificación= 50
Calificación= Calificación + 1
Escriba “Estudiantes con calificación igual a 50” Calificación
Sino
Calificación=>50 or < 80
Calificación= Calificación + 1
Escriba “Estudiantes con calificación igual o mayor a 50 y menor que 80” Calificación
Sino
Calificación=>70 or <80
Calificación= Calificación + 1
Escriba “Estudiantes con calificación igual o mayor a 70 y menor que 80” Calificación
Sino
Calificación=>80
Calificación= Calificación + 1
Escriba “Estudiantes con calificación mayor a 80” Calificación
Fin si
Fin si
Fin si
Fin Mientras
Fin

Prueba de escritorio
Calificaciones 57, 50, 64, 70, 52, 80, 84, 92

Igual a 50 = > a 50 pero < 80 = > a 70 pero < 80 = > 80

Estudiantes 3 5 1 3

51. Un avión que viaja 800 Km/hr. Dispara un proyectil autoimpulsado, en el


momento del disparo, el avión hace un giro de 90 0 y acelera a 20 mtrs/seg2. El
proyectil sigue su curso, acelerando a 10 mtrs./seg2.
Diseñe un pseudocódigo que escriba cada segundo, la distancia que separa al avión del
proyectil, hasta que estén a 10,000 mtrs. o más.

52. Una pizzería, vende sus pizzas en tres tamaños:


pequeña (10 pul. De diámetro); mediana (12 pulg. De diámetro); y grandes (16 pulg. De
diámetro); Una pizza puede ser sencilla (con sólo salsa y carne), o con ingredientes
extras, tales como pepinillos, champiñones o cebollas
Los propietarios desean desarrollar un programa que calcule el precio de venta de una
pizza, dándole el tamaño y el numero de ingredientes extras. El precio de venta será 1.5
veces el costo total, que viene determinado por el área de la pizza, mas el numero de
ingredientes.
En particular el costo total se calcula sumando:
- un costo fijo de preparación
- un costo base variable que es proporcional al tamaño de la pizza
- un costo adicional por cada ingrediente extra. Por simplicidad se supone que cada
ingrediente extra tiene el mismo costo por unidad de área.

ANÁLISIS
Se toman las opciones se la piza según su tamaño y la forma de la pizza
Teniendo en cuenta si la quiere especial o sencilla

DIAGRAMA DE FLUJO:
Pseudocódigo

entero tampiz, fpiz


hiofh+

inicioescriba "Digite 1 para elegir pizza pequeña, Digite 2 para elegir pizza mediana, Digite 3
para elegir pizza grande"
llamar nueva_linea
lea tampiz
llamar nueva_linea
Si tampiz = 1 Entonces
escriba "la pizza es pequeña"
si tampiz = 2 Entonces
escriba "la pizza es Mediana"
si tampiz = 3 Entonces
escriba "la pizza es Grande"
Fin Si
fin si
fin si
llamar nueva_linea
escriba "Ingrese forma de la pizza (Sencilla) o (Extra)"
llamar nueva_linea
lea fpiz

PRUEBA DE ESCRITORIO:

TAMAÑO DE LA PIZZA FORMA DE LA PIZZA


OP1 OP2
OP3 OP1
OP2 OP2

53. Diseñar un pseudocódigo que calcule el promedio ponderado para alumno del ITT .
El cálculo se hace de la siguiente forma:
- Se multiplica cada calificación por los créditos de cada materia
- El resultado anterior se suma con los resultados de todas las materias, por separado se
suman los créditos de cada materia y finalmente se divide la suma de todas las materias
por sus respectivos créditos, entre la suma de todos los créditos.

Análisis
A= calificacion1*credito1
B= calificacion2*credito2
C= calificacion3*credito3
D= calificacion4*credito4
E= calificacion5*credito5
T=A+B+C+D+E
Suma= credito1+credito2+credito3+credito4+credito5
Promedio=T/Suma

DIAGRAMA DE FLUJO

INICIO

“Digite calificación
de cada materia”

cal1, cal2, cal3,


cal4, cal5

“Digite los
créditos de cada
materia”

“Digite los créditos de


cada materia”

A= cal1*cre1
B= cal2*cre2
C= cal3*cre3
D= cal4*cre4
E= cal5*cre5
T=A+B+C+D+E
Suma= cre1+cre2+cre3+cre4+cre5
Promedio=T/Suma

“el promedio ponderado


de el alumno es”,
Promedio

FIN

Pseudocódigo

Inicio
Escriba “Digite calificación de cada materia”
Leer cal1, cal2, cal3, cal4, cal5
Escriba “Digite los créditos de cada materia”
Leer cre1, cre2, cre3, cre4, cre5
A= cal1*cre1
B= cal2*cre2
C= cal3*cre3
D= cal4*cre4
E= cal5*cre5
T=A+B+C+D+E
Suma= cre1+cre2+cre3+cre4+cre5
Promedio=T/Suma
Escriba “el promedio ponderado de el alumno es”, Promedio
Fin

Prueba de escritorio

Calificaciones Créditos Multiplicación SuMultiplicación


5 2 4 2 1 1 2 1 2 1 5 4 4 4 1 7

53. Calcule la suma de los términos de la serie FIBONACCI cuyos valores se


encuentran entre 100 y 10,000.

54. Calcule exactamente el número de días vividos por una persona hasta la fecha.
Contemplar los años bisiestos.

ANALISIS:
Año=365 Dias
Nºaños=años
Diasvividos=año*Nºaños

DIAGRAMA DE FLUJO: INICIO

Año, nºaños,diasvividos

“digite su edad actual”

Nºaños

Diasvividos=año*Nºaños

“los días vividos por usted es de:”;


diasvividos

Fin
Pseudocódigo:

Inicio
Año, nºaños, diasvividos
Escriba (“el numero de años que tiene”)
Lea(nºaños)
Diasvividos=dias*Nºaños
Escriba (“los días vividos por usted son de:” ; diasvividos)
Fin

PLUEBA DE ESCRITORIO:

nºaños días Diasvividos mostrar


23 365º 3895 3895