Vous êtes sur la page 1sur 4

Hello tout le monde.

Vous utilisez plein de loopers pour votre training scratch et vous avez
toujours voulu en faire un ? Alors ce tutoriel est pour vous.

Introduction

Nous allons voir ici comment faire un looper grâce à flash. Je ne vais pas vous expliquer
comment faire des visu qui claquent et des animations de fou, mais seulement comment a
partir de vos loops, les intégrer et les faire interagir avec les boutons afin de les lire.
Uniquement ça, pour le graphisme il y a largement assez de sites internet dédiés à ca.

Pré requis

- Ses sons au format .wav (16bit, 44100hz)


- Flash installé (de Flash MX 2004 à Flash CS3)
- De la place sur votre disque (tout dépend du nombre de boucles que vous voulez dans votre
looper. Car au format .wav, ca prend vite beaucoup de place)

Préambule de Flash

Ce tutoriel est fait pour les versions de Flash MX 2004 à Flash CS3, il y’aura donc 2 parties
au niveau programmation, une partie ActionScript 2.0 et une partie ActionScript 3.0, bien sur
la version conseillée est l’AS3.0 mais elle est uniquement disponible sous Flash CS3.

Flash CS3 est disponible gratuitement sur le site d’Adobe.

On s'y met

Alors pour commencer créons notre dossier ou nous allons mettre nos fichiers. Ensuite pour
plus d'organisation (oui à notre niveau c'est pas forcement évident mais c'est toujours mieux
de faire correctement les choses ;)).

Donc ensuite allons sur Flash et créons un nouveau projet Flash AS2 ou AS3 que nous allons
nous empresser de sauvegarder dans le dossier fraichement créé.

La première chose est d'importer les sons dans flash. Pour se faire, aller dans le menu «
Fichiers->Importer->Importer dans la bibliothèque... », sélectionner toutes vos boucles (si
elles sont dans le même dossier) et importer.
Ensuite nous allons les nommer de façon plus simple puis faites un clique droite sur le nom
puis aller dans Liaison. Cochez la case Exporter pour ActionScript. (Un avertissement peut
apparaitre, il suffit de cliquer sur OK et décocher la case de rappel), nommer le beat1, et
répéter pour tous les sons : beat1, beat2, beat3…… beatx

Créons maintenant le bouton qui nous permettra de lire notre loop. J'ai choisi de simplement
afficher le numéro, donc se sera avec l'outil texte mais vous pouvez très bien importer des
images dans notre bibliothèque, ensuite (que se soit texte ou image), faites un clique droit sur
le texte, puis convertir en symbole..., nommez le bouton1 choisissez Clip. Il va apparaître
dans la bibliothèque. Ensuite donner lui un nom d’occurrence « bt1 », répéter pour tout les
boutons : bt1, bt2, bt3……..btx

Et c'est parti pour le charabia

Nous allons maintenant faire intéragir nos boutons avec les sons. Commencez par cliquez sur
l’image n°1 de la timeline (ou dans le gris du document), ensuite afficher la fenêtre d'actions
en allant dans le menu « Fenêtre->Actions »

Si vous avez choisie l’AS2 voici le code a mettre :

Citation :

// LOOP definie le nombre de beat ici c’est 4


var LOOP:Number = 4 ;
var sound:Sound = new Sound();

for (var i:Number = 1; i<=LOOP; i++) {


this["bt"+i].addEventListener("click",player);
}

function player(event) {
sound.stop();
var n:Number = parseInt(event.target._name.substr("bt".length));
sound.attachSound("beat"+n);
sound.start(0,1000);
}
Si vous avez choisie l’AS3 voici le code a mettre :
Citation :

// LOOP definie le nombre de beat ici c’est 4


var LOOP:Number = 4;
var channel:SoundChannel = new SoundChannel();

for (var i:int=1; i<=LOOP; i++) {


this["bt" + i].addEventListener(MouseEvent.CLICK, player);
}

function player(event:MouseEvent):void {
var n:Number = parseInt(event.target.name.substr("bt".length()));
channel.stop();
var sound = getDefinitionByName("beat" + n);
var snd:Object = new sound();
channel = snd.play(0,1000);
}

Maintenant pour tester il suffit de faire « ctrl+enter » et cliquer sur le bouton afin d'entendre
notre loop se jouer en boucle :)
Le son est bizarre ? c’est normal allez dans Fichier -> Paramètres de publication -> onglet
Flash ->faites Définir « pour son d’événement »
Choisissez MP3, décocher le prétraitement, et mettez la vitesse à 128.

Maintenant dans l’onglet Formats, allez cocher projection windows ou mac

Quand votre looper sera finit, allez dans « Fichier->Publier->»


RDV dans votre dossier pour découvrir votre fichier swf, exe ou app

Par :
Mindless aka. Skram, 01 novembre 2007
Contact : david.ansermot@gmail.com
Stealth, 06 novembre 2007
Contact : jinmoku@hotmail.com