Vous êtes sur la page 1sur 18

Tema 1: SQL Server

Requerimientos de este laboratorio:

 SQL SERVER 2005 o 2008


 Visual Studio 2008

Paso 1: Iniciar en todos los programas – Microsoft SQL Server – SQL Server Management Studio.

Paso 2: Teclear el nombre del servidor (Nombre Equipo\Instancia de SQL Server instalada), autenticación de
SQL Server o Autenticación de Windows, Inicio de sesión (Usuario: sa + password) si se trata de autenticación
SQL Server.

Paso 3: Dar clic en Nueva Consulta, en donde podrá teclear el código T-SQL de este laboratorio.

Paso 4: Crear una base de datos como la siguiente figura:


Paso 5: Teclee un nombre de base de datos y de agregar.

Paso 5: Después de agregar la base de datos, debe utilizarla, dando clic en la lista y seleccionando la base de
datos Tienda.
Paso 6: Empiece a escribir código T-SQL en el espacio de trabajo de SQL Server.

Código Tabla Productos:

CREATE TABLE [dbo].[Productos] (


[Codigo] [int] IDENTITY(1,1) NOT NULL,
[Descripcion] [varchar](30) NOT NULL,
[Precio] [float] NOT NULL
)
ALTER TABLE [Productos] ADD CONSTRAINT PK_Productos PRIMARY KEY(Codigo)
GO

Para ejecutar el código que se ha tecleado debe seleccionar toda la sentencia y dar clic en el botón Ejecutar o
F5 desde el teclado.
Si no hubo ningún error al ejecutar la sentencia nos mandará este mensaje.

Código Tabla Ventas:

CREATE TABLE [dbo].[Ventas] (


[Codigo] [int] identity(1,1) NOT NULL,
[Fecha] [datetime] DEFAULT getdate()
)
ALTER TABLE [Ventas] ADD CONSTRAINT PK_Ventas PRIMARY
KEY(Codigo)
GO

Código Tabla Productos Venta:

CREATE TABLE [dbo].[ProductosVenta] (


[Codigo] [int] identity(1,1) NOT NULL,
[CodigoVenta] [int],
[CodigoProducto] [int],
[Cantidad] [int] DEFAULT 0
)
ALTER TABLE [ProductosVenta] ADD CONSTRAINT PK_ProductosVenta PRIMARY KEY(Codigo)
GO
Código Llaves Foráneas Productos Venta:

ALTER TABLE [ProductosVenta] ADD CONSTRAINT FK_ProductosVenta_Venta FOREIGN


KEY(CodigoVenta)
REFERENCES [Ventas] (Codigo)
ALTER TABLE [ProductosVenta] ADD CONSTRAINT FK_ProductosVenta_Productos FOREIGN
KEY(CodigoProducto)
REFERENCES [Productos] (Codigo)
GO

Código Agregar Productos:

INSERT INTO Productos (Descripcion, Precio) VALUES ('MotherBoard PC333', 45.30);


INSERT INTO Productos (Descripcion, Precio) VALUES ('Placa de Red 100 Mbps', 15.75);
INSERT INTO Productos (Descripcion, Precio) VALUES ('Microprocesador 1GHz', 112.90);
INSERT INTO Productos (Descripcion, Precio) VALUES ('Disco Rígido 7200 rpm', 84.10);
INSERT INTO Productos (Descripcion, Precio) VALUES ('Access Point Wi-Fi 802.11g', 66.40);
INSERT INTO Productos (Descripcion, Precio) VALUES ('Placa de Red PCMCIA', 25.00);
INSERT INTO Productos (Descripcion, Precio) VALUES ('Hub USB 4 Puertos', 12.80);
INSERT INTO Productos (Descripcion, Precio) VALUES ('Mouse óptico', 33.60);
INSERT INTO Productos (Descripcion, Precio) VALUES ('Monitor 17 pulgadas', 175.50);
INSERT INTO Productos (Descripcion, Precio) VALUES ('Gabinete Mid-Tower', 35.30);
INSERT INTO Productos (Descripcion, Precio) VALUES ('Teclado Internet', 25.80);
INSERT INTO Productos (Descripcion, Precio) VALUES ('Placa de Video 128 MB', 45.70);
INSERT INTO Productos (Descripcion, Precio) VALUES ('DVD-ROM 8x', 45.00);
GO

Código Seleccionar Productos:

select * from Productos


Tema 2: Conectando SQL Server con Visual Studio 2008.
Paso 1: Todos los programas – Visual Studio 2008.

Paso 2: Ir al menú Ver (View) y dar clic en el Explorador de Servidores (Server Explorer).

Paso 3: Agregar una nueva conexión a la base de datos.

Paso 4: Seleccionar el proveedor de acceso a datos (SQL SERVER) y de clic en Aceptar (OK).

Paso 5: Seleccionar el proveedor de acceso a datos (SQL SERVER) y de clic en Aceptar (OK).
Paso 6: Seleccionar el nombre del servidor, si cuenta con usuario con autenticación SQL Server o de lo
contrario puede ser de tipo Windows, por ultimo seleccione la base de datos de la lista.

Paso 7: Pruebe la conexión y de OK.


Paso 8: Podemos navegar por el explorador de servidores y ver las tablas que ha creado desde SQL Server
Management Studio.

Paso 9: Podemos navegar por el explorador de servidores y ver las tablas que ha creado desde SQL Server
Management Studio.

Tema 3: Creando una aplicación Windows Forms con Visual Studio


2008.
Paso 1: Ir al menú Archivo (File)- Nuevo (New) – Proyecto (Project).

Paso 2: Escoger un proyecto Visual Basic o Visual C# de tipo Windows Forms Application, teclee un nombre de
la aplicación y escoja el directorio.
Paso 2: Seleccione menú Datos (Data) – Agregar nuevo recurso de datos… (Add New Data Source…)

Paso 3: Seleccione menú Datos (Data) – Agregar nuevo recurso de datos… (Add New Data Source…)
Paso 3: Seleccione la opción base de datos.

Paso 4: Seleccione la cadena de Conexión.


Paso 5: Escriba un nombre de cadena de conexión.

Paso 6: Seleccione un objeto (tabla) que se incorporan en el DataSet.


Paso 7: El diseñador ha creado un DataSet y un TableAdapter.

Paso 8: Agregue una nueva consulta.

Paso 9: Seleccione la opción de Utilizar sentencias SQL (Use SQL Statements).


Paso 10: Seleccione la opción de Seleccionar con filas retornadas. (SELECT which returns rows).

Paso 11: Puede personalizar la consulta creada o dar clic en siguiente.


Paso 12: Personalice los métodos dependiendo lo que usted quiere obtener.

Paso 13: De clic en Finalizar.


Paso 14: Seleccione un control DataGridView de la barra de herramientas (Toolbox) del lado izquierdo de su
entorno. Si no encuentra dicha barra, puede ir a menú Ver ( View )– Barra de Herramientas (Toolbox)

Paso 15: Seleccione un control BindingSource de la barra de herramientas (Toolbox) del lado izquierdo de su
entorno. Si no encuentra dicha barra, puede ir a menú Ver ( View )– Barra de Herramientas (Toolbox).
Paso 16: Seleccione el control BindingSource que agregó en el paso anterior y presione F4 o clic derecho
“Propiedades”, seleccione la propiedad DataSource y despliegue la siguiente lista.

Paso 17: Seleccione el recurso de datos TiendaDataSet.


Paso 18: Seleccione la propiedad DataMember y después la tabla Productos.

Paso 19: En la parte de abajo Visual Studio ha creado tres controles.

Paso 20: En la parte de abajo Visual Studio ha creado tres controles.

Paso 21: Seleccione la pestaña de arriba del control DataGridView, de clic en la opción Seleccionar Recurso de
datos y después seleccione BindingSource1.
Paso 22: Presione F5 para visualizar los datos.

Material elaborado por Microsoft Student Partners.

Dudas o Preguntas:
edison@student-partners.com
Blog:
http://mredison.wordpress.com