Vous êtes sur la page 1sur 51

RESEAUX

ROUTEUR
Plan
Généralités
ִRappels
ִFonctions WAN d’un routeur
ִFonction LAN d’un routeur
ִProtocoles routés / de routage
Architecture d’un routeur cisco
Séquence de démarrage d’un routeur cisco
Configuration minimale d ’un routeur cisco

Jean-Luc Damoiseaux - Dpt R&T


Luminy
Rappels (1)
Adresse logique
(par exemple 198.133.219.25)
Paquet
routeur

Adresse physique
(par exemple 00-50-56-C0-00-01)
Topologie logique
(par exemple bus ou anneau)

commutateur pont carte réseau Trame

Topologie physique
(par exemple étoile, bus, anneau)
Jean-Luc Damoiseaux - Dpt R&T
concentrateur répéteur cable Luminy Train de bits
Rappels (2)

Jean-Luc Damoiseaux - Dpt R&T


Luminy
Fonctions WAN d’un Routeur

Un routeur détermine, à partir de l’adresse


logique contenue dans le paquet, le meilleur
chemin pour atteindre le destinataire

Un routeur connecte des réseaux utilisant


des technologies différentes au niveau de la
couche liaison

Jean-Luc Damoiseaux - Dpt R&T


Luminy
Exemple (1-a) : sélection du
chemin

Jean-Luc Damoiseaux - Dpt R&T


Luminy
Exemple (1-b) : sélection du
chemin

Jean-Luc Damoiseaux - Dpt R&T


Luminy
Exemple (2) : Interconnexion
de réseau

Jean-Luc Damoiseaux - Dpt R&T


Luminy
Couche Physique WAN

Jean-Luc Damoiseaux - Dpt R&T


Luminy
Couche liaison de données
WAN

Jean-Luc Damoiseaux - Dpt R&T


Luminy
Fonction LAN d’un Routeur (1)

Segmente un réseau LAN en augmentant le


nombre de domaines de broadcast mais en
diminuant leur taille

Jean-Luc Damoiseaux - Dpt R&T


Luminy
Domaine de collisions : liè à Ethernet ; zone
réseau dans laquelle voyagent des trames qui
peuvent rentrer en collision avec d'autres

Domaine de broadcast : Ensemble de tous les


dispositifs qui recevront des trames de
diffusion provenant de n'importe quel des
dispositifs faisant partie de cet ensemble
Jean-Luc Damoiseaux - Dpt R&T
Luminy
1 domaine de collision / 1 domaine de broadcast
Jean-Luc Damoiseaux - Dpt R&T
Luminy
0 domaine de collision / 1 domaine de broadcast
Jean-Luc Damoiseaux - Dpt R&T
Luminy
4 domaines de collision / 1 domaine de broadcast
Jean-Luc Damoiseaux - Dpt R&T
Luminy
0 domaine de collision / 1 domaine de broadcast
Jean-Luc Damoiseaux - Dpt R&T
Luminy
4 domaines de collision / 4 domaines de broadcast
Jean-Luc Damoiseaux - Dpt R&T
Luminy
0 domaine de collision / 4 domaines de broadcast
Jean-Luc Damoiseaux - Dpt R&T
Luminy
Fonction LAN d’un Routeur
(2-a)

Jean-Luc Damoiseaux - Dpt R&T


Luminy
Fonction LAN d’un Routeur
(2-b)

Jean-Luc Damoiseaux - Dpt R&T


Luminy
Protocoles routés / de
routage

Les protocoles routés (routables) sont des


protocoles prenant en charge les fonctions
de la couche réseau (IP,IPX,AppleTalk)

Les protocoles de routages fournissent les


mécanismes de partage et de gestion des
tables de routage entre les routeurs
(RIP,IGRP,EIGRP,OSPF)
Jean-Luc Damoiseaux - Dpt R&T
Luminy
Plan
Généralités
Architecture d’un routeur cisco
ִAspect
ִComposants et leur contenu
ִAccès à un routeur
Séquence de démarrage d’un routeur cisco
Configuration minimale d ’un routeur cisco

Jean-Luc Damoiseaux - Dpt R&T


Luminy
Aspect exterieur

Jean-Luc Damoiseaux - Dpt R&T


Luminy
Principaux composants de
configuration (1)

Jean-Luc Damoiseaux - Dpt R&T


Luminy
Principaux composants de
configuration (2)
Mémoire
ִROM : Read Only Memory
ִRAM : Random Access Memory
ִNVRAM : Nonvolatile RAM
ִFlash : Mémoire morte réinscriptible
(eeprom)
ִRegistre de configuration
Connectique
ִInterfaces : connexions réseau
ִConsole : Prise d’accès
Jean-Luc Damoiseaux direct
Luminy
- Dpt R&T

ִAuxiliaire : Prise d’accès par modem


Principaux composants de
configuration (3)

Jean-Luc Damoiseaux - Dpt R&T


Luminy
Contenu des composants de
configuration

Jean-Luc Damoiseaux - Dpt R&T


Luminy
Contenu de la ROM
Bootstrap : démarre le routeur et charge le système
POST (Power-On Self Test) : teste le fonctionnement
des composants physiques du routeur (processeur,
mémoire, interface)
ROM monitor : commandes de bas niveau pour
tester et administrer le routeur
Mini-IOS (RXBOOT) : mini-système suffisant pour
monter une interface puis charger un système
d’exploitation plus complet
Jean-Luc Damoiseaux - Dpt R&T
Luminy
Contenu de la RAM

Le système d’exploitation en cours


d’exécution
Les différentes tables et files d’attente
(ARP, routage, etc.)
Le fichier de configuration active (running
config)

Jean-Luc Damoiseaux - Dpt R&T


Luminy
Fichier de configuration
LAB-A#show run
Building configuration...
Current configuration:
version 11.1
hostname LAB-A
enable secret 5 $1$xT7v$9EC3X5IBHLwq2RehHNvWc
interface Ethernet0
ip address 192.5.5.1 255.255.255.0
shutdown
router rip
network 192.5.5.0
network 205.7.5.0
Jean-Luc Damoiseaux - Dpt R&T
Luminy
Contenu de la NVRAM et de la
flash

NVRAM : Le fichier de configuration de


démarrage (startup config)

FLASH : Une ou plusieurs images du


système d’exploitation (IOS)

Jean-Luc Damoiseaux - Dpt R&T


Luminy
Nom de l’IOS

Jean-Luc Damoiseaux - Dpt R&T


Luminy
Contenu du registre de
configuration

Valeur codée sur deux octets et indiquant


comment le routeur démarre et d’où il
charge le système
15 14 13 12 11 10 9 8 7 6 5 4 3 2 1 0
Break disabled Ignore NVRAM Boot field
00 ROM monitor
01 Boot image from ROM
02-F Specifies a default
Exemples : boot filename
0x2102 0010 0001 0000 0010
0x2142 0010 0001 0100 0010
Jean-Luc Damoiseaux - Dpt R&T
Luminy
Accès au routeur (1)

Jean-Luc Damoiseaux - Dpt R&T


Luminy
Accès au routeur (2)

Jean-Luc Damoiseaux - Dpt R&T


Luminy
Accès au routeur (3)

Jean-Luc Damoiseaux - Dpt R&T


Luminy
Accès au routeur (4)

Jean-Luc Damoiseaux - Dpt R&T


Luminy
Plan
Généralités
Architecture d’un routeur cisco
Séquence de démarrage d’un routeur cisco
ִSchéma général
ִModification du démarrage
ִPrompt et mode de démarrage
ִDémarrage classique / récupération de mot de
passe
minimale
ConfigurationJean-Luc Damoiseaux - d ’un routeur cisco
Dpt R&T
Luminy
Schéma général

Jean-Luc Damoiseaux - Dpt R&T


Luminy
Modification de la séquence
de démarrage
Changement de la valeur du registre de
configuration
ִ0Xnnn0démarrage en moniteur ROM
ִ0Xnnn1 chargement de la première image en flash
ִ0Xnnn2 – 0Xnnnf utilisation des commandes boot
system
Commande boot system :
ִSituées dans la NVRAM
ִSpécifie la localisation du système chargé lors du
démarrage
Jean-Luc Damoiseaux - Dpt R&T
Luminy
Prompts et modes de démarrage

Jean-Luc Damoiseaux - Dpt R&T


Luminy
Démarrage « Classique »
(OX2102)

Jean-Luc Damoiseaux - Dpt R&T


Luminy
Démarrage récupération
mot de passe (0x2142)

Jean-Luc Damoiseaux - Dpt R&T


Luminy
Plan
Généralités
Architecture d’un routeur cisco
Séquence de démarrage d’un routeur cisco
Configuration minimale d ’un routeur cisco
ִModes de configuration
ִGestion du nom, des mots de passe
ִGestion des interfaces
ִGestion du routage
Jean-Luc Damoiseaux - Dpt R&T
Luminy
Modes de configuration

Jean-Luc Damoiseaux - Dpt R&T


Luminy
Configuration du nom et de la
bannière d’accueil
Router> enable
Router# configure terminal
Router(config)#hostname Marseille
Marseille(config)# banner motd $ Bienvenue sur
Marseille, accès autorisé uniquement $

Jean-Luc Damoiseaux - Dpt R&T


Luminy
Configuration des mots de
passe

Accès administrateur

Encryption de tous les mots de passes

Jean-Luc Damoiseaux - Dpt R&T


Luminy
Configuration des mots de
passe

Accès console par la liaison série

Accès telnet (ou virtual terminal)

Jean-Luc Damoiseaux - Dpt R&T


Luminy
Configuration d ’une interface
ethernet et fast-ethernet
Router(config)#interface ethernet 0
Router(config-if)#ip address 10.0.0.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit

Router(config)#interface fast 0/0


Router(config-if)#ip address 10.0.0.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit

Jean-Luc Damoiseaux - Dpt R&T


Luminy
Configuration d ’une
interface série
Le routeur est le DCE
Router(config)#interface s0
Router(config-if)#ip address 10.0.0.1 255.255.255.0
Router(config-if)#clock rate 56000
Router(config-if)#no shutdown

Le routeur est le DTE


Router(config)#interface s0
Router(config-if)#ip address 10.0.0.1 255.255.255.0
Router(config-if)#no shutdown

Jean-Luc Damoiseaux - Dpt R&T


Luminy
Configuration de RIP v1
Router(config)#router rip
Router(config-router)#network 172.16.0.0
Router(config-router)#network 160.89.0.0
Router(config-router)#network 172.30.0.0
Router(config-router)#exit

Jean-Luc Damoiseaux - Dpt R&T


Luminy