Vous êtes sur la page 1sur 29

Les raccourcis claviers

Écrit par Pybourdin Marc


26-06-2007

En fonction des méthodes que vous utilisez pour vous connecter à votre routeur Cisco, les flèches
ou autre moyen de navigation usuels peuvent fonctionner de manière aléatoire.

Voici la liste des raccourcis claviers vous permettant de naviguer dans la configuration de votre
équipement Cisco :

Backspace efface le caractère a gauche du curseur


Tab complétion de la commande
? aide
Ctrl A déplace le curseur en début de ligne
Ctrl B recule d'un caractère
Ctrl D efface le caractère situé sur le curseur
Ctrl E déplace le curseur en fin de ligne
Ctrl H efface le caractère à gauche du curseur
Ctrl I complétion de la commande
Ctrl K efface tous les caractères jusqu'à la fin de la ligne
Ctrl L réaffiche la ligne en cours (utile si le Debug d'affiche pendant la saisie)
Ctrl N affiche la ligne suivante dans l'historique des commandes
Ctrl P affiche la ligne précédente dans l'historique des commandes
Ctrl R réaffiche la ligne en cours (utile si le Debug d'affiche pendant la saisie)
Ctrl T transpose les caractères
Ctrl U efface les caractères jusqu'à la fin de la ligne et les place dans un tampon
Ctrl W efface le mot précédent
Ctrl X efface les caractères jusqu'au début de la ligne et les place dans un tampon
Ctrl Y insert le tampon dans la ligne de commande

Esc < affiche la première commande situé dans l'historique des commandes
Esc > affiche la dernière commande situé dans l'historique des commandes
Esc b déplace le curseur d'un mot en arrière
Esc c sélectionne le mot après le curseur
Esc d efface le mot après le curseur
Esc f avance le curseur d'un mot
Esc i Tab
Esc l passe le mot placé après le curseur en minuscules
Esc u passe le mot placé après le curseur en majuscules
Esc y colle le tampon
Esc Del efface le mot placé avant le curseur
Le registre de configuration
Écrit par Robin Eric
26-06-2007

1) Généralités

Le registre de configuration a une taille de 16 bits, et s’exprime sous la forme d’une valeur
hexadécimale.

On peut modifier sa valeur :

Depuis IOS, en utilisant la commande config-register {valeur} dans le mode de configuration


globale.
Depuis le mode RXBoot, accessible en utilisant la combinaison de Break avant les 60 secondes qui
suivent le démarrage à froid du routeur (en général Ctrl-Pause). La commande permettant de
modifier la valeur dépend du type de dispositif sur lequel on se trouve.
La valeur par défaut du registre de configuration est 0x2102.
Ce registre a pour principal but d’établir le comportement d’un routeur :

Bits 0 à 3 : Champ d’amorçage.


Bit 4 : Démarrage rapide (sur les routeurs 7000).
Bit 5 : Vitesse de la ligne console supérieure à 9600 Bauds.
Bit 6 : Ignorer le fichier de configuration de sauvegarde (en NVRAM).
Bit 7 : OEM.
Bit 8 : Combinaison de Break après chargement d’IOS.
Bit 9 : Utilisation du bootstrap secondaire.
Bit 10 : Broadcast IP avec tout à zéro.
Bits 11 & 12 : Vitesse de la ligne console.
Bit 13 : Utiliser l’image par défaut en ROM si échec du démarrage réseau.
Bit 14 : Broadcasts IP n’ont pas de numéros de réseau.
Bit 15 : Activer les messages de diagnostics et ignorer le contenu de la NVRAM.
2) Explication de la valeur de chaque Bit

a) Bits 0 à 3 : Champ d’amorçage.

Ces quatre Bits permettent de spécifier l’ordre de recherche des commandes boot system sur notre
dispositif Cisco :

Il se peut que, lorsque l’on utilise les commandes boot system présentes en mémoire NVRAM, ces
commandes boot system ne mènent pas à une image valide de la plate-forme logicielle Cisco IOS.
Dans ce cas, le dispositif utilise la séquence d’amorçage par défaut. Cette séquence par défaut
cherche l’image usine installée en Flash, puis cherche une image réseau sur un serveur TFTP, et
finalement utilisera en dernier recours l’image présente en mémoire ROM.

Le nom du fichier de l’image réseau utilisé lors de la séquence par défaut est alors :

Exemple, sur un routeur 2500, le nom par défaut de l’image réseau serait cisco{numéro}-2500.

b) Bits 5, 11 & 12 : Vitesse de la ligne console.

Ces trois Bits spécifient la vitesse de synchronisation de la ligne console :

c) Bit 6 : Ignorer le fichier de configuration de sauvegarde.

Ce Bit permet de forcer IOS à ignorer le fichier de configuration de sauvegarde, présent en mémoire
NVRAM :
0 : Utilisation du fichier de configuration.
1 : Fichier de configuration ignoré.
La possibilité de pouvoir ignorer ce fichier de configuration est très pratique, principalement pour la
procédure de récupération des mots de passe, afin d’outrepasser les mots de passe configurés.

d) Bit 8 : Combinaison de Break après chargement d’IOS.

La possibilité de pouvoir utiliser la combinaison de Break, même après le chargement d’IOS, est
indiquée par la valeur du 8ème Bit :

0 : Combinaison de Break activée.


1 : Combinaison de Break désactivée après le chargement d’IOS (défaut).

e) Bits 10 & 14 : Broadcasts IP.

Ces 2 Bits indiquent comment doivent être formés les broadcasts IP :

Ceci permet de définir l’adresse de destination des broadcasts IP.

f) Bit 13 : Utiliser l’image par défaut en ROM si échec du démarrage réseau.

Avec ce Bit, on peut modifier le comportement du bootstrap face à un échec de démarrage réseau
(TFTP) :

0 : Tentatives infinies de chargement du fichier image d’IOS depuis le réseau (TFTP).


1 : Maximum 5 tentatives de chargement réseau avant d’utiliser l’image présente en mémoire ROM.

3) Exemples

0x2102 : Valeur par défaut. La combinaison de Break est désactivée après le chargement d’IOS, et
la ligne console fonctionnera a une vitesse de 9600 Bauds.

0x2142 : Idem que précédemment, sauf que l’on va ignorer le fichier de configuration de
sauvegarde. Cette valeur du registre est généralement utilisée pour la procédure de récupération des
mots de passe.

0x6502 : Idem qu’avec la valeur 0x2102, sauf que les broadcasts IP seront émis uniquement sur le
sous-réseau local (exemple : 192.168.10.255) et non sur tous les réseaux (255.255.255.255).
Personnalisez votre routeur en créant une bannière
Écrit par Guillemot Erwan
26-06-2007

La bannière est le texte qui vous accueille lorsque vous vous connectez au routeur. Pour créer votre
bannière, il suffit de rentrer en mode de configuration globale de votre routeur :

Une fois dans ce mode, vous rentrez les paramètres suivants :

L’expression motd ! indique que le caractère qui va mettre fin à la saisie de votre bannière est le
point d’exclamation. On aurait pu mettre n’importe quel autre caractère.
Au démarrage du routeur, on obtient donc ceci, tout de même plus convivial :
Configuration des paramètres horaires de votre routeur Cisco
Écrit par Pybourdin Marc
26-06-2007

la commande clock vous permet de configurer la date et l'heure sur votre routeur Cisco :

clock set hh:mm:ss dd month yyyy


cette commande paramêtre la date et l'heure sur votre routeur
ex : clock set 18:40:00 25 PAR 2002

clock timezone XXX O


cette commande vous permet de spécifier au routeur la zone horaire ou le routeur se trouve
(EST,CST,MST,PST)
ex : clock timezone CST °

clock summer-time XXX recurring


cette commande paramêtres les paramêtres liés à l'heure d'été
ex : clock summer-time EST recurring

service timestamps log datetime localtime show-timezone


cette commande affiche toutes les entrées du routeur contenue dans la table de log avec la date,
l'heure
Sauvegarder les configurations de routeur sur un serveur TFTP
Écrit par Guillemot Erwan
26-06-2007

Introduction :

Une fois la configuration de nos routeurs terminée, il est important de stocker ces fichiers de
configuration. En effet, sur les réseaux critiques il est souvent nécessaire de posséder des routeurs
de rechange pré-configurés pour opérer à un remplacement rapide en cas de panne. Pour cela, on
peut importer et exporter les configurations sur des serveurs TFTP.

Serveur TFTP :

TFTP, pour Trivial File Transfer Protocol , est un protocole de la pile TCP/IP qui permet l’échange
d’informations entre les nœuds. Comme l’indique son nom, ce protocole est simplifié par rapport au
protocole FTP et ne permet pas l’authentification des utilisateurs.

Vous trouverez aisément un serveur TFTP sur Internet, en voici un exemple à www.solarwinds.net

Dans cet exemple, l’adresse du serveur est 192.168.10.222 (adresse de la machine sur laquelle est
installé le serveur TFTP).

Copier une configuration vers un serveur TFTP :

Les adresses de notre serveur TFTP et d’une interface Ethernet du routeur doivent être sur le même
réseau…

En mode privilégié, tapez copy startup-config tftp

Le routeur vous demande ensuite l’adresse du serveur ; dans ce cas tapez 192.168.10.222
Finalement il vous est demandé de rentrer le nom du fichier de votre configuration.
On peut voir sur le routeur que le fichier a bien été envoyé et copié, on peut aussi le vérifier sur le
serveur TFTP

Voyons maintenant à quoi ressemble le fichier sauvegardé.

!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname LabA
!
enable secret 5 $1$ka36$a8XgHYpt63DVTZWLQxRxP1
!
ip subnet-zero
ip host LabC 204.204.7.1 199.6.13.2 223.8.151.1
ip host LabD 204.204.7.2 210.93.105.1
ip host LabE 210.93.105.2
ip host LabB 201.100.11.2 199.6.13.1 219.17.100.1
!
!
!
interface Ethernet0
ip address 192.5.5.1 255.255.255.0
no ip directed-broadcast
!
interface Serial0
ip address 201.100.11.1 255.255.255.0
no ip directed-broadcast
no ip mroute-cache
clockrate 56000
!
interface Serial1
no ip address
no ip directed-broadcast
shutdown
!
router rip
network 192.5.5.0
network 201.100.11.0
!
ip classless
!
!
line con 0
login
transport input none
line aux 0
line vty 0 4
password cisco
login
!
end

Rapatrier une configuration d’un serveur TFTP sur un routeur :

Pour copier un fichier de configuration d’un serveur TFTP vers notre routeur, il suffit juste de
configurer une interface Ethernet avec une adresse situé sur le même réseau que le serveur TFTP.

Ensuite, on tape copy tftp startup-config

On indique l’adresse du serveur TFTP et le nom du fichier de configuration.


La configuration est donc copier dans la mémoire NVRAM ; il faut ensuite la recopier dans la
mémoire de travail du routeur : copy startup-config running-config
La commande show
Écrit par Pybourdin Marc
26-06-2007

La commande show est très efficace pour le monitoring et le dépannage La commande show est très
efficace pour le monitoring et le dépannage. Vous pouvez l'utiliser pour exécuter toute une série de
fonctions :
Monitoring du routeur pendant l'installation et pendant sa production
Isolation des problèmes d'interface, de média ou d'application
Déterminer la charge du réseau
Déterminer l'état des serveurs, client ou encore des routeurs voisins

Le tableau suivant présente les usages les plus courants de la commande show :

show access-lists affiche les listes de contrôles d'accès configurés sur le routeur ainsi que les
interfaces auxquelles elles se rapportent
show buffers affiche l'état du tampon du routeur
show clock affiche les paramètres horaires du routeur
show <interface> affiche différentes statistiques pour l'interface concernée comme par exemple le
type de média raccordé
show DECnet static affiche les routes statiques configurées
show flash affiche la version de lIOS utilisés par le routeur ainsi que la quantité de mémoire flash
utilisée
show flash all affiche la quantité de mémoire flash utilisée
show interfaces affiche les statistiques ainsi que les caractéristiques de toutes les interfaces du
routeur
show interfaces accounting affiche un aperçu des protocoles voyageant au travers des interfaces
show ip arp affiche la table arp du routeur
show ip OSPF <interface> affiche le statut d'ospf sur l'interface concernée
show ip route affiche la table de routage IP
show IPX interfaces affiche l'état des interfaces IPX ainsi que leur adresse MAC
show ip protocols affiche les information de routage
show ip traffic affiche les statistique de traffic passant par le routeur
show ipx servers affiche les serveurs que le routeur connait
show line affiche les lignes actives du routeur
show log affiche les logs du routeur ( il convient d'activer les logs au préalable)
show memory affiche l'état de la mémoire du routeur
show running-config affiche la configuration stockée en RAM, utilisée par le routeur en
fonctionnement
show startup-config affiche la configuration stockée en NVRAM, utilisée par le routeur au
démarrage
show tcp affiche les connections TCP
show version affiche le uptime du routeur, la version de l'IPS, la séquence de boot ainsi que les
caractéristiques physiques du routeur

Il existe un nombre incroyables d'autres options pour la commande show, pour les connaître,
utilisez l'aide du routeur en tapant la commande : "show ?".
Il est important de rappeler que les options disponibles différent en fonction du mode ou l'utilisateur
se trouve.
Récupération de mots de passe sur un 2600
Écrit par Papin Nicolas
26-06-2007

Procédures de récupération de mot de passe oublié

Cet article à pour but d’expliquer la procédure à suivre quand on a perdu les mots de passe d’un
routeur Cisco 2600. Cette procédure présente l’avantage de ne pas écraser la configuration,
simplement de changer les mots de passe tout en gardant la configuration existante. La connexion
doit se faire par un câble console.

Nous nous trouvons dans l’impossibilité de rentrer dans le mode privilégié du routeur.

La solution décrite dans la procédure est de redémarrer en mode ROM, avec l’image minimaliste
afin de changer la valeur du registre de configuration.

Il faut ensuite redémarrer le routeur avec l’interrupteur et appuyer sur la touche CTRL et « Pause »
ou « Break » au clavier dans les 30 secondes après le démarrage. L’écran suivant doit alors
apparaître :

Nous sommes alors avec l’image minimaliste, très peu de commandes sont disponibles.

Nous allons nous intéresser au registre de configuration.

La valeur normale du registre de configuration est : 0X2102, nous allons pour ignorer la
configuration passer cette valeur en confreg 0x2142 :

Puis on redémarre avec la commande reset, cette valeur du registre de configuration permet
d’ignorer la copie du fichier de configuration de sauvegarde dans le fichier de configuration active.
Autrement dit, d’ignorer les mots de passe.
Après redémarrage le routeur demande si l’on veut rentrer dans le mode SETUP, répondre « no » à
cette question.

La prochaine étape est de rentrer dans le mode privilégié avec cette configuration « vierge » :

Aucun mot de passe ne nous est demandé car la configuration est vierge.

Maintenant que nous sommes en mode privilégié, nous pouvons récupérer notre configuration, le
mot de passe ne nous sera plus demandé. La commande est donc « copy startup-config running-
config » En effet notre configuration n’a pas été supprimée mais simplement ignorée. :

Nous avons donc récupérer toute notre configuration, avec également les mots de passe que nous
avions oubliés.

Ensuite nous allons donc écraser le mot de passe du mode privilégié :

L’étape suivante est très importante, il s’agit de remettre la valeur du registre de configuration à sa
valeur initiale. En effet si cela est omis, le routeur va tout le temps redémarrer en ignorant la
configuration.

Pour afficher la valeur du registre de configuration, la commande à utiliser est show version en
mode privilégié :

Nous remarquons que la valeur est restée à 0X2142, nous allons donc modifier cette valeur pour le
prochain redémarrage avec la commande config-register 0x2102 :
Enfin pour terminer, il faut enregistrer les changements de mot de passe et de la valeur du registre
de configuration avec la commande copy running-config startup-config
Changer votre version d’IOS
Écrit par Guillemot Erwan
26-06-2007

Sauvegardez et mettez à jour vos images IOS

Les routeurs Cisco utilisent le système d’exploitation IOS pour gérer les opérations propres au
routage et à la configuration du dispositif. Vous pouvez être amené à réparer une version
défectueuse d’IOS ou à installer une version plus récente sur votre routeur.

Pour cela, procédez comme suit :

Enregistrer une version IOS valide sur un serveur TFTP :

Démarrez votre serveur TFTP. Vous pouvez télécharger un serveur TFTP gratuit à l’adresse
suivante: www.solarwinds.net

En mode privilégié, tapez copy flash tftp.

Le routeur vous demande l’adresse du serveur, dans ce cas : 192.168.10.222. Ensuite, vous devez
rentrer le nom du fichier que vous voulez uploader. (Le routeur vous propose le nom du fichier IOS
installé).

Pour terminer, vous devez indiquer un nom pour le fichier qui sera stocké sur le serveur.

Une fois le fichier transféré, vous obtenez le message ci-dessous :


Le nom du fichier IOS est important ; il permet de connaître les spécificités du logiciel.

Prenons l’exemple de notre fichier : c1600-y-mz.112-18.P

c1600 représente la plate forme sur laquelle l’IOS est exécutée.

y représente les fonctions et les capacités spéciales compatibles avec l'image

mz signifie que le fichier est compressé (format Zip)

112-18.P représente la version de l’IOS

Enregistrer une version IOS valide à partir d’un serveur TFTP :

L’opération inverse consiste à flasher votre routeur pour lui installer une version IOS plus récente.

Prenons le cas où notre routeur n’a aucune configuration. Montons une interface Ethernet :

Routeur(config-if)# ip address 192.168.10.254 255.255.255.0

Routeur(config-if)# no shutdown

Routeur# copy running-config startup-config

Il est important de copier la configuration courante dans la NVRAM, car certains routeurs
demandent un redémarrage lors du flashage (à perte de l’interface Ethernet à impossibilité de
joindre le serveur TFTP au redémarrage).

L’étape suivante consiste à rentrer : copy tftp flash.

Le routeur vous demande l’adresse du serveur TFTP, puis le nom de l’image IOS.

Ensuite il vous est demandé de confirmer le formatage de l’image IOS présente à ce moment sur le
routeur. (deux confirmations).

Le formatage se caractérise sur le schéma ci-dessous par des « e »

Le chargement de la nouvelle image se caractérise par des points de suspension.


Une fois le chargement terminé, vous recevez le message suivant :

Votre nouvelle image est maintenant fonctionnelle.


Configuration du protocole RIP
Écrit par Robin Eric
26-06-2007

1) Description

RIP (Routing Information Protocol) est relativement ancien, mais est encore couramment utilisé. Il
s’agit d’un IGP (Interior Gateway Protocol) créé pour être utilisé dans de petits réseaux homogènes,
et est un protocole de routage à vecteur de distance.

RIP utilise le protocole UDP en diffusion (Broadcast) pour échanger l’information de routage.

Les mises à jour de routage sont envoyées toutes les 30 secondes.


Si un routeur ne reçoit aucune mise à jour d’un autre routeur dans un délai de 180 secondes, il
marque les routes desservies par le routeur ne répondant pas comme inutilisables.
S’il n’y a toujours aucune mise à jour après 240 secondes, le protocole RIP enlève toutes les entrées
dans sa table de routage correspondant au routeur qui ne répond pas.
Caractéristiques principales :

La métrique qu’utilise RIP est le nombre de sauts (Hop count).


Chaque entrée dans la table de routage apprise par RIP a une distance administrative de 120.
Un réseau directement connecté a une métrique de 0, alors qu’un réseau inaccessible aura une
métrique de 16.

2) Configuration du protocole RIP

a) Activation de RIP

La commande router rip, dans le mode de configuration globale, permet :

De passer en mode de configuration du protocole de routage.


D’activer le protocole RIP.
Il faut maintenant indiquer quels sont les réseaux directement connectés au routeur interagiront au
niveau des mises à jour. Ceci inclus les réseaux sur lesquels le routeur enverra les paquets de mise à
jour ainsi que les réseaux qui seront inclus dans les mises à jour. Il faut utiliser la commande
network {réseau}, depuis le mode de configuration du protocole de routage.

b) Mises à jour unicast

Par défaut, les mises à jour sont diffusées (Broadcast).

Il est possible d’émettre ces mises à jour vers des destinataires uniques en utilisant la commande
neighbor {IP}, dans le mode de configuration du protocole de routage.

c) Offsets de métriques de routage

Les métriques des entrées apprises par RIP ont généralement pour valeur le cumul de celles
présentes dans le paquet de mise à jour avec la métrique du lien entre le routeur local et celui qui a
envoyé la mise à jour.

Il est possible de rajouter un mécanisme d’incrémentation sélectif de ces métriques.


La commande offset-list [acl] {in | out} {valeur} [{type} {numéro}] du mode de configuration du
protocole de routage configure ce système d’incrémentation :

[acl] : Nom ou numéro d’ACL, afin de limiter l’offset-list (Paramètre optionnel).


{in | out} : L’offset-list sera appliquée lors de la réception (in) ou de l’émission (out) d’un paquet de
mise à jour.
{valeur} : Nombre qui sera ajouté aux métriques concernées.
[{type} {numéro}] : L’offset-list peut aussi être appliquée sur une interface spécifique (Paramètre
optionnel).

d) Temporisateurs

Tous les protocoles de routage utilisent différents temporisateurs, afin d’établir le comportement
pour la gestion de la table de routage. Les temporisateurs utilisés par RIP sont les suivants :

update timer : Intervalle de transmission des paquets de mise à jour (Défaut à 30 secondes).
invalid timer : Temps de non mise à jour d’une entrée pour une route avant Qu’elle soit marquée
comme invalide dans la table de routage (Défaut à 180 secondes).
holddown timer : Temps après lequel l’entrée non mise à jour dans la table de routage n’est plus
examinée durant la phase de recherche du meilleur chemin (Défaut à 180 secondes).
flush timer : Temps après lequel l’entrée non mise à jour sera supprimée de la table de routage
(Défaut à 240 secondes).
La commande a utiliser est timers basic {update} {invalid} {holddown} {flush} depuis le mode de
configuration du protocole de routage.

e) Version de RIP

Il est possible de spécifier la version de RIP utilisée pour les mises à jour envoyées et reçues. Les
commandes suivantes sont à utiliser depuis le mode de configuration du protocole de routage :

f) Authentification RIP

RIPv2 supporte l’authentification. IOS fournit donc plusieurs commandes afin de configurer cette
authentification :

ip rip authentication key-chain {mot}


mot correspond à la chaîne de caractères pour l’authentification.
ip rip authentication mode {text | md5}
La chaîne de caractère peut être envoyée en clair (text) ou crypté (md5).
Ces commandes sont disponibles depuis le mode de configuration de l’interface correspondante.

La configuration de l’authentification est à effectuer sur tous les routeurs devant communiquer entre
eux.

g) Regroupement des routes

RIPv2 est un protocole classless, c’est-à-dire qu’il peut gérer des routes pour des sous-réseaux, et
non pas uniquement pour des réseaux respectant l’adressage en classes prédéfinies.

L’une des spécificités de RIPv2 est le regroupement des routes, généralement appelé route
summarization. Cela permet de simplifier les tables de routage en regroupant des routes pour des
sous-réseaux en une seule route généralisée en utilisant le réseau classfull correspondant.

La commande pour activer (Par défaut) le regroupement des routes est auto-summary depuis le
mode de configuration du protocole de routage.

h) Validation des adresses IP sources

Un routeur valide par défaut les adresses IP sources des paquets de mise à jour RIP. Si l’adresse
n’est pas valide, le routeur rejette la mise à jour.

L’activation de la validation de adresses IP sources se fait par le biais de la commande validate-


update-source du mode de configuration du protocole de routage.

i) Split Horizon

Split horizon est actif par défaut pour tous les types de média sauf pour les réseaux SMDS et Frame
Relay.

La commande d’activation est ip split-horizon depuis le mode de configuration d’une interface.

Si une interface est configurée avec une ou plusieurs adresses IP secondaires et que Split Horizon
est actif, les mises à jour ne partiront pas pour chaque adresse IP secondaire. Une seule mise à jour
sera alors émise pour chaque réseau.

j) Délai inter-paquet

RIP émet parfois plusieurs paquets de mise à jour au même moment. Ces mises à jour sont
transmises immédiatement l’une après l’autre.

Il est possible de configurer un délai inter-paquet spécifique aux mises à jour de RIP via la
commande output-delay {délai} depuis le mode de configuration du protocole de routage. Ce délai
peut avoir une valeur comprise entre 8 et 50 (Millisecondes).
Configuration des routes Statiques
Écrit par Dzodic Veljko
26-06-2007

1.Introduction

Le routage statique précéda le routage dynamique. Il faut savoir qu’aujourd’hui, un administrateur


réseau ne déploie pas uniquement le routage dynamique. En effet, les deux types de routages sont
combinés. Par ailleurs, le routage statique est la solution optimale dans certains cas.

D’un côté, l’administrateur réseau peut recourir vers la simplicité en utilisant les routes statiques.
Cela est un choix légitime pour des petits réseaux qui peuvent être facilement contrôlés de près. Un
petit système autonome (AS) est souvent connecté à son ISP par le biais des routes statiques pour la
même raison, qu’est la simplicité. Effectivement, mettre en place des routes statiques est une
configuration moins onéreuse par rapport à la mise en place de BGP et/ou la redistribution entre des
protocoles de routage.

De l’autre côté, les routes statiques peuvent être utilisées pour la sécurité supplémentaire du réseau.
Lorsqu’une liaison tombe en panne, un autre chemin pourrait être pris, indiqué par la route statique.

L’activité d’un routeur se résume par deux fonctionnalités principales:


 Trouver la meilleure route
 Commuter le paquet sur l’interface appropriée

Pour trouver la meilleure route, un routeur compare l’adresse de destination du paquet avec les
adresses réseau de sa table de routage.

Les routes statiques représentent des réseaux distants, éloignés par un saut au moins.
Lorsque la table de routage est créée manuellement, les routes sont dites statiques. La configuration
de la métrique et de la distance administrative est laissée à l’administrateur.

2.Route statique

Pour configurer une route statique, la commande ip route est utilisée à partir du mode de
configuration globale :

Router(config)#ip route préfixe masque { prochain_saut | int_type int_num } [ distance ]


[ tag ] [ permanent ]
2.1.Route Statique : Exemple 1

Voici un exemple de configuration simple des routes statiques. Trois routeurs RTA, RTB et RTC
sont connectés en série :

Figure 1 – Topologie simple

Pour lier ces trois routeurs, il faut placer une route statique sur les routeurs de bord. Attention, il est
important de définir pour tous les routeurs tous leurs réseaux distants. Dans le cas contraire, on
court le risque d’avoir des équipements qui reçoivent des paquets, mais ne savent pas comment les
renvoyer vers la source.

Dans l’exemple, présenté ci-dessus, le réseau distant pour le routeur RTA est 20.0.0.0/8 et le
prochain saut menant vers ce réseau est 10.0.0.2/8. Alors la configuration est :

RTA(config)#ip route 20.0.0.0 255.0.0.0 10.0.0.2

Le routeur RTB est directement connecté aux deux autres. La configuration pour le routeur RTC
est :

RTC(config)#ip route 10.0.0.0 255.0.0.0 20.0.0.1

Il serait parfaitement légitime de spécifier l’interface de sortie (interface ethernet 0) menant vers le
réseau distant, en lieu de l’adresse IP du prochain saut. Cependant, spécifier l’adresse du prochain
saut est la méthode plus précise, et plus sûre.

Pour comprendre le fonctionnement des routes statiques configurées avec l’interface sortante,
considérons l’exemple suivant.

2.2.Route Statique : Exemple 2

Dans cet exemple les routeurs RTA, RTB et RTC sont branchés sur un LAN. La route statique est
configurée sur le routeur RTA pour le réseau distant 192.168.1.0/24.

Les réseaux 20.0.0.0/8, 30.0.0.0/8 et 192.168.1.0/24 sont gérés par le protocole de routage RIP, ce
qui facilite la configuration en nous épargnant des routes statiques supplémentaires.
Figure 2 – Topologie avec quatre routeurs

Pour rappel, si on configurait la route statique de RTA vers 192.168.1.0 avec l’une des deux
adresses IP du prochain saut, à savoir 10.0.0.2 (RTP), ou 10.0.0.3 (RTQ), il n’y aurait aucunement
d’ambiguïté par rapport au premier saut de RTA.

Par contre, si nous spécifions comme le point de sortie l’interface Ethernet 0 (E0), cela va
fonctionner, mais l’incertitude du prochain saut est introduite :

RTA(config)#ip route 192.168.1.0 255.255.255.0 ethernet 0

Vous devez sûrement vous demander de quelle manière sont acheminés les paquets destinés au
réseau 192.168.1.0/24 ?

Pour déterminer ce qui se passe, on effectue un ping de RTA vers 192.168.1.1 (RTZ). En même
temps nous écoutons le trafic généré sur le LAN avec un terminal branché au concentrateur.

RTA#ping 192.168.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
!!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 32/32/32 ms
RTA#

Cela fonctionne ! Les paquets font le tour avec succès. Toutefois, remarquez qu’il y a un « echo »
de moins. C’est à cause de l’opération de résolution d’adresses déclanchée par la commande ping et
donc il n’y a que quatre requêtes envoyées.

Les échanges, présentés dans la figure 3, ont été enregistrés par Ethereal, le logiciel de capture de
trames.
Figure 3 – Trames capturées par Ethereal

La communication effectuée sur le LAN peut être lu donc très facilement. En voici la traduction :

Le routeur RTA ne connaît pas l’adresse physique pour atteindre l’adresse distante et il demande
alors : qui est-ce qui a l’adresse 192.168.1.1 ?
Les routeurs RTP et RTQ ayant dans leurs tables de routage connaissance du réseau 192.168.1.0/24,
répondent avec leurs adresses physiques respectives.
La dernière adresse MAC reçue est mise dans le cache ARP de RTA. Par conséquence, tout trafic
partant vers 192.168.1.0/24 est encapsulé en trames avec cette adresse physique.
Les 4 pings sont envoyés au routeur RTZ passant par le routeur RTQ
En effet, le dernier routeur qui répond avec une réponse ARP devient le routeur intermédiaire.
L’entrée statique dans la table de résolution ARP est affichée comme suit :

RTA#show arp
Protocol Address Age (min) Hardware Addr Type Interface
Internet 10.0.0.2 119 0011.93a8.6380 ARPA FastEthernet0/0
Internet 10.0.0.3 119 0011.93a8.5b00 ARPA FastEthernet0/0
Internet 192.168.1.1 0 0011.93a8.5b00 ARPA FastEthernet0/0
RTA#

Vous avez compris que lorsqu’il y a plusieurs routeurs capables d’acheminer les données vers le
réseau distant, c’est malheureusement le routeur avec la plus grande latence qui assure cette tâche.

Pour résumer, si vôtre topologie est de type multi-accès, pointez toujours votre route statique vers
l’adresse IP du prochain saut.
3.Route par défaut

La route statique par défaut est configurée pour le trafic destiné à tous les réseaux inconnus. Son
prochain saut est donc la passerelle par défaut. Par exemple, tous les paquets d’une entreprise qui
sont destinés pour l’Internet passent par la route par défaut.

Il existe trois syntaxes pour configurer la route par défaut, toutes trois exécutées à partir du mode de
configuration global :

 ip default-gateway
 ip default-network
 ip route 0.0.0.0 0.0.0.0

La première commande est un cas spécial. Elle est employée lorsque le routage ip est désactivé pour
le routeur.

La deuxième commande permet de définir une route statique vers un réseau classful :

Router(config)#ip default-network {préfixe_réseau}

Avec la troisième, pour dire « tous les réseaux » nous tapons « 0.0.0.0 » comme préfixe réseau et «
0.0.0.0 » pour le masque :

Router(config)#ip route 0.0.0.0 0.0.0.0 { prochain_saut | int_type int_num } [ distance ] [ tag ] [


permanent ]

4.Route statique flottante

La route statique flottante est une route de sauvegarde. Lorsque une route primaire tombe, c’est la
route statique qui prend la relève.

Toute route statique a une distance administrative de 1, qui après 0 signifie la plus haute
importance. Cela veut donc dire qu’une route statique est toujours la plus préférable. C’est normal,
l’administrateur sait le mieux ce qu’il fait.

D’habitude, la route flottante est couplée avec des routes dynamiques. Elle doit simplement être
rendue moins « intéressante » que la route primaire. Pour ce faire, la distance administrative de la
route statique est changée.

Puisque tous les protocoles de routage ont des valeurs de distance administrative supérieures à 1
(EIGRP 90, OSPF 110, RIP 120), la route statique flottante doit avoir une distance plus grande que
la route principale.
Voilà l’exemple pour créer une route statique flottante, qui serait moins importante que la plupart
d’autres routes dynamiques, car sa distance administrative est fixée à 250 :

RTZ(config)#ip route 10.0.0.0 255.0.0.0 20.0.0.1 250

5.Redistribution des routes statiques

La diffusion de routes statiques se fait à l’aide des protocoles de routage. Une route statique est
partagée comme tout autre entrée de la table de routage, selon le protocole déployé.
Pour ce faire, il faut configurer le protocole de routage. En simple, la configuration indique au
protocole qu’il faut diffuser l’entrée statique avec les autres entrées de la table de routage.

Les configurations pour des différents protocoles sont faites sur la topologie présentée dans la figure
4.

Figure 4 – Exemple pour la redistribution des routes statiques

5.1.RIP

Diffusion des routes statiques ordinaires

Voici la syntaxe pour le protocole RIP pour la diffusion des routes statiques ordinaires :

Router(config-router)#redistribute static [ metric | route-map ]

Le routeur RT2 contient une route statique pour le réseau 10.0.0.0/8. Nous choisissons d’indiquer
aux routeurs voisins que les paquets entrants sur l’interface Série 0 (S0) ont deux sauts à parcourir
pour atteindre le réseau 10.0.0.0/8. Etant donné que la métrique de RIP se mesure en nombre de
saut, il suffit de taper :

RT2(config-router)#redistribute static metric 2

Ainsi, le routeur RT5 saura que le réseau 10.0.0.0/8 est éloigné de 4 sauts :

RT5#show ip route
! (… lignes coupées pour des raisons de clarté)
Gateway of last resort is not set
C 50.0.0.0/8 is directly connected, Serial0/1
R 40.0.0.0/8 [120/1] via 50.0.0.1, 00:00:23, Serial0/1
R 10.0.0.0/8 [120/4] via 50.0.0.1, 00:00:23, Serial0/1
R 30.0.0.0/8 [120/2] via 50.0.0.1, 00:00:23, Serial0/1
RT5#
Distribution des routes par défaut

Prudence ! Il est très important de ne pas confondre la distribution des routes statiques ordinaires
avec la distribution des routes par défaut. La deuxième diffuse une candidate pour la passerelle par
défaut à tous les routeurs dans le système autonome. Voici la syntaxe :

Router(config-router)#default-information originate

5.2.IGRP, EIGRP

Diffusion des routes statiques ordinaires

Bien que la commande redistribute soit utilisée pour diffuser les routes statiques, elle permet aussi
une redistribution entre protocoles de routage. L’explication exhaustive de la commande dépasse la
portée de ce document, et n’est donc pas donnée.

Pour redistribuer les routes statiques il suffit de taper :

RT2(config-router)#redistribute static

Pour vérifier que la route statique de RT2 est bien diffusée, nous inspectons la table de routage de
RT3.

RT3#show ip route
! (… lignes coupées pour des raisons de clarté)
Gateway of last resort is not set
I 20.0.0.0/8 [100/82125] via 30.0.0.1, 00:00:33, Serial0/1
C 40.0.0.0/8 is directly connected, Serial0/0
I 10.0.0.0/8 [100/82125] via 30.0.0.1, 00:00:33, Serial0/1
C 30.0.0.0/8 is directly connected, Serial0/1

En effet, la route statique est diffusée et associée à la métrique respective du protocole.

Diffusion des routes par défaut

Pour définir une route par défaut, l’on exécute ip default-network :

RT2(config)#ip default-network 10.0.0.0

Attention, IGRP ne comprend pas la commande « ip route 0.0.0.0 0.0.0.0 » !

Contrôle

A l’aide de la commande ci-dessous, IGRP et EIGRP peuvent mieux contrôler la redistribution des
routes par défaut :

Router(config-router)#default-information {allowed | in | out} {ACL-n° | ACL-nommée}


Au premier abord fort complexe, toujours est-il que cette commande permet une grande flexibilité
de configuration. N’oubliez pas qu’elle, en soit, n’active pas la redistribution.