Vous êtes sur la page 1sur 6

Vetores: Exercicio em Portugol usando o VisualG 1.

Faa um algoritmo para gerar um vetor de 30 posies, onde cada elemento corresponde ao quadrado de sua posio. Imprima depois o vetor resultante. algoritmo "Indice do vetor ao quadrado" //Funo Faa um algoritmo para gerar um vetor de 30 posies, onde cada elemento // corresponde ao quadrado de sua posio. Imprima depois o vetor resultante. // Autor : Adao Braga // Data : 12/06/2011 // Seo de Declaraes var indice:inteiro p30: vetor [1..30] de real inicio para indice de 1 ate 30 faca p30[indice]<-(indice^2) escreval(p30[indice]) fimpara fimalgoritmo

www.adaobraga.com.br

2. Ler 20 nmeros inteiros e depois imprimi-los em ordem inversa. algoritmo "Indice do vetor invertido" // Funo : Estudando vetores // Autor : Adao Braga // Data : 12/06/2011 // Seo de Declaraes var indice:inteiro p20:vetor [1..20] de inteiro inicio // 2. Ler 20 nmeros inteiros e depois imprimi-los em ordem inversa. para indice de 1 ate 20 faca p20[indice]<-(indice) fimpara para indice de 20 ate 1 passo -1 faca escreva(p20[indice]) fimpara fimalgoritmo

www.adaobraga.com.br

3. Ler 3 nmeros reais em vetor e depois exibir os nmeros localizados nas posies impares. algoritmo "30 vetores e os impares" var numeros: vetor [1..30] de real i : inteiro inicio para i de 1 ate 30 faca escreva("Entre com o ", i, " valor: ") leia( numeros[i]) fimpara para i de 1 ate 30 faca se (( i mod 2) = 1) entao escreva (numeros[i]) fimse fimpara fimalgoritmo

www.adaobraga.com.br

4. Ler 50 valores reais e armazenar em um vetor. Modifique o vetor de modo que os valores das posies impares sejam aumentados em 5%, e os das posies pares sejam aumentados em 2%. Imprima depois o vetor resultante. algoritmo "Aumentando Percentuais em vetor" //FUNO: Ler 50 valores reais e armazenar em um vetor. // Modifique o vetor de modo que os valores das posies impares sejam aumentados // em 5%, e os das posies pares sejam aumentados em 2%. // Imprima depois o vetor resultante. // DATA: 01/07/2011 //AUTOR: Ado Braga var vet5x : vetor [1..5] de real i : inteiro inicio para i de 1 ate 5 faca escreva("Entre com o ", i, " valor: ") leia(vet5x[i]) fimpara para i de 1 ate 5 faca se ((i mod 2) = 1 ) entao vet5x[i] <- vet5x[i] * 1.05 senao vet5x[i] <- vet5x[i] * 1.02 fimse fimpara para i de 1 ate 5 faca escreva(vet5x[i]," " ) fimpara escreval(" ") fimalgoritmo

www.adaobraga.com.br

5. Faa um algoritmo para criar um vetor real de 20 posies: as 10 primeiras so informados pelo usurio, e as 10 seguintes so s mesmos nmeros em ordem inversa. algoritmo "Vetor: Metade Usuario - Metade Sistema e Inverso" // FUNO: Faa um algoritmo para criar um vetor real de 20 posies: // as 10 primeiras so informados pelo usurio, e as 10 seguintes so // os mesmos nmeros em ordem inversa. // Data: 01/07/2011 // Autor: Ado Braga var num: vetor [1..20] de real i : inteiro inicio para i de 1 ate 10 faca escreva("Entre com o ", i, " valor: ") leia( num[i]) fimpara para i de 1 ate 10 faca num[i+10]<- num[11-i] fimpara para i de 1 ate 20 faca escreva(num[i]) fimpara fimalgoritmo

www.adaobraga.com.br

6. Ler dois vetores de nmeros inteiros, cada um com 30 posies. Crie um terceiro vetor onde cada valor a soma dos valores contidos nas posies respectivas dos vetores originais. Imprima depois os trs vetores. programa vetorSoma algoritmo "2 vetores + 3 vetor de soma" // FUNO: 6. Ler dois vetores de nmeros inteiros, cada um com 30 posies. // Crie um terceiro vetor onde cada valor a soma dos valores contidos // nas posies respectivas dos vetores originais. Imprima depois os trs // vetores. programa vetorSoma // Data: 01/07/2011 // Autor: Ado Braga var vet1 vet2 vet3 i inicio para i de 1 ate 30 faca escreva("Entre com o ", i, " valor: ") leia( vet1[i]) fimpara para i de 1 ate 30 faca escreva("Entre com o ", i, " valor: ") leia( vet2[i]) fimpara para i de 1 ate 30 faca vet3[i] <- vet1[i] + vet2[i] fimpara para i de 1 ate 30 faca escreval(vet1[i], " + ", vet2[i], " = ", vet3[i], " ") fimpara escreva(" ") fimalgoritmo : vetor [1..30] de real : vetor [1..30] de real : vetor [1..30] de real : inteiro

www.adaobraga.com.br