Vous êtes sur la page 1sur 9

4.2.5.

Les Outils pour les Arêtes et les Faces (Edge and Face Tools)
Mode : mode Edit (Mesh) – Raccourci : CTRL E ou K – Menu : Mesh>Edges.
L'une des questions-clef en modélisation est la nécessité d'ajouter des sommets à certains endroits d'un
maillage, et cela revient le plus souvent à couper, ou ajouter, des arêtes dans une zone donnée.
La plupart des outils relatif aux arêtes (Edge Tools) sont regroupés dans un menu accessible par K
(menu Loop/Cut, image ci-contre), mais chaque outils dispose également de son propre raccourci.
Les outils de sélection et de manipulation relatifs aux arêtes sont regroupés dans un menu Edge Specials (image ci-dessous)
accessible par CTRL E :
• Mark Seam : Utilisé pour le mapping UV.
• Clear Seam : Utilisé également pour le mapping UV.
• Rotate Edge CW : Opère des rotation d'arêtes dans le sens des aiguilles d'une montre.
• Rotate Edge CCW : Opère des rotation d'arêtes dans le sens inverse des aiguilles d'une montre.
• Loopcut : Cette option est destinée à l'outil Loop Subdivide.
• Edge Slide : Permet de glisser une arête le long de ces deux faces adjacentes.
• Edge Loop Select : Active le mode Edge Loop Select (mode de sélection).
• Edge Ring Select : Active le mode Edge Ring Select (mode de sélection).
• Loop to Region :
• Region to Loop :

4.2.5.1. Sélection d’une Arête (Edge Selection)


Mode : mode Edit (Mesh) – Raccourci : RMB.
En mode Edit, il n'existe que quelques façons de sélectionner des arêtes : implicitement, explicitement,
par boucle ou avec l'outil Region Selection (cet outil permet la sélection d'arêtes et de faces en se
basant sur une intersection avec une zone 2D circulaire), voir plus haut pour ce type de sélection).
Implicitement signifie que vous décrivez un élément plus complexe à partir d'autres éléments moins Modes de Sélection
complexes. Par exemple, pour décrire une arête, vous n'avez besoin de spécifier que deux vertices et
pour décrire une face vous devez spécifier trois vertices (ou plus) ou trois arêtes (ou plus).
Sélection Explicite des Arêtes (Explicit Edge Selection)
Pour sélectionner une arête, utilisez le mode Edges Select et un RMB sur une arête. Pour sélectionner des arêtes
supplémentaires, utilisez SHIFT RMB.
Sélection Implicite des Arêtes (Implicit Edge Selection)
L'autre méthode pour sélectionner une arête est de sélectionner deux vertices qui
délimitent l'arête concernée. Vous sélectionnez implicitement une arête en sélectionnant
les vertices qui la délimite. Pour sélectionner une arête implicitement, utilisez le mode
Vertices Select en combinaison avec RMB et/ou SHIFT RMB. L'image ci-contre
montre sur le cube de gauche, une arête sélectionnée en utilisant ses vertices. Le cube de
droite montre ce qui s'affiche lorsque vous basculez en mode Edges Select.

4.2.5.2. Sélection d’Arêtes par Boucle (Edge Loop Selection)


Mode : mode Edit (Mesh) > mode Vertices Select ou mode Edges Select – Raccourci : ALT RMB ou CTRL E, 7 (basé sur
une sélection d'arête existante) – Menu : Select > Edge Loop (basé sur une sélection d'arête existante).
Maintenir ALT appuyé tout en sélectionnant une arête, permet de sélectionner une boucle d'arêtes qui sont connectées en une
ligne bout à bout, en passant par l'arête située sous le pointeur de la souris. Maintenir appuyé SHIFT tout en cliquant ajoute à
la sélection en cours. Des boucles d'arêtes peuvent aussi être sélectionnées en se basant sur une sélection d'arêtes existante, en
utilisant le mode Edge Loop Select du menu Edge Specials.
Exemple de Sélection Edge Loop
La sphère de gauche montre une arête qui a été sélectionnée
longitudinalement. Remarquez comme la boucle est ouverte. C'est
parce que l'algorithme rencontre les vertices aux pôles et se termine
car les arêtes au pôle sont connectées à plus que trois autres arêtes.
Par contre, la sphère de droite montre une arête qui a été sélectionnée
horizontalement et qui a formé une boucle fermée. C'est parce que
l'algorithme a rejoint la première arête dont il est parti.

Détails Techniques
L'algorithme utilisé lors de la sélection est le suivant :
• D'abord, contrôler si l'arête sélectionnée est connectée à seulement trois autres arêtes.

IV - 44
• Si l'arête en cours d'examen a déjà été ajoutée à la liste des arêtes sélectionnées, alors la sélection s'arrête.
• Sur les trois arêtes qui sont connectées à l'arête en cours, celles qui partagent une face avec l'arête en cours sont éliminées
et l'arête restante est ajoutée à la liste des arêtes sélectionnées et devient la nouvelle arête en cours.

4.2.5.3. Sélection d’un Anneau d’Arêtes (Edge Ring Selection)


Mode: mode Edit (Mesh) > mode Edges Select – Raccourci : CTRL ALT RMB.
En mode Edges Select, maintenir appuyé CTRL ALT tout en sélectionnant une arête, sélectionne une séquence d'arêtes qui ne
sont pas connectées, mais sur des côtés opposés les unes par rapport aux autres en continuant le long d'une boucle de faces.
Utiliser la même commande en mode Vertices Select, sélectionnera implicitement une telle boucle de faces.
Exemple de Sélection Edge Ring
Dans l'image ci-contre, la même arête a été cliquée, mais deux
groupes différents d'arêtes ont été sélectionnés, en fonction de la
commande utilisée. Pendant le calcul, l'une est basée sur des arêtes
(boucle d'arêtes sélectionnées à gauche) et l'autre est basée sur des
faces (anneau d'arêtes sélectionnées).
Détails Techniques
Une sélection d'un anneau d'arêtes (Edge Ring) est basée sur le même algorithme que la sélection d'une boucle de faces (Face
Loop), sauf que le résultat final diffère puisque seules des arêtes sont sélectionnées.

4.2.5.4. Sélection d’une Face (Face Selection)


Mode : mode Edit (Mesh) – Raccourci : RMB.
En mode Edit, il n'existe que quelques façons de sélectionner des faces : implicitement, explicitement, par boucle ou par
sélection de zone. Implicitement signifie que vous décrivez un élément plus complexe à partir d'autres éléments moins
complexes. Par exemple, pour décrire une face, vous ne devez spécifier que trois vertices (ou plus) ou trois arêtes (ou plus).
Sélection Explicite de Face (Explicit Face Selection)
Pour sélectionner une face, utilisez le mode Faces Select et RMB. Pour sélectionner des faces supplémentaires, utilisez
SHIFT RMB.
Sélection Implicite de Face (Implicit Face Selection)
Sélectionner les trois (ou quatre) vertices qui décrivent la face en mode Vertices
Select la sélectionne implicitement. L'image ci-contre montre une face sélectionnée
grâce à ses vertices sur le cube de gauche. C'est le cube de droite qui s'affiche
quand vous basculez en mode Faces Select. Vous pouvez aussi sélectionner
implicitement des faces en sélectionnant les arêtes qui délimitent la face à
sélectionner. Cela aura le même résultat que sélectionner les vertices.

4.2.5.5. Sélection d’une Boucle de Faces (Face Loop Selection)


Mode : mode Edit (Mesh) > mode Faces Select ou mode Vertices Select – Raccourci : ALT RMB (mode Faces Select) ou
CTRL ALT RMB (mode Vertices Select).
En mode Faces Select, maintenir appuyé ALT tout en sélectionnant une arête, sélectionne une boucle de faces qui sont
connectées en une ligne bout à bout, le long de leurs arêtes opposées. En mode Vertices Select, la même chose peut être
accomplie en utilisant CTRL ALT pour sélectionner un anneau d'arêtes, ce qui sélectionne implicitement la boucle de faces.
Exemple de Sélection Face Loop

Une boucle de faces peut aussi être sélectionnée en mode Vertices


Cette boucle de faces a été sélectionnée en cliquant ALT Select (image ci-dessus). Les arêtes sélectionnée dans la grille
RMB sur une arête, en mode Faces Select. La boucle appelée Alt-RMB sont le résultat de la sélection d'une boucle
s'étend perpendiculairement à partir de l'arête qui était d'arêtes à comparer à la sélection d'un anneau d'arêtes dans la grille
sélectionnée. appelée Ctrl-Alt-RMB. Comme nous sommes en mode Vertices
Select, et que la sélection des arêtes opposées d'une face
sélectionne implicitement la face entière, la boucle de faces a été
implicitement sélectionnée.

IV - 45
Notez que dans ces cas, le résultat généré par l'algorithme était des vertices car nous étions en mode Vertices Select. Toutefois,
si nous avions été en mode Edges Select, le résultat généré aurait été des arêtes sélectionnées.
Détails Techniques
L'algorithme de sélection fonctionne comme suit :
• Une boucle de faces est faite de deux boucles d'arête voisines.
• Elle ne s'applique qu'à des faces quadrilatérales.
• Elle se termine quand une face triangulaire est rencontrée (et que les deux boucles d'arêtes enveloppantes fusionnent en
une seule).

4.2.5.6. L’outil Loop Subdivide


Mode : mode Edit (Mesh) – Raccourci : CTRL R – Menu : Mesh>Edges>Loop Subdivide… .
L'outil Loop Subdivide divise une boucle de faces en insérant une nouvelle boucle d'arêtes intersectant avec l'arête choisie.
L'outil est interactif et fonctionne en deux étapes :
1. Prévisualisation de la Coupure (Previsualising the cut) : La coupure à effectuer est marquée par une ligne de couleur
magenta alors que vous déplacez la souris sur les diverses arêtes. Dans l'image ci-dessous à gauche, le curseur de la souris
était localisé là où est placé le cercle blanc. Ceci fait que la ligne de la boucle apparaît à mi-chemin de l'arête. La boucle
d'arêtes à créer s'arrête aux pôles où la boucle de faces existante se termine.
• Sur activation initiale de l'outil, l'entête de la Vue 3D change pour afficher le nombre de coupures (Number of Cuts)
( ). Entrer un nombre au clavier (ou scroller avec MW) modifie le nombre de coupures
(maximum de 130). Ces coupures courent parallèlement à la ligne de la boucle de faces.
• S fait passer la coupure en mode Smooth. Par défaut, les nouveaux vertices pour la nouvelle boucle d'arêtes sont
placés exactement sur les arêtes préexistantes. Ceci conserve plates les faces subdivisées, mais peut tordre la
géométrie, en particulier quand vous utiliser les Surfaces de Subdivision. Si le mode Smooth est activé, alors les
nouveaux vertices ne sont pas placés sur l'arête précédente, mais décalés d'un pourcentage donné, de façon similaire à
la commande Subdivide Smooth.
2. Faire glisser la nouvelle Boucle d'Arêtes (Sliding the new edge loop) : Une fois qu'une arête est choisie via LMB, cette
arête est mise en évidence en vert (image ci-dessous au centre) et vous pouvez déplacer la souris le long de l'arête pour
déterminer où la nouvelle boucle d'arêtes sera placée. Ceci est identique à l'outil Edge Slide. Cliquer de nouveau LMB
pour confirme et crée la coupure à l'emplacement pré-visualisé, ou cliquer MMB force la coupure à exactement 50%.
L'image ci-dessous à droite montre les nouvelles faces et arêtes, A et B. La vue a été pivotée de sorte que les nouvelles
faces et arêtes soient clairement visibles depuis le haut de la sphère.
• P fait basculer entre le mode Proportional et le mode Percentage. Le mode par défaut est Percentage.
• En mode Proportional, MW (ou ← et → ) modifie l'arête sélectionnée pour calculer une proportion.
• Maintenir enfoncé CTRL ou SHIFT contrôle la précision du glissement. CTRL restreint le mouvement à des étapes
de 10% par mouvement et SHIFT restreint le mouvement à des étapes de 1% par mouvement. La valeur par défaut
est fixée à des étapes de 5% par mouvement.

Exemple de Boucle de Faces dans une Grille


Dans le but d'expliquer les modes Proportional et Percentage, nous pouvons utiliser un maillage
très simple disposé comme une grille 2 x 9, comme ci-contre. Les vertices en A et D ont été
déplacés afin de mettre en évidence la différence entre les deux modes. Les vertices aux niveaux
C et B restent inchangés. E sera une zone interressante lorsque nous étudirons le mode
Proportional.
Le mode Percentage
Dans le mode Percentage, l'entête de la Vue 3D se transforme comme dans l'image ci-contre afin
d'afficher un nombre entre -1 et 1, avec 0 représentant 50% (ou point central intermédiaire).
Si vous déplacez la souris, le pourcentage se modifie et la ligne de la boucle d'arêtes, dessinée en jaune, se déplace pour
représenter le pourcentage de la distance entre l'arête marquée en vert, comme on le voie dans les trois images ci-dessous :

IV - 46
25% Mi-Chemin 89%
La ligne de boucle d'arêtes jaune est toujours au même pourcentage le long de l'alignée d'arêtes qui sont en train d'être
coupées, sans se préoccuper de la longueur de ces arêtes. Par exemple, sur l'image du centre, la ligne de boucle d'arêtes jaune
est exactement à mi-chemin entre le vertex A et le vertex B et est également exactement à mi-chemin entre le vertex C et le
vertex D. Sur l'image de gauche, vous pouvez voir que la ligne de boucle d'arêtes jaune est toujours à 25% de chacune des
arêtes coupées.
Le mode Proportional
La division d'une boucle de faces en mode Proportional conserve la forme de la boucle d'arêtes nouvellement coupée à
l'identique d'une des boucles d'arêtes intermédiaires, plutôt que de diviser selon un pourcentage le long de chaque arête
perpendiculaire.
En mode Proportional, l'entête de la Vue 3D change pour afficher la position
le long de l'arête actuellement sélectionnée qui est marquée en vert.
Le déplacement de la boucle d'arêtes glissante est restreint à cette longueur. Alors que vous déplacez la souris, l'indicateur de
longueur dans l'entête change pour indiquer où vous êtes sur la longueur de l'arête.
Contrairement au mode Percentage, le mode
Proportional traite l'arête comme ayant un vertex de
début et un vertex de fin, le vertex de début étant indiqué
par un marqueur magenta. Le vertex de début A (image
ci-contre à gauche) peut être inversé avec le vertex
opposé à l'aide de la touche F (image ci-contre à droite).

Déplacer la souris, rapproche ou éloigne la ligne de coupe du vertex de début, mais la ligne de la boucle d'arêtes ne se
déplacera pas plus loin que la longueur de l'arête actuellement sélectionnée, en se conformant à la forme d'une des boucles
d'arêtes englobantes.
L'image ci-contre montre un exemple de la façon dont la distance est
restreinte par la longueur de l'arête sélectionnée (B). En regardant en A,
vous pouvez voir que la ligne de boucle s'est déplacée de la même
distance. Si la ligne ne se déplace que de 0,2 unités sur l'arête
sélectionée, alors elle ne se déplacera que de 0,2 unités n'importe où
ailleurs dans la zone de la boucle de faces. Intervalle Proportionnel
La portion de la ligne de boucle d'arêtes en A n'a pas fait tout le chemin vers le "bas" car l'arête sélectionnée ne fait que 0,25
unité de longueur. La portion de ligne en A ne peut pas se déplacer au-dela de 0,25 unités vers le bas car l'intervalle de
mouvement est limitée à la longueur de l'arête sélectionnée.
L'image ci-contre montre un autre exemple où le vertex de début a été
inversé tout en utilisant la même arête sélectionnée par comparaison à
l'exemple ci-dessus. Vous pouvez voir que le mouvement est toujours
limité à la longueur de l'arête sélectionnée. La ligne jaune de la boucle
d'arêtes reste droite, en se conformant à la boucle d'arêtes enveloppante
inférieure, car la découpe est placée à un distance constante depuis la Intervalle Proportionnel Inversé
boucle d'arêtes inférieure, le long des arêtes transversales.

4.2.5.7. Effacer une Boucle d’Arêtes (Delete Edge Loop)


Mode : mode Edit (Mesh) – Raccourci : X ou Delete – Menu : Mesh>Edges>Delete Edge Loop.

L'option Edge Loop du menu Erase vous permet de supprimer une boucle d'arêtes sélectionnée si elle se
trouve entre deux autres boucles d'arêtes.
Ceci créera une boucle de faces là ou il y en avait deux auparavant.

IV - 47
Note : L'option Edge Loop est très différente de l'option Edges, même si vous l'utilisez sur des arêtes qui semblent former une
boucle d'arêtes. Effacer une boucle d'arêtes fusionne les faces voisines pour préserver la surface du maillage. En effaçant une
chaîne d'arêtes, les arêtes sont effacées en effaçant aussi les faces environnantes. Cela laisse des trous dans le maillage là où se
trouvaient auparavant ces faces.

Limitations
Pour que l'outil Erase > Edge Loop fonctionne correctement, une unique boucle d'arêtes doit être sélectionnée. Les mêmes
restrictions que pour l'outil Edge Slide s'applique (voir cet outil pour plus de détails).

Exemple
La boucle d'arêtes sélectionnée sur l'UV
Sphère (ci-contre) a été supprimée et les
faces ont été fusionnées avec les arêtes
environnantes.

Si les arêtes avaient été effacées en


utilisant l'option Edges du menu Erase,
il y aurait eu à la place une bande vide
de faces effacées le long de la sphère.
Avant
Erase>Edge Loop Après Erase>Edge Loop

4.2.5.8. L’outil Knife Subdivide


Mode : mode Edit (Mesh) – Panneau : Contexte Edit>Mesh Tools – Raccourci : SHIFT K – Menu : Mesh>Edges>Knife
Subdivide... .
L'outil Knife Subdivide subdivise les arêtes sélectionnées via leur intersection avec une ligne de découpe dessinée par
l'utilisateur. Par exemple, si vous voulez découper un trou dans la partie avant d'une sphère, vous ne sélectionnez que les arêtes
de la partie avant, et ensuite, vous dessinez une ligne sur les arêtes sélectionnées avec la souris. L'outil est interactif et ne
fonctionne qu'avec des arêtes, qu'elles soient sélectionnées implicitement ou explicitement.
Le menu Cut Type
Ce menu de l'outil Knife Subdivide propose les types de découpes suivants :
• Exact Line divisera les arêtes exactement à leur intersection avec la ligne de découpe.
• Midpoints divisera en leur centre les arêtes intersectées par la ligne de découpe.
• Multicut permet plusieurs coupures parallèles. Un nombre supplémentaire doit être entré pour sélectionner
le nombre de coupures.
Dessin de la Ligne de Découpe
Quand vous utilisez l'outil Knife Subdivide, le curseur
prend l'apparence d'un scalpel et l'entête de la Vue 3D
change comme ci-contre :
Vous pouvez tracer des lignes droites connectées en cliquant LMB puis en déplaçant la souris de façon répétitive, ou vous
pouvez créer des lignes à main levée en appuyant sans relâcher LMB tout en déplaçant simultanément la souris. MMB
contraint le tracé de la ligne de découpe à suivre un axe vertical ou horizontal (par rapport à l'écran).
Confirmation et Sélection
Presser ESC ou RMB à tout instant abandonne l'outil, et presser ENTER confirme la découpe, avec les options suivantes :
• ENTER laissera sélectionné les arêtes, sauf les nouvelles arêtes créées par la découpe.
• CTRL ENTER ne sélectionnera que les nouvelles arêtes créées par la découpe. Note : seules les arêtes qui intersectent les
arêtes sélectionnées dessinées à la main seront sélectionnées.
Topologie
L'outil Knife Subdivide utilise les mêmes options que les autres outils Subdivide, localisés dans le contexte Edit. Si l'option
Beauty est activée, les faces sélectionnées ne sont subdivisées que le long des deux côtés les plus longs. Si les options Beauty
et Short sont activées toutes deux, les faces sélectionnées ne sont subdivisées que le long des deux côtés les plus courts.
Note : Utiliser le mode Edges Select pour ne sélectionner que les arêtes que vous voulez subdiviser, crée une subdivision plus
précise qu'avec l'utilisation du bouton Beauty.
Exemple de découpe Exact Line
Le dessin ci-dessous montre un exemple d'utilisation de l'option Exact Line de l'outil Knife Subdivide. La découpe est
déterminée par la ligne A dessinée à la main dans le plan appelé Drawing (à gauche).

IV - 48
Le plan appelé Enter (au centre) est le résultat de la validation par ENTER. Les intersections sur les arêtes du plan sont là où
la ligne dessinée intersecte réellement, indépendement de l'aspect tortueux de cette ligne de découpe. De plus, toutes les arêtes,
autres que celles nouvellement créées, ont été sélectionnées par l'outil.
Le plan appelé Ctrl-Enter (à droite) est le résultat de la validation par CTRL ENTER. Dans ce cas, seules les arêtes
nouvellements crées, B et C sont sélectionnées, alors que l'arête D ne l'est pas. L'arête D est une arête secondaire créée par
l'utilisation de l'outil.

Exemple de découpe Midpoints


Le dessin ci-dessous montre un exemple d'utilisation de l'option Midpoints de l'outil Knife Subdivide. La découpe est
déterminée par la ligne A dessinée à la main sur le plan appelé Drawing (à gauche). Remarquez comment la ligne A coupe
deux fois l'arête de droite; seule la première intersection sera prise en compte lors de la découpe.
Le plan appelé Enter (au centre) est le résultat de la validation par ENTER. Les intersections sur les arêtes du plan sont les
points du milieu de chaque arête, indépendement de l'endroit où a été dessinée la ligne de découpe. Toutes les arêtes, autres
que celles nouvellement créées, ont été sélectionnées par par l'outil.
Le plan appelé Ctrl-Enter (à droite) est le résultat de la validation par CTRL ENTER. Dans ce cas, seules les arêtes
nouvellements crées, B et C, sont sélectionnées, alors que l'arête D ne l'est pas. L'arête D est une arête secondaire créée par
l'utilisation de l'outil.

Exemple de découpe MultiCut


L'image ci-dessous montre un exemple d'utilisation de l'option MultiCut de l'outil Knife Subdivide.
Ce type de découpe fait apparaître une boîte de dialogue qui vous demande le nombre de coupures
(Number of Cuts, ci-contre), qui définie le nombre de coupures également espacées que doit
effectuer l'outil sur chaque arête intersectée. Par exemple, le nombre par défaut de 2 génère deux
intersections (ou trois nouvelles arêtes) pour chaque arête intersectée par la ligne dessinée à la main.
La découpe est déterminée par la ligne A dessinée à la main sur le plan appelé Drawing (à gauche), en utilisant la valeur de 2
par défaut pour le nombre de découpes. La ligne de découpe a été tracée de manière à ce qu'elle intersecte trois arêtes.
Le plan appelé Enter (au centre) est le résultat de la validation par ENTER. Il y a deux découpes également espacées sur
chaque arête intersectée par la ligne dessinée; appelées A, B et C. L'arête D est une arête secondaire créée par l'utilisation de
l'outil.
Le plan appelé Ctrl-Enter est le résultat de la validation par CTRL ENTER (à droite). Dans ce cas, seules les arêtes
nouvellement crées sont sélectionnées, alors que l'arête D ne l'est pas.

IV - 49
Limitations
• Les lignes de découpe peuvent être dessinées avec un nombre quelconque de segments, mais une seule intersection est
détectée par arête (un seul croisement). D'autres croisements plusieurs fois sur une arête ne produisent pas des coupures
additionnelles sur cette arête.
• Le mode Snap to Grid n'est pas implémenté.
Optimisation
Avec un grand Maillage, il sera plus rapide de sélectionner un petit nombre de vertices, ceux qui définissent uniquement les
arêtes que vous planifiez de séparer avec l'outil Knife Subdivide.

4.2.5.9. Faire Pivoter une Arête en CW (Rotate Edge CW)


Faire Pivoter une Arête en CCW (Rotate Edge CCW)
Mode : mode Edit (Mesh) – Raccourci : CTRL E, 3 et CTRL E, 4 – Menu : Mesh>Edges>Rotate Edge CW / Rotate Edge
CCW.
Les outils Rotate Edge CW et Rotate Edge CCW font pivoter une arête entre deux faces autour de leurs vertices. Ils sont très
utiles pour restructurer la topologie d'un Maillage. Ces outils peuvent opérer sur une arête explicitement sélectionnée, ou sur
deux vertices sélectionnés (ou deux faces sélectionnées) qui sélectionnent implicitement une arête entre eux.
Exemples :

Arête sélectionnée pivotée en CW et en CCW


Soyez conscient que parfois, comme vous pouvez le voir indiqué par un T dans l'image ci-dessus, vous pourriez produire des
jonctions/noeuds en forme de T avec cet outil. Cependant, Blender a créé des arêtes supplémentaires qui évitent des fissures
dans le maillage. Vous pouvez vous en assurer en sélectionnant le vertex en T et en en le déplaçant pour constater qu'il y a
maintenant deux arête au lieu d'une seule longue arête.
Pour faire pivoter une arête en se basant sur des faces, vous devez sélectionner deux faces
(image ci-contre), sinon Blender vous prévient par un message d'erreur ERROR : Select one
edge or two adjacent faces.

Utiliser soit l'outil Rotate Edge CW,soit l'outil Rotate Edge CCW produira exactement le
même résultat que si vous aviez sélectionné l'arête commune comme dans l'image précédente.

4.2.5.10. L’outil Edge Slide


Mode : mode Edit (Mesh) > mode Vertices Select ou mode Edges Select – Raccourci : CTRL E, 6 – Menu : Mesh>Edges>
Slide Edge.

L'outil Edge Slide permet de décaler une (ou plusieurs) arête(s) le long des faces adjacentes aux arêtes sélectionnées, mais
avec quelques restrictions concernant la sélection des arêtes.
• LMB confirme l'utilisation de l'outil, et RMB (ou ESC) l'abandonne.
• Comme pour l'outil Loop Subdivide, cet outil dispose des modes Percentage et Proportional, qui sont affichés dans
l'entête de la Vue 3D. Ces modes se comportent de la même façon que pour l'outil Loop Subdivide, en incluant toutes les
clés pour contrôler la précision du mouvement de l'arête.
Exemple de décalage simple d'un arête le long d'une boîte
extrudée
L'arête sélectionnée est appelée E et les faces adjacentes à
cette arête sont F1 et F2. Dans l'image Edge moving (au
centre), l'arête a été décalée le long de l'arête dessinée en vert.
L'image Moved (à droite) montre le résultat.
Limitations
Il existe des restrictions sur les types de sélection d'arête(s) qui peuvent être utilisés. Les sélections invalides sont :

IV - 50
Croisement de Boucle ( Error : loop crosses itself) :
Ceci signifie que l'outil ne trouve pas de faces adjacentes valables qui soient adjacentes à l'
(aux) arête(s) sélectionnée(s). L'image ci-contre en montre un exemple où deux arêtes
sélectionnée partage une face adjacente. Une face ne peut être adjacente à elle-même.

Arête Isolée (Error : Was not a single edge loop) :


La plus part du temps ceci signifie que vous avez sélectionné des arêtes qui ne partagent
pas la même boucle d'arêtes. L'image ci-contre en montre un exemple où les arêtes
sélectionnées ne sont pas dans la même boucle d'arêtes, ce qui implique qu'elles n'ont pas
d'arête commune. Vous pouvez minimisez le risque d'avoir cette erreur en sélectionnant
toujours des d'arête formant une chaîne.

Ordre de Boucle (Error : could not order loop) :


Ceci signifie que l'outil ne trouve pas de boucle d'arêtes en se basant sur les arêtes
sélectionnées. L'image ci-contre est l'exemple d'une unique arête sélectionnée sur un
Object Plane 2D. Une boucle d'arête ne peut être trouvée car il n'y a qu'une seule face.
Rappelez vous que les boucles d'arête sont des boucles qui nécessitent deux ou plusieurs
faces.

Une règle générale à respecter est que si plusieurs arêtes sont sélectionnées, elles doivent être connectées bout à bout afin de
former une chaîne continue. C'est litéralement une règle générale, car vous pouvez toujours sélectionner des arêtes en une
chaîne qui sera invalide car quelques arêtes dans la chaîne sont dans des boucles d'arêtes différentes. L'image sur le croisement
de boucle (plus haut) en est un bon exemple car les arêtes sélectionnées forment une chaîne mais n'appartiennent pas toutes à la
même boucle d'arêtes.
Si vous sélectionnez plusieurs arêtes, vérifiez bien qu'elles soient connectées. Cela diminuera la possibilité d'obtenir des erreur
de boucle.

4.2.5.11. L’outil Bevel


Mode : mode Edit (Mesh) – Raccourci : W, ALT 2 – Menu : Mesh>Edges>Bevel.
Un biseau (Bevel) est quelque chose qui lisse une arête vive ou un coin pointu. Les arêtes du monde réel sont très rarement
totalement vive (sharp). Même l'arête d'une lame de couteau ne peut être considérée comme totalement vive. La plupart des
arêtes sont intentionnellement biseautées pour des raisons mécanique et pratique.
Les biseaux sont aussi utiles pour donner du réalisme à des Objets non
organiques.

Dans le monde réel, les arêtes émoussées capture la Lumière et


modifie l'ombrage autour des arêtes.

Ceci donne un aspect solide réaliste (image ci-contre à gauche) à


opposer aux Objets non biseautés qui ont un aspect désagréable
(image ci-contre à droite).
Les Options de l'outil Bevel
Recursion : Le nombre de récursions dans le biseau peut être défini dans un champ flottant
supplémentaire. Plus le nombre de récursions est grand, et plus le biseau est lisse.
Si Recursion: est réglé à 1, alors chaque face est réduite en taille et chaque arête devient une unique nouvelle face. Des faces
Tri et Quad sont créées si nécessaire aux vertices correspondants. Si Recursion: est réglé à un nombre supérieur à 1, alors la
procédure Bevel est appliquée autant de fois que ce nombre. Donc, pour une Recursion de 2, chaque arête est transformée en
4 arêtes, trois nouvelles faces apparaissent au niveau de cette arête tout en lissant l'arête originale. En général, le nombre de
nouvelles arêtes est égal à 2 élevé à la puissance Recursion.
Width : Vous pouvez modifier la largeur du biseau en rapprochant (ou en éloignant) la souris de
l'Objet.
Le retaillage peut être contrôlé de façon plus fine, soit en maintenant appuyé CTRL pour retailler par étape de 0.1, soit en
maintenant appuyé SHIFT pour retailler par étape de 0.001. LMB finalise l'opération, RMB (ou ESC) abandonne l'action.
Alternativement, vous pouvez entrer manuellement une valeur de retaillage en pressant SPACE. Une boîte de dialogue
apparaît, qui vous demande de taper le facteur de retaillage du biseau, appelé Width. Le retaillage est limité à un intervalle
entre 0.0 et 10.0 et une fois le bouton OK cliqué, l'action Bevel est terminée.
Entête de la fenêtre de l'outil Bevel

IV - 51
Attention : Souvenez-vous que dans chaque récursion, pour chaque nouvelle arête, deux nouveaux vertices sont créés, avec
des vertices supplémentaires créés aux intersections entre les arêtes. Ceci veut dire que votre compte de vertices peut
rapidement devenir énorme si vous utilisez l'outil Bevel avec une récursion élevée !
Limitation
L'outil Bevel est toujours en développement et l'implémentation actuelle est plutôt brute puisque toutes les arêtes dans un
Maillage donné sont biseautées. Il n'y a aucun contrôle sur les arêtes que vous voulez conserver vives, ou sur des arêtes placées
sur des surfaces presque plates, que vous ne voulez pas du tout biseauter.
Exemple de Biseautage d'un Cube
L'image ci-contre est un exemple de biseautage d'un cube avec
une Recursion de 2. Une fois que la valeur Recursion est
fixée, chaque face du maillage reçoit un indicateur jaune. Le
cube appelé Bevelling montre l'outil en action.
Le résultat final peut être vu dans les cubes appelés Beveled
ou Shaded.

IV - 52