Vous êtes sur la page 1sur 2

TD Programmation C/C++ N°3

Objectifs :
1. Utilisation de constantes.
2. Définir de variables nécessaires à une application.
3. Expression relationnelle.
4. Utilisation de structure de contrôle Si ...Alors ... Sinon... FinSi

Sujet 1
1. Quel type de donnée représentent les mots réservés ci-dessous :
int, short, float, char, string, bool, double
Décrire les particularités de chaque type.
Donner des exemples de déclaration.
2. Initialiser les variables ci-dessous à une constante appropriée :
x : type d'entier à valeur -123
y : type de réel à 0.00002
z : type de réel à 230000000.0
i0 : type d'entier à 3acf (Hex)
i1 : type d'entier à 34576 (Oct)
s : type de chaîne de caractère à GEII MULHOUSE
b : type de booléen à VRAI
c : type d'entier au code de la lettre A.
t : type d'entier au code du chiffre 4.

3.
- Imaginer les variables nécessaires au programme permettant de calculer le volume
d'un cylindre
- Imaginer les variables nécessaires à une facture de téléphone :
Prénom, Nom, Numéro, Nombre d'unités au tarif normal, nombre d'unités au tarif
réduit, Prix unitaire, TVA, Montant HT, Montant Total.

Sujet 2

1. Traduire les expressions relationnelles ci-dessous en C :


- i inférieur ou égal à x
- j ∈ [x, y)
- m ∉(x, y]
- i égal à t et x est différent de y
- i inférieur à x élevé au carré OU j est négatif
2. Décrire la séquence des instructions permettant d'échanger les valeurs des deux
variables A et B.
3. Etant donné la fonction de racine carrée sqrt(x), décrire la séquence des instructions
permettant de calculer la racine carrée de | x | sans recours à la fonction valeur absolue.

Sujet 3

Représenter les séquences algorithmiques suivantes en organigramme puis en C :


1. Si x est supérieur à y et y n'est pas zéro Alors
x incrémente de 1
y prend la valeur de x
Sinon
TD Programmation C/C++ N°3

y décrémente de 1
x prend la valeur de y
2. Si y est une lettre majuscule Alors
y se transforme en minuscule
3. Si x est un chiffre Alors
x prend la valeur numérique de ce chiffre.

Sujet 4

1. Etudier la solution de l'équation a * x + c= 0.


- Définir le type des variables ;
- Donner l'algorithme de solution.
2. Etudier la solution de l'équation a * x2 + c = 0.
- Définir le type des variables ;
- Donner l'algorithme de solution.

Résumé

mots clés : Si ... Alors ... Sinon ... FinSi, ' ', " "