Vous êtes sur la page 1sur 10

Ejercicios Resueltos

1.- Ingresar por teclado el nombre y la edad de cualquier persona e imprima tanto el nombre como la edad 1. Inicio 2. Declaracin de variables: nombre, edad 3. Leer nombre, edad 4. Escribir nombre, edad 5. Fin 2.- Mostrar su nombre, sexo edad y estado civil, que son ingresados por teclado 1. Inicio 2. Declaracin de variables: nombre, sexo, estadocivil , edad 3. Leer nombre, sexo, edad, estadocivil 4. Escribir nombre, sexo, edad , estadocivil 5. Fin

3.- Ingresar por teclado el nombre y la edad de cualquier persona e imprima, solo si la persona es mayor de edad, el nombre de la persona. 1. Inicio 2. Declaracin de variables: nombre, edad 3. Leer nombre, edad 4. SI (edad >= 18) Entonces Escribir nombre 5. Fin SI 6. Fin 4.- Ingresar por teclado el nombre y la edad de cualquier persona e imprima solo si la persona es mayor de edad, el nombre de la persona, de lo contrario, imprima un mensaje que diga : no puede votar. 1. Inicio 2. Declaracin de variables: nombre, edad // Ec = estado civil 3. Leer nombre, edad 4. SI (edad >= 18) Entonces Escribir nombre 5. Sino 6. Escribir no puede votar !! 7. Fin SI 8. Fin

5.- Ingresar por teclado el nombre, la edad y el sexo de cualquier persona e imprima, solo si la persona es de sexo masculino y mayor de edad, el nombre de la persona. NOTA: suponga que en el campo denominado sexo el numero 1 es masculino o el numero 2 es femenino

1. Inicio 2. Declaracin de variables: nombre, sexo, edad 3. Leer nombre, sexo, edad 4. SI (sexo = 1) y (edad >= 18) Entonces Escribir nombre 5. Fin SI 6. Fin 6.- Ingresar por teclado el nombre, la edad, el sexo (1 o 2) y el estado civil de cualquier persona e imprima solo si la persona es un hombre soltero mayor de edad, el nombre de la persona. NOTA: en el campo de estado civil se graba el numero 1 en vez de soltero, el numero 2 en vez de casado o el numero 3 en vez de otro. 1. Inicio 2. Declaracin de variables: nombre, sexo, estadocivil , edad 3. Leer nombre, sexo, edad, estadocivil 4. SI (sexo = 1) y (estadocivil = 1) y (edad >= 18) Entonces Escribir nombre 5. Fin SI 6. Fin

7.- Desarrolle un algoritmo que permita leer dos valores distintos, determinar cual de los dos valores es el mayor y escribirlo. 1. Inicio 2. Inicializar variables: A = 0, B = 0 3. Solicitar la introduccin de dos valores distintos 4. Leer los dos valores 5. Asignarlos a las variables A y B 6. Si A = B Entonces vuelve a 3 porque los valores deben ser distintos 7. Si A>B Entonces Escribir A, Es el mayor 8. De lo contrario: Escribir B, Es el mayor 9. Fin_Si 10. Fin

8.- Desarrolle un algoritmo que permita leer tres valores y almacenarlos en las variables A, B y C respectivamente. El algoritmo debe imprimir cual es el mayor y cual es el menor. Recuerde constatar que los tres valores introducidos por el teclado sean valores distintos. Presente un mensaje de alerta en caso de que se detecte la introduccin de valores iguales. 1. Inicio 2. Inicializar las variables A, B y C 3. Leer los tres valores 4. Almacenar en las variables A, B y C 5. Si A > B y A > C Entonces 6. Escribir A Es el mayor 7. Sino 8. Si B > A y B > C Entonces 9. Escribir B Es el mayor 10. Sino 11. Escribir C Es el mayor 12. Fin_Si 13. Fin_Si 14. Fin 9.- Desarrolle un algoritmo que realice la sumatoria de los nmeros enteros comprendidos entre el 1 y el 10, es decir, 1 + 2 + 3 + . + 10. 1. Inicio 2. Declaracin de variables:N= 0, Suma = 0 3. Asignacin Contador :N = N + 1 4. Asignacin Acumulador:Suma = Suma + N 5. Si N = 10 Entonces 6. Escribir Suma 7. De lo contrario, Repetir desde el paso 3 8. Fin_Si 9. Fin

10.- Determinar la hipotenusa de un tringulo rectngulo conocidas las longitudes de sus dos catetos. Desarrolle el algoritmo correspondiente. 1. Inicio 2. Declaracin de Variables: CatA= 0,CatB=0 3. Leer el valor de cada cateto 4. Almacenarlo en la variable CatA y CatB 5. Calcular el valor de Hip con la formula indicada 6. Escribir el valor de la Hipotenusa 7. Fin

11.- Desarrolle un algoritmo que permita determinar el rea y volumen de un cilindro dado su radio (R) y altura (H). 1. Inicio 2. Declaracin de variables: R = 0, H = 0 3. Leer el valor de Radio (R) y Altura (H) 4. Calcular el Volumen aplicando la frmula 5. Calcular el valor del rea aplicando la frmula respectiva 6. Escribir el valor del rea y del Volumen 7. Fin 12.- Desarrolle un algoritmo que permita leer un valor cualquiera N y escriba si dicho nmero es par o impar. 1. Inicio 2. Declaracin de variables: N 3. Leer un nmero 4. Asignarlo a la variable N 5. Si el residuo de dividir a N entre 2 es igual a cero 6. Si es Si: Entonces: Escribir Es par 7. Sino: Escribir Es impar 8. Fin_Si 9. Fin 13.- Desarrolle un algoritmo que permita leer dos nmeros y ordenarlos de menor a mayor, si es el caso. 1. Inicio 2. Declaracin de Variables:A = 0, B = 0, Temporal = 0 3. Leer A y B 4. Si A<B Entonces 5. Asignar a Temporal = B 6. Asignar a B = A 7. Asignar a A = Temporal 8. Si no (De lo contrario) 9. Fin_Si 10. Escribir Orden = , A, B 11. Fin

14.- Realice un algoritmo que a partir de proporcionarle la velocidad de un automvil, expresada en kilmetros por hora, proporcione la velocidad en metros por segundo. 1. Inicio 2. Declaracin de Variables: Versal , Vel = 0 3. Leer Datos: Vel 4. Versal = (Vel * 1000) / 3600 5. Escribir resultado = ,Versal 6. Fin 15.- Desarrolle un algoritmo que permita calcular Promedio de Notas; finaliza cuando N = 0. 1. Inicio 2. Declaracin de Variables: N = 0, Promedio = 0, Acumula= 0 3. Leer N 4. Mientras N <> 0 hacer 5. Cuenta = Cuenta + 1 6. Acumula = Acumula + N 7. Fin Mientras 8. Promedio = Acumula/Cuenta 9. Escribir Promedio:; Promedio 10. Fin

16.- Desarrolle un algoritmo que permita leer un valor entero positivo N y determinar si es primo o no. 1. Inicio 2. Declaracin de variables: J = 2, S =0 3. Leer N 4. Mientras J<= N / 2 hacer 5. Si N / J =0 6. S=S+1 7. J=J+1 8. Fin_Si 9. Fin del ciclo mientras 10. Si S = 0 Entonces 11. Escribir N es primo 12. Sino (De lo contrario) 13. Escribir N no es primo 14. Fin_Si 15. Fin

17.- Desarrolle un algoritmo para la empresa Constructora Casas S.A., que le permita calcular e imprimir la nmina para su cancelacin a un total de 50 obreros calificados a quienes debe cancelar por horas trabajadas. La hora trabajada se paut en 2500 Pesos 1. Inicio 2. Declaracin de Variables: Numero_Obreros =50 Numero_Hora_Trabajada = 0 Total_nomina = 0 3. Imprimir lneas de ttulos de la nmina 4. Leer Datos 5. Mientras Numero_Obreros>0 6. Salario = Numero_Hora_Trabajada * 30 7. Total_nmina= Totalnmina + Salario 8. Numero_Obreros = Numero_Obreros - 1 9. Escribir Registro 10. Leer Datos 11. Fin_Mientras 12. Escribir Total : , Total_nmina 13. Fin

18.- Escribir un programa que calcule la expresin:

x^i
, ( 0,..,n) para cualquier par de valores de n y x. Para evaluar cada uno de los trminos de la sumatoria, crear y utilizar una funcin POTEN que tenga como parmetros la base x y el exponente i. Exhibir x, n y el resultado de la sumatoria.

1. Inicio 2. Declaracin de Variables: Suma = 0 i=0 3. Leer x, n 4. Para i = 0 a n 5. Suma = Suma + poten (x, i) 6. Fin_Para 7. Escribir x,n, Suma 8. Fin

Funcin poten 1. Inicio 2. Declaracin de Variables: bas i=0 ex p=0 3. Recibir bas, ex 4. Para i = 0 a ex 5. p = p * bas 6. Fin_Para 7. Retornar p 8. Fin

19.- Escribir un programa que reciba un numero del 1 al 12 desde el teclado y muestre el nmero de das correspondiente al mes que corresponda con ese da (usar funciones). 1. Inicio 2. Declaracin de Variables: mes= 0 3. Escribir Introduzca un numero del 1 al 12: 4. Leer mes 5. Si (mes < 1) o (mes > 12) Entonces 6. Escribir El numero introducido no corresponde a ningun mes 7. Sino (De lo contrario) 8. Escribir El mes tiene, dia_mes (mes),' dias.') 9. Si (mes = 2) Entonces 10. Escribir El o 29 si es ao bisiesto' 11. Fin_Si 12. Fin_Si 8. Fin

Funcin dia_mes 1. Inicio 2. Declaracin de Variables: dias_mes=0 i 3. Recibir i 4. Si i=1,3,5,7,8,10,12 Entonces dias_mes31 5. Fin_Si 6. Si i=1,3,5,7,8,10,12 Entonces dias_mes31 7. Fin_Si 8. Si i=1,3,5,7,8,10,12 Entonces dias_mes31 9. Fin_Si 10. Retornar dias_mes 11. Fin

Ejercicios Por Resolver


1) Desarrolle un algoritmo que permita determinar si un nmero dado es par, impar o cero. 2) Desarrolle un algoritmo que permita determinar de una serie de nmeros cuntos son par, impar o cero.

3) Desarrolle un algoritmo que lea un nmero, y si es negativo que lo imprima. 4) Desarrolle un algoritmo que lea una serie de nmeros, imprima el nmero si es negativo y el positivo del mismo.

5) Desarrolle un algoritmo que le permita leer el nombre, la edad , el sexo y el estado civil de cualquier persona e imprima el nombre de la persona si es un hombre casado y mayor de 40 aos o una mujer soltera menor de 50 aos. 6) Desarrolle un algoritmo que le permita leer las notas de las materias que ha cursado un estudiante hasta el momento, saque su promedio e imprima su nombre, nmero de carnet y el promedio.

7) Desarrolle un algoritmo para leer el nombre de un empleado, el salario bsico por hora y el nmero de horas trabajadas durante una semana. Calcule el salario neto, teniendo en cuenta que si el nmero de horas trabajadas durante la semana es mayor de 48 horas, esas horas dems se consideran horas extras y tienen un recargo del 35%. Imprima el nombre del empleado y su salario neto. 8) Desarrolle un algoritmo que le permita determinar dadas tres cajas cada una con 15 nmeros, en cul caja est un nmero dado.

9) Desarrolle un algoritmo que le permita determinar el nmero medio de tres nmeros. El nmero medio es aquel que no es el mayor ni el menor. 10) Desarrolle un algoritmo que le permita obtener la sucesin de Fibonacci 0,1,1,2 etc. Recuerde que la serie de Fibonacci se genera empezando con los nmeros 0 y 1 y calculando cada nuevo miembro como la suma de dos

miembros precedentes en la sucesin. Imprima los primeros n trminos de la sucesin.

11) Elabore un algoritmo que dado un valor X, calcule

Para X positivo: F(x) = (x - 2) 2 + (x - 4) 4 + (x - 6) 6 2 4 6 Para X negativo: F(x) = (x + 2) 2 + (x + 4) 4 + (x + 6) 6 2 4 6

12) Elabore un algoritmo, que calcule el aumento de sueldo de un trabajador, conociendo del mismo, su nombre, tipo de trabajador, su sueldo y la cantidad de hijos que tiene. El porcentaje de aumento del sueldo viene dado por el tipo de trabajador que es: Tipo de trabajador V 10% G 15% E 20% O 30% Adicionalmente se le paga una prima por cada hijo la cual es conocida y la misma para todos. 13) El colegio Mi angelito desea calcular el monto a pagar por inscripcin del nuevo ao escolar, para las familias con hijos en el colegio. Para ello se conoce el numero de hijos que tiene la familia en el colegio, el monto de matricula por nio, el monto de la mensualidad del mes de septiembre por nio y el monto de la sociedad de padres. Elabore un algoritmo que calcule el total a pagar por la familia, si la sociedad de padres se cobra una vez por familiar y si se otorga un descuento por la cantidad de hijos en el colegio que viene dado por la siguiente tabla. Cantidad de hijos 2 nios 3 nios > 3 nios Descuento 10% 15% 20%