Vous êtes sur la page 1sur 11

Crer un diagramme de Pareto dans Excel

par SilkyRoad (silkyroad.developpez.com)


Date de publication : 08 Novembre 2008 Dernire mise jour :

Cet article montre comment mettre en oeuvre un diagramme de Pareto dans Excel, sans VBA. Les descriptions correspondent une utilisation dans Excel 2007. Le principe de fonctionnement est identique pour les versions antrieures.

Crer un diagramme de Pareto dans Excel par SilkyRoad (silkyroad.developpez.com)

I - Introduction..............................................................................................................................................................3 II - La collecte des donnes........................................................................................................................................3 III - Les calculs............................................................................................................................................................ 4 III-A - Lister les catgories sans doublons............................................................................................................ 4 III-B - Compter le nombre d'occurrences par catgorie........................................................................................ 6 III-C - Dterminer le rang de chaque catgorie.....................................................................................................6 III-D - Trier les catgories par totaux dcroissants................................................................................................6 III-E - Calculer la part de chaque catgorie.......................................................................................................... 6 III-F - Cumuler les occurrences............................................................................................................................. 7 III-G - Visualiser les limites A, B et C dans le graphique...................................................................................... 7 IV - Le rsultat............................................................................................................................................................. 7 IV-A - Le diagramme de Pareto.............................................................................................................................7 IV-B - L'ajout des sries dans le graphique.......................................................................................................... 8 IV-C - La mise en forme du graphique..................................................................................................................9 IV-C-1 - Redfinir les limites de l'axe des ordonnes......................................................................................9 IV-C-2 - Modifier les types de sries d'histogramme en courbe...................................................................... 9 IV-C-3 - Afficher toutes les catgories sur l'axe des abscisses....................................................................... 9 IV-C-4 - Supprimer les espaces entre chaque donne en abscisses............................................................ 10 V - Conclusion........................................................................................................................................................... 10 VI - Liens....................................................................................................................................................................11 VII - Remerciements.................................................................................................................................................. 11 VIII - Tlchargement................................................................................................................................................ 11

-2Les sources prsentes sur cette pages sont libres de droits, et vous pouvez les utiliser votre convenance. Par contre la page de prsentation de ces sources constitue une oeuvre intellectuelle protge par les droits d'auteurs. Copyright 2008 Developpez LLC. Tout droits rservs Developpez LLC. Aucune reproduction, mme partielle, ne peut tre faite de ce site et de l'ensemble de son contenu : textes, documents et images sans l'autorisation expresse de Developpez LLC. Sinon vous encourez selon la loi jusqu' 3 ans de prison et jusqu' 300 000 E de dommages et intrts.

Crer un diagramme de Pareto dans Excel par SilkyRoad (silkyroad.developpez.com)

I - Introduction
Le diagramme de Pareto est un outil statistique qui permet d'identifier l'importance relative de chaque catgorie dans une liste d'enregistrements, en comparant leur frquence d'apparition. Un diagramme de Pareto est mis en vidence lorsque 20 % des catgories produisent 80 % du nombre total d'effets. Cette mthode permet donc de dterminer rapidement quelles sont les priorits d'actions. Si on considre que 20 % des causes reprsentent 80% des occurrences, agir sur ces 20 % aide solutionner un problme avec un maximum d'efficacit. Citation
En prparant leurs ambitions, les managers expriments savent que seuls quelques lments majeurs sont dcisifs. Le reste sera trait par la mme occasion en tant que parties de ces lments. Joseph Moser Juran - 1964

Un diagramme de Pareto est gnralement prsent sous forme d'histogramme en colonne. Les catgories sont affiches en abscisses, par ordre dcroissant de frquence. Le nombre d'apparition est indiqu sur l'axe des ordonnes. Une courbe en ligne contenant les valeurs cumules complte le diagramme. Le diagramme de Pareto est galement appel : * Mthode "ABC". * Rgle des 80/20. L'exemple prsent dans cet article a t mis en oeuvre dans Excel 2007. Le principe reste identique sous les versions antrieures. Il existe bien entendu d'autres solutions Excel pour visualiser un diagramme de Pareto. Cette dmo reposait sur plusieurs attendues : * Ne pas utiliser de VBA. * Automatiser au maximum le classeur pour que l'utilisateur ait simplement renseigner les donnes collectes. * Dtailler les formules pour expliquer le principe de calcul. * Afficher les valeurs dans un graphique pour obtenir un rsultat visuel. * Pouvoir rutiliser directement le classeur dmo pour d'autres analyses. Le classeur dmo montre galement comment : * Extraire des donnes sans doublons puis les trier, par formule. * Crer des plages nommes dynamiques dans Excel 2007. * Utiliser ces noms dans des graphiques Excel 2007.

II - La collecte des donnes


La collecte des donnes est une action essentielle car toute l'analyse va tre base sur la validit des informations recueillies. Il convient donc de vrifier : * La justesse des priodes de mesures. * La vracit des enregistrements. * Les units de mesure identiques pour l'ensemble de la source de donnes. * La cohrence des catgories. * Le regroupement des causes mineures en une seule catgorie "Divers". L'exemple propos dans la feuille 'Collecte' (voir le classeur en tlchargement la fin de cette page) liste les causes d'immobilisation d'une machine de production. Un nombre d'heures d'arrt, mesur sur une anne, est associ chaque catgorie. L'objectif final est d'identifier les causes principales d'arrt et de savoir sur quelles catgories agir en priorit pour augmenter le taux de rendement de l'installation.

-3Les sources prsentes sur cette pages sont libres de droits, et vous pouvez les utiliser votre convenance. Par contre la page de prsentation de ces sources constitue une oeuvre intellectuelle protge par les droits d'auteurs. Copyright 2008 Developpez LLC. Tout droits rservs Developpez LLC. Aucune reproduction, mme partielle, ne peut tre faite de ce site et de l'ensemble de son contenu : textes, documents et images sans l'autorisation expresse de Developpez LLC. Sinon vous encourez selon la loi jusqu' 3 ans de prison et jusqu' 300 000 E de dommages et intrts.

Crer un diagramme de Pareto dans Excel par SilkyRoad (silkyroad.developpez.com)

Si vous souhaitez rutiliser le classeur pour votre projet, supprimez les donnes existantes dans la feuille 'Collecte', partir de la deuxime ligne, puis insrez vos valeurs. La colonne A contient les catgories (les causes). Insrez les lments la suite dans la feuille, sans ligne vide. Ne vous proccupez pas des calculs ou des tris pralables. L'application va s'en charger automatiquement comme vous le dcouvrirez dans la suite du tutoriel. Pensez juste regrouper les catgories mineures en une seule catgorie "Divers" afin de ne pas polluer l'analyse par des donnes non reprsentatives. La colonne B contient le nombre d'occurrences pour chaque catgorie. Indiquez les valeurs en prenant soins de conserver une seule unit (Par exemple, ne mlangez pas des kilos avec des tonnes). Attention ne pas utiliser plusieurs libells pour une mme cause. Excel dispose d'une fonctionnalit dans le menu contextuel des cellules afin de choisir rapidement parmi les lment existants dans les cellules contiges d'une colonne : Clic droit dans la premire cellule vide de la colonne / Liste droulante de choix.

Nota : Si vous disposez d'une liste brute de catgories sans comptage d'occurrences, placez simplement les groupes dans la colonne A et indiquez 1 dans chaque cellule de la colonne B.

III - Les calculs


Toutes les oprations sont ralises dans la feuille 'Calculs'. Ce chapitre dcrit en dtail le processus qui va permettre d'obtenir le rsultat dfinitif.

III-A - Lister les catgories sans doublons


La premire phase consiste extraire la liste des catgories sans doublons, de la feuille 'Collecte'. La formule ci-dessous est saisie dans la cellule A2 (colonne 'IndexUniques') puis tire vers le bas : Formule
=SI(Collecte!A2="";"";SI(NB.SI(Collecte!A$2:A2;Collecte!A2)>1;"";MAX($A$1:$A1)+1))

Ainsi, vous reprez et indexez la position de chaque catgorie de manire unique. Important : Cette formule doit tre recopie dans autant de lignes qu'il y a de donnes dans la feuille 'Collecte' afin de pouvoir prendre en compte toutes les catgories. Dans la cellule B2 (colonne 'Liste catgories'), est saisie la formule : Formule
=SI(LIGNES($A$2:$A2)>MAX(IndexUniques);"";DECALER(Collecte!$A$2;EQUIV(LIGNES($A$2: $A2);IndexUniques;0)-1;0))

Vous obtenez la liste des catgories sans doublons. Remarquez dans la formule, l'utilisation d'une plage nomme 'IndexUniques' qui reprsente la colonne A dans la feuille 'Calculs'. Procdez de la manire suivante pour crer le nom : Onglet "Formules" dans le ruban. Bouton "Gestionnaire de noms" dans le groupe "Noms dfinis".
-4Les sources prsentes sur cette pages sont libres de droits, et vous pouvez les utiliser votre convenance. Par contre la page de prsentation de ces sources constitue une oeuvre intellectuelle protge par les droits d'auteurs. Copyright 2008 Developpez LLC. Tout droits rservs Developpez LLC. Aucune reproduction, mme partielle, ne peut tre faite de ce site et de l'ensemble de son contenu : textes, documents et images sans l'autorisation expresse de Developpez LLC. Sinon vous encourez selon la loi jusqu' 3 ans de prison et jusqu' 300 000 E de dommages et intrts.

Crer un diagramme de Pareto dans Excel par SilkyRoad (silkyroad.developpez.com)

Bouton "Nouveau". "IndexUniques" est saisi dans le champ "Nom". C'est la rfrence qui sera utilise dans la cellule B2. La formule =DECALER(Calculs!$A$2;;;NBVAL(Collecte!$A:$A)-1;1) est indique dans le champ "Fait rfrence :". Le bouton OK permet de valider le nom. La fonction DECALER peut tre rsume ainsi dans notre exemple : DECALER(Cellule de base;;;Nombre de lignes;Nombre de colonnes) Le nombre de lignes de la plage nomme est dpendant de la partie NBVAL(Collecte!$A:$A)-1. Elle compte le nombre de donnes dans la colonne A de la feuille 'Collecte'. La formule DECALER permet donc la mise en oeuvre d'une plage nomme dynamique, c'est dire qui sera redfinie automatiquement en fonction du nombre de donnes dans la feuille 'Collecte'. Les autres fonctions du classeur utilisent galement des plages nommes dynamiques. Les mises jour sont donc automatises et l'utilisateur n'a pas besoin de modifier toutes les formules quand le nombre et le contenu des donnes changent. Nota C'est volontairement que la plage nomme 'IndexUniques' est base sur le nombre de lignes de la feuille 'Collecte'. Ce choix limite le risque d'oublier des catgories dans la source de donnes. Le tableau suivant rcapitule les noms et les rfrences utiliss dans le classeur dmo : Nom Rfrence Feuille Collecte / colonne A Feuille Collecte / colonne B Feuille Calculs / colonne A Feuille Calculs / colonne C Feuille Calculs / colonne D Feuille Calculs / colonne F Feuille Calculs / colonne G Feuille Calculs / colonne H Feuille Calculs / colonne I Feuille Calculs / colonne J Feuille Calculs / colonne K Feuille Calculs / colonne L Formule =DECALER(Collecte!$A $2;;;NBVAL(Collecte!$A: $A)-1;1) =DECALER(Collecte!$B $2;;;NBVAL(Collecte!$B: $B)-1;1) =DECALER(Calculs!$A $2;;;NBVAL(Collecte!$A: $A)-1;1) =DECALER(Calculs!$C $2;;;SOMMEPROD((Calculs! $C$1:$C$100<>"")*1)-1;1) =DECALER(Calculs!$D $2;;;SOMMEPROD((Calculs! $D$1:$D$100<>"")*1)-1;1) =DECALER(Calculs!$F $2;;;SOMMEPROD((Calculs! $C$1:$C$100<>"")*1)-1;1) =DECALER(Calculs!$G $2;;;SOMMEPROD((Calculs! $G$1:$G$100<>"")*1)-1;1) =DECALER(Calculs!$H $2;;;SOMMEPROD((Calculs! $C$1:$C$100<>"")*1)-1;1) =DECALER(Calculs!$I $2;;;SOMMEPROD((Calculs! $C$1:$C$100<>"")*1)-1;1) =DECALER(Calculs!$J $2;;;SOMMEPROD((Calculs! $C$1:$C$100<>"")*1)-1;1) =DECALER(Calculs!$K $2;;;SOMMEPROD((Calculs! $D$1:$D$100<>"")*1)-1;1) =DECALER(Calculs!$L $2;;;SOMMEPROD((Calculs! $D$1:$D$100<>"")*1)-1;1)

Categories Occurences

IndexUniques NbOccurences RangUnique OrdreOccurences CategoriesTriees Part CumulOccurences Pourcentage Limite_A Limite_B

-5Les sources prsentes sur cette pages sont libres de droits, et vous pouvez les utiliser votre convenance. Par contre la page de prsentation de ces sources constitue une oeuvre intellectuelle protge par les droits d'auteurs. Copyright 2008 Developpez LLC. Tout droits rservs Developpez LLC. Aucune reproduction, mme partielle, ne peut tre faite de ce site et de l'ensemble de son contenu : textes, documents et images sans l'autorisation expresse de Developpez LLC. Sinon vous encourez selon la loi jusqu' 3 ans de prison et jusqu' 300 000 E de dommages et intrts.

Crer un diagramme de Pareto dans Excel par SilkyRoad (silkyroad.developpez.com)

III-B - Compter le nombre d'occurrences par catgorie


La colonne C (champ 'Nb occurences') de la feuille 'Calculs' va comptabiliser le total de valeurs pour chaque groupe. Formule
=SI(B2="";"";SOMME.SI(Categories;B2;Occurences))

Le nom 'Categories' reprsente la colonne A dans la feuille 'Collecte' : =DECALER(Collecte!$A$2;;;NBVAL(Collecte!$A:$A)-1;1) Le nom 'Occurences' reprsente la colonne B dans la feuille 'Collecte' : =DECALER(Collecte!$B$2;;;NBVAL(Collecte!$B:$B)-1;1) La formule additionne toutes les valeurs par catgorie.

III-C - Dterminer le rang de chaque catgorie


Un diagramme de Pareto reprsente gnralement un histogramme de donnes dcroissantes et une courbe des valeurs cumules. Pour obtenir le mme rsultat visuel dans un graphique Excel, nous allons devoir classer chaque total par ordre dcroissant. Tout d'abord il faut identifier le rang de chaque total : 1 pour le plus grand total, 2 pour le deuxime total, ...etc ... La formule suivante est insre dans la colonne D (champ 'RangUnique'). Formule
=SI(B2="";"";RANG(C2;NbOccurences)+NB.SI($C$2:C2;C2)-1)

Le nom 'NbOccurences' reprsente la colonne C dans la feuille 'Calculs'. +NB.SI($C$2:C2;C2)-1 permet de diffrencier la numrotation des ex-aequo. Cela sera utile pour lister les catgories tries, comme vous pourrez le voir dans le chapitre suivant.

III-D - Trier les catgories par totaux dcroissants


La phase suivante consiste trier les valeurs et les catgories associes. La colonne F (champ 'OrdreOccurences') trie les totaux par ordre dcroissant. Formule
=SI(C2="";"";GRANDE.VALEUR(NbOccurences;LIGNE()-1))

La colonne G (champ 'CatgoriesTries') trie les catgories par ordre dcroissant. Cette plage de cellules servira crer l'axe des abscisses du graphique. Formule
=SI(C2="";"";INDEX(DECALER(RangUnique;;-2;SOMMEPROD((Calculs!$C$1:$C $100<>"")*1)-1;3);EQUIV(LIGNE()-1;RangUnique;0);1))

III-E - Calculer la part de chaque catgorie


Les donnes de la colonne H (champ 'Part') vont servir de valeurs d'ordonnes pour l'histogramme du graphique. Il s'agit donc ici de redfinir les valeurs de la colonne F (champ 'OrdreOccurences') sous forme de pourcentage par rapport au total de cette colonne.

-6Les sources prsentes sur cette pages sont libres de droits, et vous pouvez les utiliser votre convenance. Par contre la page de prsentation de ces sources constitue une oeuvre intellectuelle protge par les droits d'auteurs. Copyright 2008 Developpez LLC. Tout droits rservs Developpez LLC. Aucune reproduction, mme partielle, ne peut tre faite de ce site et de l'ensemble de son contenu : textes, documents et images sans l'autorisation expresse de Developpez LLC. Sinon vous encourez selon la loi jusqu' 3 ans de prison et jusqu' 300 000 E de dommages et intrts.

Crer un diagramme de Pareto dans Excel par SilkyRoad (silkyroad.developpez.com)

Formule
=SI(C2="";"";F2/SOMME(OrdreOccurences))

III-F - Cumuler les occurrences


Un diagramme de Pareto est galement bas sur la reprsentation d'une courbe cumule de 0 100%. La colonne I (champ 'OrdreOccurences') va additionner les valeurs tries dans la colonne F. Formule
=SI(F2="";"";SOMME($F$2:F2))

La colonne J (champ 'Pourcentage') va convertir les valeurs de la colonne I en pourcentage par rapport au total de cette colonne. Cette plage de cellules servira d'ordonnes pour la courbe de cumul dans le graphique. Formule
=SI(I2="";"";I2/SOMME(NbOccurences))

III-G - Visualiser les limites A, B et C dans le graphique


L'efficacit d'un graphique Excel reposant en partie sur son attrait visuel, il reste dfinir des droites 80 et 95 %. Vous pourrez ainsi visualiser rapidement les limites qui dfinissent l'analyse de Pareto : La plage A : Catgories contenant de 0 80% des effets. La plage B : Catgories contenant de 80 95 % des effets. La plage C : les 5 % d'effets restants. Le calcul effectu dans les colonnes K et L permettra d'afficher ces droites limites dans le graphique. Formule
=SI(C2="";"";0,8)

Formule
=SI(C2="";"";0,95)

IV - Le rsultat IV-A - Le diagramme de Pareto


Dsormais, tous les paramtres sont en place pour afficher le diagramme de Pareto dans un graphique Excel. L'objectif consiste obtenir la prsentation finale suivante :

-7Les sources prsentes sur cette pages sont libres de droits, et vous pouvez les utiliser votre convenance. Par contre la page de prsentation de ces sources constitue une oeuvre intellectuelle protge par les droits d'auteurs. Copyright 2008 Developpez LLC. Tout droits rservs Developpez LLC. Aucune reproduction, mme partielle, ne peut tre faite de ce site et de l'ensemble de son contenu : textes, documents et images sans l'autorisation expresse de Developpez LLC. Sinon vous encourez selon la loi jusqu' 3 ans de prison et jusqu' 300 000 E de dommages et intrts.

Crer un diagramme de Pareto dans Excel par SilkyRoad (silkyroad.developpez.com)

IV-B - L'ajout des sries dans le graphique


Ajoutez une nouvelle feuille de calcul. Slectionnez l'onglet "Insertion" dans le ruban. Cliquez sur le bouton "Colonne" dans le groupe "Graphiques". Slectionnez "Histogramme 2D" / group. Un nouvel objet graphique vierge est insr dans la feuille. Slectionnez cet objet graphique. Faites un clic droit. Cliquez sur l'option "Slectionner des donnes" dans le menu contextuel. Cliquez sur le bouton "Ajouter".

Nous allons crer l'histogramme dcroissant (donnes de la colonne H) : Indiquez un nom pour la srie. Dans le champ "Valeurs de la srie", saisissez la plage nomme correspondant la colonne H : ='pareto_XL2007.xls'!Part

Cliquez sur le bouton OK pour valider. Cliquez sur le bouton "Modifier" pour spcifier l'abscisse (la liste des catgories).

Saisissez la plage nomme correspondant la colonne G : =pareto_XL2007.xls!CategoriesTriees

Cliquez sur le bouton OK dans toutes les botes de dialogue pour valider. Reproduisez la mme opration pour ajouter les autres sries. La courbe de cumul :
-8Les sources prsentes sur cette pages sont libres de droits, et vous pouvez les utiliser votre convenance. Par contre la page de prsentation de ces sources constitue une oeuvre intellectuelle protge par les droits d'auteurs. Copyright 2008 Developpez LLC. Tout droits rservs Developpez LLC. Aucune reproduction, mme partielle, ne peut tre faite de ce site et de l'ensemble de son contenu : textes, documents et images sans l'autorisation expresse de Developpez LLC. Sinon vous encourez selon la loi jusqu' 3 ans de prison et jusqu' 300 000 E de dommages et intrts.

Crer un diagramme de Pareto dans Excel par SilkyRoad (silkyroad.developpez.com)

=pareto_XL2007.xls!Pourcentage La droite de limite des 80 % : =pareto_XL2007.xls!Limite_A La droite de limite des 95 % : =pareto_XL2007.xls!Limite_B Toutes les sries sont insres dans le graphique mais on est encore loin du compte pour ce qui est du rsultat visuel :

Le chapitre suivant montre comment mettre en forme le graphique et finaliser le projet.

IV-C - La mise en forme du graphique IV-C-1 - Redfinir les limites de l'axe des ordonnes
Par dfaut, les valeurs d'ordonnes sont indiques de 0 120 %. Pour afficher les valeurs de 0 100 %, slectionnez l'axe des ordonnes. Clic droit. Slectionnez "Mise en forme de l'axe" dans le menu contextuel. Cliquez sur le menu "Options de l'axe". Slectionnez l'option "Fixe" pour la valeur "Maximum". Indiquez 1 (ce qui reprsente 100 %) dans le champ. Cliquez sur le bouton "Fermer".

IV-C-2 - Modifier les types de sries d'histogramme en courbe


Les sries Cumul, Limite_A et Limite_B doivent tre transformes en courbes dans le diagramme de Pareto. Procdez de la mme manire pour les 3 sries : Slectionnez la srie. Clic droit. Slectionnez "Modifier le type de graphique Srie de donnes" dans le menu contextuel. Choisissez le type de graphique "Courbe". Cliquez sur le bouton OK pour valider.

IV-C-3 - Afficher toutes les catgories sur l'axe des abscisses


Pour visualiser la liste complte des catgories sur l'axe des abscisses :
-9Les sources prsentes sur cette pages sont libres de droits, et vous pouvez les utiliser votre convenance. Par contre la page de prsentation de ces sources constitue une oeuvre intellectuelle protge par les droits d'auteurs. Copyright 2008 Developpez LLC. Tout droits rservs Developpez LLC. Aucune reproduction, mme partielle, ne peut tre faite de ce site et de l'ensemble de son contenu : textes, documents et images sans l'autorisation expresse de Developpez LLC. Sinon vous encourez selon la loi jusqu' 3 ans de prison et jusqu' 300 000 E de dommages et intrts.

Crer un diagramme de Pareto dans Excel par SilkyRoad (silkyroad.developpez.com)

Slectionnez l'axe des abscisses. Clic droit. Slectionnez "Mise en forme de l'axe" dans le menu contextuel. Choisissez le menu "Options de l'axe". Cliquez sur l'option "Spcifier l'unit de l'intervalle". Indiquez la valeur 1.

Ensuite, Cliquez sur le menu "Alignement". Choisissez "Faire pivoter tout le texte de 270" dans le menu droulant "Orientation du texte". Cliquez sur le bouton "Fermer". Nota : Lorsque vous faites un clic droit sur l'axe, apparait galement la mini barre d'outils Excel 2007. Utilisez ce menu contextuel pour personnaliser le format du texte.

IV-C-4 - Supprimer les espaces entre chaque donne en abscisses


Slectionnez la srie en histogramme ('Catgories'). Clic droit. Slectionnez l'option "Mettre en forme une srie de donnes". Menu "Options des sries". Ramenez le curseur "Largeur de l'intervalle" 0%. Pendant que la fentre de personnalisation de la srie est ouverte, vous pouvez mettre en forme : * La couleur de fond * Les bordures * Les types de traits et les marqueurs Cliquez sur le bouton "Fermer" pour terminer. La mise en forme de votre graphique est dsormais termine et vous pouvez visualiser le diagramme de Pareto.

On voit clairement qu'il faut agir en priorit sur les temps de panne mcanique et sur la dure des intercampagnes pour diminuer significativement l'immobilisation de la machine.

V - Conclusion
J'espre que les informations fournies dans cet article vous aideront finaliser vos projets. Adaptez et modifiez librement le classeur dmo en fonction de vos besoins.

- 10 Les sources prsentes sur cette pages sont libres de droits, et vous pouvez les utiliser votre convenance. Par contre la page de prsentation de ces sources constitue une oeuvre intellectuelle protge par les droits d'auteurs. Copyright 2008 Developpez LLC. Tout droits rservs Developpez LLC. Aucune reproduction, mme partielle, ne peut tre faite de ce site et de l'ensemble de son contenu : textes, documents et images sans l'autorisation expresse de Developpez LLC. Sinon vous encourez selon la loi jusqu' 3 ans de prison et jusqu' 300 000 E de dommages et intrts.

Crer un diagramme de Pareto dans Excel par SilkyRoad (silkyroad.developpez.com)

Les formules sont ici volontairement dtailles sur plusieurs colonnes mais vous pouvez regrouper les fonctions, masquer ou rarranger les colonnes de calcul intermdiaire comme bon vous semble.

VI - Liens
Le diagramme de Pareto, sur WikiPedia. Utiliser les fonctions Excel Optimisez vos recherches avec les fonctions Index et Equiv La gestion des doublons dans Excel

VII - Remerciements
Je remercie toute l'quipe Office de DVP et particulirement Philippe Jochmans, Jean Ballat , pour la relecture et la correction du tutoriel.

VIII - Tlchargement
Tlchargez le classeur dmo (Test sous Excel2002 et Excel2007).

- 11 Les sources prsentes sur cette pages sont libres de droits, et vous pouvez les utiliser votre convenance. Par contre la page de prsentation de ces sources constitue une oeuvre intellectuelle protge par les droits d'auteurs. Copyright 2008 Developpez LLC. Tout droits rservs Developpez LLC. Aucune reproduction, mme partielle, ne peut tre faite de ce site et de l'ensemble de son contenu : textes, documents et images sans l'autorisation expresse de Developpez LLC. Sinon vous encourez selon la loi jusqu' 3 ans de prison et jusqu' 300 000 E de dommages et intrts.