Vous êtes sur la page 1sur 5

Centro Universitrio Anhanguera Campus II Campo Grande - MS Disciplina: Algoritmos e Programao Turma:Engenharias A e B Prof.: Luciene de O.

Marin 1 Lista de Exerccios


1) Assinalar os identificadores vlidos ( ) ALICE ( ) SALARIOMINIMO ( ) 1A1B1C ( ) A1B1C1 ( ) EU_E_VOCE ( ) TRESVEZESQUATRO ( ) NOIS ( ) ZERO ( ) NOME ( ( ( ( ) 3x4 ) M2 ) MEU ) CERTO ( ( ( ( ) EU*E*VOC )HEIN! ) A-B ) KM/H

2) Sendo A,B,C,D,E variveis do tipo numrico quais os resultados obtidos por cada uma da seguintes funes, onde A = 13; B = 2; C = 4,8 ; D = 5,1 ; E = 13 a) QUOCIENTE (A,B) e RESTO(A,B) = b) SINAL (A+B-E) = c) ARREDONDA(A+C) = d) TRUNCA(A + C) = e) ABS(A-B2 + D) = f) EXP(A - E) = 3) Dadas as variveis numricas A, B, C e as variveis literais NOME e ESPORTE, resolva as relaes abaixo: Variveis NOME JOS MARIA PEDRO Relaes ESPORTE = GOLFE

A 3 2 1

B 2 3 4

C 16 10 7

ESPORTE FUTEBOL TNIS GOLFE

A+B2>C

NOME JOS

4) Baseando-se nas seguintes declaraes, marque C ( Certo) ou E (Errado) para as atribuies: A, E, I, X, Z so variveis Numricas K, L, M so variveis Literais C1, C2 so variveis Lgicas ( ) A A ( ) X CINCO ( ) C1 F ( ) E 4350 ( ) Z 2030 ( ) M QUATRO ( ) C2 falso ( ) L UFSC ( ) K 1234 ( )I1 ( ) C2 X > Z

5) Baseando-se nas seguintes atribuies, marque nos parnteses os valores lgicos das expresses : X 100 Y 2,5 Z 23 A AMIGO B5<9 C ALICE D 50 ( ( ( ( ( ( ( ( ( )A=C ) Z*3 - D > Y ) AMIGA A ) B ou C < A ) V e Z = X ou no F ) no ( X+ D < Z ) ou X Y ) Y = D*2 e X 0 ou X Y )Y = D*2 e (X 0 ou X Y ) ) A = AMIGA e no B

6) Dado o algoritmo abaixo, responda incio-algoritmo declare B1, B2, B3: lgico se (B1) ento C1; seno se (B2) ento se (B3) ento C2; seno C3; C4; fim-se fim-se fim-se C5; fim-algoritmo Se B1= verdadeiro, B2 = verdadeiro, B3 = falso, quais os comandos que sero executados ? Se B1= falso, B2 = verdadeiro, B3 = falso, quais os comandos que sero executados ? Quais os valores de B1, B2, B3 para que somente o comando C5 seja executado? Se B1= falso, B2 = verdadeiro, B3 = Verdadeiro, quais os comandos que sero executados ? 7) Dado o algoritmo abaixo, responda incio-algoritmo declare A, B, C : lgico declare X, Y, V,L : numrico L 2; A falso; B verdadeiro; C falso; X 1,5; Y 3,2; X X + 1; se (C ou ( (X + Y > 5) ou ( no A e B))) L 0; fim-se fim-algoritmo Qual o valor de L aps a execuo deste trecho de algoritmo ? 8) Quais as sadas do algoritmo abaixo: incio-algoritmo declare A, B, T: numrico escreva Digite dois nmeros leia A, B T A A B B T escreva A, B fim-algoritmo para A = 1 e B = 5, A = 7 e B = 9 9) Quais as sadas do algoritmo abaixo: incio-algoritmo declare A, B: numrico escreva Digite dois nmeros leia A, B A A + B B A - B A A - B escreva A, B fim-algoritmo para A = 1 e B = 5, A = 7 e B = 9

ento

10) Dado o algoritmo abaixo, responda incio-algoritmo declare NMERO, A, B, C, D: numrico NMERO 1352; D RESTO ( NMERO,10); C RESTO (QUOCIENTE ( NMERO,10), 10); B RESTO (QUOCIENTE ( NMERO,100), 10); A RESTO (QUOCIENTE ( NMERO,1000), 10); escreva A, B, C, D fim-algoritmo Quais os valores escritos pelo algoritmo? 11) Quais os resultados produzidos pelo algoritmo que se segue ? incio-algoritmo declare Y: numrico declare X: lgico Y 0; X falso; enquanto (Y 6) faa X no X; Y Y + 1; se ( X ) ento escreva ( Y ) seno escreva ( -Y ) fim-se fim-enquanto fim-algoritmo 12) Quais os resultados produzidos pelo algoritmo que se segue se : a) NUM = 10 b) NUM = 0 c)NUM = -47

incio-algoritmo declare NUM: numrico declare QUALE: literal escreva Digite um nmero leia NUM se (NUM > 0) ento QUALE NMERO POSITIVO; seno se ( NUM < 0 ) ento QUALE NMERO NEGATIVO; seno QUALE ZERO; fim-se fim-se escreva QUALE; fim-algoritmo 13) O que est errado no algoritmo abaixo ? incio-algoritmo declare N, PAR, X: numrico escreva Digite um nmero leia N X RESTO ( N,2 ) se (X = 0) ento PAR verdadeiro; seno PAR falso; fim-se fim-algoritmo

14) Dado o algoritmo abaixo incio-algoritmo declare A, B, C, I, J, K: numrico A 32; C 2; B A^(1/5); I 5; J C * (3/4); se (B > J) ento K 8 * I/(6^2/C); seno K A + I/A - I; fim-se escreva B, J, K fim-algoritmo que valores sero escritos ? 15) Dado o algoritmo abaixo incio-algoritmo declare NUM, T, DIVI, AR : numrico DIVI 0; AR 0, T 0 escreva Digite um nmero leia NUM se (NUM 0) ento T TRUNCA (NUM/12); DIVI NUM/12; AR ARREDONDA (NUM/12); se (RESTO(NUM,12) 6) ento T T + 1; fim-se fim-se escreva DIVI, AR, T fim-algoritmo que valores sero escritos se, em sucessivas execues, fossem lidos os valores 30, 19, 27, 60, 0 ? 16) Quais as sadas do algoritmo abaixo ? incio-algoritmo declare I, A, B, C: numrico I 1; B 2 ; C 3 enquanto (I < 5) faa A B + C escreva A I I + 1 B A + 1 C A + C fim-enquanto fim-algoritmo

17). Quais as sadas do algoritmo abaixo ? incio-algoritmo declare I, A, B, C: numrico A 1 ; B 2 ; C 3 para (I 1 at 5 passo1) faa se (RESTO(I,2) = 0)ento {verifica se o nmero par} A A + 1 Seno B A + C fim-se fim-para escreva A, B, C fim-algoritmo

18) Faa um algoritmo que escreva todos os nmeros inteiros de 1 a 5. 19) Faa um algoritmo que leia dois nmeros e mostre qual o maior dos dois. 20) Faa um algoritmo que leia dez nmeros, calcule e mostre quantos so pares e quantos so mpares. 21) Faa um algoritmo que leia dez nmeros, calcule e mostre a soma dos nmeros pares. 22) Faa um algoritmo que leia dez nmeros, calcule e mostre a mdia dos nmeros mpares. 23) Faa um algoritmo que leia um nmero N, some todos os nmeros inteiros de 1 a N, e escreva esta soma. 24) Dados N ( nmero de termos que conter uma seqncia) e uma seqncia de N nmeros inteiros , determinar e escrever a soma dos nmeros pares. 25) A converso de graus Farenheit para centgrados obtida pela frmula C = 5 * ( F - 32 ) 9 26) Fazer um algoritmo que calcule e escreva uma tabela de centgrados em funo de graus Farenheit, que variam de 50 a 150 de 2 em 2. 27) Ler 3 nmeros e verificar se os 3 so iguais ou se h dois iguais ou se no h nenhum, conforme escrever uma mensagem com o resultado. 28) Ler 3 nmeros e verificar se estes podem formar um tringulo. Para sabermos se os nmeros formam um tringulo podemos usar a frmula Lado1 + Lado2 > Lado3 ( ou seja, a soma de dois lados tem que ser necessariamente maior que o 3 lado) . Conforme o resultado escreva uma mensagem. 29) Dado 3 valores verificar se eles podem ser os comprimentos dos lados de um tringulo e, se forem, verificar se um tringulo equiltero ( 3 lados iguais ) , issceles ( 2 lados iguais ) ou escaleno ( 3 lados diferentes ). Conforme o resultado escreva uma mensagem. 30) Faa um algoritmo que leia um nmero X, e depois uma lista de nmeros at que um nmero seja igual ao nmero X. Escreva esse nmero. 31) Faa um algoritmo que leia uma quantidade indeterminada de letras. Flag letra Z. Calcule e escreva a quantidade de vogais lidas. 32) Faa um algoritmo que leia uma quantidade indeterminada de letras. Flag letra J. Calcule e escreva a quantidade de cada vogal lida. 33) Faa um algoritmo que leia uma quantidade indeterminada de letras. Flag letra D. Calcule e escreva a quantidade de p e q lidas.