Vous êtes sur la page 1sur 17

Exerccios VisuAlg

Pede-se: Desenvolver o algoritmo em Pseudocdigo ou Portugol, como o exemplo no exerccio 9, o diagrama de bloco, e o teste de mesa. Execut-los pelo VisuAlg. 1) Ler uma temperatura em graus Celsius e apresent-la convertida em graus Fahrenheit. A frmula de converso : F (9 * C + 160) / 5, sendo F a temperatura em Fahrenheit e C a temperatura em Celsius. 2) Ler uma temperatura em graus Fahrenheit e apresent-la convertida em graus Celsius. A frmula de converso : C ( F - 32 ) * ( 5 / 9 ), sendo F a temperatura em Fahrenheit e C a temperatura em Celsius. 3) Calcular e apresentar o volume de um recipiente cilndrico (por exemplo, uma lata de leo), utilizando a frmula: { VOLUME ( * R2 * ALTURA)} VOLUME 4) Ler valores diferentes para as variveis A e B, e efetuar a troca dos valores de forma que, a varivel A passe a possuir o valor da varivel B, e a varivel B o valor da varivel A. Apresentar os valores trocados. (3.14159 * R2 * ALTURA) 5) Um veculo deve cumprir um percurso de K quilmetros. Sabendo-se que a capacidade do seu tanque de L litros e que seu consumo mdio de C quilmetros por litro, Como verificar se haver ou no necessidade de reabastecer? No incio do percurso o tanque est cheio. Exibir uma das mensagens: Deve reabastecer! ou No deve reabastecer!. 6) Encontrar e imprimir o menor e o maior nmero de uma srie aleatria fornecida pelo usurio. A srie composta de pelo menos um nmero. Quando o usurio digitar zero (0), a condio de fim, ou seja, o programa termina. Imprimir o maior e o menor nmero a cada valor digitado e incluir o nmero digitado numa lista do tipo Label ou Textbox. 7) Troco em Moedas A bilheteria de uma Estao do Metr possui moedas de 1 centavo, 10 centavos, 50 centavos, e 1 real para compor os valores de troco. Conhecendo-se o valor a ser cobrado (em reais) e o valor fornecido por um usurio (tambm em reais), como determinar as quantidades de cada tipo de moeda necessrias para completar o valor do troco, de maneira que seja utilizado o menor nmero de moedas no total? 8) Conhecendo-se a velocidade de um mvel em m/s (metros por segundo), como obter a velocidade equivalente em km/h (quilmetros por hora)?

Exerccio 1 Fluxograma

Cdigo algoritmo "Exercicio 1" // Funo : Ler uma temperatura em graus Celsius e apresenta-la convertida em Fahreinheit // Autor : // Data : 05/03/2013 // Seo de Declaraes var C,F: real inicio // Seo de Comandos escreva("Digite o valor da temperatura em graus Celsius: ") leia(C) F<- (9*C+160)/5 escreva("A temperatura em graus Fahreinheit : ",F) fimalgoritmo

Teste de Mesa
C F 26 78.8

Exerccio 2 Fluxograma

Cdigo algoritmo "Exerccio 2" // Funo : Ler uma temperatura em graus Fahreinheit e apresenta-la convertida em graus Celsius // Autor : // Data : 05/03/2013 // Seo de Declaraes var c,f:real inicio // Seo de Comandos escreva("temperatura em graus fahrenheit ") leia(f) c<-(f-32)*(5/9) escreva("temperatura em graus celsius ",c) fimalgoritmo

Teste de Mesa
F C 85 29.4

Exerccio 3 Fluxograma

Cdigo algoritmo "Exercicio 3" // Funo : Calcula e apresentar o volume de um recipiente cilindrico // Autor : // Data : 05/03/2013 // Seo de Declaraes var volume,altura,r:real inicio // Seo de Comandos escreva("Digite a altura do recipiente: ")

leia(altura) escreva("Digite o raio do recipiente: ") leia(r) volume<-(3.14159*(r*r)*altura) escreva("O volume ",volume) fimalgoritmo Teste de Mesa
Altura 10 Raio Volume 5 785.39

Exerccio 4 Fluxograma

Cdigo algoritmo "Exercicio 4" // Funo : Ler valores diferentes para as variaveis A e B, e efetuar a troca dos valores de forme que a variavel A passe a possuir o valor da variavel B // e B passe a ter o valor da variavel A // Autor : // Data : 05/03/2013 // Seo de Declaraes var a,b,c,d:real

inicio // Seo de Comandos escreva("Digite o valor de A: ") leia(a) escreva("Digite o valor de B: ") leia(b) c<-a d<-b a<-d b<-c escreval("Valor de A -> ",a) escreva("Valor de B -> ",b) fimalgoritmo Teste de Mesa
A 52 85 B 85 52

Exerccio 5 Fluxograma

Cdigo algoritmo "Exercicio5" var distancia,capacidade,consumo,media:real inicio // Seo de Comandos escreva("Digite o percurso: ") leia(distancia) escreva("Digite a capacidade do tanque: ") leia(capacidade) escreva("Digite o consumo mdio: ") leia(consumo) media:=(distancia/consumo) SE (media>capacidade) ENTAO escreval("Deve reabastecer!") FIMSE SE (media<capacidade) ENTAO escreval("No deve reabastecer!") FIMSE Fimalgoritmo Teste de Mesa
distancia capacidade consumo media 950 45 15 63.3

Exerccio 6 Fluxograma

Cdigo algoritmo "Exercicio6" var

maior,menor,i:inteiro cont:vetor[1..3] DE INTEIRO inicio menor:=999999999 cont[1]:=1 ENQUANTO cont[1]>0 FACA PARA i de 1 ate 3 FACA escreval("Digite o ",i," nmero: ") leia(cont[i]) SE cont[i]=0 ENTAO fimalgoritmo FIMSE SE (cont[i]>maior) ENTAO maior:=cont[i] FIMSE SE (cont[i]<menor) ENTAO menor:=cont[i] FIMSE FIMPARA escreval("O maior nmero ",maior) escreval("O menor nmero ",menor) escreval("") FIMENQUANTO Fimalgoritmo Teste de Mesa
i cont[1] cont[2] cont[3] maior menor 1 15 15 15 2 20 20 15 3 25 25 15

Exerccio 7 Fluxograma

Cdigo algoritmo "Troco" var N100,N50,N10,N1,Troco:inteiro Troco2,Ttotal,Total,Vpago:real inicio

escreval ("Digite o valor total da passagem: ") escreva ("R$ ") leia (Total) escreval ("Digite o valor pago pelo cliente: ") escreva ("R$ ") leia (Vpago) Ttotal:=(Vpago-Total) Troco2:=(Vpago-Total)*100 Troco:= Int(Troco2) SE (Troco)>=100 ENTAO N100<-(Troco\100) Troco:=(Troco%100) fimse SE (Troco<100) e (Troco >=50) ENTAO N50:=(Troco\50) Troco:=(Troco%50) fimse SE (Troco<50) e (Troco>=10) ENTAO N10:=(Troco\10) Troco:=(Troco%10) fimse SE (Troco<10) e (Troco>=1) ENTAO N1:=(Troco\1) Troco:=(Troco%1) fimse Escreval (" O troco de R$",Ttotal," foi dividido em:") Escreval (N100," moeda(s) de R$1 real.") Escreval (N50," moedas(s) de R$0,50 centavos.") Escreval (N10," moeda(s) de R$0,10 centavos.") Escreval (N1," moeda(s) de R$0,01 centavo.") Fimalgoritmo Teste de Mesa
Total 7.39 Vpago Ttotal 10 2.61 Troco2 Troco N100 261 261 N50 2 1 N10 1 N1 1

Exerccio 8 Fluxograma

Cdigo algoritmo "Exercicio8" var ms,km:real inicio // Seo de Comandos escreva("Digite a velocidade em m/s (metros por segundo): ") leia(ms) km:=(ms*3.6) escreval("A velocidade de",km," Km/h.") fimalgoritmo Teste de Mesa

ms 35

km 126