Vous êtes sur la page 1sur 2

ESTRUCTURAS REPETITIVAS Las computadoras estan especialmente diseadas para todas aquellas aplicaciones en las cuales una operacin

o conjunto de ellas deben repetirse muchas veces. Un tipo muy importante de estructura es el algoritmo necesario para repetir una o varias acciones un numero determinado de veces. Un programa que procesa las transacciones de los clientes de un banco puede repetir la misma secuencia de mensajes al usuario e instrucciones de lectura hasta que ya se termine la jornada de atencion bancaria. Las estructuras que repiten una secuencia de instrucciones un numero determinado de veces se denominan bucles, y se llama iteraccion al hecho de repetir la ejecucion de una secuencia de acciones. El CICLO MIENTRAS Ejecuta un bloque de acciones mientras que una condicin dada se cumpla, es decir, cuando la condicin se evala y da como un resultado verdadero. La condicin es evaluada antes de ejecutar el bloque de acciones y si la condicin no se cumple, el bloque no se ejecuta, y se dirije a la instruccin siguiente al Fin_Mientras. De esta manera es que el nmero de repeticiones del bloque de acciones sea cero, pues, si la condicin la primera vez evala a falso, el bloque no ser ejecutado ni una vez. La forma general del ciclo Mientras es la siguiente: mientras (condicin) hacer <bloque de instrucciones> fin_mientras Donde, (condicin) es la condicin que determina si el bloque de acciones<bloque>es ejecutado o no. Si la condicin evala a verdadero el bloque es ejecutado y si evala a falso no es ejecutado. Despus de ejecutar el bloque de acciones se vuelve a evaluar la condicin. Ejemplo : Imprimir los numeros naturales enteros del 1 al 10. clase Numeros Metodo Principal entero contador=1 mientras (contador <=10) hacer flujo.imprimir(contador) contador = contador + 1 // incrementamos en 1 al contador fin_mientras Fin_Metodo Fin_clase

Terminacion de ciclos con datos de entrada

Si un algoritmo est leyendo una lista de valores (tipo cadena o numricos) con un ciclo mientras, se debe incluir algun tipo de mecanismo para terminar el ciclo o bucle. Existen cuatro mtodos tipicos para terminar un bucle de entrada: 1. 2. 3. 4. Preguntar antes de la iteracin. Encabezar la lista de datos con su tamao. Finalizar la lista con un valor de entrada (dato centinela). Agotar los datos de entrada (fin de archivo).

El primer mtodo simplemente solicita con un mensaje al usuario si existen ms entradas. Ejemplo: clase Ciclo_Tipo_1 /* Algoritmo que lee y suma un conjunto de datos numricos, hasta que el usuario indique que no hay mas datos. */ Metodo Principal entero Suma = 0 entero Numero = 0 cadena Respuesta = flujo.imprimir(Desea ingresar un numero? S/N) Respuesta = flujo.leer() mientras (Respuesta = s) o (Respuesta = S) hacer flujo.imprimir(Digite un Numero: ) Numero = flujo.leer() Suma = Suma + Numero flujo.imprimir(Hay mas numeros? S/N) Respuesta = flujo.leer() fin_mientras flujo.imprimir(La suma de los numeros leidos es: + Suma) fin metodo fin clase

Este mtodo a veces es aceptable y es muy til en ciertas ocasiones, pero suele ser tedioso para conjuntos de grandes datos; en este caso es preferible incluir una seal de fin de datos (Mtodo 3).