Vous êtes sur la page 1sur 12

#HDLC est la mthode dencapsulation par dfaut utilise par les priphriques Cisco sur des lignes srie

synchrones.
!! Passez en mode de configuration dinterface de linterface srie. Router(config-if)#encapsulation hdlc

#La sortie renvoye de cette commande indique ltat des canaux de linterface srie et signale la prsence ou labsence dun cble.
Router #show controllers serial 0/0/0

PROTOCOLE PPP
#pour activer lencapsulation PPP sur interface serial0/0/0
Router#configure terminal Router(config)#interface serial 0/0/0 Router(config-if)#encapsulation ppp

#pour configurer la compression sur PPP aprs lavoir activ il faut choisir lune des 2 options de la commande soit predictor ou stac les deux spcifient un algorithme de compression
Router(config-if)#compress [predictor | stac]

# Pour garantir que la liaison est conforme aux exigences de qualit dfinies
Router(config-if)#ppp quality percentage (percentage spcifie le seuil de qualit de la liaison 1100) EX : Router(config-if)#ppp quality 80

# Pour effectuer un quilibrage de la charge sur plusieurs liaisons :


Router(config-if)#ppp multilink

Router#configure terminal Router(config)#interface serial 0/0 Router(config-if )#encapsulation ppp Router(config-if )#compress stac Router(config-if )#ppp quality 80 Router(config-if )#ppp multilink

Vrification dune configuration de lencapsulation PPP srie :


Show interfaces : affiche des statistiques sur toutes les interfaces configures Show interfaces serial : affiche les informations relatives une interface srie Debug ppp : dbogue le protocole ppp (2.3.4.1 pour voir les options de la commande) Undebog all : dsactive tous les crans de dbogage

# le protocole PPP utilise deux types dauthentification PAP et CHAP

configuration dun routeur R1 pour quil utilise lauthentification PAP avec R2 : (INTERFACE SERIAL0/0/0)
R1(config)#username R2 password cisco123
(R2 va se connecter avec le nom R2 et le mot de passe cisco123

R1(config)#interface s0/0/0 R1(config-if)#encapsulation ppp R1(config-if)#ppp authentication pap R1(config-if)#ppp pap sent-username R1 password cisco123 (Configurez le nom dutilisateur et le mot de passe qui seront envoys R2) R1(config-if)#end

REMARQUE :Repetez la configuration sur R2 pour que la liaison sera oprationnelle et utilisez la commande ppp pap sent-username R2 password cisco123 sur R2

configuration dun routeur R3 pour quil utilise lauthentification CHAP avec R2 : (INTERFACE SERIAL0/0/1)
R3(config)#username R2 password cisco123
(R2 va se connecter avec le nom R2 et le mot de passe cisco123

R3(config)#interface s0/0/1 R3(config-if)#encapsulation ppp R3(config-if)#ppp authentication chap

Remarque : le Protocol dauthentification PAP ne chiffre pas le mot de passe par contre dans le cas dutiliser le protocole dauthentification CHAP le mot de passe est chiffr

Protocole Frame Relay


Remarque : Pour quun routeur Cisco puisse transmettre des donnes par le protocole Frame Relay, la correspondance entre le DLCI local et ladresse de couche 3 de destination doit tre connue Notez Bien : lARP (Address Resolution Protocol) traduit les adresses de couche 3 en adresses de couche 2 LARP INVERSE (Invers Address Resolution Protocol) traduit les adresses d e couche 2 en adresses de couche 3 .Cest un protocole principalement utilis dans les rseaux Frame Relay et ATM

Configuration du protocol Frame Relay sur R1 :


R1 # configure terminal R1(config)#interface serial0/0/0 R1(config)#ip address 10.1.1.1 255.255.255.0 R1(config)#encapsulation frame-relay R1(config)#bandwidth 64 R1(config)#no shutdown (commande facultative pour spcifier la bande passante)

Configuration dun mappage statique sur R1 :


R1#configure terminal R1(config) # interface serial0/0/0 R1(config)#frame-relay map protocol address-protocol dlci broadcast [cisco | ietf ] Loption ietf : si vous vous connectez un routeur dune marque autre que Cisco. Remarque : broadcast pour appliquer la diffusion

Configuration du LMI sur R1 :


# LMI est essentiellement un mcanisme de test dactivit qui fournit des informations sur les connexions Frame Relay entre le routeur (ETTD) et le commutateur Frame Relay (DCE). R1(config)#interface serial0/0/0 R1(config-if)#frame-relay lmi-type [ cisco | ansi | q933 ]

R1#configure terminal R1(config)#interface s0/0/0 R1(config-if)#ip adress 10.1.1.1 255.255.255.0 R1(config-if)#encapsulation frame-relay
R1(config-if)#frame-relay map ip 10.1.1.2 102 broadcast cisco

R1(config-if)#no shutdown R1(config-if)# Frame-relay lmi-type ansi

Pour R2: R2(config-if)#frame-relay map ip 10.1.1.1 201 broadcast cisco #La modification du type dinterface en DCE indique au routeur denvoyer des messages de veille linterface de supervision locale et permet Frame Relay dacheminer des instructions appliquer.
R1(config-if)#frame-relay intf-type dce

#Configurez le routeur pour quil transfre le trafic entrant sur linterface srie 0/0/0 avec DLCI 102 vers linterface srie 0/0/0 avec un DLCI de sortie dfini sur 201.
R1(config-if)#frame-relay route 102 interface serial 0/0/1 201

configuration de sous-interfaces sur R1:


R1(config-if) #interface serial [Multipoint | point-to-point] R1(config-if) #frame-relay interface-dlci dlci-number Ex: R1(config-if) # interface serial0/0/0.102 point-to-point R1(config-if) #ip address 10.1.1.1 255.255.255.252 R1(config-if) #bandwidth 64 (prfixe 30)

R1(config-if) # frame-relay interface-dlci 102

Vrification du fonctionnement de Frame Relay :


R1#show interface serial 0/0/0 #vrifiez que Frame Relay fonctionne correctement R1#show frame-relay lmi #vrifier le fonctionnement de linterface LMI. #vrifier le fonctionnement du circuit virtuel permanent #pour afficher les entres de mappage actuelles, ainsi que Des informations sur les connexions R1#clear frame-relay inarp #Pour supprimer les mappages Frame Relay crs de faon dynamique laide de la rsolution dadresse inverse

R1# frame-relay pvc [interface interface] [dlci] EX : R1#frame-relay pvc 102 R1#show frame-relay map

Dpannage de configuration Frame Relay :


R1#debug frame-relay lmi #pour dterminer si le routeur et le commutateur Frame Relay envoient et reoivent correctement les paquets LMI

Scurit du rseau
Configuration du mot de passe :
1) R1(config)# username Student password cisco123 R1(config)# do show run | include username username Student password 0 cisco123 #le 0 indique que le mot de passe nest pas masqu 2) R1(config)# service password-encryption R1(config)# do show run | include username username Student password 7 03075218050061 #le 7 indique un Chiffrement simple appel mthode de type 7 masque le mot de passe laide dun algorithme simple 3) R1(config)# username Student secret cisco123 R1(config)# do show run | include username

username Student secret 5 $1$z245$lVSTJzuYgdQDJiacwP2Tv/

#le 5 indique un

Chiffrement complexe appel mthode de type 5 masque le mot de passe . Se base sur le hachage MD5

Dfinir la longueur minimale du mot de pass :


R1(config)# security passwords min-length 10 #10 indique le nombre minimal des Caractres

Empcher les ouvertures de sessions sur des lignes inutilises :


R1(config) # line aux 0 R1(config-line) # password cisco R1(config-line) # login R1(config-line) # exit

Contrle des accs VTY entrant :


R1(config) # line vty 0 4 R1(config-line) # no transport input #pour ne pa accepter des connexions distance

R1(config-line) # transport input ssh telnet #accepter que des connexions ssh et telnet R1(config-line) # exit

Configuration de scurit VTY supplmentaires :


R1(config) # line vty 0 4 R1(config-line) # exec-timeout 3 R1(config-line) # exit R1(config) # service tcp-keepalives-in #pour lactivation du test dactivit TCP sur les connexions entrantes #pour configurer un dlais dattente

Configuration de la scurit SSH :


Router (config)# hosname R1 R1 (config)# ip domain-name cisco.com #dfinition du nom de domaine pour activer ssh

R1 (config)# crypto key generate rsa #gnrer une cl pour chiffrer le trafic de gestion SSH R1(config)# username Student secret cisco R1(config)# line vty 0 4 R1(config-line)# no transport input R1(config-line)# transport input ssh R1(config-line)# login local R1(config)# exit R1(config)# ip ssh timeout 15 #activer le dlai dattente (15 secondes) #dfinir que cest un utilisateur local

R1(config)# ip ssh authentication-retries 2 #actives les tentatives dauthentification (2 fois )

Configuration de RIPv2 avec authentification du protocole de routage :


R1(config)# router rip R1(config-router)#version 2 R1(config-router)# passive-interface default # dsactive les annonces de routage Sur toutes les interfaces R1(config-router)# no passive-interface s0/0/0 # active lenvoi et la rception de mises jour RIP sur linterface S0/0/0. R1(config-router)#exit R1(config)# key chain RIP_KEY R1(config-keychain)#key 1 R1(config-keychain-key)#key-string cisco R1(config)#int s0/0/0 # crer une chane de cls appele RIP_KEY . Key 1 est configure pour contenir une chane de caractres appele cisco pour empcher la rception non autorise de mises jour RIP

R1(config-if)#ip rip authentication mode md5 R1(config-if)#ip rip authentication key-chain RIP_KEY

Configuration de EIGRP avec authentification du protocole de routage :

R1(config)# router eigrp R1(config-router)# passive-interface default R1(config-router)# no passive-interface s0/0/0 R1(config-router)#exit R1(config)# key chain EIGRP_KEY R1(config-keychain)#key 1 R1(config-keychain-key)#key-string cisco R1(config-keychain-key)#exit R1(config-keychain)#exit R1(config)#int s0/0/0 R1(config-if)#ip authentication mode eigrp 1md5 R1(config-if)#ip authentication key-chain eigrp 1 EIGRP_KEY

Configuration dOSPF avec authentification du protocole de routage


R1(config)#interface s0/0/0 R1(config-if)#ip ospf message-digest-key 1 md5 cisco R1(config-if)#ip ospf authentication [message-digest | null] R1(config-if)#exit R1(config)#router ospf 1 R1(config-router)# area 1 authentication message-digest [mot-de-passe] R1(config-router)#exit R1(config)#exit R1#auto secure #pour dsactiver les processus et les services non essentiels du systme

Configuration dun routeur pour lutilisation dun SDM :


R1 #configure terminal R1(config)#ip http server R1(config)#ip http secure-server R1(config)#ip http authentication local #activer le serveur HTTP #activer le serveur HTTPS #Crez un compte utilisateur avec niveau de privilge 15 R1(config)#line vty 0 4
R1(config-line)#privilege level 15

R1(config)#usename student privilege 15 secret cisco

#activer niveau de privilge de 15 #configurer une session locale #Configurer SSH et Telnet

R1(config-line)#login local R1(config-line)#transport input telnet ssh R1(config-line)#exit

R1#show file system

#affiche la liste de tous les systmes de fichiers dun routeur Cisco afficher le contenu du NVRAM #changer de rpertoire et accder au nvram\ #affiche le rpertoire courant ici pour vrifier que cest nvram\ #affiche le contenu de la mmoire vive non volatile

R1#cd nvram : R1#pwd R1#dir

Gestion des fichiers de configuration :


Router #copy source-url : destination-url : R2# copy running-config startup-config # Copie de la configuration courante de la RAM la configuration de demarrage NVRAM R1# copy running-config tftp: R1# copy system:running-config tftp: # Copie de la configuration courante de la RAM un emplacement distant

R1#copy system:running-config nvram:startup-config

R1# copy tftp: running-config R1# copy tftp: system:running-config R1# copy tftp: startup-config R1# copy tftp: nvram:startup-config

#Copie de la configuration dune source distante la configuration courante #Copie de la configuration dune source distante la configuration de dmarrage

Sauvegarde de limage logicielle Cisco IOS : (serveur TFTP : 192.168.20.254/24)


R1#ping 192.168.20.254 R1#show flash

#verifier si le serveur TFTP est accessible #pour connatre la taille du fichier image #copier le fichier image du system sur le serveur TFTP du

R1#copy flash: tftp: rseau

Remarque : la derrnire commande demande dentrer ladresse IP de lhte distant (192.168.20.254) , ainsi que le nom des fichiers image du systme source et du systme de destination

Mise niveau des images du logiciel Cisco IOS :


R1#copy tftp: flash: #pour tlcharger la nouvelle image depuis le serveur TFTP

Remarque : Par dfaut, la squence de dmarrage du routeur charge la premire image Cisco IOS rpertorie dans la mmoire flash. Pour faire en sorte que le routeur charge la nouvelle image entrez la commande suivante : R2(config)#boot system flash c1841-ipbasek9-mz.124-12.bin c1841-ipbasek9-mz.124-12.bin : nom de fichier dans le logiciel Cisco IOS

Configuration pour que R1 doit rcuprer limage IOS perdu et prcdemment copie sur le serveur TFTP :
1) Connecter le PC de ladministrateur au port console du R1 2) Connectez le serveur TFTP au premier port Ethernet du routeur et le configurer avec ladresse statique 192.168.1.1/24 3) Dmarrer R1 et dfinir les variables ROMmon : Rommon1>IP_ADDRESS=192.168.1.2 Rommon2>IP_SUBNET_MASK=255.255.255.0 Rommon3>DEFAULT_GATEWAY=192.168.1.1 Rommon4>TFTP_SERVER=192.168.1.1 Rommon5>TFTP_FILE=c1841-ipbase-mz.123-14.T7.bin Rommon6>tftpdnld

Rcupration du mot de passe dun routeur :


1) Connectez-vous au port de console 2) R1#show version <show command output omitted> Configuration register is 0x2102 teignez le routeur plus rallumez-le laide de son interrupteur Dans un dlai de 60 secondes aprs la mise sous tension, appuyez sur la touche Pause du clavier du terminal pour activer le mode ROMmon du routeur Rommon1>confreg 0x2102 Rommon2>reset Tapez no en rponse chaque question Router#copy startup-config running-config Router#configure terminal Router(config)#enable secret cisco Router(config)#interface serial0/0/0 Router(config-if)#no shutdown Router(config-if)#exit Router(config)#config-register 0x2102 Router(config)#end Router(config)#copy running-config startup-config

3) 4) 5) 6) 7) 8)

Vous aimerez peut-être aussi