Vous êtes sur la page 1sur 8

---------R1-------------class-map match-all vlan30

match vlan 30
class-map match-all vlan20
match vlan 20
policy-map abc
policy-map xyz
class xyz
class vlan20
class vlan30

interface FastEthernet0/0
description vlan Management
ip address 192.168.0.101 255.255.255.0
ip nbar protocol-discovery
load-interval 30
duplex full
speed 100
service-policy input abc
service-policy output xyz
interface FastEthernet0/0.20
encapsulation dot1Q 20
ip address 10.20.0.1 255.255.255.0
interface FastEthernet0/0.30
encapsulation dot1Q 30
ip address 10.30.0.1 255.255.255.0
---------R2-------------interface FastEthernet0/0.20
encapsulation dot1Q 20
ip address 10.20.0.2 255.255.255.0
ip nbar protocol-discovery
---------R3-------------interface FastEthernet0/0.30
encapsulation dot1Q 30
ip address 10.30.0.3 255.255.255.0
ip nbar protocol-discovery
---------CAT2950--------interface FastEthernet0/1
switchport mode trunk
load-interval 30
speed 100
duplex full
spanning-tree portfast
!
interface FastEthernet0/2
switchport mode trunk
speed 100
duplex full
spanning-tree portfast
!
interface FastEthernet0/3

switchport mode trunk


speed 100
duplex full
spanning-tree portfast
-------------------R1---------------------------------------------FastEthernet0/0 is up, line protocol is up
Hardware is MV96340 Ethernet, address is 0015.622e.ab40 (bia 0015.622e.ab40)
Description: vlan Management
Internet address is 192.168.0.101/24
MTU 1500 bytes, BW 100000 Kbit/sec, DLY 100 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation 802.1Q Virtual LAN, Vlan ID 1., loopback not set
Keepalive set (10 sec)
Full-duplex, 100Mb/s, 100BaseTX/FX
ARP type: ARPA, ARP Timeout 04:00:00
Last input 00:00:00, output 00:00:00, output hang never
Last clearing of "show interface" counters 5d01h
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
30 second input rate 379000 bits/sec, 135 packets/sec
30 second output rate 378000 bits/sec, 134 packets/sec
---------R1#show policy-map int f0/0
FastEthernet0/0
Service-policy input: abc
Class-map: class-default (match-any)
73053 packets, 25731072 bytes
30 second offered rate 378000 bps, drop rate 0 bps
Match: any
Service-policy output: xyz
Class-map: xyz (match-all)
0 packets, 0 bytes
30 second offered rate 0 bps
Match: none
Class-map: vlan20 (match-all)
15251 packets, 5562154 bytes
30 second offered rate 187000 bps
Match: vlan 20
Class-map: vlan30 (match-all)
14982 packets, 5464276 bytes
30 second offered rate 187000 bps
Match: vlan 30
Class-map: class-default (match-any)
64427 packets, 22043470 bytes
30 second offered rate 4000 bps, drop rate 0 bps
Match: any

----------------R2#sh ip nbar protocol-discovery


FastEthernet0/0.20
Last clearing of "show ip nbar protocol-discovery" counters 00:21:38

Input
Output
---------Protocol
Packet Count
Packet Count
Byte Count
Byte Count
30sec Bit Rate (bps) 30sec Bit Rate (bps)
30sec Max Bit Rate (bps) 30sec Max Bit Rate (bps)
------------------------ ------------------------ -----------------------dns
83014
0
30383124
0
187000
0
187000
0
------------------R3#sh ip nbar proto
FastEthernet0/0.30
Last clearing of "show ip nbar protocol-discovery" counters 00:23:35

Input
Output
---------Protocol
Packet Count
Packet Count
Byte Count
Byte Count
30sec Bit Rate (bps) 30sec Bit Rate (bps)
30sec Max Bit Rate (bps) 30sec Max Bit Rate (bps)
------------------------ ------------------------ -----------------------snmp
90502
0
33123732
0
187000
0
187000
0

-----------------NESTED POLICY 100Kbps sur R1-------------------------------policy-map xyz


class xyz
class vlan20
class vlan30
policy-map parent
class class-default
police 100000

service-policy xyz
interface FastEthernet0/0
service-policy output parent
------------------------------------R1---------------------------------------------R1#sh policy-map interface f0/0
FastEthernet0/0
Service-policy input: abc
Class-map: class-default (match-any)
251361 packets, 88557136 bytes
30 second offered rate 378000 bps, drop rate 0 bps
Match: any
Service-policy output: parent
Class-map: class-default (match-any)
60653 packets, 21204239 bytes
30 second offered rate 378000 bps, drop rate 277000 bps
Match: any
police:
cir 100000 bps, bc 3125 bytes
conformed 16634 packets, 5605226 bytes; actions:
transmit
exceeded 42802 packets, 15510066 bytes; actions:
drop
conformed 99000 bps, exceed 277000 bps
------------------------------------R2---------------------------------------------R2#sh int f0/0
FastEthernet0/0 is up, line protocol is up
Hardware is MV96340 Ethernet, address is 0015.622e.6558 (bia 0015.622e.6558)
Internet address is 192.168.0.102/24
MTU 1500 bytes, BW 100000 Kbit/sec, DLY 100 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation 802.1Q Virtual LAN, Vlan ID 1., loopback not set
Keepalive set (10 sec)
Full-duplex, 100Mb/s, 100BaseTX/FX
ARP type: ARPA, ARP Timeout 04:00:00
Last input 00:00:00, output 00:00:00, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
30 second input rate 55000 bits/sec, 21 packets/sec
30 second output rate 1000 bits/sec, 3 packets/sec
------------------------------------R3---------------------------------------------FastEthernet0/0 is up, line protocol is up
Hardware is MV96340 Ethernet, address is 0015.2b97.edc0 (bia 0015.2b97.edc0)
Internet address is 192.168.0.103/24
MTU 1500 bytes, BW 100000 Kbit/sec, DLY 100 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation 802.1Q Virtual LAN, Vlan ID 1., loopback not set
Keepalive set (10 sec)

Full-duplex, 100Mb/s, 100BaseTX/FX


ARP type: ARPA, ARP Timeout 04:00:00
Last input 00:00:00, output 00:00:00, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
30 second input rate 43000 bits/sec, 17 packets/sec
---------------------------------------------------------------------------------------remarque:
SJO-R1(config)#policy-map xyz
SJO-R1(config-pmap)# class vlan20
SJO-R1(config-pmap-c)# bandwidth percent 30
Cannot attach queuing-based child policy to a non-queuing based class
pour qu'on puisse faire du queuing dans child policy, il faut un parametre bandwith ou shape ou aucun
des deux mais pas le parametre police.
--------------------------------------------------------------------------------------policy-map parent
class ANY
bandwidth 200
shape peak 100000
service-policy xyz
policy-map xyz
class vlan20
bandwidth percent 30
class vlan30
bandwidth percent 30
-----------------------------------------------------------------------------------------SJO-R1#show policy-map interface f0/0
FastEthernet0/0
Service-policy input: abc
Class-map: class-default (match-any)
417509 packets, 146814285 bytes
30 second offered rate 378000 bps, drop rate 0 bps
Match: any
Service-policy output: parent
Class-map: ANY (match-all)
61564 packets, 21292084 bytes
30 second offered rate 383000 bps, drop rate 179000 bps
Match: any
Queueing
queue limit 64 packets
(queue depth/total drops/no-buffer drops) 64/15749/0
(pkts output/bytes output) 22087/7508716
shape (peak) cir 100000, bc 400, be 400
target shape rate 200000
----------------------------------------------------------------------------------

R3#sh int f0/0


FastEthernet0/0 is up, line protocol is up
Hardware is MV96340 Ethernet, address is 0015.2b97.edc0 (bia 0015.2b97.edc0)
Internet address is 192.168.0.103/24
MTU 1500 bytes, BW 100000 Kbit/sec, DLY 100 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation 802.1Q Virtual LAN, Vlan ID 1., loopback not set
Keepalive set (10 sec)
Full-duplex, 100Mb/s, 100BaseTX/FX
ARP type: ARPA, ARP Timeout 04:00:00
Last input 00:00:00, output 00:00:00, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
30 second input rate 100000 bits/sec, 37 packets/sec
-----------------------------------------------------------------------------------R2#sh int f0/0
FastEthernet0/0 is up, line protocol is up
Hardware is MV96340 Ethernet, address is 0015.622e.6558 (bia 0015.622e.6558)
Internet address is 192.168.0.102/24
MTU 1500 bytes, BW 100000 Kbit/sec, DLY 100 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation 802.1Q Virtual LAN, Vlan ID 1., loopback not set
Keepalive set (10 sec)
Full-duplex, 100Mb/s, 100BaseTX/FX
ARP type: ARPA, ARP Timeout 04:00:00
Last input 00:00:00, output 00:00:00, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
30 second input rate 100000 bits/sec, 36 packets/sec
------------------------------------policy-map parent
class ANY
shape average 100000
service-policy xyz
-----------------------------------SJO-R1#sh policy-map interface f0/0
FastEthernet0/0
Service-policy input: abc
Class-map: class-default (match-any)
491381 packets, 172440805 bytes
30 second offered rate 380000 bps, drop rate 0 bps
Match: any
Service-policy output: parent
Class-map: ANY (match-all)
136354 packets, 47188091 bytes
30 second offered rate 384000 bps, drop rate 280000 bps

Match: any
Queueing
queue limit 64 packets
(queue depth/total drops/no-buffer drops) 64/29611/0
(pkts output/bytes output) 20576/6673124
shape (average) cir 100000, bc 400, be 400
target shape rate 100000
-------------La classe prioritaire n'est pas droppe si depassement de la BW--------policy-map parent
class ANY
priority 100
SJO-R1#show policy-map int f0/0
FastEthernet0/0
Service-policy input: abc
Class-map: class-default (match-any)
18261 packets, 6439019 bytes
30 second offered rate 378000 bps, drop rate 0 bps
Match: any
Service-policy output: parent
queue stats for all priority classes:
Queueing
queue limit 64 packets
(queue depth/total drops/no-buffer drops) 0/0/0
(pkts output/bytes output) 18253/6439036
Class-map: ANY (match-all)
18450 packets, 6453071 bytes
30 second offered rate 379000 bps, drop rate 0 bps
Match: any
Priority: 100 kbps, burst bytes 2500, b/w exceed drops: 0

Vous aimerez peut-être aussi