Vous êtes sur la page 1sur 8

http://publib.boulder.ibm.com/infocenter/systems/index.jsp? topic=/com.ibm.aix.cmds/doc/aixcmds6/vmo.

htm

What is mean by mount the CD ROM? *********************************************************************** *

* How will increase the File systems? smit lv, set charateristics, change- insure that the maximum number of logical partitions times the size of the physical partitions exceeds the size that you want to change the file system size to.lsvg vgname will give you the size of the physical partition. Then - smitty jfs - change/show - the numnber of units is in 512 byte blocks - so this number should be your final size of the file system in bytes divided by 512. you will need to do some calculations (free PPs, size of a PP, etc) to calculate the size you need. ??? not a lot of math though: before 5.2, you want to add 1GB to a file system take 512 (block size) 512 times 2 ==> 2blocks 1K 512 times 2048 ==> 2048blocks is 1M 512 times 2048x1024 ==> 20971525blocks is 1GB in chfs command specify chfs -a size=+20971525 /file/system/name or specify +20971525 in SMIT panel to add 1GB from 5.2 onwards chfs -asize=+1G /file/system/name or use appropriate SMIT fields (value=1 unitsize=gigabytes) It still stands that the underlying LV needs to be accomodating (max number of PPs) but chfs will tell you if this isn't so. You may need to do some more math to get that limit high enough or simply start by doubling the current value (smit chlv)

*********************************************************************** * *How will you create the file systems?


$ mkfs: destroy /dev/hdisk1 (y)? y logform: Format inline log for <y>?y File system created successfully. 142077508 kilobytes total disk space. Device /dev/hdisk1: Standard empty file system Size: 284155016 512-byte (DEVBLKSIZE) blocks $ mount /dev/hdisk1 /data

Disk driver configuration Utility smit disk Add a Volumegroup smit vg Create new filesystems smit fs Create a mount point mkdir /disk1 Mount filesystems mount /dev/hd0/? /disk1 Show mounted Filesystems lsfs Backup Volumegroups smit vgbackup Install packages smitty install_latest Upgrade a package installp -a Create an installation server for network installation nimconfig Set up a client for network installation nim -o bos_inst

*Which command will use list the paging space? VMO ( Virtual Memory Manager)
Data is essentially held in pages of 4096b, and a page in RAM is accessible by the CPU, if the page is on disk the CPU can't access it directly. A page fault occurs when a wanted page address does not translate to a real memory address. At this point the Virtual Memory Manager (VMM)knows it needs to get data from disk and place it in RAM - it therefore checks to see that there is space in RAM in which to out this data.

If there's enough room, VMM checks to see if the wanted page has been used previously by this process: - if not, an "initial page fault", VMM allocates _two_ pages for the data; one in RAM and the other on a backing page on disk where it can go if it has to be temporarily removed from RAM. This is known as "late page space allocation". - if it has, a "repage fault" I/O is scheduled to bring the data back from disk and into RAM - the act of resolving this repage fault is called a "page-in" (the process that is waiting for this to happen is in a "page wait state"). So what happens if there's not enough room in RAM to put the page? Well the page stealer is there to ensure that there is a supply of free RAM pages available for an initial page fault. If the number of free RAM pages drops below a specified value then the page stealer will try and get some pages back. It keeps on stealing pages until it reaches an upper limit. So how does it decide which pages to steal? The page stealer will select the least recently used, or LRU, pages. If the page has been modified in RAM it's classed as a dirty page and is put to a backing store (either page space or a filesystem); if it's clean (the copy in RAM matches the copy in page space) then the RAM page is purged. Note that the page space is used for non-persistent or working pages, and the filesystem is used for persistent or file pages. There is, of course, a basic assumption here that all stale pages are treated equally, i.e. whether it's a file- or nonfile- page makes no difference to the page stealer. However this is not the case. Increased paging activity makes VMM act upon the different types of (stale) pages in a different manner. When the number of [stale] file pages exceed a number - set by the maxperm threshold - the page stealer will steal only file pages. If the number of stale file pages is below maxperm (but above the set minperm threshold) then two other considerations come into play. The VMM checks the repage rates of both file and nonfile pages, and will steal file pages if the file page repage rate is higher than the repage rate for nonfiles. If this not the case then both types of pages are treated as equal victims. PERFORMANCE HITS / ACTUAL DISK I/O... To understand the performance hit of the paging figures that you come across, you need to realise that page faults do NOT (necessarily) result in disk activity. Remember from above that only the repage fault - the act of bringing back previously used data into memory - causes disk I/O to be scheduled. Page out I/O only occurs when a page is stolen by the page stealer AND is marked as 'dirty'. This only happens when there is a shortage of free RAM pages. Hence the page-out figure can be an indicator of how memory constrained the system is. The vmstat command is only of limited use as it just reports activity concerned with page space (and not paging to/from filesystem space).

If the system consistently appears to hover around the minperm value (the "fre" column in vmstat) then it does not follow that the system is memory constrained consider the scenario where an initial page fault is resolved by purging a clean, but stale, page. In this there is paging activity but no corresponding I/O. System performance may be improved by reducing the amount of RAM that file pages occupy - this ensures that working pages are not continually being pushed out to make way for file pages. This can be achieved through the use of the vmtune command (/usr/samples/kernel) and DECREASING values for minperm and maxperm. PAGING SPACE So how much page space do I need? For systems that have up to 256MB of real memory, use the well known formula... page_space = 2 x real_memory ...for those systems with more than 256MB of real memory use... page_space = 512MB + (real_memory - 256MB) * 1.25 The following should also be adhered to where possible: 1. configure just one paging space per disk 2. use between 2 and 6 paging spaces in a medium size system 3. configure the paging spaces on each disk to be the same size

*********************************************************************** * How will increase the paging space?

Hi all - I'm having some memory issues where I'm running out of paging space. I'm not sure if I need to add more ram to the server. Or if I can get by, by increasing the paging space. I'm hoping I can increase the paging space. I know I can do this using SMIT. But I'm not sure if I need to add allocate some space to a logical volume group first. I have a lot of unallocated free space that can be added if need be. Or if I can simply plug in a number using smitty mkps. I have a 1 gb ram module in the system, but it looks like the system only recognizes 900 mb based on the number the bootinfo -r command returns. And it looks like I've got 1.5 gb of paging space. I have a pair of 72 gb drives that are mirrored. Based on the output of the commands I've ran below, what can I safely increase my paging space to, and what number do I need to plug in via smitty mkps? Or do I need to add ram the system and then increase the paging space? Thanks # lsvg -l rootvg rootvg: LV NAME TYPE hd5 boot 1

LPs PPs PVs LV STATE 2 2 closed/syncd N/A

MOUNT POINT

hd6 hd8 hd4 hd2 hd9var hd3 hd1 hd10opt fwdump orm exportlv lv00 loglv00

paging 12 24 2 open/syncd N/A jfslog 1 2 2 open/syncd N/A jfs 2 4 2 open/syncd / jfs 29 58 2 open/syncd /usr jfs 4 8 2 open/syncd /var jfs 13 26 2 open/syncd /tmp jfs 10 20 2 open/syncd /home jfs 6 12 2 open/syncd /opt jfs 2 4 2 open/syncd /var/adm/ras/platf jfs2 80 80 1 open/syncd /export jfs 42 42 1 closed/syncd N/A jfs2log 1 1 1 open/syncd N/A

# lsvg rootvg VOLUME GROUP: rootvg VG IDENTIFIER: 00c011fa00004c000000010 340b7d7dd VG STATE: active PP SIZE: 128 megabyte(s) VG PERMISSION: read/write TOTAL PPs: 1092 (139776 megabytes) MAX LVs: 256 FREE PPs: 809 (103552 megabytes) LVs: 13 USED PPs: 283 (36224 megabytes) OPEN LVs: 11 QUORUM: 1 TOTAL PVs: 2 VG DESCRIPTORS: 3 STALE PVs: 0 STALE PPs: 0 ACTIVE PVs: 2 AUTO ON: yes MAX PPs per PV: 1016 MAX PVs: 32 LTG size: 128 kilobyte(s) AUTO SYNC: no HOT SPARE: no BB POLICY: relocatable # bootinfo -r 901120 # lsattr -El sys0 | grep realmem realmem 901120 Amount of usable physical memory in Kbytes False # lsps -a Page Space Physical Volume Volume Group Size %Used Active Auto Type hd6 hdisk3 rootvg 1536MB 86 yes yes lv # lsps -s Total Paging Space Percent Used 1536MB 86% #

*********************************************************************** * How will you stop the services?


stopsrc -g nfs this command stops all nfs services. problem is if the system restart these services will start automaticaly. i want to stop them permenantly . like wht i did with ftp i just stop the service and after tht put # in /etc/inetd.conf against ftp. Same i want for nfs but i dont know where to put # as i dont know nfs location. can somebody guide me for tht. i know these services are in /etc/rc.nfs. but still i dont know where to mark an entry of #.

*********************************************************************** * How will you start the services?


IIRC if there is no file /etc/exports then nfs will not start at reboot. startsrc -g group_of_daemons startsrc -s subsystem_daemon Eg. startsrc -g spooler startsrc -s lpd

List the Services? What are the processes are running on AIX box? There are four CPU is running in single system? How will you stop single CPU? How will you find the VG information? There are two maintenance levels, how will you check particular maintenance level package? How will you find the operating system level? What is mean by Maintenance level? Tell me about Tape library? How will you add new PV in existing VG? What is mean by cfgmgr commands? How will check the installed softwares? How will you upgrade software (eg.JAVA) existing to new? Tell me about How will you mirroring VG? I want mirror particular file systems black? How will you do that? What is mean by lsvg vgname? Any other way to find the vg information? What is mean by mirror S m? Explain both S m? What is difference between JFS and JFS2? How will you find the vg space? How will you calculate the space? How will you remove the paging space? How will you change the paging space? How will you turn on and turn off paging space? What is mean by lscfg? Explain it? I want to remove the particular tape? How will you do that?

I want to kill particular process? Tell me about -9? How will you backup the rootvg? Which command will use to restart the system? What is mean by F? How will you install the software? How will you check the installed software? Which command will use the removing PV? I want to vary off particular VG? What is mean by lsdev? Explain lsdev C & lsdev P? Tell me your AIX model? Explain? How many aix box you are using? How will you assign automation? How will you check performance monitoring? What is mean by network installation? How will you install the fresh OS in network installation? How will you find the installed software versions? Day to day activities? What are the types of VGs? Tell me about BIG VG? How will check the Run level? How will you identify the print queue? How will you delete particular print job? What is difference between V5.3 & V5.3L?

TSM What is difference between V5.2 & V5.3? What is main advantage of V5.3? How will you configure the DS 4200? You are implementing DS 4200 what are the input you will get from Customer? Tell me brief explanation about your Disk storage? Tell me about doli environment? What is mean by device drive? How will you define device drive? Tell me about Tape Library? What is mean by LAN free backup? How will you stop & start the TSM server? Tell about TSM path in AIX? How will you take the DB backup? Tell me about TDP? Schedules not run? What is the reason?

How will define scheduling? Explain? How will you associate node? Explain? How will you start the server? What is mean by dsmadmc? Where will you define the schedule? Define Tape Library? The data not backup? Tell me brief explanation?

Vous aimerez peut-être aussi