Vous êtes sur la page 1sur 0

Auteur : O.

J accomard 2005


















Les ATELIERS TICE




Prise en main du tableur Excel







Technologies de lInformation et
de la Communication pour
lEnseignement
2/28 Formation Excel 2003

2/28
2005 O.J accomard

Table des matires


Table des matires................................................................................................................................................... 2

I) Introduction.............................................................................................................................................. 3

II) La mise en forme de la feuille la sauvegarde du classeur...................................................................... 4

III) Les premires formules............................................................................................................................ 9

IV) Les formules de la feuille de moyenne trimestrielle............................................................................... 12

V) La protection dune feuille le contrle de la saisie des donnes.......................................................... 16

VI) Les feuilles : copiage, suppression, insertion..................................................................................... 18

VI) Les feuilles : formules sur plusieurs feuilles. ......................................................................................... 19

VII) Les graphiques........................................................................................................................................ 22

VIII) Limpression.......................................................................................................................................... 23

IX) Les macrocommandes............................................................................................................................ 25












2005 Formation Excel 2003 3/28

2005 O.J accomard
3/28

Extrmement utile !

I) Introduction
Le but pdagogique de ce T.P. est dapprendre les bases du tableur Excel.
Le but technique sera de faire un classeur capable de calculer les moyennes des lves.
Un petit point mathmatique, que vous pouvez passer si vous tes allergique, sur le calcul de
moyennes :
Une note sur 10 coefficient 3 revient une note sur 20 coefficient 1,5. Plus gnralement une
note sur n coefficient c revient une note sur 20 coefficient cn/20.
La moyenne pondre par des coefficients est donc :
[(note1/sur_combien120coefficient1sur_combien1/20)+
(note2/sur_combien220coefficient2sur_combien2/20)+
+(noten/sur_combienn20coefficientnsur_combienn/20)]/[coefficient1sur_combien1/20
+coefficient2sur_combien2/20+ +coefficientnsur_combienn/20].
On peut simplifier cette formule, notamment le numrateur, et on obtient :
note1coefficient1+note2coefficient2+ +notencoefficientn

coefficient1sur_combien1
20
+
coefficient2sur_combien2
20
+ +
coefficientnsur_combienn
20
.
Cest cette formule qui sera utilise.
De tels programmes existent dj. Lintrt, ici, est de pouvoir avoir des moyennes par catgorie de
devoir, ce qui permet une valuation plus fine des lves.

Une dernire remarque avant de commencer : le clavier est trs souvent plus rapide que la souris. Il est
donc rentable de connatre la combinaison de touches qui, sur le clavier, permet deffectuer certaines
manipulations standards :
Pour mmoriser dans lordinateur ce que vous avez slectionnez, appuyez sur la touche Ctrl,
maintenez-la enfonce, et appuyez sur la touche C.
Pour enlever ce qui est slectionn, tout en le gardant dans la mmoire de lordinateur,
appuyez sur la touche Ctrl, maintenez-la enfonce, et appuyez sur la touche X.
Pour restituer lendroit du curseur ce que lordinateur a mmoris, appuyez sur la touche
Ctrl, maintenez-la enfonce, et appuyez sur la touche V.
Pour slectionner un document entier, appuyez sur la touche Ctrl, maintenez-la enfonce, et
appuyez sur la touche A.
Pour annuler une fausse manuvre, appuyez sur la touche Ctrl, maintenez-la enfonce, et
appuyez sur la touche Z.
Pour refaire la manuvre annule tord, appuyez sur la touche Ctrl, maintenez-la enfonce, et
appuyez sur la touche Y.
4/28 Formation Excel 2003

4/28
2005 O.J accomard


II) La mise en forme de la feuille la sauvegarde du classeur

Dans un premier temps, nous allons apprendre mettre en forme une feuille dun classeur (taille,
couleur, etc.) et enregistrer le travail.
a. Dmarrez le tableur Excel en cliquant deux fois sur cet icne (fig.1) :
b. Le but de cette mise en forme est dobtenir la figure 2 :




On appellera A1 la case qui est dans la colonne A, ligne n1. Cliquez avec le bouton
gauche dans cette case. Tapez alors au clavier le mot Date , et appuyez sur Enter.
c. Mettons ce mot en gras : slectionnez de nouveau la
case A1 avec le bouton gauche de la souris, et
cliquez sur Format, Cellule. (Fig.3).


d. Slectionnez longlet Police (Fig.5)
et cliquez sur Gras.
Remarque : vous pouvez faire les
tapes c et d en cliquant directement
sur licne Gras (Fig.4)







e. Dans la case A2, tapez, en utilisant les mmes mthodes quaux tapes c et d, Type de
devoir , en gras, et appuyez sur la touche Enter.
Remarque : vous pouvez mettre en gras plus rapidement en appuyant sur la touche Ctrl, en la
maintenant enfonce, et en appuyant sur la touche G. Une combinaison de touches
Fig. 1
Fig. 2
Fig. 3
Fig. 5
1
2
Fig. 4
2005 Formation Excel 2003 5/28

2005 O.J accomard
5/28

( Ctrl + G ) associe une commande ( mettre en gras ) sappelle un raccourci
clavier.
f. Dans la case A3, tapez, en utilisant le raccourci clavier Ctrl+G pour mettre en gras, le texte
Note sur . Appuyez sur Enter.
g. Dans la case A4, tapez en gras le texte Coefficient . Appuyez
sur Enter.
h. Avec la touche flche vers le bas, dplacez-vous jusqu la case
A47.
i. Tapez alors, en gras, le texte Moyenne ,
dans cette case A47. Appuyez sur Enter.
j. En A48, tapez Note min et validez en
appuyant sur Enter.
k. En A49, tapez Note max et validez.
l. En A50, tapez 0%<notes<25% et
validez. Cette ligne correspondra au nombre de notes comprises
entre 0 et 25% de ce sur combien est not le devoir.
m. En A51, tapez 25%<notes<50% et validez.
n. En A52, tapez 50%<notes<75% et validez.
o. En A53, tapez 75%<notes<100% et validez.
p. A ce stade, vous remarquez que le classeur nest pas visible en
entier sur lcran, ce qui nest pas trs pratique. Cliquez sur
Affichage, puis sur Zoom (Fig.6).
q. Cliquez sur le bouton Personnalis, et remplacez 100% par
60% (Fig.8). Validez (en cliquant sur OK ou en appuyant sur
Enter). Si vous ne voyez toujours pas la fois Date et
75%<notes<100% sur lcran, rduisez encore le
pourcentage du zoom en suivant la mme procdure. Vous devez
obtenir un affichage du type de la figure 7.
r. Vous remarquez aussi que le texte dpasse
parfois de la colonne (comme en A4, par
exemple). Nous allons donc changer la largeur
de la colonne A. Cliquez sur le A de la
colonne A, avec le bouton droit de la souris.
s. Dans le menu qui apparat, slectionnez
Largeur de colonne(voir Fig.9).
t. Remplacez le 10.71 par 18.79 et validez. La
largeur de la colonne est modifie.
u. Modifions de mme la largeur des colonnes B
AK. Pour cela, cliquez sur la colonne B,
maintenez le bouton de la souris enfonce, et
dplacez-la jusqu la colonne AK (le tableau
dfile), puis relchez.
v. Cliquez alors avec le bouton droit sur la zone
slectionne, puis slectionnez Largeur de colonne et rglez-la 6. Validez.
w. Nous allons maintenant nous occuper des bordures : slectionnez lensemble des cases A1
AK53 (cliquez sur A1, maintenez le bouton
enfonc, tranez jusqu AK53). Cliquez alors
avec le bouton droit sur la zone slectionne,
puis sur Format de cellule. La fentre Format
de cellule souvre.
x. Slectionnez longlet Bordures (voir Fig.10).
Slectionnez ensuite le trait le plus pais, puis
cliquez sur licne Contour. Le contour de la
slection est entour dun
trait pais.
y. Faisons un quadrillage
intrieur : Cliquez sur le
trait le plus fin, puis sur
licne Intrieur
(Fig.11).
1
2
Fig. 6
Fig. 8
Fig. 7 Fig. 9
Fig. 10
1
2
3
1
2
Fig. 11
6/28 Formation Excel 2003

6/28
2005 O.J accomard

z. Validez le tout en cliquant sur le bouton OK.
aa. Slectionnez les cases B1 K57, puis cliquez
avec le bouton droit sur la zone slectionne et
cliquez sur Format de cellule. Slectionnez
Bordure, puis le trait moyen. Cliquez
successivement sur les icnes reprsentant des
traits verticaux (voir Fig.12).
bb. Slectionnez les cases A1 AK4, cliquez avec
le bouton droit sur la zone slectionne, et
cliquez sur Format de cellule. Slectionnez
Bordure, puis le trait moyen. Cliquez sur
licne reprsentant un trait horizontal bas.
cc. Recommencez avec les cases A47 AK53, en
cliquant cette fois sur licne reprsentant un
trait horizontal en haut du carr.
dd. Nous voulons modifier la couleur de fond des
lignes A5 A46, une fois sur deux. Les zones
slectionner ne sont pas contigus, mais on
peut quand mme les slectionner en mme
temps : dans un premier temps, slectionnez les cellules A5 AK5 (clic gauche maintenu
enfonc, traner). Dans un deuxime temps, appuyez sur la touche Ctrl, maintenez-la
enfonce, et slectionnez de la mme manire que prcdemment les cellules A7 AK7.
Continuez ainsi en slectionnant une ligne sur deux jusqu A45 AK45 (voir le rsultat
fig.14).






















ee. Cliquez alors avec le bouton droit sur la zone slectionne, et
cliquez sur Format de cellule.
ff. Cliquez sur longlet Motifs. Choisissez le carr gris lger (voir
Fig.13). Validez, et cliquez sur une case quelconque de la
feuille pour voir leffet obtenu.
gg. Si vous regardez la figure 2, vous constaterez que certaines
cases sont fusionnes, c'est--dire que le texte est cheval sur
plusieurs cases : cest le cas de la case B1B7, par exemple.
Nous allons voir comment arriver ce rsultat : slectionnez
les cases B1 B4 (clic gauche maintenu enfonc, traner).
hh. Cliquez avec le bouton droit sur la zone slectionne, puis sur
Format de cellule.
ii. Slectionnez longlet Alignement et cochez la case Fusionner
les cellules.
1
2 3 4
Fig. 12
Fig. 14
Fig. 13
2005 Formation Excel 2003 7/28

2005 O.J accomard
7/28

jj. Cliquez sur le petit carr rouge droite de
Texte, maintenez enfonc, et tranez de faon
que le texte soit inclin vers le bas denviron
60 (voir Fig.15). Validez en cliquant sur
OK.
kk. Dans la cellule fusionne, tapez le mot
Moyenne et validez, pour voir leffet produit.
ll. Pour vous entraner, faites une zone
fusionne avec les cases E1 E4, et crivez-
y Contrles inclin 60 environ.
mm. Il peut tre fastidieux de rpter des mises en
forme de case. Nous allons recopier la mise
en forme de B1B4 sur les cases C1 C4, D1
D4, , K1 K4. Slectionnez la case
fusionne B1B4. Cliquez sur Edition, puis
sur Copier (Fig.16) : la case est mmorise
par lordinateur.
nn. Slectionnez ensuite les cases C1 K4.
oo. Cliquez de nouveau sur Edition, puis sur Collage
spcial
pp. Cochez Format et validez. Seule la mise en forme est
copie, pas le contenu (ici, le texte Moyenne , par
exemple, napparat pas dans les cases C1 K4).
Remarque : pour aller plus vite, la copie peut se faire avec
la combinaison de touches Ctrl et C. En revanche, le
collage spcial ne peut se faire que par le menu.
qq. Ce classeur ayant pour objectif de calculer des
moyennes, les cases L5 AK46 contiendront des
notes. Il peut tre utile dimposer un format
daffichage des nombres dans cette zone. Pour cela,
tapez dabord 1.5 en L5 et 3 en M5. Ne tapez
pas despace.
Remarques :
1) Suivant les prfrences de Excel, cest le point ou
la virgule qui sert de sparateur entre la partie entire
et la partie dcimale. Pour modifier cela, allez dans
Outils, Options, International, Gestion des
nombres.
2) Pour valider une valeur, il nest pas obligatoire de taper sur Enter : on peut aussi utiliser
les flches de dplacement.
3) Si vos nombres sont aligns sur le bord gauche des cases, cest quils sont pris pour du
texte. Enlevez tout espace et autre symbole non numrique.
rr. Slectionnez les cases L5 AK46, puis cliquez avec le bouton droit sur la zone slectionne.
Cliquez ensuite sur Format de
cellule. Slectionnez longlet
Nombre.
ss. Dans la fentre Catgorie,
choisissez Nombre, et ajustez le
Nombre de dcimales 2 (voir
Fig.18). Validez. Vous constatez
que 1.5 devient 1.50 et que
3 devient 3.00 .
tt. Pour vous entraner, slectionnez les
cellules A1 AK1 et choisissez le
format Date , 14/3 . De
mme, slectionnez les cellules B5
B46 et attribuez-leur le format
Nombre, avec 2 dcimales.
uu. Il reste une dernire technique
matriser : on peut vouloir, pour une raison desthtisme, masquer des colonnes ou des lignes.
1
2
Fig. 15
Fig. 16
Fig. 17
1
2
3
Fig. 18
8/28 Formation Excel 2003

8/28
2005 O.J accomard

Pour cela, slectionnez par exemple les enttes des colonnes C et D (voir
Fig.19) (clic maintenu enfonc, dplacer).
vv. Cliquez alors sur les enttes avec le bouton droit et slectionnez Masquer
(voir Fig.21). Les colonnes disparaissent (voir Fig.20).
ww. Pour accder de nouveau ces colonnes,
slectionnez les enttes des colonnes B E,
cliquez avec le bouton droit dessus, et
cliquez sur Afficher. La technique est
strictement la mme concernant les lignes.








xx. Nous avons fait peu prs le tour des techniques de mise en forme.
yy. Sauvegardons le travail : cliquez sur Fichier, puis sur Enregistrer. Si cest la premire fois
que vous enregistrez votre classeur, Excel vous demandera un nom. Tapez en un (mettez votre
nom propre, par exemple, pour que le fichier soit reprable), et validez.
zz. Les fois suivantes, si vous cliquez sur Fichier, puis sur Enregistrer, Excel ne vous demandera
rien : il connat le nom du classeur, et remplace lancienne version par celle que vous voulez
enregistrer.
aaa. Si vous voulez enregistrer votre classeur sous un autre nom, cliquez sur Fichier, puis sur
Enregistrer sous. Un nom de fichier vous sera alors demand.
bbb. Passons aux techniques de calcul.


Fig. 19
Fig. 21
Fig. 20
2005 Formation Excel 2003 9/28

2005 O.J accomard
9/28


III) Les premires formules
Dans cette partie, nous allons rentrer et copier des formules.
Dans un premier temps, nous allons faire des essais avec des formules simples, pour
bien comprendre le principe de calcul et de recopiage. On suppose que vous avez fait
le chapitre sur la mise en forme.
a. Si vous ne lavez pas encore fait, tapez 1.5 en L5 et 3 en M5.
b. Tapez 2 en L6 et 3.5 en M6.
c. Voici notre premire formule : en K5, tapez =L5+M5 (sans espace
voir Fig. 22) et validez. Vous constatez alors que le tableur na pas affich
L5+M5 , mais bien le rsultat de lopration demande (Fig.24). Autrement
dit, pour obtenir le rsultat dun calcul, il suffit
de donner les coordonnes des cellules avec
lesquelles on veut oprer.
d. Cliquez sur la case K6. Pour connatre toutes les
fonctions quExcel peut utiliser, cliquez sur
Insertion, Fonction et, dans Ou
slectionnez une catgorie , slectionnez Tous.
(voir Fig.23). Une brve description de chaque
fonction apparat en dessous quand elle est
slectionne dans la liste. Cherchez NB.SI et
slectionnez-la. Validez.
e. Dans le rectangle Plage, tapez L6:AK6 .
Dans le rectangle Critre, tapez <3 . (voir
Fig.25). Validez.
f. En K6, apparat le nombre 1. En effet, dans la
zone L6 AK6, il ny a quun seul
nombre plus petit que 3.
g. En N6, tapez le nombre 1 . Aussitt,
K6 passe 2. On constate donc que le
calcul se fait en temps rel.
h. Voyons maintenant ce qui se passe
quand on recopie des formules.
Slectionnez K6, puis cliquez sur
Edition, Copier.
i. Slectionnez ensuite les cases K7 K13
(clic sur K7, maintenu enfonc, et
traner jusqu K13). Cliquez ensuite sur
Edition, Coller. Vous constatez que :
1) la mise en forme a t recopie, ce
qui nest pas souhaitable dans notre cas.
Nous verrons comment y remdier.
2) les formules en K7, K8, etc. ont t modifies : par
exemple, cliquez sur K7 : elle contient
=NB.SI(L7:AK7;"<3") et non =NB.SI(L6:AK6;"<3"). Les
coordonnes ont t modifies.
j. Annulons lopration de recopie que nous venons
deffectuer : tapez sur la touche Ctrl, maintenez-la
enfonce, et tapez sur Z. Si cela ne marche pas, faites une
recopie de format de J6:J13 vers K6:K13 (voir chapitre
prcdent, tapes oo. et pp.), puis supprimez le contenu des
cellules K6:K13 en les slectionnant et en appuyant sur la
touche Suppr.
k. Supposons que nous voulions recopier les cases sans
toucher la mise en forme : on passe alors par le collage spcial : cliquez sur K6, slectionnez
Edition, Copier. Slectionnez les cases K7 K13. Cliquez ensuite sur Edition, Collage
spcial. Slectionnez Formules (voir Fig.26) . Validez. Cette fois-ci, la mise en forme
initiale a t conserve.
Fig. 22
Fig. 24
Fig. 25
Fig. 26
Fig. 23
10/28 Formation Excel 2003

10/28
2005 O.J accomard

l. Il peut tre utile, dans certains cas, de faire en sorte que la formule recopie ne modifie pas
toutes les coordonnes. Par exemple, dans notre cas, on peut souhaiter que :
- la formule en K5 cherche les nombres infrieurs 3 dans la zone L5 AK5,
- la formule en K6 cherche les nombres infrieurs 3 dans la zone L5 AK6,
- la formule en K7 cherche les nombres infrieurs 3 dans la zone L5 AK7,
- etc.
On constate quil faut que les coordonnes de L5 restent les mmes dans toutes les formules,
mme en cas de recopie. Pour cela, il suffit de faire prcder les coordonnes du symbole $. La
formule =NB.SI(L5:AK5;"<3") deviendra donc =NB.SI($L$5:AK5;"<3"). Pour modifier la
formule en K5, cliquez sur K5, et tapez =NB.SI($L$5:AK5;"<3").
m. Voyons si la recopie seffectue comme nous le souhaitons : cliquez sur la case K5, puis sur
Edition, Copier. Slectionnez ensuite les cases K6 K13. Cliquez sur Edition, Collage
spcial. Slectionnez Formules (voir Fig.25) . Validez.
n. Vrifiez sur K13 : la formule est =NB.SI($L$5:AK13;"<3"). L5 na pas boug.
o. Si nous poursuivons lobjectif de faire un programme qui calcule les moyennes, nous auront
besoin de manipuler la fonction SI. Son format est le suivant :
=SI(condition;formule si la condition est vraie;formule si la condition est fausse)
Pour bien en comprendre le fonctionnement, cliquez en J5, et tapez =SI(K5=1; "un seul
nombre est plus petit que 3.";"plusieurs nombres
sont plus petits que 3.") .
p. Recopiez la formule contenue dans la case J5
dans les cases J6 J13 (voir ltape k), et
agrandissez la largeur de la colonne J pour voir
les rsultats. La formule teste si Kn est diffrent
de 1. Si oui, elle affiche la phrase un seul
nombre est plus petit que 3 , sinon, elle affiche
plusieurs nombres sont plus petits que 3 .
q. Tapez 2 en M8, 4 en L6 et 4 en N6. Vous remarquez que les rsultats changent en
temps rel (voir Fig.27).
r. Un autre type de formule nous sera utile : les valeurs logiques. En I13, tapez =(K13=2)
(sans espace) et validez. Vous obtenez VRAI, ce qui est logique, puisque K13 vaut bien 2.
s. Dans H13, tapez =I13*2 (sans espace) et validez. Vous obtenez 2 ! En effet, dans Excel, la
valeur logique VRAI est associe la valeur numrique 1.
t. Copiez la zone H13:I13 dans les cases H5 I12. Vous remarquez que les cases H5, H6, et H7
valent 0, car I5, I6 et I7 sont FAUX. On en dduit que la valeur logique FAUX est associe
la valeur numrique 0.
u. Enfin, nous aurons besoin des formules matricielles. Il sagit souvent dune formule qui
permet denchaner deux sries doprations. Par exemple, imaginons que nous voulions
multiplier L5 avec L6, M5 avec M6, etc. jusqu AK5 et AK6, additionner les rsultats, et
stocker le rsultat final dans G5.
On pourrait crire :
=L5L6+M5M6+ etc. Cest
un peu fastidieux. Cliquez sur G5
et tapez
=SOMME(L5:AK5*L6:AK6)
SANS VALIDER. La validation
dune formule matricielle est un
peu spciale : pour valider,
appuyez sur la touche Ctrl,
maintenez-la enfonce, appuyez
sur la touche Schift (en dessous
de la touche de mise en majuscule), maintenez-la aussi enfonce, et enfin, appuyez sur la
touche Enter. Relchez. Vous obtenez la figure 28.
Remarque :
1) la formule matricielle se reconnat par les accolades autour de la formule dans la barre
ddition.
2) il est videmment possible de recopier des formules matricielles selon le mme principe
que pour les formules ordinaires.
3) 16,5 est bien le rsultat de 1,54+33,5. N5 tant vide, le 4 de N6 nest pas multipli par le
contenu de N5.
Fig. 27
Fig. 28
2005 Formation Excel 2003 11/28

2005 O.J accomard
11/28

v. Une dernire petite manipulation avant que vous construisiez votre
premire feuille : il est possible que vous ayez besoin dinsrer ou de
supprimez aprs coup des lignes ou des colonnes. Cest ce que nous
allons faire ici pour prparer le terrain de la feuille de moyenne
trimestrielle : cliquez sur lentte de ligne 3, puis sur Insertion (voir
Fig.29). Une ligne sinsre.
w. Recommencez de faon avoir au total trois lignes insres entre Type
de devoirs et Note sur.
x. Supprimez les lignes 47 49 de la mme faon (slection des enttes des
trois lignes, clic droit, Supprimer).
y. Insrez une ligne entre Note max et 0%<notes<25%.
z. Insrez une ligne entre 0%<notes<25% et 25%<notes<50%.
aa. Insrez une ligne entre 50%<notes<75% et 75%<notes<100%.
bb. Insrez trois colonnes entre E et F.
cc. Supprimez le contenu de toutes les cellules entre K8 et R16, en les slectionnant et en
appuyant sur la touche Suppr. Vous tes prt pour faire la feuille de moyenne trimestrielle.

Fig. 29
12/28 Formation Excel 2003

12/28
2005 O.J accomard


IV) Les formules de la feuille de moyenne trimestrielle
Cette partie est volontairement peu guide, car elle met en uvre toutes les notions abordes aux
paragraphes prcdents. Les figures suivantes vous montre ce que vous devez obtenir (Fig.30 et
suivantes).


a. Les formules de la colonne C sont matricielles : noubliez pas dutiliser la combinaison de
touches Ctrl+Shift+Enter pour les valider. La colonne C reprsente la somme des produit
notecoef, la colonne D reprsente la somme des coefficients, la colonne B est la moyenne.
Les colonnes E,F et G sont du mme ordre, pour les contrles, etc.
b. Voir la figure 30 : tapez la formule en B8 ( =SI(D8=0;"";C8/D8) ), validez-la, et recopiez-la
de B9 B46. (Moyenne)
c. Tapez la formule en C8 ( =SOMME($N8:$AK8*$N$7:$AK$7*($N$6:$AK$6<>"")) ),
validez-la (avec Ctrl+Shift+Enter) et recopiez-la de C9 C46. (Somme des notes pour la
moyenne).
d. Voir la figure 31 : tapez chaque formule de
B47
(=SI(NB.VIDE(B8:B46)=39;"";MOYENNE
(B8:B46)) ), B48
( =SI(NB.VIDE(B8:B46)=39;"";MIN(B8:B
46)) ), B49
( =SI(NB.VIDE(B8:B46)=39;"";MAX(B8:
B46)) ),
B51( =SI(NB.VIDE(B$8:B$46)=39;"";NB.
SI(B$8:B$46;"<=5")) ), B53( =SI(NB.VIDE(B$8:B$46)=39;"";NB.SI(B$8:B$46;"<=10")-
B$51) ), B55( =SI(NB.VIDE(B$8:B$46)=39;"";NB.SI(B$8:B$46;"<=15")-
(B$51+B$53)) ), et B57( =SI(NB.VIDE(B$8:B$46)=39;"";NB.SI(B$8:B$46;">15")) ) en
les validant, et recopiez la zone B47 B57 dans les zones C47 C57, D47 D57, E47 E57,
F47 F57, G47 G57, H47 H57, I47 I57, J47 J57, K47 K57.
e. Recopiez aussi la zone B47 B49 dans la zone N47 AK49.
Fig. 30
Fig. 31
2005 Formation Excel 2003 13/28

2005 O.J accomard
13/28

f. Tapez la formule en D8( =SOMME($N$7:$AK$7*($N8:$AK8<>"")*$N$6:$AK$6/20) ),
validez-la (avec Ctrl+Shift+Enter) et recopiez-la de D9 D46. (somme des coefs pour la
moyenne)
g. Tapez la formule en E8( =SI(G8=0;"";F8/G8) ), validez-la, et recopiez-la de E9 E46.
(Moyenne des contrles)
h. Tapez la formule en
F8( =SOMME($N8:$AK8*$N$7:$AK$7*($N$6:$AK$6<>"")*$N$3:$AK$3) ), validez-la
(avec Ctrl+Shift+Enter) et recopiez-la de F9 F46. (Somme des notes pour la moyenne des
contrles)
i. Tapez la formule en
G8( =SOMME($N$7:$AK$7*($N8:$AK8<>"")*$N$6:$AK$6/20*$N$3:AK$3) ), validez-
la (avec Ctrl+Shift+Enter) et recopiez-la de G9 G46. (Somme des coefficients pour la
moyenne des contrles)
j. Tapez la formule en H8( =SI(J 8=0;"";I8/J 8) ), validez-la et recopiez-la de H9 H46.
(Moyenne des brevets)
k. Tapez la formule en
I8( =SOMME($N8:$AK8*$N$7:$AK$7*($N$6:$AK$6<>"")*$N$4:$AK$4) ) , validez-la
(avec Ctrl+Shift+Enter) et recopiez-la de I9 I46. (somme des notes pour la moyenne des
brevets)
l. Tapez la formule en
J8( =SOMME($N$7:$AK$7*($N8:$AK8<>"")*$N$6:$AK$6/20*$N$4:$AK$4) ) ,
validez-la (avec Ctrl+Shift+Enter) et recopiez-la de J9 J46. (somme des coefficients pour la
moyenne des brevets)
m. Tapez la formule en K8( =SI(M8=0;"";L8/M8) ), validez-la et recopiez-la de K9 K46.
(Moyenne des interrogations)
n. Tapez la formule en
L8( =SOMME($N8:$AK8*$N$7:$AK$7*($N$6:$AK$6<>"")*$N$5:$AK$5) ) , validez-la
(avec Ctrl+Shift+Enter) et recopiez-la de L9 L46. (somme des notes pour la moyenne des
interrogations)
o. Tapez la formule en
M8( =SOMME($N$7:$AK$7*($N8:$AK8<>"")*$N$6:$AK$6/20*$N$5:$AK$5) ),
validez-la (avec Ctrl+Shift+Enter) et recopiez-la de M9 M46. (somme des coefficients pour
la moyenne des interrogations)
p. Tapez la formule en N3( =SI(OU(STXT(N2;1;1)="c";STXT(N2;1;1)="C");1;0) ), validez-la
et recopiez-la de O3 AK3. (teste si le type de devoir commence par c ou C - en ce
cas, cest un contrle).
q. Tapez la formule en N4( =SI(OU(STXT(N2;1;1)="b";STXT(N2;1;1)="B");1;0) ), validez-la
et recopiez-la de O4 AK4. (teste si le type de devoir commence par b ou B - en ce
cas, cest un brevet).
r. Tapez la formule en N5( =SI(OU(STXT(N2;1;1)="i";STXT(N2;1;1)="I");1;0) ), validez-la
et recopiez-la de O5 AK5. (teste si le type de devoir commence par i ou I - en ce cas,
cest une interrogation).
s. En N50, tapez la formule =SOMME(SI((N$8:N$46<N$6/4)*(N$8:N$46<>"");1;0)) .
Validez-la avec Ctrl+Shift+Enter et recopiez-la de O50 AK50. (comptabilise le nombre de
notes infrieures 25% de la note maximale)
t. En N51, tapez =SI(N50=0;"";N50) et validez. Recopiez la formule en N53, N55 et N57.
Recopiez aussi de O51 AK57.
u. En N52, tapez
=SOMME(SI((N$8:N$46>=N$6/4)*(N$8:N$46<N$6/2)*(N$8:N$46<>"");1;0)) , validez-
la avec Ctr+Shift+Enter et recopiez-la de O52 AK52. (comptabilise le nombre de notes
comprises entre 25% et 50% de la note maximale)
v. En N54, tapez
=SOMME(SI((N$8:N$46>=N$6/2)*(N$8:N$46<3*N$6/4)*(N$8:N$46<>"");1;0)) ,
validez-la avec Ctr+Shift+Enter et recopiez-la de O54 AK54. (comptabilise le nombre de
notes comprises entre 50% et 75% de la note maximale)
w. En N56, tapez =SOMME(SI((N$8:N$46>=3*N$6/4)*(N$8:N$46<>"");1;0)) , validez-la
avec Ctr+Shift+Enter et recopiez-la de O56 AK56. (comptabilise le nombre de notes
comprises entre 50% et 75% de la note maximale).
x. Vous trouverez dans les pages suivantes des crans des diffrentes colonnes de formules que
doit contenir la feuille de moyenne trimestrielle.
14/28 Formation Excel 2003

14/28
2005 O.J accomard


Fig. 35 : D10 D57 Fig. 34 : E10 E57
Fig. 33 : F4 F57 Fig. 32 : G4 G57
2005 Formation Excel 2003 15/28

2005 O.J accomard
15/28






Fig. 41 : H4 H57 Fig. 40 : I4 I57 Fig. 39 : J 4 J 57
Fig. 38 : K4 K57
Fig. 37 : L4 L57 Fig. 36 : M4 M57
16/28 Formation Excel 2003

16/28
2005 O.J accomard

Fig. 45
Fig. 47
Fig. 46

Les colonnes
suivantes ressemblent aux colonnes O et P, jusqu AK.
y. Pensez sauvegarder votre travail.
V) La protection dune feuille le contrle de la
saisie des donnes
a. Dans le cas de la saisie de notes, il peut tre utile dinterdire
laccs aux formules pour viter quelles soient effaces par
erreur, et on peut vouloir empcher la saisie dautre chose que
des nombres dcimaux compris entre 0 et la note maximale.
Cest ce que nous allons faire ici. Slectionnez la zone N8
AK46. Cliquez sur Donnes, Validation (voir fig.45).
b. Cliquez sur longlet Options et (voir Fig.47) :
i. dans Autoriser, slectionnez Dcimal.
ii. dans Donnes, slectionnez comprise entre.
iii. dans Minimum, tapez 0 .
iv. dans Maximum, tapez N$6 (cela veut dire que la
valeur maximale est stocke dans N6 pour la colonne
N, O6 pour la colonne O, etc).
c. Cliquez sur longlet Message de saisie et (voir Fig.46) :














Fig. 43 : N3 N57
Fig. 42 : O3 O57
Fig. 44 : P3 P57
2005 Formation Excel 2003 17/28

2005 O.J accomard
17/28


i. Cochez Quand la cellule est slectionne.
ii. Dans Titre :, tapez Notes .
iii. Dans Message de saisie :, tapez Entrez
une note .
d. Cliquez sur longlet Alerte derreur et (voir
Fig.48) :
i. Cochez Quand les donnes non valides
sont tapes
ii. Dans Style, slectionnez Avertissement
iii. Dans Titre : , tapez Saisie incorrecte
iv. Dans Message derreur :, tapez Soit ce
que vous avez saisi nest pas un nombre,
soit il nest pas dans la plage des
nombres autoriss
e. Validez.
f. Testez en rentrant des contrles avec des valeurs dans les colonnes N et O.
g. Slectionnez les cases A8 A46 : il sagit de la zone de saisie des noms dlves.
h. Pour vous entraner, faites une validation des donnes sans contrainte, qui indique en titre
Elve , et en message Entrez le nom de llve .
Nous allons maintenant nous occuper du principe de verrouillage de la feuille : on peut verrouiller
des cases (c'est--dire en empcher laccs), mais ce verrouillage ne prend effet QUE si la feuille
est elle-mme protge. Nous allons donc procder en trois tapes :
i. Verrouiller toutes les cases de la feuille.
ii. Dverrouiller les cases o lon saisi les notes et les noms des lves.
iii. Protger la feuille.
i. Pour slectionner toute la feuille, cliquez sur lentte vide en haut gauche (voir
Fig.49).
j. Cliquez dans la zone slectionne avec le bouton droit, et slectionnez Format
de cellule.
k. Cliquez sur longlet Protection. Cochez Verrouille. Validez.
l. Dverrouillons les cases de saisie : slectionnez les cases A8 A46. Cliquez sur
la zone slectionne avec le bouton droit, cliquez sur Format de cellule, cliquez sur longlet
Protection et dcochez la
case Verrouille. Validez.
m. Procdez de la mme
faon pour la zone N8
AK46 et avec la zone N1
AK7.
n. Si vous cliquez deux fois
sur une cellule contenant
une formule, vous
constatez que vous
pouvez toujours lditer.
Enclenchons la protection : cliquez sur Outils, Protection, Protger la feuille.(voir Fig.50).
o. Cochez Protger la feuille et le contenu des cellules
verrouilles si ce nest pas dj coch. Cochez
Slectionner les cellules dverrouilles et dcochez
tout le reste (voir Fig.51). Tapez votre mot de passe
dans le rectangle Mot de passe pour ter la protection
de la feuille :. Validez. Confirmez le mot de passe en le
retapant.
p. Testez : vous ne pouvez accder quaux cellules
dverrouilles.
q. Sauvegardez votre travail.





Fig. 48
Fig. 49
Fig. 50
Fig. 51
18/28 Formation Excel 2003

18/28
2005 O.J accomard


VI) Les feuilles : copiage, suppression, insertion
Dans cette partie, nous allons :
Copier la feuille que nous avons cre dans dautres feuilles pour faire les
moyennes trimestrielles du trimestre 2 et du trimestre 3.
Renommer les feuilles.
Crer une nouvelle feuille qui calculera les moyennes annuelles.
Crer une nouvelle feuille qui contiendra toutes les notes de tous les lves.
Crer une feuille qui contiendra les graphiques.

a. Otons dabord la protection de la feuille : cliquez sur Outils, Protection, Oter la protection
de la feuille (voir Fig.52). Rentrez le mot de passe et validez.





b. Le copiage : slectionnez toute la feuille en cliquant sur lentte vide en haut gauche (voir
fig.49).
c. Copiez (Edition, Copier ou Ctrl+C).
d. Cliquez sur longlet Feuil2 (voir Fig.53).
e. Collez (Edition, Coller ou Ctrl+V). Modifiez le zoom 60 ou 70%
(voir Fig.6 et suivantes, en dbut du document).
f. Cliquez sur longlet Feuil3 (voir Fig.53) et collez (Edition, Coller ou
Ctrl+V). Modifiez le zoom 60 ou 70%.
g. Renommer : cliquez sur longlet Feuil1 avec le bouton droit, puis cliquez sur Renommer.
h. Tapez Trimestre n1 et validez.
i. Cliquez sur longlet Feuil2 avec le bouton droit, puis cliquez sur Renommer. Tapez
Trimestre n2 et validez.
j. Refaites la mme manipulation pour la Feuil3 en la renommant Trimestre n3.
k. Insertion et dplacement dune feuille : cliquez avec le bouton droit sur Trimestre n3, et
slectionnez Insrer
l. Dans la fentre Insrer, slectionnez licne Feuille et
validez en cliquant sur OK ou en appuyant sur Enter. Une
nouvelle feuille nomme Feuil1 sinsre entre Trimestre n2
et Trimestre n3.
m. Dplaons-la : cliquez avec le bouton gauche sur longlet
Feuil1, maintenez le bouton enfonc, et dplacez le curseur
de la souris vers la droite aprs Trimestre n3, puis relchez
(Fig.55 et 56).








n. Renommez-la en Moyenne annuelle (voir tape g.)
o. Copiez la mise en forme (collage spcial,
Format) et la largeur des colonnes (collage
spcial, Largeur de colonne) du
Trimestre n1, zone A1 K57, sur la feuille
Moyenne annuelle. Vous constatez que les
lignes caches sont copies et visibles.
Comme nous navons pas besoin de ces
lignes (qui servaient pour le calcul pour les
trimestres), il faut les supprimer : slectionnez les lignes 48 51 (par les enttes), cliquez sur la
zone slectionne avec le bouton droit, et slectionnez Supprimer. (voir le rsultat Fig.57).
Fig. 52
Fig. 53
Fig. 54
Fig. 56
Fig. 55
Fig. 57
2005 Formation Excel 2003 19/28

2005 O.J accomard
19/28

p. Sauvegardez votre travail.

VI) Les feuilles : formules sur plusieurs feuilles.
Dans cette partie, vous utiliserez des formules qui font appel au contenu de cellules situes sur des
feuilles diffrentes.
a. Nous allons complter la feuille Moyenne annuelle. Affichez dabord toutes les colonnes en
slectionnant les enttes des colonnes B, E, H et K, et cliquant sur la zone slectionne avec le
bouton droit, et en cliquant sur Afficher.
b. La premire colonne contiendra les noms des lves que lon aura tap sur la premire feuille
(Trimestre n1) : dans A8, tapez =Trimestre n1!A8 . Validez. Pour vrifiez le
fonctionnement de la formule, slectionnez la feuille Trimestre n1, et, en A8, tapez un nom.
Retournez sur la feuille Moyenne annuelle : le nom que vous venez de taper doit apparatre.
c. Copiez la case A8, et collez la formule (collage spcial), sur les cases A9 A46.
d. Pour vous entraner, copiez de la mme faon les cases A8 A46 de la feuille Trimestre n1,
sur les feuilles Trimestre n2 et Trimestre n3. Verrouillez les cases A8 A46 de ces deux
feuilles (Clic droit, Format de cellule, etc.)
e. Sur la feuille Moyenne annuelle, insrez une colonne entre B et C (clic droit sur entte C,
Insertion), puis entre F et G, et enfin entre Jet K. Insrez encore trois colonnes entre N et O.
f. Dans les cases C8 C46, copiez les moyennes gnrales de la feuille Trimestre n1 (dans
C8 : =Trimestre n1!B8 , puis copiage)
g. Dans les cases D8 D46, copiez (en tapant la formule adquate) les moyennes gnrales de la
feuille Trimestre n2.
h. Dans les cases E8 E46, copiez (en tapant la formule adquate) les moyennes gnrales de la
feuille Trimestre n3.
i. Dans les cases G8 G46, copiez (en tapant la formule adquate) les moyennes de contrle de
la feuille Trimestre n1.
j. Dans les cases H8 H46, copiez (en tapant la formule adquate) les moyennes de contrle de
la feuille Trimestre n2.
k. Dans les cases I8 I46, copiez (en tapant la formule adquate) les moyennes de contrle de la
feuille Trimestre n3.
l. Dans les cases K8 K46, copiez (en tapant la formule adquate) les moyennes de brevet de la
feuille Trimestre n1.
m. Dans les cases L8 L46, copiez (en tapant la formule adquate) les moyennes de brevet de la
feuille Trimestre n2.
n. Dans les cases M8 M46, copiez (en tapant la formule adquate) les moyennes de brevet de la
feuille Trimestre n3.
o. Dans les cases O8 O46, P8 P46, Q8 Q46, copiez (en tapant la formule adquate) les
moyennes dinterrogation des feuilles Trimestre n1, Trimestre n2, et Trimestre n3.
p. Il nous faut savoir le nombre de moyennes qua un lve dans chaque catgorie ( gnrale,
contrle, brevet, interrogation), et diviser par ce nombre pour avoir la moyenne annuelle. Pour
cela, insrons des colonnes qui contiendront le nombre de moyennes, pour chaque catgorie :
insrez une colonne entre B et C, puis une colonne entre G et H, une entre L et M et une entre
Q et R.
q. En C8, tapez =('Trimestre n1'!B8<>"")+('Trimestre n2'!B8<>"")+('Trimestre
n3'!B8<>"") . Recopiez cette formule de C9 C46.
r. En H8, faites de mme, en tapant =('Trimestre 1'!E8<>"")+('Trimestre
2'!E8<>"")+('Trimestre 3'!E8<>"") .
s. En M8, faites de mme, en tapant =('Trimestre 1'!H8<>"")+('Trimestre
2'!H8<>"")+('Trimestre 3'!H8<>"") .
t. En R8, faites de mme, en tapant =('Trimestre 1'!K8<>"")+('Trimestre
2'!K8<>"")+('Trimestre 3'!K8<>"") .
u. Calculons les moyennes : en B8, tapez =SI(C8=0;"";(D8+E8+F8)/C8) . Recopiez cette
formule de B9 B46.
v. En G8, tapez =SI(H8=0;"";(I8+J8+K8)/H8) . Recopiez cette formule de G9 G46.
w. En L8, tapez =SI(M8=0;"";(N8+O8+P8)/M8) . Recopiez cette formule de L9 L46.
x. En Q8, tapez =SI(R8=0;"";(S8+T8+U8)/R8) . Recopiez cette formule de Q9 Q46.
y. Masquez les colonnes de calcul pour ne garder visible que les colonnes de moyennes B, G, L
et Q.
20/28 Formation Excel 2003

20/28
2005 O.J accomard

z. Indiquez la nature des colonnes en B1, G1, L1 et Q1 en tapant Moyenne gnrale en B1,
Moyenne des contrles en G1, etc. Changez linclinaison du texte si ncessaire (Clic
droit, Format de cellule,etc.)
aa. Vous remarquez que si la case An de la feuille Trimestre n1 est vide, le lien =Trimestre
n1!An renvoie 0 et non un vide. Pour modifier cela, il faut modifier la formule en testant si
la case est vide : en A8, feuille Moyenne gnrale tapez =SI(Trimestre
n1!A8="";"";Trimestre n1!A8). Copiez cette formule dans les cases A9 A46. Les 0
disparaissent. Recommencez la manipulation pour les feuilles Trimestre n2 et Trimestre
n3.
bb. Il reste soccuper des cases B47 Q53. En B47, tapez la formule
=SI(NB.VIDE(B8:B46)=39;"";MOYENNE(B8:B46)) . Validez.
cc. En B48, tapez la formule =SI(NB.VIDE(B8:B46)=39;"";MIN(B8:B46)) . Validez.
dd. En B49, tapez la formule =SI(NB.VIDE(B8:B46)=39;"";MAX(B8:B46)) . Validez.
ee. En B50, tapez la formule =SI(NB.VIDE(B$8:B$46)=39;"";NB.SI(B$8:B$46;"<=5")) .
Validez.
ff. En B51, tapez la formule =SI(NB.VIDE(B$8:B$46)=39;"";NB.SI(B$8:B$46;"<=10")-
B$50) . Validez.
gg. En B52, tapez la formule =SI(NB.VIDE(B$8:B$46)=39;"";NB.SI(B$8:B$46;"<=15")-
(B$50+B$51)) . Validez.
hh. En B53, tapez la formule =SI(NB.VIDE(B$8:B$46)=39;"";NB.SI(B$8:B$46;">15")) .
Validez.
ii. Recopiez les cases B47 B53 dans la zone G47 Q53.
jj. Sauvegardez votre travail en cliquant sur Fichier, Enregistrer.
kk. Insrez une nouvelle feuille nomme touteslesnotes, et dplacez-la aprs Moyenne gnrale :
nous allons y insrer toutes les notes des trois trimestres.
ll. En B8 de la feuille touteslesnotes, tapez une formule qui reprenne la note situe en N8 de la
feuille Trimestre n1. En C8 de touteslesnotes, tapez une formule qui reprenne la note situe
en O8 de Trimestre n1. Continuez ainsi pour les notes du premier trimestre.
mm. En Z8 de touteslesnotes, tapez une formule qui reprenne la note situe en O8 de
Trimestre n2. Reportez ainsi toutes les notes du deuxime trimestre. Faites de mme pour le
trioisime trimestre.
nn. En A8, tapez la formule suivante : =SI('Trimestre
1'!A8<>"";CONCATENER('Trimestre 1'!A8;" - T1:M:";'Trimestre 1'!B8;"-
c:";'Trimestre 1'!E8;"-b:";'Trimestre 1'!H8;"-i:";'Trimestre 1'!K8;" -
T2:M:";'Trimestre 2'!B8;"-c:";'Trimestre 2'!E8;"-b:";'Trimestre 2'!H8;"-
i:";'Trimestre 2'!K8;" - T3:M:";'Trimestre 3'!B8;"-c:";'Trimestre 3'!E8;"-
b:";'Trimestre 3'!H8;"-i:";'Trimestre 3'!K8);"") . Explication : cette formule permet de
mettre dans une seule chane de caractre le nom de llve, sa moyenne gnrale au premier
trimestre, etc. Cest ce que fait CONCATENER. Cette case (A8) servira de titre au graphique
que nous construirons dans le paragraphe suivant.
oo. Recopiez toutes les formules des A8 BU8, sur la zone A9 BU46.
pp. En B3, tapez la formule =SI('Trimestre
n1'!N1<>"";CONCATENER(TEXTE('Trimestre n1'!N1;"jj/mm/aa");"-";'Trimestre
n1'!N2;"- /";'Trimestre n1'!N6);"") . Cette formule permet de reporter la date, le type et
la note maximale dun devoir dans une seule case.
qq. Copiez cette formule de C3 Y3.
rr. En Z3, tapez la formule =SI('Trimestre
n2'!N1<>"";CONCATENER(TEXTE('Trimestre n2'!N1;"jj/mm/aa");"-";'Trimestre
n2'!N2;"- /";'Trimestre n2'!N6);"") . Cest la mme formule quen B3, mais pour le
second trimestre.
ss. En AX3, tapez la formule =SI('Trimestre
n3'!N1<>"";CONCATENER(TEXTE('Trimestre n3'!N1;"jj/mm/aa");"-";'Trimestre
n3'!N2;"- /";'Trimestre n3'!N6);"") . Il sagit des dates pour le trimestre 3.
tt. Changez le zoom daffichage 75%.
uu. Sauvegardez le travail. Vous pouvez contrlez que vous avez correctement effectu les tapes
de ce paragraphe avec la capture dcran page suivante (Fig.58):




2005 Formation Excel 2003 21/28

2005 O.J accomard
21/28




























































Fig. 58
22/28 Formation Excel 2003

22/28
2005 O.J accomard

Fig. 59
Fig. 60
1
2


VII) Les graphiques.
Dans cette partie, nous allons apprendre faire des graphiques partir du
contenu des cellules.
a. Crer une nouvelle feuille nomme Graphique.
b. Dplacez-la entre Moyenne gnrale et touteslesnotes
c. Insrons notre premier graphique : cliquez sur Insertion, puis
sur Graphique (voir fig.59).
d. La premire fentre qui souvre est
celle du choix du graphique (voir
Fig.60). Choisissez Courbes en
cliquant dessus, puis cliquez sur
Suivant >.
e. La seconde fentre qui souvre est
celle du choix de la zone de donnes
que lon veut mettre dans le graphique
(voir Fig.61). Cliquez sur le bouton de
slection de la zone de donne (
droite du rectangle Plage de donnes).
f. Nous voulons faire un graphique qui
contient toutes les notes dun lve, et
celles-ci se trouvent sur la feuille
touteslesnotes. Cliquez sur longlet de
feuille touteslesnotes, puis
slectionnez les cases B8 BU8. Vous
pouvez aussi taper directement la
formule dans la fentre qui sest
ouverte (voir Fig.62).

g. Cliquez ensuite sur le bouton de fin de
slection (voir Fig.62). Vous revenez
alors la fentre de la figure 61.
h. Slectionnez longlet Srie (voir
Fig.63).
i. Il nous reste slectionner deux
objets : le titre du graphique :
cliquez sur le bouton de slection
du rectangle Nom, et tapez
=touteslesnotes !$A$8 pour
que le titre soit le nom de llve et
ses moyennes (ou slectionnez la
feuille touteslesnotes, puis la case
$A$8. Cliquez ensuite sur le bouton
de fin de slection (voir Fig.62).
j. Cliquez ensuite sur le bouton de
Fig. 61
Fig. 62
1 2
Fig. 63
1
2
2005 Formation Excel 2003 23/28

2005 O.J accomard
23/28

slection du rectangle Etiquettes de laxe des abscisses (X), et tapez
=touteslesnotes !$B$3:$BU$7 (ou utilisez la mthode de slection). Ainsi, les tiquettes
de laxe des x contiendront la date des devoirs.
k. Cliquez ensuite sur Suivant : la
troisime fentre saffiche (voir
fig.64). Nous allons supprimer la
lgende de gauche (qui, dans
notre cas, est inutile, puisque le
titre contient dj tous les
renseignements, et quil ny a
quune srie de notes). Cliquez
sur longlet Lgende.
l. Dcochez la case Afficher la
lgende (Fig.65) et cliquez sur
Suivant >.
m. Ltape 4 apparat. Vrifiez que
en tant quobjet dans :
Graphiques est slectionn
(cest le nom de la feuille dans
laquelle on veut insrer le
graphique) et cliquez sur Terminer.
Le graphique est insr. Lintrt est
l encore la mise jour en temps rel
du graphique : si llve a une
nouvelle note, le graphique est mis
jour.











VIII) Limpression
Dans cette partie, nous allons imprimer une feuille de
notre classeur. Limpression directe en cliquant sur
licne de limprimante est vivement dconseille, car
Excel risque dimprimer des cases vides, et ce sur
plusieurs feuilles.
a. Cliquez sur la feuille Trimestre n1. Si la feuille
est protge, vous ne pouvez pas slectionner la
zone A1 AK57. Dprotgez la feuille (Outils,
).
b. Slectionnez les cases A1 AK57.
c. Pour dfinir les limites de la zone imprimer,
cliquez sur Fichier, Zone dimpression,
Dfinir (voir Fig.66).
d. Nous souhaitons imprimer le trimestre n1, en
indiquant en titre le nom de la feuille et la
date dimpression : Cliquez sur Fichier, puis
sur Imprimer.
e. Une fentre souvre (Fig.67) : cliquez sur
Aperu. Le programme nous montre laspect
quaura limpression. Un premier problme
Fig. 64
Fig. 65
Fig. 66
Fig. 67
24/28 Formation Excel 2003

24/28
2005 O.J accomard

apparat : il faut que le tableau
apparaisse dans lautre sens (voir
Fig.68).
f. Cliquez sur Page
g. Cliquez sur le bouton Paysage. (Voir
fig.70)
h. Slectionnez longlet En-tte/Pied de
page, puis cliquez sur En-tte
personnalis.
i. Une fentre souvre. Cliquez dans la
fentre Partie centrale :, puis sur le
bouton Date, et enfin sur le bouton
Onglet (voir fig.69).
j. Validez, et cliquez sur OK.
k. Si vous lancez une impression, vous
constaterez que 4 pages sont imprimes, ce qui nest pas pratique : nous allons ajuster la zone
dimpression une page. Cliquez sur Page,
puis cochez Ajuster(voir Fig.71).
l. Validez. Cliquez sur Imprimer, et validez.
m. La mthode employe a un gros inconvnient : il
faut dprotger la feuille pour pouvoir slectionner
des cellules, ou ne pas exclure la possibilit de
slectionner dans la protection de la feuille. Pour
rendre cette manipulation automatique, nous allons
faire une macrocommande, qui fera toutes les
manipulations automatiquement chaque fois que
lon cliquera sur un bouton.










Fig. 68
Fig. 70
Fig. 69
1
2
Fig. 71
2005 Formation Excel 2003 25/28

2005 O.J accomard
25/28



IX) Les macrocommandes.
Le but de cette partie est dautomatiser limpression dune
feuille protge.
a. Il faut dabord faire apparatre la barre doutils de
dessin : cliquez sur Affichage, puis sur Barres
doutils et assurez-vous que Dessin est coch
(sinon, cochez-le). Voir figure 72.
b. La barre doutils de dessin est maintenant visible.
Pour pouvoir dessiner, tez la protection de la
feuille. Cliquez sur le rectangle et dessinez un
rectangle dans la zone AL7 AM8. (voir fig.74).
c. Cliquez avec le bouton droit sur ce rectangle et
slectionnez Ajouter du texte.(Fig.73)
d. Tapez imprimer et cliquez ailleurs sur la feuille. Cliquez de
nouveau avec le bouton droit sur le rectangle, et slectionnez
Format de la forme automatique.(Fig.77)
e. Cliquez sur longlet Couleurs et traits, puis sur le rectangle
Couleur de la rubrique Remplissage et choisissez une couleur
pour lintrieur du rectangle (Fig.75). Cliquez ensuite sur
longlet Alignement pour centr le texte dans le rectangle.
f. Cliquez ensuite sur le rectangle Horizontal : et slectionnez
Centr (voir Fig.76).
g. Cliquez ensuite sur le rectangle
Vertical : et slectionnez Centr.
h. Passons lenregistrement de la macro :
protgez la feuille de nouveau (Outils,
Protection). Cliquez ensuite sur
Outils, Macro, Nouvelle macro(voir
Fig.78).
i. La fentre Enregistrer une macro
souvre. Dans le rectangle Nom de la
macro, tapez Imprimer. Validez
en cliquant sur OK.A partir de cet
instant, tout ce que vous ferez sera
enregistr dans la macro.
j. Cliquez sur Outils, Protection,
ter la protection de la
feuille(Fig.79)
Fig. 72
Fig. 74
Fig. 73
Fig. 77
Fig. 76
1
2
3
Fig. 75
1
2
Fig. 78
Fig. 79
26/28 Formation Excel 2003

26/28
2005 O.J accomard

k. Tapez le mot de passe et validez.
l. Slectionnez les cases A1 AK57 (ce que vous
ne pouviez pas faire tant que la feuille tait
protge).
m. Cliquez sur Fichier, Zone dimpression, Dfinir
(Fig.80). Ceci permet Excel de dfinir la zone
imprimer partir de la zone slectionne.
n. Cliquez sur Fichier, Imprimer(Fig.81).
o. Vous obtenez la fentre de la figure 82.
Demandez au
formateur si
limprimante
slectionne est la
bonne, puis
slectionnez Slection,
et enfin cliquez sur
Aperu.
p. Laspect dExcel change compltement : il vous montre quel sera laspect de la page
imprime. Pour modifier les options les plus courantes, il faut cliquer sur Page.Faites-le.
q. Vrifiez que les options suivantes sont
slectionnes dans longlet Page (Fig.83):
i. Paysage est slectionn : la liste
des lves sera ainsi sur le bord le
plus court.
ii. Ajuster est slectionn : tout
tiendra sur une seule page.
r. Cliquez maintenant sur longlet En-
tte/Pied de page. La figure 84 vous donne
laspect souhait pour len-tte : le nom de
la feuille gauche et la date du jour
dimpression au centre. Pour obtenir cela,
cliquez sur En-tte personnalis.
s. Cliquez dans la partie gauche, et
slectionnez le bouton . Cela ajoute le
nom de la feuille sous la forme du code
&[Onglet].
t. Cliquez sur la partie centrale et slectionnez
le bouton pour insrer la date du jour.
Fig. 80
Fig. 81
Fig. 82
3
1
Fig. 83
1
2
Fig. 85
1 2
Fig. 84
2005 Formation Excel 2003 27/28

2005 O.J accomard
27/28

u. Validez en cliquant sur OK. Validez la mise en page en cliquant encore sur OK.
Cliquez ensuite sur Imprimer.Limpression se lance.
v. Remettez la protection de la feuille (Outils, Protection, Protger la feuille)
w. Arrtez lenregistrement de la macro en cliquant sur le bouton darrt (voir
Fig.86).
x. Testons la macro : cliquez sur Outils,
Macro, Macros (Fig.87).
y. slectionnez la macro Imprimer et cliquez
sur le bouton Excuter.
z. La macro vous demande le mot de passe de
protection, et vous devrez fermer le mode
aperu aprs excution, mais le reste est
automatique. Soyez un peu patient
cependant, car lxcution est plus lente que
quand vous imprimez la main. Pour viter
ce genre dinterruption, vous pouvez
enregistrer une macro dans laquelle vous ne
passez pas par laperu.
aa. Associons maintenant la macro cre au
bouton : tez la protection de la feuille, et cliquez avec le bouton droit sur le rectangle
Imprimer, sur la feuille.
bb. Cliquez sur Affecter une macro. (Fig.
89). Une fentre Affecter une macro
souvre. Slectionnez la macro Imprimer et
cliquez sur OK pour valider.
cc. Reprotgez la feuille.
dd. Si vous cliquez maintenant sur le rectangle
Imprimer, la macro qui imprime la feuille
se lance.
ee. Pour vous entraner, vous pouvez refaire un bouton dimpression sur
les autres trimestres.
ff. En fait, pour faire la macro, Excel a gnr un programme dans un
langage appel Visual Basic Application (VBA). Ce langage permet
beaucoup de choses. Nous allons par exemple demander ici
confirmation de limpression en modifiant le code gnr par Excel.
Cliquez sur Outils, Macro, Visual Basic Editor. (Fig.90)
gg. Dans la fentre Microsoft Visual Basic, cliquez sur Module 2 sil
existe, (Module 1 sinon). Le code apparat alors dans la fentre de
droite : il commence par Sub Imprimer(). (Fig.91).
hh. Modifiez le code (comme dans un traitement de texte) comme indiqu
la figure 92. Vous navez qu rajouter ce qui est encadr en rouge.
ii. Enregistrez le code en cliquant sur la disquette
ou sur Fichier,
Enregistrer (voir
Fig.91).
jj. Testez : on vous
demande de
confirmer : si
vous tapez O ,
limpression se
lance. Sinon, rien ne se produit.

Fig. 86
Fig. 87
Fig. 88
Fig. 89
Fig. 90
Fig. 91
28/28 Formation Excel 2003

28/28
2005 O.J accomard











kk. Des centaines dinstructions sont possibles, y compris la lecture ou lcriture dans des cases du
tableur. Pour explorer le langage VBA pour Excel, je vous renvoie laide de ce langage (le
point dinterrogation), car le sujet est trop vaste pour tre trait ici.







Fig. 92