Vous êtes sur la page 1sur 6

Premire S2 TP Info : Polynmes du second degr 2010-2011 Algorithme pour dterminer les solutions d'une quation du second degr

On se propose d'crire un algorithme permettant de dterminer des valeurs approches des solutions (ventuelles) d'une quation du second degr et d'implmenter cet algorithme avec AlgoBox ou sur une calculatrice scientifique. On considre le polynme du second degr P(x) = ax + bx + c. On se propose de rsoudre l'quation P(x) = 0 1) Ecriture de l'algorithme a) Quels sont les paramtres en entre de l'algorithme ? b) A l'aide de quelle structure algorithmique, peut-on traiter la discussion sur le de nombre de solutions de l'quation ? c) Proposer un algorithme rpondant au problme pos. 2) Implmentation sous AlgoBox a) Implmenter l'algorithme propos l'aide d'AlgoBox b) Le tester pour rsoudre les quations suivantes : 3x + 9x - 30 = 0 x + 3x - 2 = 0 3x + x + 2 = 0 49x - 14x + 1 =0 Quelle est la diffrence pour les solutions obtenues pour la premire quation par rapport celles de la deuxime quation ou la quatrime quation ? c) Donner les solutions relles exactes des quations ayant des solutions. 3) Implmentation de l'algorithme sur une calculatrice graphique a) Implmenter l'algorithme sur une calculatrice programmable. b) Tester le programme avec les mmes quations que dans la question 2) b). 4) Comparaison avec un logiciel de calcul formel Rsoudre les quations prcdentes l'aide du logiciel XCas et de la commande resoudre et expliquer les diffrences obtenues avec AlgoBox ou la calculatrice. 4) Prolongement possible Expliquer comment adapter l'algorithme prcdent pour dterminer les valeurs exactes d'une quation de la forme ax + bx + c = 0 dans le cas o a, b et c sont des entiers.

Premire S TP Info : Polynmes du second degr Algorithme pour dterminer les solutions d'une quation du second degr CORRECTION 1) a) Les paramtres en entre de l'algorithme sont les trois coefficients a, b et c. b) Le nombre de solutions de l'quation du second degr dpend du signe du discriminant. On dtermine le nombre de solutions de l'quation l'aide d'une structure : "Si . alors . Sinon .. finSi" c) Dbut algorithme quation second degr Donnes : a, b ,c : paramtres delta : discriminant de l'quation x1,x2 : les solutions ventuelles de l'quation Traitement Lire a,b,c delta = b*b - 4*a*c Si delta < 0 alors afficher "Pas de solution" sinon Si delta = 0 alors x1 prend la valeur -b/2/a Afficher "une solution double : " + x1 sinon x1 prend la valeur (-b - racine(delta))/2/a x2 prend la valeur (-b + racine(delta))/2/a Afficher "deux solutions distinctes " + x1 + " et " + x2 finsi finsi fin algorithme

Premire S TP Info : Polynmes du second degr Algorithme pour dterminer les solutions d'une quation du second degr CORRECTION 2) a) resolution_equation_second_degre 08.08.2010

****************************************** Algorithme qui rsout (en donnant des valeurs approches des solutions ventuelles) une quation du second degr de la forme ax + bx + c = 0 o a, b et c sont des coefficients rels. ****************************************** 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 VARIABLES a EST_DU_TYPE NOMBRE b EST_DU_TYPE NOMBRE c EST_DU_TYPE NOMBRE delta EST_DU_TYPE NOMBRE x1 EST_DU_TYPE NOMBRE x2 EST_DU_TYPE NOMBRE DEBUT_ALGORITHME LIRE a LIRE b LIRE c delta PREND_LA_VALEUR b*b-4*a*c SI (delta<0) ALORS DEBUT_SI AFFICHER "Pas de solution" FIN_SI SINON DEBUT_SINON SI (delta==0) ALORS DEBUT_SI x1 PREND_LA_VALEUR -b/2/a AFFICHER "Une solution relle double : " AFFICHER x1 FIN_SI SINON DEBUT_SINON x1 PREND_LA_VALEUR (-b - sqrt(delta))/2/a x2 PREND_LA_VALEUR (-b + sqrt(delta))/2/a AFFICHER "Deux solutions relles : " AFFICHER x1 AFFICHER " et " AFFICHER x2 FIN_SINON FIN_SINON FIN_ALGORITHME b) 3x + 9x - 30 = 0

Premire S TP Info : Polynmes du second degr Algorithme pour dterminer les solutions d'une quation du second degr CORRECTION x + 3x - 2 = 0

3x + x + 2 = 0

49x - 14x + 1 =0

Les solutions donnes par AlgoBox pour l'quation 1 sont des solutions exactes tandis que pour les quations 2 et 4 ce sont des valeurs approches des solutions exactes. c) Pour l'quation 2 : x + 3x - 2 = 0 = 3 - 41(-2) = 17 Les deux solutions relles sont : -3 - 17 -3 + 17 -3,56 et 0,56. 2 2

Pour l'quation 4 : 49x - 14x + 1 = 0 = (-14) - 449 = 0 Une solution relle double : 14 1 = 0,14 249 7

Premire S TP Info : Polynmes du second degr Algorithme pour dterminer les solutions d'une quation du second degr CORRECTION 3) Programme pour calculatrices TI* : :Input A :Input B :Input C :B*B -4*A*C :If D < 0 :Then :Disp "Pas de solution reelle" :Else :If D = 0 :Then :-B/2/A X D

:Disp "Une solution reelle double : ",X :Else :(-B :(-B + D)/2/A D)/2/A X Y

:Disp "Deux solutions reelles : ",X,Y :End :End 4) Avec Xcas :

XCas fournit les valeurs exactes des solutions. C'est pour cela que l'on dit que c'est un logiciel de calcul formel.

Premire S TP Info : Polynmes du second degr Algorithme pour dterminer les solutions d'une quation du second degr CORRECTION 4) Il faudrait implmenter la simplification des racines carres (par exemple partir de la dcomposition d'un entier en produit de facteurs premiers) ainsi que la simplification des fractions en fraction irrductible ( partir du calcul du PGCD par exemple).