Vous êtes sur la page 1sur 0

FRECON Mathieu Dcembre 2006

ORAND Nicolas




Projet de Master 2 SIR
2006/2007







- GIGA ROUTEUR -






















M. Frecon & N. Orand Giga-Routeur Page 2 sur 24


Caractristiques du document

Rdacteur(s) :
Mathieu FRECON
Nicolas ORAND

Historique :
Version 1 : 12 dcembre 2006

Rfrence du document :
Rapport_TER_GigaRouteur_Frecon_Orand_2006.pdf

Nombre de pages : 24

Tables des matires

1. Prsentation du projet ________________________________________________________ 3
2. Introduction sur les gigas routeurs _____________________________________________ 4
2.1 Historique des rseaux backbones_________________________________________________ 4
2.2 Pourquoi des gigas routeurs ?______________________________________________________ 5
2.3 Enjeux conomiques & March Vis _______________________________________________ 5
3. Les Rseaux Optiques ________________________________________________________ 6
3.1 SONET/ SDH______________________________________________________________________ 6
3.2 DWDM ___________________________________________________________________________ 7
4. Acheminement des donnes travers les gigas routeurs _______________________ 9
4.1 MPLS_____________________________________________________________________________ 9
4.2 La gestion des liens MPLS : LMP (Link Management Protocol) _______________________ 12
4.3 Le routage dans MPLS____________________________________________________________ 13
5. Un peu de Technique______________________________________________________ 16
5.1 Comment configurer un giga routeur______________________________________________ 16
5.2 Autres configurations_____________________________________________________________ 19
5.3 Performances de certains matriels_______________________________________________ 20
6. Conclusion__________________________________________________________________ 20
7. Annexes ____________________________________________________________________ 22
7.1 Bibliographie ____________________________________________________________________ 22
7.2 Fichiers de configuration_suite____________________________________________________ 23

M. Frecon & N. Orand Giga-Routeur Page 3 sur 24










1. Prsentation du projet

La croissance soutenue que connat le rseau Internet depuis plusieurs annes et sa
transformation en infrastructure commerciale ont fait passer Internet du statut de rseau de
donnes universitaire celui dinfrastructure de communication globale. Cette volution
soulve de nombreux problmes techniques, parmi lesquels notamment une croissance
exponentielle du trafic transport par les rseaux IP.

Le dveloppement des tlcommunications est de plus en plus rapide ces dernires
annes, entranant une volution constante des rseaux mtropolitains. Les services haut
dbit deviennent indispensables pour satisfaire les besoins croissants des usagers. Les rseaux
informatiques existants sont confronts un grand dfi. Aprs les rseaux ATM 155 Mbps, les
rseaux tout optiques sont proposes pour offrir la possibilit de trs haut dbit, quelques
centaines de giga bits par seconde.

Le march des entreprises est particulirement concern par ce mouvement de
croissance. Aujourdhui, plus dune entreprise franaise sur deux est connecte Internet.
Les socits utilisent galement de plus en plus de services forte valeur ajoute intgrant
voix/donnes/multimdia et ncessitant une forte capacit de transmission. Tous ces
facteurs contribuent intensifier le besoin dvolution des matriels actifs vers de hautes
performances.

Nous commencerons par prsenter les giga routeurs, point fort des rseaux hauts
dbits, puis les technologies optiques des giga routeurs, la mthode dacheminement de
donnes et enfin une technique de configuration des giga routeurs.

M. Frecon & N. Orand Giga-Routeur Page 4 sur 24


2. Introduction sur les gigas routeurs
2.1 Historique des rseaux backbones

La technologie ATM a t adopte par l'Union Internationale des
Tlcommunications (UIT) la fin des annes 80 pour rpondre la demande des oprateurs
de tlcommunication d'un Rseau Numrique Intgration de Service Large Bande
unifiant dans un mme protocole leurs mcanismes de transport des donnes, d'images et
surtout de la voix, et garantissant la qualit de service. Les mcanismes propres aux donnes
ont ensuite t affins par l'ATM Forum pour tre utilisables dans les rseaux locaux et les
rseaux longue distance lorsque les dbits excdent 34 ou 43 Mbit/ s en insrant ATM entre IP
et SDH.

IP sur ATM est - dfaut d'alternative - l'approche privilgie dans les rseaux IP
oprationnels aux Etats-Unis (SprintLink, UUnet) entre 1994 et 1998 pour des dbits de 155 puis
622 Mbit/s.
C'est sur des prvisions qui, l'poque, voyaient dans l'augmentation du trafic tlphonique
la source principale de croissance que se sont bass les oprateurs existants de
tlcommunication, aux Etats-Unis et surtout en Europe, pour investir massivement dans ATM
comme technologie de leurs rseaux 155 Mbit/s partir de la premire moiti des annes
90. Malheureusement, si ATM est appropri lorsque le trafic est constitu majoritairement de
voix, il est inadapt lorsque le trafic est majoritairement constitu de donnes, ce qui est et
sera de plus en plus le cas avec l'explosion du trafic li l'Internet.

Une opportunit stratgique apparat, favorable aux oprateurs mergents qui
s'appuient sur une unification autour de IP, rput plus adapt au transport de donnes. Les
oprateurs historiques se trouvent pris en porte--faux par des investissements levs et des
offres inadaptes.
Pour adjoindre - rcemment - IP les mcanismes propres garantir la qualit de service, les
ingnieurs et chercheurs dfinissent l'IETF des mcanismes internes au rseau, tels que
rservation de ressources ou contrle adaptatif dans le protocole TCP, dans les applications
de diffusion et dans les routeurs d'extrmit.

Dans le mme temps, l'augmentation des fonctionnalits de commutation ralisables
directement de manire optique conduira terme IP tre le protocole unique, soit
directement sur fibre optique 40 Gbit/s et au del, soit sur de multiples sous canaux (WDM)
des dbits binaires moins levs (2,5 et 10 Gbit/s).
C'est l'approche favorise outre-atlantique par les oprateurs mergents pour les dbits
dpassant le Gbit/s (Qwest, Level3, IXC, et Sprint).

Dans le mme temps, l'ATM Forum effectue un travail de mme type pour assurer le transport
par ATM de tout type de protocole (Multi Protocol Over ATM, MPOA). Cette initiative est
complmentaire de la volont de la communaut de l'ATM Forum de mieux prendre en
compte le phnomne IP sous peine pour ATM d'tre remis en cause par d'autres solutions
comme le Gigabit.

M. Frecon & N. Orand Giga-Routeur Page 5 sur 24

Voici lvolution de lInternet :


Figure 1 : volution des technologies employes dans lInternet.

2.2 Pourquoi des gigas routeurs ?

Afin damliorer les capacits de commutation au sein des rseaux fdrateurs, les
entreprises comme Cisco ou Alcatel se sont lances dans des mthodes de commutation
pouvant atteindre plusieurs dizaine de Gbps. Ce qui a pouss le dveloppement des gigas
routeurs afin de permettre une plus grande commutation au cur du rseau.

2.3 Enjeux conomiques & March Vis

a) Enjeux conomiques

Un des enjeux majeur est le partage rapide des donnes et le contrle de site distant
d la dlocalisation des entreprises. De plus la mondialisation joue un rle important sur le
dveloppement des mthodes de communication dans un seul et unique but le profit.

b) Next Generation Networking (NGN)

NGN, pour Next Generation Network est une nouvelle architecture de rseau de
communication. Le principe est dutiliser les technologies de transport en mode paquet,
rserv jusqualors pour les donnes, pour transporter lensemble des services de
tlcommunications. De plus, on spare les interfaces des diffrentes couches du rseau de
communication (transport, commande et applications), pour permettre une volutivit plus
importante du rseau. Enfin, NGN utilise les nouvelles technologies paquets pour proposer
des services hauts dbits.
Avec NGN, lobjectif est donc de disposer dun rseau unique pour lensemble des
services, alors, quactuellement, il existe pratiquement un rseau par type de service.
En effet, les services voluent beaucoup plus vite que les infrastructures de transport. Or, la
couche transport constitue le gros des investissements. Il est donc important de ne pas
remettre en cause les investissements de la couche transport lorsque que lon veut changer
un service.

Aujourdhui, cest lxDSL qui joue ce rle sur la ligne de cuivre ou encore la fibre
optique dans les pays en voie de dveloppement. LxDSL, ntant pas vraiment rentable
pour un simple accs Internet haut dbit, il sagit dapporter de nouveaux services exploitant
les possibilits de cette technologie.


M. Frecon & N. Orand Giga-Routeur Page 6 sur 24

Larchitecture NGN a aussi de nombreuses applications au niveau du rseau daccs.
La premire dentre elles est le remplacement des commutateurs tlphoniques existants.
La deuxime application est la possibilits de mettre en place de nouvelles offres de services
(l encore, on retrouve les deux filires : la tlphonie pour les remplacement de CAA
existants et le multimdia).
Enfin, le gros du march devrait se situer au niveau des services l'accs avec le
dveloppement des services multimdias avec garantie de qualit de service, mettant
profit les accs hauts dbit.

3. Les Rseaux Optiques


Les intrts de ce procd de transmission par fibre optique, sont nombreux :

- perte de signal sur une grande distance bien plus faible que lors d'une transmission
lectrique dans un conducteur mtallique,
- vitesses de transmission trs leves,
- poids au mtre faible (c'est important, aussi bien pour rduire le poids qu'exercent
les installations complexes dans les btiments, que pour rduire la traction des longs cbles
leurs extrmits),
- insensibilit aux interfrences extrieures (proximit d'un non ou d'un cble haute
tension, par exemple),
- pas d'chauffement ( haute frquence le cuivre chauffe, il faut le refroidir pour
obtenir des dbits trs levs).

3.1 SONET / SDH

La demande croissante de la part des oprateurs pour de nouveaux services de
Tlcom large bande a t l'origine des travaux sur les rseaux optiques synchrones ds
1984. Les premiers rsultats concernant les rseaux optiques synchrones (SONET : Synchronous
Optical NETwork) ont t publis aux Etats-Unis fin 1986, l'initiative de BELLCORE (BELL
COmmunication REsearch).
Toute la difficult de la normalisation a t de trouver un compromis entre les intrts
amricains, europens et japonais afin de garantir l'interconnexion des diffrents rseaux des
oprateurs.
C'est finalement un dbit de 51,84 Mb/s qui a t retenu pour former le premier niveau : STS -
1 (Synchronous Transport Signal, level 1). Les niveaux au-dessus du niveau 1 (STS - n) sont des
multiples du niveau de base.
C'est en 1988, que des accords internationaux ont abouti une nouvelle srie de
recommandations :
- G.707 (Synchronous digital bit rate),
- G.708 (Network Node Interface for the synchronous digital hierarchy),
- G.709 (Synchronous multiplexing structure).
Ces accords sur la SDH furent ratifis par le CCITT, en 1988.

Pour la norme SONET, les niveaux sont classs en OC : Optical Container.
Pour la norme SDH, les niveaux sont organiss hirarchiquement en STM - n (Synchronous
Transport Module, niveau n).





M. Frecon & N. Orand Giga-Routeur Page 7 sur 24
La hirarchie de la norme SDH correspond celle de SONET pour les interfaces ATM.
Le niveau 1 de SDH (155,52 Mb/s) est le niveau 3 de SONET et le niveau 2 de SDH (622,08
Mb/s) est le niveau 12 de SONET.

SDH SONET Dbit
STM 1 OC 3 155 Mb/ s
STM 4 OC 12 622 Mb/ s
STM 16 OC 48 2.5 Gb/ s
STM 64 OC 192 10 Gb/s
STM 128 OC 384 20 Gb/s
STM -256 OC -768 40 Gb/s

Les rseaux SDH les plus dploys sont aujourd'hui des rseaux combinant les niveaux STM 1,
STM 4 et STM 16. Du ct rseau d'oprateur, les agrgats, du ct rseau d'abonn, les
affluents :

Figure 2 : architecture de raccordement en SDH.


Les principaux avantages de la technologie SDH par rapport aux systmes traditionnels PDH
concernent :

- la normalisation internationale,
- la fiabilit des transmissions ralises (possibilit de reconfiguration automatique pour
les systmes double cheminement),
- le prix de revient du Mb/s transmis,
- l'exploitation distance des quipements et la supervision du rseau,
- la flexibilit et l'volutivit du rseau.


3.2 DWDM

Alors que les systmes de transmission ne reposaient que sur l'utilisation du
multiplexage temporel (ou TDM pour Time Division Multiplexing), pour la transmission de 155
Mb/ s, 622 Mb/ s, 2,5 Gb/ s, 10 Gb/s, 40 Gb/ s sur une seule longueur d'onde, une nouvelle
gnration de systmes est apparue au dbut des annes 90, mettant en oeuvre le
multiplexage de longueurs d'onde (ou WDM pour Wavelength Division Multiplexing).

La technologie WDM est ne de l'ide d'injecter simultanment dans la mme fibre
optique plusieurs trains de signaux numriques la mme vitesse de modulation, mais
chacun une longueur d'onde distincte.


M. Frecon & N. Orand Giga-Routeur Page 8 sur 24
A l'mission, on multiplexe n canaux au dbit nominal D, la rception, on
dmultiplexe le signal global n x D en n canaux nominaux.
La recommandation internationale ITU-T G.692 (Interfaces optiques pour systmes multi-
canaux avec amplificateurs optiques) a dfini un peigne de longueurs d'onde autorises
dans la seule fentre de transmission 1530-1565 nm. Elle normalise l'espacement en
nanomtre (nm) ou en Gigahertz (GHz) entre deux longueurs d'onde permises de la fentre :
200 GHz ou 1,6 nm et 100 GHz ou 0,8 nm.

La technologie WDM est dite dense (DWDM) lorsque l'espacement utilis est gal ou infrieur
100 GHz. Des systmes 50 GHz (0,4 nm) et 25 GHz (0,2 nm) permettent d'obtenir
respectivement 80 et 160 canaux optiques.
Pour des espacements encore plus faibles, on parlera de U-DWDM : Ultra - Dense
Wavelength Division Multiplexing. Ainsi, des systmes 10 GHz (0,08) permettent d'obtenir 400
canaux optiques.

Les systmes WDM / DWDM les plus commercialiss aujourd'hui comportent 8, 16, 32, 80
canaux optiques, ce qui permet d'atteindre des capacits de 80, 160, 320, 800 Gb/ s en
prenant un dbit nominal de 10 Gb/s. On peut atteindre une capacit de 4 000 Gb/s (4
Tbps) avec 400 canaux optiques 10 Gb/s, en technologie U-DWDM.

Figure 3 : principe dune liaison WDM/ DWDM

Rappel sur DWDM
Nombre de canaux J usqu' 300
Espace inter-canaux 0.8 0.2 nm
Dbit par longueur donde 10 40 Gb/ s


Cependant, les technologies DWDM et U-DWDM n'ont pas encore atteintes leurs
limites. De nouvelles techniques en cours de dveloppement permettront de multiplier
encore plus les capacits des systmes optiques :

- la transmission soliton permettant le transport d'impulsions trs troites sur des milliers
de Km sans dformation, tout en conservant une bande passante trs large,
- la modulation des impulsions, ou transmission duo-binaire, permettant la
multiplication par deux ou trois fois du dbit lectronique, en utilisant des impulsions
2 ou 3 niveaux binaires,
- l'amplification et le multiplexage dans la fentre 1300 nm permettant de mieux
rentabiliser les fibres optiques conventionnelles G652 qui connaissent des limites dans
l'utilisation des systmes DWDM 1550 nm.







M. Frecon & N. Orand Giga-Routeur Page 9 sur 24
4. Acheminement des donnes travers les gigas routeurs


Nous avons vu, grce aux parties prcdentes que le dbit dinformation navait de
cesse daugmenter ces dernires annes. Il a donc fallut mettre en place des protocoles
dacheminement des donnes pouvant supporter de tels dbits.
Cest pour cela que plusieurs techniques rseaux dont le rle principal sont de combiner les
concepts de routage IP de niveau 3, et les mcanismes de commutation de niveau 2 ont t
normaliss par lIETF.

Aperu des protocoles que nous allons traiter :
Evolution du Standard MPLS
1
re
Etape : MPLS (Multi Protocol Label Switching)
o Bas sur le trafic IP
o Ajout du service Traffic Engineering (MPLS-TE 2
me
tape)

3
me
Etape : MPS (Multi Protocol Lambda Switching)
o Bas sur les longueurs dondes
o Ajout dun nouveau protocole, LMP (Link Management
Protocol) pour la gestion des liens et des erreurs.

4
me
Etape : GMPLS (Generalized MPLS)
o Extension de MPLS-TE qui permet aux LSR de supporter
plusieurs types de commutation, Paquets, TDM
(SDH/SONET), Lambdas, Fibres
o Gnralisation de la dfinition d'un label
o Ajout de la signalisation via le protocole RSVP-TE
(ReSerVation Protocol Traffic Engineering)
o Amlioration des protocoles de routage pour dcrire la
topologie du rseau : OSPF et IS-IS
IETF
46-48
IETF
48-49
IETF
52-55+



4.1 MPLS

a) Introduction

Le MPLS (Multi Protocol Label Switching) est une technique rseau permettant aux
oprateurs tlcoms d'amliorer l'utilisation de leurs routeurs et l'efficacit du routage tout en
aidant garantir des niveaux de services sur un rseau IP en mode non connect. Le MPLS
s'impose dans le cur de rseau des oprateurs comme une technique simple permettant
de s'affranchir du type de protocole utilis (Ethernet, PPP, SDH ou ATM).

b) Fonctionnement

Le MPLS se substitue au routage classique o chaque paquet IP dispose pour
s'orienter de l'adresse du prochain routeur qu'il doit traverser et de celle qu'il vient de
traverser. Cette mthode traditionnelle de transmission a pour but de fluidifier le trafic sur
Internet en s'assurant de tracer le chemin le plus court d'un point un autre. Pour cela, elle


M. Frecon & N. Orand Giga-Routeur Page 10 sur 24
s'appuie sur la table de routage des diffrents switchs que les paquets traversent. Ce sont eux
qui, par le biais de trames rseaux, dterminent quels sont les routeurs les plus proches d'eux.
Avec le MPLS, l'en-tte du paquet IP dispose d'un champ particulier baptis "label".
Renseigne, cette valeur dfinit la classe de services laquelle le paquet appartient, afin de
rediriger ce dernier vers un routeur d'une mme classe. C'est aussi travers de ce label que
les oprateurs garantissent que les prochains paquets IP appartenant au mme message
parviendront leurs destinataires toujours par le mme chemin.

c) Principe

Premirement, au niveau du fonctionnement du routage, le MPLS s'avre plus
conomique en ressources machines que les mthodes de routage ordinaires. Dans un
schma classique, chaque nud d'un rseau occasionne pour un paquet IP le changement
des valeurs indiquant le routeur source et le routeur cible. A l'inverse, avec le MPLS, seuls les
routeurs en bordure de rseau (ceux assurant la connexion entre les rseaux WAN et les
rseaux MAN ou LAN) interviennent dans le calcul du chemin.


Figure 4 : topologie basique dun rseau MPLS


Au niveau d'un LSR (Label Switch Router) du nuage MPLS, la permutation d'tiquette
est ralise en analysant une tiquette entrante, qui est ensuite permute avec l'tiquette
sortante et finalement envoye au saut suivant.
Les tiquettes ne sont imposes sur les paquets qu'une seule fois en priphrie du rseau
MPLS au niveau du Ingress E-LSR (Edge Label Switch Router) o un calcul est effectu sur le
datagramme afin de lui affecter un label spcifique. Ce qui est important ici, est que ce
calcul n'est effectu qu'une seule fois (ie, la premire fois que le datagramme d'un flux arrive
un Ingress E-LSR). Ce label est supprim l'autre extrmit par le Egress E-LSR.
Donc le mcanisme est le suivant : Le Ingress LSR (E-LSR) reoit les paquets IP, ralise une
classification des paquets, y assigne un label et transmet les paquets labelliss au nuage
MPLS. En se basant uniquement sur les labels, les LSR du nuage MPLS commutent les paquets
labelliss jusqu' l'Egress LSR qui supprime les labels et remet les paquets leur destination
finale.
L'affectation des tiquettes aux paquets dpend des groupes ou des classes de flux FEC
(Forwarding Equivalence Class). Les paquets appartenant une mme classe FEC sont
traits de la mme manire. Le chemin tabli par MPLS appel LSP (Label Switched Path) est
emprunt par tous les datagrammes de ce flux.
L'tiquette est ajoute entre la couche 2 et l'en-tte de la couche 3 (dans un environnement
de paquets) ou dans le champ VPI/ VCI (identificateur de chemin virtuel/identificateur de
canal virtuel dans les rseaux ATM). Le LSR du nuage MPLS lit simplement les tiquettes,
applique les services appropris et redirige les paquets en fonction des tiquettes. Ce
schma de consultation et de transfert MPLS offre la possibilit de contrler explicitement le
routage en fonction des adresses source et destination, facilitant ainsi l'introduction de
nouveaux services IP.




M. Frecon & N. Orand Giga-Routeur Page 11 sur 24
d) Son architecture

Larchitecture de la technologie MPLS est constitue dun plan de contrle et dun
plan de donnes (control plane et data plane). Dans MPLS, les flux de donnes du plan de
contrle et du plan de donnes sont logiquement spars.


Figure 5 : sparation du plan de contrle et du plan de data dans MPLS

Le plan de contrle est compos par lensemble des protocoles de signalisation et des
protocoles de routage appartenant chacun au plan de signalisation et au plan de routage.
Le plan de contrle est responsable de la construction, de la maintenance des tables
dacheminement (Forwarding Tables) et est responsable de la communication inter-noeuds
(LSR) afin de dissminer les informations concernant le routage.
- Les protocoles de signalisation utiliss sont CR-LDP ou RSVP-TE si lon prend en
considration les problmes de Traffic Engineering.
- Les protocoles de routage sont quant eux OSPF-TE ou IS-IS-TE.

Le plan de data est responsable de transporter les paquets commuts travers le rseau en
se basant sur les Forwarding Tables . Il correspond lacheminement des donnes en
accolant un label aux paquets arrivant dans le domaine MPLS.


e) Ses utilisations

L'une des premires utilisations de cette solution rseau tient - pour les oprateurs
tlcoms - une meilleure utilisation de leurs ressources. En effet, la mthode de routage de
l'IP laisse parfois des liens entre deux switchs sous-utiliss tandis que d'autres routes risquent la
saturation. Avec le MPLS, les oprateurs peuvent forcer l'utilisation des liens peu exploits.

En crant un chemin prdfini pour toute la communication, les oprateurs peuvent aussi
utiliser le MPLS pour gnrer des rseaux privs virtuels (VPN) sur leur rseau. Le systme de
niveau de service implant dans MPLS s'avre bien adapt aux applications multicast, aux
services de voix sur IP, de vido la demande ou d'hbergement de services Web.

f) Son futur

Il se nomme GMPLS ou Generalized MPLS. L'objectif du GMPLS est de transmettre non
plus uniquement des paquets mais aussi des circuits (la voix par exemple) o le flux
d'informations est variable mais la connexion ininterrompue. Le GMPLS pourrait ainsi
augmenter la qualit de service de la voix sur IP longue distance ou d'autres applications
ncessitant encore aujourd'hui des liaisons point point.


M. Frecon & N. Orand Giga-Routeur Page 12 sur 24
4.2 La gestion des liens MPLS : LMP (Link Management Protocol)

NB : Notions de Link Building :
Le concept de Link Bundling a donc pour but de grouper et de mapper les
informations relatives certaines ressources physiques (et leurs proprits) dans des
informations qui pourront tre utilises facilement par le protocole de routage pour calculer
les routes et par la signalisation de GMPLS. Cela amliorera la scalabilit du routage en
rduisant la quantit dinformations devant tre gres par le protocole de routage.


Tous les Component Link dun mme Bundled Link doivent commencer et se
terminer au niveau de la mme paire de LSR. Ils doivent aussi avoir en commun quelques
caractristiques ou proprits, comme par exemple tre du mme type ou partager les
mmes contraintes administratives (TE-metrics).

Afin de rpondre au besoin de manager les diffrents liens dans un fibre (avec
lutilisation de la technologie optique DWDM) entre deux LSR, MPS va utiliser un nouveau
protocole : LMP.
LMP correspond un ensemble de procdures qui seront utiles localement pour rendre
certains services comme :

- le management des canaux de contrle (Control Channel Management) :
Il est utilis pour tablir et pour maintenir les canaux de contrle entre les noeuds. Une fois
que le canal de contrle est configur entre deux noeuds adjacents, cest le protocole
Hello qui va tre utilis pour tablir et maintenir la connectivit entre ces deux noeuds et
pour dtecter les problmes. Cela se droule en deux phases : une phase de ngociation et
une phase keep-alive .

- la vrification de la connectivit des liens (Link Connectivity Verification) :
La vrification de la connectivit des liens est une procdure qui est utilise pour vrifier la
connectivit physique des liens de donnes (cest dire, les components links dun
bundle) et pour changer les identifiants sur ces Component Links .

- la corrlation de la proprit des liens (Link Property Correlation) :
Un mcanisme dchange des proprits dun lien permet de regrouper plusieurs
Component Links dans un seul et mme Bundled Link ou dajouter un Component
Link un Bundled Link . Cette fonctionnalit permet aussi de modifier dynamiquement
certaines caractristiques du lien, comme par exemple, changer les mcanismes de
protection dun lien ou changer les identifiants de ports.

- le management de lincident (Fault Management) :
Le Fault Management est une vraie exigence dun point de vue oprationnelle. Il comprend
de manire gnrale : la dtection de lincident, la localisation de lincident et la notification
de lincident.
Lorsquun incident survient et est dtect (fault detection), loprateur a besoin de savoir
exactement o cela sest produit (fault localization) et le noeud lorigine du signal doit tre
averti de manire prendre les mesures adquates (fault notification).


M. Frecon & N. Orand Giga-Routeur Page 13 sur 24
4.3 Le routage dans MPLS

Nous avons vu que le label switching seffectuait partir des informations prsentes
dans les Forwarding Tables . Nous allons voir maintenant comment ces tables sont
construites.
Un protocole de distribution des labels est un ensemble de procdures par lesquelles un LSR
en informe un autre des affectations label/ FEC quil a faites. On dit que deux LSR sont en
label distribution peers lorsquils utilisent un protocole de distribution de label pour
changer leurs affectations label/FEC.

Il peut tre souhaitable de rajouter dautres fonctionnalits un protocole de
distribution des labels, comme par exemple le fait de pouvoir aussi slectionner et rserver
des ressources dans le rseau le long dun LSP. Pour cela il y a deux manires de procder,
dcrite dans GMPLS, qui sont dutiliser :
- un protocole servant dj la rservation de ressources et ltendre afin quil puisse
aussi faire de la distribution de labels (RSVP-TE).
- un protocole servant lorigine la distribution de labels et ltendre afin quil
puisse aussi faire de la rservation de ressources (LDP tendu en CR-LDP).


a) Routage implicite : LDP (Label Distribution Protocol)

LDP dfinit une suite de procdures et de messages utiliss par les LSR pour s'informer
mutuellement du mapping entre les labels et le flux. Les labels sont spcifis selon le chemin
Hop By Hop dfini par l'IGP (Interior Gateway Protocol) dans le rseau. Chaque noeud
doit donc mettre en oeuvre un protocole de routage de niveau 3, et les dcisions de
routage sont prises indpendamment les unes des autres.

LDP est bidirectionnel et permet la dcouverte dynamique des noeuds adjacents
grce des messages Hello changs par UDP. Une fois que les 2 noeuds se sont
dcouverts, ils tablissent une session TCP qui agit comme un mcanisme de transport fiable
des messages d'tablissement de session TCP, des messages d'annonce de labels et des
messages de notification.

NB : Limitation du routage classique
Supposons que lon veuille mettre en place un LSP entre A et E et un autre entre F et I.
Pour ce faire, LDP et OSPF (Open Shortest Path First) seront utiliss.



Le LSP entre A et E sera A-B-C-D-E (suivant OSPF).
Le LSP entre F et I sera F-B-C-D-I (suivant OSPF).
La bande passante entre B et G, G et H, et H et D ne sera pas utilise. Les liens entre B et C et
entre C et D, seront quant eux surexploits.
Avec le routage OSPF, rsultant de la minimisation des mtriques, les LSP sont tablis sans
tenir compte de la charge du rseau.



M. Frecon & N. Orand Giga-Routeur Page 14 sur 24
b) Routage explicite : LDP +Traffic Engineering
1

L'Explicit Routing est la solution MPLS pour faire du Traffic Engineering dont l'objectif est
le suivant :
- utiliser efficacement des ressources du rseau
- viter les points de forte congestion en rpartissant le trafic sur l'ensemble du
rseau. En effet, le plus court chemin dtermin par le routage classique IP pour
atteindre une destination peut ne pas tre le seul chemin possible et certains chemins
alternatifs peuvent tre sous-utiliss alors que le plus court chemin est surexploits.

L'Explicit Routing permet un oprateur de faire du Traffic Engineering en imposant
au rseau des contraintes sur les flux, du point source jusqu'au point destination. Ainsi, des
routes autres que le plus court chemin peuvent tre utilises. Le rseau dtermine lui-mme
le chemin en suivant les tapes ci-dessous :

- connaissance de l'tat du rseau :
Topologie, bande passante relle d'un lien, bande passante utilise, bande passante
restante. Des extensions ont t apportes aux protocoles de routage OSPF et IS-IS car la
distribution dynamique des bases de donnes tait limite aux noeuds adjacents et une
seule mtrique.

- calcul d'un chemin rpondant aux contraintes spcifies. Les extensions d'OSPF et
d'IS-IS sont ncessaires.

- tablissement du ER-LSP (Explicitly Routed Path) :
La source connat le chemin complet de l'ingress node l'egress node et c'est elle qui
spcifie les LSR l'intrieur du LSP. Deux options de signalisation spcifies pour
l'tablissement du LSP : RSVP-TE (ReSerVation Protocol Traffic Engineering) ou CR-LDP
(Constraint-Based Routing LDP).
CR-LDP est l'alternative RSVP; il est jug plus fiable dans la mesure o il met en oeuvre TCP
(orient connexion). De plus, CR-LDP peut inter-fonctionner avec LDP et utilise les messages
LDP pour signaler les diffrentes contraintes. Les fonctions de CR-LDP sont ralises par des
instructions matrielles ASIC (Application Specific Interface Circuits) ne ncessitant pas de
frquents rafrachissements, contrairement RSVP dont les fonctions sont ralises par le
logiciel.

- envoi du trafic sur le chemin trouv.

- supervision de l'tat des LSP et le transmet l'IGP.

- r-optimisation des LSP quand ncessaire.

Reprise de lexemple prcdent :



1
Traffic Engineering : fonctions rseaux grant la bande passante, la QoS, les VPN...


M. Frecon & N. Orand Giga-Routeur Page 15 sur 24

Avec Explicit Routing , il est possible de slectionner une autre route pour le LSP entre F et I,
celle passant par G et H et le problme rsoudre revient mettre en place un LSP en
minimisant les mtriques et en prenant en compte les contraintes attaches la route.

M. Frecon & N. Orand Giga-Routeur Page 16 sur 24

5. Un peu de Technique

5.1 Comment configurer un giga routeur

Dans cette partie, nous allons vous expliquer comment intgrer les protocoles vus
prcdemment pour pouvoir amliorer les performances gnrales de votre rseau.
Bien videmment cette mthode peut sappliquer sur nimporte quels types de routeur assez
volus.
NB : nous prendrons comme exemple les routeurs Cisco voluant sous lIOS 12.2 et plus
rcente.
En effet, le protocole MPLS ne sapplique pas forcment sur des giga routeurs. Les seules
diffrences sont que les giga routeurs ont une matrice de commutation plus rapide que les
autres et quils implmentent le protocole dCEF (distributed Cisco Express Forwarding
2
) au
lieu du protocole CEF basique.

Il existe bien sr plusieurs implmentations possibles de ce protocole mais nous allons
vous prsenter son utilisation dans le cadre de cration de tunnels entre ELSR en utilisant le
Traffic Engineering et le routage OSPF.

a) Composants fonctionnels

Description des composants fonctionnels pour cet exemple de configuration :


Composant

Description
Tunnels ou LSP
Couche 2 : configur en fonction de la bande passante
disponible et de sa priorit.
Couche 3 : lien virtuel entre deux ELSR.
RSVP-TE
RSVP est utilis pour tablir et maintenir des LSP en se basant sur
le calcul de chemin et des messages RSVP.
Avec lextension TE, RSVP est aussi utilis pour la distribution des
labels.
Protocole de routage
intrieur (IGP) : OSPF-TE
Utilis pour changer des informations sur la topologie du rseau
calcule en fonction de ltat des liens.
Module MPLS-TE pour le
calcul du chemin
Permet de savoir au dbut du LSP le chemin emprunter (ie,
cest le premier ELSR qui indique le chemin complet).
Module MPLS-TE pour
ltat des liens
Permet lchange dinformations topologique entre chaque saut
avec OSPF laide de messages de signalisations RSVP.
C'est--dire : permet linteraction entre le protocole RSVP (dans
le nuage MPLS) et OSPF (dans le LAN).
Commutation de label Mcanisme basique de commutation de label utilis dans MPLS.

2
Protocole augmentant les performances du point de vue de la commutation de paquets dans
l'quipement.

M. Frecon & N. Orand Giga-Routeur Page 17 sur 24
b) Schma du rseau


c) Configuration rapide

Nous allons utiliser ces diffrentes tapes pour tablir une configuration rapide.

1. Configurer votre rseau de faon habituelle (paramtrage des interfaces, protocole
de routage, adressage). Dans notre cas, les interfaces sries sont configur pour
utiliser Frame Relay.
NB : il est obligatoire de crer une interface de loopback avec un masque de 32 bits.
Elle sera utilise pour la configuration de MLPS et doit tre accessible par la table de
routage globale.
2. Configurer le protocole de routage tat de liens (OSPF) pour MPLS avec les
commandes :
a. mpls traffic-eng area X, o X est le numro didentification du protocole OSPF.
b. mpls traffic-eng router-id LoopbackN o N est le numro de linterface qui est
0 par dfaut (le masque de la loopback doit tre de 255.255.255.255).
3. Activation de MPLS-TE.
a. Entrer ip cef (ou ip cef distributed si le matriel le permet) dans le mode de
configuration gnral.
b. Activer MPLS sur chaque interface concerne (tag-switching ip).
c. Enfin enter mpls traffic-engineering tunnel pour activer MPLS-TE.
4. Activer RSVP en entrant ip rsvp bandwidth XXX sur chaque interface concerne, o
XXX est le cot dun lien entre deux LSR.
5. Etablir les tunnels employer pour le TE. Il y a beaucoup doption possible pour crer
un LSP sous MLPS-TE mais la commande tunnel mode mpls traffic-eng est obligatoire.
Puis la commande tunnel mpls traffic-eng autoroute announce annonce la prsence
dun LSP au protocole de routage.
NB : ne pas oublier dutiliser la commande ip unnumbered loopbackN pour ladresse
IP de linterface dutunnel.




M. Frecon & N. Orand Giga-Routeur Page 18 sur 24

d) Fichiers de configuration pour notre exemple

Nous allons vous montrer seulement un seul fichier permettant dimplmenter notre
exemple (les autres pour la configuration complte seront donns en annexe).
NB : les commandes en bleu font rfrence lactivation de MPLS et les commandes en gras
font rfrences aux options spcifiques du TE.

Fichier pour le routeur Pesaro :

Current configuration:
!
version 12.1
!
hostname Pesaro
!
ip cef
!
mpls traffic-eng tunnels
!
interface Loopback0
ip address 10.10.10.6 255.255.255.255
!
interface Tunnel158
ip unnumbered Loopback0
tunnel destination 10.10.10.4
tunnel mode mpls traffic-eng
tunnel mpls traffic-eng autoroute announce
tunnel mpls traffic-eng priority 2 2
tunnel mpls traffic-eng bandwidth 158
tunnel mpls traffic-eng path-option 1 explicit name low
!
interface Tunnel159
ip unnumbered Loopback0
tunnel destination 10.10.10.4
tunnel mode mpls traffic-eng
tunnel mpls traffic-eng autoroute announce
tunnel mpls traffic-eng priority 4 4
tunnel mpls traffic-eng bandwidth 159
tunnel mpls traffic-eng path-option 1 explicit name straight
!
interface Serial0/0
no ip address
encapsulation frame-relay
!
interface Serial0/0.1 point-to-point
bandwidth 512
ip address 10.1.1.22 255.255.255.252
tag-switching ip
mpls traffic-eng tunnels
frame-relay interface-dlci 603
ip rsvp bandwidth 512 512
!
router ospf 9
network 10.1.1.0 0.0.0.255 area 9
network 10.10.10.0 0.0.0.255 area 9
mpls traffic-eng area 9
mpls traffic-eng router-id Loopback0
!
ip classless
!
ip explicit-path name low enable
next-address 10.1.1.21
next-address 10.1.1.10
next-address 10.1.1.1
next-address 10.1.1.14
!
ip explicit-path name straight enable
next-address 10.1.1.21
next-address 10.1.1.5
next-address 10.1.1.14
!
end


M. Frecon & N. Orand Giga-Routeur Page 19 sur 24

5.2 Autres configurations


Solutions implmenter dans les IOS Cisco :

Exemples de configuration MPLS sous Cisco IOS :
http://www.cisco.com/en/US/tech/tk436/tk428/tech_configuration_examples_list.html

Utilisation spcifique MPLS dveloppe par Cisco, Aleron :
http://www.cisco.com/application/pdf/en/us/ guest/tech/tk428/c1488/ccmigration_09186a0
08019c100.pdf

Mise en place de VPN avec Qos laide de MPLS par la socit BELL au Canada :
http://www.cisco.com/application/pdf/en/us/ guest/tech/tk428/c1488/ccmigration_09186a0
08019c103.pdf

Global One, filiale de France Telecom offrant un service MPLS-VPN pour ses
connectivits WAN :
http://www.cisco.com/application/pdf/en/us/ guest/tech/tk428/c1488/ccmigration_09186a0
08019c104.pdf

Infonet, un ISP international offrant un service global de VPN plus scuris et plus
scalable grce lutilisation de MPLS et de BGP :
http://www.cisco.com/application/pdf/en/us/ guest/tech/tk428/c1488/ccmigration_09186a0
08019c102.pdf



M. Frecon & N. Orand Giga-Routeur Page 20 sur 24

5.3 Performances de certains matriels


Hardware AVICI (TSR)
NEXABIT
(NX64000)
PLURIS (TNR) ARGON (GPN)
TORRENT
(IP9000)
JUNIPER (M40) CISCO (12000)
Internal data format Cells Packets 64 bytes cells Cells Cells 64 bytes cells
Aggregate
Bandwidch
32 Tbits/ s
(14*40*60
Gbits/s)
6.4 Tbits/ s (4*6.4
Gbits/s)
164 Tbits/ s
(128*16*80
Gbits/s)
180 Gbits/s
(8*20 Gbits/ s)
10 Gbit/s
(IP9010)
20 Gbits/ s
(IP9520)
40 Gbits/ s
60 Gbits/ s (4*15
Gbits/s)
Congestion Control RED RED, WRED, RIO a WRED RED
EPD, LPLQ, bit
CLP
RED, WRED RED, WRED
Traffic Engineering(TE)
MPLS (RSVP)
protected TE
MPLS (RSVP) MPLS (RSVP) MPLS (RSVP) Tag switching
Line cards
OC 48c (POS)
OC12c (POS)
OC 3c
(POS/ATM)
OC 192c
(POS)(99)
OC 48c (POS)
OC12c
(POS/ATM)
OC 3c
(POS/ATM)
OC 192c
(POS)(99)
Gibabit(99)

OC 192 (POS)
OC 48c (POS)

OC 48c
(POS/ATM)
OC12c
(POS/ATM)
DS3

OC 48c (POS)
OC12c
(POS/ATM)
OC 3c
(POS/ATM)
DS3
10/100 Base T

OC 48c (POS)
OC12c
(POS/ATM)
OC 3c
(POS/ATM)
DS3
Gibabit(99)
OC12c
(POS/ATM)
OC 3c
(POS/ATM)
Gigabit OC 48
(with a new
ASIC for L3F)
OC 192(99)

M. Frecon & N. Orand Giga-Routeur Page 21 sur 24




6. Conclusion


Comme nous lavons montr tout au long de notre tude, les amliorations possibles
pour voir le dbit de nos rseaux WAN augmenter seraient effectuer au niveau des
couches 2, 3 & 4 du modle OSI.

En effet, peu damlioration voire aucune sont possible aujourdhui dans les domaines
suivant :
- au niveau de la couche physique au vu des performances des rseaux optiques,
- en ce qui concerne les couches hautes, seule laugmentation de la rapidit des
processeurs et des accs mmoires est envisageable.

Donc daprs nous, le gros du travail de recherche, dans le futur afin de bonifier les dbits
utiles dans les rseaux fdrateurs devra se focaliser sur :

- lamlioration des ASICS pour permettre aux matriels actif une plus grande
vitesse de calcul,
- la continuit du dveloppement des techniques dacheminement utilises
actuellement (par exemple poursuivre lvolution du protocole GMPLS-TE),
- lamlioration des protocoles de transport de couche 4 nous semble judicieuse
mme si nous ne lavons pas abord dans notre rapport, de mme pour
lamlioration de la QoS.

Enfin, cette tude nous a permis de faire un tour dhorizon des techniques utilises au
sein des rseaux backbones jusquici inconnues pour nous. De plus, nous avons acquis une
valeur ajoute pour notre futur mtier dingnieur rseaux, en ce qui concerne la mise en
place du protocole MPLS sur des routeurs Cisco (en plus de lobtention du CCNA lors de
lanne universitaire).

M. Frecon & N. Orand Giga-Routeur Page 22 sur 24
7. Annexes

7.1 Bibliographie

Sites Web :
- NGN : http://en.wikipedia.org/wiki/Next_Generation_Networking
- Rseaux Optique : http://www.guideinformatique.com/fiche-fibre_optique-
506.html
http://www.iec.org/online/tutorials/dwdm/
- MPLS : http://www.mplsrc.com/index.shtml
http://www.cisco.com/en/US/tech/tk436/tsd_technology_support_category_home.ht
ml


Slection de livres pour approfondir ses connaissances sur les sujets traits dans notre
rapport :


Traffic Engineering with MPLS,
By Eric Osborne & Ajay Simha,
Published by Cisco Press,
Series: Networking Technology.


Next-Generation Network Services,
By Robert Wood,
Published by Cisco Press,
Series: Networking Technology.


MPLS Configuration on Cisco IOS Software,
By Umesh Lakshman & Lancy Lobo,
Published by Cisco Press,
Series: Networking Technology.


Optical Network Design and Implementation,
By Vivek Alwayn,
Published by Cisco Press,
Series: Networking Technology.




M. Frecon & N. Orand Giga-Routeur Page 23 sur 24

7.2 Fichiers de configuration_suite

Voici le reste des fichiers de configuration pour raliser nos tunnels MPLS.

Pescara
Current configuration:
!
version 12.0
!
hostname Pescara
!
ip cef
!
mpls traffic-eng tunnels
!
interface Loopback0
ip address 10.10.10.4 255.255.255.255
!
interface Tunnel1
ip unnumbered Loopback0
no ip directed-broadcast
tunnel destination 10.10.10.6
tunnel mode mpls traffic-eng
tunnel mpls traffic-eng autoroute announce
tunnel mpls traffic-eng priority 5 5
tunnel mpls traffic-eng bandwidth 25
tunnel mpls traffic-eng path-option 2 dynamic
!
interface Tunnel3
ip unnumbered Loopback0
no ip directed-broadcast
tunnel destination 10.10.10.6
tunnel mode mpls traffic-eng
tunnel mpls traffic-eng autoroute announce
tunnel mpls traffic-eng priority 6 6
tunnel mpls traffic-eng bandwidth 69
tunnel mpls traffic-eng path-option 1 dynamic
!
interface Serial0/1
no ip address
encapsulation frame-relay
!
interface Serial0/ 1.1 point-to-point
bandwidth 512
ip address 10.1.1.14 255.255.255.252
mpls traffic-eng tunnels
tag-switching ip
frame-relay interface-dlci 401
ip rsvp bandwidth 512 512
!
router ospf 9
network 10.1.1.0 0.0.0.255 area 9
network 10.10.10.0 0.0.0.255 area 9
mpls traffic-eng area 9
mpls traffic-eng router-id Loopback0
!
end
Pomerol
Current configuration:
version 12.0
!
hostname Pomerol
!
ip cef
!
mpls traffic-eng tunnels
!
interface Loopback0
ip address 10.10.10.3 255.255.255.255
!
interface Serial0/1
no ip address
encapsulation frame-relay
!
interface Serial0/ 1.1 point-to-point
bandwidth 512
ip address 10.1.1.6 255.255.255.252
mpls traffic-eng tunnels
tag-switching ip
frame-relay interface-dlci 301
ip rsvp bandwidth 512 512
!

interface Serial0/ 1.2 point-to-point
bandwidth 512
ip address 10.1.1.9 255.255.255.252
mpls traffic-eng tunnels
tag-switching ip
frame-relay interface-dlci 302
ip rsvp bandwidth 512 512
!
interface Serial0/ 1.3 point-to-point
bandwidth 512
ip address 10.1.1.21 255.255.255.252
mpls traffic-eng tunnels
tag-switching ip
frame-relay interface-dlci 306
ip rsvp bandwidth 512 512
!
router ospf 9
network 10.1.1.0 0.0.0.255 area 9
network 10.10.10.0 0.0.0.255 area 9
mpls traffic-eng area 9
mpls traffic-eng router-id Loopback0
!
ip classless
!
End




M. Frecon & N. Orand Giga-Routeur Page 24 sur 24

Pulligny
Current configuration:
!
version 12.1
!
hostname Pulligny
!
ip cef
!
mpls traffic-eng tunnels
!
interface Loopback0
ip address 10.10.10.2 255.255.255.255
!
interface Serial0/1
no ip address
encapsulation frame-relay
!
interface Serial0/ 1.1 point-to-point
bandwidth 512
ip address 10.1.1.2 255.255.255.252
mpls traffic-eng tunnels
tag-switching ip
frame-relay interface-dlci 201
ip rsvp bandwidth 512 512
!
interface Serial0/ 1.2 point-to-point
bandwidth 512
ip address 10.1.1.10 255.255.255.252
mpls traffic-eng tunnels
tag-switching ip
frame-relay interface-dlci 203
ip rsvp bandwidth 512 512
!
router ospf 9
network 10.1.1.0 0.0.0.255 area 9
network 10.10.10.0 0.0.0.255 area 9
mpls traffic-eng area 9
mpls traffic-eng router-id Loopback0
!
ip classless
!
end
Pauillac
!
version 12.1
!
hostname pauillac
!
ip cef
!
mpls traffic-eng tunnels
!
interface Loopback0
ip address 10.10.10.1 255.255.255.255
!
interface Serial0/0
no ip address
encapsulation frame-relay
!
interface Serial0/ 0.1 point-to-point
bandwidth 512
ip address 10.1.1.1 255.255.255.252
mpls traffic-eng tunnels
tag-switching ip
frame-relay interface-dlci 102
ip rsvp bandwidth 512 512
!

interface Serial0/ 0.2 point-to-point
bandwidth 512
ip address 10.1.1.5 255.255.255.252
mpls traffic-eng tunnels
tag-switching ip
frame-relay interface-dlci 103
ip rsvp bandwidth 512 512
!
interface Serial0/ 0.3 point-to-point
bandwidth 512
ip address 10.1.1.13 255.255.255.252
mpls traffic-eng tunnels
tag-switching ip
frame-relay interface-dlci 104
ip rsvp bandwidth 512 512
!
router ospf 9
network 10.1.1.0 0.0.0.255 area 9
network 10.10.10.0 0.0.0.255 area 9
mpls traffic-eng area 9
mpls traffic-eng router-id Loopback0
!
ip classless
!
end