Vous êtes sur la page 1sur 11

9

1.

Fonctions de comptage

Comptage sans conditions

La premire phase de ltude dune population est den dnombrer les individus. Les trois fonctions NBVAL, NB, NB.VIDE sont connexes. Elles retournent toutes les trois un nombre mais avec quelques variantes. 1.1. Fonction NBVAL

La fonction NBVAL compte le nombre de cellules qui ne sont pas vides et les valeurs comprises dans la liste des arguments. Utilisez NBVAL pour compter le nombre de cellules contenant des donnes dans une plage de cellules. Sa syntaxe : =NBVAL(valeur1 ; [valeur2] ; . . . ) valeur1, valeur2,. . . reprsentent les arguments correspondant aux valeurs compter. Seul le premier argument est obligatoire La fonction NBVAL compte tout type dinformation, y compris du texte vide, le caractre espace, des valeurs logiques ou des valeurs derreur. Notez quune cellule peut sembler vide mais elle contient en fait un espace ou un texte vide. De ce fait, cette cellule nest pas considre comme tant vide par NBVAL.

Application : Le tableau suivant reprsente une liste de personnes ayant pass un examen. Les candidats tant prsents ont une note. Les candidats absents sont nots par un ABS. Lobjectif est de compter le nombres de candidats inscrits lexamen.
c FSJES-Agadir 2013 Tableurs Semestre 3

9 Fonctions de comptage

80

Mise en place de la formule : La cellule H2 contient la formule =NBVAL(C3:C8) 1.2. Fonction NB

La fonction NB compte le nombre de cellules contenant des valeurs numriques et les valeurs numriques compris dans la liste des arguments. Utilisez NB pour obtenir le nombre dentres numriques dans dune plage de cellules. Sa syntaxe : =NB(valeur1 ; [valeur2] ; . . . ) valeur1, valeur2,. . . reprsentent les arguments correspondant aux valeurs compter. Seul le premier argument est obligatoire Les arguments de la fonction NB peuvent contenir ou rfrer diffrents types de donnes, mais seuls les nombres sont compts. Les arguments qui sont des nombres, des dates ou une reprsentation textuelle de nombres sont pris en compte. Application : Reprenons le tableau reprsentant la liste de personnes ayant pass un examen. Lobjectif est de compter le nombres de participants lexamen.

Mise en place de la formule : La cellule H2 contient la formule =NB(C3:C8)


c FSJES-Agadir 2013 Tableurs Semestre 3

9 Fonctions de comptage 1.3. Fonction NB.VIDE

81

La fonction NB.VIDE compte le nombre de cellules vides dune plage de cellules. Sa syntaxe : =NB.VIDE(plage) plage reprsente la plage dans laquelle vous voulez compter les cellules vides. Les cellules contenant des formules qui renvoient "" (texte vide) sont galement comptes, ce qui nest pas le cas des cellules contenant la valeur 0. Notez quune cellule contenant la formule =SI(VRAI;"";0), qui renvoie du texte vide, est considre comme tant vide par NB.VIDE, mais elle nest pas considre comme tant vide par NBVAL.

Application : Le tableau suivant reprsente une liste de personnes tant prsents lors dun examen. Certains candidats, qui ont oubli dinscrire leurs noms sur leurs copies dexamen, nont pas t nots. Lobjectif est de compter le nombres de candidats non nots.

Mise en place des formules : La cellule H2 contient la formule =NB.VIDE(C3:C8)

2.
2.1.

Comptage avec conditions


La fonction NB.SI

Quand vous cherchez compter le nombre de fois o vous avez un nom, une date, une valeur dans une liste, seule la fonction NB.SI doit tre utilise. La fonction ne ncessite que deux paramtres pour pouvoir fonctionner. Sa syntaxe :
c FSJES-Agadir 2013 Tableurs Semestre 3

9 Fonctions de comptage =NB.SI(plage ; critre) plage : une plage de donnes o se trouve la donnes que vous cherchez comptabiliser critre : la donne rechercher ou le critre de recherche. Application :

82

Dans le tableau suivant, vous avez une liste de vente de matriel informatique et voulez savoir combien de fois vous avez vendu de souris, et combien de fois vous avez reu de commandes dune quantit suprieure ou gale 10 units.

Mise en place des formules : La cellule D13 contient la formule =NB.SI(D4:D11 ; "Souris"). La cellule D14 contient la formule =NB.SI(E4:E11 ; ">=10"). Il est noter que la valeur recherche dans le tableau doit tre identique celles du tableau. Par exemple, les mots "Souris" et " Souris" ne sont pas identiques puisque le deuxime commence par un espace. Notez aussi quun test avec un oprateur logique, tout comme pour du texte, doit se mettre entre guillemets. 2.2. La fonction NB.SI.ENS

La fonction NB.SI vous permet de dnombrer combien de fois vous avez un lment dans une liste. Cependant, lorsque vous voulez faire un dnombrement sur plusieurs critres, la fonction NB.SI montre ses limites.
c FSJES-Agadir 2013 Tableurs Semestre 3

9 Fonctions de comptage

83

La fonction NB.SI.ENS (ENS pour ensemble) apporte la solution et le nombre de critres que vous pouvez utiliser peut aller jusqu 255 ! Cette fonction nest disponible que depuis la version dExcel 2007. Sa syntaxe : =NB.SI.ENS(plage_critres1 ; critre1 ; [plage_critres2 ; critres2] ; . . . ) Application : Supposons que vous souhaitez connatre le nombre de femmes ayant obtenu une moyenne suprieure ou gale 10, lors dun concours.

Mise en place de la formule : Pour chacun des critres, slectionnez tout dabord la plage de cellules o ce critre se trouve et ensuite votre critre lui-mme. Votre formule scrit alors : =NB.SI.ENS(C4:C12 ; "Femme" ; E4:E12 ; ">=10"). 2.3. La fonction SOMME.SI

Cette fonction est base sur le mme principe que la fonction NB.SI. Mais, au lieu de compter le nombre de fois quun lment est prsent dans une liste, vous pouvez ici calculer la somme dune plage correspondant votre critre. La fonction SOMME.SI a besoin de trois paramtres pour fonctionner. Sa syntaxe : =SOMME.SI(plage ; critre ; somme_plage) plage critre : la plage de cellules correspond lendroit ou lon va aller rechercher le critre. : la donne rechercher ou le critre de recherche.

c FSJES-Agadir 2013 Tableurs Semestre 3

9 Fonctions de comptage

84

somme_plage : la plage de cellules correspond aux chiffres que lon va devoir additionner en fonction du critre. Application : Dans le tableau suivant, vous avez une liste de vente de matriel informatique et supposons que vous souhaitez connatre la quantit vendu de chaque produit.

Mise en place des formules : Suivez les instructions suivantes : 1. Slectionnez la cellule I5 2. Tapez, le dbut de la formule, =SOMME.SI( 3. Slectionnez la plage qui contient vos produits C2:C11 et appuyez sur F4 4. Tapez le caractre ; puis entrez le critre de slection en slectionnant la cellule H5, puis trois fois successives appuyez sur F4 5. Slectionnez la plage qui contient les donnes que vous voulez sommer. Donc, pour dterminer la quantit vendue, slectionnez la plage D2:D11 et appuyez sur F4 Votre formule scrit alors : =SOMME.SI($C$4:$C$11 ; $H5 ; $D$4:$D$11). Copiez la formule vers la droite, puis ditez la formule contenue dans J5 et remplacez les deux lettres D par deux lettres F. Pour terminez, Slectionnez la plage I5:J5 et copiez vers le bas.

c FSJES-Agadir 2013 Tableurs Semestre 3

9 Fonctions de comptage 2.4. La fonction SOMME.SI.ENS

85

La fonction SOMME.SI.ENS se construit comme la fonction NB.SI.ENS dans le sens o vous avez la possibilit de raliser une somme sur une partie de vs donnes en slectionnant un ou plusieurs critres. Cette fonction nest disponible que depuis la version dExcel 2007. Sa syntaxe : =SOMME.SI.ENS(somme_plage ; plage_critres1 ; critre1 ; [plage_critres2 ; critres2] ; . . . ) Notez la diffrence entre SOMME.SI.ENS et SOMME.SI. En effet, largument somme_plage est le premier argument dans SOMME.SI.ENS, mais le dernier dans SOMME.SI. Ainsi, si vous copiez ou modiez ces fonctions similaires, veillez placer les arguments dans lordre appropri. 2.5. La fonction SOMMEPROD

La fonction SOMMEPROD a t dveloppe pour permettre de faire la somme des produits de matrices. Do son nom, Somme Produits. Cest une des plus utiles et plus puissantes fonctions dExcel. Cependant, SOMMEPROD permet de faire beaucoup plus que la somme de produits. En effet, par une syntaxe dtourne, elle permet de raliser une somme ou un dnombrement de donnes selon plusieurs conditions. Ce qui permet bien dautres utilisations importantes qui ne sont pas documentes dans laide dexcel. Utilisation standard Dans sa forme classique, SOMMEPROD multiplie chaque valeur dans une plage par la valeur correspondante dans une autre plage de mme dimension, et renvoie la somme des produits. Syntaxe : =SOMMEPROD(matrice1 ; [matrice2] ; [matrice3] ; . . . ) matrice1, matrice2, matrice3,. . . reprsentent les matrices dont vous voulez multiplier les valeurs pour ensuite additionner leur produit. Seul le premier argument est obligatoire SOMMEPROD affecte aux entres de matrice non numriques la valeur zro. Soit A et B deux matrices de mme dimensions ou tout simplement de tableaux rectangulaires ayant le mme nombre de lignes et le mme nombre de colonnes : a11 a12 b11 b12 A = a21 a22 B = b21 b22 a31 a32 b31 b32
c FSJES-Agadir 2013 Tableurs Semestre 3

9 Fonctions de comptage SOMMEPROD(A; B)=a11 b11 + a12 b12 + a21 b21 + a22 b22 + a31 b31 + a32 b32 Application :

86

Le tableau suivant contient les notes obtenues par un tudiant en six matires. Les coefcients ne sont pas les mmes. Lobjectif est de calculer la moyenne obtenu par ltudiant.

Mise en place des formules : Pour calculer une moyenne pondre, nous allons calculer la somme pondre des notes avec leurs coefcients respectifs, puis diviser par la somme des coefcients : La fonction SOMMEPROD vous permet de raliser la somme pondre des notes avec leurs coefcients respectifs sans faire tous les calculs intermdiaires. La fonction SOMME vous permet de calculer la somme des coefcients. La cellule C11 contient alors la formule =SOMMEPROD(C4:C9;D4:D9)/SOMME(D4:D9) SOMMEPROD tendu La fonction SOMMEPROD est plus couramment utilise pour calculer le nombre ou la somme de valeurs dune plage en fonction de conditions testes dans diffrentes plages. Dnombrement conditionnel, avec autant de tests logiques que ncessaire. La syntaxe est : =SOMMEPROD((plage1=condition1)*(plage2=condition2)*(plage3)) Somme conditionnelle, avec autant de tests logiques que ncessaire. Souvent, on place les tests logiques avant la plage contenant les valeurs sommer.
c FSJES-Agadir 2013 Tableurs Semestre 3

9 Fonctions de comptage =SOMMEPROD((plage1=condition1)*(plage2=condition2)*(plage3)) qui est quivalent =SOMMEPROD((plage1=condition1)*(plage2=condition2);(plage3))

87

Les paramtres plage1=condition1, plage2=condition2,. . . doivent tre des "formules" qui renvoient VRAI ou FAUX. Il nest pas possible dutiliser les fonctions SI, ET, OU dans les formules des tests logiques. Vous exploiterez le fait que la valeur logique VRAI correspond la valeur numrique 1, et la valeur logique FAUX la valeur numrique 0, pour intgrer des plages qui seront en fait des tests sur diffrents critres. Application : Responsable dun magasin de vente de matriel informatique, vous souhaitez suivre les ventes ralises.

Imaginons que votre objectif est de connatre rapidement les informations suivantes : Compter le nombre des ventes faites par Brahim dans la rgion du Nord. Cest une formule conditionnelle qui emploie deux conditions. =SOMMEPROD((C4:C11="Brahim")*(D4:D11="Nord")) Compter le nombre de ventes de quantits comprises entre certaines valeurs spciques Par exemple, compte le nombre de fois o les quantits vendues sont comprises entre 10 et 20. La formule emploie deux conditions : la quantit suprieure ou gale 10, et la quantit infrieure ou gale 20.
c FSJES-Agadir 2013 Tableurs Semestre 3

9 Fonctions de comptage =SOMMEPROD((F4:F11>=10)*(F4:F11<=20)) Totaliser les montants raliss par vendeur dans une rgion donne

88

La formule suivante calcule les montants raliss, base sur deux conditions : quand le vendeur est Brahim et la rgion est Nord. =SOMMEPROD((C4:C11="Brahim")*(D4:D11="Nord")*(H4:C11)) Mais nous pouvons aussi donner des noms aux plages C4:C11, D4:D11 et H4:C11. Pour cela : Slectionnez la plage C4:C11 Cliquez sur Insertion | Nom | Dfnir . Puis entrez un Nom, par exemple, Vendeurs. Cliquez sur le bouton [OK]. Faites de mme avec les plages D4:D11 et H4:C11 que vous pouvez nommer respectivement Regions et Montants. Vous pouvez maintenant utiliser la formule : =SOMMEPROD((Vendeurs="Brahim")*(Regions="Nord")*Montants) Vous voulez, maintenant, une formule simple que vous dveloppez dans une seule cellule (coin suprieur gauche du tableau) et que vous pouvez copier/coller dans toutes les cellules du tableau de synthse. La formule qui suit se trouve dans la cellule L5 et elle scrit comme suit : =SOMMEPROD((Vendeurs=L$4)*(Regions=$K5)*Montants)

c FSJES-Agadir 2013 Tableurs Semestre 3

9 Fonctions de comptage Totaliser les ventes combines pour deux vendeurs

89

La formule ci-dessous renvoie la somme des ventes pour Brahim et Sara. Cette formule emploie un argument simple et se compose de trois expressions. =SOMMEPROD(((C4:C11="Brahim")+(C4:C11="Sara"))*(H4:C11)) Les deux premiers termes (C4:C11="Brahim") et (C4:C11="Sara") ne sont pas multiplis comme dans les exemples prcdents. Dans la mesure o nous ralisons un test logique "OU", ils sont additionns : un montant sera pris en considration si le vendeur associ est Brahim OU Sara.

c FSJES-Agadir 2013 Tableurs Semestre 3