Vous êtes sur la page 1sur 113

sair

Guia passo-a-passo do Mikrotik


Tabela de contedo
[esconder]
1 Prefcio
2 Configuraes iniciais
3 Configurando o Mikrotik (LINK ou MODEM ROTEADO)
4 A PROPOSTA DOS TPICOS
5 Como amarrar IP/MAC
6 Configurando o WEB-PROXY
7 Controle de banda
8 Acesso remoto a outro Mikrotik
9 Controle P2P (MUITO BOM)
10 BACKUP e restaurao
11 Limitar conexes por cliente
12 Servidor PPPoE e Cadastro de Clientes
13 Amarrar faixa de IP no DHCP
14 Configurando o HOTSPOT
15 Configuraes dos cartes Wireless
16 Entendendo cada funo do menu do WINBOX
16.1 SUB-MENU IP
16.2 SUB-MENU ROUTING
16.3 SUB-MENU SYSTEM
17 Instalao do MIKROTIK (Link Dedicado)
17.1 Colocando ip Dedicado no cliente
18 Configurando Servidor de Hora Automtico
19 Lista de SCRIPTS e AGENDAMENTOS utis
20 Configurando Liberao Automtica de Banda por hora determinada
21 LOADBALANCE - Viso Geral e Aplicao
22 LOADBALANCE - IPD X IPD
22.1 IPD(IP DEDICADO)
22.2 Tratamento de portas
23 LOADBALANCE - DIVIDINDO CARGA DE FORMA PERSONALIZADA ENTRE
OS LINKS
23.1 Tratamento de portas
24 Mk como AP-bridge
25 FIREWALL
26 Grficos em Tempo Real do Mikrotik
27 Autor
[editar]
Prefcio
LTIMA ATUALIZAO: !-"#-""$
Restruturando este passo a passo, busco mais uma vez facilitar para os
novatos deste excelente sistema, ensinando aqui mesmo, o bsico para fazer um
servidor mikrotik funcionar. Apresento o incio, aquilo que no gostam de
ensinar, sem omisso, sem enrrolao. Para todos aqueles que querem aprender
ou conhecer o mikrotik, aqui est a forma mais simples de "rodar" um servidor
bsico para aprendizagem ou mesmo para iniciar suas experincias. Lembre-se,
estou dizendo o bsico e isso no significa "o servidor". Para os "aventureiros",
no recomendo colocar um servidor mikrotik, no configurado (com
configuraes bsicas), em produo (em funcionamento no provedor). Tenho
visto muita gente se decepcionando com o mikrotik, pelo simples fato de
conseguir configurar o bsico (que irei apresentar abaixo) e achar que tudo.
Um servidor, para rodar perfeitamente, precisa de no mnimo, configuraes
"obrigatrias", para evitar os velhos problemas conhecidos (perdas de pacotes,
lentido, etc). Falo eu CATVBRASIL (David), que j atendi mais de 500 empresas
por todo o Brasil, Argentina, Chile, USA, Itlia, Portugal e etc... Lembre-se,
conhecimento tudo... Estudem bastante e assim que possvel, se especializem,
faam treinamentos (existem vrios), tirem suas dvidas, participem do forum
do under-linux (um dos mais completos do Brasil, em termo de mikrotik) e etc....
Busquei neste passo a passo, ajudar, de certa forma, aqueles que sentem
dificuldade para realizar simples tarefas neste SO, Mikrotik. Basicamente a
estrutura de todo este passo-a-passo a fcil execuo dos procedimentos,
orientados por simples textos e imagens.
Agradeo a todos, que colaboraram direta ou indiretamente pela realizao
deste.
% e&pressa'ente proibida a ()*+A ou ,ual,uer outra -or'a de
re'unera./o por 'eio deste 'aterial0 % per'itido di1ul2ar3 colaborar3
inserir arti2os ou corre.4es neste 'aterial0 */o es,ue.a de indicar o
autor e a ori2e' do 'aterial0
Desenvolvi este manual passo-a-passo, para auxiliar a todos iniciantes ou
no deste excelente sistema operacional para roteadores.
ATENO: GRTIS!! TUDO QUE EST AQUI GRTIS!! LEMBRE-SE, DAI DE
GRAA O QUE RECEBEU DE GRAA!!!
Configuraes iniciais
5arte retirada do treina'ento a dist6ncia de 'ikrotik - 7AT(89A:IL
CONFIGURANDO UM SERVIDOR MIKROTIK BSICO (MTODO RELMPAGO)
Para configurar um servidor Mikrotik muito fcil e rpido e voc pode
configur-lo em 2 minutos no mximo!!! Consideramos que este servidor no
ter placas wireless, apenas 2 placas ethernets (1 de entrada e 1 de sada).
Para colocar um servidor Mikrotik, precisamos configurar apenas:
I5;A++9):: <de-ine o endere.o I5 para a inter-ace de entrada e
de sa=da>
I5;9OUT): <de-ine o 2ate?a@ de sa=da>
I5;+*: <de-ine o +*: pri'Ario e secundArio>
9)G9A +) *AT <I5;BI9)CALL;*AT> <de-ine o *AT 'ascarado>
SOMENTE ESTAS CONFIGURAES SO NECESSRIAS PARA LEVANTAR UM
SERVIDOR MIKROTIK BSICO. ESTE SERVIDOR J ESTAR "FUNCIONANDO.
NOTEM QUE EU DISSE "FUNCIONANDO APENAS. FUNCIONAR NO TUDO!!!
Configurando o Mikrotik (LINK ou MODEM ROTEADO)
Vamos l mos a obra!!
1 passo: 7O*BIGU9A9 O )*+)9)O <A++9)::>:
Abra o menu IP > ADDRESS
Crie um novo endereo IP (dentro da faixa do seu link ou modem, com a
mscara de rede). No esquea de definir a interface correta a qual seu roteador
ou modem est ligado, caso contrrio poder no funcionar.
Aps criar o endereo, e clicar em OK, automaticamente os endereos de
network e broadcast sero preenchidos. Estes endereos so criados
automaticamente de acordo com a mscara de rede.
2 passo: 7O*BIGU9A9 A 9OTA +) :AD+A <9OUT)9>:
Abra o menu IP > ROUTER
Crie uma nova rota, e defina apenas o endereo de gateway (este o
endereo do seu roteador ou modem). No necessrio colocar a mscara de
rede. Note que se estiver tudo certo, o campo "interface" desta nova regra, ser
preenchido automaticamente (com a interface onde est ligado seu modem ou
roteador)
3 passo: 7O*BIGU9A9 O +*::
Abra o menu IP > DNS
Abra o boto "settings" e configure o DNS primrio e secundrio do seu link.
4 passo: 7O*BIGU9A*+O O *AT:
Abra o menu IP > FIREWALL > NAT
Crie uma nova regra
Em "CHAIN escolha a opo "srcnat, em OUT INTERFACE (SADA), no
precisa escolher a interface de sada.
Na aba "ACTION, escolha a opo "MASQUERAD.
)ET9A
Passo adicional: 7O*BIGU9A*+O UM MF 7OM A+:L - MO+)M )M
89I+G):
Abra o menu INTERFACE
Clique com o boto direito, em cima da interface do ADSL, e escolha a opo
"PPPOE CLIENT"
Na aba DIAL OUT, configure os campos:
GU:)9: nome de usurio da cont ADSL (xxxxxxxxx@operadora.com.br)
G5A::CO9+: senha da conta ADSL
Deixar marcado as opes:
GA++ +)BAULT 9OUT)9
GU:)9 5))9 +*:
Mantendo estas duas opes marcadas, voc no ir precisa configurar o IP e
a ROTA (deve-se pular os passos 1 e 2 deste artigo). Dando um OK,
automaticamente o discador PPPoE ir se conectar e j estar pronto para
trabalhar.
5 passo: 7)9TIBI7A*+O HU) TU+O ):TI BU*7IO*A*+O
5)9B)ITAM)*T):
Bom, como saber se tudo que foi configurado est funcionando
perfeitamente? No winbox, h uma opo chamada "new terminal" que como o
prprio nome sugere, um terminal de comando do mikrotik. L temos vrios
comandos (podemos verificar, apenas apertando "?", dentre eles o conhecido
"ping". Para testar a funcionabilidade de nosso servidor mikrotik, basta "pingar"
um endereo qualquer (www.uol.com.br) e verificar se h resposta. Havendo
resposta, nosso servidor j est "navegando" na internet, caso no haja
resposta, significa que h algum problema na configurao (bastando iniciar
novamente este manual e verificar onde est acontecendo o erro)... Podemos
tambm atravs do comando de ping, verificar o "estado" de nosso roteador,
link, dns, etc etc...
[editar]
A PROPOSTA DOS TPICOS
Abaixo, apresento vrias solues e regras procuradas por muitos, de uma
forma simples e descomplicada. A proposta abaixo resolver algumas das
dvidas cotidianas. J vi muita gente falando no forum que configurou seu
servidor com as regras e solues abaixo e no ficou "aquele" servidor. Quero
lembrar mais uma vez, que as regras e solues apresentadas abaixo, funcionam
perfeitamente, mas no so a soluo completa. Elas resolvem algumas coisas,
mas para um servidor funcionar perfeitamente, necessrio outras
configuraes...
[editar]
Como amarrar IP/MAC
Acesse o menu IP, ARP
Crie uma nova "ARP (boto "+)
Digite o IP da mquina a qual quer amarrar, o MAC ADDRESS e a INTERFACE
a qual a mquina ser ligada.
Em COMMENT, d o nome desta ARP, como no exemplo acima.
Acesse o menu, INTERFACE
Como ltimo procedimento, voc deve habilitar em sua interface, o ARP
para reply-only.
[editar]
Configurando o WEB-PROXY
Acesse o menu IP, WEB-PROXY
Clique no boto "SETTINGS
Dever aparecer uma tela como esta
Configure de acordo com suas necessidades...
SRC-ADDRESS = Deixe em branco</p>
PORT = Escolher a porta do seu web-proxy</p>
TRANSPARENT PROXY = Deixe marcado para proxy transparente
PARENT PORT = Deixe em branco</p>
PARENT PROXY PORT = Deixe em branco</p>
CACHE ADMINISTRATOR = Deixe como est</p>
MAXIMUM OBJECT SIZE = Deixe como est</p>
CACHE DRIVE = Deixe como "system</p>
MAXIMUM CACHE SIZE = Define o tamanho do seu cache, varia de acordo
com o tamanho do seu HD</p>
MAXIMUM RAM</p>
CACHE SIZE = Define o tamanho mximo de sua memria RAM para o
cache</p>
Aps configurar estes parmetros, aperte a tecla "ENABLE
Aps configurar estes parmetros, aperte a tecla "ENABLE
NO se deve fazer CACHE de PGINAS DINMICAS (bancos, globo.com, etc
etc...)
Duas regras devem ser colocadas na aba "CACHE" do Web-Proxy para esse
efeito:
IP / WEB-PROXY / CACHE
Crie uma nova regra (boto "+)
add url=":cgi-bin \\?" action=deny comment="no cache dynamic http pages"
disabled=no
add url="https://" action=deny comment="no cache dynamic https pages"
disabled=no
O segundo passo para nosso WEB-PROXY funcionar criar um regra para
redirecionar as requisies primeiramente para o proxy, para isso:
Acesse IP, FIREWALL
Escolha a aba "NAT
Crie uma nova regra (boto "+)
Crie a regra da seguinte forma:
*CHAIN = DSTNAT
*PROTOCOL = 6 (TCP)* <r> *DST. PORT = 80
*IN. INTERFACE = INTERFACE DOS CLIENTES
V na aba "ACTION
Escolha em "ACTION a opo "REDIRECT e em "TO PORT escolha a porta
do seu proxy (definida anteriormente no comeo deste tpico).
interessante realizar uma regra para cada interface de assinantes. Neste
caso como possuo duas interfaces (LAN/WLAN), criei duas regras, uma para cada
interface.
importante criar uma regra de bloqueio externo ao web-proxy. Caso voc
no crie esta regra, ela sobrecarregar o seu proxy, travando at mesmo seu
servido. Siga abaixo:
Acesse o menu IP, FIREWALL
Acesse a aba "FILTER RULES
Crie uma nova regra (boto "+)
Segue a configurao:
*CHAIN = INPUT*
*PROTOCOL = 6 (TCP)
*DST PORT = PORTA DO SEU WEB-PROXY
*IN. INTERFACE = INTEFACE DE SADA (LINK DE INTERNET)
Acesse a aba "ACTION
Em "ACTION escolha a opo "drop.
EM COMMENT voc pode dar um nome a regra, que neste caso foi apelidado
de "BLOQUEIO DO PROXY EXTERNO.
Com este passo-a-passo, voc criou e habilitou o seu web-proxy e tambm
tornou mais eficiente, bloqueando o acesso externo a ele.
[editar]
Controle de banda
Acesse no menu, QUEUE
Crie um novo controle de banda (boto "+)
Configure como abaixo:
*NAME = Nome do "dono" da configurao - Nome do cliente
*TARGET ADDRESS = IP que ir controlar a banda
*TARGET UPLOAD - MAX LIMIT = Taxa de upload (Colocar "k Minsculo no
final)
*TARGET DOWNLAOD - MAX LIMIT = Taxa de download (Colocar "k minsculo
no final)
Controle de banda concludo. Somente isso necessrio.
[editar]
Acesso remoto a outro Mikrotik
PS: Para ter acesso a rdios AP em sua rede, voc dever habilitar a
funo "ATIVAR GERENCIAMENTO PELA PORTA WAN do seu rdio.
Simples. Basta criar trs regras no firewall. Segue abaixo:
Acesse o menu IP, FIREWALL
Clique na aba "NAT
Crie uma nova regra (boto "+)
Siga os procedimentos de configurao abaixo:
*CHAIN = DSTNAT
*DST. ADDRESS = Endereo IP do MK principal
*PROTOCOL = 6 (TCP)
*DST. PORT = 4040 (Porta padro do Firewall)
Abra a aba "ACTION
Siga as configurao abaixo:
*ACTION = DSTNAT
*O ADDRESS = Endereo IP do AP que deseja acessar.
*TO PORT = Porta de acesso do AP
Confirme e d um nome em COMMENT para sua regra.
Se o AP que voc deseja acessar for um outro AP Mikrotik, voc dever escolher
a porta padro TELNET (23). Se for um AP rdio, escolha a porta padro HTTP
(80) ou outra escolhida no rdio.
Voc dever criar uma segunda regra:
Repetindo o mesmo procedimento acima, mas desta vez, alterando apenas
o protocolo para 17 (UDP).
Salve tudo e crie a terceira regra.
Nesta regra, voc ir definir um endereo IP para seu AP. Verifique com
sua operadora quais endereos IP voc tem e quais esto sobrando.
Cria a regra como abaixo:
*CHAIN = DSTNAT
*DST. ADDRESS = Endereo IP livre, a qual ser atribudo ao seu rdio ou AP
MIKROTIK.
*PROTOCOL = 6 (TCP)
*DST. PORT = Porta de acesso ao AP ou rdio. Se voc for acessar outro AP pelo
WINBOX, selecione a porta 8291 (PORTA PADRO DO WINBOX), se voc for
acessar um rdio, a porta padro a 80 ou outra pr-definida do rdio.
Abra a aba "ACTION
Nesta aba voc ir configurar da seguinte forma:
*ACTION = DST-NAT
*TO ADDRESS = Endereo IP do seu rdio ou AP (endereo de IP da rede
interna)
*TO PORT = Porta padro para o WINBOX (AP MIKROTIK) ou porta padro para
rdios, porta 80 (ou outra definida).
Pronto!!! Para ter acesso a AP MIKROTIK, v no WINBOX, digite o IP vlido
definido acima, senha e login. Para ter acesso a rdios, abra o internet explorer,
digite o endereo IP vlido definido acima... Abrir um box para senha e login...
Digite-as e seja feliz!!!
No esquecer de adicionar os IP's vlidos que sero usados para os rdios
na ADDRESS LIST. Como??
Acesse o menu IP, ADDRESS LIST
Crie uma nova lista de endereos (boto "+)
De acordo com seu link, coloque o novo IP vlido, o Ip da "NETWORK e o
IP do BROADCAST. Defina tambm a interface (Neste caso, a interface de sada
da internet)
[editar]
Controle P2P (MUITO BOM)
Aqui voc ir aprender a controlar (shape) o trfego P2P, marcando
pacotes, facilmente. Basta apenas 4 regrinhas, 2 no firewall e 2 no queue. Ento
vamos l:
Acesse o menu IP, FIREWALL
Escolha a aba, MANGLE
Crie uma nova regra (boto "+)
No campo "CHAIN", escolha "PREROUTING". No campo "P2P", escolha "all-
p2p".
Abra a aba "ACTION
No campo "ACTION", escolha "MARK CONNECTION". No campo "NEW
CONNECTION MARK", d um nome a sua nova marcao de pacotes (no
exemplo, demos o nome de "p2p_conn". Deixe a opo "PASSTHROUGH" ligada.
Confirme.
Crie uma nova regra (boto "+)
No campo "CHAIN", escolha "PREROUTING". No campo "CONNECTION
MARK" escolha a opo com o nome definido acima (no nosso caso foi
"p2p_conn".
Abra a aba "ACTION
No campo "ACTION", escolha "MARK PACKET", no campo "NEW PACKET
MARK", defina outro nome (no nosso caso, ficou como "p2p". Confirme.
Aps criar estas duas regras no firewall, ser necessrio criar mais duas
regras no queue. Para isso:
Abra o menu, QUEUE
Abra a aba "QUEUE TREE"
Crie uma nova regra (boto "+)
Defina de acordo com a figura.
*NAME = Defina um nome para a regra
*PARENT = Escolha "GLOBAL-IN"
*PACKET MARK = Escolha a opo do nome escolhido acima. Aparecer aqui o
nome definido na regra do firewall
*QUEUE TYPE = DEFALT
*PRIORITY = 8
*MAX LIMIT = Define o limite mximo de banda reservado para o P2P. No nosso
caso, um total de 200k para p2p
Confirme...
Crie uma nova regra (boto "+)
Defina de acordo com a figura.
*NAME = Defina um nome para a regra
*PARENT = Escolha "GLOBAL-OUT"
*PACKET MARK = Escolha a opo do nome escolhido acima. Aparecer aqui o
nome definido na regra do firewall
*QUEUE TYPE = DEFALT
*PRIORITY = 8
*MAX LIMIT = Define o limite mximo de banda reservado para o P2P. No nosso
caso, um total de 200k para p2p <p style="text-indent: 40px;"
align="justify">Confirme...
Pronto!!! Moleza!!! Agora o trfego P2P, ser limitado por marcao de
pacotes. Esta regra muito eficiente!!
[editar]
BACKUP e restaurao
Abra o menu, FILES
Para criar uma cpia de backup, clique em "BACKUP"
Em "FILE NAME", aparecer o novo BACKUP. Esta cpia estar armazenada
no HD do MIKROTIK. Para copiar este backup em outro computador, clique em
"copy" (como na figura) e cole em qualquer pasta no windows.
Para restaurar o seu backup, escolha a cpia desejada na "FILE NAME" e
clique em "RESTORE", como abaixo.
Voc tambm poder restaurar uma cpia de backup, que encontra-se no
seu windows, por exemplo. Para isso, no seu sistema operacional, selecione o
arquivo do backup e com boto direito do mouse, escolha "COPIAR" (COPY). V
na janela de backup do seu MIKROTIK e clique em "paste" (como na figura).
Selecione esta nova cpia do backup (aparecer na lista) e aperte em
"RESTORE"
Aps realizar a restaurao do backup, reinicie o seu MIKROTIK.
Estamos tratando apenas de backup realizados pela "winbox", seja ele
remotamente ou no prprio servidor.
[editar]
Limitar conexes por cliente
Simplrrimo!!
Acesse o menu IP, FIREWALL
Na aba "FILTER RULES", crie uma nova regra (boto "+").
Configure da seguinte forma:
CHAIN = FORWARD
SRC. ADDRESS = ENDEREO DO CLIENTE A QUAL APLICAR O LIMITE.
PROTOCOL = 6 (TCP)
Agora abra a aba "ADVANCED"
Em "TCP FLAGS", escolha a opo "SYN" (este comando responsvel pelo
recebimento da requisio de conexo do cliente e tambm pelo aviso de que a
porta est ou no disponvel
Abra a aba "EXTRA"
Em "CONNECTION LIMIT" / "LIMIT", defina o nmero de conexes mximas
para este cliente.
No campo "NETMASK", defina a mscara 32 (32 significa que a regra ser
aplicada apenas a este IP)
Agora abra a aba "ACTION"
EM "ACTION", escolha a opo "DROP".
Basicamente esta regra libera N conexes simultneas para o cliente,
bloqueando requisies de conexes acima do limite.
Configure de acordo com suas necessidades
Caso deseje aplicar a regra para um range de IPs completo, configure o IP
XXX.XXX.XXX.0 e o NETMASK para 24.
[editar]
Servidor PPPoE e Cadastro de Clientes
Abra o menu PPP
Clique na aba "PROFILES"
Crie um novo profile (boto "+")
Configure este novo profile de acordo com suas necessidades. Basicamente
configure assim:
NAME = Nome do profile.
USE COMPRESSION = NO
USE VJ COMPRESSION = NO
USE ENCRYPTION = NO
CHANGE TCP MSS = YES
O outros campos deixe em branco, conforme a figura acima.
Confirme e abra a aba "INTERFACES" (na janela PPP mesmo) e clique no
boto "PPPoE SERVER".
Na janela "PPPoE SERVER LIST", crie um novo servidor (boto "+")
Configure de acordo com suas necessidades. Basicamente como abaixo:
Parmetros:
SERVICE NAME = Nome do servidor PPPoE.
INTERFACE = Interface com que este servidor ir trabalhar.
MAX MTU = Taxa mxima de transmisso. Basicamente deixe em 1500 para
clientes com winxp pra cima e 1452 para clientes com win98 pra baixo e clientes
que utilizam discador RASPPPOE.
MAX MRU = Taxa mxima de recepo. Configurar conforme acima.
KEEPALIVE TIMEOUT = Tempo mximo quem uma conexo retornar um erro.
Basicamente deixe em 10.
DEFAULT PROFILE = Lembra do profile que voc criou? aqui que todas estas
configuraes ficaro incorporados a ele. Basicamente o profile um atalho de
todas estas configuraes.
ONE SESSION PER HOST = Esta opo permite que login e senha de um cliente
(cadastrado no servidor pppoe), conecte por vez. Isto interessante, pois evita
que vrias pessoas conectem ao mesmo tempo com apenas um login e senha.
Deixe marcado.
MAX SESSION = Define o nmero mximo de conexes a este servidor.
Basicamente deixe em branco mesmo.
AUTENTICATION = Para haver compatibilidade com todos os servios de
discagem disponveis, deixe todas marcadas.
Voc poder criar vrios servidores PPPoE. Cada um atendendo uma
determinada interface e um determinado sistema operacional, como no exemplo
abaixo:
Para cadastrar clientes bem fcil. Aps criar seu servidor PPPoE, basta
clicar na aba "SECRETS"
Para criar uma nova conta, aperte no boto "+"
Configure de acordo com suas necessidades:
NAME = Login do assinante. Pode conter @xxxxxxx.com.br ou no.
PASSWORD = Senha de acesso.
SERVICE = Escolha PPPoe.
CALLER ID = Define qual MAC Adress ficar amarrado esta conexo
PROFILE = Define o profile que ser amarrado esta conexo.
LOCAL ADRESS = Endereo do Gateway (normalmente a faixa de IP utilizada
com final 254)
REMOTE ADRESS = Endereo IP desta mquina (preferencialmente dentro da
faixa de IP do LOCAL ADRESS)
ROUTERS = Define roteamento. Deixar em branco.
LIMITY BYTES IN = Limita o nmero de bytes de entrada. Deixar em branco.
LIMITY BYTES OUT = Limita o nmero de bytes de sada.
Confirme tudo e pronto. No computador do cliente basta criar uma conexo
PPPoE com esta senha e login e mandar conectar.
[editar]
Amarrar faixa de IP no DHCP
Um dos recursos mais interessantes em rede o DHCP, ainda hoje eu me
pergunto como os administradores conseguem trabalhar sem ele, pois ele faz
todo o trabalho de configurao da interface de rede, seja ela Linux, Windows ou
outra qualquer, com o DHCP voc pode alterar as configuraes de gateway,
DNS, faixa de IP do cliente e mscara tudo sem precisar ir na casa dele, voc
altera no Mikrotik e pede pro cliente reparar a rede ou reiniciar o computador e
est resolvido.
Resolvi dar minha contribuio neste wiki sobre esse assunto que tanto gosto e
convivo todos os dias.
Comece clicando na opo IP -> POOL
Clique no boto "+" e adicione o pool1.
Em address: voc coloca a faixa de rede que quer atribuir aos clientes.
Ex: 192.168.2.5-192.168.2.199 est bem claro no?
Clique em OK
Depois clique em IP -> DHCP Server:
Clique no boto "+" e adicione o SERVER:
M
No mesmo menu, clique na ABA "Networks" :
Clique na aba Leases: nela que vc vai amarrar os IPs no DHCP
Pronto seu DHCP Server est ativado.
[editar]
Configurando o HOTSPOT
Para configurar um Hotspot utilizando o Winbox, necessrio que as
interfaces estejam configuradas e online. V para o menu IP -> Hotspot:
Em seguida, clique em Setup. As imagens a seguir mostram as principais
telas de configuraes:
Na imagem 1, voc ir selecionar em qual interface esto os clientes do
Hotspot. Na imagem 2, voc pode aceitar o endereo padro da interface ou
atribuir um outro para o Hotspot. Na imagem 3, escolha a faixa de IPs que os
cliente usaro e por ltimo, defina um DNS vlido para esta rede.
Ao final destes passos, voc ter que criar o primeiro usurio para acessar o
Hotspot. O prprio assitente sugere o usurio Admin, digite uma senha para ele e
o assistente concluir a configurao.
Agora, voc j pode testar, dentro da rede local, basta tentar acessar qualquer
endereo externo, digite o usurio e senha e pronto.
[editar]
Configuraes dos cartes Wireless
[editar]
Entendendo cada funo do menu do WINBOX
Em construo
O primeiro menu do lado esquerdo chama-se " Interfaces ", nele que se
consegue enxergar os dispositivos fisicos conectados ao mikrotik, tais como
placas de rede, placas wireless e etc ..; neste menu tambm que se cadastra a
interfaces virtuais como PPoe server, bridge, virtualap e etc ... basta apenas
clicar no Sinal de "+" e adicionar a interface desejada.
Responde tambm pelo comando " interface " no terminal do mikrotik.
O segundo menu, - Wireless - nele que se pode abilitar e desabilitar as
interfaces wireless ( Como cartes PCMCIA - Car Mini-PCI Wireless ( Basta
apenas clicar no Sinal de "+" e adicionar a interface desejada. )
O terceiro menu, - PPP - nele que se pode criar, editar e remover conexes
PPPoe PPTP e L2TP, tambm onde se configura servidores dos mesmos
servios, configura senhas para discadores dos seus clientes e adiciona perfis de
discagem.
O quarto menu, - Bridge - nele que se pode criar, editar e remover Bridges
(Pontes entre as interfaces).
O sexto menu, - Queues - nele que se limita velocidade por IP ou faixa de
IPs ou tambm por Interface.
O stimo menu, - Drivers - onde se obtem a lista de drivers de Cartes
Wireless e Placas de Rede.
O oitavo menu, - Files - Abre um navegador no qual pode-se ver os arquivos
que esto no HD, tambm onde se cria Backup e restaura os mesmos.
O nono menu, - Log - onde se ver o log do seu sistema.
O Dcimo-Quarto menu, - Password - onde se altera a senha do seu
Mikrotik
O vigsimo, - Exit - Fecha a sua sesso do Winbox.
[editar]
:U8-M)*U I5
[editar]
:U8-M)*U 9OUTI*G
[editar]
:U8-M)*U :J:T)M
[editar]
Instalao do MIKROTIK (Link Dedicado)
Utilizo link dedicado da brasil telecon, funciona assim, eles dao por exemplo
128 ips = faixa de 201.2.180.1 at 201.2.180.127, sendo o 201.2.180.1 o
gateway, entao eh soh colocar o ip no servidor 201.2.180.2, e gateway e
pronto..
[editar]
7olocando ip +edicado no cliente
Se o cliente quer ip dedicado, cadastro ele na rede interna ex: 192.168.2.50
e adiciono mais um ip na interface do link 201.2.180.10 e faco uma regrinha
no /ip firewall nat
add chain=dstnat dst-address=201.2.180.10 protocol=tcp dst-port=0-65535 \
action=dst-nat to-addresses=192.168.2.50 to-ports=0-65535 \
comment="Direcionando IP 192.168.2.50 para 201.2.180.10" disabled=no
[editar]
Configurando Servidor de Hora Automtico
Aqui voc ir aprender a configurar servidores NTP (network time protocol)
automaticamente no mikrotik, via servidor de internet... Muito til para quem
trabalha com regras baseadas no horrio e no pode ter hora errada, adianta ou
atrazada.
Primeiro procedimento, abra o menu "NTP CLIENT"
Configure como abaixo:
MODE - Escolha a opo "UNICAST"
PRIMARY NTP SERVER = 159.148.60.2
SECONDARY NTP SERVER = 159.148.60.2
Aps configurar, aperte o boto ENABLE".
Abra o menu "CLOCK".
Configure o campo "Time Zone" de acordo com o fuso horrio da sua cidade.
Voc deve se basear no horrio mundial (Greenwich). Aqui no Rio de Janeiro,
-2:00 de diferena.
Pronto!! Agora no precisa mais se preocupar com a hora certa do seu
sistema!!!
[editar]
Lista de SCRIPTS e AGENDAMENTOS utis
Lista de Scripts prontos!!
TO+O: O: :79I5T: +)()M :)9 I*:)9I+O: (IA CI*8OE *O M)*U
:J:T)M;:79I5T: OU (IA K*)C T)9MI*ALK Ls@ste' script
:79I5T 5A9A 9)8OOTA9 AUTOMATI7AM)*T)
add name="reboot" source="/system reboot" \
policy=ftp,reboot,read,write,policy,test,winbox,password
:79I5T 5A9A 5A9A C)8-7A7M)
add name="Parar_Proxy" source="/ip web-proxy set enabled=no" \
policy=ftp,reboot,read,write,policy,test,winbox,password
:79I5T 5A9A LIM5A9 C)8-7A7M)
add name="Limpar_Proxy" source="/ip web-proxy clear-cache" \
policy=ftp,reboot,read,write,policy,test,winbox,password
:79I5T 5A9A 9)79IA9 <9)*I7IALIZA9> C)8-7A7M)
add name="Criar_Proxy" source="/ip web-proxy set enabled=yes" \
policy=ftp,reboot,read,write,policy,test,winbox,password
:79I5T 5A9A 8A7FU5 AUTOMITI7O +O MIF9OTIF
add name="backup_diario" source="/sy ba sav name=mk_bkp.backup" \
policy=ftp,reboot,read,write,policy,test,winbox,password
:79I5T: 5A9A MA8ILITA9 ) +):A8ILITA9 TO+A A 8A*+A
+):A8ILITA
add name="queue_disable" source="/queue simple { disable \[find \
name=LIBERA_TUDO\] }" \
policy=ftp,reboot,read,write,policy,test,winbox,password
MA8ILITA
add name="queue_enable" source="/queue simple { enable \[find \
name=LIBERA_TUDO\] }" \
policy=ftp,reboot,read,write,policy,test,winbox,password
AG)*+AM)*TO: T)I:
Devem ser aplicados via winbox (menus system>scheduler) ou via "new
terminal" em / system scheduler
AG)*+AM)*TO 5A9A 9)8OOT +) N! )M N! +IA:
add name="reboot" on-event=reboot start-date=nov/15/2006 start-
time=06:05:00 \
interval=4w2d comment="REBOOT DE 15 EM 15 DIAS" disabled=no
AG)*+AM)*TO: 5A9A MA*UT)*O AUTOMITI7A +O C)8-
59OEJ <! e' ! +IA:
add name="Parar_Proxy" on-event=Parar_Proxy start-date=nov/15/2006
\
start-time=05:00:00 interval=5d comment="" disabled=no
add name="Limpar_Proxy" on-event=Limpar_Proxy start-
date=nov/15/2006 \
start-time=05:03:00 interval=5d comment="" disabled=no
add name="Criar_Proxy" on-event=Criar_Proxy start-
date=nov/15/2006 \
start-time=05:10:00 interval=5d comment="MANUTEN O AUTOM TICA
DO \
WEB-PROXY" disabled=no
AG)*+AM)*TO 5A9A 8A7FU5 AUTOMITI7O +) O )M O MO9A:
add name="backup diario" on-event=backup_diario start-
date=jan/16/2007 \
start-time=00:00:00 interval=6h comment="CRIA BACKUP DE 6 EM 6
HORAS" \
disabled=no
[editar]
Configurando Liberao Automtica de Banda por
hora determinada
[editar]
LOADBALANCE - Viso Geral e Aplicao
8alancea'ento de car2a
Todo o hardware tem o seu limite, e muitas vezes o mesmo servio tem
que ser repartido por vrias mquinas, sob pena de se tornar congestionado.
Estas solues podem-se especializar em pequenos grupos sobre os quais se faz
um balanceamento de carga: utilizao do CPU, de armazenamento, ou de rede.
Qualquer uma delas introduz o conceito de clustering, ou server farm, j que o
balanceamento ser, provavelmente, feito para vrios servidores.
8alancea'ento de ar'aPena'ento <stora2e>
O balanceamento do suporte de armazenamento permite distribuir o
acesso a sistemas de ficheiros por vrios discos (software/hardware RAID), pelo
que derivam ganhos bvios em tempos acesso. Estas solues podem ser
dedicadas ou existir em cada um dos servidores do cluster.
Solues
RAID
Storage Area Network
Figura 1 - Balanceamento de carga (NAT).
Figura 2 - Balanceamento de carga (Direct Routing).
8alancea'ento de rede
O balanceamento da utilizao da rede passa sobretudo por reencaminhar
o trfego por caminhos alternativos a fim de descongestionar os acessos aos
servidores. Este balanceamento pode ocorrer a qualquer nvel da camada OSI.
A Figura 1 sugere a existncia de um mecanismo/dispositivo responsvel
pelo balanceamento (director). Na verdade, ele pode existir sob vrias formas,
dependendo do(s) servio(s) que se pretende balancear. Este director serve
tambm de interface entre o cluster de servidores e os clientes do(s) servio(s) -
tudo o que os clientes conhecem o endereo semi-pblico deste servidor. Esta
abordagem (clssica) algo limitada, em termos de escalabilidade, ao nmero
de tramas que o director consegue redireccionar, principalmente devido
velocidade dos buses das placas de rede. Existem, no entanto, outras solues
mais complexas que tiram melhor partido das caractersticas do protocolo TCP/IP
em conjunto com routing especializado (NAT, IP Tunneling, Direct Routing).
Exemplo Um exemplo de um site a utilizar tcnicas de balanceamento de
carga a prpria Wikimedia Foundation e os seus projectos. Em Junho de 2004,
a carga era balanceada usando uma combinao de:
Round robin DNS, que distribui os pedidos uniformemente para um dos
trs servidores de cache Squid;
Estes servidores de cache usam os tempos de resposta para distribuir os
pedidos para cada um dos sete servidores de pginas. Em mdia, os servidores
Squid j tm em cache pginas suficientes para satisfazer 75% dos pedidos sem
sequer consultar os servidores de pginas; Os scripts PHP que formam a
aplicao distribuem a carga para um de vrios servidores de base de dados
dependendo do tipo do pedido, com as atualizaes indo para um servidor
primrio e as consultas para um ou mais servidores secundrios.
Solues (software) Existem solues que operam exclusivamente em
apenas algumas camadas (nveis) do Modelo OSI:
Nvel 4: Linux Virtual Server
Nvel 5/6/7: Zeus Load Balancer
8alancea'ento de 75U
Este tipo de balanceamento efectuado pelos sistemas de processamento
distribudo e consiste, basicamente, em dividir a carga total de processamento
pelos vrios processadores no sistema (sejam eles locais ou remotos).
GBonte: Cikipedia
Aplica./o:
Tenho visto muitas pessoas confusas, quanto a aplicao do loadbalance...
Algums sugerem colocar lo 5 ou 10 links, pelo fato de ser "melhor"... Para que
todos possam aproveitar o mximo dos recursos do loadbalance e tambm no
gastar dinheiro desnecessariamente, deixemos claro as seguintes coisas:
Loadbalance, como o prprio nome diz K8ALA*7)AM)*TO +) 7A9GAK
ou seja, diviso de carga da sua rede e entre os links... Muitas pessoas se
enganam e acham que loadbalance soma link (1mb + 1mb = 2mb), o que no
verdade;;; Para ter o mximo de desempenho em uma tcnica de loadbalance,
devemos primeiramente analizar as necessidades de cada rede, para ae sim,
criar um loadbalance com o mximo de desempenho para nossa rede...
[editar]
LOADBALANCE - IPD X IPD
LOADBALANCE - ADSL X IPD
LOADBALANCE - ADSL X ADSL
[editar]
I5+<I5 +)+I7A+O>
/ ip firewall mangle
add chain=prerouting in-interface= Link1 connection-state=new nth=1,1,0
action=mark-connection
new-connection-mark=Link1 passthrough=yes comment="Balanceamento de
carga" disabled=no
add chain=prerouting in-interface= Link1 connection-mark=Link1 action=mark-
routing
new-routing-mark=Link1 passthrough=no comment="" disabled=no
add chain=prerouting in-interface= Link2 connection-state=new nth=1,1,1
action=mark-connection
new-connection-mark=Link2 passthrough=yes comment="" disabled=no
add chain=prerouting in-interface= Link2 connection-mark=Link2 action=mark-
routing
new-routing-mark=Link2 passthrough=no comment="" disabled=no
/ ip firewall nat
add chain=srcnat out.interface= Link1 Actoin=Link1 comment="Nat Link1"
disabled=no
add chain=srcnat out.interface= Link2 Actoin=Link2 comment="Nat Link2"
disabled=no
/ ip route
add dst-address=0.0.0.0/0 gateway=192.168.254.254 scope=255 target-
scope=10 routing-mark=Link1
comment="Gateway adsl1" disabled=no
add dst-address=0.0.0.0/0 gateway=192.168.253.253 scope=255 target-
scope=10 routing-mark=Link2
comment="Gateway adsl2" disabled=no
add dst-address=0.0.0.0/0 gateway=192.168.254.254 scope=255 target-
scope=10 comment="principal" disabled=yes
[editar]
Trata'ento de portas
/ ip firewall mangle
add chain=prerouting protocol=tcp dst-port=80 action=mark-routing new-
routing-mark=link2
passthrough=yes \
comment="HTTP no link2" disabled=no
add chain=prerouting routing-mark=link2 action=mark-packet new-packet-
mark=link2 passthrough=yes \
comment="Pacotes marcados do Link2" disabled=no
add chain=prerouting protocol=tcp dst-port=443 action=mark-routing new-
routing-mark=link2
passthrough=yes \ comment="HTTPS no Link2" disabled=no
add chain=prerouting routing-mark=link2 action=mark-packet new-packet-
mark=link2 passthrough=yes \
comment="Pacotes marcados do Link2" disabled=no
add chain=prerouting protocol=tcp dst-port=1863 action=mark-routing new-
routing-mark=link2
passthrough=yes \
comment="MSN no Link2" disabled=no
add chain=prerouting routing-mark=link2 action=mark-packet new-packet-
mark=link2 passthrough=yes \
comment="Pacotes marcados do Link2" disabled=no
add chain=prerouting protocol=tcp dst-port=21 action=mark-routing new-
routing-mark=link1
passthrough=yes \
comment="FTP no link1" disabled=no
add chain=prerouting routing-mark=link1 action=mark-packet new-packet-
mark=link1 passthrough=yes \
comment="Pacotes marcados do Link1" disabled=no
add chain=prerouting protocol=tcp dst-port=22 action=mark-routing new-
routing-mark=link1
passthrough=yes \
comment="SSH no Link1" disabled=no
add chain=prerouting routing-mark=link1 action=mark-packet new-packet-
mark=link1 passthrough=yes \
comment="Pacotes marcados do Link1" disabled=no
add chain=prerouting protocol=tcp dst-port=23 action=mark-routing new-
routing-mark=link1
passthrough=yes \
comment="TELNET" disabled=no
add chain=prerouting routing-mark=link1 action=mark-packet new-packet-
mark=link1 passthrough=yes \
comment="Pacotes marcados do Link1" disabled=no
add chain=prerouting protocol=tcp dst-port=25 action=mark-routing new-
routing-mark=link1
passthrough=yes \
comment="SMPTP" disabled=no
add chain=prerouting routing-mark=link1 action=mark-packet new-packet-
mark=link1 passthrough=yes \
comment="Pacotes marcados do Link1" disabled=no
add chain=prerouting protocol=tcp dst-port=53 action=mark-routing new-
routing-mark=link1
passthrough=yes \
comment="DNS" disabled=no
add chain=prerouting routing-mark=link1 action=mark-packet new-packet-
mark=link1 passthrough=yes \
comment="Pacotes marcados do Link1" disabled=no
add chain=prerouting protocol=tcp dst-port=110 action=mark-routing new-
routing-mark=link1
passthrough=yes \
comment="POP3" disabled=no
add chain=prerouting routing-mark=link1 action=mark-packet new-packet-
mark=link1 passthrough=yes \
comment="Pacotes marcados do Link1" disabled=no
add chain=prerouting protocol=tcp dst-port=1080 action=mark-routing new-
routing-mark=link1
passthrough=yes \
comment="" disabled=no
add chain=prerouting routing-mark=link1 action=mark-packet new-packet-
mark=link1 passthrough=yes \
comment="Pacotes marcados do Link1" disabled=no
add chain=prerouting protocol=tcp p2p=all-p2p action=mark-routing new-
routing-mark=link1
passthrough=yes \
comment="p2p no link1" disabled=no
add chain=prerouting routing-mark=link1 action=mark-packet new-packet-
mark=link1 passthrough=yes \
comment="Pacotes marcados do Link1" disabled=no
Autor: SHTURBO-INTERNET
[editar]
LOADBALANCE - DIVIDINDO CARGA DE FORMA
PERSONALIZADA ENTRE OS LINKS
[editar]
Trata'ento de portas
/ ip firewall mangle
add chain=prerouting protocol=tcp dst-port=80 action=mark-routing new-
routing-mark=link2
passthrough=yes \
comment="HTTP no link2" disabled=no
add chain=prerouting routing-mark=link2 action=mark-packet new-packet-
mark=link2 passthrough=yes \
comment="Pacotes marcados do Link2" disabled=no
add chain=prerouting protocol=tcp dst-port=443 action=mark-routing new-
routing-mark=link2
passthrough=yes \
comment="HTTPS no Link2" disabled=no
add chain=prerouting routing-mark=link2 action=mark-packet new-packet-
mark=link2 passthrough=yes \
comment="Pacotes marcados do Link2" disabled=no
add chain=prerouting protocol=tcp dst-port=1863 action=mark-routing new-
routing-mark=link2
passthrough=yes \
comment="MSN no Link2" disabled=no
add chain=prerouting routing-mark=link2 action=mark-packet new-packet-
mark=link2 passthrough=yes \
comment="Pacotes marcados do Link2" disabled=no
add chain=prerouting protocol=tcp dst-port=21 action=mark-routing new-
routing-mark=link1
passthrough=yes \
comment="FTP no link1" disabled=no
add chain=prerouting routing-mark=link1 action=mark-packet new-packet-
mark=link1 passthrough=yes \
comment="Pacotes marcados do Link1" disabled=no
add chain=prerouting protocol=tcp dst-port=22 action=mark-routing new-
routing-mark=link1
passthrough=yes \
comment="SSH no Link1" disabled=no
add chain=prerouting routing-mark=link1 action=mark-packet new-packet-
mark=link1 passthrough=yes \
comment="Pacotes marcados do Link1" disabled=no
add chain=prerouting protocol=tcp dst-port=23 action=mark-routing new-
routing-mark=link1
passthrough=yes \
comment="TELNET" disabled=no
add chain=prerouting routing-mark=link1 action=mark-packet new-packet-
mark=link1 passthrough=yes \
comment="Pacotes marcados do Link1" disabled=no
add chain=prerouting protocol=tcp dst-port=25 action=mark-routing new-
routing-mark=link1
passthrough=yes \
comment="SMPTP" disabled=no
add chain=prerouting routing-mark=link1 action=mark-packet new-packet-
mark=link1 passthrough=yes \
comment="Pacotes marcados do Link1" disabled=no
add chain=prerouting protocol=tcp dst-port=53 action=mark-routing new-
routing-mark=link1
passthrough=yes \
comment="DNS" disabled=no
add chain=prerouting routing-mark=link1 action=mark-packet new-packet-
mark=link1 passthrough=yes \
comment="Pacotes marcados do Link1" disabled=no
add chain=prerouting protocol=tcp dst-port=110 action=mark-routing new-
routing-mark=link1
passthrough=yes \
comment="POP3" disabled=no
add chain=prerouting routing-mark=link1 action=mark-packet new-packet-
mark=link1 passthrough=yes \
comment="Pacotes marcados do Link1" disabled=no
add chain=prerouting protocol=tcp dst-port=1080 action=mark-routing new-
routing-mark=link1
passthrough=yes \
comment="" disabled=no
add chain=prerouting routing-mark=link1 action=mark-packet new-packet-
mark=link1 passthrough=yes \
comment="Pacotes marcados do Link1" disabled=no
add chain=prerouting protocol=tcp p2p=all-p2p action=mark-routing new-
routing-mark=link1
passthrough=yes \
comment="p2p no link1" disabled=no
add chain=prerouting routing-mark=link1 action=mark-packet new-packet-
mark=link1 passthrough=yes \
comment="Pacotes marcados do Link1" disabled=no
Autor: SHTURBO-INTERNET
[editar]
Mk como AP-bridge
Primeiro voc vai em interface e veja se a placa wireles e a ethernet esto
ativas (se tiver esmaecida (cinza) clique nela e enable). Feito Isto v em bridge e
clique no "+" e crie uma bridge . Ainda no menu bridge clique em port vai
aparecer suas placas de redes. Assim basta clicar em cada placa de rede e
adicionar o nome da bridge criada.
Depois disso voc adiciona um ip para a bridge e exclui os ips anteriores das
placas. Pronto, seu Access Point mikrotik foi criado.
[editar]
FIREWALL
[editar]
Grficos em Tempo Real do Mikrotik
primeiro v em IP=>SERVICES,modifique a aporta do servio WWW. no meu
caso usei 809. pois vc poder precisar da porta 80.para algun servidor web na
sua rede e outra,impedira que outros fique fuando seu MT.
Logo apos v em TOOLS=>GRAPHING
Adicione as rules que vc tem nescessidade:
Queue Rules:monitora as regras de velocidade de seus clientes.
Interfaces Rules:Monitora as interfaces de rede do seu MT
Resource Rules :Monitora CPU,MEMORY e UPTIME do seu MT.
Agora o teste,digite no seu navegador op ip do seu MT junto scom a porta do
seu MT.no meu caso http://192.168.0.254:809 .no esquea da porta que vc
modificou em IP=>SERVICES.
Veja que ai vc tm algumas opes ,mais v no que interessa em GRAPHS.
escolha qual grafico vc deseja verificar. clique em cima da opo que o grafico
sera mostrado.
+I7A:voc pode bloquear esta porta para o uso externo em:
IP=>FIREWALL=>FILTER RULES
Adicione uma nova regra e deixe assim.
CHAIN:forward PROTOCOL:tcp DST PORT:(porta que vc modificou para servico
www) IN INTERFACE:(interface da internet) ACTION:drop.
Use o programa (cliente DDNS) da winco tecnologia para monitorar seus MT
que esto por ai sem ip fixo.