Vous êtes sur la page 1sur 2

Static Routes

set routing-options static route 10.10.10.0/24 reject router sends a ICMP message (the network unreachable message)
set routing-options static route 10.10.10.0/24 discard silently discards the packet
set routing-options static route 10.101.10.0/24 next-table vpn.inet.0 default preference value of 5
set routing-options static route 0.0.0.0/0 next-hop 172.30.25.1
alternative path
set routing-options static route 0.0.0.0/0 qualified-next-hop 172.30.25.5 preference 7
changing default preference value for all static routes
set routing-options static defaults preference 250
Avoiding static routes from being advertised tkrough routing policy highly suggested for static routes for management traffic
set routing-options static route 172.28.102.0/24 next hop 10.210.11.190
set routing-options static route 172.28.102.0/24 no-readvertise Note: the no-advertise statement will not allow this route to exported to OSPF for example
options for BGP
set routing-options static route 172.28.102.0/24 next hop 10.210.11.190 as-path path 65500
Aggregate Routes
set routing-options aggregate defaults community 1:888 the default next-hop for aggregated routes is reject (sends ICMP unreachable)
set routing-options aggregate route 172.29.0.0/22 default route preference 130
set routing-options aggregate route 172.25.0.0/16 community 1:999
set routing-options aggregate route 172.25.0.0/16 discard
troubleshooting
show route 172.29.0.0/22 exact detail
Generated Routes
set routing-options generate defaults preference 130 next-hop will be added by the first contributing route
set routing-options generate route 0.0.0.0/0 policy match-contributing-prefix
Policy for filtering the contributing routes: allowing only external BGP routes
set policy-options policy-statement match-contributing-prefix term match-bgp-prefix from protocol bgp
set policy-options policy-statement match-contributing-prefix term match-bgp-prefix from route-filter 10.0.0.0/16 exact
set policy-options policy-statement match-contributing-prefix term match-bgp-prefix then accept
set policy-options policy-statement match-contributing-prefix term else-reject then reject
OSPF export policy: importing external BGP routes to OSPF to be annouced internally
set policy-options policy-statement export-default term match-default protocol aggregate
set policy-options policy-statement export-default term match-default route-filter 0.0.0.0/0 exact
set policy-options policy-statement export-default term match-default then accept
OSPF config: exporting BGP
set protocols ospf export export-defaults
troubleshooting
show route 0/0 exact detail
next-hop: must be the BPG external peer
Contributing routes: a list of the contributing peers must appear
Martian Addresses
show routing-options martians
set routing-options martians 240/0 orlonger allow remove the IP address block from the martian address list
troubleshooting
show route martians
Equal cost Multipath Load Sharing
per flow load balancing
set policy-options policy-statement load-balance-policy from route-filter 172.24.0.0/24 exact
set policy-options policy-statement load-balance-policy from route-filter 172.24.1.0/24 exact
set policy-options policy-statement load-balance-policy then load-balance per-packet
set routing-options forwarding-table export load-balance-policy
set forwarding-options hash-key family inet layer-3
set forwarding-options hash-key family inet layer-4
troubleshooting
show route forwarding-table
Filter-Based Forwarding
filter
set firewall family inet filter mymatch-filter term match-subnet-A from source-address 172.25.0.0/24
If you are planning to implement filter-based forwarding , you should know that source-class usage
filter matching and unicast reverse-path forwarding (RPF) checks are not supported on interfaces
configured for filter-based forwarding.
set firewall family inet filter mymatch-filter term match-subnet-A then routing-instance ISP-A
set firewall family inet filter mymatch-filter term match-subnet-B from source-address 172.25.1.0/24
set firewall family inet filter mymatch-filter term match-subnet-B then routing-instance ISP-B
forwarding instance
set routing-instances ISP-A instance-type forwarding
set routing-instances ISP-A routing-options static route 0.0.0.0/0 next-hop 172.20.0.2
set routing-instances ISP-B instance-type forwarding
set routing-instances ISP-B routing-options static route 0.0.0.0/0 next-hop 172.20.1.2
RIB group for sharing routes next-hop
set routing-options interface-routes rib-group inet my-rib-group
set routing-options rib-groups my-rib-group import-rib [inet.0 ISP-A.inet.0 ISP-B.inet.0]
filter added to incoming interface
set interfaces ge-0/0/1 unit 0 family inet filter input my-match-filter

Vous aimerez peut-être aussi