Vous êtes sur la page 1sur 5

Curso de Engenharia

Mecnica


Disciplina:
Algoritmo e Lgica de Programao




LISTA DE EXERCCIOS II

















Professor Orlando Oliveira



ANHANGUERA ALGORITMOS E LINGUAGEM DE PROGRAMAO
PROF. ORLANDO OLIVEIRA



1
1. Faa um algoritmo, usando o comando caso, para identificar se um nmero igual a 1, 5
ou 10.
2. Construa um algoritmo que, tendo como dados de entrada o preo de um produto e seu
cdigo de origem, mostre o preo junto de sua procedncia. Caso o cdigo no seja
nenhum dos especificados, o produto deve ser considerado importado. Siga a tabela de
cdigos abaixo:

Cdigo de origem Procedncia
1 Sul
2 Norte
3 Leste
4 Oeste
5 ou 6 Nordeste
7, 8 ou 9 Sudeste
10 Centro-Oeste

3. Escreva um algoritmo, usando a estrutura enquanto, que leia 50 nmeros e retorne a soma
e a mdia desses valores.
4. Faa um algoritmo que solicite que o usurio digite um nmero, e informe se este nmero
maior que 10. O programa deve parar de solicitar o nmero quando este for igual a 0
(zero).
5. Faa um algoritmo para exibir os nmeros de 1 a 10.
6. Construa um algoritmo que leia a mdia anual de 50 alunos e calcule a mdia geral da
turma, utilizando a estrutura repita-at.
7. Faa um algoritmo para ler e escrever os nmeros mpares de 1 a 50.
8. Escreva um algoritmo que leia 05 nmeros e escreva todos os que forem positivos.
9. Faa um algoritmo para ler e escrever o nome de 20 pessoas.
10. Dado dois valores A e B quaisquer, faa um algoritmo que imprima se A > B, ou A < B , ou
A = B.
11. Faa um algoritmo que receba a idade de 75 pessoas e mostre uma mensagem
informando maior de idade e menor de idade para cada pessoa. Considere a idade a
partir de 18 anos como maior de idade.
ANHANGUERA ALGORITMOS E LINGUAGEM DE PROGRAMAO
PROF. ORLANDO OLIVEIRA



2
12. Escreva um algoritmo que receba um nmero e diga se este nmero est no intervalo
entre 100 e 200.
13. Faa um algoritmo que receba um nmero e mostre uma mensagem caso este nmero
seja maior que 10.
14. Faa um algoritmo que leia um nmero de 1 a 5 e escreva por extenso. Caso o usurio
digite um nmero que no esteja neste intervalo, exibir a mensagem: nmero invlido.
15. Faa um algoritmo que receba o nmero do ms e mostre o ms correspondente. Valide
os meses invlidos.
16. Elabore um algoritmo que, dada a idade de um nadador, classifique-o em uma das
seguintes categorias:
Infantil A = 5 7 anos
Infantil B = 8 10 anos
Juvenil A = 11 13 anos
Juvenil B = 14 17 anos
Snior = 18 25 anos
Apresentar a mensagem idade fora da faixa etria quando for outro ano no
contemplado.
17. Sendo o vetor V igual a:

2 6 8 3 10 9 1 21 33 14
1 2 3 4 5 6 7 8 9 10
e as variveis X = 2 e Y = 4, escreva o valor correspondente solicitao:

a) V [X + 1]
b) V [X + 2]
c) V [8 V[2]]
d) V [V[4]]
18. Elabore um algoritmo que, utilizando as trs estruturas de repetio, imprima a tabuada
do nmero 5.
18.1 Modifique o algoritmo para que ele imprima a tabuada de quaisquer nmeros, sendo
que esses so fornecidos pelo usurio, at encontrar como finalizador -1. Sabendo que o
primeiro nmero base fornecido no -1.
ANHANGUERA ALGORITMOS E LINGUAGEM DE PROGRAMAO
PROF. ORLANDO OLIVEIRA



3
19. Dado o algoritmo a seguir, responda:
algoritmo "exercicio19"
var
A, B, I, J: inteiro
inicio
escreva ("Entre com o nmero desejado: ")
leia (A)
repita
para I de 1 ate A passo 1 faca
J <- I
enquanto (J <= A) faca
escreval (J)
J <- J + 1
fimenquanto
fimpara
B <- A
escreva ("Entre com o nmero desejado: ")
leia (A)
ate ((A = B) ou (A <= 0))
fimalgoritmo

a) O que ser mostrado se forem fornecidos os nmeros 4 e 0.
b) O que ser mostrado se forem fornecidos os nmeros 3, 2 e 2.
c) O que ser mostrado se forem fornecidos os nmeros 2, 1 e 0.
d) O que ser mostrado se forem fornecidos os nmeros 1 e 0.
ANHANGUERA ALGORITMOS E LINGUAGEM DE PROGRAMAO
PROF. ORLANDO OLIVEIRA



4
20. Elabore um algoritmo que leia, some e imprima o resultado da soma entre dois vetores
inteiros de 50 posies.