Vous êtes sur la page 1sur 8

Net-Pro Par : GHAOUTI Mohamed

1 Configuration d'origine :
1.1 Configuration physique :

Le réseau de l'entreprise est entierement composé de materiel Cisco, actuel leader


sur le marché du materiel réseau, routeurs, switchs et firewalls.
L'entreprise qu'on se propose d'aider dispose déja de plusieurs routeurs connectés
entre eux et déja configurés, ils assurent déjà le fonctionnement d'un réseau local
divisé en plusieurs sous réseaux.
Le nouveau routeur va etre disposé entre deux routeurs déjà configurés, chacun
ayant un sous réseau et plusieurs postes a charge. L'un étant relié a un serveur
mendataire générique ( proxy générique ) et l'autre n'étant relié qu'au premier ( cf.
schéma 1 ). On se propose donc d'ajouter un routeur entre le routeur A et le routeur
B.

Schéma 1.
1.2 Configuration logiciel :

Les routeurs A et B sont déja configurés, il est donc nécéssaire pour le bon
fonctionnement du réseau que nous analysions ces configurations. Nous allons donc
travailler sur un équipement Cisco fonctionnant avec son IOS ( Internetworking
Operating System ) propriétaire.
La startup-config contient la configuration au démarage du routeur, la runing-config
contient la configuration en cours d'utilisation par le routeur. Il est possible que ces
deux configurations soient différentes mais au redémarrage du routeur la running-
config utilisera la startup-config stockée dans la mémoire NV-RAM ( Non Volatil RAM
), nous éxaminerons donc uniquement la runing-config des routeurs.
Pour se faire, plusieurs méthodes sont disponibles : par Telnet, port console ou plus
rarement par SSH. Nous allons utiliser la méthode consistant a relier un ordinateur
au port sonsole du routeur.
Commençons donc par relier un ordinateur au routeur B. Il faut pour cela un cable
console avec un adaptateur série pour le relier a l'ordinateur ( ce cable est livré avec
le routeur ). Le cable console est un cable de couleur noire avec une extremité de
type RJ-45 qu'on va brancher sur la face arriere du routeur, au port console. L'autre
extrémité est une prise a 25 broches, le plus souvent femelle, il faut donc un
adaptateur pour pouvoir le relier au port série 9 broches d'un ordinateur. Il faut
ensuite lancer le terminal virtuel sur la machine reliée au routeur tel que l'hyper
terminal de windows, le configurer ( diriger la connection vers le port COM choisi,
choisir un débit de 9600 bit/s, 8 bit de données, un bit de stop et pas de parité ) et
mettre sous tension le routeur. Une ligne de commande du type routeurB> s'affiche a
l'écran. Pour pouvoir visualiser la configuration de ce routeur, il faut passer en mode
utilisateur privilegié, pour cela il faut tapper la commande enable qui aura pour effet
visuel de transformer l'invite > en invite #. Il faut ensuite tapper une commande qui
affichera la configuration courante du routeur : write terminal.

Voici la configuration qui s'affiche pour le routeur B :

03/02/2009 1/8 napster_simon@hotmail.com


Net-Pro Par : GHAOUTI Mohamed

routeurB# write terminal

Building configuration...

Current configuration :

Version 10.3

hostname routeurB

enable secret djH55fiKTKMP25$dsf$GH525$.

enable password paswd

interface ethernet0

ip address 192.5.30.1 255.255.255.0

shutdown

!interface Serial0

ip address 192.4.10.5 255.255.255.0

clockrate 64000

interface Serial1

no ip address

shutdown

router igrp1

network 192.4.10.0

03/02/2009 2/8 napster_simon@hotmail.com


Net-Pro Par : GHAOUTI Mohamed

line con0

exec-timeout 0 0

line aux0

transport input all

line vty 0 4

password ilx

login

end

Nous constaterons en premier lieu que le protocole IGRP est utilisé.


L'adresse du sous réseau relié au routeur B est 192.5.30.0 /24.
L'adresse IP de son interface sur le réseau ( serial0 ) est 192.4.10.5 /24.

La meme manipulation que pour le routeur B est nécessaire pour pouvoir lire la
configuration du routeur A ( cf. paragraphe en italique )

Voici la configuration qui s'affiche pour le routeur A :

routeurA# write terminal

Building configuration...

Current configuration :

Version 10.3

hostname routeurB

enable secret 5h$JKObkj691jf!jhoEAZA654gAjfdOI62.

enable password paswd

03/02/2009 3/8 napster_simon@hotmail.com


Net-Pro Par : GHAOUTI Mohamed

interface ethernet0

ip address 192.5.10.1 255.255.255.0

shutdown

!interface Serial0

ip address 192.4.10.1 255.255.255.0

clockrate 64000

interface Serial1

ip address 192.4.10.2 255.255.255

clockrate 64000

router igrp1

network 192.4.10.0

line con0

exec-timeout 0 0

line aux0

transport input all

line vty 0 4

password ilx

login

end

03/02/2009 4/8 napster_simon@hotmail.com


Net-Pro Par : GHAOUTI Mohamed

Le meme protocole de routage est utilisé ici.


L'adresse du sous réseau relié au routeur A est 192.5.10.0 /24.
L'adresse IP de son interface sur le réseau (serial0) reliée au serveur proxy est
192.4.10.1 /24.
L'adresse IP de son interface sur le réseau (serial1) reliée au routeur B est
192.4.10.2 /24.

Les informations importantes relevées ici sont le protocole de routage utilisés par les
voisins de notre futur nouveau routeur ( IGRP ), les adresses ip des interfaces
voisines ainsi que leurs adresses de sous réseau.

2 Configuration du routeur :
2.1 Physique

Nous allons maintenant connecter nortre nouveau routeur sur le réseau entre le
routeur A et le routeur B. Pour se faire, nous allons déconnecter les interfaces qui
relient le routeur A au routeur B pour connecter le routeur A au nouveau routeur (
routeur C ) et connecter le routeur B au routeur C comme sur le schéma 2. Il faut
ensuite relier le routeur C a un ordinateur par le port console pour pouvoir le
configurer.

Schéma 2.

Il faut pour cela un cable console avec un adaptateur série pour le relier a l'ordinateur
( ce cable est livré avec le routeur ). Le cable console est un cable de couleur noire
avec une extremité de type RJ-45 qu'on va brancher sur la face arriere du routeur, au
port console. L'autre extrémité est une prise a 25 broches, le plus souvent femelle, il
faut donc un adaptateur pour pouvoir le relier au port série 9 broches d'un ordinateur.
Il faut ensuite lancer le terminal virtuel sur la machine reliée au routeur tel que l'hyper
terminal de windows, le configurer ( diriger la connection vers le port COM choisi,
choisir un débit de 9600 bit/s, 8 bit de données, un bit de stop et pas de parité ) et
mettre sous tension le routeur.

2.2 Logiciel

Comme ce routeur n'a pas de configuration, il faut lui en donner une qu'il nous
demandera à la première mise sous tension :
Notice: NVRAM invalid, possibly due to write erease

--- System Configuration Dialog ---

At any point you may enter a question mark ? for help.


Refer to the Getting Started Guide for additional help.

Use ctrl-C to abort configuration dialog at any prompt.

Default settings are in square brackets [ ].

Would you like to enter the initial configuration dialog ? [yes]: yes

03/02/2009 5/8 napster_simon@hotmail.com


Net-Pro Par : GHAOUTI Mohamed

Il nous est ici demandé si nous désirons entrer dans le mode de configuration initiale.
Puisque cet exercice consiste a configurer un nouveau routeur dans un réseau déja
éxistant nous allons répondre par yes :
First would you like to see the current interface summary? [yes]: no

ici nous avons la possibilité de voir les interfaces du routeur mais elles ne sont pas configurées et ne montrent donc aucun interet pour
le moment.

Enter host name [Router]: routerC

le nom de ce nouveau routeur est donc routerC

Enter enable secret: passwd

ce mot de pass permettra de passer en mode utilisateur privilégié

Enter enable password: telnetpass

ce mot de pass permettra de vous connecter au routeur par telnet

Configure SNMP Network Management? [yes]: no

Simple Network Management Protocol, protocole de gestion de réseau ( couche application du model OSI ), nous choisissons de ne pas
l'implémenter dans ce réseau.

Configure IP? [yes]: no

configuration des adresses du routeur, nous le ferons a part plus tard

Configure IGRP routing? [yes]: no

configuration du protocole IGRP, nous le ferons a part plus tard

Configure RIP routing? [no]: no

configuration du protocole de routage RIP, nous ne l'utilisons pas ici

Nous entrons maintenant dans la phase de configuration des interfaces:

interface ethernet0:

Is this interface in use? [yes]: yes

ici nous activons l'interface ethernet0

Configure IP for this interface? [yes]: no

nous configurerons l'adresse de cette interface plus loin

interface serial0:

Is this interface in use? [yes]: yes

ici nous activons l'interface serial0

Configure IP for this interface? [yes]: no

nous configurerons l'adresse de cette interface plus loin

interface serial1:

03/02/2009 6/8 napster_simon@hotmail.com


Net-Pro Par : GHAOUTI Mohamed

Is this interface in use? [yes]: yes

ici nous activons l'interface serial1

Configure IP for this interface? [yes]: no

nous configurerons l'adresse de cette interface plus loin

Le mode de premiere configuration est maintenant terminé mais nous n'avons fait qu'activer les interfaces que nous allons utiliser, il faut
maintenant les configurer. La ligne de commande routeurC> apparait.

L'adresse que nous allons assigner a l'interface serial0 est 192.4.10.3 /24.
Elle sera reliée a l'interface serial1 du routeur A d'adresse 192.4.10.2 /24.
Pour se faire, il faut entrer en mode privilégié : tapper enable, puis entrer en mode de configuration:

routeurC> enable
routeurC# configure terminal
routeurC(config)# int S0
routeurC(config-if)# ip adress 192.4.10.3 255.255.255.0
routeurC(config-if)# bandwidth 64000

Nous remarquerons que le passage en mode privilégié fait apparaitre le # a la ligne de commande. Pour entrer en mode configuration il
faut entrer la commande configure terminal qui fait apparaitre config entre parentheses a la ligne puis nous précisons qu'il s'agit de
l'interface serie 0 (S0). En mode de configuration d'interface, config-if est affiché apres le nom du routeur et nous pouvons assigner
l'adresse du routeur suivie de son masque de sous réseau. La derniere ligne assigne la bande passante a l'interface pour optimiser les
echanges d'informations.

Nous ferons de meme pour l'interface Serial1 et Ethernet0 :

L'adresse que nous allons assigner a l'interface serial1 est 192.4.10.4 /24.
Elle sera reliée a l'interface serial0 du routeur B d'adresse 192.4.10.5 /24.

Serial1:
routeurC> enable
routeurC# configure terminal
routeurC(config)# int S1
routeurC(config-if)# ip adress 192.4.10.4 255.255.255.0
routeurC(config-if)# bandwidth 64000

2.3 Test de communication


La détection des voisins est automatique avec le protocole IGRP il nous reste a tester les communications.
Pour verifier que le protocole est bien en fonctionnement, nous le testons avec la commande ping pour tester le voisinage.

routerC# ping 192.4.10.2


Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.4.10.2, timeout 2 seconds:
!!!!!
Success rate is 100 percent (5/5)

Le routeur C a contacté le routeur A avec succes, testons avec le routeur B:

routerC# ping 192.4.10.5


Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.4.10.5, timeout 2 seconds:
!!!!!
Success rate is 100 percent (5/5)

Le routeur C a contacté le routeur B avec succes.

Essayons maintenant de contacter le routeur A avec le routeur B:


routerB# ping 192.4.10.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.4.10.2, timeout 2 seconds:
!!!!!
Success rate is 100 percent (5/5)

La communication entre les routeurs est donc correcte.

03/02/2009 7/8 napster_simon@hotmail.com


Net-Pro Par : GHAOUTI Mohamed

Conclusion

Nous avons maintenant un routeur capable de communiquer avec ses voisins et les
postes des sous réseaux voisins. Cette configuration simple permet de comprendre
et d'integrer les commandes de base de configuration d'un routeur Cisco.

03/02/2009 8/8 napster_simon@hotmail.com