Vous êtes sur la page 1sur 37

Contact : utilsfr@fr.

fm
Site : http://utilsfr.new.fr
http://1960nene.free.fr/passconditionnel.htm
Auteur ROBERT Ren
Entrez ci-dessous le mot de passe vous
permettant d'obtenir la version enregistre
Retrouvez ce mot de passe en cliquant
sur le lien ci-dessous
Cette accs est payant
Mettre en vidence des cellules contenant des formules
15 =SOMME(F2:F4) 4
45 45 5
5 =MOYENNE(F2:F4) 6
78 78
6 =MAX(F2:F4)
maison maison
Code insrer dans un module
Menu
Function AVEC_FORMULE(cell) As
Boolean
AVEC_FORMULE = cell.HasFormula
End Function
Mettre en vidence la plus grande valeur
=B6=MAX(($B$6:$B$11))
90
19
12.5
125
67
3
Menu
Mettre en vidence la plus petite valeur
=B6=MIN(($B$6:$B$11))
90
19
12.5
2
67
3
Menu
Mettre en vidence la deuxime plus grande valeur
B6=GRANDE.VALEUR($B$6:$B$11;2)
90
19
12.5
2
67
3
Menu
Mettre en vidence une cellule qui correspond la moyenne
C6=MOYENNE($C$6:$C$11)
100
400
200
600
500
600
Menu
Mettre en vidence les valeurs suprieur 100
=SI(C6>100;VRAI;FAUX)
100
98
200
600
56
101
78
42
3
600
78
1000
Menu
Mettre en vidence les doublons entre 2 plages
=NB.SI($B$6:$F$9;B11)+NB.SI($B$6:$F$9;B11)>1
36 8 56 1 546
45 100 47 6 456
74 99 2 24 125
3 2 3 4 6
36 25 12 47 3
Menu
Mettre en vidence les noms dans une liste de prnoms et noms
=NON(ET(ESTERREUR(CHERCHE(B7&"$";$C$7:$C$22&"$"))))
Liste Noms Liste Prnoms Noms
MARTINAC Marcel LEROND
LEROND Lon Parisot
MARTINE Patrick JOUVET
ALBERT MICHEL SARDOU
GANDON LEON ZITRONE
Golman Patricia kass
PARROT jhonny hallyday
EYRIGNOUX jean jacques GOLMAN
KIEN Maurice VIALLEZ
Parisot LOUIS DENIS
ROBERT ROBERT Ren
Ren ROBERT
ROBERT CHARLEBOIS
YVES DUTEIL
Jean michel jarre
Patrick maurice
Menu
Mettre en vidence les changements positifs ou ngatifs
Etudiants 1er Trimestre 2 me Trimestre 3 me Trimestre
Elve1 14 12 16
Elve2 2 12 16
Elve3 14 16 16
Elve4 8 8 5
Elve5 12 10.6 11
Elve6 8 6 5
Elve7 6 8.5 8
Elve8 4.5 6 6
Elve9 18 15 16
Elve10 20 16 16
Menu
Formule 1 : =$D7>$E7
Formule 2 : =$D7<$E7
Masquer les valeurs infrieur et gale 0
=SI(B6<=0;VRAI;FAUX)
36 8 56 1 546
0 100 0 6 456
0 99 2 24 -3
3 2 -2 4 6
Menu
Mettre en vidence les lignes pairs ou impairs
Pour les lignes pairs =MOD(LIGNE();2)=0
Pour les lignes impairs =MOD(LIGNE();2)>0
Valeur1 Valeur1 Valeur1 Valeur1 Valeur1 Valeur1 Valeur1
Valeur2 Valeur2 Valeur2 Valeur2 Valeur2 Valeur2 Valeur2
Valeur3 Valeur3 Valeur3 Valeur3 Valeur3 Valeur3 Valeur3
Valeur4 Valeur4 Valeur4 Valeur4 Valeur4 Valeur4 Valeur4
Valeur5 Valeur5 Valeur5 Valeur5 Valeur5 Valeur5 Valeur5
Valeur6 Valeur6 Valeur6 Valeur6 Valeur6 Valeur6 Valeur6
Valeur7 Valeur7 Valeur7 Valeur7 Valeur7 Valeur7 Valeur7
Valeur8 Valeur8 Valeur8 Valeur8 Valeur8 Valeur8 Valeur8
Menu
Valeur1
Valeur2
Valeur3
Valeur4
Valeur5
Valeur6
Valeur7
Valeur8
Mettre en vidence les numros gagnant du loto
=EQUIV(D7;$B$7:$B$14;0)
Tirage officiel Ticket 1 Ticket 2 Ticket 3 Ticket 4
34 5 6 5 5
5 2 2 45 2
25 25 14 23 47
4 42 23 42 34
13 11 12 17 11
41 48 41 48 48
29 16 15 16 16
16 26 26 26 26
Menu
Ticket 5 Ticket 6
29 2
15 26
25 25
42 42
19 5
48 48
16 8
26 7
Mettre en vidence les valeurs comprises dans l'intervalle de tolrance par rapport la valeur de rfrence
=ET(B10>=$B$7-$C$7;B10<=$B$7+$D$7)
Valeur de rfrence Tolrence inf Tolrence sup
10.50 0.30 0.20
10.51 12 12
11 8.3 10.4
12 6 10.25
9 7 9.9
8.6 12.3 10.1
10.2 10.3 10.2
11.2 11 12.5
Menu
Mettre en vidence les valeurs comprises dans l'intervalle de tolrance par rapport la valeur de rfrence
Mettre en vidence les 5 premires valeurs
=B6>=GRANDE.VALEUR($B$6:$B$15;5)
14
2
45
8
122
8
6
4.5
18
20
Menu
Mettre en vidence les 3 dernires valeurs
=OU(B6=PETITE.VALEUR($B$6:$B$15;1);B6=PETITE.VALEUR($B$6:$B$15;2);B6=PETITE.VALEUR($B$6:$B$15;3))
14
2
45
1
122
8
6
4.5
18
20
Menu
=OU(B6=PETITE.VALEUR($B$6:$B$15;1);B6=PETITE.VALEUR($B$6:$B$15;2);B6=PETITE.VALEUR($B$6:$B$15;3))
Mettre en vidence les doublons
=NB.SI($B$6:$E$10;B6)>1
125 89 45 147
45 325 89 56
26 45 4 5
47 44 8 547
65 865 1456 1458
Menu
Mettre en vidence un rsultt si toutes les cellules sont remplies
=ET($C$6:$C$9<>"")
Valeur 1 89
Valeur 2 5
Valeur 3
Valeur 4 32
TOTAL 126
MAX 89
MOY. 42
Menu
Mettre en vidence les valeurs non tries croissantes
=B7<B6
100
106
115
12
120
125
126
45
190
191
195
198
199
197
200
23
201
204
Menu
Mettre en vidence les valeurs non tries dcroissantes
=B7>B6
100
98
115
87
86
84
56
45
456
191
45
46
199
197
200
23
201
204
Menu
Masquer certain mots choisis
=NON(ESTERREUR(EQUIV(B6;$G$3:$G$5;0)))
maison
petit
254
69
loup
x
xxx
PORNO
savant
Menu
Liste de mots masquer
Porno
xxx
69
Mettre en vidence une cellule contenant un certain mot dans une phrase "Ici lapin"
=OU(NON(ESTERREUR(TROUVE("lapin ";B6)));NON(ESTERREUR(TROUVE("lapin ";B6)));DROITE(B6;6)=" lapin";NON(ESTERREUR(CHERCHE(CAR(34)&"lapin"&CAR(34);B6)>0)))
Le lapin
Maison blanche
Excel
Evier en fonte
le ver de terre
la couleur verte
le rouge gorge est cot du lapin
lapin
petit lapin
Menu
=OU(NON(ESTERREUR(TROUVE("lapin ";B6)));NON(ESTERREUR(TROUVE("lapin ";B6)));DROITE(B6;6)=" lapin";NON(ESTERREUR(CHERCHE(CAR(34)&"lapin"&CAR(34);B6)>0)))
Mettre en vidence les valeurs suprieure et infrieur la moyenne
Condition 1 : =B7>=MOYENNE($B$7:$C$18)
Condition 2 : =B7<=MOYENNE($B$7:$C$18)
16 14.6
2 12
12 2
1 6.5
12 12
18 1
9 13
3 20
10 12
5 18
14 6
14 5
Menu
Bonjour,

Avec une mise en forme conditionnelle
directe, sans colonne supplmentaire.
Slectionner les cellules partir de A2
jusqu' E10 ou E600 ou E autre chose
Barre de menu - Format -
conditionnelle
Choisir "La formule est" et taper :
=SOMMEPROD(($A2&$B2&$C2&$D2&$E
Avec une mise en forme conditionnelle
directe, sans colonne supplmentaire.
Slectionner les cellules partir de A2
jusqu' E10 ou E600 ou E autre chose
Format - Mise en forme
Choisir "La formule est" et taper :
=SOMMEPROD(($A2&$B2&$C2&$D2&$E
Mettre en vidence les lignes identiques d'un tableau
=SOMMEPROD(($A7&$B7&$C7&$D7&$E7=A$6:$A6&B$6:$B6&C$6:$C6&D$6:$D6&E$6:$E6)*1)>0
16 16 16 5 16
16 16 16 16 16
16 14 16 16 16
16 16 16 1 16
16 16 16 16 16
16 16 16 6 16
16 16 4 16 16
16 16 16 16 16
16 14 16 13 16
16 16 16 17 16
16 16 16 16 16
16 1 16 16 16
Menu
=SOMMEPROD(($A7&$B7&$C7&$D7&$E7=A$6:$A6&B$6:$B6&C$6:$C6&D$6:$D6&E$6:$E6)*1)>0