Vous êtes sur la page 1sur 16

6/7/2014 Activer laccs dadministration dun switch via telnet - CiscoMadeSimple.

be
http://www.ciscomadesimple.be/2009/08/06/cisco-configuration-dun-switch-via-telnet/ 1/16
Accueil Articles Fiches rcapitulatives Vidos Live Forums Ressources propos
Configuration simple de VLANS sur un switch Dfinition de routes IP statiques sous ubuntu 9.04
Activer laccs dadministration dun switch via telnet
De Steve De Jongh | 6 aot 2009 | Cisco, La pratique
La mthode de base pour configurer un switch Cisco est de se connecter via le port console de lappareil. Cest en tout logique ncessaire pour une
premire configuration, mais ensuite, il est tout de mme plus ais de pouvoir accder au CLI via un machine distante connecte au rseau. Voici les
quelques paramtres configurer pour rendre cel possible
Pr-requis
Il faut bien entendu, lors dune premire configuration pouvoir se connecter au port console dune manire ou dune autre. Dans la majorit des cas, il
faut disposer dun port srie sur le PC utilis, dun adaptateur RJ45-DB9 et dun cable Rollover. Et enfin disposer dun programme qui permet de grer
une communication sur port srie comme Hyperterminal (pour les utilisateur Windows).
1. Brancher le cable Rollover au port console du switch.
2. Placer ladaptateur RJ45-DB9 sur le port srie du PC.
3. Connecter le cable rollover sur ladaptateur.
Il existe en outre un cable de connexion RJ45-DB9 complet qui ne demande donc plus dadaptateur.
Il faut maintenant initialiser la connexion au port console via un programme terminal comme Hyperterminal . Il faut en outre sassurer que les
paramtres suivants sont bien dfinis:
CISCOMADESIMPLE.BE
Bl og consacr aux rseaux et au matri el Ci sco.
6/7/2014 Activer laccs dadministration dun switch via telnet - CiscoMadeSimple.be
http://www.ciscomadesimple.be/2009/08/06/cisco-configuration-dun-switch-via-telnet/ 2/16
Bits par seconde: 9600
Data Bits: 8
Parit: aucune
Stop Bits: 1
Contrle de flux: aucun
Vu que chaque programme est diffrent, je ne vais pas dtailler lutilisation de ceux-ci.
Une fois la connexion tablie, on accde linterface de configuration du switch.
Switch con0 is now available
Press RETURN to get started.
Switch>
Pour pouvoir accder au CLI via telnet, il faut pouvoir tablir une connexion entre le PC et le switch. Ce qui implique:
Le PC et le Switch disposent dune adresse IP.
Si le PC et le Switch sont sous le mme sous-rseau, il faut bein sur que les adresses IP y correspondent.
Si le PC et le Switch ne sont pas sur le mme sous rseau, il faut que les tables de routages des diffrentes passerelles soient correctement
configures.
Les connexions telnet sur le switch sont autorises.
Pour attribuer une adresse IP un switch, on en configure une sur une ou plusieurs interfaces vlan . Par dfaut, le VLAN 1 existe, nous allons donc
utiliser celle-l.
Dans le cas prsent, nous supposons que le PC est directement connect sur un des pots du switch. On attribuera ladresse 192.168.1.100 /
255.255.255.0 au switch et 192.168.1.101 / 255.255.255.0 au pc. On configurera galement une passerelle par dfaut pour les deux qui sera
192.168.1.1. Elle ne sera pas ici ncessaire, mais a montrera comment la configurer dans le cas dun rseau complexe.
6/7/2014 Activer laccs dadministration dun switch via telnet - CiscoMadeSimple.be
http://www.ciscomadesimple.be/2009/08/06/cisco-configuration-dun-switch-via-telnet/ 3/16
Commenons par configurer ladresse IP du switch sur le VLAN 1.
Switch>en
Switch#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#
interface vlan 1
Switch(config-if)#ip address 192.168.1.100 255.255.255.0
Switch(config-if)#no shut
%LINK-5-CHANGED: Interface Vlan1, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to up
Switch(config-if)#exit
Switch(config)#ip default-gateway 192.168.1.1
Switch(config)#exit
On vrifie que tout est en ordre:
Switch#show interfaces vlan 1
Vlan1 is up, line protocol is up
Hardware is CPU Interface, address is 000b.be52.34cd (bia 000b.be52.34cd)
Internet address is 192.168.1.100/24
MTU 1500 bytes, BW 100000 Kbit, DLY 1000000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
ARP type: ARPA, ARP Timeout 04:00:00
Last input 21:40:21, output never, output hang neverLast clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
6/7/2014 Activer laccs dadministration dun switch via telnet - CiscoMadeSimple.be
http://www.ciscomadesimple.be/2009/08/06/cisco-configuration-dun-switch-via-telnet/ 4/16
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
1682 packets input, 530955 bytes, 0 no buffer
Received 0 broadcasts (0 IP multicast)
0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
563859 packets output, 0 bytes, 0 underruns
0 output errors, 23 interface resets
0 output buffer failures, 0 output buffers swapped out
Switch#
On configure galement ladresse IP du PC en 192.168.1.101 / 255.255.255.0. Une fois cel fait, si tout fonctionne comme prvu, les deux machines
devraient pouvoir communiquer
Switch#ping 192.168.1.101
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.101, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 31/31/32 ms
Switch#
Ok tout est en ordre!. il reste maintenant vrifier que le switch est bien configur pour autoriser les connexion telnet.
Les connexions telnet se font via les lignes VTY. Leur nombre varie selon les modles, on peut les retrouver en jettant un oeil sur la configuration
active:
6/7/2014 Activer laccs dadministration dun switch via telnet - CiscoMadeSimple.be
http://www.ciscomadesimple.be/2009/08/06/cisco-configuration-dun-switch-via-telnet/ 5/16
Switch#sh running-config
Building configuration...
Current configuration : 979 bytes
!
version 12.2
no service password-encryption
!
hostname Switch
!
!
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
6/7/2014 Activer laccs dadministration dun switch via telnet - CiscoMadeSimple.be
http://www.ciscomadesimple.be/2009/08/06/cisco-configuration-dun-switch-via-telnet/ 6/16
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
6/7/2014 Activer laccs dadministration dun switch via telnet - CiscoMadeSimple.be
http://www.ciscomadesimple.be/2009/08/06/cisco-configuration-dun-switch-via-telnet/ 7/16
!
interface GigabitEthernet1/1
!
interface GigabitEthernet1/2
!
interface Vlan1
ip address 192.168.1.100 255.255.255.0
!
ip default-gateway 192.168.1.1
!
line con 0
!
line vty 0 4
no login
line vty 5 15
no login
!
!
end
Switch#
Afin de pouvoir se connecter en telnet, on va dfinir un mot de passe, activer lencryption des mots de passe et galement dfinir un mot de passe
pour le mode privilgi (enable).
Switch#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#service password-encryption
Switch(config)#line vty 0 15
6/7/2014 Activer laccs dadministration dun switch via telnet - CiscoMadeSimple.be
http://www.ciscomadesimple.be/2009/08/06/cisco-configuration-dun-switch-via-telnet/ 8/16
Switch(config-line)#password cisco
Switch(config-line)#login
Switch(config-line)#exit
Switch(config)#enable password cisco
Switch(config)#exit
%SYS-5-CONFIG_I: Configured from console by console
Switch#
On vrifie que tout est en place:
Switch#sh run
Building configuration...
Current configuration : 1053 bytes
version 12.2
service password-encryption
hostname Switch
enable password 7 0822455D0A16
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
6/7/2014 Activer laccs dadministration dun switch via telnet - CiscoMadeSimple.be
http://www.ciscomadesimple.be/2009/08/06/cisco-configuration-dun-switch-via-telnet/ 9/16
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
6/7/2014 Activer laccs dadministration dun switch via telnet - CiscoMadeSimple.be
http://www.ciscomadesimple.be/2009/08/06/cisco-configuration-dun-switch-via-telnet/ 10/16
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet1/1
!
interface GigabitEthernet1/2
!
interface Vlan1
ip address 192.168.1.100 255.255.255.0
ip default-gateway 192.168.1.1
!
line con 0
!
line vty 0 4
password 7 0822455D0A16
login
!
line vty 5 15
password 7 0822455D0A16
login
!
end
Switch#
6/7/2014 Activer laccs dadministration dun switch via telnet - CiscoMadeSimple.be
http://www.ciscomadesimple.be/2009/08/06/cisco-configuration-dun-switch-via-telnet/ 11/16
Configuration simple de VLANS sur un switch Dfinition de routes IP statiques sous ubuntu 9.04
Voil, il ne reste plus qu se connecter en telnet depuisun PC branch sur le Switch via un des ports Fastethernet par exemple.
Rating: 9.3/10 (9 votes cast)
Activer l'accs d'administration d'un switch via telnet, 9.3 out of 10 based on 9 ratings
Partager :
Facebook 4 Twitter Google LinkedIn
Google+
Steve De Jongh
Avec mots-clefs Cisco, configuration, encryption, login, password, switch, telnet.Lien pour marque-pages : permalien.
4 ractions Activer laccs dadministration dun switch via telnet

Follow 102
WordPress:
J'aime
Soyez le premier aimer ceci.

Florent 15 septembre 2010 11:00


Bonjour,
A quoi sert le enable secret qui nest pas voqu ici?
Merci davance
Rpondre
6/7/2014 Activer laccs dadministration dun switch via telnet - CiscoMadeSimple.be
http://www.ciscomadesimple.be/2009/08/06/cisco-configuration-dun-switch-via-telnet/ 12/16
Steve De Jongh 16 septembre 2010 22:31
La commande enable secret sert dfinir un mot de passe pour passer du mote User EXEC au mode Piviledged EXEC .
Cest le mot de passe qui sera demand lorsquon entre la commande:
Router> enable
Le mot de passe dfini par enable secret est alors enregistr en running-config sous forme crypte, que lon ait ou non activ
lencryption des mots de passe ou non , contrairement la commande enable password qui dfini un mot de passe galement
pour passer de User EXEC Priviledged EXEC mais sans lencrypter.
Si les deux sont utiliss dans la config, cest le mot de passe dfini par enable secret qui sera utilis.
Rpondre
chan 29 octobre 2012 12:27
Bonjour,
je suis un peu perdu, pourquoi avoir mis ladresse de managent dans le vlan1, qui est le VLAN par dfaut.
je sais que dans se VLAN au quune des trams sont tagues.
Merci pour votre rponse
Rpondre
Steve De Jongh 29 octobre 2012 14:13
Le fait quune trame soit ou non tague na aucun impact sur laccs au management distance.
Ici, la config est faite sur linterface VLAN1 simplement parce que le VLAN 1 existe par dfaut sur tout switch manageable Cisco, mais
aurait pu tre faite sur une autre interface VLAN.
6/7/2014 Activer laccs dadministration dun switch via telnet - CiscoMadeSimple.be
http://www.ciscomadesimple.be/2009/08/06/cisco-configuration-dun-switch-via-telnet/ 13/16
Recherche
@cmsbe
De plus, ce nest pas parce quune trame circule dans un autre VLAN que celui par dfaut quelle est obligatoirement tague. Une trame
est tague uniquement lorsquelle voyage sur un Trunk (dot1q ou ISL) qui sert de liaison entre deux switches par exemple.
Pour simplifier, taguer une trame na pour but que dajouter une information permettant lquipement qui la reoit de la replacer dans
le bon VLAN mais modifier une trame revient la dnaturer et donc un quipement qui ne sait pas lire une trame tague la
rejettera (un PC par exemple).
Rpondre
Entrez votre commentaire...
Laisser un commentaire
Rechercher OK
6/7/2014 Activer laccs dadministration dun switch via telnet - CiscoMadeSimple.be
http://www.ciscomadesimple.be/2009/08/06/cisco-configuration-dun-switch-via-telnet/ 14/16
Dcodage dun mot de passe de type 7
wp.me/pBbKi-kL
CiscoMadeSimple.be
@cmsbe
Un peu de scurit pour nos routeurs
wp.me/pBbKi-kw
CiscoMadeSimple.be
@cmsbe
tendre
Retrouvez plus aisment les articles
wp.me/pBbKi-kq
CiscoMadeSimple.be
@cmsbe
Htes virtuels pour labo Cisco rel ...
suite et fin wp.me/pBbKi-jz
CiscoMadeSimple.be
@cmsbe
tendre
Htes virtuels pour labo Cisco rel
wp.me/pBbKi-jp
CiscoMadeSimple.be
@cmsbe
tendre
20h
18 Mai
2 Mai
25 Mars
24 Mars
Articles rcents
Dcodage dun mot de passe de type 7
Un peu de scurit pour nos routeurs
6/7/2014 Activer laccs dadministration dun switch via telnet - CiscoMadeSimple.be
http://www.ciscomadesimple.be/2009/08/06/cisco-configuration-dun-switch-via-telnet/ 15/16
Retrouvez plus aisment les articles
Htes virtuels pour labo Cisco rel suite et fin
Htes virtuels pour labo Cisco rel
Trunk dot1q et vlan natif
Configuration avance de trunks dot1q
Cisco HomeLab v2.0 finalis!
LIVE 02 : petit rappel
LIVE 02 : Routing & Troubleshooting .. Samedi 22 Fvrier
Catgories
Cisco
Fiches rcapitulatives
La pratique
La thorie
Routing
Switching
Vidos
Divers
GNS3
Les rseaux
La pratique
La thorie
Non class
Contribuez
6/7/2014 Activer laccs dadministration dun switch via telnet - CiscoMadeSimple.be
http://www.ciscomadesimple.be/2009/08/06/cisco-configuration-dun-switch-via-telnet/ 16/16
BTC:
1MbSHZV5Yh1kSjtPdVUqeTJD5z3fUDVKJt
Articles les mieux cots
10.0: Configuration d'un routeur en Frame-Relay Switching (7 votes)
10.0: Dfinition de routes IP statiques sous ubuntu 9.04 (5 votes)
10.0: Do It Yourself - Monter soi-mme un rack 19" ... (5 votes)
10.0: Mise en place d'un Access Server sur base d'un routeur Cisco 2509 (3 votes)
10.0: Frame-Relay - Configuration d'un topologie de type Full-Mesh (2 votes)
Archives
Choisir un mois
Connexion
Connexion
Actualits RSS
Commentaires RSS
CiscoMadeSimple.be | Propuls par Mantra & WordPress.