Vous êtes sur la page 1sur 4

FUNCIONES ANIDADAS

DIANA E. LOPEZ IMITOLA



FUNCIONES ANIDADAS

En algunos casos, puede que deba utilizar una funcin como uno de los
argumentos (argumento: valores que utiliza una funcin para llevar a cabo
operaciones o clculos. El tipo de argumento que utiliza una funcin es
especfico de esa funcin. Los argumentos ms comunes que se utilizan en las
funciones son nmeros, texto, referencias de celda y nombres.) de otra funcin.
Por ejemplo, la siguiente frmula utiliza una funcin anidada PROMEDIO y
compara el resultado con el valor 50.



Resultados vlidos

Cuando se utiliza una funcin anidada como argumento, deber devolver el
mismo tipo de valor que el que utilice el argumento. Por ejemplo, si el
argumento devuelve un valor VERDADERO o FALSO, la funcin anidada
deber devolver VERDADERO o FALSO. Si ste no es el caso, Microsoft Excel
mostrar el valor de error #VALOR!

Lmites del nivel de anidamiento:

Una frmula puede contener como mximo siete niveles de funciones
anidadas. Si la Funcin B se utiliza como argumento de la Funcin A, la
Funcin B es una funcin de segundo nivel. Por ejemplo, la funcin
PROMEDIO y la funcin SUMA son ambas funciones de segundo nivel porque
son argumentos de la funcin SI. Una funcin anidada dentro de la funcin
PROMEDIO ser una funcin de tercer nivel, etc.

Referencias en las frmulas

Una referencia identifica una celda o un rango de celdas en una hoja de clculo
e indica a Microsoft Excel en qu celdas debe buscar los valores o los datos
que desea utilizar en una frmula. En las referencias se puede utilizar datos de
distintas partes de una hoja de clculo en una frmula, o bien utilizar el valor de
una celda en varias frmulas. Tambin puede hacerse referencia a las celdas
de otras hojas en el mismo libro y a otros libros. Las referencias a celdas de
otros libros se denominan vnculos.


Ejemplo 1:

En el siguiente ejemplo, si el valor de la celda A2 es 100, la prueba lgica ser
verdadero, y se calculara la suma total del rango A2:A7. De lo contrario, si la
prueba_lgica es Falso, se devolver una cadena de texto vaca (), se borrara
el contenido de la celda que contenga la funcin Si:

Prueba lgica = A2=100

Valor_Si_Verdadero sumatoria del rango

Valor_Si_Falso: Cadena de texto vaca ()

1. Inserte en una hoja de Excel los siguientes datos, tal como se indica en
la columna A y B respectivamente

A B
VALORES SUMA
1 100
2 80
3 100
4 100
5 88
6 100


2. Haga clic en la celda B2 para activarla y escriban la siguiente funcin:

=SI(A2=100;SUMA($A$2:$A$7)

3. Arrastre el cursor para ver los resultados

Ejemplo 2


Objetivo venta 30000


Precio promedio Minino 15


Comisin 1 5%


Comisin 2 15%

A B C D
VENDEDOR VENTAS PRECIO PROMEDIO COMISIN
CARLOS MARTINEZ 36000 16
ANDRES CARDONA 38000 18
JORGE SANTOS 40000 19
MARTA GUERRERO 25000 12
0 0



Se dese saber la formula que permita hallar la comisin que corresponda.
Se va armar la formula para la celda D7 siguiendo el esquema de arriba
Lo primero es resolver si se cumplen las dos condiciones as:
Y(B7>$C$1;C7>C2)
o B7: Ventas del vendedor 1
o $C$1: Objetivos de ventas (referencias fijas porque no cambiara
los distintos vendedores)
o C7: Precio promedio vendedor.
o $C$2: Objetivos de precio.
Ya tenemos la primera parte de la funcin:
SI(se cumplen ambas condiciones; 15% de comisin(valor_si_verdadero);
<Ac necesitamos armar la otra condicin del segundo cuadrado azul del
diagrama)
=SI(Y(B7>$C$1;C7>$C$2);$C$4;<Valor si falso>) [1]
Ahora debemos armar la parte de la derecha del diagrama, cuando NO se
cumplen ambas condiciones.
O(B7>$C$1;C7>$C$2)
Si la funcin da verdadero, corresponde el segundo nivel de comisin (que
definimos en la celda C3). La nica forma en que la evaluacin da FALSO, es
si ninguna de las condiciones se cumple. Por lo tanto, corresponde 0% de
comisin.
=SI(O(B7>$C$1;C7>$C$2);$C$3;0%) [2]
Al incluir esta ltima frmula en la frmula [1], tenemos para la celda D7:
=SI(Y(B7>$C$1;C7>C2);$C$3;SI(O(B7>$C$1;C7>C2);$C$4;0%))









TALLER A DESARROLLAR
Funciones lgicas Y O se utilizan anidadas dentro de la funcin SI, para
obtener un resultado con sentido.
Ejercicio 1
1. Cree la siguiente tabla en Excel
2. Si el porcentaje de inasistencia es menor e igual que 25 y la nota es
mayor que igual que 4, debe mostrar aprobado, de lo contrario
desaprobado.
3. Si el porcentaje de inasistencia es menor e igual que 25 o la nota es
mayor que igual que 4, debe mostrar aprobado, de lo contrario
desaprobado.


ALUMNOS % DE
INASISTENCIAS
NOTA SI - Y SI - O
A 25 7
B 30 6
C 12 10
D 10 4
E 45 5
F 8 7
G 20 5