Vous êtes sur la page 1sur 9

Comandos para Switch Cisco

S(config)# hostname (nombre)


configura el nombre del switch
S(config)#enable secret (contrasea)
contrasea para modo privilegiado
----------------------------------------------------------------------------------------------------------------------------------------------------------S(config)#line console 0
configura contrasea para acceder por consola
S(config-line)#password (contrasea)
S(config-line)#login
S(config-line)#logging synchronous
evita que los mensajes de consola interrumpan los comandos
----------------------------------------------------------------------------------------------------------------------------------------------------------S(config)#line vty 0 15
configura contrasea para acceso por telnet
S(config-line)#password (contrasea)
S(config-line)#login
----------------------------------------------------------------------------------------------------------------------------------------------------------S(config)#service password-encryption
encripta las contraseas
S(config)#banner motd #(mensaje)#
mensaje inicial
----------------------------------------------------------------------------------------------------------------------------------------------------------S#wr
copia el running config al startup config
S(config)#no ip domain-lookup
evita la bsqueda no deseada del sistema de nombres de dominio
----------------------------------------------------------------------------------------------------------------------------------------------------------S#erase startup-config
borra el archivo de configuracin de inicio
S#delete vlan.dat
borra el archivo de las vlan almacenadas
S#reload
----------------------------------------------------------------------------------------------------------------------------------------------------------S(config)#interface vlan 1
configuracin (default vlan1) para acceder localmente al switch
S(config-if)#ip address (ip)_(mascara)
S(config-if)#no shutdown
----------------------------------------------------------------------------------------------------------------------------------------------------------Seteo de default Gateway
S(config)#ip default-gateway (ip)
para acceder al switch desde otras redes (acceso remoto)
----------------------------------------------------------------------------------------------------------------------------------------------------------Configuracin de puerto enrutado (switch capa 3)
S(config)#interface f0/6
para accesar a la interfaz fast Ethernet 6
S(config-if)#no switchport
deshabilita el puerto para usarlo como puerto de capa 3
S(config-if)#ip address (ip)_(mascara)
S(config-if)#no shutdown
Activar SSH en Switch y Router
SSH->puerto TCP 22
TELNET->puerto TCP 23
S(config)#ip domain-name (cisco.com)
configura el dominio IP
Genera pares de claves RSA
S(config)#crypto key generate rsa

S(config)#crypto key generate rsa general-keys modulus (1024)


Autenticacin local de SSH
S(config)#username (usuario) secret (password)
Configuracion de lneas vty para habilitar protocolo SSH
S(config)#line vty 0 15
S(config-line)#transport input ssh
habilita sesiones SSH
S(config-line)#login local
para usar la base de datos de usuarios locales
----------------------------------------------------------------------------------------------------------------------------------------------------------S(config)#ip ssh versin 2
configura la versin 2 de ssh
----------------------------------------------------------------------------------------------------------------------------------------------------------S(config)#crypto key zeroize rsa
elimina el par de claves RSA
-----------------------------------------------------------------------------------------------------------------------------------------------------------

Cerrar sesin luego de inactividad


S(config)#line console 0
S(config-line)#exec-timeout 5 0

5 minutos de inactividad para cerrar sesin

S(config)#line vty 0 15
S(config-line)#exec-timeout 5 0

5 minutos de inactividad para cerrar sesin

Seleccionar interfaces por rango


S(config)#interface-range f0/1-4, f0/7-24, g0/1-2
S(config-if-range)#shutdown
desactiva las interfaces seleccionadas en el comando anterior
----------------------------------------------------------------------------------------------------------------------------------------------------------Configuracin de la interfaz de administracin de un Switch
Creacin de una VLAN
S(config)#vlan (id de vlan, 99)
S(config-vlan)#name (nombre de vlan)
le da nombre a la VLAN
S(config-vlan)#exit
Seteo de ip para acceso remoto a VLAN
S(config)#interface vlan (id vlan, 99)
S(config-if)#ip address (ip)_(mascara)
S(config-if)#no shutdown
Asociacin de puerto (o rango de puertos) para una VLAN
S(config)#interface (f0/6)
S(config-if)#switchport mode access
establece el puerto en modo de acceso
S(config-if)#switchport access vlan (id de vlan, 99)
Seteo de Gateway para acceso remoto
S(config)#ip default-gateway (ip)
S(config)#end
Cambio de VLAN
S(config-if)#no switchport acces vlan
Eliminacin de VLAN
S(config)#no vlan (id_vlan)
----------------------------------------------------------------------------------------------------------------------------------------------------------S#clear mac address-table dynamic
elimina las direcciones mac existentes
----------------------------------------------------------------------------------------------------------------------------------------------------------Seteo de mac estatica para un puerto perteneciente a una VLAN
S# mac address-table static (xxxx.xxxx.xxxx) vlan (id vlan, 99) interface (f0/6)
Quitar mac estatica
S#no mac address-table static (xxxx.xxxx.xxxx) vlan (id vlan, 99) interface (f0/6)
----------------------------------------------------------------------------------------------------------------------------------------------------------Seteo manual de full/half dplex y velocidad
S(config)#interface f0/6
S(config-if)#duplex (full/half)
S(config-if)#speed (10/100/1000)
----------------------------------------------------------------------------------------------------------------------------------------------------------Auto MDIX (obligatorio dplex auto, speed auto)
S(config)#interface f0/6
S(config)#duplex auto
S(config)#speed auto
S(config)#mdix auto
Examinar configuracin auto mdix
S#show controllers Ethernet-controller f0/6 phy | include Auto-MDIX

----------------------------------------------------------------------------------------------------------------------------------------------------------Seleccionar y desactivar puertos


S(config)#interface range f0/1-24

S(config)#interface range f0/1-4, f0/7-21


S(config-if)#shutdown
desactivo las interfaces seleccionadas
----------------------------------------------------------------------------------------------------------------------------------------------------------Snooping DHCP
S(config)#ip dhcp snooping
habilita la deteccin de DHCP
S(config)#ip dhcp snooping vlan (vlan id, 10,20) habilita la deteccin de DHCP para VLAN
S(config)#interface f0/6
define el o los puertos confiables
S(config-if)#ip dhcp snooping trust
define los puertos como confiables
S(config)#interface f0/6
define el o los puertos no confiables
S(config-if)#ip dhcp snooping limit rate 5
limita la velocidad de ataques para las solicitudes falsas
----------------------------------------------------------------------------------------------------------------------------------------------------------Direcciones MAC seguras estticas en modo de configuracin de la interfaz (config-if)
S(config-if)#switchport port-security mac-address (xxxx.xxxx.xxxx)
Direcciones MAC seguras persistentes en modo configuracin de la interfaz (config-if)
S(config-if)#switchport port-security mac-address sticky
Direcciones MAC seguras persistentes estticas
S(config-if)# switchport port-security mac-address sticky (xxxx.xxxx.xxxx)
Verificacion de direcciones MAC configuradas
S#show port-security interface f0/6
----------------------------------------------------------------------------------------------------------------------------------------------------------Protocolo de hora de red NTP
S(config)#ntp master (capa, 1 - 15)
configura un equipo como reloj maestro
S(config)#ntp server (ip)
permite que un servidor ntp sincronice el reloj del software
S#show ntp associations
muestra la verificacin de NTP
----------------------------------------------------------------------------------------------------------------------------------------------------------Configuracin de enlaces troncales
S(config)#interface f0/6
S(config-if)#switchport mode trunk
la interfaz cambia al modo troncal de forma permanente
S(config-if)#switchport trunk native vlan id
especifica una vlan nativa
S(config-if)#switchport trunk allowed vlan ids para limitar las vlans permitidas
Restablecimiento de enlaces troncales
S(config-if)#no switchport trunk allowed vlan permite todas las vlan
S(config-if)#no switchport trunk native vlan restablece la vlan nativa al valor por default
----------------------------------------------------------------------------------------------------------------------------------------------------------S#show ip ssh
S#show ip interface brief
S#show vlan brief
S#show mac address-table ?
S#show mac address-table dynamic
S#show vlan
S#show interface vlan (id vlan, 99)
S#show running-config
S#show startup-config

verifica el status de ssh


ver ip, ver el estado de los puertos y de las interfaces del switch
muestra todas las vlan y su status
muestra las opciones de la tabla de direcciones mac
muestra las direcciones mac detectadas dinmicamente

verifica las configuraciones del switch

S#show version
S#show flash
S#show interfaces f0/6
S#show processes
S#show cdp neighbors
S#show arp

muestra informacin estadstica y de estado de la interfaz (!)

Configuracin de interfaces para router


R(config)#interface g 0/0
R(config-if)#ip address (ip) (mascara)
R(config-if)#description (Link to LAN-10)
R(config-if)#no shutdown
Habilitar ipv6
R(config)#ipv6 unicast-routing
RIP ipv4
R(config)#ip route 0.0.0.0 0.0.0.0 (interfaz salida) (ip-siguiente salto) ruta predeterminada (internet)
R(config)#router rip
R(config-router)#version 2
R(config-router)#default-information originate
propaga la ruta predeterminada
R(config-router)#no auto-summary
deshabilita autosumarizacin
R(config-router)#passive-interface g0/0
la interfaz no propaga actualizaciones
R(config-router)#network 192.168.1.0
RIPng ipv6
En ipv6, las redes no se anuncian, se configuran para cada interfaz
R(config)#ipv6 unicast-routing
R(config)#interface g0/0
R(config)#ipv6 rip dominio enable
R(config)#no shutdown
R(config)#ipv6 route 0::/0 (interfaz salida) (ip-siguiente salto) ruta predeterminada ipv6
R(config)#ipv6 rip dominio default-information originate
propagacin de ruta predeterminada
R#show ip route
muestra los detalles de la ruta
Desactivar CDP
R(config)#no cdp run
R(config-if)#no cdp enable

desactiva cdp globalmente


desactiva cdp en una interfaz

Enrutamiento
Arranque en frio: Los router detectan sus redes directamente conectadas en el inicio.
Horizonte dividido: En protocolos de routing vector distancia (RIP), evita que la informacin se enve desde la misma
interfaz en la que se recibi dicha informacin.
Clasificacin de los protocolos de routing:

Sistema autnomo (AS): (Dominios de routing) conjunto de routers bajo una misma administracin comn, como
una empresa o una organizacin, Ej: red interna de una empresa y la red de un ISP.

Protocolo de Gateway interior (IGP): para routing dentro de un AS. Protocolos: RIP, EIGRP, OSPF, IS-IS.
Protocolo de Gateway exterior (EGP): para routing entre AS. Protocolos: BGP.
Protocolos de enrutamiento vector distancia: El router que usa este tipo de enrutamiento solo conoce la distancia
(mtrica) y que ruta o interfaz se usa para alcanzarla, no tienen un mapa en s de la topologa de la red y envan
actualizaciones peridicamente.
Protocolos de enrutamiento de estado de enlace: Un router de estado de enlace usa la informacin de estado de
enlace para crear un mapa de la topologa y seleccionar la mejor ruta hacia todas las redes de destino. Las
actualizaciones se hacen cuando hay un cambio en la topologa.

El router es el DTE, se conecta a un modem referente a la tecnologa WAN que tiene que estar sincronizado DCE
El cable smart tiene en los extremos DCE DTE, o cable nulo (no necesita modem) y en el router que va a ser DCE
(sincronizador) tiene que setear el comando R(config-if)#clock rate (velocidad 56000, 128000)
En ipv6 se necesita saber las direcciones globales y link local (tipo unicast), las globales son las direcciones que
pueden enrutarse. Las link local sirven para comunicacin interna mediante ipv6. Las direcciones link local (fe80::1)
se generan automticamente al setear direcciones globales.
La mascara aqu se denomina la longitud de prefijo, las direcciones se denominan prefijo. La longitud del prefijo
indica cuantos bits se toman del prefijo para ubicar la red
Id de interfaz: porcin de host (eui-64)-> coge la mac address y la parte en 2 (24 bits) y en la mitad se rellena con
letras y el bit mas significativo se cambia

Las interfaces virtuales en los router se llaman loopback, esto es til con OSPF
R(config)#interface loopback 0
R(config-if)#ip address

SVI switch virtual interface: Son interfaces virtuales que proporcionan un medio para administrar un switch de
forma remota a travs de una red usando IPv4. Cada switch viene con una SVI que aparece en la configuracin
predeterminada inicial. La SVI predeterminada es interface VLAN1.
Tambin se deben configurar SVI para permitir el enrutamiento entre redes VLAN. Para crear una ruta entre dos o
mas redes VLAN, cada VLAN debe tener habilitada una SVI independiente (switch de capa 3).
Cargador de arranque de un Switch: proporciona acceso al switch si no se puede usar el sistema operativo debido a
la falta de archivos de sistema o daos. El cargador de arranque tiene una lnea de comandos que proporciona
acceso a los archivos almacenados en la flash.
Pasos para acceder al cargador de arranque:
Conecte una pc al puerto consola, configure un software de emulacin de terminal para conectarse al switch
Desconecte el cable de alimentacin del switch
Vuelva a conectar el cable de alimentacin, espere 15 seg y luego presione y mantenga presionado el botn
MODE mientras el led sigue parpadeando con luz verde
Contine oprimiendo el botn MODE hasta que el led cambie de color a mbar y luego a verde, despus
suelte el botn MODE
Aparece la peticin de entrada switch: del cargador de arranque en el software de emulacin de terminal
Comando show interfaces
El resultado del comando show interfaces se puede usar para detectar problemas frecuentes de los medios, una de
las partes mas importantes de este resultado es la visualizacin del estado de protocolo de lnea y de enlace de
datos.
S1#show interfaces f0/1
FastEthernet0/1 is up, line protocol is up
El parmetro FastEthernet se refiere a la capa de hardware y refleja si la interfaz recibe la seal de deteccin de
portadora del otro extremo. El segundo parmetro line protocol se refiere a la capa de enlace de datos y refleja si se
recibenlos keepalives del protocolo de capa de enlace de datos.
Los posibles problemas se pueden reparar de la siguiente manera:
Interfaz activa y protocolo inactivo: puede haber una incompatibilidad en el tipo de encapsulacin, la
interfaz en el otro extremo puede estar inhabilitada por errores o presuntos problemas de hardware.
Interfaz inactiva y protocolo inactiva: hay un cable que no esta conectado o existe algn problema de
interfaz. El otro extremo de la conexin puede estar administrativamente inactivo.
Interfaz administrativamente inactiva: se inhabilito manualmente la configuracin activa (se emitio
shutdown).
Resolucion de problemas de los medios del switch
Interfaz Inactiva
Verifique que se usen cables adecuados, revise los cables y conectores.
El problema puede deberse a una incompatibilidad en la configuracin de velocidad, establezca
manualmente la misma velocidad en ambo extremos en caso de sospecha.
Interfaz activa
Busque indicios de ruido excesivo, estos pueden traducirse en aumento de los contadores de fragmentos de
colision, giants y runts y errores de CRC, verifique el tipo de cable y que no supere la longitud mxima, se
recomienda cables utp al menos de categora 5.
Si hay excesos de colisiones o colisiones tardas verifique la configuracin de dplex an ambos extremos, si
pareciera haber una incompatibilidad de dplex, configrelo manualmente en ambos extremos.

Snooping DHCP
Snooping DHCP es una funcin que determina cuales son los puertos de switch que pueden responder a solicitudes
de DHCP. Los puertos se identifican como confiables o no confiables. Los puertos confiables pueden recibir todos los
mensajes de DHCP, incluidos los paquetes de oferta de DHCP y de acuse de recibo de DHCP, los puertos no
confiables solo pueden recibir solicitudes. Los puertos confiables de los host se alojan en el servidor de DHCP o
pueden ser un enlace hacia dicho servidor. Si un dispositivo no autorizado en un puerto no confiable intenta enviar
un paquete de oferta de DHCP a la red, el puerto se desactiva. Esta funcin puede unirse con las opciones de DHCP
donde la informacin del switch, como el ID de puerto o la solicitud de DHCP pueden insertarse en el paquete de
solicitudes de DHCP.
Seguridad del Puerto
La seguridad de puerto limita la cantidad de direcciones MAC validas permitidas en el puerto. Se permite acceso a las
direcciones MAC de los dispositivos legtimos, mientras que otras direcciones MAC se rechazan. La seguridad de
puertos se puede configurar para permitir una o ms direcciones MAC. Si la cantidad de direcciones MAC permitidas
en el puerto se limita a una, solo el dispositivo con esa direccin MAC especifica puede conectarse correctamente al
puerto.
Tipos de direcciones MAC seguras: Existen varias maneras de configurar la seguridad de puerto. El tipo de direccin
segura se basa en la configuracin e incluye lo siguiente:
MAC seguras estticas
son direcciones MAC que se configuran manualmente en un puerto
mediante comando switchport port-security mac-address (direccin mac). Las direcciones configuradas de
esta forma se almacenan en la tabla de direcciones y se agregan a la configuracin en ejecucin del switch.
MAC seguras dinmicas
son direcciones detectadas dinmicamente y se almacenan solamente en la
tabla de direcciones. Las direcciones MAC configuradas de esta manera se eliminan cuando el switch se
reinicia.
MAC seguras persistentes
son direcciones MAC que pueden detectarse de forma dinmica o
configurarse de forma manual, y que despus se almacenan en la tabla de direcciones y se agregan a la
configuracin en ejecucin.