Vous êtes sur la page 1sur 16

Rsum

Cet article s'adresse un public confirm.La "Quality of service" ou QOS est la gestion et
l'optimisation de la bande passante d'un rseau pour offir au client une solution garantie.Cet
article permet la mise en place d'une qualit de service sur un rseau grce l'implmentation
QOS prsente sur les routeurs CISCO.

Sommaire
1. Presentation.
1.1 Configuration d'une QoS.
1.2 QoS configuration sur une interface.
1.3 Dispositif support par La QoS.
2. QoS modulaire CLI-Class Map.
2.1. Crer une Class Map .
3. QoS modulaire CLI-Policy Map.
3.1. Crer une Policy Map.
3.2. Dfinir les polices QoS.
3.3. Spcifier un Committed Access Rate .
3.4. Spcifier une police Percent-Based .
3.5. Activer le WRED (Weighted Random Early Detection).
3.6. Configurer une rservation de queue de bande passante.
3.7. Configurer Low-Latency Priority sur les files dattentes.
4. QoS modulaire CLI-Service Policy.
4.1. Configurer une oversubscription de circuit virtuel.
4.2. Configurer VCO sur Frame Relay et IEEE 802.1Q.
4.3. Configurer des VC Oversubscription pour les VC ATM.
4.4. Dfinir la police QoS de 3 niveaux hirarchiques.
4.5. Configurer un Traffic Shaping gnrique.
4.6. Classe Class-Default.

1) Prsentation.
La qualit de service (QoS) est une proccupation pour les fournisseurs de services et les
rseaux WAN (Wide Area Network) qui ajoutent toujours plus de trafic voix et vido un trafic
de donnes dont le volume ne cesse lui-mme d'augmenter. Le trafic critique est trs sensible
aux dlais, notamment celui des frquences vocales, il doit bnficier d'une QoS suprieure
celle rserve d'autres trafics moins sensibles au paramtre temps, notamment la messagerie
lectronique ou le transfert de fichiers. Les cots des liaisons WAN haut dbit tant trop levs
pour la plupart des utilisateurs, augmenter la bande passante est rarement une solution
acceptable pour de nombreux points du rseau, ce qui explique que l'optimisation de la bande
passante et l'utilisation diffrencie de cette dernire soient devenues une proccupation
majeure.

1.1) Configuration dune QoS.


La QoS est la capacit dun rseau fournir des services spcifiques avec une slection de trafic
dtermin travers diffrentes technologies comme le Frame Relay ,lATM, les rseaux Ethernet
et la norme 802.1,SONET,et les rseau IP routs. Le dispositif QoS sur le routeur Cisco 10000
series fournit les services suivants :

Congestion management (gestion des congestions rseau)


Congestion avoidance (permet dviter les congestions)
Traffic policing (mise en place de rgles de trafics)
Traffic shaping (optimisation du trafic)
Capacit manipuler diffrents services et la mise en queue des paquets.

Figure 1-1 Montre la procdure de la configuration de la QoS sur une interface.

Figure 1-1 Processus Quality of Service

1.2) QoS Configuration sur une interface.


Le service de police appliqu une interface nous montre directement comment le routeur Cisco
10000 series manipule les paquets recus sur une interface.Les services de police consistent:
Traffic classes (class maps)Dfinissent comment le routeur classifie les paquets reus sur
une interface.
Traffic policies (policy maps)Dfinissent les actions et les rgles appliques sur les paquets.
Les class maps sont associs avec des policy maps et les policy maps sont
appliques ensuite aux interfaces.
Pour configurer une QoS sur une interface en utilisant la QoS modulaire CLI ,il faut respecter
trois tapes :
Etape Configurer une classe de trafic en utilisant la commande class1
map.
Etape Configurer une police de trafic en utilisant la commande policy2
map et associer une classe de trafic avec la police.
Etape Attacher la police de trafic une interface en utilisant la
3
commande service-policy

1.3) Dispositif support par La QoS.


Le routeur cisco 10000 series supporte les dispositifs QoS suivants :
Committed access rate (CAR)Mesure le niveau du trafic et excute des actions comme le
rejet de paquets.
Percent-Based PolicingPermet de configurer une police de trafic en pourcentage de la
bande passante sur linterface rseau sur laquelle la police est applique.
Weighted random early detection (WRED)Utilise un algorithme pour ignorer
alatoirement des paquets lorsque le trafic est congestionner. Cette approche diminue la
congestion en rduisant la vitesse dmission des paquets.
Bandwidth reservation (also referred to as fair queueing)Assigne de la bande
passante certain flux de paquets.

Low-latency priority queueingPeut tre assign pour le trafic en temps rel comme la
voix ou la vido.
Traffic shapingEst utilis pour contrler le trafic en maintenant le flux de donnes un
taux dtermin.
SetSpcifie une priorit IP (DSCP) qui est utilise par les autres routeurs pour la gestion de
QoS.
Frame Relay interface queueingAssocie chaque numro de DLCI (numro fix lors de la
cration dun Private Virtual Circuit) une file dattente non prioritaire au niveau de linterface.
802.1q supportPermet la commutation PXF pour lencapsulation ARPA.

2) QoS modulaire CLI(Command Line Interface).


Le routeur Cisco 10000 series utilise linterface modulaire QoS CLI pour configurer le dispositif
QoS sur le routeur. La QoS modulaire CLI est constituer de trois lments principaux :
Class map
Policy map
Service policy

2.1) QoS modulaire CLIClass Map.


Une class map permet de classifier le trafic en entrant ou en sortant sur une interface. La
class map dfinie les critres utiliser pour diffrencier le trafic. Par exemple ,vous pouvez
utiliser la class map pour diffrencier un trafic voix dun trafic dun trafic data, bas sur une
srie de critres dfinis en utilisant la command match.
La command match est utiliser en mode de configuration globale pour crer une class map
:
Router(config)# class-map [match-any | match-all] class-map-name
match-any : un ou plusieurs critres doit correspondre.
match-all : tous les critres doivent correspondre.
Class-map-name : nom de la class map .
Utilisez la command no class-map pour supprimer une class map .
Cisco IOS software supporte un maximum de 255 class maps .

2.1.1) Crer une Class Map .


Pour crer une class map et spcifier la manire dont le routeur va classifier le trafic ,entrer
les commandes suivantes dans le mode de configuration globale:
Commande

Description

Match-any une seule rgle


est suffisante pour
lappartenance la
classe.Match-all seulement
les paquets correspondant
tous les critres font
Etape Router(config)# class-map [matchpartie de la classe.Note
1
any | match-all] class-map-name
:Le routeur va utiliser la
rgle macth-all si aucune
rgle ne lui a t
prcise.Class-map-name
est compos soit de
numros soit de lettres.
Etape Router(config-class-map)# match
2
match_statement

Dfinie les critres de


classification pour la class
map. Match_statement
dfini les paramtres de

correspondance.
Exemple 1 Montre comment crer trois class map nommes voice-traffic ,data,et
application.
Exemple 1 Crer une class map.

Router(config)# class-map voice-traffic


Router(config-cmap)# match ip rtp 16384 16383
Router(config-cmap)# exit
Router(config)# class-map data
Router(config-cmap)# match ip precedence 1
Router(config-cmap)# exit
Router(config)# class-map application
Router(config)# match ip precedence 2

Note : le dispositif IP RTP offre toutes les fonctionnalits de la


commande ip rtp reserve ,elle permet de spcifier une plage de ports
(UDP)/RTP (de 16384 32767) sur lesquels le trafic est strictement
garantie prioritaire par rapport au autre queues ou classes sur la mme
interface sortante.La priorit RTP est spcialement utilis sur des liens
dune bande passante infrieur 1.544Mbps.

Exemple 2 Dfinir les critres de correspondance.


Exemple 2 crer une class map nommes mink qui spcifie au routeur de chercher les
paquets appartenant laccess-list 1 ou qui ont une valeur de priorit IP de 3 ou 7.
Router(config)# class-map mink
Router(config-cmap)# match access-group 1
Router(config-cmap)# match ip precedence 3 7
Options match_statement :
Les options match_statement dfinissent les critres de correspondance pour une class map. Ils
dterminent comment le routeur classifie les paquets arrivant sur une interface.
Utiliser les options suivante pour dfinir les critre de classification pour la commande
match_statement:
match access-group numberPrcise que le paquet doit tre autoriser par l access group
(numro de laccess group entre 1 et 2699).
match access-group name access-list-nameSpcifie que le paquet doit tre autoriser
par lacces-list dont le nom est saisie et laccess group laquelle elle appartient.
match anyspcifie que tout les paquets appartiennent la classe .
match input-interface interface-namePrcise que les paquets entrant dans linterface
doivent correspondre linterface prciser.
match ip dscp ip-dscp-value [ip-dscp-value ip-dscp-value ip-dscp-value]Prcise que
la valeur du paquet (DSCP) faire correspondre une ou plusieurs ip value de 0 63.
match ip precedence ip-precedence-value [ip-precedence-value ip-precedence-value
ip-precedence-value]Spcifie que la priorit IP du paquet doit correspondre avec une ou
plusieurs valeur de priorit , entre 0 et 7.Il est possible de spcifier jusqu 8 valeurs de
priorits.
match qos-group numberDfini que le numro du groupe de paquet QoS doit tre entre 0

et 99.
match ip rtp lowest-udp-port:2000-65535 range:0-16383Utiliser pour faire
correspondre un paquet qui a un numro de port UDP inclus dans la fourchette spcifie.

3) QoS modulaire CLIPolicy Map.


Une policy map dfinie les actions et les rgles de QoS et les associe avec une class map
. Au sein dune policy map il est possible de dfinir des actions comme la surveillance et la
class-based weighted fair queuing cest dire la dfinition de files dattentes ou queues
class selon un poids. (Class Based Weight Fair Queue).
La commande policy-map sutilise en mode de configuration globale pour crer ou modifier une
policy map :
Router(config)# policy-map policy-map-name

Policy-map-name : nom de la policy map .

3.1) Crer une Policy Map.


Pour crer une policy map saisissez les commandes suivantes en mode de configuration globale:
Commande

Description

Etape Router(config)# policy1


map policy-map-name

Cr ou modifie une policy map


nomme en mode de configuration
globale.policy-map-name peut tre
soit des chiffre soit des lettres.

Etape Router(config-pmap)#
2
class class-map-name

Dfini la classe sur laquelle la policy


map sera active.Note : Sur une
interface donne ,le routeur utilise la
classe nomme class-default pour
assigner les polices QoS tous les
paquets qui nappartiennent pas aux
classes dfinies dans une policy
map.

Tip Le Cisco 10000 serie manage les paquets aussitt qune


correspondance a t trouve. Pour augmenter la performance QoS
,assigner les classes de trafic une policy map en commencent par la
classe qui va matcher le plus de paquets.

Exemple 3 assigne la class map nomme mink la policy map nomme lynx.
Exemple 3 Assigner une classe une policy map.
Router(config)# policy-map lynx
Router(config-pmap)# class mink
Router(config-pmap-c)#

Exemple 4 La classe par dfaut est assigne la policy map nomme lynx :
Exemple 4 Assigner la classe par dfaut une policy map.
Router(config)# policy-map lynx
Router(config-pmap)# class class-default

3.2) Dfinir les polices QoS.


Une fois que vous avez cre une policy map et que vous lavez associ une classe de trafic
vous tes prs dfinir les actions que vous voulez que le routeur excute pour une classe
particulier de trafic .
Le Tableau 1 rsume les actions policy map que le routeur supporte.
Tableau 1 Actions Policy Map
Commande

Description

set atm-clp

Fixe le rglage du bit de priorit de perte de


cellules(CLP).

set ip dscp ip-dscp-value

Marque un paquet en attribuant son IP le


DSCP dans le bit type of service TOS.ip-dscpvalue est un nombre de 0 63 qui dfini la
valeur IP DSCP.

Attribue la valeur de priorit dans lentte


IP :0routine, 1priority, 2immediate,3
set ip precedence number |
flash, 4flash-override, 5critical6
name
internet, 7network
set mpls experimental
value

Configure une police pour dfinir le champs


MPLS exprimental.Valeur qui spcifie la
valeur utilis pour dfinir le bit MPLS
exprimental dcrit par la policy map. Les
valeurs possibles sont de 0 7.

set qos-group group-id

Dcrit un ID de group qui peut tre utilis


aprs pour classifier les paquets.group-id
entre 0 et 99.

police bps [normal-burst |


max-burst] [conformaction action | exceedConfigure le dispositif de police de trafic.
action action | violateaction action]
Random detect dscp
dscpvalue min-threshold
max-threshold [markprobability-denominator]

Change le seuil minimum et maximum des


paquets pour la valeur DSCP.

Random detect precedence


{precedence | rsvp} minConfigure les paramtres WRED pour une
threshold max-threshold
priorit IP particulire.
mark-probabilitydenominator
queue-limit number-ofpackets

Spcifie le nombre maximum de paquets que


la file dattente peut contenir pour cette
classe.number-of-packets est un nombre

entre 1 to 64.
Bandwidth {interzone |
total | session} {default |
zone zone-name}
bandwidth-size

Spcifie la bande passante maximum.

Bandwidth {bandwidthkbps | percent percent}

Spcifie ou modifie la bande passante al


loue pour une classe appartenant une
policy map.

Priority {bandwidth-kbps |
Assigne une priorit une classe de trafic
percent percentage}
appartenant une policy map.
[burst]
Shape [average | peak]
mean-rate [[burst-size]
[excess-burst-size]]

Limite le trafic un taux spcifi.

Note :La valeur ip dscp est une valeur dfinie par ladministrateur.

3.3) Spcifier un Committed Access Rate .


Le dispositif Committed Access Rate ,terme dfini par Cisco, mesure le taux de trafic et bas
sur ces information prend des dcisions (comme le rejet de paquets).Un client a toujours un
dbit garanti ,le CAR permet de prendre des dcision si par exemple le client dpasse le dbit
garanti.
Tableau 2 Une liste des actions CAR que le routeur supporte.
Tableau 2 Actions CAR
Action

Description

Drop

Abandonne les paquets.

set-dscp-transmit Dfini la valeur DSCP (Differentiated Services Code


new-dscp
Point) et transmet les paquets. Valeur entre 0 et 63.
set-prec-transmit
Dfini la priorit IP et envoi les paquets. Valeur entre
new-prec
0 et 7.
set-qos-transmit
new-qos

Dfini le groupe QoS et envoi les paquets. Valeur


entre 0 et 99.

Transmit

Envoi les paquets.

Pour spcifier un CAR ,entrer les commandes suivantes dans le mode de configuration des
policy-maps:
Commande

Description

Router(config-pmap-c)# police
bps [normal-burst | max-burst]
[conform-action action | exceedaction action | violate-action action]

Spcifie un CAR.Utiliser cette


commande pour contrler le trafic
de faible priorit, par consquent
une interface a plus de bande
passante pour le trafic de haute
priorit ou pour imposer un dbit
spcifique sur une interface.bps est
une valeur de 8000
2.000.000.000 bits par seconde. Si

vous spcifier uniquement une


police bps, le routeur va se
contenter de transmettre le trafic
conformment au bps et va ignorer
le trafic excdant cette valeur
.normal-burst de 1000
512.000.000 bytes.max-burst de
2000 1.024.000.000
bytes.Conform-action action indique
laction qui va tre excute si le
traffic nest pas excdant.exceedaction action indique laction
raliser si le trafic excde la valeur
normal-burst.violate-action action
indique laction raliser si le dbit
excde la valeur max-burst.Voir
Tableau 1 pour une listes dactions.
Exemple 5 assigne un CAR la classe nomme mink.
Exemple 5 Spcifier un CAR
Router(config)# policy-map lynx
Router(config-pmap)# class mink
Router(config-pmap-c)# police 720000 90000 90000 conform-action
transmit exceed-action drop

3.4) Spcifier une police Percent-Based .


Le dispositif Percent-Based permet de configurer une police de trafic en bits par secondes ou
en pourcentage de bande passante de linterface rseau sur laquelle la police est applique.
Configurer une police de trafic base sur un pourcentage de bande passante vous permet
dutiliser la mme policy map pour plusieurs interfaces avec diffrents dbits.
Lorsque vous configurez une police de trafic base sur un pourcentage de bande passante vous
pouvez aussi spcifier une burst size en ms cest dire le dpassement du dbit garantie
par le client.
Lorsque vous utilisez la commande percent-based avec la police requise ,la police percent
based est base sur les polices topmost, classdefault, shape rate. Autrement ,la police
percent based est base sur la bande passante de linterface rseau sur laquelle la police est
applique.
Pour configurer une police de trafic base sur un pourcentage de bande passante sur une
interface ,saisissez les commandes suivantes dans le mode configuration policy-map :

Commande

Description

Router(config-pmap-c)#
police {cir] [percent] {bps |
percent} [normal-burst |
max-burst] [conform-action
{action} | exceed-action
{action} | violate-action
{action}]

Configurer une police de trafic.cir indique


dutiliser le dbit garanti (CIR ou committed
information rate) pour la police de
trafic.Percent spcifie le pourcentage de
bande passante utiliser pour calculer le
CIR.bps est une valeur de 8000
2,000,000,000 bits par seconde. Si vous
spcifier uniquement une police bps, le
routeur va se contenter de transmettre le
trafic conformment au bps et va ignorer le
trafic excdant cette valeur .percent spcifie

le pourcentage de bande passante.Normalburst de 1000 512.000.000 bytes.Maxburst de 2000 1.024.000.000


bytes.Conform-action action indique laction
qui va tre excute si le trafic nest pas
excdant.Exceed-action action indique
laction raliser si le trafic excde la valeur
normal-burst.Violate-action action indique
laction raliser si le dbit excde la valeur
max-burst.Voir Tableau 1 pour une listes
dactions.

Exemple 6 : configuration dune policy map nomme policy1 et son association avec la
classe de trafic class1. Lexemple configure une police de trafic percent-based pour class1 en
utilisant un CIR et un PIR(dbit maximum autoris pendant une courte priode) bas sur un
pourcentage de bande passante. Dans cet exemple ,un CIR de 20% et un PIR de 40% ont t
spcifis. .

Exemple 6 Configuration dune police Percent-Based :


Router(config)# policy-map policy1
Router(config-pmap)# class-map class1
Router(config-pmap-c)# police cir percent 20 bc 300 ms pir percent
40 be 400 ms
Router(config-pmap-c)# service-policy child-policy1
Router(config-pmap-c)# exit
Router(config-pmap-c)# interface serial 3/1
Router(config-if)# service-policy output policy1

3.5) Activer le WRED (Weighted Random Early


Detection).
Le dispositif WRED utilise un algorithme pour supprimer alatoirement les paquets lors dune
congestion rseau. WRED supprime les paquets par rapport leur priorit IP. Les paquets ayant
une forte priorit IP ont moins de chance dtre supprimer que les paquets ayant une faible
priorit.
Note: Si vous utilise WRED pour une ou plusieurs classe de trafic il est
ncessaire de crer une service policy ,vous devez vous assurer que
WRED nest pas configur pour linterface sur laquelle vous avez attach
la service policy .

Tableau 3 description des valeur de priorits que le routeur supporte.


Tableau 3 Valeurs de priorits
Value

Description

Precedence

Valeur entre 0 et 7 ,ou 0 est typiquement la valeur la plus


basse de priorit et 7 la plus haute.

min-value

Spcifie un seuil minimum. Valeur entre 32 et 16,384

max-value

Spcifie un seuil maximum. Valeur entre 32 et 16,384.

mark-denom

Spcifie une probabilit de suppression des paquets. Enter


a valeur entre 1 et 65,535.

Pr-requis pour le WRED

Vous devez attribuer la bande passante avant de pouvoir activer WRED.


Sur les cartes OC-12 ATM ,vous pouvez seulement utiliser WRED sur linterface principale ou
sur un PVC VBR (Variable Bit Rate , PVC dont le dbit est connu et fix nominativement ). Vous
ne pouvez pas utiliser WRED sur des PVC UBR ( Unspecified Bit Rate , PVC dont le dbit nest
pas connu nominativement par exemple le cas de trois PVC qui a eux trois ne doivent pas
dpasss 155Mb).
Pour Activer WRED ,entrer les commande suivante en mode de configuration policy-map :
Commande

Description

Active une police WRED pour une classe de


trafic qui incluse une garantie de bande
passante.ewc est une valeur vous permet de
modifier la mthode par dfaut qui permet la
dtection alatoire des paquets ,utilis pour
calculer la taille moyenne de la file dattente.
Random-detect determine la taille moyenne de
Router(config-pmap- la file dattente base sur la taille courante et
c)# random-detect [ewc la dernire taille moyenne de la file dattente.
value | prec prec-value Vous pouvez spcifier une valeur de 1 16: La
min-value max-value
plus grande valeur entrane une raction lente
mark-denom]
de WRED pour changer les conditions de
trafics. La plus faible valeur entrane une
meilleure sensibilit et une rapidit accrue pour
changer les conditions de trafics. Tip Dans la
plus part des cas la meilleure utilisation de
WRED se fait sans arguments.prec est une
valeur de priorit que vous devez spcifier
selon le Tableau 3.
Exemple 7 Active la police de rgulation WRED pour la classe de trafic nomme class-default et
associe la police la police nomme lynx.
Exemple 7 Configuration WRED
Router(config)# policy-map lynx
Router(config-pmap)# class class-default
Router(config-pmap-c)# random-detect

3.6) Configurer une rservation de queue de bande


passante.
Pour vous permettre doffrir diffrent service au clients, le routeur supporte un systme de
rservation de bande passante, low-latency priority ,et fair queueing. Les queues de
paquets sont des mmoires tampons situs sur les interfaces pour les paquets en attente dtre
traits. Le routeur utilise typiquement une simple file pour transmettre les paquets dans lordre
de leur arriv. Cette mthode est simple ,efficace ,et offre des dlais moyens optimale par
paquets parce que la bande passante est utilise dans sa totalit. Mais la mthode simple de
mise en file dattente ne distingue pas parmi les diffrent flux de trafic le plus gros trafic dans
un flux.
Le dispositif Bandwidth Reservation Queueing assigne un partage gale de bande passante
chaque file . Aucune file nest prioritaire. La rservation de bande passante divise la bande
passante du lien entre les diffrents flux de trafic dans des files multiples ,chaque file reoit la

mme quantit de bande passante divise entre toute les queues ou il y a du trafic. Vous ne
perdez pas la bande passante associ avec une file ou il ny a pas de dbit, la bande passante
inutilise est divise entre les files.
Restrictions pour le dispositif de rservation de bande passante :
Vous ne pouvez pas combiner low-latency priority et bandwith queuing dans la mme
classe.
Pour configurer bandwidth reservation queueing , entrer les commandes suivantes dans le
mode de configuration des policy-map:
Commande

Description

Active le partage gale de bande passante et


Router(configcre plusieurs classes de files bases sur la
pmap-c)# bandwidth bande passante.rate-in-kbps est une plage entre
rate-in-kbps
8 to 2,000,000 reprsentant 1% 99% de la
bande passante du lien.
Exemple 8 cre deux classes de queue:
Une file de 16 kbps pour les paquets avec un bit de priorit de 1,2,3 ou 4.
Une file de 40 kbps pour les paquets avec un bit de priorit de 5,6 ou 7.
Linterface possde une bande passante totale de 64 kbps , les deux classes de files reoivent
25% et 62% de la bande passante de linterface. Tout le reste du trafic ,incluant la priorit IP
0 ,reoit le reste de la bande passante cest dire 8kbs ou 13%.
Exemple 8 Activer la rservation de bande passante.
Router# enable
Router# configure terminal
Router(config)# class-map city
Router(config-cmap)# match ip precedence 1 2 3 4
Router(config-cmap)# class-map boston
Router(config-cmap)# match ip precedence 5 6 7
Router(config-cmap)# policy-map precedence-queues
Router(config-pmap)# class city
Router(config-pmap-c)# bandwidth 16
Router(config-pmap-c)# class boston
Router(config-pmap-c)# bandwidth 40
Router(config-pmap-c)# interface serial 6/0/0/1:1
Router(config-if)# service-policy output precedence-queues
Router(config-if)# end

3.7) Configurer Low-Latency Priority sur les


files dattentes.
Le dispositif de priorit low-latency permet dassigner une bande passante minimum
garantie sur une file dattente qui reoit les paquets prioritaires. Ce dispositif minimise la
variation du dlai sur les paquets pour le trafic sensible au dlai comme la voie ou la vido.
Restrictions pour le dispositif Low-Latency :
Vous ne pouvez pas combiner low-latency priority et bandwidth queuing dans la mme classe.
Pour crer une queue low-latency priority (queue de faible latence,la latence est le temps de
travers dun quipement) , entrer les commandes suivantes dans le mode de configuration
policy-map:
Commande
Router(config-pmap-c)#
priority rate-in-kbps

Description
Active la priorit sur les queues de
paquets.rate-in-kbps est une plage de 8

2.000.000 reprsentant la bande minimum


garantie.
Exemple 9 cration dune queue prioritaire pour le trafic voix .

Exemple 9 Activation des queues Low-Latency priority


Router# enable
Router# configure terminal
Router(config)# class-map voice
Router(config-cmap)# match ip rtp 2000 2000
Router(config-cmap)# policy-map voice-queue
Router(config-pmap)# class voice
Router(config-pmap-c)# priority 56
Router(config-pmap-c)# interface serial 6/0/0/1:1
Router(config-if)# service-policy output voice-queue
Router(config-if)#

4) QoS modulaire CLIService Policy.


Un service policy attache une policy map une interface et spcifie la direction (entrant
ou sortant) dans laquelle la police devra tre applique. Une interface peut avoir diffrentes
policy map pour des paquets entrants ou sortant de linterface.
Utiliser la commande service-policy en mode de configuration dinterface pour attacher une
policy map une interface entrante ou sortante:
Router(config-if)# service-policy [input | output] policy-map-name

input : dfini une direction entrante.


output : dfini une direction sortante.
policy-map-name : nom de la policy map .

4.1) Configurer une oversubscription de circuit


virtuel.
Le dispositif VCO (Virtual Circuit Oversubscription) permet aux fournisseurs de services une
meilleure utilisation de leur rseau ,des rseau sous-utiliss. A la place de supporter
uniquement les rservations inconditionnelles de bande passante de rseau de VC, le routeur
offre une VC oversubscription qui garantie statistiquement une bande passante pour les
circuits virtuels.
Dans les IOS cisco 12.0(25)SX, le routeur Cisco 10000 series supporte des rservations
inconditionnelles de bande passante de rseau pour les VC. Lorsque la somme des capacits de
transmissions des VC tombe au sein du rseau ,le rseau ne se congestionne pas. Chaque VC
reoit sa rservation de bande passante sans se soucier du trafic des autres VC sur ce rseau.
Cependant , les VC reoivent ce service inconditionnel au moment ou la capacit physique du
rseau est au plus haut. Parce que chaque VC utilisent une fraction de la capacit physique , a
moins que un grand nombre de VC restent occups , lutilisation globale du rseau reste faible.
Sur le Cisco IOS 12.0(25)SX, quand toute la largeur de bande assigne excde la capacit
physique, le routeur fournit la rservation de la largeur de bande de chaque VC pour une
nombre limit de VC. De cette manire le routeur utilise les avantages du multiplexage
statistique pour fournir une meilleure gestion du rseau.
Le dispositif VCO assure que la congestion au niveau du port physique na pratiquement jamais

lieu. Par exemple 10 VC sont configurs pour utiliser 25 % de la bande passante. La capacit du
rseau est augment sil y a seulement 4 VC qui tente de transmettre du trafic. Le dispositif
VCO est prvu seulement pour les rseau avec une faible utilisation ,avec une faible probabilit
de congestion.

4 .2) configurer VCO sur Frame Relay et IEEE


802.1Q.
Pour configurer VCO sur frame relay ou IEE802.1Q ,entrer les commandes suivantes en mode
de configuration dinterface ou en mode de configuration policy-map:
Commande

Description

Router(config-if)#
service-policy {input |
Attache une policy map sur une interfaces.
output} policy-mapname

Router(configpmap-c)# servicepolicy policy-mapname

Assigne une policy QoS une classe avec une


autre policy map,en utilisant la commande
service-policy dans le mode de configuration
policy-map, il faut crer une police pour grer le
trafic avec les VC. Cest pour cette raison que le
terme Nested Policy-Map Oversubscription est
souvent utilis pour faire rfrence au VCO (VC
Oversubscription).

Exemple 10 montre comment surattribuer un rseau T1 avec deux PVC Frame Relay .Un rseau
T1 a la capacit de 1536 kilobits par secondes. Parce que chaque PVC a une bande passante de
1024Kb/s avec un totale de 2048Kb/s ,qui dpasse la capacit du rseau T1 ,les VC sont
surattribus. Si chaque VC possde une bande passante de 768 Kb/s ou moins, les VC ne seront
pas surattribu.
Exemple 10 Oversubscribing PVC Frame Relay
Router(config)# policy-map 1m
Router(config-pmap)# class class-default
Router(config-pmap-c)# shape 1024
Router(config)# frame-relay map-class 1m-pvc
Router(config-mc)# service-policy output 1m
Router(config)# interface serial 1/0/0/0:0
Router(config-if)# encapsulation frame-relay
Router(config-if)# frame-relay interface-dlci 100
Router(config-if-dlci)# frame-relay class 1m-pvc
Router(config-if-dlci)# frame-relay interface-dlci 101
Router(config-if-dlci)# frame-relay class 1m-pvc

4.3) Configurer des VC Oversubscription pour


les VC(Virtual Circuit) ATM.
Pour activer loversubscription pour des VC ATM ,entrer les commandes suivantes en mode de
configuration globale :
Commande

Description

Router(config-if)# atm oversubscription-factor {1-10}

Surattribue un VC ATMOversubscribes
an ATM VC.1-10 spcifie le taux de
surattribution ,la valeur par dfaut
est 1.Note Utiliser cette commande
sur chaque interfaces ATM que vous
voulez surattribuer.

Note: Vous navez pas besoin dutiliser la commande service-policy pour


spcifier la surattribution des VC ATM parce quune VBR (Variable Bit
Rate) VC ATM utilise un dbit de cellules soutenu (SCR) pour dfinir le
dbit moyen de transmission.
Exemple 11 Surattribution ,par cinq fois la capacit de transmission,dune interface ATM.
Exemple 11 Surattribution dun VC ATM
Router(config)# interface serial 1
Router(config-if)# atm over-subscription-factor 5

4.4) Dfinir une police QoS de 3 niveaux


hirarchiques.
Le dispositif de police QoS sur 3 niveaux permet dappliquer un service de police lintrieur de
la policy map pour dfinir des polices hirarchiques .
Pour configurer une police hirarchique sur 3 niveau entrer les commande suivante en mode
configuration poilicy-map :
Commande

Description

Router(config-pmap-c)#
service-policy policy-map-name

Assigne une police QoS une policy


map.

Exemple 12 configuration dune police hirarchique sur trois niveaux qui segmente le trafic
1Mbps.Lexemple configure les spcifications suivantes:

VoIP
Limite les paquets VoIP 500Kbps.
Fourni un service de priorit sur les paquets VoIP.
Business Traffic
Guarantie un minimum de capacit de transmission 400 Kbps la classe business.
Mesure tout le trafic appartenant au classe non-SAA , marquant tout ce qui dpasse 400 Kbps
avec DSCP 40.
Durant la congestion , discarde les paquets excdant (marqu DSCP40) appartenant la
classe business avant ceux 100Kbs ou moins.
Default Traffic
Met de cot un minimum de 100Kbs de capacit de transmission pour le trafic appartenant la
classe class-default.
Mesure tout le trafic appartenant la classe non-SAA ,marquant les paquets excdant
100Kbps avec DSCP 20.
Durant la congestion , abandonne les paquets excdant (marqu DSCP20) appartenant la
classe class-default avant ceux 100Kbs ou moins.
Exemple 12 Configurer une police QoS de 3 niveaux.

Router(config)# policy-map business-meter


Router(config-pmap)# class non-SAA
Router(config-pmap-c)# police percent 40 1500 0 conform-action
transmit exceed-action set-dscp-transmit 40 Router(config-pmap-c)#
exit
Router(config-pmap)# exit
Router(config)# policy-map default-meter
Router(config-pmap)# class non-SAA
Router(config-pmap-c)# police percent 10 1500 0 conform-action
transmit exceed-action set-dscp transmit 20 Router(config-pmap-c)#
exit
Router(config-pmap)# exit
Router(config)# policy-map bi-level
Router(config-pmap)# class VoIP
Router(config-pmap-c)# priority
Router(config-pmap-c)# police percent 50
Router(config-pmap-c)# exit
Router(config-pmap)# class business
Router(config-pmap-c)# bandwidth percent 40
Router(config-pmap-c)# random-detect dscp-based
Router(config-pmap-c)# random-detect dscp 40 10 20 10
Router(config-pmap-c)# random-detect dscp 44 100 200 10
Router(config-pmap-c)# service-policy business-meter
Router(config-pmap-c)# exit
Router(config-pmap)# class class-default
Router(config-pmap-c)# random-detect dscp-based
Router(config-pmap-c)# random-detect dscp 20 10 20 10
Router(config-pmap-c)# random-detect dscp 24 100 200 10
Router(config-pmap-c)# service-policy default-meter
Router(config-pmap-c)# exit
Router(config-pmap)# exit
Router(config)# policy-map tri-level
Router(config-pmap)# class class-default
Router(config-pmap-c)# shape 1000
Router(config-pmap-c)# service-policy bi-level

4.5) Configurer un Traffic Shaping gnrique.


Le routeur cisco 10000 series utilise la fonctionnalit traffic shaping comme un mcanisme
pour contrler ou modifier le flux de trafic sur une interface ,pour assurer un dbit fourni sur
cette interface. Contrairement au committed acces rate ,le trafic shaping limite en sortie
en stockant dans des buffer le trafic excdant au lieu de labandonner. GTS (generic trafic
shaping) supporte le traffic shaping sur toutes les interfaces sans se soucier de
lencapsulation de linterface.
Pour configurer un GTS ,entrer les commandes suivantes en mode de configuration de policy
map :
Commande

But

Limite le dbit sortant rate-in-kbps.rate-inkbps est une plage entre 56 et 2.000.000,


Router(config-pmap-c)#
reprsentant le maximum de bande bassante
shape rate-in-kbps
en sortie autoris.
Exemple 13 Attribue une sortie 100kbps.
Exemple 13 Configurer GTS
Router(config-pmap-c)# shape 100
Router(config-pmap-c)#

4.6) Classe Class-Default .


La classe nomme class-default est une classe de trafic que le routeur utilise pour classifier le
trafic lorsque aucune autre classe de trafic nest dfinie. Vous ne pouvez pas modifier la classe
class-default.