Vous êtes sur la page 1sur 6

COMANDOS DE CONFIGURACIN DE ROUTERS CISCO

Borrado y recarga del Router


Router> enable
Router# erase startup-config
(confirmar)
Router# reload
(responder no a la pregunta acerca de guardar la configuracin y confirmar la recarga)
(responder no a la pregunta de entrar en el dilogo de configuracin inicial setup-)
Entrar al router en modo EXEC privilegiado
Router> enable
Router#
Entrar en el modo de configuracin global
Router# configure terminal
Router(config)#
Cambiar el nombre del host
Router(config)# hostname nombre
Configurar la contrasea de consola en el router
Router(config)# line console 0
Router(config-line)# password cisco
Router(config-line)# login
Router(config-line)# exit
Router(config)#
Configurar la contrasea en las lneas de terminal virtual del router
Router(config)# line vty 0 4
Router(config-line)# password cisco
Router(config-line)# login
Router(config-line)# exit
Router(config)#
Configurar la contrasea autorizada
Router(config)# enable password cisco
Configurar la contrasea secreta autorizada
Router(config)# enable secret class
Configurar una interface serie
Router(config)# interface serial 0
Router(config-if)# ip address 192.168.15.1 255.255.255.0
Router(config-if)# clock rate 56000
(solo para el DCE)
Router(config-if)# no shutdown
Router(config-if)# exit
Router(config)#

Configurar una interface ethernet


Router(config)# interface ethernet 0
Router(config-if)# ip address 192.168.15.1 255.255.255.0
Router(config-if)# no shutdown
Router(config-if)# exit
Router(config)#
Configurar la tabla de host IP para la red
Router(config)# ip host G 192.168.15.1 172.17.0.1
(para acceder al router con nombre G a travs de sus interfaces ethernet: 192.168.15.1 y
serial: 172.17.0.1, en este caso)
Guardar en NVRAM la configuracin actual(en memoria) del router
Router# copy running-config startup-config
(o copy run start)
Salir del modo de configuracin global
Router(config)# exit
Router#
Salir al modo EXEC de usuario
Router# disable
(o exit)
Router>
Configurar el protocolo de enrutamiento RIP (v2)
Router(config)# router rip
Router(config-router)# version 2
(Solo para usar RIP v2)
Router(config-router)# network 172.16.0.0
(Aadir una lnea similar para cada red)
Router(config-router)# exit
Router(config)#
Mostrar brevemente la informacin ip de las interfaces de un router
Router# show ip interface brief
Mostrar valores sobre los protocolos de enrutamiento y el temporizador
Router# show ip protocols
Mostrar el contenido de una tabla de enrutamiento IP
Router# show ip route
Mostrar las actualizaciones de enrutamiento IP en tiempo real
Router# debug ip rip
(Para desactivar totalmente la depuracin usar debug all o undebug all)
Establecer rutas estticas
Router(config)# ip route 172.16.1.0 255.255.255.0 172.16.2.1
Establecer rutas por defecto
Router(config)# ip default-network 172.16.1.0

Configurar (y habilitar) el protocolo de enrutamiento OSPF


Router(config)# router ospf identificador-de-proceso
(Puede haber ms de un proceso iniciado en el mismo router. Valor entre 0 y 65.535)
Router(config-router)# network 172.16.0.0 mscara-wildcard area identificador-de-rea
(Esta mscara opera al revs que la de subred. P.e.: 0.0.255.255).(El rea 0 es la de backbone)
(Aadir una lnea similar para cada red)
Crear y asignar una direccin IP a una interfaz de loopback
Router(config)# interface loopback nmero
Router(config-if)# ip address direccin-IP 255.255.255.255
(Conviene hacerlo para todos los routers que ejecutan OSPF)
Eliminar una interfaz de loopback
Router(config)# no interface loopback nmero
Mostrar valores sobre protocolos de enrutamiento OSPF
Router# show ip osfp
Mostrar valores sobre los interfaces relacionados con protocolos de enrutamiento OSPF
Router# show ip osfp interface
Configurar (y habilitar) el protocolo de enrutamiento EIGRP
Router(config)# router eigrp nmero-de-SA (sistema autnomo)
Router(config-router)# network 172.16.0.0
(Aadir una lnea similar para cada red conectada directamente al router)
Router(config-if)# bandwidth velocidad de la lnea (para enlaces serie nicamente)
(Importante: para enlaces serie. Caso contrario: rutas no ptimas o incluso no convergencia)
Router(config-router)# eigrp log-neighbor-changes

COMANDOS DE CONFIGURACIN DE SWITCHES CISCO


Borrado y recarga del switch
Switch> enable
Switch# delete flash:vlan.dat
(para eliminar la informacin de VLAN actual, borrar archivo de la base de datos VLAN,
denominado vlan.dat, del directorio flash)
Switch# erase startup-config
(confirmar)
Switch# reload
Transferencia de archivos desde la flash del switch al servidor TFTP
Switch# copy flash tftp
Source filename [] ? c2950-c3h2s-mz.120-5.3.wc.1.bin
Address or name of remote host [] ? 192.168.1.3
Destination filename [c2950-c3h2s-mz.120-5.3.wc.1.bin] ? c2950-c3h2s-mz
Transferencia de archivos desde la NVRAM del switch al servidor TFTP
Switch# copy startup-config tftp
Address or name of remote host [] ? 192.168.1.3
Destination filename [switch-config] ?
Entrar al switch en modo EXEC privilegiado
Switch> enable
Switch#
Entrar en el modo de configuracin global
Switch# configure terminal
Switch(config)#
Cambiar el nombre del host
Switch(config)# hostname nombre
Configurar la contrasea de consola en el switch
Switch(config)# line console 0
Switch(config-line)# password cisco
Switch(config-line)# login
Configurar la contrasea en las lneas de terminal virtual del switch
Switch(config)# line vty 0 15
Switch(config-line)# password cisco
Switch(config-line)# login
Configurar la contrasea autorizada
Switch(config)# enable password cisco
Configurar la contrasea secreta autorizada
Switch(config)# enable secret class
Guardar en NVRAM la configuracin actual(en memoria) del switch
Switch# copy running-config startup-config
(o copy run start)

Salir del modo de configuracin global


Switch(config)# exit
Switch#
Salir al modo EXEC de usuario
Switch# exit
Switch>
Configurar la direccin IP del switch y la pasarela por defecto
Switch(config)# interface VLAN1
(Por defecto, la VLAN 1 es la VLAN de administracin y se usa para administrar todos los
dispositivos de red en una red.)
Switch(config-if)# ip address 192.168.1.2 255.255.255.0
Switch(config-if)# exit
Switch(config)# ip default-gateway 192.168.1.1
Mostrar la configuracin activa por defecto
Switch# show running-config
Mostrar la versin del IOS y los valores del registro de configuracin
Switch# show version
Mostrar el contenido por defecto del Directorio de la Flash
Switch# show flash
(o dir flash:)
Mostrar la informacin de una interfaz de un switch
Router# show interface FastEthernet 0/1
Establecer la velocidad de un puerto y sus valores de duplex
Switch(config)# interface FastEthernet 0/2
Switch(config-if)# duplex full
Switch(config-if)# speed 100
Switch(config-if)# no shutdown
(Para habilitar el puerto.)
Mostrar y despejar la tabla de direcciones MAC de un switch
Switch# show mac-address-table
Switch# clear mac-address-table dinamic
Configurar y eliminar una direccin MAC esttica de la tabla de un switch
Sw(config)# mac-address-table static 0011.0011.0b54 interface FastEthernet 0/4 vlan 1
Sw(config)# no mac-address-table static 0011.0011.0b54 interface FastEther 0/4 vlan 1
Configuracin de la seguridad de un puerto
Switch(config)# interface FastEthernet 0/4
Switch(config-if)# switchport mode access
(configura el puerto en modo de acceso)
Switch(config-if)# switchport port-security
(habilitacin de la seguridad del puerto)
Switch(config-if)# switchport port-security maximum 1
(establece en 1 el nmero mximo de MAC de seguridad de puerto)
Switch(config-if)# switchport port-security violation shutdown
(desactivar el puerto si se produce una violacin de su seguridad)

Switch(config)# interface FastEthernet 0/4


Switch(config-if)# switchport port-security maximum 1
Switch(config-if)# port security max-mac-count 1
(habilitar la seguridad del puerto con un nmero mximo de direcciones MAC de 1)
Switch(config-if)# no port security
(deshabilitar la seguridad del puerto)