Vous êtes sur la page 1sur 22

C H A P T E R

Basic Router Configuration


This chapter provides procedures for configuring the basic parameters of your Cisco router, including
global parameter settings, routing protocols, interfaces, and command-line access. It also describes the
default configuration on startup.

Note

Interface Ports, page 3-2

Default Configuration, page 3-2

Information Needed for Configuration, page 3-4

Configuring Command-Line Access, page 3-5

Configuring Global Parameters, page 3-7

Configuring WAN Interfaces, page 3-7

Configuring the Fast Ethernet LAN Interfaces, page 3-16

Configuring the Wireless LAN Interface, page 3-16

Configuring a Loopback Interface, page 3-16

Configuring Static Routes, page 3-18

Configuring Dynamic Routes, page 3-19

Individual router models may not support every feature described in this guide. Features that are not
supported by a particular router are indicated whenever possible.
This chapter includes configuration examples and verification steps, as available.

Cisco 880 Series Integrated Services Router Software Configuration Guide


OL-22206-02

3-1

Chapter 3

Basic Router Configuration

Interface Ports

Interface Ports
Table 3-1 lists the interfaces that are supported for each router and their associated port labels on the
equipment.
Table 3-1

Supported Interfaces and Associated Port Labels by Cisco Router

Router

Interface

Port Label

Cisco 880

Fast Ethernet LAN

LAN, FE0FE3

Wireless LAN

(no label)

Cisco 881, 881W, 881G,


881GW

Fast Ethernet WAN

WAN, FE4

Cisco 886, 886W, 886G,


886GW

ADSLoverISDN

ADSLoPOTS

Cisco 887, 887W

ADSL2oPOTS WAN

ADSLoPOTS

Cisco 887V, 887VW,


887VG, 887VGW

VDSL2oPOTS WAN

VDSLoPOTS

Cisco 888, 888W

G.SHDSL WAN

G.SHDSL

Default Configuration
When you first boot up your Cisco router, some basic configuration has already been performed. All of
the LAN and WAN interfaces have been created, console and vty ports are configured, and the inside
interface for Network Address Translation (NAT) has been assigned. Use the show running-config
command to view the initial configuration, as shown in the following example for a Cisco 881W:
Router# show running-config

User Access Verification


Password:
Router> en
Password:
Router# show running-config
Building configuration...
Current configuration : 986 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$g4y5$NxDeM.0hON6YA51bcfGvN1
enable password ciscocisco
!

Cisco 880 Series Integrated Services Router Software Configuration Guide

3-2

OL-22206-02

Chapter 3

Basic Router Configuration


Default Configuration

no aaa new-model
!
!
!
!
no ip routing
no ip cef
!
!
!
!
!
multilink bundle-name authe
!
!
archive
log config
hidekeys
!
!
!
!
!
interface FastEthernet0
!
interface FastEthernet1
shutdown
!
interface FastEthernet2
shutdown
!
interface FastEthernet3
shutdown
!
interface FastEthernet4
ip address 10.1.1.1 255.255.255.0
no ip route-cache
duplex auto
speed auto
!
interface Vlan1
no ip address
no ip route-cache
shutdown
!
interface wlan-ap0
description Service Module interface to manage the embedded AP
ip unnumbered Vlan1
no cdp enable
arp timeout 0
!
ip route 0.0.0.0 0.0.0.0 10.1.1.1
!
!
no ip http server
no ip http secure-server
!
!
!
!
!
control-plane
!
!

Cisco 880 Series Integrated Services Router Software Configuration Guide


OL-22206-02

3-3

Chapter 3

Basic Router Configuration

Information Needed for Configuration

line con 0
no modem enable
line aux 0
line vty 0 4
password cisco
login
transport input telnet ssh
!
scheduler max-task-time 5000
!
webvpn cef
end
Router#

Information Needed for Configuration


You need to gather some or all of the following information, depending on your planned network
scenario, before configuring your network:

If you are setting up an Internet connection, gather the following information:


PPP client name that is assigned as your login name
PPP authentication type: Challenge Handshake Authentication Protocol (CHAP) or Password

Authentication Protocol (PAP)


PPP password to access your ISP account
DNS server IP address and default gateways

If you are setting up a connection to a corporate network, you and the network administrator must
generate and share the following information for the WAN interfaces of the routers:
PPP authentication type: CHAP or PAP
PPP client name to access the router
PPP password to access the router

If you are setting up IP routing:


Generate the addressing scheme for your IP network.
Determine the IP routing parameter information, including IP address and ATM permanent

virtual circuits (PVCs). These PVC parameters are typically virtual path identifier (VPI), virtual
circuit identifier (VCI), and traffic-shaping parameters.
Determine the number of PVCs that your service provider has given you, along with their VPIs

and VCIs.
For each PVC, determine the type of AAL5 encapsulation supported. It can be one of the

following:
AAL5SNAPThis can be either routed RFC 1483 or bridged RFC 1483. For routed RFC 1483,
the service provider must provide you with a static IP address. For bridged RFC 1483, you may
use DHCP to obtain your IP address, or you may obtain a static IP address from your service
provider.
AAL5MUX PPPWith this type of encapsulation, you need to determine the PPP-related
configuration items.

Cisco 880 Series Integrated Services Router Software Configuration Guide

3-4

OL-22206-02

Chapter 3

Basic Router Configuration


Configuring Command-Line Access

If you plan to connect over an ADSL or G.SHDSL line:


Order the appropriate line from your public telephone service provider.

For ADSL linesEnsure that the ADSL signaling type is DMT (also known as ANSI T1.413)
or DMT Issue 2.
For G.SHDSL linesVerify that the G.SHDSL line conforms to the ITU G.991.2 standard and
supports Annex A (North America) or Annex B (Europe).
After you have collected the appropriate information, you can perform a full configuration on your
router, beginning with the tasks in the Configuring Command-Line Access section on page 3-5.
To obtain or change software licenses, see Software Activation on Cisco Integrated Services Routers and
Cisco Integrated Service Routers G2.

Configuring Command-Line Access


To configure parameters to control access to the router, follow these steps, beginning in global
configuration mode:
SUMMARY STEPS
1.

line [aux | console | tty | vty] line-number

2.

password password

3.

login

4.

exec-timeout minutes [seconds]

5.

line [aux | console | tty | vty] line-number

6.

password password

7.

login

8.

end

DETAILED STEPS

Step 1

Command

Purpose

line [aux | console | tty | vty] line-number

Enters line configuration mode, and specifies the


type of line.

Example:

This example specifies a console terminal for


access.

Router(config)# line console 0


Router(config-line)#

Step 2

password password

Specifies a unique password for the console


terminal line.

Example:
Router(config)# password 5dr4Hepw3
Router(config-line)#

Step 3

login

Enables password checking at terminal session


login.

Example:
Router(config-line)# login
Router(config-line)#

Cisco 880 Series Integrated Services Router Software Configuration Guide


OL-22206-02

3-5

Chapter 3

Basic Router Configuration

Configuring Command-Line Access

Step 4

Command

Purpose

exec-timeout minutes [seconds]

Sets the interval that the EXEC command


interpreter waits until user input is detected. The
default is 10 minutes. Optionally, add seconds to
the interval value.

Example:
Router(config-line)# exec-timeout 5 30
Router(config-line)#

Step 5

line [aux | console | tty | vty] line-number

This example shows a timeout of 5 minutes and


30 seconds. Entering a timeout of 0 0 specifies
never to time out.
Specifies a virtual terminal for remote console
access.

Example:
Router(config-line)# line vty 0 4
Router(config-line)#

Step 6

password password

Specifies a unique password for the virtual


terminal line.

Example:
Router(config-line)# password aldf2ad1
Router(config-line)#

Step 7

login

Enables password checking at the virtual terminal


session login.

Example:
Router(config-line)# login
Router(config-line)#

Step 8

end

Exits line configuration mode, and returns to


privileged EXEC mode.

Example:
Router(config-line)# end
Router#

Example
The following configuration shows the command-line access commands.
You do not need to input the commands marked default. These commands appear automatically in the
configuration file generated when you use the show running-config command.
!
line con 0
exec-timeout 10 0
password 4youreyesonly
login
transport input none (default)
stopbits 1 (default)
line vty 0 4
password secret
login
!

Cisco 880 Series Integrated Services Router Software Configuration Guide

3-6

OL-22206-02

Chapter 3

Basic Router Configuration


Configuring Global Parameters

Configuring Global Parameters


To configure selected global parameters for your router, follow these steps:
SUMMARY STEPS
1.

configure terminal

2.

hostname name

3.

enable secret password

4.

no ip domain-lookup

DETAILED STEPS

Step 1

Command

Purpose

configure terminal

Enters global configuration mode, when using the


console port.

Example:

If you are connecting to the router using a remote


terminal, use the following:

Router> enable
Router# configure terminal
Router(config)#

Step 2

hostname name

telnet router name or address


Login: login id
Password: *********
Router> enable

Specifies the name for the router.

Example:
Router(config)# hostname Router
Router(config)#

Step 3

enable secret password

Specifies an encrypted password to prevent


unauthorized access to the router.

Example:
Router(config)# enable secret cr1ny5ho
Router(config)#

Step 4

no ip domain-lookup

Disables the router from translating unfamiliar


words (typos) into IP addresses.

Example:
Router(config)# no ip domain-lookup
Router(config)#

Configuring WAN Interfaces


Configure the WAN interface for your router using one of the following as appropriate:

Configuring a Fast Ethernet WAN Interface, page 3-8

Configuring a VDSL2 WAN Interface, page 3-8

Configuring ADSL or VDSL on Cisco Multi Mode 886VA and 887VA ISRs, page 3-9

Configuring ADSL Mode, page 3-10

Cisco 880 Series Integrated Services Router Software Configuration Guide


OL-22206-02

3-7

Chapter 3

Basic Router Configuration

Configuring WAN Interfaces

Configuring a Fast Ethernet WAN Interface


To configure the Fast Ethernet interface on a Cisco 861 or 881 ISR, follow these steps, beginning in
global configuration mode:
SUMMARY STEPS
1.

interface type number

2.

ip address ip-address mask

3.

no shutdown

4.

exit

DETAILED STEPS

Step 1

Command

Purpose

interface type number

Enters the configuration mode for a Fast


Ethernet WAN interface on the router.

Example:
Router(config)# interface fastethernet 4
Router(config-if)#

Step 2

ip address ip-address mask

Sets the IP address and subnet mask for the


specified Fast Ethernet interface.

Example:
Router(config-if)# ip address 192.168.12.2
255.255.255.0
Router(config-if)#

Step 3

no shutdown
Example:

Enables the Ethernet interface, changing its


state from administratively down to
administratively up.

Router(config-if)# no shutdown
Router(config-if)#

Step 4

exit
Example:

Exits configuration mode for the Fast Ethernet


interface and returns to global configuration
mode.

Router(config-if)# exit
Router(config)#

Configuring a VDSL2 WAN Interface


The VDSL2 WAN interface is used on the Cisco 887V ISR platforms.
Note

The VDSL2 WAN interface uses Ethernet as the Layer 2 transport mechanism.
To configure VDSL2 on the Cisco 887V ISR, follow these steps, beginning in global configuration
mode:
SUMMARY STEPS
1.

controller vdsl 0

2.

interface type number

Cisco 880 Series Integrated Services Router Software Configuration Guide

3-8

OL-22206-02

Chapter 3

Basic Router Configuration


Configuring WAN Interfaces

3.

ip address ip-address mask

4.

shutdown

5.

no shutdown

6.

exit

DETAILED STEPS

Step 1

Command

Purpose

controller vdsl 0

Enters controller configuration mode and the


controller number.

Example:

Note

Router# config t
Router(config)# controller vdsl 0

Step 2

interface type number

There is no need to configure any


VDSL2 parameters from the CPE side.
Any specific VDSL2 settings should
be set on the DSLAM side.

Enters the configuration mode for Ethernet


Layer 2 transport on the VDSL WAN interface
on the router.

Example:
Router(config)# interface ethernet 0
Router(config-if)#

Step 3

ip address ip-address mask

Sets the IP address and subnet mask for the


interface.

Example:
Router(config-if)# ip address 192.168.12.2
255.255.255.0
Router(config-if)#

Step 4

shutdown

Disables the interface, changing its state from


administratively up to administratively down.

Example:
Router(config-if)# no shutdown
Router(config-if)#

Step 5

no shutdown

Enables the interface, changing its state from


administratively down to administratively up.

Example:
Router(config-if)# no shutdown
Router(config-if)#

Step 6

exit

Exits configuration mode and returns to global


configuration mode.

Example:
Router(config-if)# exit
Router(config)#

Configuring ADSL or VDSL on Cisco Multi Mode 886VA and 887VA ISRs
The Cisco customer premise equipment (CPE) 886VA and 887VA Integrated Services Routers (ISRs)
support asymmetric digital subscriber line (ADSL) 1/2/2+ and very high-speed digital subscriber line 2
(VDSL2) transmission modes, also called multi mode. The 886VA supports xDSL over ISDN and the
887VA supports xDSL over a plain old telephone system (POTS).
The default CPE operating mode is auto. Auto mode means that the CPE trains up to the mode configured
on the digital subscriber line access multiplexer (DSLAM), ADSL1/2/2+ or VDSL2.
Cisco 880 Series Integrated Services Router Software Configuration Guide
OL-22206-02

3-9

Chapter 3

Basic Router Configuration

Configuring WAN Interfaces

The following examples assume the DSLAM is configured in either ADSL2+ mode or VDSL2, and the
CPE is configured in auto mode.
Figure 3-1 shows an ATM WAN or Ethernet WAN network topography.
Figure 3-1

Note

Note

Example Topology

A DSLAM in Layer 1 mode may be configured for auto mode. A DSLAM in Layer 2 mode must be
configured for ATM mode or packet transfer mode (PTM).

Cisco 886VA and 887VA allow a maximum of four permanent virtual circuits (PVCs).

Configuring ADSL Mode


To configure ADSL mode, follow these tasks:

Configuring ADSL Auto Mode, page 3-11

Configuring CPE and Peer for ADSL Mode, page 3-11

ADSL Configuration Example, page 3-13

Verifying ADSL Configuration, page 3-14

Verifying CPE to Peer Connection for ADSL, page 3-16

Cisco 880 Series Integrated Services Router Software Configuration Guide

3-10

OL-22206-02

Chapter 3

Basic Router Configuration


Configuring WAN Interfaces

Configuring ADSL Auto Mode


To configure the DSL controller to auto mode, follow these steps, beginning in global configuration
mode:
Note

Configure the DSLAM in ADSL 1/2//2+ mode prior to configuring the router.
SUMMARY STEPS
1.

controller vdsl slot

2.

operating mode {auto | adsl1 | adsl2 | adsl2+ | vdsl2 | ansl}

3.

end

DETAILED STEPS

Step 1

Command

Purpose

controller vdsl slot

Enters config mode for the VDSL


controller.

Example:
Router (config) #
Controller vdsl 0

Step 2

operating mode
Configures the operating mode. The
{auto|adsl1|adsl2|adsl2+|vdsl2| default is auto and is recommended.
ansl}
Example:
Router (config-controller) #
operating mode
auto

Step 3

end

Exits the configuration mode and enters


EXEC mode.

Example:
Router (config-conroller) #
end
Router

When configured in auto, the operating mode does not appear in the show running command.

Configuring CPE and Peer for ADSL Mode


When configuring for ADSL, the ATM main interface or ATM sub-interface must be configured with a
PVC and an IP address. Perform a no shutdown command on the interface, if needed.

Configuring the ATM CPE Side


To configure the ATM CPE side, follow these steps, beginning in global configuration mode:
SUMMARY STEPS
1.

interface type number

2.

no shutdown

3.

interface atm0.1 point-to-point

Cisco 880 Series Integrated Services Router Software Configuration Guide


OL-22206-02

3-11

Chapter 3

Basic Router Configuration

Configuring WAN Interfaces

4.

ip address ip-address mask

5.

pvc [name] vpi/vci

6.

protocol protocol {protocol-address [virtual-template] | inarp} [[no] broadcast |


disable-check-subnet | [no] enable-check-subnet]

7.

end

DETAILED STEPS
Command
Step 1

interface type number


Example:

Purpose
Enters configuration mode for the ATM
WAN interface (ATM0).

Router (config) # interface atm0

Step 2

no shutdown
Example:

Enables the configuration changes to


the ATM interface.

Router (config-if) # no shutdown


Router (config-if) #

Step 3

interface atm0.1 point-to-point


Example:

Enables the ATM0.1 point-to-point


interface.

Router (config-if) # interface


ATM0.1
point-to-point
Router (config-subif) #

Step 4

ip address ip-address mask

Enters IP address and subnet mask.

Example:
Router (config-subif)# ip address
30.0.0.1 255.255.255.0

Step 5

pvc [name] vpi/vci


Example:

Creates or assigns a name to an ATM


PVC and enters the ATM virtual circuit
configuration mode.

Router (config-subif) # pvc 13/32


Router (config-if-atm-vc) #

Step 6

Configures a static map for an ATM


protocol protocol {protocol-address
PVC.
[virtual-template] | inarp} [[no]
broadcast | disable-check-subnet | [no]
enable-check-subnet]
Example:
Router (config-if-atm-vc) #
protocol ip 30.0.0.2 broadcast

Step 7

end
Example:

Exits the configuration mode and enters


EXEC mode.

Router (config-if-atm-vc) # end


Router #

Cisco 880 Series Integrated Services Router Software Configuration Guide

3-12

OL-22206-02

Chapter 3

Basic Router Configuration


Configuring WAN Interfaces

ADSL Configuration Example


The following example shows a typical ADSL2+ configuration set to auto mode. Outputs in bold are
critical.

Router# show running


Building configuration...
Current configuration :
1250 bytes
!
! Last configuration change at 02:07:09 UTC Tue Mar 16 2010
!
version 15.1
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 10
ip source-route
!
!
!
!
ip cef
no ipv6 cef
!
!
!
!
license udi pid CISCO887-V2-K9 sn FHK1313227E
license boot module c880-data level adviperservices
!
!
vtp domain cisco
vtp mode transparet
!
!
controller VDSL 0
!
vlan 2-4
!
!
!
!
!
interface Ethernet 0
no ip address
shutdown
no fair-queue
!
interface BRI0
no ip address
encapsulation hdlc
shutdown

Cisco 880 Series Integrated Services Router Software Configuration Guide


OL-22206-02

3-13

Chapter 3

Basic Router Configuration

Configuring WAN Interfaces

isdn termintation multidrop


!
interface ATM0
no ip address
no atm ilmi-keepalive
!
interface ATM0.1 point-to-point
ip address 30.0.0.1 255.255.255.0
pvc 15/32
protocol ip 30.0.0.2 broadcast
!
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface Vlan1
no ip address
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
!
!
!
!
control-palne
!
!
line con 0
no modem enable
line aux 0
line vty 0 4
login
transport input all
!
exception data-corruption buffer truncate
end

Verifying ADSL Configuration


Verify that the configuration is set properly by using the show controller vdsl 0 command in the
privileged EXEC mode. Outputs in bold are critical.
Router# show controller vdsl 0
Controller VDSL 0 is UP

Daemon Status:
chip Vendor ID:
Chip Vendor Specific:
Chip Vendor Country:

Up
XTU-R (DS)
BDM
0x0000
0xB500

XTU-C (US)
BDCM
0x6110
0xB500

Cisco 880 Series Integrated Services Router Software Configuration Guide

3-14

OL-22206-02

Chapter 3

Basic Router Configuration


Configuring WAN Interfaces

Modem Vendor ID:


Modem Vendor Specific:
Modem Vendor Country:
Serial Number Near:
Serial Number Far:
Modem Version Nead:
Modem Version Far:

csco
BDCM
0x4602
0x6110
0xB500
0xB500
FHK1313227E 887-V2-K 15.1(20100

Modem Status:
DSL Config Mode:
Trained Mode:
TC Mode:
Selftest Result:
DELT configuration:
DELT state:
Trellis:
Line Attenuation:
Signal Attenuation:
Noise Margin:
Atteinable Rate:
Actual Power:
Total FECS:
Total ES:
Total SES:
Total LOSS:
Total UAS:
Total LPRS:
Total LOFS:
Total LOLS:
Bit swap:

TC Sync (Showtime!)
AUTO
G.992.5 (ADSL2+) Annex
ATM
0x00
disabled
not running
ON
1.0 dB
1.0 dB
6.8 dB
25036 kbits/s
13.7 dBm
0
0
0
0
0
0
0
0
163

Full inits:
Failed Full inits:
Short inits:
Failed short inits:

32
0
0
0

Firmware
-------VDSL

Source
-----embedded

Modem FW Version:
Modem PHY Version:

Speed (kbps):
Previous Speed:
Total Cells:
User Cells:
Reed-solomon EC:
CRC Errors:
Header Errors:
Interleave (ms):
Actual INP:

15.1(20100426:193435) [changahn
0x6110

ON
1.4 dB
0.0 dB
13.6 dB
1253 kbits/s
12.3 dBM
0
0
0
0
0
0
0
0
7

Filename (version)
-----------------VDSL_LINUX_DEV_01212008 (1)

100426_1053-4.02L.03.A2pv6C030f.d22j
A2pv6C030f.d22j

DS Channel1
0
0
0
0
0
0
0
0.00
0.00

DS Channel0
24184
24176
317070460
0
0
0
0
0.08
0.00

US Channel1
0
0
0
0
0
0
0
0.00
0.00

US channel0
1047
1047
13723742
0
0
0
0
13.56
1.80

Training Log:
Stopped
Training Log Filename: flash:vdsllog.bin

Cisco 880 Series Integrated Services Router Software Configuration Guide


OL-22206-02

3-15

Chapter 3

Basic Router Configuration

Configuring the Fast Ethernet LAN Interfaces

Verifying CPE to Peer Connection for ADSL


Ping the peer to confirm that CPE to peer configuration is setup correctly.
Router# ping 30.0.0.2 rep 20
Type escape sequence to abort.
Sending 20, 100-byte ICMP Echos to 30.0.0.2, timeout is 2 seconds:
!!!!!!!!!!!!!!!!!!!!
Success rate is 100 percent (20/20), round-trip min/avg/max = 20/22/28 ms
Router#

Configuring the Fast Ethernet LAN Interfaces


The Fast Ethernet LAN interfaces on your router are automatically configured as part of the default
VLAN and are not configured with individual addresses. Access is provided through the VLAN. You
may assign the interfaces to other VLANs.

Configuring the Wireless LAN Interface


The Cisco 880 series wireless routers have an integrated 802.11n module for wireless LAN connectivity.
The router can then act as an access point in the local infrastructure. For more information about
configuring a wireless connection, see the Basic Wireless Device Configuration section on page 4-1.

Configuring a Loopback Interface


The loopback interface acts as a placeholder for the static IP address and provides default routing
information.
To configure a loopback interface, follow these steps, beginning in global configuration mode:
SUMMARY STEPS
1.

interface type number

2.

ip address ip-address mask

3.

exit

Cisco 880 Series Integrated Services Router Software Configuration Guide

3-16

OL-22206-02

Chapter 3

Basic Router Configuration


Configuring a Loopback Interface

DETAILED STEPS

Step 1

Command

Purpose

interface type number

Enters configuration mode for the loopback


interface.

Example:
Router(config)# interface Loopback 0
Router(config-if)#

Step 2

ip address ip-address mask

Sets the IP address and subnet mask for the


loopback interface.

Example:
Router(config-if)# ip address 10.108.1.1
255.255.255.0
Router(config-if)#

Step 3

exit
Example:

Exits configuration mode for the loopback


interface and returns to global configuration
mode.

Router(config-if)# exit
Router(config)#

Example
The loopback interface in this sample configuration is used to support Network Address Translation
(NAT) on the virtual-template interface. This configuration example shows the loopback interface
configured on the Fast Ethernet interface with an IP address of 200.200.100.1/24, which acts as a static
IP address. The loopback interface points back to virtual-template1, which has a negotiated IP address.
!
interface loopback 0
ip address 200.200.100.1 255.255.255.0 (static IP address)
ip nat outside
!
interface Virtual-Template1
ip unnumbered loopback0
no ip directed-broadcast
ip nat outside
!

Verifying Configuration
To verify that you have properly configured the loopback interface, enter the show interface loopback
command. You should see a verification output similar to the following example:
Router# show interface loopback 0
Loopback0 is up, line protocol is up
Hardware is Loopback
Internet address is 200.200.100.1/24
MTU 1514 bytes, BW 8000000 Kbit, DLY 5000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation LOOPBACK, loopback not set
Last input never, output never, output hang never
Last clearing of "show interface" counters never
Queueing strategy: fifo
Output queue 0/0, 0 drops; input queue 0/75, 0 drops

Cisco 880 Series Integrated Services Router Software Configuration Guide


OL-22206-02

3-17

Chapter 3

Basic Router Configuration

Configuring Static Routes

5 minute input rate 0 bits/sec, 0 packets/sec


5 minute output rate 0 bits/sec, 0 packets/sec
0 packets input, 0 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
0 packets output, 0 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
0 output buffer failures, 0 output buffers swapped out

Another way to verify the loopback interface is to ping it.


Router# ping 200.200.100.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 200.200.100.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms

Configuring Static Routes


Static routes provide fixed routing paths through the network. They are manually configured on the
router. If the network topology changes, the static route must be updated with a new route. Static routes
are private routes unless they are redistributed by a routing protocol.
To configure static routes, follow these steps, beginning in global configuration mode:
SUMMARY STEPS
1.

ip route prefix mask {ip-address | interface-type interface-number [ip-address]}

2.

end

DETAILED STEPS

Step 1

Command

Purpose

ip route prefix mask {ip-address | interface-type


interface-number [ip-address]}

Specifies the static route for the IP packets.

Example:

For details about this command and about


additional parameters that can be set, see Cisco
IOS IP Routing Protocols Command Reference.

Router(config)# ip route 192.168.1.0


255.255.0.0 10.10.10.2
Router(config)#

Step 2

end

Exits router configuration mode and enters


privileged EXEC mode.

Example:
Router(config)# end
Router#

Cisco 880 Series Integrated Services Router Software Configuration Guide

3-18

OL-22206-02

Chapter 3

Basic Router Configuration


Configuring Dynamic Routes

Example
In the following configuration example, the static route sends out all IP packets with a destination IP
address of 192.168.1.0 and a subnet mask of 255.255.255.0 on the Fast Ethernet interface to another
device with an IP address of 10.10.10.2. Specifically, the packets are sent to the configured PVC.
You do not need to enter the command marked (default). This command appears automatically in the
configuration file generated when you use the show running-config command.
!
ip classless (default)
ip route 192.168.1.0 255.255.255.0 10.10.10.2!

Verifying Configuration
To verify that you have properly configured static routing, enter the show ip route command and look
for static routes signified by the S.
You should see a verification output similar to the following:
Router# show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
10.0.0.0/24 is subnetted, 1 subnets
C
10.108.1.0 is directly connected, Loopback0
S* 0.0.0.0/0 is directly connected, FastEthernet0

Configuring Dynamic Routes


In dynamic routing, the network protocol adjusts the path automatically, based on network traffic or
topology. Changes in dynamic routes are shared with other routers in the network.
The Cisco routers can use IP routing protocols, such as Routing Information Protocol (RIP) or Enhanced
Interior Gateway Routing Protocol (EIGRP), to learn routes dynamically. You can configure either of
these routing protocols on your router.

Configuring Routing Information Protocol, page 3-20

Configuring Enhanced Interior Gateway Routing Protocol, page 3-21

Cisco 880 Series Integrated Services Router Software Configuration Guide


OL-22206-02

3-19

Chapter 3

Basic Router Configuration

Configuring Dynamic Routes

Configuring Routing Information Protocol


To configure the RIP routing protocol on the router, follow these steps, beginning in global configuration
mode:
SUMMARY STEPS
1.

router rip

2.

version {1 | 2}

3.

network ip-address

4.

no auto-summary

5.

end

DETAILED STEPS

Step 1

Command

Task

router rip

Enters router configuration mode, and enables RIP


on the router.

Example:
Router> configure terminal
Router(config)# router rip
Router(config-router)#

Step 2

version {1 | 2}

Specifies use of RIP version 1 or 2.

Example:
Router(config-router)# version 2
Router(config-router)#

Step 3

network ip-address
Example:

Specifies a list of networks on which RIP is to be


applied, using the address of the network of each
directly connected network.

Router(config-router)# network 192.168.1.1


Router(config-router)# network 10.10.7.1
Router(config-router)#

Step 4

no auto-summary
Example:
Router(config-router)# no auto-summary
Router(config-router)#

Step 5

end

Disables automatic summarization of subnet routes


into network-level routes. This allows subprefix
routing information to pass across classful network
boundaries.
Exits router configuration mode and enters
privileged EXEC mode.

Example:
Router(config-router)# end
Router#

Cisco 880 Series Integrated Services Router Software Configuration Guide

3-20

OL-22206-02

Chapter 3

Basic Router Configuration


Configuring Dynamic Routes

Example
The following configuration example shows RIP version 2 enabled in IP network 10.0.0.0 and
192.168.1.0.
To see this configuration, use the show running-config command from privileged EXEC mode.
!
Router# show running-config
router rip
version 2
network 10.0.0.0
network 192.168.1.0
no auto-summary
!

Verifying Configuration
To verify that you have properly configured RIP, enter the show ip route command and look for RIP
routes signified by R. You should see a verification output like in the following example:
Router# show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set

C
R

10.0.0.0/24 is subnetted, 1 subnets


10.108.1.0 is directly connected, Loopback0
3.0.0.0/8 [120/1] via 2.2.2.1, 00:00:02, Ethernet0/0

Configuring Enhanced Interior Gateway Routing Protocol


To configure the Enhanced Interior Gateway Routing Protocol (EIGRP), follow these steps, beginning
in global configuration mode:
SUMMARY STEPS
1.

router eigrp as-number

2.

network ip-address

3.

end

Cisco 880 Series Integrated Services Router Software Configuration Guide


OL-22206-02

3-21

Chapter 3

Basic Router Configuration

Configuring Dynamic Routes

DETAILED STEPS

Step 1

Command

Purpose

router eigrp as-number

Enters router configuration mode, and enables


EIGRP on the router. The autonomous-system
number identifies the route to other EIGRP routers
and is used to tag the EIGRP information.

Example:
Router(config)# router eigrp 109
Router(config)#

Step 2

network ip-address
Example:

Specifies a list of networks on which EIGRP is to


be applied, using the IP address of the network of
directly connected networks.

Router(config)# network 192.145.1.0


Router(config)# network 10.10.12.115
Router(config)#

Step 3

end

Exits router configuration mode and enters


privileged EXEC mode.

Example:
Router(config-router)# end
Router#

Example
The following configuration example shows the EIGRP routing protocol enabled in IP networks
192.145.1.0 and 10.10.12.115. The EIGRP autonomous system number is 109.
To see this configuration, use the show running-config command, beginning in privileged EXEC mode.
!
router eigrp 109
network 192.145.1.0
network 10.10.12.115
!

Verifying Configuration
To verify that you have properly configured IP EIGRP, enter the show ip route command, and look for
EIGRP routes indicated by D. You should see a verification output similar to the following:
Router# show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set

C
D

10.0.0.0/24 is subnetted, 1 subnets


10.108.1.0 is directly connected, Loopback0
3.0.0.0/8 [90/409600] via 2.2.2.1, 00:00:02, Ethernet0/0

Cisco 880 Series Integrated Services Router Software Configuration Guide

3-22

OL-22206-02

Vous aimerez peut-être aussi