Vous êtes sur la page 1sur 18

PETIT

GUIDE EXCEL
Sommaire :
1) La fonction =SOMME()
Pour additionner entre elles plusieurs cellules contigus.
2) La formule =SOMME.SI()
Cette fonction vous permet d'additionner plusieurs cellules en fonction d'un critre dtermin.
3) La formule =SOMME.SI.ENS()
Cette formule permet d'additionner plusieurs cellules en fonction de plusieurs critres.
4) La formule =SOMMEPROD()
Ralisation d'oprations conditionnelles comptant et additionnant en utilisant des conditions
multiples.
5) La fonction =MOYENNE()
Pour obtenir la moyenne de plusieurs cellules contigus.
6) La formule =ARRONDI()
Pour viter que le rsultat dune division ou dune multiplication soit un nombre comportant
plusieurs dcimales.
7) La formule =RECHERCHEV()
Pour chercher une valeur dans la premire colonne dun tableau puis afficher le contenu de la
cellule qui se situe sur la mme ligne que la valeur recherche.
8) La formule INDEX() et EQUIV()
La fonction INDEX utilise avec la fonction EQUIV permet la recherche de valeur dans une
matrice.
9) Choix des rfrences de cellules
Rfrence Absolue, relative, mixte, nomme
10) Nota Bene
N'oubliez pas que vous pouvez combiner ces fonctions entre elles.
11) Cration dun graphique

Petit Guide Excel


Stphane ROUBIEU et Guillaume HARENT

1) La fonction =SOMME()
Pour additionner entre elles plusieurs cellules contigus, on peut utiliser la fonction
SOMME dEXCEL.

Ecrire dans la cellule o doit apparatre le rsultat : =somme(


Slectionner ensuite la souris la plage de cellules additionner.
Valider avec la touche Entre

La fonction renvoie laddition des sommes slectionnes.


Exemple :

En A5 on crit la formule suivante :

=SOMME(A1:A4)
Le rsultat donne : 31

2) La formule =SOMME.SI()
Cette fonction vous permet d'additionner plusieurs cellules en fonction d'un critre
dtermin.
Voici sa syntaxe :
=SOMME.SI(plage;critre;somme_plage)
plage est la plage de cellule contenant le critre retenir
critre est LE critre retenir (chiffre ou texte)
somme_plage est la plage de cellule o se trouvent les nombres additionner.

Exemple : Dans la colonne A on a crit des nombres. En colonne B, on a indiqu


"garon" ou "fille". On voudrait obtenir le total des nombres de la colonne A auxquels
correspondent le mot "fille" en colonne B.

Petit Guide Excel


Stphane ROUBIEU et Guillaume HARENT

En A7 on crit la formule suivante :

=SOMME.SI(B1:B6;"fille";A1:A6)
Le rsultat donne : 66

3) La formule =SOMME.SI.ENS()
Cette formule permet d'additionner plusieurs cellules en fonction de plusieurs critres.
Voici sa syntaxe :
=SOMME.SI.ENS(Plage_somme ;Plage_critres1;Critres1;[plage_critres2;critres2];
.)
Exemple :

Petit Guide Excel


Stphane ROUBIEU et Guillaume HARENT

Ici :
Plage_somme, la plage de cellule contenant les montant additionner, (dans la
formule D:D),
Premire page de critres ; la colonne du service, la colonne C (dans la formule C:C),

Premier critre, le service saisi en cellule G1,

Deuxime plage de critres, la colonne du sexe, la colonne B (dans la formule B:B),


Deuxime critre, le sexe saisie en cellule F2,

4) La formule =SOMMEPROD()
Ralisation d'oprations conditionnelles comptant et additionnant en utilisant des
conditions multiples
Les formules permettant de calculer le nombre de valeurs ou les sommes sont fondes
sur deux conditions ou plus.
La fonction que nous allons utiliser est SOMMEPROD ; celle-ci appartient la
catgorie Math & Trigo.

Exemple : Compter le nombre de mois o un commercial fait une vente. Le tableau de


dpart pourrait se prsenter sous cette forme :

Petit Guide Excel


Stphane ROUBIEU et Guillaume HARENT

Exemple 1 : Compter le nombre des ventes faites par Jules sur le mois de fvrier.
C'est une formule conditionnelle qui emploie deux conditions.
= SOMMEPROD((A2:A13="Jules")*(B2:B13="Fvrier"))
Rsultat de formule: 2

Exemple 2 : Compter les mois o les ventes sont plus grandes qu'une quantit spcifique
Vous pouvez employer une formule semblable celle ci-dessus pour travailler avec des
donnes numriques. Cette formule renvoie le nombre de lignes pour lesquelles le mois
est gal janvier et le montant est suprieur 200.
= SOMMEPROD((B2:B13="Janvier")*(C2:C13>200))
Rsultat de formule: 5

Exemple 3 : Compter le nombre de ventes comprises entre certaines valeurs spcifiques


Cette formule compte le nombre de fois o les ventes sont comprises entre 200 et 500. La
formule emploie deux conditions : la quantit suprieure ou gale 200, et la quantit
infrieure ou gale 500.
=SOMMEPROD((C2:C13>=200)*(C2:C13<=500))
Rsultat de formule: 6

Exemple 4 : Compter le nombre de ventes bases sur trois conditions


Cette formule renvoie le nombre de fois o le commercial est Jules, le mois est fvrier, et
la quantit est suprieure 500. Cette fonction emploie un argument simple, qui se
compose de trois expressions logiques multiplies les unes aux autres.
=SOMMEPROD((A2:A13="Jules")*(B2:B13="Fvrier")*(C2:C13>500))
Rsultat de formule: 1

Exemple 5 : Totaliser les ventes d'un commercial pour un mois donn


La formule calcule la somme des ventes base sur deux conditions : quand le
commercial est Jules et le mois est fvrier.
5

Petit Guide Excel


Stphane ROUBIEU et Guillaume HARENT

=SOMMEPROD((A2:A13="Jules")*(B2:B13="Fvrier")*(C2:C13))
Rsultat de formule: 1150

Exemple 6 : Totaliser les ventes combines pour deux commerciaux


La formule ci-dessous renvoie la somme des ventes pour Jules et Pascal. Cette formule
emploie un argument simple et se compose de trois expressions.
=SOMMEPROD(((A2:A13="Jules")+(A2:A13="Pascal"))*(C2:C13))
Rsultat de formule: 2585
Attention : les deux premiers arguments ne sont pas multiplis comme dans les exemples
prcdents. Dans la mesure o nous ralisons un test logique " OU ", ils sont
additionns. Addition de deux rsultats logiques de valeur 1 quand l'une ou l'autre des
expressions est VRAIE.

5) La fonction =MOYENNE()
Pour obtenir la moyenne de plusieurs cellules contigus, on peut utiliser la fonction
MOYENNE dEXCEL.

Ecrire dans la cellule o doit apparatre le rsultat : =moyenne(


Slectionner ensuite la souris la plage de cellules dsire
Valider avec la touche Entre.

La fonction renvoie la moyenne des sommes slectionnes


Exemple : Dans la colonne A on a crit des nombres. On voudrait obtenir la moyenne
des nombres de la colonne A.

En A7 on crit la formule suivante :


=MOYENNE(A1:A6)
Le rsultat donne : 26
6

Petit Guide Excel


Stphane ROUBIEU et Guillaume HARENT

6) La formule =ARRONDI()
Le rsultat dune division ou dune multiplication peut donner un nombre comportant
plusieurs dcimales. Dans le but de crer des formulaires destins des tiers (exemple
facture) les nombres doivent, en principe, se prsenter avec simplement deux dcimales.
On peut, bien entendu, utiliser le format des nombres. Mais Excel va conserver en
mmoire le nombre initial avec plusieurs dcimales et lutilisera pour les calculs
ultrieurs. Do des problmes daffichages.
Exemple :
Le rsultat du calcul : 2 divis par 3 donne le rsultat 0.666666666.....
Si on additionne 0.66666666.... avec 0.6666666.... on obtient 1.33333333.....

Avec un format des nombres deux dcimales, Excel propose un arrondi de


prsentation qui donnera : 0.67 + 0.67 = 1.33. Evidemment, cet arrondi de prsentation
nest pas satisfaisant. Il faut donc utiliser une formule dEXCEL, la formule
ARRONDI()

7) LA Formule =RECHERCHEV()

La fonction RECHERCHEV cherche une valeur dans la premire colonne dun tableau puis
elle affiche le contenu de la cellule qui se situe sur la mme ligne que la valeur recherche.
Prenons un exemple :
Nous voulons afficher le prnom dun candidat en fonction de son numro.
Ici, nous cherchons le prnom du candidat 8.

Dans Valeur_cherche , nous entrons E2 qui correspond 8.


Dans Table_matrice , nous dfinissons une plage de cellule qui contient le tableau.
7

Petit Guide Excel


Stphane ROUBIEU et Guillaume HARENT

Dans No_index_col , nous devons entrez le n de la colonne qui contient les


donnes afficher (ici les prnoms). Le n de colonne est celui du tableau slectionn.
Valeur_proche est facultatif, mais permet soit de chercher la valeur exacte de
Valeur_cherche (en entrant : FAUX), soit de trouver la valeur la plus proche de
Valeur_cherche (en entrant : VRAI ou en laissant vide).

On obtient finalement le prnom de la candidate 8.


Maintenant, il ne reste plus qu modifier E2 pour trouver un autre prnom.

Petit Guide Excel


Stphane ROUBIEU et Guillaume HARENT

8) Les formules INDEX() et EQUIV()


La fonction INDEX utilise avec la fonction EQUIV permet la recherche de valeur dans une
matrice.
Prenons un exemple :
Nous souhaitons pouvoir trouver lge et/ou la ville en fonction du prnom (peut tre appliqu
galement en fonction de lge ou de la ville).
Voici la formule :
=INDEX(C3:E12;EQUIV(H4;C3:C12;0);I6)

C3:E12 : matrice de recherche


H4 : valeur recherche (ici le prnom)
C3:C12 : plage de cellule dans laquelle H4 sera recherche (ici les prnoms)
0 : recherche la valeur exacte (1 : valeur suprieure / -1 : valeur infrieure)
I6 : n de la colonne contenant les valeurs afficher (ici les villes)

En modifiant I6 on obtient :

Petit Guide Excel


Stphane ROUBIEU et Guillaume HARENT

Remarque :
Dans cet exemple, nous avons utilis la syntaxe suivante :
=INDEX(matrice;EQUIV(valeur_cherche;matrice;0);no_colonne)
Celle-ci est galement utilisable (dans cette version, le rsultat renvoy par la fonction
EQUIV sera le n de colonne au lieu du n de ligne) :
=INDEX(matrice;no_ligne;EQUIV(valeur_cherche;matrice;0))

9) Choix des rfrences de cellules


- Rfrences relatives
Lorsqu'on cre une formule, les rfrences de cellules ou de plages de cellules sont
gnralement bases sur leur position par rapport la cellule qui contient la formule. Dans
l'exemple suivant (Figure 1), la cellule B6 contient la formule =A5; Excel recherche la
valeur situe une cellule au-dessus et une cellule gauche de la cellule B6. Il s'agit l
d'une rfrence relative.

Figure 1
Lorsqu'on copie une formule utilisant des rfrences relatives, Excel ajuste automatiquement
les rfrences contenues dans la formule colle pour faire rfrence aux diffrentes cellules
par rapport la position de la formule. Dans l'exemple (Figure 2), la formule de la cellule B6
(=A5) a t copie dans la cellule B7. Excel a ajust automatiquement la formule de la cellule
B7 en la changeant en =A6, qui fait rfrence la cellule situe une cellule au-dessus et
une cellule gauche de la cellule B7

Figure 2
10

Petit Guide Excel


Stphane ROUBIEU et Guillaume HARENT

- Rfrences absolues
Si on ne veut pas que Excel ajuste les rfrences lorsqu'on copie une formule dans une autre
cellule, il faut utiliser une rfrence absolue. Par exemple, si la formule multiplie la cellule A5
par la cellule C1 (=A5*C1) et qu'on la copie une autre cellule, Excel ajuste les deux
rfrences. On peut crer une rfrence absolue en plaant le signe $ avant les lments de la
rfrence qui ne doivent pas tre modifis. Par exemple, pour crer une rfrence absolue
la cellule C1, on ajoute les signes $ la formule comme indiqu ci-contre : =A5*$C$1.
- Rfrences mixtes
Une rfrence de style A$1 ou $A1 indique Excel comment trouver une autre cellule en
combinant des rfrences de colonne ou de ligne absolues et relatives. Elles sont signales en
plaant le signe $ devant la lettre correspondant la colonne ou devant le numro de ligne.
Par exemple dans la rfrence $A1, la rfrence de colonne ($A) est absolue tandis que la
rfrence de ligne (1) est relative.
- Saisie des rfrences
On peut introduire les rfrences en les introduisant partir du clavier ou en slectionnant les
rfrences l'aide de la souris. Aprs le signe gal (=) ou un oprateur, slectionner
simplement la ou les cellules l'aide de la souris ou du clavier. Par exemple, si en A3 on veut
crire la formule =A1+A2, on peut procder comme ceci :

Slectionner la cellule A3,


Introduire la formule suivante =A1+A2 l'aide du clavier ou
Introduire le signe =, slectionner l'aide du clavier ou de la souris la cellule A1,
introduire le signe + et slectionner l'aide du clavier ou de la souris la cellule A2,
Valider la formule.

- Changement des rfrences relatives en rfrences absolues ou mixtes


Si on a cr une formule et qu'on souhaite changer les rfrences relatives en rfrences
absolues (et vice-versa), slectionner la cellule qui contient la formule. Dans la barre de
formule, slectionner la rfrence qu'on souhaite modifier, puis appuyez sur F4. chaque
fois qu'on appuie sur F4, Excel passe d'une combinaison l'autre : colonne absolue et ligne
absolue (par exemple, $C$1) ; colonne relative et ligne absolue (C$1) ; colonne absolue et
ligne relative ($C1); enfin, colonne relative et ligne relative (C1). Par exemple, si on
slectionne l'adresse A1 dans une formule et qu'on appuie sur F4, la rfrence devient $A$1.
Si on utilise une nouvelle fois F4, la rfrence devient A$1, puis $A1 et enfin redevient A1.
- Rfrence nomme
Il est possible de donner un nom une cellule ou un groupe de cellule.
Pour nommer une cellule sous Excel il suffit de slectionner la cellule ou la plage de
cellules nommer puis d'aller dans Insertion > Nom > Dfinir

11

Petit Guide Excel


Stphane ROUBIEU et Guillaume HARENT

Ainsi lorsqu'une cellule ou une plage de cellule possde un nom (le terme d'tiquette est
parfois utilis), il est possible d'y faire rfrence via le nom. Cette fonctionnalit est
particulirement utile lorsque certaines cellules ou plages de cellules contiennent des donnes
caractristiques, car il est possible d'y faire rfrence via le nom mme si la cellule ou le
groupe de cellules a t dplac.
Dans une facture par exemple il est judicieux de donner un nom comme total_ht la cellule
donnant le total hors taxe des commandes. Vous pouvez galement crer une cellule nomme
TVA contenant l'indice de la TVA, ainsi lorsque vous dciderez de calculer le montant TTC, il
suffira de faire le produit de la cellule nomm total_ht par la cellule nomme TVA.

10) NOTA BENE


N'oubliez pas que vous pouvez combiner ces fonctions entre elles. Par exemple vous pouvez
avoir :
=somme(A1:F4)+max(B2:H28)+petite.valeur(B16:K20)

11) Cration dun graphique


Cet exercice consiste crer un graphique de type "Historigrames3D" sur une nouvelle feuille
de calcul. Plusieurs options seront dmontres par aprs.
Entrez les donnes suivantes sur une feuille de calcul du classeur.

Slectionnez les donnes en utilisant un bloc (continu ou non continu), pour l'exercice, de
A1 jusqu' D4.
La slection des donnes est trs importante. Il ne faut pas choisir les lignes ou des colonnes
vides. Gnralement, la premire colonne et la premire ligne d'un bloc qui va servir pour
crer un graphique servent la description de l'axe des " X ", l'axe des abscisses, et pour la
lgende. Cela fonctionne bien lorsque la premire colonne et la premire ligne du bloc sont du
texte. Mais Excel peut se confondre dans certains cas si la description dont vous avez besoin
est des chiffres. Le logiciel va penser qu'il s'agit des chiffres de la premire srie de donnes.
12

Petit Guide Excel


Stphane ROUBIEU et Guillaume HARENT

Pour viter cette situation, placez un espace devant les chiffres de la description sur la
premire ligne. Une autre possibilit est de laisser la premire case de la premire ligne vide.
Si vous avez besoin d'un bloc non continu pour gnrer le graphique, il ne faut pas prendre
des cellules parpilles partout. Assurez-vous que chaque bloc reprsente au moins une srie
de donnes.
Du menu Insertion, slectionnez Graphique.
OU
En utilisant l'assistant de graphiques d'Excel

Rpondez aux questions qui se retrouvent dans les prochaines fentres.

Faites votre slection. Pour l'exercice, slectionnez la mme qui est affiche sur l'image cidessus.
Appuyez sur le bouton Suivant >.
13

Petit Guide Excel


Stphane ROUBIEU et Guillaume HARENT

Pour la seconde tape de la cration du graphique, il y a deux onglets: l'un est pour dterminer
la plage de donnes et l'autre est pour donner de l'information sur les sries.

Cliquez sur l'onglet Srie.

14

Petit Guide Excel


Stphane ROUBIEU et Guillaume HARENT

Faites votre slection et appuyez sur le bouton Suivant >.


Pour la troisime tape, il y a plusieurs onglets. Chacun dcrit une caractristique du
graphique.

Cliquez sur l'onglet Axes.

15

Petit Guide Excel


Stphane ROUBIEU et Guillaume HARENT

Cliquez sur l'onglet Quadrillage.

Cliquez sur l'onglet Lgende.

16

Petit Guide Excel


Stphane ROUBIEU et Guillaume HARENT

Cliquez sur l'onglet tiquettes de donnes.

Pour cet exercice, slectionnez l'option Aucune.


Cliquez sur l'onglet Table de donnes.

17

Petit Guide Excel


Stphane ROUBIEU et Guillaume HARENT

Appuyez sur le bouton Suivant >.

Appuyez sur le bouton Fin.


Excel va ensuite vous afficher le graphique auquel vous avez rpondu aux questions.

18

Petit Guide Excel


Stphane ROUBIEU et Guillaume HARENT