Vous êtes sur la page 1sur 10

ALGORITMOS

EJERCICIOS EN PSEINT
APORTE INDIVIDUAL

HECHO POR: LIEVER ROJAS SCARPETA


CDIGO: 1075283152

PRESENTADO A: ERNESTO ORLANDO PARRA TUTOR Y COMPAEROS


GRUPO: 301303_52

UNIVERSIDAD NACIONAL ABIERTA Y A DISTANCIA


PITALITO - HUILA
2015

Ejercicio No 1
1. Se pide desarrollar el algoritmo del juego Adivina un Nmero, con las siguientes
caractersticas:
a) El nmero debe estar en el rango de 1 a 1000 (generado aleatoriamente)
Debe tener dos niveles nivel bsico y nivel experto, el nivel bsico no tendr
restricciones en nmero de oportunidades, adems se le dar indicaciones
como Caliente, Frio... El Nivel experto solo tendr 5 oportunidades con
mensajes de ayuda lejos, cerca
b) Al finalizar debe informar el nmero de intentos realizados antes de encontrar la
respuesta correcta.

Programa fuente.
Proceso Adivina_el_numero
Escribir
Escribir
Escribir
Escribir
Escribir
Escribir
Escribir

"Nombre del autor: Liever Rojas"


"Fecha: 04 de marzo del 2015"
"Doy fe que este ejercicio es de mi autora,"
"en caso de encontrar plagio la nota de todo
"mi trabajo debe ser de CERO adems de las
"respectivas sanciones a que haya lugar"
"-........................-"

opcin <- 1
intentos2 <- 5
intentos <- 1000
num_secreto <- azar(1000)+1
Escribir "En que nivel quieres adivinar el numero:";
Escribir "............................"
Escribir "1.- Nivel Basico.";
Escribir "2.- Nivel Experto.";
Escribir "............................"
Escribir "Seleccione el nivel: ";
Leer opcion
segun opcion hacer
1:
Escribir "Escogiste la opcion basico"
Escribir " "
Escribir "Adivine el numero (de 1 a 1000):"
Leer num_ingresado
Mientras num_secreto<>num_ingresado Y intentos > 1
Hacer
Si num_secreto>num_ingresado Entonces
Escribir "Estas bajo"
Sino
Escribir "Estas alto"

FinSi
intentos <- intentos-1
Leer num_ingresado
FinMientras
Si num_secreto=num_ingresado Entonces
Escribir "Exacto! Usted adivino en ",1000 - intentos,"
intentos."
FinSi
2:
Escribir "Escogiste nivel experto"
Escribir " "
Escribir "Adivina el nmero (de 1 a 1000) en 5 intentos:"
Leer num_ingresado
Mientras num_secreto<>num_ingresado Y intentos2>1
Hacer
Si num_secreto>num_ingresado Entonces
Escribir "Estas cerca"
Sino
Escribir "Estas lejos"
FinSi
intentos2 <- intentos2-1
Escribir "Cuidado te quedan ", intentos2," intentos:"
Leer num_ingresado
FinMientras
Si num_secreto=num_ingresado Entonces
Escribir "Felicidades adivinaste el numero en: ",6-intentos2,"
intentos."
Sino
Escribir "Que mal, el numero era: ",num_secreto
FinSi
FinSegun
FinProceso

Pantalla de ejecucin

El programa lee una variable y lo almacena en num_ingresado y busca


dentro de azar un nmero del 1 al 5000 y muestra los intentos que
realizo y si est cerca o lejos de adivinar el nmero.

Ejercicio No 4
Debe desarrollar un algoritmo que contenga el siguiente men
(1) Convertir de Decimal a Binario
(2) Convertir de Decimal a Octal
(3) Convertir de Binario a Decimal
(4) Salir
Proceso Menu_de_conversion
Escribir "Nombre del autor: Liever Rojas"
Escribir "Fecha: 24 de marzo del 2015"
Escribir "Doy fe que este ejercicio es de mi autora,"
escribir "en caso de encontrar plagio la nota de todo "
Escribir "mi trabajo debe ser de CERO adems de las "
Escribir "respectivas sanciones a que haya lugar"
Escribir "-........................-"
opcion<-1
Escribir "Que conversion quieres realizar"
Escribir '..............................'
Escribir '1.- Convertir de Decimal a Binario '
Escribir '2.- Convertir de Decimal a Octal '
Escribir '3.- Convertir de Binario a Decimal '
Escribir '4.- Salir '
Escribir '..............................'
Leer opcion
Segun opcion Hacer
1:
Escribir 'Escogiste convertir de Decimal a Binario'
Escribir 'Escribe el numero que quieres convertir'
Escribir '----------------------------'
definir dec Como Entero
Leer dec
bin<-0
i<-0
Repetir
r<-dec mod 2
bin<-bin+10^i*r
i<-i+1
dec<-dec/2
Hasta Que dec=1
bin<-bin+10^i
Mostrar bin
2:
Escribir 'Escogiste convertir de Decimal a Octal'
Escribir 'Escribe el numero que quieres convertir'
Escribir '----------------------------'
Definir dec Como Entero
Leer dec

oct<-0
i<-0
Repetir
r<-dec mod 8
oct<-oct+10^i*r
i<-i+1
dec<-dec/8
Hasta Que dec<8
oct<-oct+10^i*dec
Escribir "El numero en octal es: " ,oct
3:
Escribir 'Escogiste convertir de Binario a Decimal'
Escribir 'Ingresa el numero binario'
Escribir '----------------------------'
Definir bin como entero
leer bin
si bin>0 entonces
coci<-bin
re<-1
decimal<-0
mientras coci<>1 Hacer
decimal<-decimal+(coci % 10)*re
coci<- trunc(coci/10)
re<-(re*2)
FinMientras
decimal<-decimal+((coci % 10)*re)
escribir "El numero en decimal es: " , decimal
FinSi
FinSegun
Escribir "Hasta luego"
FinProceso

Pantalla de ejecucin

El programa pide elegir una opcin del 1 al 4 para hacer cualquier


opcin de conversin que muestra el men.

Ejercicio No. 11
Realizar un programa que le presente un men al usuario con las siguientes opciones:
1. Leer dos nmeros enteros positivos nicamente,
2. Sumar los dos nmeros ledos,
3. Restarle al primer nmero el segundo (siempre y cuando el primero sea mayor que
l segundo, en caso contrario indicar con un mensaje que la operacin no es posible
realizarla y volver al men principal,
4. Multiplicar los dos nmeros (siempre y cuando ninguno de los nmeros sea igual a
cero, , en caso contrario indicar con un mensaje que la operacin no es posible
realizarla y volver al men principal,),
5. Dividir el primer nmero dado por el segundo,
6 Salir Nota: Se debe garantizar que el usuario haya ingresado los dos nmeros
antes de poder realizar cualquier operacin y que no se puede escribir un resultado
sin la realizacin de una operacin.

Proceso Menu_Opciones
Escribir "Nombre del autor: Liever Rojas"
Escribir "Fecha: 28 de marzo del 2015"
Escribir "Doy fe que este ejercicio es de mi autora,"
escribir "en caso de encontrar plagio la nota de todo "
Escribir "mi trabajo debe ser de CERO adems de las "
Escribir "respectivas sanciones a que haya lugar"
Escribir "-........................-"
salir = falso
repetir
Opcion <- 1
Escribir
Escribir
Escribir
Escribir
Escribir
Escribir
Escribir
Escribir
Escribir

""
"Seleccione la opcion que desee"
"......................"
"1. Leer dos numero enteros positivos"
"2. sumar los dos numero leidos"
"3. Restarle el primer numero al segundo numero"
"4. Multiplicar los dos numero"
"5. Dividir el primer numero por el segundo"
"6. salir"

leer opcion
Borrar Pantalla
segun opcion hacer
1:
Escribir "Ingrese el primer numero entero"
leer a
si (a< 0) entonces
Escribir "No se pueden ingresar numero
negativos"

FinSi
Escribir "Ingrese el segundo numero entero"
leer b
si (b<0) Entonces
Escribir "NO se pueden ingresar numero
negativos"
Escribir " "
FinSi
2:
Escribir " "
suma <- a + b
Escribir "El resultado de la suma es " , suma
Escribir " "
3:
Escribir " "
si a > b Entonces
resta <- a - b
Escribir "El resultado de la resta es " , resta
Escribir " "
Sino
Escribir "No es posible realizar la operacion"
Escribir " "
FinSi
4:
Escribir " "
si (a = 0) o (b = 0) entonces
Escribir "No es posible relizar la operacion"
Escribir " "
Sino
multiplicacion <- a * b
Escribir "El resultado de la multiplicacion es " ,
multiplicacion
Escribir " "
FinSi
5:
Escribir " "
division <- a / b
Escribir "El resultado de la division es " , division
Escribir " "
6:
salir = Verdadero
De Otro Modo:
Escribir "Ingrese una opcion valida"
FinSegun
Hasta Que salir
FinProceso
Pantalla de ejecucin

Con un men de opciones nos damos a la tarea de insertar dos nmeros,


al ingresar en una de las opciones se nos desaparece el men borrar
pantalla y se ingresan los valores que se deseen, despus vuelve y
aparece el men para hacer cualquiera de las otras operaciones.