Vous êtes sur la page 1sur 5

WWW.RESEAUMAROC.

COM
Cours/formation /Video en informatique:Réseaux,Linux,Cisco,2003 Server,securité,
Contact : tssri-reseaux@hotmail.fr TEL : 00212669324964

Sauvegardez et deployez vos fichiers de configuration de routeur

Introduction :

Une fois la configuration de nos routeurs terminée, il est important de stocker ces fichiers de configuration. En effet,
sur les réseaux critiques il est souvent nécessaire de posséder des routeurs de rechange préconfigurés pour opérer à
un remplacement rapide en cas de panne. Pour cela, on peut importer et exporter les configurations sur des serveurs
TFTP.

Serveur TFTP :

TFTP, pour Trivial File Transfer Protocol , est un protocole de la pile TCP/IP qui permet l’échange d’informations entre
les nœuds. Comme l’indique son nom, ce protocole est simplifié par rapport au protocole FTP et ne permet pas
l’authentification des utilisateurs.

Vous trouverez aisément un serveur TFTP sur Internet, en voici un exemple à www.solarwinds.net

Dans cet exemple, l’adresse du serveur est 192.168.10.222 (adresse de la machine sur laquelle est installé le serveur
TFTP).

Copier une configuration vers un serveur TFTP :

Les adresses de notre serveur TFTP et d’une interface Ethernet du routeur doivent être sur le même réseau…

En mode privilégié, tapez copy startup-config tftp

Le routeur vous demande ensuite l’adresse du serveur ; dans ce cas tapez 192.168.10.222

Finalement il vous est demandé de rentrer le nom du fichier de votre configuration.


WWW.RESEAUMAROC.COM
Cours/formation /Video en informatique:Réseaux,Linux,Cisco,2003 Server,securité,
Contact : tssri-reseaux@hotmail.fr TEL : 00212669324964

On peut voir sur le routeur que le fichier a bien été envoyé et copié, on peut aussi le vérifier sur le serveur TFTP

Voyons maintenant à quoi ressemble le fichier sauvegardé.

version 12.0

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

hostname LabA

enable secret 5 $1$ka36$a8XgHYpt63DVTZWLQxRxP1

ip subnet-zero
WWW.RESEAUMAROC.COM
Cours/formation /Video en informatique:Réseaux,Linux,Cisco,2003 Server,securité,
Contact : tssri-reseaux@hotmail.fr TEL : 00212669324964

ip host LabC 204.204.7.1 199.6.13.2 223.8.151.1

ip host LabD 204.204.7.2 210.93.105.1

ip host LabE 210.93.105.2

ip host LabB 201.100.11.2 199.6.13.1 219.17.100.1

interface Ethernet0

ip address 192.5.5.1 255.255.255.0

no ip directed-broadcast

interface Serial0

ip address 201.100.11.1 255.255.255.0

no ip directed-broadcast

no ip mroute-cache

clockrate 56000

interface Serial1

no ip address

no ip directed-broadcast

shutdown

router rip

network 192.5.5.0

network 201.100.11.0

ip classless
WWW.RESEAUMAROC.COM
Cours/formation /Video en informatique:Réseaux,Linux,Cisco,2003 Server,securité,
Contact : tssri-reseaux@hotmail.fr TEL : 00212669324964

line con 0

login

transport input none

line aux 0

line vty 0 4

password cisco

login

end

Rapatrier une configuration d’un serveur TFTP sur un routeur :

Pour copier un fichier de configuration d’un serveur TFTP vers notre routeur, il suffit juste de configurer une interface
Ethernet avec une adresse situé sur le même réseau que le serveur TFTP.

Ensuite, on tape copy tftp startup-config

On indique l’adresse du serveur TFTP et le nom du fichier de configuration.

La configuration est donc copier dans la mémoire NVRAM ; il faut ensuite la recopier dans la mémoire de travail du
routeur : copy startup-config running-config
WWW.RESEAUMAROC.COM
Cours/formation /Video en informatique:Réseaux,Linux,Cisco,2003 Server,securité,
Contact : tssri-reseaux@hotmail.fr TEL : 00212669324964