Vous êtes sur la page 1sur 4

CCNP

ROUTE Skills Based Assessment Notes


At my Cisco academy, you are allowed to bring notes/commands to the exam.
These notes ensured I got a 100/100 in the SBA for CCNP ROUTE v6.
TCL Script Example
Router# tclsh

! Start the TCL shell

foreach var {

! Begin the foreach loop

X.X.X.X

! Array element

Y.Y.Y.Y

Z.Z.Z.Z

} {

ping $var }

! action against $var

Setting up an interface
interface <int>
when initialized

! Loopbacks will automatically go up

description ...

! Optional description for the interface

ip address <ip> <subnet mask>


including the subnet mask

! The address of the interface,

clock rate <clock>

! Clock rate in Kb/s

bandwidth <bw>
computation

! EIGRP needs bandwidth to do

no shutdown

! Open the interface

! Set an IPV6 address

ivp6 rip <NAME> enable

! Enable RIPv1 via IPV6


ipv6 address <ipv6>


tunnel source <int>

tunnel destination <ip>

! The tunnel destination IP

tunnel mode ipv6ip

! Allow IPV6 through the Tunnel

! The tunnel source interface

Routing
Gateway of Last Resort

ip route 0.0.0.0 0.0.0.0 <int>

! The the quad zero exit interface


Floating Static Routes
ip route <network> <subnet> <destination ip>
ip route <network> <subnet> <destination ip> <priority>

Create BGP Autonomous System (AS)
router bgp <AS>

no synchronization

! Only announce if local convergence

neigbor <ip> remote-as <AS>

neigbor <ip> route-map <route-map> in

! Initialize the BGP AS

! Declare neighbor
! Set route-maps for neighbor

no auto-summary

! Disable summarization

network <summary>

! Announce a network

ip route <network> <subnet> null0

! Add the nullroute

clear ip bgp
doesn't update)

! Refresh BGP (Use this if something

route-map <routemap> <permit|deny> <no>


set local-preference <no>


Create EIGRP Autonomous System (AS)
router eigrp <AS>

! Initialize the EIGRP AS

network <network> [wildcard]


broadcast

passive-interface default
EIGRP routing updates

! Set all interfaces to suppress ALL

neighbor <DEST-IP> <INT>


manually setup neigbor

! Add the networks to be

! If passive interface is set,

no passive-interface <int>
interface

! Re-enable the routing updates on this

no auto-summary

! Disable summarization

interface <int>
interval

! Enter the interface to set Hello

ip hello-interval eigrp <AS> <sec>


each end

! Hello interval, must be the same in

! MD5 on EIGRP

key chain <KEYCHAIN>


config mode

key 1

! First key

key-string <KEY>

! Keystring

! Create a new keychain in


interface <int>
ip authentication mode eigrp <AS> md5

! Setup MD5 for link

ip authentication key-chain eigrp <AS> <KEYCHAIN>




Create OSPF
interface <interface>

! Select the interface for Point to Point

ip ospf network point-to-point

! Setup OSPF point-to-point

router ospf <AS>

! Initialize the OSPF AS

router-id <id>

creating networks)

! Set the Router-ID (Do this before

area <no> range <start-ip> <end-ip>

network <network> [wildcard] area <no>


broadcast

! Optionally setup the Area


! Add the networks to

passive-interface default
no passive-interface <int>
redistribute <routing protocol> <no> subnets metric <no>
distribute-list <acl> <direction>

default-information originate always


interface <int>
ip ospf network broadcast
interface.

! Set OSPF to broadcast on the

ip ospf priority <priority>

! Set priority (force DR)

ip ospf network point-to-point


broadcast correct mask

! Loopbacks must be point-to-point to

access-list <no> <deny|permit> <network wildcard|any> ! Remember to Deny,


then Permit
router ospf <AS>
area <no> stub

! STUB, on ABR

area <no> nssa

! NSSA, on ABR

area <no> stub no-summary

! Totally STUB, on ABR

area <no> nssa no-summary

! Totally NSSA, on ABR

router ospf <AS>




otherwise create virtual link

! All areas must connect to Backbone,

area <AS> virtual-link <dest ip>


X) - also opposite direction

! Transit area (between 0 and



IPv6 Routing
ipv6 unicast-routing

! Initialize routing for IPv6

ipv6 router rip <process>

! Initialize RIP for the process

interface <int>

ipv6 rip <process> enable

! Enable process on interface

! Select interface

Vous aimerez peut-être aussi